Debian Bug report logs - #613431
ITP: wxwidgets2.9 -- wxWidgets Cross-platform C++ GUI toolkit

version graph

Package: wnpp; Maintainer for wnpp is wnpp@debian.org;

Reported by: Emil Langrock <emil.langrock@gmx.de>

Date: Mon, 14 Feb 2011 20:33:04 UTC

Owned by: olly@survex.com

Severity: wishlist

Fixed in version wxwidgets3.0/3.0.0-1

Done: Olly Betts <olly@survex.com>

Bug is archived. No further changes may be made.

Full log


Message #16 received at 613431@bugs.debian.org (full text, mbox):

Received: (at 613431) by bugs.debian.org; 12 Oct 2011 01:19:34 +0000
From olly@survex.com Wed Oct 12 01:19:34 2011
X-Spam-Checker-Version: SpamAssassin 3.3.1-bugs.debian.org_2005_01_02
	(2010-03-16) on busoni.debian.org
X-Spam-Level: 
X-Spam-Status: No, score=-3.0 required=4.0 tests=BAYES_00,BLOGSPOT,
	HAS_BUG_NUMBER,RCVD_IN_DNSWL_LOW,SPF_NEUTRAL autolearn=no
	version=3.3.1-bugs.debian.org_2005_01_02
X-Spam-Bayes: score:0.0000 Tokens: new, 15; hammy, 151; neutral, 64; spammy,
	0. spammytokens: hammytokens:0.000-+--H*i:sk:2011021,
	0.000-+--HCc:D*alioth.debian.org, 0.000-+--HCc:D*lists.alioth.debian.org,
	0.000-+--H*u:1.5.20, 0.000-+--H*UA:1.5.20
Return-path: <olly@survex.com>
Received: from atlas.wxnz.net ([58.28.6.122])
	by busoni.debian.org with esmtp (Exim 4.72)
	(envelope-from <olly@survex.com>)
	id 1RDnTq-0001DZ-Fl
	for 613431@bugs.debian.org; Wed, 12 Oct 2011 01:19:34 +0000
Received: from cavity.localnet (ip-118-90-49-78.xdsl.xnet.co.nz [118.90.49.78])
	by atlas.wxnz.net (Postfix) with ESMTP id B74EB2D840D;
	Wed, 12 Oct 2011 13:50:05 +1300 (NZDT)
Received: from olly by cavity.localnet with local (Exim 4.72)
	(envelope-from <olly@cavity>)
	id 1RDn1J-0005nV-Ba; Wed, 12 Oct 2011 13:50:05 +1300
Date: Wed, 12 Oct 2011 13:50:05 +1300
From: Olly Betts <olly@survex.com>
To: 613431@bugs.debian.org
Cc: freewx-maint@lists.alioth.debian.org
Subject: Re: Bug#613431: RFP: wxWidgets Cross-platform C++ GUI toolkit
Message-ID: <20111012005005.GA10020@cavity>
References: <201102142132.11378.emil.langrock@gmx.de>
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
In-Reply-To: <201102142132.11378.emil.langrock@gmx.de>
User-Agent: Mutt/1.5.20 (2009-06-14)
X-Greylist: delayed 1762 seconds by postgrey-1.32 at busoni; Wed, 12 Oct 2011 01:19:34 UTC
On Mon, Feb 14, 2011 at 09:32:07PM +0100, Emil Langrock wrote:
> New version of software or new software appears on the horizon which uses 
> wxwidget 2.9 only functionality. These software could be uploaded to 
> experimental, but Debian doesn't provide this version at all.

Unfortunately 2.9 is a development release series and has no guarantees
of API stability, which means it's not terribly suitable for packaging.
Every point release (e.g. 2.9.2 to 2.9.3) would be like trying to
move the archive from 2.6 to 2.8, which is just unfeasible given the
number of reverse dependencies of wx.

So this will probably need to wait until it matures and becomes 3.0.x.
Latest word I've seen is "3.0 will probably happen in the beginning of
the next year rather than in this one" at:

http://wxwidgets.blogspot.com/2011/07/292-and-plans-for-future.html

However the "huge amounts of the new code that will hopefully be in
2.9.3" makes me wonder if the start of 2012 is a realistic target.

It's rather unhelpful for upstream to be encouraging new projects to
require wx 2.9, when it isn't ABI or even API stable, but that's the
situation.

Cheers,
    Olly




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 23 14:11:18 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.