Debian Bug report logs - #722982
Broken with EMBOSS 6.4 and higher (in Wheezy and Jessie).

version graph

Package: emboss-explorer; Maintainer for emboss-explorer is Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>; Source for emboss-explorer is src:emboss-explorer.

Reported by: Charles Plessy <plessy@debian.org>

Date: Sun, 15 Sep 2013 02:27:01 UTC

Severity: grave

Found in version emboss-explorer/2.2.0-7

Fixed in versions emboss-explorer/2.2.0-8, emboss-explorer/2.2.0-7+deb7u1

Done: Charles Plessy <plessy@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, plessy@debian.org, Debian-Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>:
Bug#722982; Package emboss-explorer. (Sun, 15 Sep 2013 02:27:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Charles Plessy <plessy@debian.org>:
New Bug report received and forwarded. Copy sent to plessy@debian.org, Debian-Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>. (Sun, 15 Sep 2013 02:27:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Charles Plessy <plessy@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: Broken in Wheezy.
Date: Sun, 15 Sep 2013 11:26:17 +0900
Package: emboss-explorer
Version: 2.2.0-7
Severity: grave

Hello everybody.

I just tried emboss-explorer on a minimal Wheezy system (7.1), and it
does not work out of the box.  For each item in the menu, the main
frame reports "[item name] is not a valid EMBOSS application".

There are patches on SourceForge, that may be related to this issue.

I will try to prepare an update for Wheezy.  Of course, anybody is welcome to
self-appoint and do it instead of me.

Have a nice day,

-- 
Charles



Reply sent to Charles Plessy <plessy@debian.org>:
You have taken responsibility. (Sun, 15 Sep 2013 05:21:14 GMT) Full text and rfc822 format available.

Notification sent to Charles Plessy <plessy@debian.org>:
Bug acknowledged by developer. (Sun, 15 Sep 2013 05:21:14 GMT) Full text and rfc822 format available.

Message #10 received at 722982-close@bugs.debian.org (full text, mbox):

From: Charles Plessy <plessy@debian.org>
To: 722982-close@bugs.debian.org
Subject: Bug#722982: fixed in emboss-explorer 2.2.0-8
Date: Sun, 15 Sep 2013 05:18:03 +0000
Source: emboss-explorer
Source-Version: 2.2.0-8

We believe that the bug you reported is fixed in the latest version of
emboss-explorer, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 722982@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Charles Plessy <plessy@debian.org> (supplier of updated emboss-explorer package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Sun, 15 Sep 2013 13:50:12 +0900
Source: emboss-explorer
Binary: emboss-explorer libemboss-acd-perl
Architecture: source all
Version: 2.2.0-8
Distribution: unstable
Urgency: low
Maintainer: Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>
Changed-By: Charles Plessy <plessy@debian.org>
Description: 
 emboss-explorer - web-based GUI to EMBOSS
 libemboss-acd-perl - perl module to parse EMBOSS ACD files
Closes: 485735 669738 722982
Changes: 
 emboss-explorer (2.2.0-8) unstable; urgency=low
 .
   [ David Paleino ]
   * Removed myself from Uploaders
 .
   [ Charles Plessy ]
   * Converted patches from dpatch to quilt format.
   * Converted the source package to dpkg source format 3.0 (quilt).
   * Added a DEP 3 header to the patches.
   * Removed debian/emboss-explorer.preinst, useless after Lenny.
   * Conforms with Policy 3.9.4 (debian/control, no other changes needed).
   * Use canonical VCS URLs in debian/control.
   * Updated debian/copyright to latest machine-readable format.
   * Switch to Debhelpers compatibility level 9 (debian/compat, debian/control).
   * Convert to Debhelper's tiny mode (debian/rules, debian/docs).
   * Removed obsolete DM-Upload-Allowed field.
   * Normalised debian/control with config-model-edit.
   * Removed restriction on EMBOSS version, satisified even in oldstable.
   * Verbose build logs (debian/rules).
   * Added Debhelper’s misc:Depends substitution variable.
   * Use dh_apache2 (Closes: #669738).
     - Build-depend on apache2-dev for dh_apache2.
     - Invoke dh_apache2 through dh.
     - Updated Apache configuration file for 2.4.
     - Updated debian/emboss-explorer.links for new name of configuration file.
     - Override ‘apache2-deprecated-auth-config’ warning (would conflict
       with another file).
     - Delete obsolete postinst and postrm files.
     - Recommend apache2 or httpd through misc:Recommends.
   * Added keywords to the desktop entry.
   * Correct path for moving ACD.pm and its manual page.
   * Apply patch from upstream tracker to use emboss-explorer with EMBOSS 6.4
     (Closes: #722982 LP:#1083426).
   * Correct the alias to the EMBOSS documentation.  Closes: #485735.
Checksums-Sha1: 
 045dc91f39333ba61db7828394b4f0365237ae1d 2165 emboss-explorer_2.2.0-8.dsc
 29132fcc79b7769557c1c356f9f451f8021edb6b 8768 emboss-explorer_2.2.0-8.debian.tar.gz
 a921f5ea18758250a2bb75c6f1337ca83d1f2733 41568 emboss-explorer_2.2.0-8_all.deb
 c454962ee042f45d5276dd14e5ef37d764ff7cc6 10612 libemboss-acd-perl_2.2.0-8_all.deb
Checksums-Sha256: 
 3112f4688bcee12f1513e7287bbd0e26b4700f31edfdf1c43c7585ec4da94f8a 2165 emboss-explorer_2.2.0-8.dsc
 fed6cb100ba08155f3edb501136dc18237ece0164e4448a52e0df7346e30d79e 8768 emboss-explorer_2.2.0-8.debian.tar.gz
 6bd074386177d84b0a78398003ee3028fec10a40269a561edac3be47e4f346c8 41568 emboss-explorer_2.2.0-8_all.deb
 0d94235dc730f4cef757ea8684cd9076dca5c7f1fde234bd54803a2d82793eb3 10612 libemboss-acd-perl_2.2.0-8_all.deb
Files: 
 906d56ce4fddb598731f444fb82dc4f1 2165 science optional emboss-explorer_2.2.0-8.dsc
 0d421a1aba744410c6894c4b16b72b07 8768 science optional emboss-explorer_2.2.0-8.debian.tar.gz
 b59cf1cf5f927cf096dee5bd937e669e 41568 science optional emboss-explorer_2.2.0-8_all.deb
 11f695a3da95785276cebfd10f8b4f43 10612 perl optional libemboss-acd-perl_2.2.0-8_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.14 (GNU/Linux)

iQIcBAEBCAAGBQJSNT/3AAoJEMW9bI8ildUCNMoP/ik77kmGKvoEvkwpwIglfac1
LblvuBp53hRriKkTqo1tWTV9mJrKf6xKAvT/UU/ST0mX8KvpM4ukjHDdk+l8qQyY
NfBHvP93ZGfmdQFk6m3jk/vUVvyGBNXgZvUqTd08guh1ilqxuZ7GjGxbJt6J7JnJ
BhECntDD1mLkg/nUJH5cOHSaKG2lgPL75hznZYaml0bAvhZEhy8yTyS0pVcxqN7/
/+9zZn/NL/8oLLwYBRQndNvGZFDJEOdVNUIqmcuiZWTSXEi6l0gTGWFS4ZyKdgIw
QD4+hpNiWfLXnZzo7FYihfFDI4zJbfqWTbjei4wz11E9CzozJ0bjmkJ1SLUoX2or
RuZRdttDkoKY64bfXu9Ct9/61enj5EFnKStoBokrogps9Vq1fYJvf6cFhz3pksIU
Y0uS+ztO0mWCH9UYw0CpXkLb6oCBhdeIKoaXx28ar0MV7K5MkPJQBva/lzM+TnT/
7mqTVPFROt1rDpQZ/H7kCrblpcw8F3sUQq11Ydqt+j9fZEhgCvRAXRKhezPTf4UQ
14BY4NyTY/OxAHuGpRb3Dk3UhH15tv0rF/PwDWjacWZFUbMGtSn2pUMxFyCo++ZU
vP9t3AsOzZ/ZRT0rgE7dy7h/AZ3hTKkyPrKNk4f0c6DvgfWiVTuzLljde2TWFhyz
NONSw7WkXMEXUUiArHc/
=ttt3
-----END PGP SIGNATURE-----




Changed Bug title to 'Broken with EMBOSS 6.4 and higher (in Wheezy and Jessie).' from 'Broken in Wheezy.' Request was from Charles Plessy <plessy@debian.org> to control@bugs.debian.org. (Sun, 15 Sep 2013 05:42:04 GMT) Full text and rfc822 format available.

Reply sent to Charles Plessy <plessy@debian.org>:
You have taken responsibility. (Mon, 16 Sep 2013 17:03:23 GMT) Full text and rfc822 format available.

Notification sent to Charles Plessy <plessy@debian.org>:
Bug acknowledged by developer. (Mon, 16 Sep 2013 17:03:24 GMT) Full text and rfc822 format available.

Message #17 received at 722982-close@bugs.debian.org (full text, mbox):

From: Charles Plessy <plessy@debian.org>
To: 722982-close@bugs.debian.org
Subject: Bug#722982: fixed in emboss-explorer 2.2.0-7+deb7u1
Date: Mon, 16 Sep 2013 17:02:04 +0000
Source: emboss-explorer
Source-Version: 2.2.0-7+deb7u1

We believe that the bug you reported is fixed in the latest version of
emboss-explorer, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 722982@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Charles Plessy <plessy@debian.org> (supplier of updated emboss-explorer package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Mon, 16 Sep 2013 13:39:29 +0000
Source: emboss-explorer
Binary: emboss-explorer libemboss-acd-perl
Architecture: source all
Version: 2.2.0-7+deb7u1
Distribution: stable
Urgency: low
Maintainer: Debian-Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>
Changed-By: Charles Plessy <plessy@debian.org>
Description: 
 emboss-explorer - web-based GUI to EMBOSS
 libemboss-acd-perl - perl module to parse EMBOSS ACD files
Closes: 722982
Changes: 
 emboss-explorer (2.2.0-7+deb7u1) stable; urgency=low
 .
   * The application menu of emboss-explorer does not work with EMBOSS 6.4,
     which renders the whole emboss-explorer quite useless. This update applies
     a patch from the upstream bug tracker in SourceForge, solving this problem.
     (Closes: #722982).
Checksums-Sha1: 
 65b15b9f43c9d4f9c3093a4bbb92393cae1e5e60 2232 emboss-explorer_2.2.0-7+deb7u1.dsc
 07393df9eb8d766ae889b691f27d45a97acd197d 9143 emboss-explorer_2.2.0-7+deb7u1.diff.gz
 adc723fe2360c01e492392700d98fbe6a9e487e5 46616 emboss-explorer_2.2.0-7+deb7u1_all.deb
 33174af7d304fdef8e613ec9ccc8ed63947fb8e6 10714 libemboss-acd-perl_2.2.0-7+deb7u1_all.deb
Checksums-Sha256: 
 1667c9c268262ed5b651accf5779edc15ed5bb269609cdd9938c9d81cda4b2fe 2232 emboss-explorer_2.2.0-7+deb7u1.dsc
 18e8e4663dfdf84624e14ed9f4960d804f1476782a41c986c866eab80e764cb3 9143 emboss-explorer_2.2.0-7+deb7u1.diff.gz
 7c185788640dfd700e8fcaca40d07ce2e84375c75a8c465be3ee4bc2e792fc81 46616 emboss-explorer_2.2.0-7+deb7u1_all.deb
 9520724238e0bec9997a27ec5c3dc5642d96ab7f957b6ce210291a2bed566ec5 10714 libemboss-acd-perl_2.2.0-7+deb7u1_all.deb
Files: 
 a1c767122b24cdccfb61aef41de05e7f 2232 science optional emboss-explorer_2.2.0-7+deb7u1.dsc
 5424b7ba35313938d9f64f6f90823527 9143 science optional emboss-explorer_2.2.0-7+deb7u1.diff.gz
 59aa1b3b5ca22396eea96b1de1ff0be2 46616 science optional emboss-explorer_2.2.0-7+deb7u1_all.deb
 b3072b98a102c06381974db7b52cfabe 10714 perl optional libemboss-acd-perl_2.2.0-7+deb7u1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.14 (GNU/Linux)

iQIcBAEBCAAGBQJSNw0lAAoJEMW9bI8ildUC6/0P/2pSQtyG7ouoRh0Ho7MwBaFV
HKb21jm30Wr8ag6Mbw0wWGWVz+PEGPT6JSvQr4jr3T1jWPlmc/sFxC1Q7xJMsrOs
vGCXmoWRqIefz7EpbzX3KQjVbKX/9hobJ0lPwu/N7Yup1OAGyrOZoDaD4ME86T65
auA7Fgb2PXQltGfJmU0MshIxKUhFX90OKFCBgbzI3nPSXtuLU7rscrACB3TzYXbG
NjyxX+4+In8gwM+LhkrgPRRL1sEhylYhfaX4TIvDQZaBWkcidQZPtiVt0w+2/5hU
5j1JYyh7ZYnI21JU0wJzEME2AoCeGqxyEV4GryQrFbJYAO/egtvGyieyxojWTkds
Ln5J4ZT1I5G1cwPOLGkngD8DtZD2wOdxI6A9t9eriDvmQNPIOcHSXYa9YFe87hLg
rLIS3F0B5aS7kH6xPwP4B/baFp1QYb2ondpJT5lBzQapFdO7FYCpiE1sv2WqclgH
xvkEChpB8GNlyICpVqP/AAh7YryhhdRpR8yHEaV6Zuvc0+YuW39dJ1Kr2HyEngg2
iAyNYjt9d2Btq0tQ/hAvX8PcpRiVccQByLdzztsy2vk22WSdpPVBsAhuFT6NYjMZ
u1X+lRM1UbxYzuaxdWjIJ/wDmLKR+QP/+nOr0Mg2OUNC6bbKv372ULVD9lmhyzfr
lZ4WuzxXL2lspPhVWeW6
=8LcM
-----END PGP SIGNATURE-----




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 23 Oct 2013 07:37:32 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 16 04:30:35 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.