Debian Bug report logs - #714803
network-manager-gnome: please move gnome-bluetooth from Recommends to Suggests

version graph

Package: network-manager-gnome; Maintainer for network-manager-gnome is Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>; Source for network-manager-gnome is src:network-manager-applet.

Reported by: Leo Unglaub <leo@leo-unglaub.net>

Date: Tue, 2 Jul 2013 22:54:02 UTC

Severity: wishlist

Merged with 719967

Found in version network-manager-applet/0.9.8.2-1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#714803; Package gnome-bluetooth. (Tue, 02 Jul 2013 22:54:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Leo Unglaub <leo@leo-unglaub.net>:
New Bug report received and forwarded. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 02 Jul 2013 22:54:06 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Leo Unglaub <leo@leo-unglaub.net>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: gnome-bluetooth: gnome-bloototh recommends gnome-control-center witch pulls gnome3 also on XFCE
Date: Wed, 03 Jul 2013 00:40:29 +0200
Package: gnome-bluetooth
Severity: important

Hey Guys,
in unstable the package gnome-bluetooth recommends gnome-control-center instead
of      suggesting it. This causes apt-get to fetch gnome-control-center  as
well with installs all gnome3 and gnome-shell packages. But that is very bad if
you are on XFCE as your main desktop.
Please change this from recommending to suggesting, because otherwize people
can't use update anymore without getting houndrets of not needed packages.

Greetings
Leo



-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.9-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gnome-bluetooth depends on:
pn  bluez                                        <none>
ii  consolekit                                   0.4.5-3.1
ii  dconf-gsettings-backend [gsettings-backend]  0.16.0-4
ii  dpkg                                         1.16.10
ii  gir1.2-atk-1.0                               2.8.0-2
ii  gir1.2-freedesktop                           1.36.0-2+b1
ii  gir1.2-gdkpixbuf-2.0                         2.28.2-1
ii  gir1.2-glib-2.0                              1.36.0-2+b1
ii  gir1.2-gnomebluetooth-1.0                    3.4.2-1
ii  gir1.2-gtk-3.0                               3.8.2-2
ii  gir1.2-pango-1.0                             1.32.5-5+b1
ii  libatk1.0-0                                  2.8.0-2
ii  libc6                                        2.17-7
ii  libcairo-gobject2                            1.12.14-4
ii  libcairo2                                    1.12.14-4
ii  libgdk-pixbuf2.0-0                           2.28.2-1
ii  libglib2.0-0                                 2.36.3-2
ii  libgnome-bluetooth10                         3.4.2-1
ii  libgtk-3-0                                   3.8.2-2
ii  libnotify4                                   0.7.5-2
ii  libpango1.0-0                                1.32.5-5+b1
ii  obex-data-server                             0.4.5-1+b3
ii  obexd-client                                 0.46-1+b1
ii  udev                                         175-7.2

Versions of packages gnome-bluetooth recommends:
ii  gvfs-backends  1.16.3-1

Versions of packages gnome-bluetooth suggests:
pn  gnome-user-share  <none>
pn  nautilus-sendto   <none>



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#714803; Package gnome-bluetooth. (Tue, 02 Jul 2013 23:06:16 GMT) Full text and rfc822 format available.

Acknowledgement sent to Leo Unglaub <leo@leo-unglaub.net>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 02 Jul 2013 23:06:16 GMT) Full text and rfc822 format available.

Message #10 received at 714803@bugs.debian.org (full text, mbox):

From: Leo Unglaub <leo@leo-unglaub.net>
To: 714803@bugs.debian.org
Subject: Additional Informations
Date: Wed, 03 Jul 2013 01:00:04 +0200
Hey,
as you can see a dist-upgrade with gnome-bluetooth installed will 
suddenly install this huge chunk of other packages.

> root@voyager:/home/leo# apt-get dist-upgrade
> Paketlisten werden gelesen... Fertig
> Abhängigkeitsbaum wird aufgebaut.
> Statusinformationen werden eingelesen.... Fertig
> Paketaktualisierung (Upgrade) wird berechnet... Fertig
> Die folgenden Pakete werden ENTFERNT:
>   libpackagekit-glib2-14 python-aptdaemon.pkcompat
> Die folgenden NEUEN Pakete werden installiert:
>   accountsservice alacarte apg appstream-index cheese-common ethtool evolution-data-server evolution-data-server-common folks-common gdebi-core gir1.2-accountsservice-1.0 gir1.2-caribou-1.0 gir1.2-clutter-1.0 gir1.2-clutter-gst-1.0
>   gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-evince-3.0 gir1.2-folks-0.6 gir1.2-gck-1 gir1.2-gconf-2.0 gir1.2-gcr-3 gir1.2-gdesktopenums-3.0 gir1.2-gee-1.0 gir1.2-gkbd-3.0 gir1.2-gmenu-3.0 gir1.2-gst-plugins-base-0.10
>   gir1.2-gstreamer-0.10 gir1.2-gtkclutter-1.0 gir1.2-gtksource-3.0 gir1.2-json-1.0 gir1.2-mutter-3.0 gir1.2-networkmanager-1.0 gir1.2-panelapplet-4.0 gir1.2-polkit-1.0 gir1.2-soup-2.4 gir1.2-telepathyglib-0.12 gir1.2-telepathylogger-0.2
>   gir1.2-upowerglib-1.0 gir1.2-xkl-1.0 gjs gkbd-capplet gnome-applets gnome-applets-data gnome-contacts gnome-control-center gnome-control-center-data gnome-desktop3-data gnome-icon-theme-symbolic gnome-media gnome-menus
>   gnome-online-accounts gnome-panel gnome-panel-data gnome-power-manager gnome-session gnome-session-bin gnome-session-common gnome-session-fallback gnome-settings-daemon gnome-shell gnome-shell-common gnome-sushi gnome-system-monitor
>   gstreamer0.10-pulseaudio hwdata init-system-helpers libaccountsservice0 libappstream0 libasound2-plugins libcamel-1.2-33 libcaribou-common libcaribou0 libcheese-gtk21 libcheese3 libclutter-1.0-0 libclutter-1.0-common
>   libclutter-gst-1.0-0 libclutter-gtk-1.0-0 libclutter-imcontext-0.1-0 libclutter-imcontext-0.1-bin libcluttergesture-0.0.2-0 libcogl-common libcogl-pango0 libcogl9 libcolorhug1 libcpufreq0 libdrm-dev libebackend-1.2-2 libebook-1.2-13
>   libecal-1.2-11 libedata-book-1.2-13 libedata-cal-1.2-15 libedataserver-1.2-16 libedataserverui-3.0-1 libegl1-mesa libegl1-mesa-dev libegl1-mesa-drivers libexempi3 libfolks-eds25 libfolks-telepathy25 libfolks25 libgbm1 libgcr-base-3-1
>   libgcr-ui-3-1 libgd3 libgdata-common libgdata13 libgee2 libgjs0b libgl1-mesa-dev libglew1.7 libgnome-bluetooth11 libgnome-desktop-3-2 libgnome-media-profiles-3.0-0 libgnome-menu-3-0 libgnomekbd-common libgnomekbd7 libgtkmm-3.0-1
>   libgtksourceview-3.0-0 libgtksourceview-3.0-common libgtop2-7 libgtop2-common libgucharmap-2-90-7 libgweather-3-0 libgweather-common libjson-glib-1.0-common libkms1 libmetacity-private0a libmission-control-plugins0 libmozjs185-1.0
>   libmozjs22d libmusicbrainz5-0 libmutter0 libmx-1.0-2 libmx-bin libmx-common liboauth0 libopenvg1-mesa libpackagekit-glib2-16 libpanel-applet-4-0 libpulse-mainloop-glib0 libpulsedsp libpython-stdlib librest-extras-0.7-0
>   libsocialweb-client2 libsocialweb-common libsocialweb-service libsocialweb0 libtasn1-6 libtelepathy-glib0 libtelepathy-logger2 libtevent0 libtiff5 libwacom-common libwacom2 libwayland-client0 libwayland-server0
>   libwebrtc-audio-processing-0 libx11-xcb-dev libxcb-dri2-0-dev libxcb-glx0-dev libxxf86vm-dev mesa-common-dev mesa-utils metacity metacity-common mousetweaks mutter-common nautilus nautilus-data p11-kit packagekit
>   packagekit-backend-aptcc packagekit-tools pulseaudio pulseaudio-module-x11 pulseaudio-utils python-smbc python3-packagekit rtkit telepathy-mission-control-5 x11proto-dri2-dev x11proto-gl-dev x11proto-xf86vidmode-dev xulrunner-22.0
>   zenity zenity-common
> Die folgenden Pakete werden aktualisiert (Upgrade):
>   apt apt-utils aptdaemon colord gcr gimp gimp-data gir1.2-gnomebluetooth-1.0 gir1.2-packagekitglib-1.0 git git-man gnome-bluetooth gnome-keyring iceweasel iceweasel-l10n-de iso-codes kazam libapt-inst1.5 libapt-pkg4.12
>   libcairo-gobject2 libcairo-script-interpreter2 libcairo2 libcairo2-dev libgc1c2 libgcr-3-1 libgd-gd2-perl libgimp2.0 libgphoto2-2 libjson-glib-1.0-0 libltdl-dev libltdl7 libnm-gtk0 libpci3 libsmbclient libtool libwxgtk2.8-0 lm-sensors
>   network-manager-gnome pciutils pm-utils python python-aptdaemon python-aptdaemon.gtk3widgets python-cupshelpers python-minimal rsyslog samba-common samba-common-bin smbclient system-config-printer system-config-printer-udev
> 51 aktualisiert, 187 neu installiert, 2 zu entfernen und 0 nicht aktualisiert.
> Es müssen noch 78,0 MB von 168 MB an Archiven heruntergeladen werden.
> Nach dieser Operation werden 310 MB Plattenplatz zusätzlich benutzt.
> Möchten Sie fortfahren [J/n]?

If i remove gnome-bluetooth only a hand full of those packages will be 
updated.

Greetings
Leo

-- 
Leo Unglaub
Nachreihengasse 39 / Top 7
A-1170 Vienna
Austria

Phone: 0650 / 6575103
Website: http://www.leo-unglaub.net
Twitter: http://twitter.com/LeoUnglaub

Send with Mozilla Thunderbird on Linux (Debian)



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#714803; Package gnome-bluetooth. (Wed, 03 Jul 2013 00:12:17 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 03 Jul 2013 00:12:17 GMT) Full text and rfc822 format available.

Message #15 received at 714803@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Leo Unglaub <leo@leo-unglaub.net>, 714803@bugs.debian.org
Subject: Re: Bug#714803: gnome-bluetooth: gnome-bloototh recommends gnome-control-center witch pulls gnome3 also on XFCE
Date: Wed, 03 Jul 2013 02:10:24 +0200
[Message part 1 (text/plain, inline)]
Am 03.07.2013 00:40, schrieb Leo Unglaub:
> Package: gnome-bluetooth
> Severity: important
> 
> Hey Guys,
> in unstable the package gnome-bluetooth recommends gnome-control-center instead
> of      suggesting it. This causes apt-get to fetch gnome-control-center  as
> well with installs all gnome3 and gnome-shell packages. But that is very bad if
> you are on XFCE as your main desktop.
> Please change this from recommending to suggesting, because otherwize people
> can't use update anymore without getting houndrets of not needed packages.

The gnome-control-center recommends was added as part of a sync with Ubuntu.
The preferences dialogs require gnome-control-center. See
https://bugs.launchpad.net/ubuntu/+source/gnome-bluetooth/+bug/879970


-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#714803; Package gnome-bluetooth. (Wed, 03 Jul 2013 01:09:12 GMT) Full text and rfc822 format available.

Acknowledgement sent to Leo Unglaub <leo@leo-unglaub.net>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 03 Jul 2013 01:09:12 GMT) Full text and rfc822 format available.

Message #20 received at 714803@bugs.debian.org (full text, mbox):

From: Leo Unglaub <leo@leo-unglaub.net>
To: 714803@bugs.debian.org
Subject: Re: Bug#714803: gnome-bluetooth: gnome-bloototh recommends gnome-control-center witch pulls gnome3 also on XFCE
Date: Wed, 03 Jul 2013 02:54:36 +0200
Hi,

On 07/03/2013 02:10 AM, Michael Biebl wrote:
> The gnome-control-center recommends was added as part of a sync with Ubuntu.
> The preferences dialogs require gnome-control-center. See
> https://bugs.launchpad.net/ubuntu/+source/gnome-bluetooth/+bug/879970

that does not make sence. If it's required by gnome-bluetooth set it to 
required with makes it unuseable for XFCE, LXDE, ... or set it back to 
suggests so that people can install it very easy if they think they need it.

Greetings
Leo

-- 
Leo Unglaub
Nachreihengasse 39 / Top 7
A-1170 Vienna
Austria

Phone: 0650 / 6575103
Website: http://www.leo-unglaub.net
Twitter: http://twitter.com/LeoUnglaub

Send with Mozilla Thunderbird on Linux (Debian)



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#714803; Package gnome-bluetooth. (Thu, 11 Jul 2013 09:54:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Benjamin Eltzner <b.eltzner@gmx.de>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Thu, 11 Jul 2013 09:54:04 GMT) Full text and rfc822 format available.

Message #25 received at 714803@bugs.debian.org (full text, mbox):

From: Benjamin Eltzner <b.eltzner@gmx.de>
To: 714803@bugs.debian.org
Subject: Chains of causality
Date: Thu, 11 Jul 2013 11:52:11 +0200
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

I worked out the following chains of causality:

task-xfce-desktop
suggests network-manager-gnome
suggests gnome-bluetooth
suggests gnome-control-center
suggests gnome-session

and

lxde
suggests network-manager-gnome ...

Now, I think there is no dispute that the result "I wanted to install
a _light_ desktop and it came with the core of gnome." is unacceptable.

It might however be unfair to blame solely the maintainers of
gnome-bluetooth who happened to be the unlucky guys to close these
unfortunate chains. I personally couldn't care less, where these
chains are interrupted, but I contend they _must_ be interrupted.

I will therefore assign this bug to all packages involved in these
chains in the hope that somebody finds their package provides the
least necessary of the links.

Disclaimer: The above message is supposed to be witty. If it comes
about as insulting, annoying, moody or aggressive this is most
probably due to my not being a native speaker and completely unintended.

Cheers, Benjamin


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBAgAGBQJR3oA+AAoJEK27BRz67lmpZocQAILdLclhXiuxztQCpTlHH+NH
KdPgruTdjbJqyBi94hOvYVACjry3c/EbiyYrREZlAkMbwN+bhmilk9aL08lw2AGZ
s6lkZt9mlzQWQ7oQvhQV++4FFgPsUQglvKepDdVSl52Lmj2jJ2YmNiQb6EQkDVgW
sW71DwtQPUpgCV1cL/EcQCPeykOOzWwIJZKNQi7UbfvgNzIDzF5vwnXA5uQo/+tl
7WLSsAP+lUz+kWaOSMy/mh+8yeENib32gTPmxUAscfoCw6cTnkc24wC1zVjky/H5
aIbGs7QU6ibGNKJwy7OFpaEH+JfmK2RyCW+ry1Ds8yOqLP1Rh9dirDOB7BqeaP3b
LihL7WTayfyL5/Lkkr9+FNRbEUtFa1EQiXaHvz/C18rh8xHSdTTOlEq5s+oxCmbB
Yj0vlL4GcsxztpLiD7GrQseOzPIkehjtKEYtO1t6FFTmwqBZUHSmdH1B/UxjgbpL
+QmkZIj2c+SsrfVmGziQHakbo9MgQ/mNsP4/4JwUWHEGLnynljk3epa1GtdWa/ID
97C1uFxrQ4N3j4KI06/gQTd72AWP8ZJGNIwCBoYvi0m5gygS6pTVStEoQJfLN4Ba
JQ6sa0N/fEeuYfMI5bkDY7RfZzi8QTTLqseyppXv7ohuapXeXFQJ8Qq2tAUlacha
Yv0dEhFdW5cXmHB30owp
=GhuH
-----END PGP SIGNATURE-----



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#714803; Package gnome-bluetooth. (Thu, 11 Jul 2013 10:03:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Emilio Pozuelo Monfort <pochu@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Thu, 11 Jul 2013 10:03:04 GMT) Full text and rfc822 format available.

Message #30 received at 714803@bugs.debian.org (full text, mbox):

From: Emilio Pozuelo Monfort <pochu@debian.org>
To: Benjamin Eltzner <b.eltzner@gmx.de>, 714803@bugs.debian.org
Subject: Re: Bug#714803: Chains of causality
Date: Thu, 11 Jul 2013 12:01:49 +0200
On 11/07/13 11:52, Benjamin Eltzner wrote:
> Hi,
> 
> I worked out the following chains of causality:
> 
> task-xfce-desktop
> suggests network-manager-gnome
> suggests gnome-bluetooth
> suggests gnome-control-center
> suggests gnome-session
> 
> and
> 
> lxde
> suggests network-manager-gnome ...

Really? Suggests are not installed by default.

> Now, I think there is no dispute that the result "I wanted to install
> a _light_ desktop and it came with the core of gnome." is unacceptable.
> 
> It might however be unfair to blame solely the maintainers of
> gnome-bluetooth who happened to be the unlucky guys to close these
> unfortunate chains. I personally couldn't care less, where these
> chains are interrupted, but I contend they _must_ be interrupted.
> 
> I will therefore assign this bug to all packages involved in these
> chains in the hope that somebody finds their package provides the
> least necessary of the links.

Don't do that. Reassign this to the xfce or lxde packages and let them analyze
the situation. They can reassign if/as needed.

Emilio



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#714803; Package gnome-bluetooth. (Thu, 11 Jul 2013 10:06:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Benjamin Eltzner <b.eltzner@gmx.de>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Thu, 11 Jul 2013 10:06:09 GMT) Full text and rfc822 format available.

Message #35 received at 714803@bugs.debian.org (full text, mbox):

From: Benjamin Eltzner <b.eltzner@gmx.de>
To: Emilio Pozuelo Monfort <pochu@debian.org>
Cc: 714803@bugs.debian.org
Subject: Re: Bug#714803: Chains of causality
Date: Thu, 11 Jul 2013 12:04:18 +0200
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Am 11.07.2013 12:01, schrieb Emilio Pozuelo Monfort:
> On 11/07/13 11:52, Benjamin Eltzner wrote:
>> Hi,
>> 
>> I worked out the following chains of causality:
>> 
>> task-xfce-desktop suggests network-manager-gnome suggests
>> gnome-bluetooth suggests gnome-control-center suggests
>> gnome-session
>> 
>> and
>> 
>> lxde suggests network-manager-gnome ...
> 
> Really? Suggests are not installed by default.
> 
>> Now, I think there is no dispute that the result "I wanted to
>> install a _light_ desktop and it came with the core of gnome." is
>> unacceptable.
>> 
>> It might however be unfair to blame solely the maintainers of 
>> gnome-bluetooth who happened to be the unlucky guys to close
>> these unfortunate chains. I personally couldn't care less, where
>> these chains are interrupted, but I contend they _must_ be
>> interrupted.
>> 
>> I will therefore assign this bug to all packages involved in
>> these chains in the hope that somebody finds their package
>> provides the least necessary of the links.
> 
> Don't do that. Reassign this to the xfce or lxde packages and let
> them analyze the situation. They can reassign if/as needed.
> 
> Emilio
> 

Oh, sorry, you are right: Substitute all "suggests" by "recommends" in
the above.

Also I took your advice and only reassigned to lxde and task-xfce-desktop.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBAgAGBQJR3oMhAAoJEK27BRz67lmpud4P/j7zOyg4uxtoqXDWcPwzp2zx
GWUyk3IFcVCGG8N5y0m5ifdNJzPlpyC7VqM9czU/DzMOafLpGqCTRwa80euUPHrb
7tDDj8VEaQh1qYS1oUzVZmF+E5FccnS5Yxv2MTrBrjPuXY5HC2UtU+QJlh9K8nHT
bHy4wLQZLUrREAeI+Cg6RhNOkUhir+7u6Pu4HrkyMR8b4CuaE1YIiTpT6nPGMUA0
EZh3zPDE8i6SWEIGOLA1Mc22iCVemgOl4RozQfn1XjPXBG7kzXq+0Q4cN/Usk3ES
7wca8FGIVbrvFiJnvGTT9LStKnA0r32dRFGwJq19QwdSM22gin0PF+WPhDlt0djf
OQkZ6fCAoN1eoVUFej35vU9r7Q+17JCegWRuEp2hmxn+wMWibKWhRVM52XD6SvvQ
doIQ9EIUPZwAeIIdF++//Qs84WZMgctcIdBDL+mcgg+jeNH20Wy8p9o+jzeB/djC
+UuWxV6MgYJhJL0QUM6enhACHZmfd0z2DMozjz8hHk+Ba4FzPUNkPm++Pgf29p2S
XVyxnDUIELaA0yqMF4CxfBUvrpbDNXc7jYmqXs43xIORCEYt4Rqf4ioD+GIYNAQ8
sNxT2sOEBy6375lOclzKk05x+aqDyn0xuWIPH/Ak+PwEZcIhFtnCeJNdpyiZo32Q
7QVeUPvvm/p6E70m0E6F
=waYb
-----END PGP SIGNATURE-----



Changed Bug title to 'lxde and task-xfce-desktop pull gnome-session' from 'gnome-bluetooth: gnome-bloototh recommends gnome-control-center witch pulls gnome3 also on XFCE' Request was from Benjamin Eltzner <b.eltzner@gmx.de> to control@bugs.debian.org. (Thu, 11 Jul 2013 10:06:11 GMT) Full text and rfc822 format available.

Bug reassigned from package 'gnome-bluetooth' to 'lxde,task-xfce-desktop'. Request was from Benjamin Eltzner <b.eltzner@gmx.de> to control@bugs.debian.org. (Thu, 11 Jul 2013 10:06:12 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian LXDE Maintainers <lxde-debian@lists.lxde.org>, Debian Install System Team <debian-boot@lists.debian.org>:
Bug#714803; Package lxde,task-xfce-desktop. (Thu, 18 Jul 2013 23:12:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Bob Bib <bobbibmpn@mail.ru>:
Extra info received and forwarded to list. Copy sent to Debian LXDE Maintainers <lxde-debian@lists.lxde.org>, Debian Install System Team <debian-boot@lists.debian.org>. (Thu, 18 Jul 2013 23:12:05 GMT) Full text and rfc822 format available.

Message #44 received at 714803@bugs.debian.org (full text, mbox):

From: Bob Bib <bobbibmpn@mail.ru>
To: 714803@bugs.debian.org
Cc: Leo Unglaub <leo@leo-unglaub.net>
Subject: Re: Bug#714803: network-manager-gnome: please move gnome-bluetooth from Recommends to Suggests
Date: Fri, 19 Jul 2013 03:07:25 +0400
control: retitle -1 network-manager-gnome: please move gnome-bluetooth from Recommends to Suggests
control: reassign -1 network-manager-gnome 0.9.8.2-1
control: affects -1 lxde task-xfce-desktop

Hi people,

well, if "gnome-control-center" is so important for "gnome-bluetooth" package,
so we can't move it from Recommends to Suggests,
then we can probably move "gnome-bluetooth" itself
from Recommends to Suggests for the "network-manager-gnome" package.

(IMHO, Bluetooth is not a very critical protocol
to install its utils on every desktop by default).

This way we can get rid of that problem
with (automatic indirect useless) pulling of GNOME3 core components
on LXDE & Xfce (which recommend "network-manager-gnome").

----
Best wishes, Bob

Changed Bug title to 'network-manager-gnome: please move gnome-bluetooth from Recommends to Suggests' from 'lxde and task-xfce-desktop pull gnome-session' Request was from Bob Bib <bobbibmpn@mail.ru> to 714803-submit@bugs.debian.org. (Thu, 18 Jul 2013 23:12:05 GMT) Full text and rfc822 format available.

Bug reassigned from package 'lxde,task-xfce-desktop' to 'network-manager-gnome'. Request was from Bob Bib <bobbibmpn@mail.ru> to 714803-submit@bugs.debian.org. (Thu, 18 Jul 2013 23:12:06 GMT) Full text and rfc822 format available.

Marked as found in versions network-manager-applet/0.9.8.2-1. Request was from Bob Bib <bobbibmpn@mail.ru> to 714803-submit@bugs.debian.org. (Thu, 18 Jul 2013 23:12:07 GMT) Full text and rfc822 format available.

Added indication that 714803 affects lxde and task-xfce-desktop Request was from Bob Bib <bobbibmpn@mail.ru> to 714803-submit@bugs.debian.org. (Thu, 18 Jul 2013 23:12:08 GMT) Full text and rfc822 format available.

Severity set to 'wishlist' from 'important' Request was from Michael Biebl <biebl@alioth.debian.org> to control@bugs.debian.org. (Thu, 18 Jul 2013 23:27:05 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#714803; Package network-manager-gnome. (Fri, 19 Jul 2013 14:18:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Bob Bib <bobbibmpn@mail.ru>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Fri, 19 Jul 2013 14:18:10 GMT) Full text and rfc822 format available.

Message #59 received at 714803@bugs.debian.org (full text, mbox):

From: Bob Bib <bobbibmpn@mail.ru>
To: 714803@bugs.debian.org
Cc: Leo Unglaub <leo@leo-unglaub.net>, Michael Biebl <biebl@debian.org>, Benjamin Eltzner <b.eltzner@gmx.de>, Emilio Pozuelo Monfort <pochu@debian.org>
Subject: Re: Bug#714803: network-manager-gnome: please move gnome-bluetooth from Recommends to Suggests
Date: Fri, 19 Jul 2013 18:08:11 +0400
control: severity -1 normal

Thu, 18 Jul 2013 23:27:05 GMT from Michael Biebl:
> severity 714803 wishlist
> thanks

"wishlist" is a too low priority for this bug:
http://www.debian.org/Bugs/Developer.en.html#severities
if you don't like it "important", I've set it to "normal".

Meanwhile, I've reported a fresh bug#717334,
and it's definiteley a "wishlist" one :)

----
Best wishes, Bob

Severity set to 'normal' from 'wishlist' Request was from Bob Bib <bobbibmpn@mail.ru> to 714803-submit@bugs.debian.org. (Fri, 19 Jul 2013 14:18:10 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#714803; Package network-manager-gnome. (Fri, 19 Jul 2013 14:18:14 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Fri, 19 Jul 2013 14:18:14 GMT) Full text and rfc822 format available.

Message #66 received at 714803@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Bob Bib <bobbibmpn@mail.ru>
Cc: 714803@bugs.debian.org, Leo Unglaub <leo@leo-unglaub.net>, Benjamin Eltzner <b.eltzner@gmx.de>, Emilio Pozuelo Monfort <pochu@debian.org>, control@bugs.debian.org
Subject: Re: Bug#714803: network-manager-gnome: please move gnome-bluetooth from Recommends to Suggests
Date: Fri, 19 Jul 2013 16:17:56 +0200
[Message part 1 (text/plain, inline)]
severity 714803 wishlist
thanks

Am 19.07.2013 16:08, schrieb Bob Bib:
> control: severity -1 normal
> 
> Thu, 18 Jul 2013 23:27:05 GMT from Michael Biebl:
>> severity 714803 wishlist
>> thanks
> 
> "wishlist" is a too low priority for this bug:

Please respect the decision of the maintainer and stop changing it.


-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Severity set to 'wishlist' from 'normal' Request was from Michael Biebl <biebl@debian.org> to control@bugs.debian.org. (Fri, 19 Jul 2013 14:18:17 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#714803; Package network-manager-gnome. (Sat, 20 Jul 2013 23:39:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Bob Bib <bobbibmpn@mail.ru>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Sat, 20 Jul 2013 23:39:04 GMT) Full text and rfc822 format available.

Message #73 received at 714803@bugs.debian.org (full text, mbox):

From: Bob Bib <bobbibmpn@mail.ru>
To: Michael Biebl <biebl@debian.org>
Cc: 714803@bugs.debian.org, Leo Unglaub <leo@leo-unglaub.net>, Benjamin Eltzner <b.eltzner@gmx.de>, Emilio Pozuelo Monfort <pochu@debian.org>
Subject: Re: Bug#714803: network-manager-gnome: please move gnome-bluetooth from Recommends to Suggests
Date: Sun, 21 Jul 2013 03:34:29 +0400
Fri, 19 July 2013, 16:17 +02:00 from Michael Biebl <biebl@debian.org>:
> severity 714803 wishlist
> thanks
> 
> Am 19.07.2013 16:08, schrieb Bob Bib:
> > control: severity -1 normal
> > 
> > Thu, 18 Jul 2013 23:27:05 GMT from Michael Biebl:
> >> severity 714803 wishlist
> >> thanks
> > 
> > "wishlist" is a too low priority for this bug:
> 
> Please respect the decision of the maintainer and stop changing it.

Hi Michael,

1) you've changed this bug's severity from "important" to "wishlist" without any comment,
so it looked more like an unintentional typo somewhere.

2) just to remember, here is the current problem:
"network-manager-gnome" recommends "gnome-bluetooth",
"gnome-bluetooth" recommends "gnome-control-center" // which is unusable in non-GNOME3 DE's (LXDE at least), see bug#695817
"gnome-control-center"  recommends "gnome-session" // which finally recommends "gnome-shell"

AFAIK, "network-manager-applet" / "network-manager-gnome" is the only GTK frontend / applet for NetworkManager
packaged in Debian,
so more lightweight GTK DE's like Xfce & LXDE make use of it ("lxde" & "task-xfce-desktop" packages recommend it).
And pulling the core of GNOME3 to make a network manager work is a nonsense.
// Well, it still can be avoided on upgrade by supplying a "--no-install-recommends" option to APT:
// # apt-get --no-install-recommends dist-upgrade

Thus, I strongly suggest to move "gnome-bluetooth" to "Suggests" for "network-manager-gnome" package.
We shouldn't fear about GNOME3 users losing Bluetooth functionality,
since "gnome-core", "gnome-shell" & "gnome-user-share" packages currently have "gnome-bluetooth" in "Depends"!

----
Best wishes, Bob

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#714803; Package network-manager-gnome. (Sat, 20 Jul 2013 23:39:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Samuel Sanchez <sanchez@physik.fu-berlin.de>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Sat, 20 Jul 2013 23:39:07 GMT) Full text and rfc822 format available.

Message #78 received at 714803@bugs.debian.org (full text, mbox):

From: Samuel Sanchez <sanchez@physik.fu-berlin.de>
To: 714803@bugs.debian.org, 717334@bugs.debian.org
Subject: Re: Bug#717334: network-manager-applet: provide a simple network-manager-gtk package for non-GNOME GTK-based desktops
Date: Sun, 21 Jul 2013 01:35:05 +0200
[Message part 1 (text/plain, inline)]
> gnome-bluetooth, gnome-keyring, gconf...

The dependencies on gnome-keyring and gconf I can understand and I am
fine with it. Would be just to much work and would not make sense. I
totally agree with that.
However gnome-bluetooth a is a different story.
It do be a suggest would be just fine in my opinion. I really don't see,
why it must be a dependency. The openvpn, openconnect, pptp and vpnc are
also only suggest and bluetooth is imho the same level of feature: nice,
that it is supported, but not necessary, and thus in my understanding
not a dependency. nm-applet would also work just fine without bluetooth.

Do you know, how many users are really using the bluetooth-capability in
the first place?
I don't think, they're many.

Best,
Sam

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#714803; Package network-manager-gnome. (Sun, 04 Aug 2013 00:21:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Bob Bib <bobbibmpn@mail.ru>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Sun, 04 Aug 2013 00:21:05 GMT) Full text and rfc822 format available.

Message #83 received at 714803@bugs.debian.org (full text, mbox):

From: Bob Bib <bobbibmpn@mail.ru>
To: Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>
Cc: 714803@bugs.debian.org, Leo Unglaub <leo@leo-unglaub.net>, Benjamin Eltzner <b.eltzner@gmx.de>, Emilio Pozuelo Monfort <pochu@debian.org>, Michael Biebl <biebl@debian.org>, Samuel Sanchez <sanchez@physik.fu-berlin.de>
Subject: NetworkManager Applet: excessive dependency problems
Date: Sun, 04 Aug 2013 04:17:46 +0400
Hello Debian Xfce maintainers!

It looks like the 'task-xfce-desktop' package depends on the 'network-manager-gnome' one.

Unfortunately, currently there's an excessive dependency problem with 'network-manager-gnome'
(it recommends 'gnome-bluetooth', which since recently pulls GNOME3 core components, see the bug discussion):
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=714803
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=714803#10
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=714803#73

IMHO, NetworkManager Applet is a necessary component for Xfce (still light-weight) desktop,
so I suggest to support my proposal
(to lower the 'gnome-bluetooth' dependency priority to "Suggests" for 'network-manager-gnome'),
and thus save Debian users from installing hundreds of megabytes of unused packages.

----
Best wishes, Bob

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#714803; Package network-manager-gnome. (Sat, 14 Sep 2013 02:09:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Bob Bib <bobbibmpn@mail.ua>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. (Sat, 14 Sep 2013 02:09:04 GMT) Full text and rfc822 format available.

Message #88 received at 714803@bugs.debian.org (full text, mbox):

From: Bob Bib <bobbibmpn@mail.ua>
To: Hans-J. Ullrich <hans.ullrich@loop.de>, Michael Biebl <biebl@debian.org>
Cc: 719967@bugs.debian.org, 714803@bugs.debian.org, Debian Bug Tracking System <control@bugs.debian.org>, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>, Debian LXDE Maintainers <lxde-debian@lists.lxde.org>
Subject: Re: network-manager-gnome: wants to install tons of unnecessary gnome stuff
Date: Sat, 14 Sep 2013 06:03:31 +0400
tags 719967 - upstream
merge 714803 719967
thanks

Just to remember, the current GNOME-NM dependency nightmare is quite trivial:

"network-manager-gnome" recommends "gnome-bluetooth",
"gnome-bluetooth" recommends "gnome-control-center",
"gnome-control-center"  recommends "gnome-session",
"gnome-session" recommends "gnome-shell" etc.

To deal with it, we should decrease the priority of some package dependency
from "Recommends:" to "Suggests:".

There is a number of choices:

1) move "gnome-bluetooth" to "Suggests:" for "gnome-control-center";
effects: "gnome-bluetooth" is not automatically pulled by "network-manager-gnome":
 a) effects on GNOME3 -- none:
"gnome-core", "gnome-shell" & "gnome-user-share" packages currently have "gnome-bluetooth" in "Depends:"!;
 b) effects on any other desktop environment users: they should probably install some Bluetooth manager
manually (or maybe desktops like Xfce should recommend "blueman" or whatever, but it doesn't matter now).

2) move "gnome-control-center" to "Suggests:" for "gnome-bluetooth";
not acceptable: gnome-bluetooth uses gnome-control-center for its settings;

3) move "gnome-session" to "Suggests:" for "gnome-control-center";
effects are unknown to me.

IMHO, the solution 1) is the most painless one,
so I am merging bugs 719967 &  714803...

----
Best wishes, Bob

Merged 714803 719967 Request was from Bob Bib <bobbibmpn@mail.ua> to control@bugs.debian.org. (Sat, 14 Sep 2013 02:24:06 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 15:39:02 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.