Debian Bug report logs - #714210
DRBD 8.3 userland incompatible with 8.4 kernel modules

version graph

Package: drbd8-utils; Maintainer for drbd8-utils is Debian DRBD Maintainers <debian-ha-maintainers@lists.alioth.debian.org>; Source for drbd8-utils is src:drbd8.

Reported by: Jonas Meurer <jonas@freesources.org>

Date: Wed, 26 Jun 2013 20:51:01 UTC

Severity: grave

Tags: jessie, sid

Found in version drbd8/2:8.3.13-2

Fixed in version drbd8/2:8.4.4-1

Done: Apollon Oikonomopoulos <apoikos@gmail.com>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian DRBD Maintainers <debian-ha-maintainers@lists.alioth.debian.org>:
Bug#714210; Package drbd8-utils. (Wed, 26 Jun 2013 20:51:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jonas Meurer <jonas@freesources.org>:
New Bug report received and forwarded. Copy sent to Debian DRBD Maintainers <debian-ha-maintainers@lists.alioth.debian.org>. (Wed, 26 Jun 2013 20:51:06 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Jonas Meurer <jonas@freesources.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: DRBD 8.3 userland incompatible with 8.4 kernel modules
Date: Wed, 26 Jun 2013 22:50:20 +0200
Package: drbd8-utils
Version: 2:8.3.13-2
Severity: grave

Hello,

as the subject already mentions, DRBD 8.3 userland in jessie/testing is
incompatible with DRBD 8.4 kernel modules from the 3.9 linux package.
DRBD kernel modules are at 8.4 branch in upstream linux kernel since
kernel release 3.8.

Ubuntu already ships DRBD 8.4 userland for this reason within Raring
(13.04).

Please consider to upgrade DRBD userland to 8.4. For now DRBD is
unusable in Debian sid/unstable and jessie/testing.

Kind regards,
 jonas

-- System Information:
Debian Release: 7.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-4-amd64 (SMP w/1 CPU core)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash



Added tag(s) sid and jessie. Request was from Holger Levsen <holger@layer-acht.org> to control@bugs.debian.org. (Fri, 05 Jul 2013 15:12:10 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian DRBD Maintainers <debian-ha-maintainers@lists.alioth.debian.org>:
Bug#714210; Package drbd8-utils. (Tue, 16 Jul 2013 15:33:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Berni CED <ced@bernispa.com>:
Extra info received and forwarded to list. Copy sent to Debian DRBD Maintainers <debian-ha-maintainers@lists.alioth.debian.org>. (Tue, 16 Jul 2013 15:33:05 GMT) Full text and rfc822 format available.

Message #12 received at 714210@bugs.debian.org (full text, mbox):

From: Berni CED <ced@bernispa.com>
To: 714210@bugs.debian.org
Subject: Re: DRBD 8.3 userland incompatible with 8.4 kernel modules
Date: Tue, 16 Jul 2013 17:23:03 +0200
Package: drbd8-utils
Version: 2:8.3.13-2
Followup-For: Bug #714210

I confirm this bug.

If you install drbd8-utils along with kernel 3.9.8-1 from sid and try to
use, for example, drbdadm, you'll get messages saying you should upgrade
drbd-tools. The bad thing happens when the tool try to talk to the 
kernel module: it hangs waiting for a reply.
If you reboot with this package installed, you might not reach the login
prompt because the init script hangs on the kernel module, preventing 
the login daemon to start. I had to login via ssh. For me this was
reproducible on two machine, with the package installed but not
customized yet.

Cesare.
(Apologize if you received this mail twice)


-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (x86_64)

Kernel: Linux 3.9-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash

Versions of packages drbd8-utils depends on:
ii  debconf [debconf-2.0]  1.5.50
ii  libc6                  2.17-7

Versions of packages drbd8-utils recommends:
ii  bsd-mailx [mailx]  8.1.2-0.20111106cvs-1

Versions of packages drbd8-utils suggests:
pn  heartbeat  <none>

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Debian DRBD Maintainers <debian-ha-maintainers@lists.alioth.debian.org>:
Bug#714210; Package drbd8-utils. (Wed, 21 Aug 2013 13:58:42 GMT) Full text and rfc822 format available.

Acknowledgement sent to Federico Gimenez <fgimenez@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian DRBD Maintainers <debian-ha-maintainers@lists.alioth.debian.org>. (Wed, 21 Aug 2013 13:58:42 GMT) Full text and rfc822 format available.

Message #17 received at 714210@bugs.debian.org (full text, mbox):

From: Federico Gimenez <fgimenez@gmail.com>
To: 714210@bugs.debian.org
Subject: Re: DRBD 8.3 userland incompatible with 8.4 kernel modules
Date: Wed, 21 Aug 2013 10:50:33 -0300
[Message part 1 (text/plain, inline)]
It also happens on Wheezy (stable) if kernel 3.9 is installed from
wheezy-backports.

-- System Information:
Debian Release: 7.1
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-4-686-pae (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages drbd8-utils depends on:
ii  debconf [debconf-2.0]  1.5.49
ii  libc6                  2.13-38
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian DRBD Maintainers <debian-ha-maintainers@lists.alioth.debian.org>:
Bug#714210; Package drbd8-utils. (Tue, 05 Nov 2013 10:21:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Faidon Liambotis <paravoid@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian DRBD Maintainers <debian-ha-maintainers@lists.alioth.debian.org>. (Tue, 05 Nov 2013 10:21:04 GMT) Full text and rfc822 format available.

Message #22 received at 714210@bugs.debian.org (full text, mbox):

From: Faidon Liambotis <paravoid@debian.org>
To: 714210@bugs.debian.org
Subject: Re: Bug#714210: DRBD 8.3 userland incompatible with 8.4 kernel modules
Date: Tue, 5 Nov 2013 11:31:48 +0200
On Wed, Jun 26, 2013 at 10:50:20PM +0200, Jonas Meurer wrote:
>as the subject already mentions, DRBD 8.3 userland in jessie/testing is
>incompatible with DRBD 8.4 kernel modules from the 3.9 linux package.
>DRBD kernel modules are at 8.4 branch in upstream linux kernel since
>kernel release 3.8.
>
>Ubuntu already ships DRBD 8.4 userland for this reason within Raring
>(13.04).
>
>Please consider to upgrade DRBD userland to 8.4. For now DRBD is
>unusable in Debian sid/unstable and jessie/testing.

Is DRBD maintained at all or should it be orphaned? It's broken in 
unstable for a while, with no maintainer reply whatsoever in this 
(severity: grave) bug which exists since June or any of the other bugs, 
including a severity: serious one.

Please either act on it or orphan it, this situtation isn't doing our 
users any service at all.

Regards,
Faidon



Added tag(s) pending. Request was from Apollon Oikonomopoulos <apoikos@gmail.com> to control@bugs.debian.org. (Thu, 07 Nov 2013 18:21:04 GMT) Full text and rfc822 format available.

Reply sent to Apollon Oikonomopoulos <apoikos@gmail.com>:
You have taken responsibility. (Fri, 15 Nov 2013 15:21:28 GMT) Full text and rfc822 format available.

Notification sent to Jonas Meurer <jonas@freesources.org>:
Bug acknowledged by developer. (Fri, 15 Nov 2013 15:21:28 GMT) Full text and rfc822 format available.

Message #29 received at 714210-close@bugs.debian.org (full text, mbox):

From: Apollon Oikonomopoulos <apoikos@gmail.com>
To: 714210-close@bugs.debian.org
Subject: Bug#714210: fixed in drbd8 2:8.4.4-1
Date: Fri, 15 Nov 2013 15:19:40 +0000
Source: drbd8
Source-Version: 2:8.4.4-1

We believe that the bug you reported is fixed in the latest version of
drbd8, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 714210@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Apollon Oikonomopoulos <apoikos@gmail.com> (supplier of updated drbd8 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 07 Nov 2013 14:02:13 +0200
Source: drbd8
Binary: drbd8-utils
Architecture: source amd64
Version: 2:8.4.4-1
Distribution: unstable
Urgency: low
Maintainer: Debian DRBD Maintainers <debian-ha-maintainers@lists.alioth.debian.org>
Changed-By: Apollon Oikonomopoulos <apoikos@gmail.com>
Description: 
 drbd8-utils - RAID 1 over TCP/IP for Linux (user utilities)
Closes: 476544 711352 711781 714210 721443
Changes: 
 drbd8 (2:8.4.4-1) unstable; urgency=low
 .
   * New upstream version (Closes: #714210, #721443, #711781)
   * Do not participate in the usage count by default (Closes: #711352)
   * Basic systemd support
   * Bump compat to 9 and standards to 3.9.5
   * Convert to dh sequencer
     + use dh_installinit for the initscript and use the default ordering
      (Closes: #476544)
   * Two new patches, fixing automatic chainloading of legacy drbdsetup when
     kernel DRBD is 8.3:
     + 0001-drbdsetup-use-lib-drbd-drbdsetup-83.patch
     + 0002-drbdsetup-delay-exiting-due-to-unknown-commands.patch
   * Convert copyright to Format 1.0
   * Remove unnecessary (build-)dependencies:
     bison, bzip2, debconf
   * Fix Vcs-Git URL
Checksums-Sha1: 
 73d6ef1bb9e95f971a30aa4505be31174c7da72c 2046 drbd8_8.4.4-1.dsc
 7cb626d8b5a6fce807d9985ed117f5982b4d6c00 707642 drbd8_8.4.4.orig.tar.gz
 1c982747932fcae32392a9d5cce2628c9948adc8 17769 drbd8_8.4.4-1.debian.tar.gz
 d35fab88f1c404f1a229fe687616c86c7f6b748b 287992 drbd8-utils_8.4.4-1_amd64.deb
Checksums-Sha256: 
 24cc0e6a25edb09b5955f4687aac0776b44d0a347cc1d10fee5b3dee18290adf 2046 drbd8_8.4.4-1.dsc
 38beb2612481eccc0addebcde00495d122225572053d2d04f38ce97d9a65a142 707642 drbd8_8.4.4.orig.tar.gz
 f93cd08179bf5bc4d24bd0b3a75d6c5dfe2ef3c0224107230d81e8c3a9e56eb6 17769 drbd8_8.4.4-1.debian.tar.gz
 4f2bd90b021e2023be8e546bd92fa78d958d3f3d242fc0c326bcdfa8dc48d49a 287992 drbd8-utils_8.4.4-1_amd64.deb
Files: 
 b57e19ba1bf63b9515ac9ded393cad23 2046 admin extra drbd8_8.4.4-1.dsc
 ffa3585fb16118bb6d13dc5636980464 707642 admin extra drbd8_8.4.4.orig.tar.gz
 428c649f73ba1ed44c185b8d3f9f6622 17769 admin extra drbd8_8.4.4-1.debian.tar.gz
 944ca9c86ec2e08f85ee4fb493cf3390 287992 admin extra drbd8-utils_8.4.4-1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBAgAGBQJShjYyAAoJEAlT7XutaaHLFPcQAIeK350yE6687SRHw3FpPpeA
5osKlzl08L+m3MXUpNGCB9j1/7Ru+bxoU8X9op3a6Dl3e9aK9v3feAr0yEZq1ZVY
Ua0Fulck1URkMYS7oGW4qGKth1yE9C1LkRiESiAIeDLXJWASM+t7/+ZIDkdL0fOg
KSD4OxeKYHkeulhPPrE1Pa5cms2RRCkwfkmSJK5XSY/YfxQrCNxo8DTXYTEGnsbP
+nco04mbWiTvmwkyfx7YFLKqfTB/bRMTXASW+1dMD8zkTVDKUf+EDltTTwZXSU1E
poGjsEp91SyVa+uf9dqb1/Mh5Ol3UbUBUucFJNzR/a+yP9PPaNRLYulh1/3BifuC
mj88WWIGzaJDUb+V/jBGXueFjOl7ws8gwlRDEteBId3QtsOz7Ciub2b1IFdx2cxw
PR/yOEaN/rGPCx85jvVNh26Cyijs5QqYHaSgbmzkH+md0QI3EISt4k1yo5jw6rd5
wmhwDz6lzjrXGtkTsjTtg2RLd8E820jZXD7QGFwxhfvfIKPn8Aeh8DQU5mLQO5PU
E9LuKZfvXHbJblpPv+2yBEd3w13QPkoGobfrRmqodBMx513xceG9hl+aMOVvUqhI
k+MbJO084gU4PsdJ90kPoTgufi6uEtsK4ONxnzQVKEKyrIwrj02U0h5Z0r7dv5Vj
ZLefV3G8jOCmq5k9jpGU
=tV2Z
-----END PGP SIGNATURE-----




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 24 Dec 2013 07:26:08 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 11:09:43 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.