Debian Bug report logs - #713803
ITP: ruby-jquery-ui-rails -- gem packages the jquery UI 1.10.0 assets (javascripts, stylesheet, and images) rails 3.1+

Package: wnpp; Maintainer for wnpp is wnpp@debian.org;

Reported by: mohammed junaid <mdjunaid.54@gmail.com>

Date: Sat, 22 Jun 2013 17:21:01 UTC

Owned by: Pirate Praveen <praveen@debian.org>

Severity: wishlist

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org:
Bug#713803; Package *. (Sat, 22 Jun 2013 17:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to mohammed junaid <mdjunaid.54@gmail.com>:
New Bug report received and forwarded. (Sat, 22 Jun 2013 17:21:03 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: mohammed junaid <mdjunaid.54@gmail.com>
To: submit@bugs.debian.org
Subject: ITP: ruby-jquery-ui-rails -- gem packages the jquery UI 1.10.0 assets (javascripts, stylesheet, and images) rails 3.1+
Date: Sat, 22 Jun 2013 22:48:50 +0530
[Message part 1 (text/plain, inline)]
Package: *

wnpp
 *
*

Severity: wishlist

Owner :  Mohammed Junaid Ahmed <mdjunaid.54@gmail.com>


 *Package name: ruby-jquery-ui-rails

Version         : 4.0.3

 Upstream Author : Jo Liss

*URL             : https://github.com/joliss/jquery-ui-rails

*License         : MIT

 Programming Lang: Ruby

*Description     : This gem packages the jquery UI 1.10.0 assets
(javascripts, stylesheet, and images) for the Rails 3.1+
*



-- 
regards
Mohammed Junaid
[Message part 2 (text/html, inline)]

Bug reassigned from package '*' to 'wnpp'. Request was from Ansgar Burchardt <ansgar@debian.org> to control@bugs.debian.org. (Sat, 13 Jul 2013 09:21:12 GMT) Full text and rfc822 format available.

Owner recorded as Mohammed Junaid Ahmed <mdjunaid.54@gmail.com>. Request was from Mònica Ramírez Arceda <monica@debian.org> to control@bugs.debian.org. (Sat, 13 Jul 2013 19:03:09 GMT) Full text and rfc822 format available.

Severity set to 'wishlist' from 'normal' Request was from Adrian Bunk <bunk@stusta.de> to control@bugs.debian.org. (Mon, 16 Dec 2013 06:54:07 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, Mohammed Junaid Ahmed <mdjunaid.54@gmail.com>:
Bug#713803; Package wnpp. (Sun, 13 Apr 2014 15:03:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to Pirate Praveen <pravi.a@gmail.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org, Mohammed Junaid Ahmed <mdjunaid.54@gmail.com>. (Sun, 13 Apr 2014 15:03:10 GMT) Full text and rfc822 format available.

Message #16 received at 713803@bugs.debian.org (full text, mbox):

From: Pirate Praveen <pravi.a@gmail.com>
To: debian-ruby <debian-ruby@lists.debian.org>, Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Cc: 713803@bugs.debian.org
Subject: jquery-ui-rails and jquery-ui versions
Date: Sun, 13 Apr 2014 20:30:12 +0530
Hi,

I'm trying to package jquey-ui-rails and ran into jquery-ui version
conflicts. jquery-ui-rails embeds a version of jquery-ui and easiest
option would be to ship jquery-ui-rails as is, but it would mean
duplication of libjs-jquery-ui package. So I thought of depending on
libjs-jquery-ui package for ruby-jquery-ui-rails but the versions are
differet.

jquery-ui-rails has jquery-ui version 1.10.3 (older versions of
jquery-ui-rails has only 1.10.0)
libjs-jquery-ui is 1.10.1
jquery-ui latest upstream is 1.10.4

To keep ruby-jquery-ui-rails in a sane position,

1. jquery-ui-rails and libjs-jquery-ui maintainers have to agree to be in sync.

Other option is to

2. just use the version provided by libjs-jquery-ui for
ruby-jquery-ui-rails but it may break applications if there are
incompatible changes. We can add +jqueryui1.10.1 to debian's version.

I'm leaning towards option 2. What do you suggest?

-- 
പ്രവീണ്‍ അരിമ്പ്രത്തൊടിയില്‍
You have to keep reminding your government that you don't get your rights
from them; you give them permission to rule, only so long as they follow the
rules: laws and constitution.



Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, Mohammed Junaid Ahmed <mdjunaid.54@gmail.com>:
Bug#713803; Package wnpp. (Sun, 13 Apr 2014 19:06:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Per Andersson <avtobiff@gmail.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org, Mohammed Junaid Ahmed <mdjunaid.54@gmail.com>. (Sun, 13 Apr 2014 19:06:05 GMT) Full text and rfc822 format available.

Message #21 received at 713803@bugs.debian.org (full text, mbox):

From: Per Andersson <avtobiff@gmail.com>
To: Pirate Praveen <pravi.a@gmail.com>
Cc: debian-ruby <debian-ruby@lists.debian.org>, Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>, 713803@bugs.debian.org
Subject: Re: jquery-ui-rails and jquery-ui versions
Date: Sun, 13 Apr 2014 21:03:16 +0200
On Sun, Apr 13, 2014 at 5:00 PM, Pirate Praveen <pravi.a@gmail.com> wrote:
> Hi,
>
> I'm trying to package jquey-ui-rails and ran into jquery-ui version
> conflicts. jquery-ui-rails embeds a version of jquery-ui and easiest
> option would be to ship jquery-ui-rails as is, but it would mean
> duplication of libjs-jquery-ui package. So I thought of depending on
> libjs-jquery-ui package for ruby-jquery-ui-rails but the versions are
> differet.
>
> jquery-ui-rails has jquery-ui version 1.10.3 (older versions of
> jquery-ui-rails has only 1.10.0)
> libjs-jquery-ui is 1.10.1
> jquery-ui latest upstream is 1.10.4
>
> To keep ruby-jquery-ui-rails in a sane position,
>
> 1. jquery-ui-rails and libjs-jquery-ui maintainers have to agree to be in sync.
>
> Other option is to
>
> 2. just use the version provided by libjs-jquery-ui for
> ruby-jquery-ui-rails but it may break applications if there are
> incompatible changes. We can add +jqueryui1.10.1 to debian's version.
>
> I'm leaning towards option 2. What do you suggest?

Does different minor versions break compatibility between libjs-jquery-ui and
ruby-jquery-ui-rails?

Do you know if it is difficult or a lot of work to carry patches in
ruby-jquery-ui-rails
to fix possible incompatibilities?

I would prefer using the libjs-jquery-ui already in Debian, although trying to
keep both up to date.


--
Per



Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, Mohammed Junaid Ahmed <mdjunaid.54@gmail.com>:
Bug#713803; Package wnpp. (Mon, 14 Apr 2014 03:45:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Pirate Praveen <pravi.a@gmail.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org, Mohammed Junaid Ahmed <mdjunaid.54@gmail.com>. (Mon, 14 Apr 2014 03:45:05 GMT) Full text and rfc822 format available.

Message #26 received at 713803@bugs.debian.org (full text, mbox):

From: Pirate Praveen <pravi.a@gmail.com>
To: Per Andersson <avtobiff@gmail.com>
Cc: debian-ruby <debian-ruby@lists.debian.org>, Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>, 713803@bugs.debian.org
Subject: Re: jquery-ui-rails and jquery-ui versions
Date: Mon, 14 Apr 2014 09:11:55 +0530
2014-04-14 0:33 GMT+05:30, Per Andersson <avtobiff@gmail.com>:
> Does different minor versions break compatibility between libjs-jquery-ui
> and
> ruby-jquery-ui-rails?

I hope it would only be fixes.

> Do you know if it is difficult or a lot of work to carry patches in
> ruby-jquery-ui-rails
> to fix possible incompatibilities?

I think it is just a wrapper for jquery-ui and doesn't really make any
changes to jquery-ui itself.

> I would prefer using the libjs-jquery-ui already in Debian, although trying
> to
> keep both up to date.

yes, I'll go with this.
-- 
പ്രവീണ്‍ അരിമ്പ്രത്തൊടിയില്‍
You have to keep reminding your government that you don't get your rights
from them; you give them permission to rule, only so long as they follow the
rules: laws and constitution.



Owner changed from Mohammed Junaid Ahmed <mdjunaid.54@gmail.com> to Pirate Praveen <praveen@debian.org>. Request was from Praveen Arimbrathodiyil <praveen@ravel.debian.org> to control@bugs.debian.org. (Fri, 18 Apr 2014 09:30:10 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 09:06:39 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.