Debian Bug report logs - #712983
E: debian-installer flavour yes not supported.

version graph

Package: live-build; Maintainer for live-build is Live Systems Maintainers <debian-live@lists.debian.org>; Source for live-build is src:live-build.

Reported by: Gonéri Le Bouder <goneri@rulezlan.org>

Date: Fri, 21 Jun 2013 13:27:02 UTC

Severity: normal

Found in version live-build/3.0.5-1

Done: Daniel Baumann <daniel.baumann@progress-technologies.net>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Live Systems Maintainers <debian-live@lists.debian.org>:
Bug#712983; Package live-build. (Fri, 21 Jun 2013 13:27:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Gonéri Le Bouder <goneri@rulezlan.org>:
New Bug report received and forwarded. Copy sent to Live Systems Maintainers <debian-live@lists.debian.org>. (Fri, 21 Jun 2013 13:27:06 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Gonéri Le Bouder <goneri@rulezlan.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: E: debian-installer flavour yes not supported.
Date: Fri, 21 Jun 2013 15:22:40 +0200
Package: live-build
Version: 3.0.5-1
Severity: normal

Dear Maintainer,

"--debian-installer yes" seems to be broken. What I do:

$ mkdir foo
$cd foo
$ sudo lb config --debian-installer yes \
    --debian-installer-distribution \
    wheezy --apt-http-proxy --apt-http-proxy \
    http://ftp.fr.debian.org/debian/ --mirror-debian-installer \
    http://ftp.fr.debian.org/debian/ --apt-http-proxy http://localhost:3128
$ sudo lb build
(...)
Hit http://ftp.debian.org wheezy-updates/main amd64 Packages
Hit http://ftp.debian.org wheezy-updates/main Translation-en
Reading package lists... Done            
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
[2013-06-21 13:02:46] lb binary_manifest 
P: Begin creating manifest...
[2013-06-21 13:02:46] lb binary_package-lists 
P: Begin installing local package lists...
[2013-06-21 13:02:46] lb binary_linux-image 
P: Begin install linux-image...
[2013-06-21 13:02:47] lb binary_debian-installer 
E: debian-installer flavour yes not supported.
P: Begin unmounting filesystems...
P: Saving caches...
Reading package lists... Done
Building dependency tree       
Reading state information... Done
samgone:~/tmp/retest$which lb
/usr/bin/lb
samgone:~/tmp/retest$dpkg -l live-build
Desired=Unknown/Install/Remove/Purge/Hold
|
Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                    Version          Architecture
Description
+++-=======================-================-================-====================================================
ii  live-build              3.0.5-1          all              Live
System Build Scripts
samgone:~/tmp/retest$which lbgrep -^C
samgone:~/tmp/retest$grep -R yes config/
config/binary:# (Default: yes)
config/binary:LB_DEBIAN_INSTALLER="yes"
config/common:APT_OPTIONS="--yes"
config/common:APTITUDE_OPTIONS="--assume-yes"
samgone:~/tmp/retest$sudo lb build


If I use "--debian-installer live" instead, the build finish properly
and the ISO works correctly.

Best regards,
-- 
   Gonéri Le Bouder


-- Package-specific info:

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.9-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages live-build depends on:
ii  cdebootstrap  0.5.10
ii  debootstrap   1.0.52

Versions of packages live-build recommends:
ii  cpio                            2.11+dfsg-1
ii  gnu-fdisk                       1.2.5-2
ii  live-boot-doc                   3.0.1-1
ii  live-config-doc                 3.0.23-1
ii  live-manual-html [live-manual]  1:3.0.2-1

Versions of packages live-build suggests:
ii  debian-keyring          2013.04.21
ii  dosfstools              3.0.16-2
ii  fakeroot                1.19-2
ii  git                     1:1.8.3.1-1
ii  gpgv                    1.4.12-7
pn  loadlin                 <none>
pn  memtest86+ | memtest86  <none>
ii  mtools                  4.0.18-1
ii  parted                  2.3-13
ii  squashfs-tools          1:4.2+20130409-1
ii  sudo                    1.8.5p2-1+nmu1
ii  syslinux                3:4.05+dfsg-6+deb7u3
ii  uuid-runtime            2.20.1-5.4
pn  win32-loader            <none>
ii  xorriso                 1.2.2-2

-- no debconf information



Information forwarded to debian-bugs-dist@lists.debian.org, Live Systems Maintainers <debian-live@lists.debian.org>:
Bug#712983; Package live-build. (Fri, 21 Jun 2013 14:00:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ben Armstrong <synrg@sanctuary.nslug.ns.ca>:
Extra info received and forwarded to list. Copy sent to Live Systems Maintainers <debian-live@lists.debian.org>. (Fri, 21 Jun 2013 14:00:09 GMT) Full text and rfc822 format available.

Message #10 received at 712983@bugs.debian.org (full text, mbox):

From: Ben Armstrong <synrg@sanctuary.nslug.ns.ca>
To: Gonéri Le Bouder <goneri@rulezlan.org>, 712983@bugs.debian.org
Subject: Re: Bug#712983: E: debian-installer flavour yes not supported.
Date: Fri, 21 Jun 2013 10:57:12 -0300
On 21/06/13 10:22 AM, Gonéri Le Bouder wrote:
> Package: live-build
> Version: 3.0.5-1
> Severity: normal
> 
> Dear Maintainer,
> 
> "--debian-installer yes" seems to be broken. What I do:

Sorry, but I didn't notice when I asked you to file the bug:

The lb_config man page says 'true' is a valid value and says nothing
about 'yes'. Would you please re-test with 'true'?

Thanks,
Ben




Reply sent to daniel.baumann@progress-technologies.net:
You have taken responsibility. (Fri, 21 Jun 2013 14:06:08 GMT) Full text and rfc822 format available.

Notification sent to Gonéri Le Bouder <goneri@rulezlan.org>:
Bug acknowledged by developer. (Fri, 21 Jun 2013 14:06:08 GMT) Full text and rfc822 format available.

Message #15 received at 712983-done@bugs.debian.org (full text, mbox):

From: Daniel Baumann <daniel.baumann@progress-technologies.net>
To: Gonéri Le Bouder <goneri@rulezlan.org>
Cc: 712983-done@bugs.debian.org
Subject: Re: Bug#712983: E: debian-installer flavour yes not supported.
Date: Fri, 21 Jun 2013 16:03:57 +0200
On 06/21/2013 03:22 PM, Gonéri Le Bouder wrote:
> "--debian-installer yes" seems to be broken.

--debian-installer takes either a boolean, or a value supported by the
respective repository you're building against.

a boolean would be 'true' or 'false', a value would for the debian
repository would e.g. be 'live' or 'cdrom', etc.

'yes' is neither.

-- 
Address:        Daniel Baumann, Donnerbuehlweg 3, CH-3012 Bern
Email:          daniel.baumann@progress-technologies.net
Internet:       http://people.progress-technologies.net/~daniel.baumann/



Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 20 Jul 2013 07:34:36 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 19:14:52 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.