Debian Bug report logs - #711237
Logging into KDE turn off the screen (for laptops with i915.invert_brightness=1?)

version graph

Package: kde-workspace-bin; Maintainer for kde-workspace-bin is Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>; Source for kde-workspace-bin is src:kde-workspace.

Reported by: Petter Reinholdtsen <pere@hungry.com>

Date: Wed, 5 Jun 2013 18:57:09 UTC

Severity: important

Tags: fixed-upstream

Found in version kde-workspace/4:4.8.4-6

Forwarded to https://bugs.kde.org/show_bug.cgi?id=321580

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#711237; Package kde-full. (Wed, 05 Jun 2013 18:57:13 GMT) Full text and rfc822 format available.

Acknowledgement sent to Petter Reinholdtsen <pere@hungry.com>:
New Bug report received and forwarded. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. (Wed, 05 Jun 2013 18:57:13 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Petter Reinholdtsen <pere@hungry.com>
To: submit@bugs.debian.org
Subject: Logging into KDE turn off the screen (for laptops with i915.invert_brightness=1?)
Date: Wed, 05 Jun 2013 20:56:51 +0200
Package: kde-full
Version: 5:77+deb7u1
Severity: important
User:     debian-edu@lists.debian.org
Usertags: debian-edu

When installing Debian Wheezy on a Packard Bell EasyNote LV, the
screen is turned off when the machine boot after installation.  See
<URL: http://bugs.debian.org/710938 > for the details.  When applying
the workaround (i915.invert_brightness=1), I get the gdm and kdm login
display, and can log in.  And when I log into Gnome, I can use the
desktop.

But when I log into KDE, the splash screen show up, the first icon show
up, and then suddenly the screen is turned off.  The login continue, and
the screen to not turn on again until quite a while later.  I suspect
what happen is that the screen saver kick in and try to turn off the
screen while in reality it turn it on again.  When I move the mouse, the
screen turn off again.

I have no idea what package could cause this, so I file it against
kde-full, hoping you can help me debug this and pinpoint the problem to
the correct package.

The same problem exist in Ubuntu Raring when logging into KDE there.

-- 
Happy hacking
Petter Reinholdtsen



Information forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#711237; Package kde-full. (Tue, 11 Jun 2013 12:09:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Petter Reinholdtsen <pere@hungry.com>:
Extra info received and forwarded to list. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. (Tue, 11 Jun 2013 12:09:09 GMT) Full text and rfc822 format available.

Message #10 received at 711237@bugs.debian.org (full text, mbox):

From: Petter Reinholdtsen <pere@hungry.com>
To: 711237@bugs.debian.org
Subject: Re: Bug#711237 Logging into KDE turn off the screen (for laptops with i915.invert_brightness=1?)
Date: Tue, 11 Jun 2013 14:04:53 +0200
[Message part 1 (text/plain, inline)]
reassign 711237 kde-workspace-bin
found 711237 4:4.8.4-6
thanks

Sune (svuorela on IRC) suggested I talked to Alex Fiestas (afiestas on
#solid - irc.freenode.net), and I did.  He suggested I ran
'kscreen-console bug' and said that the problem most likely is caused
by powerdevil, a kded module in the kde-workspace-bin package.

While trying to figure out what was causing the black scree, I also
got some ideas for debugging on #debian-kde, suggesting to use
kdebugdialog to enable debugging in ksmserver, ksplash and something
like that to get log messages to show up in .xsession-errors.

Luckily this did not prove neccessary, as powerdevil was the cause,
and editing /usr/share/kde4/services/kded/powerdevil.desktop, changing
X-KDE-Kded-autoload from true to false worked around the problem.

Reassigning this bug to the binary package most likely responsible.

The output from kscreen-console bug is attached.

-- 
Happy hacking
Petter Reinholdtsen
[kde-black.txt (text/plain, attachment)]

Bug reassigned from package 'kde-full' to 'kde-workspace-bin'. Request was from Petter Reinholdtsen <pere@hungry.com> to control@bugs.debian.org. (Tue, 11 Jun 2013 12:09:15 GMT) Full text and rfc822 format available.

No longer marked as found in versions meta-kde/5:77+deb7u1. Request was from Petter Reinholdtsen <pere@hungry.com> to control@bugs.debian.org. (Tue, 11 Jun 2013 12:09:16 GMT) Full text and rfc822 format available.

Marked as found in versions kde-workspace/4:4.8.4-6. Request was from Petter Reinholdtsen <pere@hungry.com> to control@bugs.debian.org. (Tue, 11 Jun 2013 12:09:17 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#711237; Package kde-workspace-bin. (Mon, 24 Jun 2013 21:42:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Petter Reinholdtsen <pere@hungry.com>:
Extra info received and forwarded to list. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. (Mon, 24 Jun 2013 21:42:07 GMT) Full text and rfc822 format available.

Message #21 received at 711237@bugs.debian.org (full text, mbox):

From: Petter Reinholdtsen <pere@hungry.com>
To: 711237@bugs.debian.org
Subject: Re: Bug#711237 Logging into KDE turn off the screen (for laptops with i915.invert_brightness=1?)
Date: Mon, 24 Jun 2013 23:27:13 +0200
forwarded 711237 https://bugs.kde.org/show_bug.cgi?id=321580
thanks

I've reported this problem upstream to
<URL: https://bugs.kde.org/show_bug.cgi?id=321580 >.

-- 
Happy hacking
Petter Reinholdtsen



Set Bug forwarded-to-address to 'https://bugs.kde.org/show_bug.cgi?id=321580'. Request was from Petter Reinholdtsen <pere@hungry.com> to control@bugs.debian.org. (Mon, 24 Jun 2013 21:42:12 GMT) Full text and rfc822 format available.

Added tag(s) fixed-upstream. Request was from bts-link-upstream@lists.alioth.debian.org to control@bugs.debian.org. (Mon, 29 Jul 2013 18:21:07 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 05:05:24 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.