Debian Bug report logs - #700605
nmu: ruby libraries lacking rubygems integration

Package: release.debian.org; Maintainer for release.debian.org is Debian Release Team <debian-release@lists.debian.org>;

Reported by: Raphael Hertzog <hertzog@debian.org>

Date: Fri, 15 Feb 2013 08:06:01 UTC

Severity: normal

Done: Julien Cristau <jcristau@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, pkg-ruby-extras-maintainers@lists.alioth.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#700605; Package release.debian.org. (Fri, 15 Feb 2013 08:06:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Raphael Hertzog <hertzog@debian.org>:
New Bug report received and forwarded. Copy sent to pkg-ruby-extras-maintainers@lists.alioth.debian.org, Debian Release Team <debian-release@lists.debian.org>. (Fri, 15 Feb 2013 08:06:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Raphael Hertzog <hertzog@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: nmu: ruby libraries lacking rubygems integration
Date: Fri, 15 Feb 2013 09:03:16 +0100
Package: release.debian.org
Severity: normal
User: release.debian.org@packages.debian.org
Usertags: binnmu

nmu ruby-bcrypt_3.0.1-2 ruby-bdb_0.6.5-7 ruby-dep-selector_0.0.8-1 ruby-eventmachine_0.12.10-3 ruby-gherkin_2.11.1-1 ruby-globalhotkeys_0.3.2-3 ruby-libxml_2.3.2-1 ruby-msgpack_0.4.6-4 ruby-raindrops_0.10.0-1 ruby-sequel-pg_1.5.0-1 ruby-shadow_2.1.4-2 ruby-systemtimer_1.2.3-2 ruby-taglib2_0.1.5-1 ruby-termios_0.9.6-2 . ALL . -m "rebuild to enable rubygems integration"

Hello,

the above are all the "arch: any" ruby libraries that are currently
lacking rubygems integration and where a simple rebuild would enable
it (I tested it by rebuilding them all, rubygems-integration can be
seen with the existence of files in /usr/share/rubygems-integration).
Their problem is "just" that they haven't been reuploaded since
gem2deb 0.3 hit Debian.

I believe we should bin-nmu them all right now because:

1/ any future bin-nmu or security update will lead to those changes
anyway, and it's better to have those changes now while they can
still be tested until the release than after a stable release where
this kind of change is even more frowned upon

2/ in the ruby world, end-users are encouraged to use gems and the more
gems are provided by Debian, the less pre-compiled binaries users will
download via this tool.

Thank you!

ruby-bcrypt_3.0.1-2
ruby-bdb_0.6.5-7
ruby-dep-selector_0.0.8-1
ruby-eventmachine_0.12.10-3
ruby-gherkin_2.11.1-1
ruby-globalhotkeys_0.3.2-3
ruby-libxml_2.3.2-1
ruby-msgpack_0.4.6-4
ruby-raindrops_0.10.0-1
ruby-sequel-pg_1.5.0-1
ruby-shadow_2.1.4-2
ruby-systemtimer_1.2.3-2
ruby-taglib2_0.1.5-1
ruby-termios_0.9.6-2

-- System Information:
Debian Release: 7.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.7-trunk-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

-- 
Raphaël Hertzog ◈ Debian Developer

Get the Debian Administrator's Handbook:
→ http://debian-handbook.info/get/



Reply sent to Julien Cristau <jcristau@debian.org>:
You have taken responsibility. (Sun, 05 May 2013 16:39:21 GMT) Full text and rfc822 format available.

Notification sent to Raphael Hertzog <hertzog@debian.org>:
Bug acknowledged by developer. (Sun, 05 May 2013 16:39:21 GMT) Full text and rfc822 format available.

Message #10 received at 700605-done@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: Raphael Hertzog <hertzog@debian.org>, 700605-done@bugs.debian.org
Subject: Re: Bug#700605: nmu: ruby libraries lacking rubygems integration
Date: Sun, 5 May 2013 18:36:37 +0200
[Message part 1 (text/plain, inline)]
On Fri, Feb 15, 2013 at 09:03:16 +0100, Raphael Hertzog wrote:

> Package: release.debian.org
> Severity: normal
> User: release.debian.org@packages.debian.org
> Usertags: binnmu
> 
> nmu ruby-bcrypt_3.0.1-2 ruby-bdb_0.6.5-7 ruby-dep-selector_0.0.8-1 ruby-eventmachine_0.12.10-3 ruby-gherkin_2.11.1-1 ruby-globalhotkeys_0.3.2-3 ruby-libxml_2.3.2-1 ruby-msgpack_0.4.6-4 ruby-raindrops_0.10.0-1 ruby-sequel-pg_1.5.0-1 ruby-shadow_2.1.4-2 ruby-systemtimer_1.2.3-2 ruby-taglib2_0.1.5-1 ruby-termios_0.9.6-2 . ALL . -m "rebuild to enable rubygems integration"
> 
Didn't happen in time for wheezy, closing this request, as I assume
there'll be source uploads for these in the future.

Cheers,
Julien
[signature.asc (application/pgp-signature, inline)]

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 03 Jun 2013 07:33:20 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 13:02:01 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.