Debian Bug report logs - #700007
netpbm: please mark Multi-Arch: foreign

version graph

Package: netpbm; Maintainer for netpbm is Andreas Barth <aba@not.so.argh.org>; Source for netpbm is src:netpbm-free.

Reported by: Colin Watson <cjwatson@ubuntu.com>

Date: Thu, 7 Feb 2013 10:42:02 UTC

Severity: wishlist

Tags: patch

Found in version netpbm-free/2:10.0-15

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Andreas Barth <aba@not.so.argh.org>:
Bug#700007; Package netpbm. (Thu, 07 Feb 2013 10:42:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Colin Watson <cjwatson@ubuntu.com>:
New Bug report received and forwarded. Copy sent to Andreas Barth <aba@not.so.argh.org>. (Thu, 07 Feb 2013 10:42:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Colin Watson <cjwatson@ubuntu.com>
To: submit@bugs.debian.org
Subject: netpbm: please mark Multi-Arch: foreign
Date: Thu, 7 Feb 2013 10:39:47 +0000
Package: netpbm
Version: 2:10.0-15
Severity: wishlist
Tags: patch
User: crossbuild@debian.org
Usertags: cross

Hi,

Enough source packages (41 in unstable) Build-Depend on netpbm that it
would be very helpful to have it marked as "Multi-Arch: foreign", on the
basis that even though it's "Architecture: any" it doesn't matter which
architecture you get on a multiarch system as long as you can execute
the binary.  This would make it easier to cross-build those packages.

The patch is trivial, but it follows in case it helps.  Note that this
is independent of adding multiarch support to libnetpbm*.

  * Make netpbm Multi-Arch: foreign, so that it can satisfy
    cross-build-dependencies.

diff -u netpbm-free-10.0/debian/control netpbm-free-10.0/debian/control
--- netpbm-free-10.0/debian/control
+++ netpbm-free-10.0/debian/control
@@ -11,6 +11,7 @@
 
 Package: netpbm
 Architecture: any
+Multi-Arch: foreign
 Depends: libnetpbm10 (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
 Recommends: ghostscript
 Conflicts: netpbm-nonfree (<= 1:19940301.1-3), pnmtopng, pbmwbmp, netpbm-dev (<= 2:9.10), ucbmpeg (<= 1r2-6)

Thanks,

-- 
Colin Watson                                       [cjwatson@ubuntu.com]



Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 23 07:00:00 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.