Debian Bug report logs - #698971
fails to install package upgrade cups_1.4.4-7+squeeze2_i386

version graph

Package: cups; Maintainer for cups is Debian Printing Team <debian-printing@lists.debian.org>; Source for cups is src:cups.

Reported by: Juris <juris.kaminskis@gmail.com>

Date: Fri, 25 Jan 2013 21:45:03 UTC

Severity: grave

Found in version cups/1.4.4-7+squeeze2

Done: "Adam D. Barratt" <adam@adam-barratt.org.uk>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, juris.kaminskis@gmail.com, Debian Printing Team <debian-printing@lists.debian.org>:
Bug#698971; Package cups. (Fri, 25 Jan 2013 21:45:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Juris <juris.kaminskis@gmail.com>:
New Bug report received and forwarded. Copy sent to juris.kaminskis@gmail.com, Debian Printing Team <debian-printing@lists.debian.org>. (Fri, 25 Jan 2013 21:45:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Juris <juris.kaminskis@gmail.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: fails to install package upgrade cups_1.4.4-7+squeeze2_i386
Date: Fri, 25 Jan 2013 23:42:52 +0200
Package: cups
Version: 1.4.4-7+squeeze2
Severity: grave
Tags: d-i
Justification: renders package unusable

Setting up cups (1.4.4-7+squeeze2) ...
insserv: warning: script 'S94scr3xxx' missing LSB tags and overrides
insserv: warning: script 'scr3xxx' missing LSB tags and overrides
insserv: There is a loop at service stop-bootlogd if started
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!
insserv: Max recursions depth 99 reached
insserv:  loop involving service nfs-kernel-server at depth 6
insserv: There is a loop between service stop-bootlogd and mountnfs if started
insserv:  loop involving service mountnfs at depth 6
insserv:  loop involving service nfs-common at depth 5
insserv: There is a loop between service stop-bootlogd and checkroot if started
insserv:  loop involving service checkroot at depth 3
insserv:  loop involving service hdparm at depth 2
insserv:  loop involving service mountnfs-bootclean at depth 8
insserv:  loop involving service hwclock at depth 5
insserv:  loop involving service hostname at depth 4
insserv:  loop involving service alsa-utils at depth 12
insserv: There is a loop between service stop-bootlogd and mountall if started
insserv:  loop involving service mountall at depth 8
insserv:  loop involving service checkfs at depth 7
insserv:  loop involving service mtab at depth 6
insserv: There is a loop between service stop-bootlogd and ifupdown-clean if started
insserv:  loop involving service ifupdown-clean at depth 6
insserv:  loop involving service module-init-tools at depth 6
insserv: There is a loop between service scr3xxx and udev if started
insserv:  loop involving service udev at depth 1
insserv: There is a loop at service scr3xxx if started
insserv:  loop involving service mountkernfs at depth 1
insserv:  loop involving service scr3xxx at depth 1
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing cups (--configure):
 subprocess installed post-installation script returned error exit status 1
configured to not write apport reports
                                      dpkg: dependency problems prevent configuration of cups-driver-gutenprint:
 cups-driver-gutenprint depends on cups (>= 1.3.0); however:
  Package cups is not configured yet.
dpkg: error processing cups-driver-gutenprint (--configure):
 dependency problems - leaving unconfigured
configured to not write apport reports
                                      Errors were encountered while processing:
 cups
 cups-driver-gutenprint
E: Sub-process /usr/bin/dpkg returned an error code (1)

-- System Information:
Debian Release: 6.0.6
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cups depends on:
ii  adduser            3.112+nmu2            add and remove users and groups
ii  bc                 1.06.95-2             The GNU bc arbitrary precision cal
ii  cups-client        1.4.4-7+squeeze2      Common UNIX Printing System(tm) - 
ii  cups-common        1.4.4-7+squeeze2      Common UNIX Printing System(tm) - 
ii  cups-ppdc          1.4.4-7+squeeze2      Common UNIX Printing System(tm) - 
ii  debconf [debconf-2 1.5.36.1              Debian configuration management sy
ii  ghostscript        8.71~dfsg2-9+squeeze1 The GPL Ghostscript PostScript/PDF
ii  libavahi-client3   0.6.27-2+squeeze1     Avahi client library
ii  libavahi-common3   0.6.27-2+squeeze1     Avahi common library
ii  libc6              2.11.3-4              Embedded GNU C Library: Shared lib
ii  libcups2           1.4.4-7+squeeze2      Common UNIX Printing System(tm) - 
ii  libcupscgi1        1.4.4-7+squeeze2      Common UNIX Printing System(tm) - 
ii  libcupsdriver1     1.4.4-7+squeeze2      Common UNIX Printing System(tm) - 
ii  libcupsimage2      1.4.4-7+squeeze2      Common UNIX Printing System(tm) - 
ii  libcupsmime1       1.4.4-7+squeeze2      Common UNIX Printing System(tm) - 
ii  libcupsppdc1       1.4.4-7+squeeze2      Common UNIX Printing System(tm) - 
ii  libdbus-1-3        1.2.24-4+squeeze1     simple interprocess messaging syst
ii  libgcc1            1:4.4.5-8             GCC support library
ii  libgnutls26        2.8.6-1+squeeze2      the GNU TLS library - runtime libr
ii  libgssapi-krb5-2   1.8.3+dfsg-4squeeze6  MIT Kerberos runtime libraries - k
ii  libijs-0.35        0.35-7                IJS raster image transport protoco
ii  libkrb5-3          1.8.3+dfsg-4squeeze6  MIT Kerberos runtime libraries
ii  libldap-2.4-2      2.4.23-7.2            OpenLDAP libraries
ii  libpam0g           1.1.1-6.1+squeeze1    Pluggable Authentication Modules l
ii  libpaper1          1.1.24                library for handling paper charact
ii  libpoppler5        0.12.4-1.2            PDF rendering library
ii  libslp1            1.2.1-7.8             OpenSLP libraries
ii  libstdc++6         4.4.5-8               The GNU Standard C++ Library v3
ii  libusb-0.1-4       2:0.1.12-16           userspace USB programming library
ii  lsb-base           3.2-23.2squeeze1      Linux Standard Base 3.2 init scrip
ii  poppler-utils      0.12.4-1.2            PDF utilitites (based on libpopple
ii  procps             1:3.2.8-9squeeze1     /proc file system utilities
ii  ssl-cert           1.0.28                simple debconf wrapper for OpenSSL
ii  ttf-freefont       20090104-7            Freefont Serif, Sans and Mono True
ii  zlib1g             1:1.2.3.4.dfsg-3      compression library - runtime

Versions of packages cups recommends:
pn  cups-driver-gutenp <none>                (no description available)
ii  foomatic-filters   4.0.5-6+squeeze2      OpenPrinting printer support - fil
ii  ghostscript-cups   8.71~dfsg2-9+squeeze1 The GPL Ghostscript PostScript/PDF

Versions of packages cups suggests:
ii  cups-bsd                1.4.4-7+squeeze2 Common UNIX Printing System(tm) - 
pn  cups-pdf                <none>           (no description available)
ii  foomatic-db             20100630-1       OpenPrinting printer support - dat
pn  hplip                   <none>           (no description available)
pn  smbclient               <none>           (no description available)
ii  udev                    164-3            /dev/ and hotplug management daemo
pn  xpdf-korean | xpdf-japa <none>           (no description available)

-- debconf information:
  cupsys/raw-print: true
  cupsys/backend: ipp, lpd, parallel, scsi, serial, socket, usb, snmp, dnssd



Removed tag(s) d-i. Request was from Adam D. Barratt <adam@adam-barratt.org.uk> to control@bugs.debian.org. (Fri, 25 Jan 2013 21:54:07 GMT) Full text and rfc822 format available.

Reply sent to "Adam D. Barratt" <adam@adam-barratt.org.uk>:
You have taken responsibility. (Fri, 25 Jan 2013 21:57:07 GMT) Full text and rfc822 format available.

Notification sent to Juris <juris.kaminskis@gmail.com>:
Bug acknowledged by developer. (Fri, 25 Jan 2013 21:57:07 GMT) Full text and rfc822 format available.

Message #12 received at 698971-done@bugs.debian.org (full text, mbox):

From: "Adam D. Barratt" <adam@adam-barratt.org.uk>
To: Juris <juris.kaminskis@gmail.com>, 698971-done@bugs.debian.org
Subject: Re: Bug#698971: fails to install package upgrade cups_1.4.4-7+squeeze2_i386
Date: Fri, 25 Jan 2013 21:56:15 +0000
On Fri, 2013-01-25 at 23:42 +0200, Juris wrote:
> Setting up cups (1.4.4-7+squeeze2) ...
> insserv: warning: script 'S94scr3xxx' missing LSB tags and overrides
> insserv: warning: script 'scr3xxx' missing LSB tags and overrides
> insserv: There is a loop at service stop-bootlogd if started
> insserv: Starting scr3xxx depends on stop-bootlogd and therefore on system facility `$all' which can not be true!

This is nothing to do with cups. The problem is with whatever is
providing the "scr3xxx" init script on your system, and needs to be
fixed there.

As far as I can tell that script is not provided by any package in the
Debian archive. If you need help discovering where it came from, please
consult debian-user@lists.debian.org. If it transpires that it is
somehow provided by an official Debian package, please reopen the bug
and reassign it to that package.

Regards,

Adam




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 23 Feb 2013 07:28:25 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 01:03:14 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.