Debian Bug report logs - #698697
broadcom-sta: hidden ssids connection fails

version graph

Package: broadcom-sta-source; Maintainer for broadcom-sta-source is Cyril Lacoux <clacoux@easter-eggs.com>; Source for broadcom-sta-source is src:broadcom-sta.

Reported by: Jonathan Klee <klee.jonathan@gmail.com>

Date: Tue, 22 Jan 2013 12:51:05 UTC

Severity: normal

Found in version broadcom-sta/5.100.82.112-8

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Cyril Lacoux <clacoux@easter-eggs.com>:
Bug#698697; Package broadcom-sta-source. (Tue, 22 Jan 2013 12:51:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jonathan Klee <klee.jonathan@gmail.com>:
New Bug report received and forwarded. Copy sent to Cyril Lacoux <clacoux@easter-eggs.com>. (Tue, 22 Jan 2013 12:51:07 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Jonathan Klee <klee.jonathan@gmail.com>
To: submit@bugs.debian.org
Subject: broadcom-sta: hidden ssids connection fails
Date: Tue, 22 Jan 2013 07:47:01 -0500
[Message part 1 (text/plain, inline)]
Package: broadcom-sta-source
Version: 5.100.82.112-8
Severity: normal

Updating from Squeeze to Wheezy on my MacBook Air and recompiling wl as
explained on http://wiki.debian.org/wl made me unable to connect to a
hidden network anymore. Connecting to a non-hidden network fully works. I
tried both methods listed on the wiki package, the one for Squeeze and the
one for Wheezy. I faced the issue in both cases. Booting back on Wheezy
with the 2.6.32-5 kernel also enables me to connect to a hidden network
with wpa_supplicant and the same wpa_supplicant.conf file.

-- System Information:
Debian GNU/Linux 7.0
Linux macbook 3.2.0-4-amd64 #1 SMP Debian 3.2.35-2 x86_64 GNU/Linux

ii  broadcom-sta-common                                   5.100.82.112-8
ii  broadcom-sta-modules-2.6.32-5-amd64            5.60.48.36-2+2.6.32-46

ii  broadcom-sta-modules-3.2.0-4-amd64              5.100.82.112-8+3.2.35-2

ii  broadcom-sta-source                                      5.100.82.112-8

ii  module-assistant                           0.11.4
ii  wireless-tools                                30~pre9-8

ii  linux-headers-3.2.0-4-amd64           3.2.35-2

ii  linux-headers-3.2.0-4-common        3.2.35-2
ii  linux-libc-dev:amd64                       3.2.35-2

Versions of packages broadcom-sta-source depends on:
ii  bzip2                                          1.0.6-4
ii  debhelper                                    9.20120909
ii  make                                          3.81-8.2
ii  quilt                                            0.60-2
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Cyril Lacoux <clacoux@easter-eggs.com>:
Bug#698697; Package broadcom-sta-source. (Tue, 22 Jan 2013 15:09:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jonathan Klee <klee.jonathan@gmail.com>:
Extra info received and forwarded to list. Copy sent to Cyril Lacoux <clacoux@easter-eggs.com>. (Tue, 22 Jan 2013 15:09:03 GMT) Full text and rfc822 format available.

Message #10 received at 698697@bugs.debian.org (full text, mbox):

From: Jonathan Klee <klee.jonathan@gmail.com>
To: 698697@bugs.debian.org
Date: Tue, 22 Jan 2013 10:07:26 -0500
[Message part 1 (text/plain, inline)]
I forgot to mention something important :

$ lspci | grep -i broad
02:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n
(rev 01)
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Cyril Lacoux <clacoux@easter-eggs.com>:
Bug#698697; Package broadcom-sta-source. (Wed, 23 Jan 2013 08:24:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Geoff Simmons <gsimmons@gsimmons.org>:
Extra info received and forwarded to list. Copy sent to Cyril Lacoux <clacoux@easter-eggs.com>. (Wed, 23 Jan 2013 08:24:03 GMT) Full text and rfc822 format available.

Message #15 received at 698697@bugs.debian.org (full text, mbox):

From: Geoff Simmons <gsimmons@gsimmons.org>
To: Jonathan Klee <klee.jonathan@gmail.com>, 698697@bugs.debian.org
Subject: Re: Bug#698697: broadcom-sta: hidden ssids connection fails
Date: Wed, 23 Jan 2013 19:12:54 +1100
Hi Jonathan,

On Tue, Jan 22, 2013 at 07:47:01AM -0500, Jonathan Klee wrote:
> Package: broadcom-sta-source
> Version: 5.100.82.112-8
> Severity: normal
>
> Updating from Squeeze to Wheezy on my MacBook Air and recompiling wl as
> explained on http://wiki.debian.org/wl made me unable to connect to a
> hidden network anymore. Connecting to a non-hidden network fully works.

As an alternative, please try connecting to the hidden network using the
in-tree brcmsmac driver, which also supports your BCM43224-based device.
See [1] for more information.

In your case, you would also be required to purge (not remove) the
broadcom-sta-common package, as this blacklists the brcmsmac module.

Geoff

[1] http://wiki.debian.org/brcm80211



Information forwarded to debian-bugs-dist@lists.debian.org, Cyril Lacoux <clacoux@easter-eggs.com>:
Bug#698697; Package broadcom-sta-source. (Wed, 23 Jan 2013 11:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jonathan Klee <klee.jonathan@gmail.com>:
Extra info received and forwarded to list. Copy sent to Cyril Lacoux <clacoux@easter-eggs.com>. (Wed, 23 Jan 2013 11:21:03 GMT) Full text and rfc822 format available.

Message #20 received at 698697@bugs.debian.org (full text, mbox):

From: Jonathan Klee <klee.jonathan@gmail.com>
To: Geoff Simmons <gsimmons@gsimmons.org>
Cc: 698697@bugs.debian.org
Subject: Re: Bug#698697: broadcom-sta: hidden ssids connection fails
Date: Wed, 23 Jan 2013 12:19:06 +0100
[Message part 1 (text/plain, inline)]
This actually worked, thanks you.
The bug still remains with the wl driver though.

On Wed, Jan 23, 2013 at 9:12 AM, Geoff Simmons <gsimmons@gsimmons.org>wrote:

> Hi Jonathan,
>
> On Tue, Jan 22, 2013 at 07:47:01AM -0500, Jonathan Klee wrote:
> > Package: broadcom-sta-source
> > Version: 5.100.82.112-8
> > Severity: normal
> >
> > Updating from Squeeze to Wheezy on my MacBook Air and recompiling wl as
> > explained on http://wiki.debian.org/wl made me unable to connect to a
> > hidden network anymore. Connecting to a non-hidden network fully works.
>
> As an alternative, please try connecting to the hidden network using the
> in-tree brcmsmac driver, which also supports your BCM43224-based device.
> See [1] for more information.
>
> In your case, you would also be required to purge (not remove) the
> broadcom-sta-common package, as this blacklists the brcmsmac module.
>
> Geoff
>
> [1] http://wiki.debian.org/brcm80211
>
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Cyril Lacoux <clacoux@easter-eggs.com>:
Bug#698697; Package broadcom-sta-source. (Sat, 09 Feb 2013 17:57:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Keith Smiley <keithbsmiley@gmail.com>:
Extra info received and forwarded to list. Copy sent to Cyril Lacoux <clacoux@easter-eggs.com>.

Your message did not contain a Subject field. They are recommended and useful because the title of a $gBug is determined using this field. Please remember to include a Subject field in your messages in future.

(Sat, 09 Feb 2013 17:57:03 GMT) Full text and rfc822 format available.


Message #25 received at 698697@bugs.debian.org (full text, mbox):

From: Keith Smiley <keithbsmiley@gmail.com>
To: 698697@bugs.debian.org
Date: Sat, 09 Feb 2013 12:55:21 -0500
I also have this issue on a MacbookPro7,1, doesn't seem like there's an 
alternate driver option here. It only doesn't connect on hidden networks 
if I make the same network visible it works perfectly.

>> lspci | grep -i broad
02:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n 
Wireless LAN Controller (rev 01)




Information forwarded to debian-bugs-dist@lists.debian.org, Cyril Lacoux <clacoux@easter-eggs.com>:
Bug#698697; Package broadcom-sta-source. (Sat, 09 Feb 2013 23:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Geoff Simmons <gsimmons@gsimmons.org>:
Extra info received and forwarded to list. Copy sent to Cyril Lacoux <clacoux@easter-eggs.com>. (Sat, 09 Feb 2013 23:15:03 GMT) Full text and rfc822 format available.

Message #30 received at 698697@bugs.debian.org (full text, mbox):

From: Geoff Simmons <gsimmons@gsimmons.org>
To: Keith Smiley <keithbsmiley@gmail.com>, 698697@bugs.debian.org
Subject: Re: Bug#698697: (no subject)
Date: Sun, 10 Feb 2013 10:13:52 +1100
Hi Keith,

On Sat, Feb 09, 2013 at 12:55:21PM -0500, Keith Smiley wrote:
> I also have this issue on a MacbookPro7,1, doesn't seem like there's
> an alternate driver option here. It only doesn't connect on hidden
> networks if I make the same network visible it works perfectly.

Thanks for your information.  Your BCM4322-based device (PCI ID 14e4:432b)
is supported by the in-tree b43 driver since Linux 2.6.38.

As a workaround, install the firmware-b43-installer package from contrib,
purge the broadcom-sta-common package (this blacklists the b43 module),
restart the system and try connecting to the hidden network.

Geoff



Information forwarded to debian-bugs-dist@lists.debian.org, Cyril Lacoux <clacoux@easter-eggs.com>:
Bug#698697; Package broadcom-sta-source. (Tue, 26 Feb 2013 15:18:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Alban Dericbourg <alban@dericbourg.net>:
Extra info received and forwarded to list. Copy sent to Cyril Lacoux <clacoux@easter-eggs.com>. (Tue, 26 Feb 2013 15:18:03 GMT) Full text and rfc822 format available.

Message #35 received at 698697@bugs.debian.org (full text, mbox):

From: Alban Dericbourg <alban@dericbourg.net>
To: 698697@bugs.debian.org
Date: Tue, 26 Feb 2013 16:13:51 +0100
[Message part 1 (text/plain, inline)]
Hi,

I could not find an alternative driver for mine:
    $ lspci -nn | grep 802\.11
    02:00.0 Network controller [0280]: Broadcom Corporation BCM43228
802.11a/b/g/n [14e4:4359]

Is it planned to fix the hidden network issue or is it better if I compile
manually the driver (probably not the latest vendor version since it does
not compile: "src/wl/sys/wl_linux.c:388:2: error: unknown field
‘ndo_set_multicast_list’ specified in initializer").

Thanks,

Alban
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 03:47:05 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.