Debian Bug report logs - #696578
live-build fails to build image

version graph

Package: live-build; Maintainer for live-build is Live Systems Maintainers <debian-live@lists.debian.org>; Source for live-build is src:live-build.

Reported by: Peter Ryzhenkov <peter.ryzhenkov@gmail.com>

Date: Sun, 23 Dec 2012 06:42:01 UTC

Severity: normal

Found in version live-build/3.0~a51-1

Fixed in version 3.0~b4-1

Done: Daniel Baumann <daniel.baumann@progress-technologies.net>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Live Project <debian-live@lists.debian.org>:
Bug#696578; Package live-build. (Sun, 23 Dec 2012 06:42:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Peter Ryzhenkov <peter.ryzhenkov@gmail.com>:
New Bug report received and forwarded. Copy sent to Debian Live Project <debian-live@lists.debian.org>. (Sun, 23 Dec 2012 06:42:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Peter Ryzhenkov <peter.ryzhenkov@gmail.com>
To: submit@bugs.debian.org
Subject: live-build fails to build image
Date: Sun, 23 Dec 2012 10:39:12 +0400
[Message part 1 (text/plain, inline)]
Package: live-build
Version: 3.0~a51-1

Steps to reproduce:
1. Start image build
2. after the squashfs building stage the build process will stop and
you'll see the following message:

Some packages could not be installed. This may mean that you
haverequested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 grub-pc : Depends: grub2-common (= 1.99-23.1) but it is not going to
be installed
           Conflicts: grub-legacy but 0.97-66.1 is to be installed
E: Unable to correct problems, you have held broken packages.
P: Begin unmounting filesystems...

Not sure that's the live-build error, it's rather caused by the
grub-pc update, but the dist-upgrade went fine on all my wheezy
machines, the problem occurred only during the live-build image
creation.

Please fix it.

Thanks in advance,
Peter Ryzhenkov.
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Live Project <debian-live@lists.debian.org>:
Bug#696578; Package live-build. (Sun, 23 Dec 2012 07:36:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Peter Ryzhenkov <peter.ryzhenkov@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Live Project <debian-live@lists.debian.org>. (Sun, 23 Dec 2012 07:36:03 GMT) Full text and rfc822 format available.

Message #10 received at 696578@bugs.debian.org (full text, mbox):

From: Peter Ryzhenkov <peter.ryzhenkov@gmail.com>
To: 696578@bugs.debian.org
Date: Sun, 23 Dec 2012 11:25:20 +0400
[Message part 1 (text/plain, inline)]
Update: the netinst installation goes smooth, same arch (amd64), same mirror
[Message part 2 (text/html, inline)]

Reply sent to daniel.baumann@progress-technologies.net:
You have taken responsibility. (Sun, 23 Dec 2012 09:57:03 GMT) Full text and rfc822 format available.

Notification sent to Peter Ryzhenkov <peter.ryzhenkov@gmail.com>:
Bug acknowledged by developer. (Sun, 23 Dec 2012 09:57:03 GMT) Full text and rfc822 format available.

Message #15 received at 696578-done@bugs.debian.org (full text, mbox):

From: Daniel Baumann <daniel.baumann@progress-technologies.net>
To: 696578-done@bugs.debian.org
Subject: Re: live-build fails to build image
Date: Sun, 23 Dec 2012 10:57:33 +0100
Version: 3.0~b4-1

-- 
Address:        Daniel Baumann, Donnerbuehlweg 3, CH-3012 Bern
Email:          daniel.baumann@progress-technologies.net
Internet:       http://people.progress-technologies.net/~daniel.baumann/



Information forwarded to debian-bugs-dist@lists.debian.org, Debian Live Project <debian-live@lists.debian.org>:
Bug#696578; Package live-build. (Fri, 28 Dec 2012 15:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Fernando Toledo <ftoledo@docksud.com.ar>:
Extra info received and forwarded to list. Copy sent to Debian Live Project <debian-live@lists.debian.org>. (Fri, 28 Dec 2012 15:15:03 GMT) Full text and rfc822 format available.

Message #20 received at 696578@bugs.debian.org (full text, mbox):

From: Fernando Toledo <ftoledo@docksud.com.ar>
To: 696578@bugs.debian.org
Subject: same here
Date: Fri, 28 Dec 2012 12:02:16 -0300
hello!
i use 3.0~a51-1

i try to make a i386 image from amd64 machine boot running wheezy

any workaround to this?

-- 
Fernando Toledo
Dock Sud BBS
http://bbs.docksud.com.ar
telnet://bbs.docksud.com.ar



Information forwarded to debian-bugs-dist@lists.debian.org, Debian Live Project <debian-live@lists.debian.org>:
Bug#696578; Package live-build. (Fri, 28 Dec 2012 15:45:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ben Armstrong <synrg@sanctuary.nslug.ns.ca>:
Extra info received and forwarded to list. Copy sent to Debian Live Project <debian-live@lists.debian.org>. (Fri, 28 Dec 2012 15:45:03 GMT) Full text and rfc822 format available.

Message #25 received at 696578@bugs.debian.org (full text, mbox):

From: Ben Armstrong <synrg@sanctuary.nslug.ns.ca>
To: Fernando Toledo <ftoledo@docksud.com.ar>, 696578@bugs.debian.org
Subject: Re: Bug#696578: same here
Date: Fri, 28 Dec 2012 11:41:28 -0400
On 28/12/12 11:02 AM, Fernando Toledo wrote:
> hello!
> i use 3.0~a51-1
> 
> i try to make a i386 image from amd64 machine boot running wheezy
> 
> any workaround to this?
> 

Perhaps you overlooked in the full bug report that it is fixed in
3.0~b4-1? Simply use that version.

Ben



Information forwarded to debian-bugs-dist@lists.debian.org, Debian Live Project <debian-live@lists.debian.org>:
Bug#696578; Package live-build. (Fri, 28 Dec 2012 15:45:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Fernando Toledo <ftoledo@docksud.com.ar>:
Extra info received and forwarded to list. Copy sent to Debian Live Project <debian-live@lists.debian.org>. (Fri, 28 Dec 2012 15:45:05 GMT) Full text and rfc822 format available.

Message #30 received at 696578@bugs.debian.org (full text, mbox):

From: Fernando Toledo <ftoledo@docksud.com.ar>
To: 696578@bugs.debian.org
Subject: Re: Bug#696578: same here
Date: Fri, 28 Dec 2012 12:38:48 -0300
El 28/12/12 12:02, Fernando Toledo escribió:
> hello!
> i use 3.0~a51-1
> 
> i try to make a i386 image from amd64 machine boot running wheezy
> 
> any workaround to this?
> 

boot => both

-- 
Fernando Toledo
Dock Sud BBS
http://bbs.docksud.com.ar
telnet://bbs.docksud.com.ar



Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 02 Mar 2013 07:27:47 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 11:53:03 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.