Debian Bug report logs - #694865
RFP: gpass -- The password manager for GNOME2

Package: wnpp; Maintainer for wnpp is wnpp@debian.org;

Reported by: riu <stanraystan@rambler.ru>

Date: Sat, 1 Dec 2012 14:12:01 UTC

Severity: wishlist

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, stanraystan@rambler.ru, wnpp@debian.org:
Bug#694865; Package wnpp. (Sat, 01 Dec 2012 14:12:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to riu <stanraystan@rambler.ru>:
New Bug report received and forwarded. Copy sent to stanraystan@rambler.ru, wnpp@debian.org. (Sat, 01 Dec 2012 14:12:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: riu <stanraystan@rambler.ru>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: RFP: gpass -- The password manager for GNOME2
Date: Sat, 01 Dec 2012 18:09:06 +0400
Package: wnpp
Severity: wishlist

* Package name    : gpass
  Version         : 0.5.1
  Upstream Author : Morten Fjord-Larsen, Kouji TAKAO
* URL             : http://projects.netlab.jp/gpass/
* License         : GPL
  Programming Lang: C
  Description     : The password manager for GNOME2

I would like to have Gpass packaged in Debian again. It was present in Debian,
but removed. See

#617590 - RM: gpass -- RoQA; dead upstream, low popcon, alternatives exist,
orphaned - Debian Bug report logs
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=617590

I fixed (hopefully) the problem that prevented Gpass to compile with gcc
versions newer than 4.4, and also updated gpass to version 0.5.1 from its
official site. The code: https://code.launchpad.net/~stanray/gpass/gpass051 .
Gpass now compiles succesfully. If you compile Gpass manually with compilers
newer than gcc-4.4, configure script should be edited as well, e.g.
LDFLAGS="$LDFLAGS -Wl,--no-as-needed". See these bug reports:

Bug #770994 “gpass version 0.5.0-2 failed to build on amd64 with...” : Bugs
: “gpass” package : Ubuntu
https://bugs.launchpad.net/ubuntu/+source/gpass/+bug/770994

Bug #505921 “[needs-packaging] newer version” : Bugs : “gpass” package
: Ubuntu
https://bugs.launchpad.net/ubuntu/+source/gpass/+bug/505921

Gpass is useful. E.g., it allows to copy both ID and the password with single
Ctrl+Shift+B, and then paste them one by one.



Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 04:28:11 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.