Debian Bug report logs - #694075
ITP: gtkparasite -- GTK+ debugging and development tool

Package: wnpp; Maintainer for wnpp is wnpp@debian.org;

Reported by: Anthony Wong <anthony.wong@ubuntu.com>

Date: Fri, 23 Nov 2012 17:09:02 UTC

Owned by: Anthony Wong <anthony.wong@ubuntu.com>

Severity: wishlist

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org:
Bug#694075; Package wnpp. (Fri, 23 Nov 2012 17:09:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Anthony Wong <anthony.wong@ubuntu.com>:
New Bug report received and forwarded. Copy sent to wnpp@debian.org. (Fri, 23 Nov 2012 17:09:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Anthony Wong <anthony.wong@ubuntu.com>
To: submit@bugs.debian.org
Cc: Devid Antonio Filoni <d.filoni@ubuntu.com>, Devid Antonio Filoni <devidfil@gmail.com>
Subject: ITP: gtkparasite -- GTK+ debugging and development tool
Date: Sat, 24 Nov 2012 01:06:46 +0800
Package: wnpp
Severity: wishlist

Package name: gtkparasite
Homepage: http://chipx86.github.com/gtkparasite/
License: MIT
Description: GTK+ debugging and development tool
 Parasite is a debugging and development tool that runs inside your GTK+
 application's process. It can inspect your application, giving you detailed
 information on your UI, such as the hierarchy, X window IDs, widget
 properties, and more. You can modify properties on the fly in order to
 experiment with the look of your UI.
 .
 But you can go further than that. You can actually modify your application
 logic while the program is running! Parasite includes an embedded Python
 shell that lets you write new code that directly interacts with your
 application's UI, regardless of the language the application is written in.
 Create new dialogs, attach temporary signal handlers to buttons, test out
 new logic, and gather additional debug information.

This package had been packaged by Devid in 2009 [1] but was later removed
on request due to lack of upstream activity [2]. Lately upstream started to
support GTK3 so we should provide this package again.

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=514033
[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=638178

Thanks,
Anthony



Owner recorded as Anthony Wong <anthony.wong@ubuntu.com>. Request was from Bart Martens <bartm@quantz.debian.org> to control@bugs.debian.org. (Sat, 24 Nov 2012 04:21:07 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, Anthony Wong <anthony.wong@ubuntu.com>:
Bug#694075; Package wnpp. (Thu, 27 Jun 2013 11:06:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Pietro Battiston <me@pietrobattiston.it>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org, Anthony Wong <anthony.wong@ubuntu.com>. (Thu, 27 Jun 2013 11:06:04 GMT) Full text and rfc822 format available.

Message #12 received at 694075@bugs.debian.org (full text, mbox):

From: Pietro Battiston <me@pietrobattiston.it>
To: 694075@bugs.debian.org
Subject: Working package
Date: Thu, 27 Jun 2013 13:02:40 +0200
Hello,

the debian packaging of the last version seems to basically work with
the new upstream updates, after changing just one line of debian/rules.

You should be able to build a working version of gtkparasite for Gtk3 by
doing:

git clone git://git.debian.org/git/collab-maint/gtkparasite.git
git chechout debian
git-buildpackage

That said,
- python support is not working (presumably a missing build dependence,
but I ignore which),
- certainly other (non-optional) build-depends are missing,
- I'm currently getting a strange error trying to pbuild in a sid
chroot,¹
- due to time constraints, I don't think I will ever try to adopt this
package.

Still, anyone interested is welcome to start from that repo.

Pietro

¹
./configure: line 11807: syntax error near unexpected token `GTK,'
./configure: line 11807: `PKG_CHECK_MODULES(GTK, gtk+-$GTK_API_VERSION
>= $GTK_REQUIRED)'





Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 12:02:22 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.