Debian Bug report logs - #693474
dctrl-tools: Add multiarch metadata

version graph

Package: dctrl-tools; Maintainer for dctrl-tools is dctrl-tools developers <dctrl-tools-devel@lists.alioth.debian.org>; Source for dctrl-tools is src:dctrl-tools.

Reported by: Wookey <wookey@wookware.org>

Date: Fri, 16 Nov 2012 21:45:02 UTC

Severity: normal

Tags: patch

Found in version dctrl-tools/2.22.2

Fixed in version dctrl-tools/2.23

Done: Antti-Juhani Kaijanaho <ajk@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, dctrl-tools developers <dctrl-tools-devel@lists.alioth.debian.org>:
Bug#693474; Package dctrl-tools. (Fri, 16 Nov 2012 21:45:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Wookey <wookey@wookware.org>:
New Bug report received and forwarded. Copy sent to dctrl-tools developers <dctrl-tools-devel@lists.alioth.debian.org>. (Fri, 16 Nov 2012 21:45:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Wookey <wookey@wookware.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: dctrl-tools: Add multiarch metadata
Date: Fri, 16 Nov 2012 21:41:25 +0000
[Message part 1 (text/plain, inline)]
Package: dctrl-tools
Version: 2.22.2
Severity: normal
Tags: patch
User: multiarch-devel@lists.alioth.debian.org
Usertags: multiarch

For build-dependencies to work properly under multiarch this package
needs to be marked

Multi-Arch: foreign

so that it can satisfy a build-dependency for any architecture. See
http://wiki.debian.org/Multiarch/CrossDependencies and
http://wiki.debian.org/Multiarch/Implementation for explanation and
background. 

There are 6 packages in debian which can't be cross-built until this
is done. 

-- System Information:
Debian Release: 6.0.6
  APT prefers stable
  APT policy: (990, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32.33-kvm-i386-20111128-dirty (SMP w/1 CPU core)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
[dctrl-tools-2.22.2-multiarch.patch (text/x-diff, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, dctrl-tools developers <dctrl-tools-devel@lists.alioth.debian.org>:
Bug#693474; Package dctrl-tools. (Sat, 17 Nov 2012 10:21:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Antti-Juhani Kaijanaho <antti-juhani@kaijanaho.fi>:
Extra info received and forwarded to list. Copy sent to dctrl-tools developers <dctrl-tools-devel@lists.alioth.debian.org>. (Sat, 17 Nov 2012 10:21:03 GMT) Full text and rfc822 format available.

Message #10 received at 693474@bugs.debian.org (full text, mbox):

From: Antti-Juhani Kaijanaho <antti-juhani@kaijanaho.fi>
To: Wookey <wookey@wookware.org>, 693474@bugs.debian.org
Subject: Re: [Dctrl-tools-devel] Bug#693474: dctrl-tools: Add multiarch metadata
Date: Sat, 17 Nov 2012 12:16:59 +0200
On Fri, Nov 16, 2012 at 09:41:25PM +0000, Wookey wrote:
> For build-dependencies to work properly under multiarch this package
> needs to be marked
> 
> Multi-Arch: foreign

Thanks.  This change would be for jessie, yes?  It seems to me to be too late
to offer it to the release team for unblocking.

> There are 6 packages in debian which can't be cross-built until this
> is done. 

I'm curious; which ones?

-- 
Antti-Juhani Kaijanaho, Jyväskylä, Finland
http://antti-juhani.kaijanaho.fi/newblog/
http://www.flickr.com/photos/antti-juhani/




Information forwarded to debian-bugs-dist@lists.debian.org, dctrl-tools developers <dctrl-tools-devel@lists.alioth.debian.org>:
Bug#693474; Package dctrl-tools. (Sat, 17 Nov 2012 22:45:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Wookey <wookey@wookware.org>:
Extra info received and forwarded to list. Copy sent to dctrl-tools developers <dctrl-tools-devel@lists.alioth.debian.org>. (Sat, 17 Nov 2012 22:45:03 GMT) Full text and rfc822 format available.

Message #15 received at 693474@bugs.debian.org (full text, mbox):

From: Wookey <wookey@wookware.org>
To: Antti-Juhani Kaijanaho <antti-juhani@kaijanaho.fi>
Cc: 693474@bugs.debian.org
Subject: Re: [Dctrl-tools-devel] Bug#693474: dctrl-tools: Add multiarch metadata
Date: Sat, 17 Nov 2012 22:42:35 +0000
+++ Antti-Juhani Kaijanaho [2012-11-17 12:16 +0200]:
> On Fri, Nov 16, 2012 at 09:41:25PM +0000, Wookey wrote:
> > For build-dependencies to work properly under multiarch this package
> > needs to be marked
> > 
> > Multi-Arch: foreign
> 
> Thanks.  This change would be for jessie, yes?  It seems to me to be too late
> to offer it to the release team for unblocking.

I guess so. Although it's a totally harmless change and 'multiarch'
is a Wheezy Goal so they probably would let it in if you did an
upload. But there is no real need to do so.  

> > There are 6 packages in debian which can't be cross-built until this
> > is done. 
> 
> I'm curious; which ones?

I find out with:
grep-aptavail -s Package -F Build-depends,Build-depends-indep grep-dctrl /var/lib/apt/lists/*Sources | sort | uniq

Package: ghc
Package: libcdio
Package: wine
Package: wine-unstable
Package: wings3d

Hmm, seems I can't count - that's 5 packages :-)

Wookey
-- 
Principal hats:  Linaro, Emdebian, Wookware, Balloonboard, ARM
http://wookware.org/



Information forwarded to debian-bugs-dist@lists.debian.org, dctrl-tools developers <dctrl-tools-devel@lists.alioth.debian.org>:
Bug#693474; Package dctrl-tools. (Sun, 18 Nov 2012 00:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Antti-Juhani Kaijanaho <antti-juhani@kaijanaho.fi>:
Extra info received and forwarded to list. Copy sent to dctrl-tools developers <dctrl-tools-devel@lists.alioth.debian.org>. (Sun, 18 Nov 2012 00:51:03 GMT) Full text and rfc822 format available.

Message #20 received at 693474@bugs.debian.org (full text, mbox):

From: Antti-Juhani Kaijanaho <antti-juhani@kaijanaho.fi>
To: Wookey <wookey@wookware.org>, 693474@bugs.debian.org
Cc: Antti-Juhani Kaijanaho <antti-juhani@kaijanaho.fi>
Subject: Re: [Dctrl-tools-devel] Bug#693474: Bug#693474: dctrl-tools: Add multiarch metadata
Date: Sun, 18 Nov 2012 02:46:59 +0200
On Sat, Nov 17, 2012 at 10:42:35PM +0000, Wookey wrote:
> I guess so. Although it's a totally harmless change and 'multiarch'
> is a Wheezy Goal so they probably would let it in if you did an
> upload. But there is no real need to do so.  

I just seem to recall seeing lots of negative feedback to multiarch related
changes on debian-release.  But then again, this is just one line.

> > I'm curious; which ones?
> 
> I find out with:
> grep-aptavail -s Package -F Build-depends,Build-depends-indep grep-dctrl /var/lib/apt/lists/*Sources | sort | uniq
> 
> Package: ghc
> Package: libcdio
> Package: wine
> Package: wine-unstable
> Package: wings3d
> 
> Hmm, seems I can't count - that's 5 packages :-)

Those are packages that haven't been updated with that respect in years:

$ grep-aptavail -F Build-depends,Build-depends-indep dctrl-tools /var/lib/apt/lists/*Sources -c
16

-- 
Antti-Juhani Kaijanaho, Jyväskylä, Finland
http://antti-juhani.kaijanaho.fi/newblog/
http://www.flickr.com/photos/antti-juhani/




Reply sent to Antti-Juhani Kaijanaho <ajk@debian.org>:
You have taken responsibility. (Tue, 07 May 2013 21:06:07 GMT) Full text and rfc822 format available.

Notification sent to Wookey <wookey@wookware.org>:
Bug acknowledged by developer. (Tue, 07 May 2013 21:06:07 GMT) Full text and rfc822 format available.

Message #25 received at 693474-close@bugs.debian.org (full text, mbox):

From: Antti-Juhani Kaijanaho <ajk@debian.org>
To: 693474-close@bugs.debian.org
Subject: Bug#693474: fixed in dctrl-tools 2.23
Date: Tue, 07 May 2013 21:02:47 +0000
Source: dctrl-tools
Source-Version: 2.23

We believe that the bug you reported is fixed in the latest version of
dctrl-tools, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 693474@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Antti-Juhani Kaijanaho <ajk@debian.org> (supplier of updated dctrl-tools package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 07 May 2013 23:16:00 +0300
Source: dctrl-tools
Binary: dctrl-tools
Architecture: source amd64
Version: 2.23
Distribution: unstable
Urgency: low
Maintainer: dctrl-tools developers <dctrl-tools-devel@lists.alioth.debian.org>
Changed-By: Antti-Juhani Kaijanaho <ajk@debian.org>
Description: 
 dctrl-tools - Command-line tools to process Debian package information
Closes: 693474
Changes: 
 dctrl-tools (2.23) unstable; urgency=low
 .
   [ David Prévot ]
 .
   * Fix charset in pt_BR program translation.
 .
   [ Antti-Juhani Kaijanaho ]
 .
   * Merge 2.22.1 and 2.22.2.
   * Add a test case (tests/0021.{in,out,sh}) to verify that tbl-dctrl
     handles UTF-8 correctly.
      - As it requires the C.UTF-8 locale, build-depend on libc-bin >= 2.13
   * Since mblen is unnecessarily marked warn_unused_result with
     _FORTIFY_SOURCE, (see bug #674917), causing spurious warnings upon
     mblen initialization calls, switch to using mbrlen in tbl-dctrl.c (a
     good idea in any case).
   * Add -Wextra to non-package builds (and clean up the resulting warnings).
   * lib/msg.c (msg_primitive): Write the period before the newline, not after!
   * tests/0022.{out,err,fails}: New test case, for grep-dctrl
     --ignore-parse-errors
   * tester.sh: Handle missing diffs gracefully.
   * lib/fsaf.c and others: Remove mmap support (recognize but ignore --mmap).
     It was only complicating matters without giving much benefit.
   * lib/fsaf.[ch]: Make fsaf_read an inline function (50 % speedup in my
     tests.)
   * debian/control (Build-Depends): Remove versioned gcc
     Thanks to Jakub Wilk for pointing out the version spec was broken.
     It also turns out to be obsolete.
   * Some code cleanup.
   * debian/control: Add "Multi-Arch: foreign"
     Closes: 693474 (Add multiarch metadata)
     Reported by Wookey <wookey@wookware.org>.
   * po/fi.po: Fix charset issue discovered by Jakub Wilk
     and reported by David Prévot, and delete obsolete entries.
Checksums-Sha1: 
 c3db0e649aad41a31b3dbe81dc8f485484e6dfa8 1052 dctrl-tools_2.23.dsc
 6fc0a6f31221f5d620ac5f4097581c51f377ad88 3403747 dctrl-tools_2.23.tar.gz
 c9235601de628055b29050d67eead6bc79c7f73d 170168 dctrl-tools_2.23_amd64.deb
Checksums-Sha256: 
 9d4af8d578f8af7986a5f6a0d122c1d86762056e00fa46d2ffeaeae8e0a44328 1052 dctrl-tools_2.23.dsc
 8e1eeca92f6c22b48fc3b8cc6f53bfbf7f04f33c74e585fd1a35230e9e1959d0 3403747 dctrl-tools_2.23.tar.gz
 27e7bab390a2b544a5687ca4da5c3a433b6c3dff01af676d32018408d4ffdae0 170168 dctrl-tools_2.23_amd64.deb
Files: 
 d00d682a14a1a93caf85abf3ea976c2c 1052 utils optional dctrl-tools_2.23.dsc
 77402eb21b3717cfec31e5be297bf2ac 3403747 utils optional dctrl-tools_2.23.tar.gz
 bd03d316868bc6bbdb83629eed3ea62b 170168 utils optional dctrl-tools_2.23_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAlGJYgsACgkQHsI32VNFhOiO6ACbB8/Q/tfI63A+IoNu5kxFHvWt
ePsAoJZLBMcDJ0BFrmXgMZ9ogLarMAjL
=UdEb
-----END PGP SIGNATURE-----




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 20 Jun 2013 07:49:34 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 00:25:59 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.