Debian Bug report logs - #691925
update-notifier-common: Add an option to only show security packages

version graph

Package: update-notifier-common; Maintainer for update-notifier-common is Julian Andres Klode <jak@debian.org>; Source for update-notifier-common is src:update-notifier.

Reported by: Rodolphe Quiédeville <rodolphe@quiedeville.org>

Date: Wed, 31 Oct 2012 13:03:02 UTC

Severity: wishlist

Found in version update-notifier/0.99.3debian8

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Julian Andres Klode <jak@debian.org>:
Bug#691925; Package update-notifier-common. (Wed, 31 Oct 2012 13:03:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Rodolphe Quiédeville <rodolphe@quiedeville.org>:
New Bug report received and forwarded. Copy sent to Julian Andres Klode <jak@debian.org>. (Wed, 31 Oct 2012 13:03:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Rodolphe Quiédeville <rodolphe@quiedeville.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: update-notifier-common: Add an option to only show security packages
Date: Wed, 31 Oct 2012 14:01:47 +0100
[Message part 1 (text/plain, inline)]
Package: update-notifier-common
Version: 0.99.3debian8
Severity: wishlist

Hi,

Please found attach a patch to add an option -s like -p but to show onlys packages from security

Regards,


-- System Information:
Debian Release: 6.0.6
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-openvz-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages update-notifier-common depends on:
ii  python                2.6.6-3+squeeze7   interactive high-level object-orie
ii  python-apt            0.7.100.1+squeeze1 Python interface to libapt-pkg

Versions of packages update-notifier-common recommends:
ii  libpam-modules        1.1.1-6.1+squeeze1 Pluggable Authentication Modules f

update-notifier-common suggests no packages.

-- no debconf information
[patch (text/plain, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#691925; Package update-notifier-common. (Tue, 06 Nov 2012 14:18:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julian Andres Klode <jak@debian.org>:
Extra info received and forwarded to list. (Tue, 06 Nov 2012 14:18:03 GMT) Full text and rfc822 format available.

Message #10 received at 691925@bugs.debian.org (full text, mbox):

From: Julian Andres Klode <jak@debian.org>
To: Rodolphe Quiédeville <rodolphe@quiedeville.org>, 691925@bugs.debian.org
Subject: Re: Bug#691925: update-notifier-common: Add an option to only show security packages
Date: Tue, 6 Nov 2012 15:15:02 +0100
On Wed, Oct 31, 2012 at 02:01:47PM +0100, Rodolphe Quiédeville wrote:
> Package: update-notifier-common
> Version: 0.99.3debian8
> Severity: wishlist
> 
> Hi,
> 
> Please found attach a patch to add an option -s like -p but to show onlys packages from security

Total NAK. You're duplicating most of the code. What you want is
to modify write_package_names to add an additional filtering
stage, by checking whether the candidates of the packages
are security updates.

But you should probably submit this upstream to Ubuntu anyway,
after signing a Contributor License Agreement with Canonical.
-- 
Julian Andres Klode  - Debian Developer, Ubuntu Member

See http://wiki.debian.org/JulianAndresKlode and http://jak-linux.org/.



Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 16:19:20 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.