Debian Bug report logs - #690282
building of contrib package with non-free build-dependencies not supported

Package: buildd.debian.org; Maintainer for buildd.debian.org is Debian Buildd Team <wb-team@buildd.debian.org>;

Reported by: Hideki Yamane <henrich@debian.or.jp>

Date: Fri, 12 Oct 2012 01:39:01 UTC

Severity: important

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, ruby-pgplot@packages.debian.org, Debian Buildd Team <wb-team@buildd.debian.org>:
Bug#690282; Package buildd.debian.org. (Fri, 12 Oct 2012 01:39:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Hideki Yamane <henrich@debian.or.jp>:
New Bug report received and forwarded. Copy sent to ruby-pgplot@packages.debian.org, Debian Buildd Team <wb-team@buildd.debian.org>. (Fri, 12 Oct 2012 01:39:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Hideki Yamane <henrich@debian.or.jp>
To: submit@bugs.debian.org
Subject: Something wrong with buildd when contrib package needs to be built with non-free package
Date: Fri, 12 Oct 2012 10:35:10 +0900
Package: buildd.debian.org
Severity: important
X-debbugs-CC: ruby-pgplot@packages.debian.org

Hi,

 Something wrong with buildd when contrib package needs to be built with non-free
 package, for example, ruby-pgplot.

>Dependency installability problem for ruby-pgplot on armel, armhf, hurd-i386, i386, ia64, kfreebsd-amd64, kfreebsd-i386, mips, mipsel, powerpc, s390, s390x and sparc:
>
>  ruby-pgplot (= 0.1.3-6) build-depends on missing:
>  - pgplot5

 However, pgplot5 is in unstable. I can build it with pbuilder when I would add 
 non-free to apt line, and cannot build without it.


-- 
Regards,

 Hideki Yamane     henrich @ debian.or.jp/org
 http://wiki.debian.org/HidekiYamane



Information forwarded to debian-bugs-dist@lists.debian.org, Debian Buildd Team <wb-team@buildd.debian.org>:
Bug#690282; Package buildd.debian.org. (Fri, 12 Oct 2012 09:42:03 GMT) Full text and rfc822 format available.

Message #8 received at 690282@bugs.debian.org (full text, mbox):

From: Philipp Kern <pkern@debian.org>
To: Hideki Yamane <henrich@debian.or.jp>, 690282@bugs.debian.org
Subject: Re: Bug#690282: Something wrong with buildd when contrib package needs to be built with non-free package
Date: Fri, 12 Oct 2012 11:38:21 +0200
[Message part 1 (text/plain, inline)]
Control: retitle -1 building of contrib package with non-free build-dependencies not supported

Hideki,

am Fri, Oct 12, 2012 at 10:35:10AM +0900 hast du folgendes geschrieben:
>  Something wrong with buildd when contrib package needs to be built with
>  non-free  package, for example, ruby-pgplot.

this is not implemented and not supported on the official infrastructure.
It's a known problem that would need filtered non-free Packages input for the
build process.

Kind regards
Philipp Kern
[signature.asc (application/pgp-signature, inline)]

Changed Bug title to 'building of contrib package with non-free build-dependencies not supported' from 'Something wrong with buildd when contrib package needs to be built with non-free package' Request was from Philipp Kern <pkern@debian.org> to 690282-submit@bugs.debian.org. (Fri, 12 Oct 2012 09:42:03 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Buildd Team <wb-team@buildd.debian.org>:
Bug#690282; Package buildd.debian.org. (Fri, 12 Oct 2012 13:00:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Hideki Yamane <henrich@debian.or.jp>:
Extra info received and forwarded to list. Copy sent to Debian Buildd Team <wb-team@buildd.debian.org>. (Fri, 12 Oct 2012 13:00:06 GMT) Full text and rfc822 format available.

Message #15 received at 690282@bugs.debian.org (full text, mbox):

From: Hideki Yamane <henrich@debian.or.jp>
To: Philipp Kern <pkern@debian.org>
Cc: 690282@bugs.debian.org, ruby-pgplot@packages.debian.org
Subject: Re: Bug#690282: Something wrong with buildd when contrib package needs to be built with non-free package
Date: Fri, 12 Oct 2012 21:57:31 +0900
Hi Philipp,

On Fri, 12 Oct 2012 11:38:21 +0200
Philipp Kern <pkern@debian.org> wrote:
> >  Something wrong with buildd when contrib package needs to be built with
> >  non-free  package, for example, ruby-pgplot.
> 
> this is not implemented and not supported on the official infrastructure.
> It's a known problem that would need filtered non-free Packages input for the
> build process.

 Well, then what is the way to make non-free_build-depends_contrib package
 buildable, is there any information for it?

 This time, for ruby-pgplot (CCed: maintainer)

-- 
Regards,

 Hideki Yamane     henrich @ debian.or.jp/org
 http://wiki.debian.org/HidekiYamane



Information forwarded to debian-bugs-dist@lists.debian.org, Debian Buildd Team <wb-team@buildd.debian.org>:
Bug#690282; Package buildd.debian.org. (Fri, 12 Oct 2012 13:42:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Philipp Kern <pkern@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Buildd Team <wb-team@buildd.debian.org>. (Fri, 12 Oct 2012 13:42:03 GMT) Full text and rfc822 format available.

Message #20 received at 690282@bugs.debian.org (full text, mbox):

From: Philipp Kern <pkern@debian.org>
To: Hideki Yamane <henrich@debian.or.jp>
Cc: 690282@bugs.debian.org, ruby-pgplot@packages.debian.org
Subject: Re: Bug#690282: Something wrong with buildd when contrib package needs to be built with non-free package
Date: Fri, 12 Oct 2012 15:39:03 +0200
On Fri, Oct 12, 2012 at 09:57:31PM +0900, Hideki Yamane wrote:
> On Fri, 12 Oct 2012 11:38:21 +0200
> Philipp Kern <pkern@debian.org> wrote:
> > >  Something wrong with buildd when contrib package needs to be built with
> > >  non-free  package, for example, ruby-pgplot.
> > this is not implemented and not supported on the official infrastructure.
> > It's a known problem that would need filtered non-free Packages input for the
> > build process.
>  Well, then what is the way to make non-free_build-depends_contrib package
>  buildable, is there any information for it?

You have to build it yourself at the moment, sorry. (Or try to get the packages
fixed so that it can go into main.)

Kind regards
Philipp Kern



Information forwarded to debian-bugs-dist@lists.debian.org, Debian Buildd Team <wb-team@buildd.debian.org>:
Bug#690282; Package buildd.debian.org. (Mon, 15 Oct 2012 08:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Youhei SASAKI <uwabami@gfd-dennou.org>:
Extra info received and forwarded to list. Copy sent to Debian Buildd Team <wb-team@buildd.debian.org>. (Mon, 15 Oct 2012 08:51:03 GMT) Full text and rfc822 format available.

Message #25 received at 690282@bugs.debian.org (full text, mbox):

From: Youhei SASAKI <uwabami@gfd-dennou.org>
To: "Philipp Kern" <pkern@debian.org>
Cc: "Hideki Yamane" <henrich@debian.or.jp>, 690282@bugs.debian.org, ruby-pgplot@packages.debian.org
Subject: Re: Bug#690282: Something wrong with buildd when contrib package needs to be built with non-free package
Date: Mon, 15 Oct 2012 17:42:35 +0900
Hi, Philipp, Hideki

I'm Youhei SASAKI, ruby-pgplot maintainer.

At 12 Oct 2012 15:39:03 +0200,
"Philipp Kern" <pkern@debian.org> wrote:
> 
> On Fri, Oct 12, 2012 at 09:57:31PM +0900, Hideki Yamane wrote:
> > On Fri, 12 Oct 2012 11:38:21 +0200
> > Philipp Kern <pkern@debian.org> wrote:
> 
> You have to build it yourself at the moment, sorry. 

Ok. 

I'll try to build i386/amd64 arch. 
However, I can not build any other arch because I'm just DM, not DD.

>(Or try to get the packages  fixed so that it can go into main.)

Yes. I know, it's best. However, AFAIK, it's difficult. 
# PGPLOT is freely available for non-commercial use, not be redistributable. :-/

Best Wishes,
Youhei

---
Youhei SASAKI <uwabami@gfd-dennou.org>
              <uwabami@debian.or.jp>
GPG fingerprint:
  4096/RSA: 66A4 EA70 4FE2 4055 8D6A C2E6 9394 F354 891D 7E07



Information forwarded to debian-bugs-dist@lists.debian.org, Debian Buildd Team <wb-team@buildd.debian.org>:
Bug#690282; Package buildd.debian.org. (Mon, 15 Oct 2012 09:03:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Hideki Yamane <henrich@debian.or.jp>:
Extra info received and forwarded to list. Copy sent to Debian Buildd Team <wb-team@buildd.debian.org>. (Mon, 15 Oct 2012 09:03:03 GMT) Full text and rfc822 format available.

Message #30 received at 690282@bugs.debian.org (full text, mbox):

From: Hideki Yamane <henrich@debian.or.jp>
To: Youhei SASAKI <uwabami@gfd-dennou.org>
Cc: "Philipp Kern" <pkern@debian.org>, 690282@bugs.debian.org, ruby-pgplot@packages.debian.org
Subject: Re: Bug#690282: Something wrong with buildd when contrib package needs to be built with non-free package
Date: Mon, 15 Oct 2012 18:01:34 +0900
Hi Youhei,

On Mon, 15 Oct 2012 17:42:35 +0900
Youhei SASAKI <uwabami@gfd-dennou.org> wrote:
> I'll try to build i386/amd64 arch. 
> However, I can not build any other arch because I'm just DM, not DD.

 Well, it's enough to build on only i386/amd64 arch, isn't it?
 If so, just build i386/amd64 and upload, then file unblock request, please.

-- 
Regards,

 Hideki Yamane     henrich @ debian.or.jp/org
 http://wiki.debian.org/HidekiYamane



Information forwarded to debian-bugs-dist@lists.debian.org, Debian Buildd Team <wb-team@buildd.debian.org>:
Bug#690282; Package buildd.debian.org. (Mon, 15 Oct 2012 09:42:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Adam D. Barratt" <adam@adam-barratt.org.uk>:
Extra info received and forwarded to list. Copy sent to Debian Buildd Team <wb-team@buildd.debian.org>. (Mon, 15 Oct 2012 09:42:08 GMT) Full text and rfc822 format available.

Message #35 received at 690282@bugs.debian.org (full text, mbox):

From: "Adam D. Barratt" <adam@adam-barratt.org.uk>
To: Hideki Yamane <henrich@debian.or.jp>, <690282@bugs.debian.org>
Cc: Youhei SASAKI <uwabami@gfd-dennou.org>, Philipp Kern <pkern@debian.org>, <ruby-pgplot@packages.debian.org>
Subject: Re: Bug#690282: Something wrong with buildd when contrib package needs to be built with non-free package
Date: Mon, 15 Oct 2012 10:37:58 +0100
On 15.10.2012 10:01, Hideki Yamane wrote:
> Hi Youhei,
>
> On Mon, 15 Oct 2012 17:42:35 +0900
> Youhei SASAKI <uwabami@gfd-dennou.org> wrote:
>> I'll try to build i386/amd64 arch.
>> However, I can not build any other arch because I'm just DM, not DD.
>
>  Well, it's enough to build on only i386/amd64 arch, isn't it?
>  If so, just build i386/amd64 and upload, then file unblock request, 
> please.

It's already unblocked, but not migrating due to the missing builds.

You either need to get builds uploaded for all of the architectures on 
which the package currently exists in unstable, or get ftp-master to 
remove the difference.

Regards,

Adam



Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 16:50:41 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.