Debian Bug report logs - #685963
ruby-pgplot: dh_ruby FTBFS in sid

version graph

Package: ruby-pgplot; Maintainer for ruby-pgplot is Youhei SASAKI <uwabami@gfd-dennou.org>; Source for ruby-pgplot is src:ruby-pgplot.

Reported by: Micah Gersten <micahg@ubuntu.com>

Date: Mon, 27 Aug 2012 03:51:02 UTC

Severity: serious

Found in version ruby-pgplot/0.1.3-5

Fixed in version ruby-pgplot/0.1.3-6

Done: Youhei SASAKI <uwabami@gfd-dennou.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, micahg@ubuntu.com, Youhei SASAKI <uwabami@gfd-dennou.org>:
Bug#685963; Package ruby-pgplot. (Mon, 27 Aug 2012 03:51:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Micah Gersten <micahg@ubuntu.com>:
New Bug report received and forwarded. Copy sent to micahg@ubuntu.com, Youhei SASAKI <uwabami@gfd-dennou.org>. (Mon, 27 Aug 2012 03:51:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Micah Gersten <micahg@ubuntu.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: ruby-pgplot: dh_ruby FTBFS in sid
Date: Sun, 26 Aug 2012 22:49:56 -0500
[Message part 1 (text/plain, inline)]
Package: ruby-pgplot
Version: 0.1.3-5
Severity: serious
Justification: fails to build from source (but built successfully in the past)

I was trying to build this new version for Ubuntu hoping it would clear the FTBFS, but it fails on Ubuntu and Debian as well.  Here's the snippet from the Debian chroot and the full log is attached.

/usr/lib/ruby/vendor_ruby/gem2deb.rb:29:in `run': [/usr/bin/ruby1.8 -I/usr/lib/r
uby/vendor_ruby /usr/lib/ruby/vendor_ruby/gem2deb/extension_builder.rb ruby-pgpl
ot failed!] (Gem2Deb::CommandFailed)
        from /usr/lib/ruby/vendor_ruby/gem2deb/dh_ruby.rb:144:in `block in insta
ll_files_and_build_extensions'
        from /usr/lib/ruby/vendor_ruby/gem2deb/dh_ruby.rb:142:in `each'
        from /usr/lib/ruby/vendor_ruby/gem2deb/dh_ruby.rb:142:in `install_files_
and_build_extensions'
        from /usr/lib/ruby/vendor_ruby/gem2deb/dh_ruby.rb:97:in `install'
        from /usr/bin/dh_ruby:63:in `block (2 levels) in <main>'
        from /usr/lib/ruby/1.9.1/optparse.rb:1360:in `call'
        from /usr/lib/ruby/1.9.1/optparse.rb:1360:in `block in parse_in_order'
        from /usr/lib/ruby/1.9.1/optparse.rb:1347:in `catch'
        from /usr/lib/ruby/1.9.1/optparse.rb:1347:in `parse_in_order'
        from /usr/lib/ruby/1.9.1/optparse.rb:1341:in `order!'
        from /usr/lib/ruby/1.9.1/optparse.rb:1432:in `permute!'
        from /usr/lib/ruby/1.9.1/optparse.rb:1453:in `parse!'
        from /usr/bin/dh_ruby:67:in `<main>'
dh_auto_install: dh_ruby --install /«PKGBUILDDIR»/debian/tmp returned exit code 1


-- System Information:
Debian Release: wheezy/sid
  APT prefers precise-updates
  APT policy: (500, 'precise-updates'), (500, 'precise-security'), (500, 'precise-proposed'), (500, 'precise'), (100, 'precise-backports')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-30-generic (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
[ruby-pgplot_0.1.3-5-amd64-20120826-2240 (text/plain, attachment)]

Reply sent to Youhei SASAKI <uwabami@gfd-dennou.org>:
You have taken responsibility. (Sat, 01 Sep 2012 20:51:03 GMT) Full text and rfc822 format available.

Notification sent to Micah Gersten <micahg@ubuntu.com>:
Bug acknowledged by developer. (Sat, 01 Sep 2012 20:51:03 GMT) Full text and rfc822 format available.

Message #10 received at 685963-close@bugs.debian.org (full text, mbox):

From: Youhei SASAKI <uwabami@gfd-dennou.org>
To: 685963-close@bugs.debian.org
Subject: Bug#685963: fixed in ruby-pgplot 0.1.3-6
Date: Sat, 01 Sep 2012 20:49:04 +0000
Source: ruby-pgplot
Source-Version: 0.1.3-6

We believe that the bug you reported is fixed in the latest version of
ruby-pgplot, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 685963@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Youhei SASAKI <uwabami@gfd-dennou.org> (supplier of updated ruby-pgplot package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sun, 02 Sep 2012 04:59:44 +0900
Source: ruby-pgplot
Binary: ruby-pgplot ruby-pgplot-dbg
Architecture: source amd64
Version: 0.1.3-6
Distribution: unstable
Urgency: low
Maintainer: Youhei SASAKI <uwabami@gfd-dennou.org>
Changed-By: Youhei SASAKI <uwabami@gfd-dennou.org>
Description: 
 ruby-pgplot - Ruby interface to the PGPLOT graphics library
 ruby-pgplot-dbg - Ruby-PGPLOT debugging symbols
Closes: 685963
Changes: 
 ruby-pgplot (0.1.3-6) unstable; urgency=low
 .
   * Fix FTBFS: Add gfortran-4.6 into Build-Depends
     (Ruby1.8 is build by gcc-4.6)
     Thanks to Micah Gersten! (Closes: #685963)
   * Add libpng12-dev, libx11-dev into Build-Depends
     for better user support
Checksums-Sha1: 
 aab638c449ad22d1c74628fded5a0782deefd9b5 2165 ruby-pgplot_0.1.3-6.dsc
 b4d9090795a1761392b2e0e31666e19c91f42a74 26484 ruby-pgplot_0.1.3-6.debian.tar.gz
 39415c470a8f5649b7443cc5bb03abf443e1cf55 52092 ruby-pgplot_0.1.3-6_amd64.deb
 d5bb34b04b9378117428367462cea18066e9a20f 64118 ruby-pgplot-dbg_0.1.3-6_amd64.deb
Checksums-Sha256: 
 d3a044a56e2316c6df3ad43d044846bb05ced38daf451831228920c435557fca 2165 ruby-pgplot_0.1.3-6.dsc
 45624a13765c385ab1238565721a7e1968987eef5ebba984d2f4a5f05700b3e1 26484 ruby-pgplot_0.1.3-6.debian.tar.gz
 dee2fc3d7fd50665744da7eb17f401f415858977f3b07821b14a51ed895734a3 52092 ruby-pgplot_0.1.3-6_amd64.deb
 985c2c59b3f04283404d05730c33ccc8ea26c700c4e3328eb47a1b7095eed86b 64118 ruby-pgplot-dbg_0.1.3-6_amd64.deb
Files: 
 d53554bbbcc2749f7520ed78d144b262 2165 contrib/ruby optional ruby-pgplot_0.1.3-6.dsc
 e68601922df058726d0a325c60149215 26484 contrib/ruby optional ruby-pgplot_0.1.3-6.debian.tar.gz
 6c70a58bf2aa3e0bec8f4e1fcb193574 52092 contrib/ruby optional ruby-pgplot_0.1.3-6_amd64.deb
 726c1082f8162eb941aa74f5b8a4228d 64118 contrib/debug extra ruby-pgplot-dbg_0.1.3-6_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCgAGBQJQQmvRAAoJEJOU81SJHX4HtjcQAL6DV4n+g91hKYIahXb74+xP
tQgBnt+AZEJb3ifboM9FL1c3HwScxIMQvvmU8snHe9wbgAXe1xExrCDYp6RT1Q+N
EA6hSXMm8wsPRuUexyVqbpeX0HLTD5qL28DZ0s3H3rz6znVq5Odv9eRPLLx2mFGX
HZz8m3EpL884ppFesPRweQXzmQDmV6mqmrEKemc9zyxsil5DidC3M3rtEh+iHOqx
Dfa7/8/8jOdO4HbniU50pPaJ0L7czyLmfSN5B+Ovm2kBA6rIY4TVuZ1qToKBJcM1
6GFRnH6Gx/hgAfSBC0LkUAm4F1E5iR+wLsM+LAiRd3uB4V0s7YqtnPqm6UA+foEw
LrC3OrZdeFOf/xMyi/bYkkFMPsqvI80gNPBFUYQiGatkLutyqwCLkCXYkNFnLJ23
4ykDP/CMis9e0n0AB+FhehLS3vt7DDPweQ/NnIDQGkggSFOFJBixvAkSqXfpnn84
UJPqy8b7rzVENGF7K/bq9R/mzrOSABsBnfdfqaDwcHAINhwSuaF+1PNhyw+hb+W/
xQONzBnbbpwzv74h2DLwcl7836RwGXFrV3UOiPcWorzeqtU2kEq81thvFCibVAPU
JWzlb3MNQwEzu3HMrPuC4QRChhkHHT1yANx4DEkXtVB5QDmZes752FX4aP8cv9A4
qF0nD6ZdHHhQ0ZlCBtkB
=Am8s
-----END PGP SIGNATURE-----




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 30 Sep 2012 07:30:24 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 20:55:49 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.