Debian Bug report logs - #685243
breaks squeeze-wheezy upgrade into very bad state

version graph

Package: vlc-nox; Maintainer for vlc-nox is Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>; Source for vlc-nox is src:vlc.

Reported by: Daniel Pocock <daniel@pocock.com.au>

Date: Sat, 18 Aug 2012 18:24:01 UTC

Severity: serious

Tags: pending

Merged with 693695

Found in versions vlc/1.1.3-1squeeze6, vlc/2.0.3-4

Fixed in version vlc/2.0.3-5

Done: Benjamin Drung <bdrung@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>:
Bug#685243; Package vlc-nox. (Sat, 18 Aug 2012 18:24:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Pocock <daniel@pocock.com.au>:
New Bug report received and forwarded. Copy sent to Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>. (Sat, 18 Aug 2012 18:24:03 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Daniel Pocock <daniel@pocock.com.au>
To: submit@bugs.debian.org
Subject: breaks squeeze-wheezy upgrade into very bad state
Date: Sat, 18 Aug 2012 18:20:48 +0000
Package: vlc-nox
Version: 1.1.3-1squeeze6
Severity: important


My box is amd64, running squeeze

I started an upgrade to wheezy,

apt-get upgrade

was successful.  Then I ran

apt-get dist-upgrade

and it failed here:

Processing triggers for vlc-nox ...
/usr/lib/vlc/vlc-cache-gen: error while loading shared libraries:
libvlccore.so.5: cannot open shared object file: No such file or directory
dpkg: error processing vlc-nox (--unpack):
 subprocess installed post-installation script returned error exit
status 127
configured to not write apport reports
                                      Errors were encountered while
processing:
 vlc-nox
E: Sub-process /usr/bin/dpkg returned an error code (1)



and now

apt-get -f install

fails

E: Error, pkgProblemResolver::Resolve generated breaks, this may be
caused by held packages.
E: Unable to correct dependencies



# dpkg --list | grep vlc
rc  libvlc0                               0.8.6.h-4+lenny2.3
      multimedia player and streamer library
iU  libvlc5                               2.0.3-1
      multimedia player and streamer library
ii  libvlccore4                           1.1.3-1squeeze6
      base library for VLC and its modules
ii  vlc-data                              1.1.3-1squeeze6
      Common data for VLC
iU  vlc-plugin-notify                     2.0.3-1
      LibNotify plugin for VLC
iU  vlc-plugin-pulse                      2.0.3-1
      PulseAudio plugin for VLC



and full error output:


# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 amarok : Depends: amarok-common (= 2.6~beta1+75.g47e75df-1) but 2.3.1-1
is installed
          Depends: amarok-utils (= 2.6~beta1+75.g47e75df-1) but 2.3.1-1
is installed
          Depends: kde-runtime but it is not installed
          Depends: libavcodec53 (>= 6:0.8.3-4) but it is not installed or
                   libavcodec-extra-53 (>= 6:0.8.3-4) but it is not
installed
          Depends: libavformat53 (>= 6:0.8.3-4) but it is not installed
          Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not installed
          Depends: libkcmutils4 (>= 4:4.7) but it is not installed
          Depends: libkdecore5 (>= 4:4.7) but 4:4.4.5-2+squeeze3 is
installed
          Depends: libkdeui5 (>= 4:4.7) but 4:4.4.5-2+squeeze3 is installed
          Depends: libkdewebkit5 (>= 4:4.7) but it is not installed
          Depends: libkdnssd4 (>= 4:4.7) but 4:4.4.5-2+squeeze3 is installed
          Depends: libkfile4 (>= 4:4.7) but 4:4.4.5-2+squeeze3 is installed
          Depends: libkio5 (>= 4:4.7) but 4:4.4.5-2+squeeze3 is installed
          Depends: libknewstuff3-4 (>= 4:4.7) but 4:4.4.5-2+squeeze3 is
installed
          Depends: libmtp9 (>= 1.1.0) but it is not installed
          Depends: libmysqlclient18 (>= 5.5.24+dfsg-1) but it is not
installed
          Depends: libplasma3 (>= 4:4.7) but 4:4.4.5-2+squeeze3 is installed
          Depends: libqjson0 (>= 0.7.1) but it is not installed
          Depends: libqtcore4 (>= 4:4.8.0) but 4:4.6.3-4+squeeze1 is
installed
          Depends: libqtgui4 (>= 4:4.8.0) but 4:4.6.3-4+squeeze1 is
installed
          Depends: libqtwebkit4 (>= 2.1.0~2011week13) but it is not
installed
          Depends: libsolid4 (>= 4:4.7) but 4:4.4.5-2+squeeze3 is installed
          Depends: libtag1c2a (>= 1.7) but 1.6.3-1 is installed
          Depends: libthreadweaver4 (>= 4:4.7) but 4:4.4.5-2+squeeze3 is
installed
 brasero : Depends: libbrasero-media3-1 (= 3.4.1-2) but it is not installed
           Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not installed
           Depends: libgtk-3-0 (>= 3.0.0) but it is not installed
           Depends: libnautilus-extension1a (>= 2.91) but it is not
installed
           Depends: libtotem-plparser17 (>= 2.32) but 2.30.3-1 is installed
           Depends: libtracker-sparql-0.14-0 (>= 0.10.0) but it is not
installed
 brasero-common : Depends: dconf-gsettings-backend but it is not
installed or
                           gsettings-backend
 consolekit : Depends: libck-connector0 (= 0.4.5-3.1) but 0.4.1-4 is
installed
 eog : Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not installed
       Depends: libgirepository-1.0-1 (>= 0.9.3) but it is not installed
       Depends: libgnome-desktop-3-2 (>= 3.2.0) but it is not installed
       Depends: libgtk-3-0 (>= 3.3.18) but it is not installed
       Depends: libjpeg8 (>= 8c) but it is not installed
       Depends: liblcms2-2 but it is not installed
       Depends: libpeas-1.0-0 (>= 1.0.0) but it is not installed
       Depends: dconf-gsettings-backend but it is not installed or
                gsettings-backend
       Depends: gir1.2-atk-1.0 but it is not installed
       Depends: gir1.2-freedesktop but it is not installed
       Depends: gir1.2-gdkpixbuf-2.0 but it is not installed
       Depends: gir1.2-glib-2.0 but it is not installed
       Depends: gir1.2-gtk-3.0 but it is not installed
       Depends: gir1.2-pango-1.0 but it is not installed
       Depends: gsettings-desktop-schemas (>= 2.91.92) but it is not
installed
       Depends: gir1.2-peas-1.0 but it is not installed
 evince : Depends: libevdocument3-4 (= 3.4.0-2+b1) but it is not installed
          Depends: libevview3-3 (= 3.4.0-2+b1) but it is not installed
          Depends: libgail-3-0 (>= 3.0.0) but it is not installed
          Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not installed
          Depends: libgtk-3-0 (>= 3.0.2) but it is not installed
          Depends: libnautilus-extension1a (>= 2.91) but it is not installed
          Depends: evince-common (>= 3.4) but 2.30.3-2+squeeze1 is installed
 file-roller : Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not
installed
               Depends: libgtk-3-0 (>= 3.0.2) but it is not installed
               Depends: libnautilus-extension1a (>= 2.91) but it is not
installed
               Depends: dconf-gsettings-backend but it is not installed or
                        gsettings-backend
               Depends: nautilus-data (>= 3.0) but 2.30.1-2squeeze1 is
installed
 foo2zjs : Depends: printer-driver-foo2zjs but it is not installed
 gnome-applets : Depends: gconf-service but it is not installed
                 Depends: libgconf-2-4 (>= 2.31.1) but it is not installed
                 Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not
installed
                 Depends: libgtk-3-0 (>= 3.0.0) but it is not installed
                 Depends: libgucharmap-2-90-7 (>= 1:3.0.0) but it is not
installed
                 Depends: libgweather-3-0 (>= 3.0.0) but it is not installed
                 Depends: libnotify4 (>= 0.7.0) but it is not installed
                 Depends: libpanel-applet-4-0 (>= 3.2.1) but it is not
installed
                 Depends: libwnck-3-0 (>= 2.91.6) but it is not installed
                 Depends: gnome-applets-data (>= 3.4) but 2.30.0-3 is
installed
                 Depends: python-gi but it is not installed
                 Depends: gir1.2-gtk-3.0 but it is not installed
                 Depends: gir1.2-gdkpixbuf-2.0 but it is not installed
                 Depends: gir1.2-gconf-2.0 but it is not installed
                 Depends: gir1.2-panelapplet-4.0 but it is not installed
 gnome-bluetooth : Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not
installed
                   Depends: libgnome-bluetooth10 (>= 3.4.0) but it is
not installed
                   Depends: libgtk-3-0 (>= 3.0.0) but it is not installed
                   Depends: libnotify4 (>= 0.7.0) but it is not installed
                   Depends: dconf-gsettings-backend but it is not
installed or
                            gsettings-backend
                   Depends: gir1.2-atk-1.0 but it is not installed
                   Depends: gir1.2-freedesktop but it is not installed
                   Depends: gir1.2-gdkpixbuf-2.0 but it is not installed
                   Depends: gir1.2-glib-2.0 but it is not installed
                   Depends: gir1.2-gnomebluetooth-1.0 (= 3.4.2-1) but it
is not installed
                   Depends: gir1.2-gtk-3.0 but it is not installed
                   Depends: gir1.2-pango-1.0 but it is not installed
 gnome-control-center : Depends: libcanberra-gtk3-0 (>= 0.25) but it is
not installed
                        Depends: libcheese-gtk21 (>= 3.4.0) but it is
not installed
                        Depends: libcheese3 (>= 3.0.1) but it is not
installed
                        Depends: libclutter-1.0-0 (>= 1.10.0) but
1.2.12-3 is installed
                        Depends: libcogl-pango0 (>= 1.7.4) but it is not
installed
                        Depends: libcogl9 (>= 1.7.4) but it is not installed
                        Depends: libcolord1 (>= 0.1.13) but it is not
installed
                        Depends: libgdk-pixbuf2.0-0 (>= 2.23.0) but it
is not installed
                        Depends: libgnome-bluetooth10 (>= 3.4.0) but it
is not installed
                        Depends: libgnome-desktop-3-2 (>= 3.2.0) but it
is not installed
                        Depends: libgnome-menu-3-0 (>= 3.2.0.1) but it
is not installed
                        Depends: libgnomekbd7 (>= 2.91.91) but it is not
installed
                        Depends: libgnutls26 (>= 2.12.17-0) but
2.8.6-1+squeeze2 is installed
                        Depends: libgoa-1.0-0 (>= 3.1.1) but it is not
installed
                        Depends: libgtk-3-0 (>= 3.3.16) but it is not
installed
                        Depends: libjson-glib-1.0-0 (>= 0.12.0) but
0.10.2-2squeeze1 is installed
                        Depends: libnm-glib4 (>= 0.8.998) but it is not
installed
                        Depends: libnm-gtk0 (>= 0.9.1.95) but it is not
installed
                        Depends: libnm-util2 (>= 0.8.998) but it is not
installed
                        Depends: libnotify4 (>= 0.7.3) but it is not
installed
                        Depends: libpolkit-gobject-1-0 (>= 0.99) but
0.96-4+squeeze2 is installed
                        Depends: libpulse-mainloop-glib0 (>= 0.99.1) but
0.9.21-3+squeeze1 is installed
                        Depends: libpulse0 (>= 0.99.1) but
0.9.21-3+squeeze1 is installed
                        Depends: libsocialweb-client2 (>= 0.25.3) but it
is not installed
                        Depends: libwacom2 (>= 0.3) but it is not installed
                        Depends: accountsservice but it is not installed
                        Depends: apg but it is not installed
                        Depends: gnome-control-center-data (< 1:3.5) but
it is not installed
                        Depends: gnome-control-center-data (>=
1:3.4.2-2) but it is not installed
                        Depends: gnome-desktop3-data but it is not installed
                        Depends: gnome-icon-theme-symbolic but it is not
installed
                        Depends: gnome-menus (>= 3.0) but 2.30.3-1 is
installed
                        Depends: gsettings-desktop-schemas (>= 3.3.0)
but it is not installed
                        Recommends: gnome-online-accounts but it is not
installed
                        Recommends: mousetweaks but it is not installed
 gnome-dictionary : Depends: libgdict-1.0-6 (= 3.4.0-2) but 2.30.0-2 is
installed
                    Depends: libgtk-3-0 (>= 3.0.0) but it is not installed
                    Depends: dconf-gsettings-backend but it is not
installed or
                             gsettings-backend
 gnome-disk-utility : Depends: libavahi-ui-gtk3-0 (>= 0.6.30) but it is
not installed
                      Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is
not installed
                      Depends: libgdu-gtk0 (>= 3.0.0) but 2.30.1-2 is
installed
                      Depends: libgtk-3-0 (>= 3.0.0) but it is not installed
                      Depends: libnautilus-extension1a (>= 2.91) but it
is not installed
                      Depends: libnotify4 (>= 0.7.0) but it is not installed
                      Depends: libunique-3.0-0 (>= 2.90.1) but it is not
installed
 gnome-icon-theme : Depends: libgtk-3-bin but it is not installed
 gnome-panel : Depends: gconf-service but it is not installed
               Depends: libdconf0 (>= 0.7) but it is not installed
               Depends: libebook-1.2-13 (>= 3.4.3) but it is not installed
               Depends: libecal-1.2-11 (>= 3.4.3) but it is not installed
               Depends: libedataserver-1.2-16 (>= 3.4.3) but it is not
installed
               Depends: libedataserverui-3.0-1 (>= 3.4.3) but it is not
installed
               Depends: libgconf-2-4 (>= 2.31.1) but it is not installed
               Depends: libgdk-pixbuf2.0-0 (>= 2.25.2) but it is not
installed
               Depends: libgnome-desktop-3-2 (>= 3.2.0) but it is not
installed
               Depends: libgnome-menu-3-0 (>= 3.2.0.1) but it is not
installed
               Depends: libgtk-3-0 (>= 3.3.16) but it is not installed
               Depends: libgweather-3-0 (>= 3.0.0) but it is not installed
               Depends: libpanel-applet-4-0 (>= 3.4.1) but it is not
installed
               Depends: librsvg2-2 (>= 2.32.0) but 2.26.3-1 is installed
               Depends: libtelepathy-glib0 (>= 0.14.0) but 0.11.11-1 is
installed
               Depends: libwnck-3-0 (>= 2.91.6) but it is not installed
               Depends: gnome-icon-theme-symbolic (>= 3.0.0) but it is
not installed
               Depends: gnome-panel-data (= 3.4.2.1-2) but 2.30.2-2 is
installed
               Depends: gnome-menus (>= 3.1.4) but 2.30.3-1 is installed
               Recommends: gnome-session-fallback but it is not installed
 gnome-power-manager : Depends: libgtk-3-0 (>= 3.3.16) but it is not
installed
                       Depends: dconf-gsettings-backend but it is not
installed or
                                gsettings-backend
 gnome-session : Depends: gnome-shell (>= 3.0) but it is not installed
                 Depends: gnome-session-bin (>= 3.4.2.1-1) but 2.30.2-3
is installed
                 Recommends: gnome-session-fallback but it is not installed
 gnome-settings-daemon : Depends: libcanberra-gtk3-0 (>= 0.25) but it is
not installed
                         Depends: libcolord1 (>= 0.1.12) but it is not
installed
                         Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it
is not installed
                         Depends: libgnome-desktop-3-2 (>= 3.4.0) but it
is not installed
                         Depends: libgnomekbd7 (>= 2.91.90) but it is
not installed
                         Depends: libgnutls26 (>= 2.12.17-0) but
2.8.6-1+squeeze2 is installed
                         Depends: libgtk-3-0 (>= 3.3.18) but it is not
installed
                         Depends: liblcms2-2 but it is not installed
                         Depends: libnotify4 (>= 0.7.3) but it is not
installed
                         Depends: libpackagekit-glib2-14 but it is not
installed
                         Depends: libpolkit-gobject-1-0 (>= 0.99) but
0.96-4+squeeze2 is installed
                         Depends: libpulse-mainloop-glib0 (>= 0.99.1)
but 0.9.21-3+squeeze1 is installed
                         Depends: libpulse0 (>= 0.99.1) but
0.9.21-3+squeeze1 is installed
                         Depends: libwacom2 (>= 0.3) but it is not installed
                         Depends: dconf-gsettings-backend but it is not
installed or
                                  gsettings-backend
                         Depends: gsettings-desktop-schemas (>= 3.3.0)
but it is not installed
                         Depends: nautilus-data (>= 2.91.3-1) but
2.30.1-2squeeze1 is installed
 gnome-user-share : Depends: gconf-service but it is not installed
                    Depends: libcanberra-gtk3-0 (>= 0.25) but it is not
installed
                    Depends: libgconf-2-4 (>= 2.31.1) but it is not
installed
                    Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is
not installed
                    Depends: libgnome-bluetooth10 (>= 2.91.2) but it is
not installed
                    Depends: libgtk-3-0 (>= 3.0.0) but it is not installed
                    Depends: libnautilus-extension1a (>= 2.91) but it is
not installed
                    Depends: libnotify4 (>= 0.7.0) but it is not installed
 grub2-common : Depends: grub-common (= 1.99-22.1) but
1.98+20100804-14+squeeze1 is installed
 gthumb : Depends: libexiv2-12 but it is not installed
          Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not installed
          Depends: libgnome-keyring0 (>= 3.2.0) but 2.30.1-1 is installed
          Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but
0.10.30-1 is installed
          Depends: libgtk-3-0 (>= 3.2.0) but it is not installed
          Depends: libjpeg8 (>= 8c) but it is not installed
          Depends: librsvg2-2 (>= 2.34.0) but 2.26.3-1 is installed
          Depends: libsoup-gnome2.4-1 (>= 2.36) but 2.30.2-1+squeeze1 is
installed
          Depends: libtiff4 (> 3.9.5-3~) but 3.9.4-5+squeeze4 is installed
          Depends: gsettings-desktop-schemas but it is not installed
          Recommends: flex but it is not installed
 gthumb-data : Depends: dconf-gsettings-backend but it is not installed or
                        gsettings-backend
 gvfs : Depends: gvfs-daemons (>= 1.12.3-1) but it is not installed
        Depends: gvfs-daemons (< 1.12.3-1.1~) but it is not installed
        Depends: gvfs-libs (= 1.12.3-1+b1) but it is not installed
        Depends: gvfs-common (= 1.12.3-1) but it is not installed
 gvfs-backends : Depends: libarchive12 but it is not installed
                 Depends: libbluetooth3 (>= 4.91) but 4.66-3 is installed
                 Depends: libcdio-cdda1 (>= 0.83) but it is not installed
                 Depends: libcdio-paranoia1 (>= 0.83) but it is not
installed
                 Depends: libcdio13 (>= 0.83) but it is not installed
                 Depends: libgphoto2-2 (>= 2.4.10.1) but 2.4.6-3 is
installed
                 Depends: libgphoto2-port0 (>= 2.4.10.1) but 2.4.6-3 is
installed
                 Depends: libimobiledevice2 (>= 1.1.0) but it is not
installed
                 Depends: dconf-gsettings-backend but it is not installed or
                          gsettings-backend
                 Depends: gvfs-daemons (= 1.12.3-1+b1) but it is not
installed
                 Depends: gvfs-libs (= 1.12.3-1+b1) but it is not installed
                 Depends: gvfs-common (= 1.12.3-1) but it is not installed
 gvfs-bin : Depends: gvfs-common (= 1.12.3-1) but it is not installed
 hamster-applet : Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is
installed
                  Depends: python-gobject-2 (>= 2.14.0) but it is not
installed
 libgnome2-0 : Depends: libgconf2-4 (>= 2.31.1) but 2.28.1-6 is installed
 libgnutlsxx27 : Depends: libgnutls26 (= 2.12.20-1) but 2.8.6-1+squeeze2
is installed
 libvlc5 : Depends: libvlccore5 (>= 2.0.0) but it is not installed
 nautilus : Depends: libgail-3-0 (>= 3.0.0) but it is not installed
            Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not installed
            Depends: libgnome-desktop-3-2 (>= 3.2.0) but it is not installed
            Depends: libgtk-3-0 (>= 3.3.18) but it is not installed
            Depends: libnautilus-extension1a (>= 2.91) but it is not
installed
            Depends: libnotify4 (>= 0.7.0) but it is not installed
            Depends: libtracker-sparql-0.14-0 (>= 0.10.0) but it is not
installed
            Depends: nautilus-data (>= 3.4) but 2.30.1-2squeeze1 is
installed
            Depends: gsettings-desktop-schemas but it is not installed
            Recommends: gnome-sushi but it is not installed
 nautilus-sendto : Depends: libebook-1.2-13 (>= 3.4.3) but it is not
installed
                   Depends: libedataserver-1.2-16 (>= 3.4.3) but it is
not installed
                   Depends: libedataserverui-3.0-1 (>= 3.4.3) but it is
not installed
                   Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not
installed
                   Depends: libgssdp-1.0-3 (>= 0.12.0) but it is not
installed
                   Depends: libgtk-3-0 (>= 3.0.0) but it is not installed
                   Depends: libgupnp-1.0-4 (>= 0.18.0) but it is not
installed
                   Depends: dconf-gsettings-backend but it is not
installed or
                            gsettings-backend
 nautilus-sendto-empathy : Depends: gconf-service but it is not installed
                           Depends: libcanberra-gtk3-0 (>= 0.25) but it
is not installed
                           Depends: libchamplain-0.12-0 (>= 0.11.0) but
it is not installed
                           Depends: libchamplain-gtk-0.12-0 (>= 0.11.0)
but it is not installed
                           Depends: libcheese-gtk21 (>= 3.0.1) but it is
not installed
                           Depends: libclutter-1.0-0 (>= 1.10.0) but
1.2.12-3 is installed
                           Depends: libclutter-gtk-1.0-0 (>= 0.91.8) but
it is not installed
                           Depends: libcogl-pango0 (>= 1.7.4) but it is
not installed
                           Depends: libcogl9 (>= 1.7.4) but it is not
installed
                           Depends: libebook-1.2-13 (>= 3.4.3) but it is
not installed
                           Depends: libedataserver-1.2-16 (>= 3.4.3) but
it is not installed
                           Depends: libfolks-telepathy25 (>= 0.6.6) but
it is not installed
                           Depends: libfolks25 (>= 0.6.2) but it is not
installed
                           Depends: libgck-1-0 (>= 2.91.1) but it is not
installed
                           Depends: libgconf-2-4 (>= 2.31.1) but it is
not installed
                           Depends: libgcr-3-1 (>= 3.4.0) but it is not
installed
                           Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but
it is not installed
                           Depends: libgeocode-glib0 (>= 0.99.0) but it
is not installed
                           Depends: libgnome-keyring0 (>= 3.2.2-2~) but
2.30.1-1 is installed
                           Depends: libgnutls26 (>= 2.12.17-0) but
2.8.6-1+squeeze2 is installed
                           Depends: libgoa-1.0-0 (>= 3.3.0) but it is
not installed
                           Depends: libgstreamer0.10-0 (>= 0.10.32) but
0.10.30-1 is installed
                           Depends: libgtk-3-0 (>= 3.3.6) but it is not
installed
                           Depends: libjavascriptcoregtk-3.0-0 (>=
1.5.1) but it is not installed
                           Depends: libjson-glib-1.0-0 (>= 0.12.0) but
0.10.2-2squeeze1 is installed
                           Depends: libmission-control-plugins0 (>=
5.5.0~) but it is not installed
                           Depends: libnm-glib4 (>= 0.7.999) but it is
not installed
                           Depends: libnotify4 (>= 0.7.0) but it is not
installed
                           Depends: libpulse-mainloop-glib0 (>= 0.99.1)
but 0.9.21-3+squeeze1 is installed
                           Depends: libpulse0 (>= 0.99.1) but
0.9.21-3+squeeze1 is installed
                           Depends: libtelepathy-glib0 (>= 0.18.0) but
0.11.11-1 is installed
                           Depends: libtelepathy-logger2 (>= 0.2.10) but
it is not installed
                           Depends: libwebkitgtk-3.0-0 (>= 1.3.10) but
it is not installed
                           Depends: empathy-common (= 3.4.2.3-1) but
2.30.3-1 is installed
 rhythmbox : Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not installed
             Depends: libgirepository-1.0-1 (>= 0.9.2) but it is not
installed
             Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.32) but
0.10.30-1 is installed
             Depends: libgstreamer0.10-0 (>= 0.10.32) but 0.10.30-1 is
installed
             Depends: libgtk-3-0 (>= 3.2.0) but it is not installed
             Depends: libjson-glib-1.0-0 (>= 0.12.0) but
0.10.2-2squeeze1 is installed
             Depends: libpeas-1.0-0 (>= 1.0.0) but it is not installed
             Depends: librhythmbox-core6 (= 2.97-2.1) but it is not
installed
             Depends: libtotem-plparser17 (>= 2.32.1) but 2.30.3-1 is
installed
             Depends: rhythmbox-data (= 2.97-2.1) but it is not installed
 rhythmbox-plugin-cdrecorder : Depends: libbrasero-media3-1 (>= 3.0.0)
but it is not installed
                               Depends: libgdk-pixbuf2.0-0 (>= 2.22.0)
but it is not installed
                               Depends: libgtk-3-0 (>= 3.2.0) but it is
not installed
                               Depends: librhythmbox-core6 (>= 2.97) but
it is not installed
 rhythmbox-plugins : Depends: gconf-service but it is not installed
                     Depends: libclutter-1.0-0 (>= 1.10.0) but 1.2.12-3
is installed
                     Depends: libclutter-gst-1.0-0 (>= 0.10.0) but it is
not installed
                     Depends: libclutter-gtk-1.0-0 (>= 1.0) but it is
not installed
                     Depends: libcogl-pango0 (>= 1.7.4) but it is not
installed
                     Depends: libcogl9 (>= 1.7.4) but it is not installed
                     Depends: libdmapsharing-3.0-2 (>= 2.9.12) but it is
not installed
                     Depends: libgconf-2-4 (>= 2.31.1) but it is not
installed
                     Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is
not installed
                     Depends: libgirepository-1.0-1 (>= 0.9.2) but it is
not installed
                     Depends: libgrilo-0.1-0 (>= 0.1.19-1) but it is not
installed
                     Depends: libgstreamer-plugins-base0.10-0 (>=
0.10.32) but 0.10.30-1 is installed
                     Depends: libgstreamer0.10-0 (>= 0.10.32) but
0.10.30-1 is installed
                     Depends: libgtk-3-0 (>= 3.2.0) but it is not installed
                     Depends: libimobiledevice2 (>= 0.9.7) but it is not
installed
                     Depends: libjson-glib-1.0-0 (>= 0.12.0) but
0.10.2-2squeeze1 is installed
                     Depends: libmtp9 (>= 1.1.0) but it is not installed
                     Depends: libmusicbrainz5-0 but it is not installed
                     Depends: libmx-1.0-2 (>= 1.2.0) but it is not installed
                     Depends: libnotify4 (>= 0.7.0) but it is not installed
                     Depends: libpeas-1.0-0 (>= 1.0.0) but it is not
installed
                     Depends: librhythmbox-core6 (= 2.97-2.1) but it is
not installed
                     Depends: libtotem-plparser17 (>= 2.32.1) but
2.30.3-1 is installed
                     Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7
is installed
                     Depends: python2.7 but it is not installed
                     Depends: gir1.2-rb-3.0 (= 2.97-2.1) but it is not
installed
                     Depends: gir1.2-glib-2.0 but it is not installed
                     Depends: gir1.2-gtk-3.0 but it is not installed
                     Depends: gir1.2-webkit-3.0 but it is not installed
                     Depends: gir1.2-gconf-2.0 but it is not installed
                     Depends: gir1.2-peas-1.0 but it is not installed
                     Depends: gir1.2-gnomekeyring-1.0 but it is not
installed
                     Depends: gir1.2-gstreamer-0.10 but it is not installed
                     Depends: python-gi but it is not installed
                     Depends: zeitgeist-core but it is not installed
 tomboy : Depends: mono-runtime (>= 2.10.1) but 2.6.7-5.1 is installed
          Depends: libdbus-glib1.0-cil (>= 0.5) but it is not installed
          Depends: libdbus1.0-cil (>= 0.7) but it is not installed
          Depends: libgmime2.6-cil (>= 2.6.0) but it is not installed
          Depends: libgtk2.0-0 (>= 2.24.0) but 2.20.1-2 is installed
          Depends: libmono-addins-gui0.2-cil (>= 0.6) but 0.4-8 is installed
          Depends: libmono-addins0.2-cil (>= 0.6) but 0.4-8 is installed
          Depends: libmono-cairo4.0-cil (>= 2.10.1) but it is not installed
          Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not installed
          Depends: libmono-posix4.0-cil (>= 2.10.1) but it is not installed
          Depends: libmono-system-core4.0-cil (>= 2.10.3) but it is not
installed
          Depends: libmono-system-xml4.0-cil (>= 1.0) but it is not
installed
          Depends: libmono-system4.0-cil (>= 2.10.7) but it is not installed
          Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not installed
 totem : Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not installed
         Depends: libgirepository-1.0-1 (>= 0.9.2) but it is not installed
         Depends: libgtk-3-0 (>= 3.0.0) but it is not installed
         Depends: libnautilus-extension1a (>= 2.91) but it is not installed
         Depends: libpeas-1.0-0 (>= 1.0.0) but it is not installed
         Depends: libtotem-plparser17 (>= 2.32.4-2) but 2.30.3-1 is
installed
         Depends: libtotem0 (>= 3.0.1-8) but it is not installed
         Depends: libtotem0 (< 3.1) but it is not installed
         Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is installed
         Depends: gnome-icon-theme-symbolic but it is not installed
         Depends: totem-common (= 3.0.1-8) but 2.30.2-6 is installed
 totem-plugins : Depends: libbluetooth3 (>= 4.91) but 4.66-3 is installed
                 Depends: libepc-1.0-3 (>= 0.4.2) but it is not installed
                 Depends: libepc-ui-1.0-3 (>= 0.4.2) but it is not installed
                 Depends: libgdata13 (>= 0.8.1) but it is not installed
                 Depends: libgdk-pixbuf2.0-0 (>= 2.23.0) but it is not
installed
                 Depends: libgnutls26 (>= 2.12.17-0) but
2.8.6-1+squeeze2 is installed
                 Depends: libgtk-3-0 (>= 3.0.0) but it is not installed
                 Depends: libtotem-plparser17 (>= 2.32.4-2) but 2.30.3-1
is installed
                 Depends: libtotem0 (>= 3.0.1-8) but it is not installed
                 Depends: libtotem0 (< 3.1) but it is not installed
                 Depends: libtracker-sparql-0.14-0 (>= 0.10.0) but it is
not installed
                 Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is
installed
                 Depends: python2.7 but it is not installed
                 Depends: gir1.2-totem-1.0 (= 3.0.1-8) but it is not
installed
                 Depends: gir1.2-gtk-3.0 but it is not installed
                 Depends: gir1.2-gdkpixbuf-2.0 but it is not installed
                 Depends: gir1.2-glib-2.0 but it is not installed
                 Depends: gir1.2-pango-1.0 but it is not installed
                 Depends: gir1.2-peas-1.0 but it is not installed
                 Depends: python-gi (>= 2.90.3) but it is not installed
 vlc-plugin-notify : Depends: vlc-nox (= 2.0.3-1) but it is not installed
                     Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is
not installed
                     Depends: libnotify4 (>= 0.7.0) but it is not installed
                     Depends: libvlccore5 (>= 2.0.0) but it is not installed
 vlc-plugin-pulse : Depends: vlc-nox (= 2.0.3-1) but it is not installed
                    Depends: libpulse0 (>= 0.99.4) but 0.9.21-3+squeeze1
is installed
                    Depends: libvlccore5 (>= 2.0.0) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be
caused by held packages.
E: Unable to correct dependencies



Information forwarded to debian-bugs-dist@lists.debian.org, Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>:
Bug#685243; Package vlc-nox. (Sat, 18 Aug 2012 21:21:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Benjamin Drung <bdrung@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>. (Sat, 18 Aug 2012 21:21:05 GMT) Full text and rfc822 format available.

Message #10 received at 685243@bugs.debian.org (full text, mbox):

From: Benjamin Drung <bdrung@debian.org>
To: Daniel Pocock <daniel@pocock.com.au>, 685243@bugs.debian.org
Subject: Re: Bug#685243: breaks squeeze-wheezy upgrade into very bad state
Date: Sat, 18 Aug 2012 23:17:44 +0200
[Message part 1 (text/plain, inline)]
Am Samstag, den 18.08.2012, 18:20 +0000 schrieb Daniel Pocock:
> Package: vlc-nox
> Version: 1.1.3-1squeeze6
> Severity: important
> 
> 
> My box is amd64, running squeeze
> 
> I started an upgrade to wheezy,
> 
> apt-get upgrade
> 
> was successful.  Then I ran
> 
> apt-get dist-upgrade
> 
> and it failed here:
> 
> Processing triggers for vlc-nox ...
> /usr/lib/vlc/vlc-cache-gen: error while loading shared libraries:
> libvlccore.so.5: cannot open shared object file: No such file or directory
> dpkg: error processing vlc-nox (--unpack):
>  subprocess installed post-installation script returned error exit
> status 127
> configured to not write apport reports
>                                       Errors were encountered while
> processing:
>  vlc-nox
> E: Sub-process /usr/bin/dpkg returned an error code (1)

vlc-cache-gen was run in postinst prior to 2.0.0-1. I dunno, why it is
still called.

-- 
Benjamin Drung
Debian & Ubuntu Developer
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>:
Bug#685243; Package vlc-nox. (Sun, 23 Sep 2012 14:27:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to intrigeri <intrigeri@boum.org>:
Extra info received and forwarded to list. Copy sent to Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>. (Sun, 23 Sep 2012 14:27:03 GMT) Full text and rfc822 format available.

Message #15 received at 685243@bugs.debian.org (full text, mbox):

From: intrigeri <intrigeri@boum.org>
To: Benjamin Drung <bdrung@debian.org>
Cc: 685243@bugs.debian.org, Daniel Pocock <daniel@pocock.com.au>
Subject: Re: Bug#685243: breaks squeeze-wheezy upgrade into very bad state
Date: Sun, 23 Sep 2012 16:22:32 +0200
Hi,

Benjamin Drung wrote (18 Aug 2012 21:17:44 GMT) :
>> [...]
>> and it failed here:
>> 
>> Processing triggers for vlc-nox ...
>> /usr/lib/vlc/vlc-cache-gen: error while loading shared libraries:
>> libvlccore.so.5: cannot open shared object file: No such file or directory
>> dpkg: error processing vlc-nox (--unpack):
>>  subprocess installed post-installation script returned error exit
>> status 127
>> configured to not write apport reports
>>                                       Errors were encountered while
>> processing:
>>  vlc-nox
>> E: Sub-process /usr/bin/dpkg returned an error code (1)

I just reproduced this.

I confirm the upgrade process is left is a deeply broken state, which
"apt-get -f install" and "dpkg --configure -a" are unable to resolve.
I had to manually "dpkg -i" a few dozen packages in the right order
before apt-get could get back to a working state.

> vlc-cache-gen was run in postinst prior to 2.0.0-1. I dunno, why it
> is still called.

I had a look, immediately after seeing apt-get/dpkg aborted by this
error, to the installed vlc-nox's postinst: this file was still
present, and it did contain a call to vlc-cache-gen.

It looks to me as if the file trigger set by vlc-nox on
/usr/lib/vlc/plugins made the old vlc-nox.postinst run *before*
vlc-nox is upgraded (and before that old postinst is removed).

Regards,
--
  intrigeri
  | GnuPG key @ https://gaffer.ptitcanardnoir.org/intrigeri/intrigeri.asc
  | OTR fingerprint @ https://gaffer.ptitcanardnoir.org/intrigeri/otr.asc



Merged 685243 693695 Request was from Timo Juhani Lindfors <timo.lindfors@iki.fi> to control@bugs.debian.org. (Mon, 19 Nov 2012 13:12:04 GMT) Full text and rfc822 format available.

Severity set to 'serious' from 'important' Request was from intrigeri@debian.org to control@bugs.debian.org. (Mon, 19 Nov 2012 14:00:03 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>:
Bug#685243; Package vlc-nox. (Sun, 30 Dec 2012 11:27:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to intrigeri <intrigeri@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>. (Sun, 30 Dec 2012 11:27:09 GMT) Full text and rfc822 format available.

Message #24 received at 685243@bugs.debian.org (full text, mbox):

From: intrigeri <intrigeri@debian.org>
To: Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
Cc: 685243@bugs.debian.org
Subject: Re: Bug#685243: breaks squeeze-wheezy upgrade into very bad state
Date: Sun, 30 Dec 2012 12:25:08 +0100
Hi VLC maintainers,

intrigeri wrote (23 Sep 2012 14:22:32 GMT) :
> I confirm the upgrade process is left is a deeply broken state, which
> "apt-get -f install" and "dpkg --configure -a" are unable to resolve.
> I had to manually "dpkg -i" a few dozen packages in the right order
> before apt-get could get back to a working state.

>> vlc-cache-gen was run in postinst prior to 2.0.0-1. I dunno, why it
>> is still called.

> I had a look, immediately after seeing apt-get/dpkg aborted by this
> error, to the installed vlc-nox's postinst: this file was still
> present, and it did contain a call to vlc-cache-gen.

> It looks to me as if the file trigger set by vlc-nox on
> /usr/lib/vlc/plugins made the old vlc-nox.postinst run *before*
> vlc-nox is upgraded (and before that old postinst is removed).

What are your plans to fix this bug in time for the Wheezy release?

If you don't think you'll manage to do it yourselves, I'm sure this is
no big issue, but then you may want to tag the bug "help" so that the
situation is made clear, and so that people working on RC bugs can
prioritize this one :)

Cheers,
--
  intrigeri
  | GnuPG key @ https://gaffer.ptitcanardnoir.org/intrigeri/intrigeri.asc
  | OTR fingerprint @ https://gaffer.ptitcanardnoir.org/intrigeri/otr.asc



Information forwarded to debian-bugs-dist@lists.debian.org, Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>:
Bug#685243; Package vlc-nox. (Tue, 01 Jan 2013 14:21:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julien Cristau <jcristau@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>. (Tue, 01 Jan 2013 14:21:05 GMT) Full text and rfc822 format available.

Message #29 received at 685243@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: Daniel Pocock <daniel@pocock.com.au>, 685243@bugs.debian.org
Cc: 671711@bugs.debian.org
Subject: Re: Bug#685243: vlc: breaks squeeze-wheezy upgrade into very bad state
Date: Tue, 1 Jan 2013 15:19:24 +0100
[Message part 1 (text/plain, inline)]
On Sat, Aug 18, 2012 at 18:20:48 +0000, Daniel Pocock wrote:

> Package: vlc-nox
> Version: 1.1.3-1squeeze6
> Severity: important
> 
> 
> My box is amd64, running squeeze
> 
> I started an upgrade to wheezy,
> 
> apt-get upgrade
> 
> was successful.  Then I ran
> 
> apt-get dist-upgrade
> 
> and it failed here:
> 
> Processing triggers for vlc-nox ...
> /usr/lib/vlc/vlc-cache-gen: error while loading shared libraries:
> libvlccore.so.5: cannot open shared object file: No such file or directory
> dpkg: error processing vlc-nox (--unpack):
>  subprocess installed post-installation script returned error exit
> status 127
> configured to not write apport reports
>                                       Errors were encountered while
> processing:
>  vlc-nox
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> 
Please provide the full upgrade log and contents of /var/lib/dpkg/status
before and after the upgrade.

I suspect this is yet another case of dpkg triggering unconfigured
packages (#671711).  Which dpkg maintainers don't plan on fixing, and
recommend working around in other packages.  Except I'm not aware of any
work-around having been suggested.

Cheers,
Julien
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>:
Bug#685243; Package vlc-nox. (Tue, 12 Feb 2013 21:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Petter Reinholdtsen <pere@hungry.com>:
Extra info received and forwarded to list. Copy sent to Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>. (Tue, 12 Feb 2013 21:51:03 GMT) Full text and rfc822 format available.

Message #34 received at 685243@bugs.debian.org (full text, mbox):

From: Petter Reinholdtsen <pere@hungry.com>
To: 685243@bugs.debian.org
Cc: Holger Levsen <holger@layer-acht.org>
Subject: vlc-nox: breaks squeeze-wheezy upgrade into very bad state
Date: Tue, 12 Feb 2013 22:47:48 +0100
This problem is also seen in the chroot upgrade testing for a full
desktop installation, see
<URL: http://jenkins.debian.net/job/chroot-installation_squeeze_install_full_desktop_upgrade_to_wheezy/79/parsed_console >:

[...]
 atd: stopping...starting...done.

 Services restarted successfully.

 (Reading database ... 273029 files and directories currently installed.)
 Preparing to replace libck-connector0 0.4.1-4 (using .../libck-connector0_0.4.5-3.1_amd64.deb) ...
 Unpacking replacement libck-connector0:amd64 ...
 Preparing to replace consolekit 0.4.1-4 (using .../consolekit_0.4.5-3.1_amd64.deb) ...
 Unpacking replacement consolekit ...
 Preparing to replace vlc-plugin-notify 1.1.3-1squeeze6 (using .../vlc-plugin-notify_2.0.3-4_amd64.deb) ...
 Unpacking replacement vlc-plugin-notify ...
 Preparing to replace vlc-plugin-pulse 1.1.3-1squeeze6 (using .../vlc-plugin-pulse_2.0.3-4_amd64.deb) ...
 Unpacking replacement vlc-plugin-pulse ...
 Preparing to replace libvlc5 1.1.3-1squeeze6 (using .../libvlc5_2.0.3-4_amd64.deb) ...
 Unpacking replacement libvlc5 ...
 Processing triggers for vlc-nox ...
 /usr/lib/vlc/vlc-cache-gen: error while loading shared libraries: libvlccore.so.5: cannot open shared object file: No such file or directory
 dpkg: error processing vlc-nox (--unpack):
 subprocess installed post-installation script returned error exit status 127
 configured to not write apport reports
 Errors were encountered while processing:
 vlc-nox
 E: Sub-process /usr/bin/dpkg returned an error code (1)

<URL: http://bugs.debian.org/678848 > describe a workaround using
Breaks.  Perhaps it could be used here too?

-- 
Happy hacking
Petter Reinholdtsen



Information forwarded to debian-bugs-dist@lists.debian.org, Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>:
Bug#685243; Package vlc-nox. (Tue, 12 Feb 2013 23:21:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Benjamin Drung <bdrung@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>. (Tue, 12 Feb 2013 23:21:04 GMT) Full text and rfc822 format available.

Message #39 received at 685243@bugs.debian.org (full text, mbox):

From: Benjamin Drung <bdrung@debian.org>
To: Petter Reinholdtsen <pere@hungry.com>, 685243@bugs.debian.org
Cc: Holger Levsen <holger@layer-acht.org>
Subject: Re: Bug#685243: vlc-nox: breaks squeeze-wheezy upgrade into very bad state
Date: Wed, 13 Feb 2013 00:16:14 +0100
[Message part 1 (text/plain, inline)]
Am Dienstag, den 12.02.2013, 22:47 +0100 schrieb Petter Reinholdtsen:
> This problem is also seen in the chroot upgrade testing for a full
>
> [...]
>
> <URL: http://bugs.debian.org/678848 > describe a workaround using
> Breaks.  Perhaps it could be used here too?

Please test the attached patch if it really works around the bug.

-- 
Benjamin Drung
Debian & Ubuntu Developer
[proposed-fix-for-685243.patch (text/x-patch, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>:
Bug#685243; Package vlc-nox. (Sun, 03 Mar 2013 09:57:14 GMT) Full text and rfc822 format available.

Acknowledgement sent to Reinhard Tartler <siretart@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>. (Sun, 03 Mar 2013 09:57:14 GMT) Full text and rfc822 format available.

Message #44 received at 685243@bugs.debian.org (full text, mbox):

From: Reinhard Tartler <siretart@gmail.com>
To: Benjamin Drung <bdrung@debian.org>, 685243@bugs.debian.org
Cc: Petter Reinholdtsen <pere@hungry.com>, Holger Levsen <holger@layer-acht.org>
Subject: Re: Bug#685243: vlc-nox: breaks squeeze-wheezy upgrade into very bad state
Date: Sun, 3 Mar 2013 10:56:33 +0100
On Wed, Feb 13, 2013 at 12:16 AM, Benjamin Drung <bdrung@debian.org> wrote:
> Am Dienstag, den 12.02.2013, 22:47 +0100 schrieb Petter Reinholdtsen:
>> This problem is also seen in the chroot upgrade testing for a full
>>
>> [...]
>>
>> <URL: http://bugs.debian.org/678848 > describe a workaround using
>> Breaks.  Perhaps it could be used here too?
>
> Please test the attached patch if it really works around the bug.

I am able to confirm the problem in current wheezy:

Preparing to replace libvlc5 1.1.3-1squeeze6 (using
.../libvlc5_2.0.3-4_i386.deb) ...
Unpacking replacement libvlc5 ...
Processing triggers for vlc-nox ...
/usr/lib/vlc/vlc-cache-gen: error while loading shared libraries:
libvlccore.so.5: cannot open shared object file: No such file or
directory
dpkg: error processing vlc-nox (--unpack):
 subprocess installed post-installation script returned error exit status 127

and I am happy to confirm that your proposed patch fixes the problem.

Benjamin, can you upload it to t-p-u?

-- 
regards,
    Reinhard



Reply sent to Benjamin Drung <bdrung@debian.org>:
You have taken responsibility. (Mon, 04 Mar 2013 21:06:08 GMT) Full text and rfc822 format available.

Notification sent to Daniel Pocock <daniel@pocock.com.au>:
Bug acknowledged by developer. (Mon, 04 Mar 2013 21:06:08 GMT) Full text and rfc822 format available.

Message #49 received at 685243-close@bugs.debian.org (full text, mbox):

From: Benjamin Drung <bdrung@debian.org>
To: 685243-close@bugs.debian.org
Subject: Bug#685243: fixed in vlc 2.0.3-5
Date: Mon, 04 Mar 2013 21:02:54 +0000
Source: vlc
Source-Version: 2.0.3-5

We believe that the bug you reported is fixed in the latest version of
vlc, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 685243@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Benjamin Drung <bdrung@debian.org> (supplier of updated vlc package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Mon, 04 Mar 2013 16:15:02 +0100
Source: vlc
Binary: libvlc-dev libvlc5 libvlccore-dev libvlccore5 vlc vlc-data vlc-dbg vlc-nox vlc-plugin-fluidsynth vlc-plugin-jack vlc-plugin-notify vlc-plugin-pulse vlc-plugin-sdl vlc-plugin-svg vlc-plugin-zvbi
Architecture: source amd64 all
Version: 2.0.3-5
Distribution: testing
Urgency: low
Maintainer: Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
Changed-By: Benjamin Drung <bdrung@debian.org>
Description: 
 libvlc-dev - development files for libvlc
 libvlc5    - multimedia player and streamer library
 libvlccore-dev - development files for libvlccore
 libvlccore5 - base library for VLC and its modules
 vlc        - multimedia player and streamer
 vlc-data   - Common data for VLC
 vlc-dbg    - debugging symbols for vlc
 vlc-nox    - multimedia player and streamer (without X support)
 vlc-plugin-fluidsynth - FluidSynth plugin for VLC
 vlc-plugin-jack - Jack audio plugins for VLC
 vlc-plugin-notify - LibNotify plugin for VLC
 vlc-plugin-pulse - PulseAudio plugin for VLC
 vlc-plugin-sdl - SDL video and audio output plugin for VLC
 vlc-plugin-svg - SVG plugin for VLC
 vlc-plugin-zvbi - VBI teletext plugin for VLC
Closes: 685243
Changes: 
 vlc (2.0.3-5) testing; urgency=low
 .
   * vlc-plugin-*: Break vlc-nox (<< 2.0.0) to workaround running an outdated
     vlc-cache-gen. (Closes: #685243)
Checksums-Sha1: 
 69fa1f3f27abbeb8e339cda2d463ca3dceca33f2 4844 vlc_2.0.3-5.dsc
 ad0f364f36947ed3a734fd3a271598df2ba1ab9d 58759 vlc_2.0.3-5.debian.tar.gz
 d3595a26eb5f106d20d6ab4849ebb917ee10f07e 59478 libvlc-dev_2.0.3-5_amd64.deb
 00046a5c136d1d293a1f1c67dab84660ae7d2a49 39264 libvlc5_2.0.3-5_amd64.deb
 c056ce30712d650967dadfe1235a5cf9f025fefd 504458 libvlccore-dev_2.0.3-5_amd64.deb
 a213bcf6fe273c798186a148922dee680d7f3fbf 356370 libvlccore5_2.0.3-5_amd64.deb
 040cce3d0767a1c54f8821272e0170f50fb5d804 1050892 vlc_2.0.3-5_amd64.deb
 51eca9a80607105ffd2c5624040774a018e73072 5107420 vlc-data_2.0.3-5_all.deb
 312462989adb5ada8e306e0866e40cf2cbaf875e 13274058 vlc-dbg_2.0.3-5_amd64.deb
 650397130231171c865d56fc9c2636bf288a8962 2550962 vlc-nox_2.0.3-5_amd64.deb
 6ed20fe5b19b4b7440c681ab96f78d5c9a46c82e 5476 vlc-plugin-fluidsynth_2.0.3-5_amd64.deb
 ced7937143dd01162a402b2a0bebdfd461dea71f 10498 vlc-plugin-jack_2.0.3-5_amd64.deb
 8ae0f47c4c206a06a60cb2ba4537762c9ab87b33 5620 vlc-plugin-notify_2.0.3-5_amd64.deb
 05f756e5cb3788831f73e1ffd9f122ecb433dade 16774 vlc-plugin-pulse_2.0.3-5_amd64.deb
 58b4a9e3a76bf1d2947bbab382d051ce390c39f1 8114 vlc-plugin-sdl_2.0.3-5_amd64.deb
 4c9c52bdc15c5b179e058bccf089e433e76b5f45 6314 vlc-plugin-svg_2.0.3-5_amd64.deb
 6f12a6748f629657831da6ee3b073b0dcc5d4616 8036 vlc-plugin-zvbi_2.0.3-5_amd64.deb
Checksums-Sha256: 
 f62560c8eb1b217012937fd8b44f4bf320b36bebfebe64b0df0513a814e54452 4844 vlc_2.0.3-5.dsc
 719af6a50647e183b836eb0586dfa773b655ae5caefe9639e1d9fd32a1423dee 58759 vlc_2.0.3-5.debian.tar.gz
 3144954a9eed377a084a41c76c258436bb1d890debaba786a1c0435b2c968dbb 59478 libvlc-dev_2.0.3-5_amd64.deb
 bc72d004eb32eeac2844879547c762dbe8e119fa4b1407689db3bbfb63c61edc 39264 libvlc5_2.0.3-5_amd64.deb
 a0e1b865aba1bdb2bc343880ba37aaa9d2ddd33d69a24bcc4a6a596e160ae285 504458 libvlccore-dev_2.0.3-5_amd64.deb
 8f373a0a6c8b39c432d664deee17f36f3509f386816d196ec49f703d6599cbd5 356370 libvlccore5_2.0.3-5_amd64.deb
 96459fb26cb2664f718a8b56897cdf3940454dcc6c5987a7dc27bf6138fc3f2c 1050892 vlc_2.0.3-5_amd64.deb
 e2f452cd594d287d5501d54b7fe3848f7b48c1046827dfaff08339838cb62c40 5107420 vlc-data_2.0.3-5_all.deb
 4427664a877103e42bfe09b79143161e30750a1e9bcc1e50896d6d3d98ed7217 13274058 vlc-dbg_2.0.3-5_amd64.deb
 af611a338c5106e8a734990e9990665af8549a52ed70c9877889168fd7078af3 2550962 vlc-nox_2.0.3-5_amd64.deb
 52fba3cbc9072fdece20beb5b76abcf143be3cea08d9bb9a0941176f55ea9f6a 5476 vlc-plugin-fluidsynth_2.0.3-5_amd64.deb
 5390690bf7fc27360f88ede5149e1e40cc1f72107092c67c963962b68c5a047d 10498 vlc-plugin-jack_2.0.3-5_amd64.deb
 d108ae74564c0013aec91e60521f1fb50c52c0a3285b96b6b46b2f60029009e4 5620 vlc-plugin-notify_2.0.3-5_amd64.deb
 ac3df4d7c7f716803d3d8bc7fd15d5a765e83e1fd85ead6162bba86042acc0e1 16774 vlc-plugin-pulse_2.0.3-5_amd64.deb
 df79830da33f2d908934c3925739903e0c47fdc5da52f698b54598c3d86fe6df 8114 vlc-plugin-sdl_2.0.3-5_amd64.deb
 1e214daf05493afecf7e32088beb214e29c8592e0e59c7d5a216006752d3789c 6314 vlc-plugin-svg_2.0.3-5_amd64.deb
 9f9878e980aebe27fc994c83642eff51e0337cb620c1c2bb2acf5c3333ec625d 8036 vlc-plugin-zvbi_2.0.3-5_amd64.deb
Files: 
 afefc472eb911e7f75377bb653de1712 4844 video optional vlc_2.0.3-5.dsc
 057a2fda4d2a4b58ea0a5602a5ae1853 58759 video optional vlc_2.0.3-5.debian.tar.gz
 0329fbe94bc5749754abfc9114cb7de4 59478 libdevel optional libvlc-dev_2.0.3-5_amd64.deb
 611a47de44af0d8e3a7772402ff5d9bb 39264 libs optional libvlc5_2.0.3-5_amd64.deb
 a9cb009a2f5f774f7eb997b2bb5a8e34 504458 libdevel optional libvlccore-dev_2.0.3-5_amd64.deb
 edfd0bd061b85ee144885a05170378a9 356370 libs optional libvlccore5_2.0.3-5_amd64.deb
 aa466306353e43aae771202475f5d820 1050892 video optional vlc_2.0.3-5_amd64.deb
 1300d9c8030ec9be2c8e69718874df0d 5107420 video optional vlc-data_2.0.3-5_all.deb
 b57d380e0cb5f598daf1e2cf096eaa09 13274058 debug extra vlc-dbg_2.0.3-5_amd64.deb
 2287e18d780ffc5aebd854efb1ab0879 2550962 video optional vlc-nox_2.0.3-5_amd64.deb
 e638fb5b37d49b1b6de9eb651b67cdbb 5476 video optional vlc-plugin-fluidsynth_2.0.3-5_amd64.deb
 cfa532b78718fae7f45925f263dbbcba 10498 video optional vlc-plugin-jack_2.0.3-5_amd64.deb
 0f8a8ae7493aab9242b2ec9e54fc63f9 5620 video optional vlc-plugin-notify_2.0.3-5_amd64.deb
 adda76178912b99030bc7d31da6f481a 16774 video optional vlc-plugin-pulse_2.0.3-5_amd64.deb
 be87017b443000837f1d5648974b3809 8114 video optional vlc-plugin-sdl_2.0.3-5_amd64.deb
 4b710c11e16747a721c6419385e4b4f6 6314 video optional vlc-plugin-svg_2.0.3-5_amd64.deb
 433a5a836fd54b15760d26a9d29d2a16 8036 video optional vlc-plugin-zvbi_2.0.3-5_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCgAGBQJRNPKBAAoJEBWetcTvyHdMytUQAK0Fgn3WHkYaFncZNweZMQyo
pcTzyQ4+2bszEHElTYN4eKE+zcziYmcvyDqSl2t+iNZSHXeykZJYLu4DjvQs6K7H
F2m9AG7FQgZ+gZx1RTu6VtGUWtGjzaIuxnF5Cz6aRceqyNKOkg0z9Z9FEDPkDete
WQvbm4eDrLFxhvqpGc23ZBi3d7zrMg5Kn5rEN/pa3OoampB9T4DpIWzuU7r92gRv
xVdREV/P5sJ1VTMkP0+yJsi9gRbmjyW+2MKqLFchuKyBhMJHrY8cqZqiqBEZ4G0n
m2dDgE9c0/1RC1h7yYZuD/39NR94QLVRMsgvxP0syChjxBBFtQz7tfdUQD53TrDq
Go5WDF8uFGkeG5xk2d822OpvUpb/rp3RFLGGVqXaidYBI3gc+MT144C2U2JNYiyG
xgraZNRMMm56+coz6TpwMpMkb5ZeflGffNzmh+fmmP1m45NbHLMdmmLLLWVu2/VI
c2z5cJ4Kp4TrdVKadpeWcZeCnuj2VDUyKaLNWmTQcuHivDhs8ncJ3P12XrbBhXiT
+scl7DaLpL/LkjJHCaflLQx4JclIZ5FdqQVRoBXfd1ZzyDeQMRjuX5h1W3WPOdDs
tMyme4Ps65Teh6oHxR3g6n/Qsy4GV4TOOPooL4bex5zfRWqsKJtMcngk2jbGGqaL
M1NRxqHYBQvs1nN8pezl
=h2nl
-----END PGP SIGNATURE-----




Reply sent to Benjamin Drung <bdrung@debian.org>:
You have taken responsibility. (Mon, 04 Mar 2013 21:06:08 GMT) Full text and rfc822 format available.

Notification sent to Victor Porton <porton@narod.ru>:
Bug acknowledged by developer. (Mon, 04 Mar 2013 21:06:08 GMT) Full text and rfc822 format available.

Added tag(s) pending. Request was from Benjamin Drung <bdrung@debian.org> to control@bugs.debian.org. (Tue, 05 Mar 2013 14:33:06 GMT) Full text and rfc822 format available.

Marked as found in versions vlc/2.0.3-4. Request was from Niels Thykier <niels@thykier.net> to control@bugs.debian.org. (Wed, 06 Mar 2013 19:45:03 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 05 May 2013 07:44:14 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 01:15:55 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.