Debian Bug report logs - #683343
Installation of xul-ext-firebug causes conkeror's extension screen to hang

version graph

Package: conkeror; Maintainer for conkeror is Axel Beckert <abe@debian.org>; Source for conkeror is src:conkeror.

Reported by: Sascha Silbe <sascha-debian-bugs-conkeror-2012-07-31@silbe.org>

Date: Mon, 30 Jul 2012 22:57:01 UTC

Severity: important

Found in version conkeror/1.0~~pre+git120527-1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, sascha-debian-bugs-cc@silbe.org, Axel Beckert <abe@debian.org>:
Bug#683343; Package conkeror. (Mon, 30 Jul 2012 22:57:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sascha Silbe <sascha-debian-bugs-conkeror-2012-07-31@silbe.org>:
New Bug report received and forwarded. Copy sent to sascha-debian-bugs-cc@silbe.org, Axel Beckert <abe@debian.org>. (Mon, 30 Jul 2012 22:57:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Sascha Silbe <sascha-debian-bugs-conkeror-2012-07-31@silbe.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: conkeror: extensions screen never finishes loading
Date: Tue, 31 Jul 2012 00:52:30 +0200
Package: conkeror
Version: 1.0~~pre+git120527-1
Severity: important

Dear Maintainer,

after the update to Wheezy, the extensions screen (invoked via Alt+x
"extensions") shows only a constantly spinning "Loading..."
message. It doesn't use the CPU much and doesn't seem to be doing
anything on disk either.

Output in the terminal:

sascha.silbe@twin:~$ conkeror 
NS_ERROR_FILE_TARGET_DOES_NOT_EXIST: Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsILocalFile.isSymlink]
load_rc()@chrome://conkeror/content/rc.js:23
handle_command_line()@chrome://conkeror/content/command-line.js:179
null()@file:///usr/share/conkeror/components/command-line.js:23
Console error: [JavaScript Warning: "reference to undefined property types[type]" {file: "chrome://mozapps/content/extensions/extensions.js" line: 1480}]
  Category: chrome javascript
Console error: [JavaScript Error: "Root node doesn't exist for 'discover' view" {file: "chrome://mozapps/content/extensions/extensions.js" line: 647}]
  Category: chrome javascript


Marking as important as it's impossible to manage and configure
extensions other than by using the extensions screen AFAIK.

-- Package-specific info:

-- Extensions information
Name: Monkeysphere
Location: /usr/share/mozilla/extensions/{a79fe89b-6662-4ff4-8e88-09950ad4dfde}/tls-xul-ext@monkeysphere.info
Status: app-disabled

-- Plugins information
Name: IcedTea-Web Plugin (using IcedTea-Web 1.2 (1.2-2))
Location: /usr/lib/jvm/java-6-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so
Package: icedtea-6-plugin:amd64
Status: enabled


-- Addons package information
ii  icedtea-6-plug 1.2-2          web browser plugin based on OpenJDK and Iced

-- Extensions information
Name: Monkeysphere
Location: /usr/share/mozilla/extensions/{a79fe89b-6662-4ff4-8e88-09950ad4dfde}/tls-xul-ext@monkeysphere.info
Status: app-disabled

-- Plugins information
Name: IcedTea-Web Plugin (using IcedTea-Web 1.2 (1.2-2))
Location: /usr/lib/jvm/java-6-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so
Package: icedtea-6-plugin:amd64
Status: enabled


-- Addons package information
ii  icedtea-6-plug 1.2-2          web browser plugin based on OpenJDK and Iced

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.2.0-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages conkeror depends on:
ii  xulrunner-1.9.1  1.9.1.16-17
ii  xulrunner-10.0   10.0.6esr-1

Versions of packages conkeror recommends:
ii  conkeror-spawn-process-helper  1.0~~pre+git120527-1
ii  xdg-utils                      1.1.0~rc1+git20111210-6

Versions of packages conkeror suggests:
ii  emacs [emacsen]    23.4+1-3
ii  emacs23 [emacsen]  23.4+1-3

-- no debconf information



Information forwarded to debian-bugs-dist@lists.debian.org, Axel Beckert <abe@debian.org>:
Bug#683343; Package conkeror. (Tue, 07 Aug 2012 20:33:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Vincent Bernat <bernat@debian.org>:
Extra info received and forwarded to list. Copy sent to Axel Beckert <abe@debian.org>. (Tue, 07 Aug 2012 20:33:03 GMT) Full text and rfc822 format available.

Message #10 received at 683343@bugs.debian.org (full text, mbox):

From: Vincent Bernat <bernat@debian.org>
To: Debian Bug Tracking System <683343@bugs.debian.org>
Subject: Re: conkeror: extensions screen never finishes loading
Date: Tue, 07 Aug 2012 22:24:41 +0200
Package: conkeror
Version: 1.0~~pre+git120527-1
Followup-For: Bug #683343

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hi!

I have the same problem on a fresh install. However, there is a
workaround: download XPI manually then install them with the menu in
the extensionpanel (left of the search area). Works fine for me.

- -- Package-specific info:

- -- Extensions information
Name: Adblock Plus
Location: ${PROFILE_EXTENSIONS}/{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}.xpi
Status: enabled

Name: MozRepl
Location: ${PROFILE_EXTENSIONS}/mozrepl@hyperstruct.net.xpi
Status: enabled

- -- Plugins information
Name: IcedTea-Web Plugin (using IcedTea-Web 1.2 (1.2-2))
Location: /usr/lib/jvm/java-6-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so
Package: icedtea-6-plugin:amd64
Status: enabled

Name: Shockwave Flash
Location: /usr/lib/flashplugin-nonfree/libflashplayer.so
Status: enabled


- -- Addons package information
ii  icedtea-6-plug 1.2-2        amd64        web browser plugin based on OpenJ

- -- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (101, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.2.0-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages conkeror depends on:
ii  xulrunner-10.0  10.0.6esr-2

Versions of packages conkeror recommends:
ii  conkeror-spawn-process-helper  1.0~~pre+git120527-1
ii  xdg-utils                      1.1.0~rc1+git20111210-6

Versions of packages conkeror suggests:
ii  emacs24-lucid [emacsen]  24.1+1-4

- -- no debconf information

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJQIXmEAAoJEJWkL+g1NSX5+IoP/iEMFf5klxcO06NPG3MnPWrK
CGa1eaO3vuYi74dtFppEq34lRX3Kkt+79CMJA/IxHjfLBWf0wRMxLXC+9u7q36F4
H7aSxh4mxCUC4hw1r5x8xs4x2d4Ltsyy4XFvFf85T5xoIzKSpEs+5JMrfDlfQMpj
JFn7zvDvFq3wnT+pGphZM1S0EoVpZ2aZQWwdgxg7xXoQmCnrxia3+mQnPEsxg2OJ
357Pr3rWWOvpqgXlEAUYNO9SwwyHCy3QU8ZYnzA7noA+VNhdgrxq7n/K49hCsrSO
qxAoZRkrJi33k0NNvEsvDBO3ag/uBH+MUZbPSdz8DwJHM0RE33fT3It39Yl1fcIG
apM70jLI1UD+YiIKhBfhBZoW3V7tf7WZGlyzxxmbBtacgKIpfVWRp3+GJYZAAXg3
MXIcEAEZGpXYhKTSGWnzmKf/b4UVNx+QGGDiaS+3D5B+Oipz2Dhw9TamxM7KGIaf
xeY4D9boikf//i2NYkrbsopST7BVLwUs2z2lX3+Yt0yeinBfGwGtGk8mmi56fpU7
+e0OKeHJOka2MIQbxygE3varDeLY8Ie8CpLIIzGfFEvxRQzt1CIRLXI8V2RH6eXJ
GxaVv9UrnbCxK4z7h0/rsjpmT5nk8JDx/ZjT4K60a4SOm9QNRaU2oXnTDgQw1SXQ
CMCmo+eFIq4qfcjgpwbB
=mzMh
-----END PGP SIGNATURE-----



Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#683343; Package conkeror. (Tue, 07 Aug 2012 22:57:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Axel Beckert <abe@debian.org>:
Extra info received and forwarded to list. (Tue, 07 Aug 2012 22:57:04 GMT) Full text and rfc822 format available.

Message #15 received at 683343@bugs.debian.org (full text, mbox):

From: Axel Beckert <abe@debian.org>
To: Sascha Silbe <sascha-debian-bugs-conkeror-2012-07-31@silbe.org>, 683343@bugs.debian.org, Vincent Bernat <bernat@debian.org>
Subject: Re: Bug#683343: conkeror: extensions screen never finishes loading
Date: Wed, 8 Aug 2012 00:55:04 +0200
Hi,

Sascha Silbe wrote:
> after the update to Wheezy, the extensions screen (invoked via Alt+x
> "extensions") shows only a constantly spinning "Loading..."
> message. It doesn't use the CPU much and doesn't seem to be doing
> anything on disk either.

Hmmm, on a first glance I can't reproduce that problem, neither with
xulrunner-10.0 nor with xulrunner-16.0.

> -- Extensions information
> Name: Monkeysphere
> Location: /usr/share/mozilla/extensions/{a79fe89b-6662-4ff4-8e88-09950ad4dfde}/tls-xul-ext@monkeysphere.info
> Status: app-disabled
> 
> -- Plugins information
> Name: IcedTea-Web Plugin (using IcedTea-Web 1.2 (1.2-2))
> Location: /usr/lib/jvm/java-6-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so
> Package: icedtea-6-plugin:amd64
> Status: enabled
> 
> 
> -- Addons package information
> ii  icedtea-6-plug 1.2-2          web browser plugin based on OpenJDK and Iced

Vincent Bernat wrote:
> -- Extensions information
> Name: Adblock Plus
> Location: ${PROFILE_EXTENSIONS}/{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}.xpi
> Status: enabled
> 
> Name: MozRepl
> Location: ${PROFILE_EXTENSIONS}/mozrepl@hyperstruct.net.xpi
> Status: enabled
> 
> -- Plugins information
> Name: IcedTea-Web Plugin (using IcedTea-Web 1.2 (1.2-2))
> Location: /usr/lib/jvm/java-6-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so
> Package: icedtea-6-plugin:amd64
> Status: enabled
> 
> Name: Shockwave Flash
> Location: /usr/lib/flashplugin-nonfree/libflashplayer.so
> Status: enabled
> 
> 
> -- Addons package information
> ii  icedtea-6-plug 1.2-2        amd64        web browser plugin based on OpenJ

The only thing which is not present in my setup but common between
those both configurations is the IcedTea-Web Plugin. Have to check if
installing that allows me to reproduce the issue.

		Regards, Axel
-- 
 ,''`.  |  Axel Beckert <abe@debian.org>, http://people.debian.org/~abe/
: :' :  |  Debian Developer, ftp.ch.debian.org Admin
`. `'   |  1024D: F067 EA27 26B9 C3FC 1486  202E C09E 1D89 9593 0EDE
  `-    |  4096R: 2517 B724 C5F6 CA99 5329  6E61 2FF9 CD59 6126 16B5



Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#683343; Package conkeror. (Wed, 08 Aug 2012 00:27:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Axel Beckert <abe@debian.org>:
Extra info received and forwarded to list. (Wed, 08 Aug 2012 00:27:05 GMT) Full text and rfc822 format available.

Message #20 received at 683343@bugs.debian.org (full text, mbox):

From: Axel Beckert <abe@debian.org>
To: Sascha Silbe <sascha-debian-bugs-conkeror-2012-07-31@silbe.org>, 683343@bugs.debian.org, Vincent Bernat <bernat@debian.org>
Subject: Re: Bug#683343: conkeror: extensions screen never finishes loading
Date: Wed, 8 Aug 2012 02:22:56 +0200
Hi again,

Axel Beckert wrote:
> Hmmm, on a first glance I can't reproduce that problem, neither with
> xulrunner-10.0 nor with xulrunner-16.0.
[...]
> The only thing which is not present in my setup but common between
> those both configurations is the IcedTea-Web Plugin. Have to check if
> installing that allows me to reproduce the issue.

Sorry, but even with icedtea-plugin installed, I still can't reproduce
ithe problem. Any ideas on further potential differences which could
cause this behaviour are welcome.

		Regards, Axel
-- 
 ,''`.  |  Axel Beckert <abe@debian.org>, http://people.debian.org/~abe/
: :' :  |  Debian Developer, ftp.ch.debian.org Admin
`. `'   |  1024D: F067 EA27 26B9 C3FC 1486  202E C09E 1D89 9593 0EDE
  `-    |  4096R: 2517 B724 C5F6 CA99 5329  6E61 2FF9 CD59 6126 16B5



Added tag(s) unreproducible. Request was from Axel Beckert <abe@debian.org> to control@bugs.debian.org. (Wed, 08 Aug 2012 00:27:07 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Axel Beckert <abe@debian.org>:
Bug#683343; Package conkeror. (Wed, 08 Aug 2012 05:39:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Vincent Bernat <bernat@debian.org>:
Extra info received and forwarded to list. Copy sent to Axel Beckert <abe@debian.org>. (Wed, 08 Aug 2012 05:39:03 GMT) Full text and rfc822 format available.

Message #27 received at 683343@bugs.debian.org (full text, mbox):

From: Vincent Bernat <bernat@debian.org>
To: Axel Beckert <abe@debian.org>
Cc: Sascha Silbe <sascha-debian-bugs-conkeror-2012-07-31@silbe.org>, 683343@bugs.debian.org
Subject: Re: Bug#683343: conkeror: extensions screen never finishes loading
Date: Wed, 08 Aug 2012 07:37:15 +0200
[Message part 1 (text/plain, inline)]
 ❦  8 août 2012 02:22 CEST, Axel Beckert <abe@debian.org> :

>> Hmmm, on a first glance I can't reproduce that problem, neither with
>> xulrunner-10.0 nor with xulrunner-16.0.
> [...]
>> The only thing which is not present in my setup but common between
>> those both configurations is the IcedTea-Web Plugin. Have to check if
>> installing that allows me to reproduce the issue.
>
> Sorry, but even with icedtea-plugin installed, I still can't reproduce
> ithe problem. Any ideas on further potential differences which could
> cause this behaviour are welcome.

Maybe system-wide extensions are doing this? I have:
 - xul-ext-adblock-plus
 - xul-ext-firebug
 - xul-ext-flashblock
 - xul-ext-greasemonkey

I have removed all of them and it works. Installing just xul-ext-firebug
is sufficient to get the error back:

#v+
Console error: [JavaScript Warning: "reference to undefined property types[type]" {file: "chrome://mozapps/content/extensions/extensions.js" line: 1480}]
  Category: chrome javascript
Console error: [JavaScript Error: "Root node doesn't exist for 'discover' view" {file: "chrome://mozapps/content/extensions/extensions.js" line: 647}]
  Category: chrome javascript
#v-

Removing xul-ext-firebug is not the neatest workaround (since I still
need it for Firefox), but this is something that I can live with. Maybe
it's possible to blacklist/disable it?
-- 
Don't over-comment.
            - The Elements of Programming Style (Kernighan & Plauger)
[Message part 2 (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#683343; Package conkeror. (Wed, 08 Aug 2012 07:18:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Axel Beckert <abe@debian.org>:
Extra info received and forwarded to list. (Wed, 08 Aug 2012 07:18:03 GMT) Full text and rfc822 format available.

Message #32 received at 683343@bugs.debian.org (full text, mbox):

From: Axel Beckert <abe@debian.org>
To: Vincent Bernat <bernat@debian.org>
Cc: 683343@bugs.debian.org
Subject: Re: Bug#683343: conkeror: extensions screen never finishes loading
Date: Wed, 8 Aug 2012 09:15:22 +0200
tag 683343 - unreproducible
retitle 683343 Installation of xul-ext-firebug causes conkeror's extension screen to hang
kthxbye

Vincent Bernat wrote:
> I have removed all of them and it works. Installing just xul-ext-firebug
> is sufficient to get the error back:
> 
> #v+
> Console error: [JavaScript Warning: "reference to undefined property types[type]" {file: "chrome://mozapps/content/extensions/extensions.js" line: 1480}]
>   Category: chrome javascript
> Console error: [JavaScript Error: "Root node doesn't exist for 'discover' view" {file: "chrome://mozapps/content/extensions/extensions.js" line: 647}]
>   Category: chrome javascript
> #v-

Cool! Thanks for checking!

> Removing xul-ext-firebug is not the neatest workaround (since I still
> need it for Firefox), but this is something that I can live with. Maybe
> it's possible to blacklist/disable it?

I'll check. I'm also surprised that it affects conkeror at all.

It though can be a bug in any of those two packages: Conkeror
shouldn't load any code from xul-ext-firebug while xul-ext-firebug
shouldn't break unrelated packages. That would be an RC bug.

At least the xul-ext-firebug doesn't install anything in conkeror's
/usr/share/mozilla/extensions/ directory. Then the source of the
problem would have been obvious. :-)

		Regards, Axel
-- 
 ,''`.  |  Axel Beckert <abe@debian.org>, http://people.debian.org/~abe/
: :' :  |  Debian Developer, ftp.ch.debian.org Admin
`. `'   |  1024D: F067 EA27 26B9 C3FC 1486  202E C09E 1D89 9593 0EDE
  `-    |  4096R: 2517 B724 C5F6 CA99 5329  6E61 2FF9 CD59 6126 16B5



Removed tag(s) unreproducible. Request was from Axel Beckert <abe@debian.org> to control@bugs.debian.org. (Wed, 08 Aug 2012 07:18:05 GMT) Full text and rfc822 format available.

Changed Bug title to 'Installation of xul-ext-firebug causes conkeror's extension screen to hang' from 'conkeror: extensions screen never finishes loading' Request was from Axel Beckert <abe@debian.org> to control@bugs.debian.org. (Wed, 08 Aug 2012 07:18:05 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 01:32:27 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.