Debian Bug report logs - #683032
update-auctex-elisp looks for emacs-snapshot instead of emacs24

version graph

Package: auctex; Maintainer for auctex is Davide G. M. Salvetti <salve@debian.org>; Source for auctex is src:auctex.

Reported by: Chiraag Nataraj <chiraag.nataraj@gmail.com>

Date: Fri, 27 Jul 2012 22:57:01 UTC

Severity: wishlist

Tags: confirmed, sid

Merged with 679712, 679942, 681124

Found in versions auctex/11.86-10.1, auctex/11.86-10

Fixed in version auctex/11.86-12

Done: salve@debian.org (Davide G. M. Salvetti)

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Davide G. M. Salvetti <salve@debian.org>:
Bug#683032; Package auctex. (Fri, 27 Jul 2012 22:57:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Chiraag Nataraj <chiraag.nataraj@gmail.com>:
New Bug report received and forwarded. Copy sent to Davide G. M. Salvetti <salve@debian.org>. (Fri, 27 Jul 2012 22:57:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Chiraag Nataraj <chiraag.nataraj@gmail.com>
To: submit@bugs.debian.org
Subject: update-auctex-elisp looks for emacs-snapshot instead of emacs24
Date: Fri, 27 Jul 2012 18:52:55 -0400
Package: auctex
Version: 11.86-10.1

When auctex gets updated, it scans for emacs flavours to update.  I have both auctex and emacs24 installed from sid.  When dpkg processes auctex triggers, here is what it says:

The following NEW packages will be installed:
  auctex 
The following packages are RECOMMENDED but will NOT be installed:
  evince evince-gtk xpdf 
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,244 kB of archives. After unpacking 3,345 kB will be used.
Get: 1 http://ftp.debian.org/debian/ sid/main auctex all 11.86-10.1 [1,244 kB]
Fetched 1,244 kB in 2s (585 kB/s) 
Preconfiguring packages ...
Selecting previously unselected package auctex.
(Reading database ... 370046 files and directories currently installed.)
Unpacking auctex (from .../auctex_11.86-10.1_all.deb) ...
Processing triggers for man-db ...
Processing triggers for install-info ...
install-info: warning: no info dir entry in `/usr/share/info/lilypond-changes.info.gz'
install-info: warning: no info dir entry in `/usr/share/info/lilypond-learning.info.gz'
install-info: warning: no info dir entry in `/usr/share/info/lilypond-essay.info.gz'
install-info: warning: no info dir entry in `/usr/share/info/lilypond-extending.info.gz'
install-info: warning: no info dir entry in `/usr/share/info/lilypond-usage.info.gz'
install-info: warning: no info dir entry in `/usr/share/info/music-glossary.info.gz'
install-info: warning: no info dir entry in `/usr/share/info/lilypond-contributor.info.gz'
install-info: warning: no info dir entry in `/usr/share/info/lilypond-snippets.info.gz'
install-info: warning: no info dir entry in `/usr/share/info/lilypond-notation.info.gz'
Processing triggers for doc-base ...
Processing 2 added doc-base files...
Setting up auctex (11.86-10.1) ...
Install auctex for emacs
Install auctex for emacs23
auctex/install: Byte-compiling for Emacs flavor emacs23 (log to /usr/share/emacs23/site-lisp/auctex/CompilationLog)... done.
Install auctex for emacs24
auctex/install: Ignoring unsupported Emacs flavor: emacs24
Processing triggers for auctex ...
update-auctex-elisp[26643]: Will scan macros for Emacs flavor emacs23 (log to /var/lib/auctex/emacs23/CompilationLog)

When I dove into /usr/lib/emacsen-common/install/auctex, I found the line which was preventing auctex from installing itself for emacs24:

case "${FLAVOR}" in
    (emacs)
        ;;
    (emacs23|emacs-snapshot)
    ...

As you can see, emacs24 is nowhere in the list, so auctex thinks it is an "unsupported version".  If you add emacs24 there, it all works fine (auctex has no compatibility problems with emacs24).

I suggest adding emacs24 to the list of flavours which is checked.

I am using Debian GNU/Linux wheezy/sid, kernel 3.4.    



Severity set to 'wishlist' from 'normal' Request was from "Davide G. M. Salvetti" <salve@debian.org> to control@bugs.debian.org. (Mon, 30 Jul 2012 21:57:08 GMT) Full text and rfc822 format available.

Marked as found in versions auctex/11.86-10. Request was from "Davide G. M. Salvetti" <salve@debian.org> to control@bugs.debian.org. (Mon, 30 Jul 2012 21:57:08 GMT) Full text and rfc822 format available.

Merged 679712 679942 681124 683032 Request was from "Davide G. M. Salvetti" <salve@debian.org> to control@bugs.debian.org. (Mon, 30 Jul 2012 21:57:11 GMT) Full text and rfc822 format available.

Added tag(s) confirmed. Request was from "Davide G. M. Salvetti" <salve@debian.org> to control@bugs.debian.org. (Mon, 30 Jul 2012 21:57:14 GMT) Full text and rfc822 format available.

Added tag(s) pending. Request was from "Davide G. M. Salvetti" <salve@debian.org> to control@bugs.debian.org. (Fri, 16 Nov 2012 17:27:05 GMT) Full text and rfc822 format available.

Added tag(s) sid. Request was from "Davide G. M. Salvetti" <salve@debian.org> to control@bugs.debian.org. (Mon, 19 Nov 2012 06:51:05 GMT) Full text and rfc822 format available.

Message #18 received at 679712-close@bugs.debian.org (full text, mbox):

From: salve@debian.org (Davide G. M. Salvetti)
To: 679712-close@bugs.debian.org
Subject: Bug#679712: fixed in auctex 11.86-12
Date: Wed, 28 Nov 2012 23:17:29 +0000
Source: auctex
Source-Version: 11.86-12

We believe that the bug you reported is fixed in the latest version of
auctex, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 679712@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Davide G. M. Salvetti <salve@debian.org> (supplier of updated auctex package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Wed, 28 Nov 2012 22:22:51 +0100
Source: auctex
Binary: auctex preview-latex-style
Architecture: source all
Version: 11.86-12
Distribution: unstable
Urgency: low
Maintainer: Davide G. M. Salvetti <salve@debian.org>
Changed-By: Davide G. M. Salvetti <salve@debian.org>
Description: 
 auctex     - integrated document editing environment for TeX etc.
 preview-latex-style - extraction of elements from LaTeX documents as graphics
Closes: 668357 669948 673228 679712 682720
Changes: 
 auctex (11.86-12) unstable; urgency=low
 .
   * [d79a7ed] Stop removing old empty site-start.d directories.
     Thanks to Sven Joachim (Closes: #673228)
   * [a039a20] Fix obsolete conffiles dpkg-maintscript-helper removal.
     Thanks to Josh Triplett (Closes: #669948)
   * [3b64839] Add emacs24 GNU Emacs flavor.
     Thanks to Svante Signell, S├ębastien Villemot (Closes: #682720, #679712)
   * [1386555] Add patch: Fix typo in the reference card.
     Thanks to S├ębastien Villemot (Closes: #668357)
   * [3af9183] debian/copyright: Switch to machine readable format.
   * [c763f4a] Update Standards-Version to 3.9.4.
Checksums-Sha1: 
 7ecf990b9c478941a08c4ae2f8dd4a9125aef847 1346 auctex_11.86-12.dsc
 6efbbd20b1b0762281cdc8d30faa327267485f89 59265 auctex_11.86-12.debian.tar.gz
 878575c2c530f160d138379409a5852449010d23 1247250 auctex_11.86-12_all.deb
 75767260dd096426ac051ae39b40efc15c17b4f2 310628 preview-latex-style_11.86-12_all.deb
Checksums-Sha256: 
 0f248e0f4fc4fa412c3f65c0095088098addba5caec5836307d6af19a8c1e5f8 1346 auctex_11.86-12.dsc
 f3edd939d53b132e239ef48542735123e8d059dc4d9d7a73437d86e225e56a0a 59265 auctex_11.86-12.debian.tar.gz
 2cbba88fb77ef16c28421ea8961866b2a57a1fb6aadd669eb70b91baa413733c 1247250 auctex_11.86-12_all.deb
 06273f2f2165d1c7551b81cf247f040afa4e784fc2bfbad4c5162568231c6568 310628 preview-latex-style_11.86-12_all.deb
Files: 
 60c9a286b47122481e8d64612684a67f 1346 tex optional auctex_11.86-12.dsc
 8983ecf2cbfef11ee22ef8479bf83798 59265 tex optional auctex_11.86-12.debian.tar.gz
 bc02a1f84c41f8aa30b8dc41df6a690b 1247250 tex optional auctex_11.86-12_all.deb
 a5ddab42a0e0fd7d7b1f517b1352b07c 310628 tex optional preview-latex-style_11.86-12_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: http://www.linux.it/~salve/dgms.gpg

iEYEARECAAYFAlC2mKYACgkQISswbJOWhl0jFwCfW1zl/WdgKpaXlhSL6PPF2WV9
tM8An1kVgrOGO1HVHNDuYpZ7FzHFyi2o
=VkEs
-----END PGP SIGNATURE-----




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 27 Dec 2012 07:25:57 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 16 11:45:10 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.