Debian Bug report logs - #680636
missing desktop file to auto-start xbrlapi in the gdm3 greeter

version graph

Package: xbrlapi; Maintainer for xbrlapi is Debian Accessibility Team <debian-accessibility@lists.debian.org>; Source for xbrlapi is src:brltty.

Reported by: Jean-Philippe MENGUAL <texou@accelibreinfo.eu>

Date: Sat, 7 Jul 2012 15:03:14 UTC

Severity: important

Found in version brltty/4.4-9

Fixed in version brltty/4.4-10

Done: Samuel Thibault <sthibault@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#680636; Package gdm3. (Sat, 07 Jul 2012 15:03:17 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jean-Philippe MENGUAL <texou@accelibreinfo.eu>:
New Bug report received and forwarded. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Sat, 07 Jul 2012 15:03:21 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Jean-Philippe MENGUAL <texou@accelibreinfo.eu>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: gdm3: I cannot use my braille keyboard
Date: Sat, 07 Jul 2012 16:30:31 +0200
Package: gdm3
Version: 3.4.1-2
Severity: important

Dear Maintainer,
*** Please consider answering these questions, where appropriate ***

   * What led up to the situation? I started gdm3 after brltty. Brltty displays: "screen not in teut mode", it's expected.

   * What exactly did you do (or not do) that was effective (or
     ineffective)? I tried entering login and password with a braille keyboard instead of classical keyboard. It has always worked.

   * What was the outcome of this action? No character was entered.

   * What outcome did you expect instead? It should have been writen some letters or some stars


*** End of the template - remove these lines ***

Thanks for your answer.


-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-2-686-pae (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gdm3 depends on:
ii  accountsservice                             0.6.21-5
ii  adduser                                     3.113+nmu3
ii  dconf-gsettings-backend                     0.12.1-2
ii  dconf-tools                                 0.12.1-2
ii  debconf [debconf-2.0]                       1.5.44
ii  dpkg                                        1.16.4.3
ii  gir1.2-freedesktop                          1.32.1-1
ii  gir1.2-glib-2.0                             1.32.1-1
ii  gnome-session [x-session-manager]           3.4.2.1-1
ii  gnome-session-bin                           3.4.2.1-1
ii  gnome-session-fallback [x-session-manager]  3.4.2.1-1
ii  gnome-settings-daemon                       3.4.2-3
ii  gnome-terminal [x-terminal-emulator]        3.4.1.1-1
ii  gsettings-desktop-schemas                   3.4.2-1
ii  libaccountsservice0                         0.6.21-5
ii  libatk1.0-0                                 2.4.0-2
ii  libattr1                                    1:2.4.46-8
ii  libaudit0                                   1:1.7.18-1.1
ii  libc6                                       2.13-33
ii  libcairo-gobject2                           1.12.2-1
ii  libcairo2                                   1.12.2-1
ii  libcanberra-gtk3-0                          0.28-4
ii  libcanberra0                                0.28-4
ii  libdbus-1-3                                 1.6.0-1
ii  libdbus-glib-1-2                            0.100-1
ii  libfontconfig1                              2.9.0-6
ii  libgdk-pixbuf2.0-0                          2.26.1-1
ii  libglib2.0-0                                2.32.3-1
ii  libglib2.0-bin                              2.32.3-1
ii  libgtk-3-0                                  3.4.2-1
ii  libpam-modules                              1.1.3-7.1
ii  libpam-runtime                              1.1.3-7.1
ii  libpam0g                                    1.1.3-7.1
ii  libpango1.0-0                               1.30.0-1
ii  librsvg2-common                             2.36.1-1
ii  libselinux1                                 2.1.9-5
ii  libupower-glib1                             0.9.17-1
ii  libwrap0                                    7.6.q-23
ii  libx11-6                                    2:1.5.0-1
ii  libxau6                                     1:1.0.7-1
ii  libxdmcp6                                   1:1.1.1-1
ii  libxklavier16                               5.2.1-1
ii  libxrandr2                                  2:1.3.2-2
ii  lsb-base                                    4.1+Debian7
ii  metacity [x-window-manager]                 1:2.34.3-2
ii  policykit-1-gnome                           0.105-2
ii  upower                                      0.9.17-1
ii  x11-common                                  1:7.7+1
ii  x11-xserver-utils                           7.7~3
ii  xterm [x-terminal-emulator]                 278-1

Versions of packages gdm3 recommends:
ii  desktop-base             7.0.0
ii  gnome-icon-theme         3.4.0-2
ii  libatk-adaptor [at-spi]  2.5.2-1
ii  x11-xkb-utils            7.7~1
ii  xserver-xephyr           2:1.12.1.902-1
ii  xserver-xorg             1:7.7+1
ii  zenity                   3.4.0-2

Versions of packages gdm3 suggests:
ii  gnome-mag             1:0.16.3-1
ii  gnome-orca            3.4.2-2
ii  gnome-shell           3.4.1-8
pn  gok                   <none>
ii  libpam-gnome-keyring  3.4.1-4

-- debconf information:
* shared/default-x-display-manager: gdm3
  gdm3/daemon_name: /usr/sbin/gdm3




Information forwarded to debian-bugs-dist@lists.debian.org, debian-accessibility@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#680636; Package gdm3. (Wed, 11 Jul 2012 02:18:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jean-Philippe MENGUAL <texou@accelibreinfo.eu>:
Extra info received and forwarded to list. Copy sent to debian-accessibility@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 11 Jul 2012 02:18:04 GMT) Full text and rfc822 format available.

Message #10 received at 680636@bugs.debian.org (full text, mbox):

From: Jean-Philippe MENGUAL <texou@accelibreinfo.eu>
To: Debian Bug Tracking System <680636@bugs.debian.org>
Subject: Re: gdm3: I cannot use my braille keyboard
Date: Wed, 11 Jul 2012 00:39:41 +0200
Package: gdm3
Version: 3.4.1-2
Followup-For: Bug #680636

Hi,

After a search with Samuel, we realise that xbrlapi should be running. But we 
don't find how it can be run automatically by gdm3. See xbrlapi package and
xbrlapi.desktop: we put this file in /etc/X11/Xsession.d for user sessions. 
But we need it also for gdm sessions. 

Thanks,


-- System Information:
Debian Release: wheezy/sid
Architecture: i386 (i686)

Kernel: Linux 3.2.0-2-686-pae (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gdm3 depends on:
ii  accountsservice                             0.6.21-5
ii  adduser                                     3.113+nmu3
ii  dconf-gsettings-backend                     0.12.1-2
ii  dconf-tools                                 0.12.1-2
ii  debconf [debconf-2.0]                       1.5.45
ii  dpkg                                        1.16.7
ii  gir1.2-freedesktop                          1.32.1-1
ii  gir1.2-glib-2.0                             1.32.1-1
ii  gnome-session-bin                           3.4.2.1-1
ii  gnome-session-fallback [x-session-manager]  3.4.2.1-1
ii  gnome-settings-daemon                       3.4.2-3
ii  gnome-terminal [x-terminal-emulator]        3.4.1.1-1
ii  gsettings-desktop-schemas                   3.4.2-1
ii  libaccountsservice0                         0.6.21-5
ii  libatk1.0-0                                 2.4.0-2
ii  libattr1                                    1:2.4.46-8
ii  libaudit0                                   1:1.7.18-1.1
ii  libc6                                       2.13-34
ii  libcairo-gobject2                           1.12.2-2
ii  libcairo2                                   1.12.2-2
ii  libcanberra-gtk3-0                          0.28-4
ii  libcanberra0                                0.28-4
ii  libdbus-1-3                                 1.6.2-2
ii  libdbus-glib-1-2                            0.100-1
ii  libfontconfig1                              2.9.0-6
ii  libgdk-pixbuf2.0-0                          2.26.1-1
ii  libglib2.0-0                                2.32.3-1
ii  libglib2.0-bin                              2.32.3-1
ii  libgtk-3-0                                  3.4.2-2
ii  libpam-modules                              1.1.3-7.1
ii  libpam-runtime                              1.1.3-7.1
ii  libpam0g                                    1.1.3-7.1
ii  libpango1.0-0                               1.30.0-1
ii  librsvg2-common                             2.36.1-1
ii  libselinux1                                 2.1.9-5
ii  libupower-glib1                             0.9.17-1
ii  libwrap0                                    7.6.q-23
ii  libx11-6                                    2:1.5.0-1
ii  libxau6                                     1:1.0.7-1
ii  libxdmcp6                                   1:1.1.1-1
ii  libxklavier16                               5.2.1-1
ii  libxrandr2                                  2:1.3.2-2
ii  lsb-base                                    4.1+Debian7
ii  metacity [x-window-manager]                 1:2.34.3-2
ii  policykit-1-gnome                           0.105-2
ii  upower                                      0.9.17-1
ii  x11-common                                  1:7.7+1
ii  x11-xserver-utils                           7.7~3
ii  xfwm4 [x-window-manager]                    4.10.0-1
ii  xterm [x-terminal-emulator]                 278-1

Versions of packages gdm3 recommends:
ii  desktop-base             7.0.0
ii  gnome-icon-theme         3.4.0-2
ii  libatk-adaptor [at-spi]  2.5.3-1
ii  x11-xkb-utils            7.7~1
ii  xserver-xephyr           2:1.12.1.902-1
ii  xserver-xorg             1:7.7+1
ii  zenity                   3.4.0-2

Versions of packages gdm3 suggests:
ii  gnome-mag             1:0.16.3-1
ii  gnome-orca            3.4.2-2
pn  gnome-shell           <none>
pn  gok                   <none>
ii  libpam-gnome-keyring  3.4.1-4

-- debconf information excluded




Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#680636; Package gdm3. (Wed, 11 Jul 2012 02:48:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 11 Jul 2012 02:48:10 GMT) Full text and rfc822 format available.

Message #15 received at 680636@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Jean-Philippe MENGUAL <texou@accelibreinfo.eu>, 680636@bugs.debian.org
Subject: Re: Bug#680636: gdm3: I cannot use my braille keyboard
Date: Wed, 11 Jul 2012 04:44:44 +0200
[Message part 1 (text/plain, inline)]
On 11.07.2012 00:39, Jean-Philippe MENGUAL wrote:

> After a search with Samuel, we realise that xbrlapi should be running. But we 
> don't find how it can be run automatically by gdm3. See xbrlapi package and
> xbrlapi.desktop: we put this file in /etc/X11/Xsession.d for user sessions. 
> But we need it also for gdm sessions. 


You should be able to start applications in the gdm session by adding a
.desktop file to
/usr/share/gdm/greeter/applications/



-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#680636; Package gdm3. (Wed, 11 Jul 2012 08:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to 680636@bugs.debian.org:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 11 Jul 2012 08:15:05 GMT) Full text and rfc822 format available.

Message #20 received at 680636@bugs.debian.org (full text, mbox):

From: Josselin Mouette <joss@debian.org>
To: 680636@bugs.debian.org
Cc: Jean-Philippe MENGUAL <texou@accelibreinfo.eu>
Subject: Re: Bug#680636: gdm3: I cannot use my braille keyboard
Date: Wed, 11 Jul 2012 10:11:14 +0200
Le mercredi 11 juillet 2012 à 04:44 +0200, Michael Biebl a écrit : 
> On 11.07.2012 00:39, Jean-Philippe MENGUAL wrote:
> 
> > After a search with Samuel, we realise that xbrlapi should be running. But we 
> > don't find how it can be run automatically by gdm3. See xbrlapi package and
> > xbrlapi.desktop: we put this file in /etc/X11/Xsession.d for user sessions. 
> > But we need it also for gdm sessions. 
> 
> 
> You should be able to start applications in the gdm session by adding a
> .desktop file to
> /usr/share/gdm/greeter/applications/

I don’t think this is the correct way anymore. I’ll have a look but you
need to start it up as other components, and this might require
patching.

Cheers,
-- 
 .''`.      Josselin Mouette
: :' :
`. `'
  `-





Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#680636; Package gdm3. (Sun, 07 Apr 2013 20:54:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Emilio Pozuelo Monfort <pochu@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Sun, 07 Apr 2013 20:54:04 GMT) Full text and rfc822 format available.

Message #25 received at 680636@bugs.debian.org (full text, mbox):

From: Emilio Pozuelo Monfort <pochu@debian.org>
To: 680636@bugs.debian.org
Cc: Jean-Philippe MENGUAL <texou@accelibreinfo.eu>, Samuel Thibault <sthibault@debian.org>
Subject: Re: Bug#680636: gdm3: I cannot use my braille keyboard
Date: Sun, 07 Apr 2013 22:50:50 +0200
Hi,

I have fixed this bug by patching gnome-session and gdm3 to add back a directory 
where to place .desktop files that are started in the gdm session (for bug 
#689559). The only thing needed here is then to add that .desktop file to xbrlapi.

I have done that and tested it. xbrlapi is started in the gdm session, but it 
exits here because brltty1 is not available.

openConnection: connect: No such file or directory
cannot connect to brltty at :0

I suppose this is because I don't have the necessary hardware and that's a 
normal thing. In any case, could you test my changes and confirm they fix the 
bug for you? I have built i386 packages and put them (and the sources) at

http://people.debian.org/~pochu/a11y/

You need to install gnome-session*, gdm3 and xbrlapi, then restart gdm3.

I'll soon submit my gnome-session and gdm3 changes to debian-release.

Thanks,
Emilio



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#680636; Package gdm3. (Sun, 07 Apr 2013 21:54:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Emilio Pozuelo Monfort <pochu@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Sun, 07 Apr 2013 21:54:05 GMT) Full text and rfc822 format available.

Message #30 received at 680636@bugs.debian.org (full text, mbox):

From: Emilio Pozuelo Monfort <pochu@debian.org>
To: 680636@bugs.debian.org
Cc: Jean-Philippe MENGUAL <texou@accelibreinfo.eu>, Samuel Thibault <sthibault@debian.org>
Subject: Re: Bug#680636: gdm3: I cannot use my braille keyboard
Date: Sun, 07 Apr 2013 23:51:11 +0200
[Message part 1 (text/plain, inline)]
On 04/07/2013 10:50 PM, Emilio Pozuelo Monfort wrote:
> Hi,
>
> I have fixed this bug by patching gnome-session and gdm3 to add back a directory
> where to place .desktop files that are started in the gdm session (for bug
> #689559). The only thing needed here is then to add that .desktop file to xbrlapi.

btw here's the debdiff. The commented line in the .desktop file can go away.

Cheers,
Emilio
[brltty.debdiff (application/x-extension-debdiff, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#680636; Package gdm3. (Tue, 09 Apr 2013 23:33:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Samuel Thibault <sthibault@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 09 Apr 2013 23:33:04 GMT) Full text and rfc822 format available.

Message #35 received at 680636@bugs.debian.org (full text, mbox):

From: Samuel Thibault <sthibault@debian.org>
To: Emilio Pozuelo Monfort <pochu@debian.org>
Cc: 680636@bugs.debian.org, Jean-Philippe MENGUAL <texou@accelibreinfo.eu>
Subject: Re: Bug#680636: gdm3: I cannot use my braille keyboard
Date: Wed, 10 Apr 2013 01:28:38 +0200
Hello,

Emilio Pozuelo Monfort, le Sun 07 Apr 2013 22:50:50 +0200, a écrit :
> I have fixed this bug by patching gnome-session and gdm3 to add back a
> directory where to place .desktop files that are started in the gdm session
> (for bug #689559).

Oh! Great! I was indeed sad that gdm would not be accessible.

> I have done that and tested it. xbrlapi is started in the gdm session, but
> it exits here because brltty1 is not available.
> 
> openConnection: connect: No such file or directory
> cannot connect to brltty at :0
> 
> I suppose this is because I don't have the necessary hardware and that's a
> normal thing.

Yes. Although you can for instance configure brltty to use its TTY
driver and use e.g. a named pipe as device.

Samuel



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#680636; Package gdm3. (Mon, 15 Apr 2013 08:42:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Raphael Hertzog <hertzog@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Mon, 15 Apr 2013 08:42:04 GMT) Full text and rfc822 format available.

Message #40 received at 680636@bugs.debian.org (full text, mbox):

From: Raphael Hertzog <hertzog@debian.org>
To: Emilio Pozuelo Monfort <pochu@debian.org>, 680636@bugs.debian.org
Cc: Jean-Philippe MENGUAL <texou@accelibreinfo.eu>, Samuel Thibault <sthibault@debian.org>
Subject: Re: Bug#680636: gdm3: I cannot use my braille keyboard
Date: Mon, 15 Apr 2013 10:39:34 +0200
Control: reassign -1 xbrlapi 4.4-9
Control: severity -1 important
Control: retitle -1 missing desktop file to auto-start xbrlapi in the gdm3 greeter

On Sun, 07 Apr 2013, Emilio Pozuelo Monfort wrote:
> gdm session (for bug #689559). The only thing needed here is then to
> add that .desktop file to xbrlapi.

This .desktop file has been added upstream already, cf
http://mielke.cc/pipermail/brltty/2013-April/010061.html

Samuel, Mario, can we get this .desktop file in the unstable version of
the package so that it can be unblocked together with
gnome-session/3.4.2.1-4 gdm3/3.4.1-7 (cf #704934) ?

Thank you in advance!
-- 
Raphaël Hertzog ◈ Debian Developer

Get the Debian Administrator's Handbook:
→ http://debian-handbook.info/get/



Bug reassigned from package 'gdm3' to 'xbrlapi'. Request was from Raphael Hertzog <hertzog@debian.org> to 680636-submit@bugs.debian.org. (Mon, 15 Apr 2013 08:42:04 GMT) Full text and rfc822 format available.

No longer marked as found in versions gdm3/3.4.1-2. Request was from Raphael Hertzog <hertzog@debian.org> to 680636-submit@bugs.debian.org. (Mon, 15 Apr 2013 08:42:05 GMT) Full text and rfc822 format available.

Marked as found in versions brltty/4.4-9. Request was from Raphael Hertzog <hertzog@debian.org> to 680636-submit@bugs.debian.org. (Mon, 15 Apr 2013 08:42:05 GMT) Full text and rfc822 format available.

Changed Bug title to 'missing desktop file to auto-start xbrlapi in the gdm3 greeter' from 'gdm3: I cannot use my braille keyboard' Request was from Raphael Hertzog <hertzog@debian.org> to 680636-submit@bugs.debian.org. (Mon, 15 Apr 2013 08:42:06 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Accessibility Team <debian-accessibility@lists.debian.org>:
Bug#680636; Package xbrlapi. (Mon, 15 Apr 2013 23:15:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Samuel Thibault <sthibault@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Accessibility Team <debian-accessibility@lists.debian.org>. (Mon, 15 Apr 2013 23:15:04 GMT) Full text and rfc822 format available.

Message #53 received at 680636@bugs.debian.org (full text, mbox):

From: Samuel Thibault <sthibault@debian.org>
To: Raphael Hertzog <hertzog@debian.org>
Cc: Emilio Pozuelo Monfort <pochu@debian.org>, 680636@bugs.debian.org, Jean-Philippe MENGUAL <texou@accelibreinfo.eu>
Subject: Re: Bug#680636: gdm3: I cannot use my braille keyboard
Date: Tue, 16 Apr 2013 01:05:55 +0200
Control: tags -1 + pending

Hello,

Raphael Hertzog, le Mon 15 Apr 2013 10:39:34 +0200, a écrit :
> On Sun, 07 Apr 2013, Emilio Pozuelo Monfort wrote:
> > gdm session (for bug #689559). The only thing needed here is then to
> > add that .desktop file to xbrlapi.
> 
> This .desktop file has been added upstream already, cf
> http://mielke.cc/pipermail/brltty/2013-April/010061.html
> 
> Samuel, Mario, can we get this .desktop file in the unstable version of
> the package so that it can be unblocked together with
> gnome-session/3.4.2.1-4 gdm3/3.4.1-7 (cf #704934) ?

I have now uploaded it.

Since this case (xbrlapi not started) is only an inconvenience for the
user, not a stopper, I guess we would target r1, not r0?

Samuel



Added tag(s) pending. Request was from Samuel Thibault <sthibault@debian.org> to 680636-submit@bugs.debian.org. (Mon, 15 Apr 2013 23:15:04 GMT) Full text and rfc822 format available.

Reply sent to Samuel Thibault <sthibault@debian.org>:
You have taken responsibility. (Mon, 15 Apr 2013 23:21:18 GMT) Full text and rfc822 format available.

Notification sent to Jean-Philippe MENGUAL <texou@accelibreinfo.eu>:
Bug acknowledged by developer. (Mon, 15 Apr 2013 23:21:19 GMT) Full text and rfc822 format available.

Message #60 received at 680636-close@bugs.debian.org (full text, mbox):

From: Samuel Thibault <sthibault@debian.org>
To: 680636-close@bugs.debian.org
Subject: Bug#680636: fixed in brltty 4.4-10
Date: Mon, 15 Apr 2013 23:17:45 +0000
Source: brltty
Source-Version: 4.4-10

We believe that the bug you reported is fixed in the latest version of
brltty, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 680636@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Samuel Thibault <sthibault@debian.org> (supplier of updated brltty package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Mon, 15 Apr 2013 21:42:05 +0200
Source: brltty
Binary: brltty brltty-dbg libbrlapi0.5 libbrlapi-dbg libbrlapi-dev libbrlapi-jni libbrlapi-java brltty-flite brltty-speechd brltty-espeak brltty-udeb brltty-x11 xbrlapi cl-brlapi python-brlapi
Architecture: source amd64 all
Version: 4.4-10
Distribution: unstable
Urgency: low
Maintainer: Debian Accessibility Team <debian-accessibility@lists.debian.org>
Changed-By: Samuel Thibault <sthibault@debian.org>
Description: 
 brltty     - Access software for a blind person using a braille display
 brltty-dbg - debugging symbols for brltty
 brltty-espeak - Access software for a blind person - espeak driver
 brltty-flite - Access software for a blind person - Flite speech driver
 brltty-speechd - Access software for a blind person - Speech Dispatcher driver
 brltty-udeb - Access software for a blind person using a braille display (udeb)
 brltty-x11 - Access software for a blind person using a braille display - X11
 cl-brlapi  - Common Lisp bindings for BrlAPI
 libbrlapi-dbg - braille display access via BRLTTY - shared library debugging symb
 libbrlapi-dev - Library for communication with BRLTTY - static libs and headers
 libbrlapi-java - Java bindings for BrlAPI
 libbrlapi-jni - Java bindings for BrlAPI (native library)
 libbrlapi0.5 - braille display access via BRLTTY - shared library
 python-brlapi - Python bindings for BrlAPI
 xbrlapi    - Access software for a blind person using a braille display - xbrl
Closes: 680636
Changes: 
 brltty (4.4-10) unstable; urgency=low
 .
   * Add xbrlapi.desktop file to gdm session to get braille keyboard input
     working. Closes: #680636.
Checksums-Sha1: 
 be905cc7bb582dc740ce7cd8be4b91e34b5e9bb7 2985 brltty_4.4-10.dsc
 0346b2e357643cebd2f9d88cb5ffd018f9f31dcb 33927 brltty_4.4-10.debian.tar.gz
 9109d542f4f11dda81ddea4a86cec186a3be9361 1727636 brltty_4.4-10_amd64.deb
 a4aa3b427d954fc875a412f7be98d1f9682d24e2 962970 brltty-dbg_4.4-10_amd64.deb
 8ad3a0e9c6aaf4c87de45e99a39751ce2ea98da2 79810 libbrlapi0.5_4.4-10_amd64.deb
 bc7b05f2fc34b7d333fcac93f773ff5e8d8a3566 178074 libbrlapi-dbg_4.4-10_amd64.deb
 6e75bdadce796ea66cb6a2aeeadc380fe205ceb6 205080 libbrlapi-dev_4.4-10_amd64.deb
 614f083b5284fdd91e686747271434ed93706154 69908 libbrlapi-jni_4.4-10_amd64.deb
 b3c8fb37df14e3a85ad7215faa7bcd867fbf403b 63948 brltty-flite_4.4-10_amd64.deb
 ec94bf3fbefe9f4c1f616290677f2f2c29799f19 64800 brltty-speechd_4.4-10_amd64.deb
 259a4c3f3e50cedf7c4225b706478d966f49732d 63984 brltty-espeak_4.4-10_amd64.deb
 815f4783360d2a07582d53ae0b7881415f63073c 81776 brltty-x11_4.4-10_amd64.deb
 3b2cd7ee7b2b18a8d36deec13d4ad2ae3b5ccb07 152560 xbrlapi_4.4-10_amd64.deb
 6395fda263ee4306cd4c619ef99bd0640cf02b6f 106866 python-brlapi_4.4-10_amd64.deb
 52cad73b9d84fb2f21a84b1c47b2366f57700752 117012 libbrlapi-java_4.4-10_all.deb
 b27439a7b044845b50b6d24b045b2408c82a15cb 63388 cl-brlapi_4.4-10_all.deb
 4eb177666b34b3f0de6cd4bd4adcd6589c7cc598 241588 brltty-udeb_4.4-10_amd64.udeb
Checksums-Sha256: 
 157048d01ac0f7367a00e581bf88ce2b7753c9e05f8ad5185448e57c768b692d 2985 brltty_4.4-10.dsc
 a82874db24e24a6b606a92d8eafa601488797d811cb68ceed068f949df900a1a 33927 brltty_4.4-10.debian.tar.gz
 f4c7460e8d81498bff4a25a1258320feafd95ebd95229472da0e8e852b4e1d54 1727636 brltty_4.4-10_amd64.deb
 52ed0968de5b010e496f92e4d0ef8e105372a2f61d4340a2214d086e73ea005b 962970 brltty-dbg_4.4-10_amd64.deb
 8a8ad2fe95fc3065cc196ebf9f2f6422a6b9a00ac38c3901ea9eb0be8668f5f5 79810 libbrlapi0.5_4.4-10_amd64.deb
 f1b39a853bf43058b27ee8e580b72423f27f058c99f433437c404deeba6d5675 178074 libbrlapi-dbg_4.4-10_amd64.deb
 a0fbc12e8b155d6a2ea83e03e0cb0ef2b3cb49b4e973d982b08f93642fd0ffb7 205080 libbrlapi-dev_4.4-10_amd64.deb
 6d02b01d5f495fd97fe70ad9c71b03d77c94a98eb66f2e9200ba93be2d53db71 69908 libbrlapi-jni_4.4-10_amd64.deb
 f4d0c9320c05753dca9309833daa22bfa878caf130c532fb17017608e464cc2a 63948 brltty-flite_4.4-10_amd64.deb
 b3c290161672bbf1311a25e36c7b89616a72fb33eb54a70420eb1d3c3060c94d 64800 brltty-speechd_4.4-10_amd64.deb
 c281fc5e4c24d196731efa2bfecbedbf76f8993b436ade23f71e62bb59e7f0d1 63984 brltty-espeak_4.4-10_amd64.deb
 254f4d2dfa07b66ab1bb0c6242e0eae2cfd2f20f1753167feed7dc1ce27a7b41 81776 brltty-x11_4.4-10_amd64.deb
 5b9eb4edd7b55a6fd97a6ee6495742eeea784357670ddf15e792bf33a2454f61 152560 xbrlapi_4.4-10_amd64.deb
 c20674fa998f219c835f83d3a4783cc6d617699f3498135ea5f33ac315f24c33 106866 python-brlapi_4.4-10_amd64.deb
 373f91ef0fc8080e6aa87d27400dcb111e5d52ddd994b90ad88c34ee98bfea67 117012 libbrlapi-java_4.4-10_all.deb
 afd5014e24e74831f2d7a313337a1961f5501572243c9de5e4fa971950c0014a 63388 cl-brlapi_4.4-10_all.deb
 ebcb104a521f8e430c54f3e072daab5ebc07cafa6570924562a0b2376a992920 241588 brltty-udeb_4.4-10_amd64.udeb
Files: 
 75ab263f8fbd3cf3c58392b636968fc7 2985 admin extra brltty_4.4-10.dsc
 9d82938bdd87e4c1309503ca3610726b 33927 admin extra brltty_4.4-10.debian.tar.gz
 62372b7f53fa07e04e7d29c2be443428 1727636 admin extra brltty_4.4-10_amd64.deb
 1cf540c5c4ce0a9819ab9b982a1566eb 962970 debug extra brltty-dbg_4.4-10_amd64.deb
 370a124ff51f2746cd2e90119ba748aa 79810 libs extra libbrlapi0.5_4.4-10_amd64.deb
 1579795dad7fc17805def82b3951c803 178074 debug extra libbrlapi-dbg_4.4-10_amd64.deb
 c88d22228020033511abf5a081bb69d8 205080 libdevel extra libbrlapi-dev_4.4-10_amd64.deb
 1804e4ec3d34785cc4989144b67b3eec 69908 libs extra libbrlapi-jni_4.4-10_amd64.deb
 68a6f67bafc29eb5ca4f92b3d6516460 63948 admin extra brltty-flite_4.4-10_amd64.deb
 e6e7adbc3e3e14937317670abdb4723f 64800 admin extra brltty-speechd_4.4-10_amd64.deb
 0954493c1366ae5343288efd03c43397 63984 admin extra brltty-espeak_4.4-10_amd64.deb
 ecb0209b90b6315c967dc996907e6295 81776 admin extra brltty-x11_4.4-10_amd64.deb
 2ef9a9144e162e021eb1e453e14340ec 152560 admin extra xbrlapi_4.4-10_amd64.deb
 ca60663c93d91ece5bf18b4fcfa124f1 106866 python extra python-brlapi_4.4-10_amd64.deb
 974c8be9c2ea90bf9fcb98f6fdd262e8 117012 java extra libbrlapi-java_4.4-10_all.deb
 f751926f8e3b1a5e1de2230bec97ee99 63388 lisp extra cl-brlapi_4.4-10_all.deb
 f4a3d7a77e74e873a6473e69f69112fc 241588 debian-installer extra brltty-udeb_4.4-10_amd64.udeb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCgAGBQJRbIMuAAoJECqpogBB8bdXjBoQAIE5wvlvvNehXbVu/5yMNnIy
ciNA47ag29CCSQsaNA4cwiMQDdh3uiE3xiY5N/qv3a2jp6ONIkqDAmwxEF46kpbA
VEYCIOXQaN5HyLMdZd4u2YwuvNSvdBUeSTTSvLkZz5Vy8Mjx1Z+u/w1jb3mOJsBA
ATfdMCvLhPNxqdlRGb9Xpa4010L3REhZhnjwFAeLVcS+w66TwwJBp2SdwNerdxi+
0lIahJrRzpbUnUm6Qp+ejm5VlCyN5l8K8lsYxB4t239vudZCB7yRuBJtj8eyUlXq
HzlxDiXey7KNdm3EWnzpVIBfKINnTgAmPIqew2cs6DJdndhVqp3EKlZICZF30Gw2
MojDK3sCf5qFffccLcq2dJyGZlKBByvCbFP5fYUx0PVtqfvmci2zCPuHwDmteFtN
onyGBdCU75LKXfeqe07O4vCm0dVHFFiM/669m2/kX8XaTK9aVT+Bjr+MGJh8JhvS
V+K4MxTcgdkI1knwppA6ylLFvyEQVsFf3ByEgDZkks/z4uk79znfqr0AWpeXFoVj
9Ro7U13d95xtSLSzudDmx368mzDrp5D8wzeg9+UpDQaX+dBradkORQ3Hy72zbwmO
WS4fCvVke+HRxiWYGJZO6segZYVPReZPSHDRz49ZPcsWhboZBPH1Vvu9nUfjrCrR
o7yfNh/VHoWVnC400e3S
=DREP
-----END PGP SIGNATURE-----




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Accessibility Team <debian-accessibility@lists.debian.org>:
Bug#680636; Package xbrlapi. (Tue, 16 Apr 2013 00:15:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Emilio Pozuelo Monfort <pochu@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Accessibility Team <debian-accessibility@lists.debian.org>. (Tue, 16 Apr 2013 00:15:04 GMT) Full text and rfc822 format available.

Message #65 received at 680636@bugs.debian.org (full text, mbox):

From: Emilio Pozuelo Monfort <pochu@debian.org>
To: Samuel Thibault <sthibault@debian.org>
Cc: Raphael Hertzog <hertzog@debian.org>, 680636@bugs.debian.org, Jean-Philippe MENGUAL <texou@accelibreinfo.eu>
Subject: Re: Bug#680636: gdm3: I cannot use my braille keyboard
Date: Tue, 16 Apr 2013 02:14:05 +0200
On 04/16/2013 01:05 AM, Samuel Thibault wrote:
> Since this case (xbrlapi not started) is only an inconvenience for the
> user, not a stopper, I guess we would target r1, not r0?

This change is trivial and fixes an important bug so it might be accepted for r0.

Regards,
Emilio



Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Fri, 17 May 2013 07:30:25 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 01:03:07 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.