Debian Bug report logs - #679085
wpasupplicant: [REGRESSION 0.7.3-6 => 1.0-2] WPA-PSK + openmoko: unable to get DHCPACK

version graph

Package: wpasupplicant; Maintainer for wpasupplicant is Debian/Ubuntu wpasupplicant Maintainers <pkg-wpa-devel@lists.alioth.debian.org>; Source for wpasupplicant is src:wpa.

Reported by: Timo Juhani Lindfors <timo.lindfors@iki.fi>

Date: Tue, 26 Jun 2012 09:24:02 UTC

Severity: normal

Found in version wpa/1.0-2

Forwarded to http://w1.fi/bugz/show_bug.cgi?id=456

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian/Ubuntu wpasupplicant Maintainers <pkg-wpa-devel@lists.alioth.debian.org>:
Bug#679085; Package wpasupplicant. (Tue, 26 Jun 2012 09:24:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Timo Juhani Lindfors <timo.lindfors@iki.fi>:
New Bug report received and forwarded. Copy sent to Debian/Ubuntu wpasupplicant Maintainers <pkg-wpa-devel@lists.alioth.debian.org>. (Tue, 26 Jun 2012 09:24:06 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Timo Juhani Lindfors <timo.lindfors@iki.fi>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: wpasupplicant: [REGRESSION 0.7.3-6 => 1.0-2] WPA-PSK + openmoko: unable to get DHCPACK
Date: Tue, 26 Jun 2012 12:21:38 +0300
Package: wpasupplicant
Version: 0.7.3-6
Severity: normal

Steps to reproduce:
1) On an openmoko freerunner phone I run

sudo killall dhclient
sudo killall wpa_supplicant
om wifi power 0
sleep 4
om wifi power 1
sleep 4
om wifi maxperf wlan 1
sleep 4
sudo /sbin/wpa_supplicant -B -f /tmp/wpasupplicant.log -P /var/run/wpa_supplicant.wlan.pid -i wlan -D wext -t -ddd -C /var/run/wpa_supplicant
sleep 4
sudo wpa_cli -p /var/run/wpa_supplicant -i wlan add_network
sleep 4
sudo wpa_cli -p /var/run/wpa_supplicant -i wlan set_network 0 ssid "\"SoneraGateway00-26-44-A1-45-A9\""
sleep 4
sudo wpa_cli -p /var/run/wpa_supplicant -i wlan set_network 0 psk "\"Thaeret0\""
sleep 4
sudo wpa_cli -p /var/run/wpa_supplicant -i wlan enable_network 0
sleep 4
sleep 4
sudo dhclient -d wlan

Expected results:
1) dhclient reports DHCPACK

Actual results:
1) dhclient reports "No DHCPOFFERS received."

More info:
1) The kernel is

http://pkg-fso.alioth.debian.org/debian/pool/main/l/linux-2.6-openmoko/linux-image-2.6.34-openmoko-gta02_20101212.git049b71de-2_armel.deb

2) The wifi hardware is from atheros and supported using (out-of-tree)
   CONFIG_AR6000_WLAN=y.

3) I booted the system six times and saved syslog and wpa debug
   log. First three times with 0.7.3-6 and then three times with
   1.0-2. Results are consistent:

attempt | wpasupplicant | result
1       | 0.7.3-6       | WORKS: http://lindi.iki.fi/lindi/wpasupplicant/boot1-syslog.txt
        |               | http://lindi.iki.fi/lindi/wpasupplicant/boot1-wpa.txt
2       | 0.7.3-6       | WORKS: http://lindi.iki.fi/lindi/wpasupplicant/boot2-syslog.txt
        |               | http://lindi.iki.fi/lindi/wpasupplicant/boot2-wpa.txt
3       | 0.7.3-6       | WORKS: http://lindi.iki.fi/lindi/wpasupplicant/boot3-syslog.txt
        |               | http://lindi.iki.fi/lindi/wpasupplicant/boot3-wpa.txt
4       | 1.0-2         | FAILS: http://lindi.iki.fi/lindi/wpasupplicant/boot4-syslog.txt
        |               | http://lindi.iki.fi/lindi/wpasupplicant/boot4-wpa.txt
5       | 1.0-2         | FAILS: http://lindi.iki.fi/lindi/wpasupplicant/boot5-syslog.txt
        |               | http://lindi.iki.fi/lindi/wpasupplicant/boot5-wpa.txt
6       | 1.0-2         | FAILS: http://lindi.iki.fi/lindi/wpasupplicant/boot6-syslog.txt
        |               | http://lindi.iki.fi/lindi/wpasupplicant/boot6-wpa.txt

Is there some more information that I should provide?

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: armel (armv4tl)

Kernel: Linux 2.6.34-20101212.git049b71de
Locale: LANG=C, LC_CTYPE=fi_FI.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages wpasupplicant depends on:
ii  adduser           3.113+nmu3
ii  initscripts       2.88dsf-27
ii  libc6             2.13-33
ii  libdbus-1-3       1.6.0-1
ii  libnl-3-200       3.2.7-2
ii  libnl-genl-3-200  3.2.7-2
ii  libpcsclite1      1.8.3-3
ii  libreadline6      6.2-8
ii  libssl1.0.0       1.0.1c-3
ii  lsb-base          4.1+Debian7

wpasupplicant recommends no packages.

Versions of packages wpasupplicant suggests:
pn  libengine-pkcs11-openssl  <none>
pn  wpagui                    <none>

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Debian/Ubuntu wpasupplicant Maintainers <pkg-wpa-devel@lists.alioth.debian.org>:
Bug#679085; Package wpasupplicant. (Tue, 26 Jun 2012 10:39:15 GMT) Full text and rfc822 format available.

Acknowledgement sent to Timo Juhani Lindfors <timo.lindfors@iki.fi>:
Extra info received and forwarded to list. Copy sent to Debian/Ubuntu wpasupplicant Maintainers <pkg-wpa-devel@lists.alioth.debian.org>. (Tue, 26 Jun 2012 10:39:21 GMT) Full text and rfc822 format available.

Message #10 received at 679085@bugs.debian.org (full text, mbox):

From: Timo Juhani Lindfors <timo.lindfors@iki.fi>
To: 679085@bugs.debian.org
Cc: control@bugs.debian.org
Subject: #679085 wpasupplicant: [REGRESSION 0.7.3-6 => 1.0-2] WPA-PSK + openmoko: unable to get DHCPACK
Date: Tue, 26 Jun 2012 13:38:33 +0300
package wpasupplicant
forwarded 679085 http://w1.fi/bugz/show_bug.cgi?id=456
found 679085 1.0-2
notfound 679085 0.7.3-6
thanks

I forwarded the bug upstream to http://w1.fi/bugz/show_bug.cgi?id=456





Set Bug forwarded-to-address to 'http://w1.fi/bugz/show_bug.cgi?id=456'. Request was from Timo Juhani Lindfors <timo.lindfors@iki.fi> to control@bugs.debian.org. (Tue, 26 Jun 2012 10:39:28 GMT) Full text and rfc822 format available.

Marked as found in versions wpa/1.0-2. Request was from Timo Juhani Lindfors <timo.lindfors@iki.fi> to control@bugs.debian.org. (Tue, 26 Jun 2012 10:39:32 GMT) Full text and rfc822 format available.

No longer marked as found in versions wpasupplicant/0.7.3-6. Request was from Timo Juhani Lindfors <timo.lindfors@iki.fi> to control@bugs.debian.org. (Tue, 26 Jun 2012 10:39:33 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 06:24:19 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.