Debian Bug report logs - #678269
sup-mail: Sup doesnt start anymore on Sid with ruby1.9

version graph

Package: sup-mail; Maintainer for sup-mail is Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>; Source for sup-mail is src:sup-mail.

Reported by: Johannes Schauer <j.schauer@email.de>

Date: Wed, 20 Jun 2012 13:45:02 UTC

Severity: grave

Found in version sup-mail/0.12.1-1

Fixed in version sup-mail/0.12.1+git20120407.aaa852f-1

Done: Per Andersson <avtobiff@gmail.com>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Decklin Foster <decklin@red-bean.com>:
Bug#678269; Package sup-mail. (Wed, 20 Jun 2012 13:45:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Johannes Schauer <j.schauer@email.de>:
New Bug report received and forwarded. Copy sent to Decklin Foster <decklin@red-bean.com>. (Wed, 20 Jun 2012 13:45:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Johannes Schauer <j.schauer@email.de>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: sup-mail: Sup doesnt start anymore on Sid with ruby1.9
Date: Wed, 20 Jun 2012 15:41:46 +0200
Package: sup-mail
Version: 0.12.1-1
Severity: grave
Justification: renders package unusable

Hi,

sup-mail will not start anymore with a fresh Debian Sid installation, as
its dependencies pull in ruby1.9 through the ruby dependency.

After apt-get install sup-mail, starting sup-mail results into the following:

/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- sup (LoadError)
	from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
	from /usr/bin/sup-mail:20:in `<main>'

A solution would be, to make it depend on ruby1.8 instead of ruby, or
change the shebang line in /usr/bin/sup-mail to /usr/bin/ruby1.8 instead
of using /usr/bin/env ruby.

Moving /usr/lib/ruby/1.8/sup.rb into /usr/lib/ruby/1.9.1/sup.rb will not
help due to other version specific issues.

cheers, josch




Information forwarded to debian-bugs-dist@lists.debian.org, Decklin Foster <decklin@red-bean.com>:
Bug#678269; Package sup-mail. (Thu, 21 Jun 2012 16:11:42 GMT) Full text and rfc822 format available.

Acknowledgement sent to Per Andersson <avtobiff@gmail.com>:
Extra info received and forwarded to list. Copy sent to Decklin Foster <decklin@red-bean.com>. (Thu, 21 Jun 2012 16:11:44 GMT) Full text and rfc822 format available.

Message #10 received at 678269@bugs.debian.org (full text, mbox):

From: Per Andersson <avtobiff@gmail.com>
To: 678269@bugs.debian.org
Cc: Andrea Veri <and@debian.org>
Subject: .
Date: Thu, 21 Jun 2012 17:59:10 +0200
tag 678269 + pending
kthxbye

Hi!

There is a new version of sup-mail Debian package in the working.
The new package (and some of it's dependencies I might add) is
patched to run with Ruby 1.9.1.

It is pending an upload and just waiting for dependencies to be
accepted.

See the changelog at the packaging repository. [0]

[0] http://anonscm.debian.org/gitweb/?p=pkg-ruby-extras/sup-mail.git;a=blob_plain;f=debian/changelog;hb=HEAD


Best,
Per




Marked as fixed in versions sup-mail/0.12.1+git20120407.aaa852f-1. Request was from Per Andersson <avtobiff@gmail.com> to control@bugs.debian.org. (Thu, 28 Jun 2012 21:51:09 GMT) Full text and rfc822 format available.

Marked Bug as done Request was from Per Andersson <avtobiff@gmail.com> to control@bugs.debian.org. (Thu, 28 Jun 2012 21:51:10 GMT) Full text and rfc822 format available.

Notification sent to Johannes Schauer <j.schauer@email.de>:
Bug acknowledged by developer. (Thu, 28 Jun 2012 21:51:11 GMT) Full text and rfc822 format available.

Message sent on to Johannes Schauer <j.schauer@email.de>:
Bug#678269. (Thu, 28 Jun 2012 21:51:13 GMT) Full text and rfc822 format available.

Message #19 received at 678269-submitter@bugs.debian.org (full text, mbox):

From: Per Andersson <avtobiff@gmail.com>
To: control@bugs.debian.org
Cc: 678269-submitter@bugs.debian.org
Subject: closing 678269
Date: Thu, 28 Jun 2012 23:28:44 +0200
close 678269 0.12.1+git20120407.aaa852f-1
thanks

Current version of sup-mail runs with Ruby 1.9.1, thus closing.


--
Per





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 06 Aug 2012 07:33:32 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 15:20:03 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.