Debian Bug report logs - #677407
gnome-dbg: fails to upgrade from squeeze - apt does not find an upgrade path

version graph

Package: gnome-core; Maintainer for gnome-core is Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>; Source for gnome-core is src:meta-gnome3.

Reported by: Andreas Beckmann <anbe@debian.org>

Date: Wed, 13 Jun 2012 17:30:02 UTC

Severity: serious

Tags: wheezy

Found in versions meta-gnome3/1:3.4+4, meta-gnome3/1:3.4+5, meta-gnome3/1:3.4+7, meta-gnome3/1:3.4+1, meta-gnome3/1:3.4+6, meta-gnome3/1:3.0+9

Done: Julien Cristau <jcristau@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-dbg. (Wed, 13 Jun 2012 17:30:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
New Bug report received and forwarded. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 13 Jun 2012 17:30:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: gnome-dbg: fails to upgrade from squeeze - apt does not find an upgrade path
Date: Wed, 13 Jun 2012 19:26:42 +0200
[Message part 1 (text/plain, inline)]
Package: gnome-dbg
Version: 1:3.0+9
Severity: serious
User: debian-qa@lists.debian.org
Usertags: piuparts

Hi,

during a test with piuparts I noticed your package fails to upgrade from
'squeeze'.
It installed fine in 'squeeze', then the upgrade to 'wheezy' fails.

>From the attached log (scroll to the bottom...):

  The following packages have unmet dependencies:
   eog-dbg : Depends: eog (= 3.4.1-2) but 2.30.2-1 is to be installed
   libglib2.0-0 : Breaks: eog (< 3.2.2-3) but 2.30.2-1 is to be installed
  E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

The full output from Debug::pkgProblemResolver is included in the logfile.

cheers,

Andreas
[gnome-dbg.log.gz (application/x-gzip, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-dbg. (Wed, 13 Jun 2012 18:15:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 13 Jun 2012 18:15:02 GMT) Full text and rfc822 format available.

Message #10 received at 677407@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Andreas Beckmann <debian@abeckmann.de>, 677407@bugs.debian.org, apt@packages.debian.org
Subject: Re: Bug#677407: gnome-dbg: fails to upgrade from squeeze - apt does not find an upgrade path
Date: Wed, 13 Jun 2012 20:13:16 +0200
[Message part 1 (text/plain, inline)]
On 13.06.2012 19:26, Andreas Beckmann wrote:
> Package: gnome-dbg
> Version: 1:3.0+9
> Severity: serious
> User: debian-qa@lists.debian.org
> Usertags: piuparts
> 
> Hi,
> 
> during a test with piuparts I noticed your package fails to upgrade from
> 'squeeze'.
> It installed fine in 'squeeze', then the upgrade to 'wheezy' fails.
> 
>>From the attached log (scroll to the bottom...):
> 
>   The following packages have unmet dependencies:
>    eog-dbg : Depends: eog (= 3.4.1-2) but 2.30.2-1 is to be installed
>    libglib2.0-0 : Breaks: eog (< 3.2.2-3) but 2.30.2-1 is to be installed
>   E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
> 
> The full output from Debug::pkgProblemResolver is included in the logfile.
> 

I assume you used apt-get dist-upgrade?

Imo this is not a bug which can be fixed in gnome-dbg in any way.
Bringing the apt maintainers into the loop. Maybe they have an idea why
the upgrade fails and what can be done about this.

Michael

-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, apt@packages.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-dbg. (Sat, 16 Jun 2012 08:51:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
Extra info received and forwarded to list. Copy sent to apt@packages.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Sat, 16 Jun 2012 08:51:05 GMT) Full text and rfc822 format available.

Message #15 received at 677407@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: Debian Bug Tracking System <677407@bugs.debian.org>
Subject: gnome-core: fails to upgrade from squeeze - apt does not find an upgrade path
Date: Sat, 16 Jun 2012 10:49:19 +0200
[Message part 1 (text/plain, inline)]
Package: gnome-core
Version: 1:3.0+9
Followup-For: Bug #677407

Hi,

the problem I previously reported for gnome-dbg now also shows up for
gnome-core. I hope the apt maintainers can find an idea how to improve
the package relationships (or where to add a transitional package).

Installation of Recommends is disabled.
Output from apt-get dist-upgrade with
Debug::pkgProblemResolver(::showScores) enabled:

  Reading package lists...
  Building dependency tree...
  Reading state information...
  Starting
  Settings used to calculate pkgProblemResolver::Scores::
    Important => 3
    Required => 2
    Standard => 1
    Optional => -1
    Extra => -2
    Essentials => 100
    InstalledAndNotObsolete => 1
    Depends => 1
    Recommends => 1
    AddProtected => 10000
    AddEssential => 5000
  Show Scores
  7237 libc6 [ amd64 ] < 2.11.3-3 -> 2.13-33 > ( libs )
  6131 dpkg [ amd64 ] < 1.15.8.12 -> 1.16.3 > ( admin )
  5779 libc-bin [ amd64 ] < 2.11.3-3 -> 2.13-33 > ( libs )
  5446 debianutils [ amd64 ] < 3.4 -> 4.3.1 > ( utils )
  5234 tar [ amd64 ] < 1.23-3 -> 1.26-4 > ( utils )
  5223 util-linux [ amd64 ] < 2.17.2-9 -> 2.20.1-5 > ( utils )
  5220 sysvinit-utils [ amd64 ] < 2.88dsf-13.1+squeeze1 -> 2.88dsf-22.1 > ( admin )
  5207 base-files [ amd64 ] < 6.0squeeze5 -> 6.9 > ( admin )
  5207 dash [ amd64 ] < 0.5.5.1-7.4 -> 0.5.7-3 > ( shells )
  5188 perl-base [ amd64 ] < 5.10.1-17squeeze3 -> 5.14.2-11 > ( perl )
  5117 coreutils [ amd64 ] < 8.5-1 -> 8.13-3.2 > ( utils )
  5110 e2fsprogs [ amd64 ] < 1.41.12-4stable1 -> 1.42.2-2 > ( admin )
  5110 bsdutils [ amd64 ] < 1:2.17.2-9 -> 1:2.20.1-5 > ( utils )
  5110 mount [ amd64 ] < 2.17.2-9 -> 2.20.1-5 > ( admin )
  5107 sed [ amd64 ] < 4.2.1-7 -> 4.2.1-10 > ( utils )
  5103 diffutils [ amd64 ] < 1:3.0-1 -> 1:3.2-6 > ( utils )
  5103 bash [ amd64 ] < 4.1-3 -> 4.2-2 > ( shells )
  5103 login [ amd64 ] < 1:4.1.4.2+svn3283-2+squeeze1 -> 1:4.1.5.1-1 > ( admin )
  5103 base-passwd [ amd64 ] < 3.5.22 -> 3.5.24 > ( admin )
  5103 findutils [ amd64 ] < 4.4.2-1+b1 -> 4.4.2-4 > ( utils )
  5103 ncurses-base [ amd64 ] < 5.7+20100313-5 -> 5.9-8 > ( misc )
  5103 grep [ amd64 ] < 2.6.3-3 -> 2.12-2 > ( utils )
  5103 gzip [ amd64 ] < 1.3.12-9 -> 1.4-5 > ( utils )
  5103 ncurses-bin [ amd64 ] < 5.7+20100313-5 -> 5.9-8 > ( utils )
  5103 hostname [ amd64 ] < 3.04 -> 3.11 > ( admin )
  5103 sysvinit [ amd64 ] < 2.88dsf-13.1+squeeze1 -> 2.88dsf-22.1 > ( admin )
  3290 multiarch-support [ amd64 ] < none -> 2.13-33 > ( libs )
  1784 libglib2.0-0 [ amd64 ] < 2.24.2-1 -> 2.32.3-1 > ( libs )
  1393 zlib1g [ amd64 ] < 1:1.2.3.4.dfsg-3 -> 1:1.2.7.dfsg-11 > ( libs )
  1128 libselinux1 [ amd64 ] < 2.0.96-1 -> 2.1.9-2 > ( libs )
  1005 libx11-6 [ amd64 ] < 2:1.3.3-4 -> 2:1.4.99.901-2 > ( libs )
  902 libgcc1 [ amd64 ] < 1:4.4.5-8 -> 1:4.7.0-8 > ( libs )
  657 libcairo2 [ amd64 ] < 1.8.10-6 -> 1.12.2-1 > ( libs )
  585 libfreetype6 [ amd64 ] < 2.4.2-2.1+squeeze4 -> 2.4.9-1 > ( libs )
  542 libfontconfig1 [ amd64 ] < 2.8.0-2.1 -> 2.9.0-6 > ( libs )
  509 libgdk-pixbuf2.0-0 [ amd64 ] < none -> 2.26.1-1 > ( libs )
  463 libpango1.0-0 [ amd64 ] < 1.28.3-1+squeeze2 -> 1.30.0-1 > ( libs )
  441 libxml2 [ amd64 ] < 2.7.8.dfsg-2+squeeze3 -> 2.8.0+dfsg1-3 > ( libs )
  426 shared-mime-info [ amd64 ] < 0.71-4 -> 0.90-1.1 > ( misc )
  414 libatk1.0-0 [ amd64 ] < 1.30.0-1 -> 2.4.0-2 > ( libs )
  390 libtinfo5 [ amd64 ] < none -> 5.9-8 > ( libs )
  385 libdbus-1-3 [ amd64 ] < 1.2.24-4+squeeze1 -> 1.6.0-1 > ( libs )
  334 libcomerr2 [ amd64 ] < 1.41.12-4stable1 -> 1.42.2-2 > ( libs )
  334 libffi5 [ amd64 ] < 3.0.9-3 -> 3.0.10-3 > ( libs )
  326 libblkid1 [ amd64 ] < 2.17.2-9 -> 2.20.1-5 > ( libs )
  326 libxrender1 [ amd64 ] < 1:0.9.6-1 -> 1:0.9.7-1 > ( libs )
  321 libxext6 [ amd64 ] < 2:1.1.2-1 -> 2:1.3.1-2 > ( libs )
  305 libcairo-gobject2 [ amd64 ] < none -> 1.12.2-1 > ( libs )
  300 libgtk-3-0 [ amd64 ] < none -> 3.4.2-1 > ( libs )
  286 libglib2.0-data [ amd64 ] < 2.24.2-1 -> 2.32.3-1 > ( libs )
  286 libpcre3 [ amd64 ] < 8.02-1.1 -> 1:8.30-5 > ( libs )
  284 libuuid1 [ amd64 ] < 2.17.2-9 -> 2.20.1-5 > ( libs )
  278 libxcb1 [ amd64 ] < 1.6-1 -> 1.8.1-1 > ( libs )
  275 libxfixes3 [ amd64 ] < 1:4.0.5-1 -> 1:5.0-4 > ( libs )
  269 libpng12-0 [ amd64 ] < 1.2.44-1+squeeze4 -> 1.2.49-1 > ( libs )
  261 libgcrypt11 [ amd64 ] < 1.4.5-2 -> 1.5.0-3 > ( libs )
  246 libbz2-1.0 [ amd64 ] < 1.0.5-6+squeeze1 -> 1.0.6-1 > ( libs )
  239 debconf [ amd64 ] < 1.5.36.1 -> 1.5.43 > ( admin )
  237 libdbus-glib-1-2 [ amd64 ] < 0.88-2.1 -> 0.98-1 > ( libs )
  235 libxdamage1 [ amd64 ] < 1:1.1.3-1 -> 1:1.1.3-2 > ( libs )
  231 libxcomposite1 [ amd64 ] < 1:0.4.2-1 -> 1:0.4.3-2 > ( libs )
  223 libk5crypto3 [ amd64 ] < 1.8.3+dfsg-4squeeze5 -> 1.10.1+dfsg-1 > ( libs )
  217 libsepol1 [ amd64 ] < 2.0.41-1 -> 2.1.4-3 > ( libs )
  215 initscripts [ amd64 ] < 2.88dsf-13.1+squeeze1 -> 2.88dsf-22.1 > ( admin )
  210 libxi6 [ amd64 ] < 2:1.3-7 -> 2:1.6.1-1 > ( libs )
  209 libgnutls26 [ amd64 ] < 2.8.6-1+squeeze2 -> 2.12.19-1 > ( libs )
  207 libkrb5-3 [ amd64 ] < 1.8.3+dfsg-4squeeze5 -> 1.10.1+dfsg-1 > ( libs )
  207 libgssapi-krb5-2 [ amd64 ] < 1.8.3+dfsg-4squeeze5 -> 1.10.1+dfsg-1 > ( libs )
  180 lsb-base [ amd64 ] < 3.2-23.2squeeze1 -> 4.1+Debian6 > ( misc )
  167 libxrandr2 [ amd64 ] < 2:1.3.0-3 -> 2:1.3.2-2 > ( libs )
  165 libgconf-2-4 [ amd64 ] < none -> 3.2.5-1 > ( libs )
  165 gconf-service [ amd64 ] < none -> 3.2.5-1 > ( libs )
  160 hicolor-icon-theme [ amd64 ] < 0.12-1 > ( misc )
  153 libjpeg8 [ amd64 ] < none -> 8d-1 > ( libs )
  151 libcups2 [ amd64 ] < 1.4.4-7+squeeze1 -> 1.5.3-1 > ( libs )
  150 libsoup2.4-1 [ amd64 ] < 2.30.2-1+squeeze1 -> 2.38.1-2 > ( libs )
  148 libsqlite3-0 [ amd64 ] < 3.7.3-1 -> 3.7.12.1-1 > ( libs )
  145 libstdc++6 [ amd64 ] < 4.4.5-8 -> 4.7.0-8 > ( libs )
  144 libattr1 [ amd64 ] < 1:2.4.44-2 -> 1:2.4.46-7 > ( libs )
  142 libxinerama1 [ amd64 ] < 2:1.1-3 -> 2:1.1.2-1 > ( libs )
  140 libexpat1 [ amd64 ] < 2.0.1-7 -> 2.1.0-1 > ( libs )
  140 libxcursor1 [ amd64 ] < 1:1.1.10-2 -> 1:1.1.13-1 > ( libs )
  138 libpam0g [ amd64 ] < 1.1.1-6.1+squeeze1 -> 1.1.3-7.1 > ( libs )
  134 xz-utils [ amd64 ] < 5.0.0-2 -> 5.1.1alpha+20110809-3 > ( utils )
  132 gir1.2-glib-2.0 [ amd64 ] < none -> 1.32.1-1 > ( introspection )
  132 gcc-4.7-base [ amd64 ] < none -> 4.7.0-8 > ( libs )
  129 dconf-gsettings-backend [ amd64 ] < none -> 0.12.1-1 > ( libs )
  128 dbus [ amd64 ] < 1.2.24-4+squeeze1 -> 1.6.0-1 > ( admin )
  127 libslang2 [ amd64 ] < 2.2.2-4 -> 2.2.4-10 > ( libs )
  125 python [ amd64 ] < 2.6.6-3+squeeze7 -> 2.7.3~rc2-1 > ( python )
  124 libxcb-render0 [ amd64 ] < 1.6-1 -> 1.8.1-1 > ( libs )
  122 libpixman-1-0 [ amd64 ] < 0.16.4-1 -> 0.24.4-1 > ( libs )
  122 libpam-modules [ amd64 ] < 1.1.1-6.1+squeeze1 -> 1.1.3-7.1 > ( admin )
  121 libncurses5 [ amd64 ] < 5.7+20100313-5 -> 5.9-8 > ( libs )
  121 libacl1 [ amd64 ] < 2.2.49-4 -> 2.2.51-7 > ( libs )
  121 libxcb-shm0 [ amd64 ] < none -> 1.8.1-1 > ( libs )
  120 liblzma5 [ amd64 ] < none -> 5.1.1alpha+20110809-3 > ( libs )
  120 tzdata [ amd64 ] < 2012c-0squeeze1 -> 2012c-1 > ( libs )
  119 libtiff4 [ amd64 ] < 3.9.4-5+squeeze4 -> 3.9.6-5 > ( oldlibs )
  115 bsdmainutils [ amd64 ] < 8.0.13 -> 9.0.3 > ( utils )
  115 sensible-utils [ amd64 ] < 0.0.4 -> 0.0.7 > ( utils )
  114 fontconfig [ amd64 ] < 2.8.0-2.1 -> 2.9.0-6 > ( fonts )
  114 sysv-rc [ amd64 ] < 2.88dsf-13.1+squeeze1 -> 2.88dsf-22.1 > ( admin )
  113 libxft2 [ amd64 ] < 2.1.14-2 -> 2.2.0-3 > ( libs )
  112 libgtk-3-bin [ amd64 ] < none -> 3.4.2-1 > ( misc )
  112 libpam-runtime [ amd64 ] < 1.1.1-6.1+squeeze1 -> 1.1.3-7.1 > ( admin )
  111 libthai0 [ amd64 ] < 0.1.14-2 -> 0.1.17-1 > ( libs )
  111 libjasper1 [ amd64 ] < 1.900.1-7+squeeze1 -> 1.900.1-13 > ( libs )
  108 e2fslibs [ amd64 ] < 1.41.12-4stable1 -> 1.42.2-2 > ( libs )
  108 libss2 [ amd64 ] < 1.41.12-4stable1 -> 1.42.2-2 > ( libs )
  107 libmount1 [ amd64 ] < none -> 2.20.1-5 > ( libs )
  107 libx11-data [ amd64 ] < 2:1.3.3-4 -> 2:1.4.99.901-2 > ( x11 )
  105 xml-core [ amd64 ] < 0.13 > ( text )
  105 libgtk-3-common [ amd64 ] < none -> 3.4.2-1 > ( misc )
  103 libcolord1 [ amd64 ] < none -> 0.1.21-1 > ( libs )
  102 libnspr4-0d [ amd64 ] < 4.8.6-1 -> 2:4.9-3 > ( oldlibs )
  102 libgdk-pixbuf2.0-common [ amd64 ] < none -> 2.26.1-1 > ( libs )
  101 libice6 [ amd64 ] < 2:1.0.6-2 -> 2:1.0.8-2 > ( libs )
  94 libatk1.0-data [ amd64 ] < none -> 2.4.0-2 > ( misc )
  93 libgtk2.0-0 [ amd64 ] < 2.20.1-2 -> 2.24.10-1 > ( libs )
  89 libgstreamer0.10-0 [ amd64 ] < 0.10.30-1 -> 0.10.36-1 > ( libs )
  85 dconf-service [ amd64 ] < none -> 0.12.1-1 > ( libs )
  79 python2.7 [ amd64 ] < none -> 2.7.3~rc2-2.1 > ( python )
  79 libdb5.1 [ amd64 ] < none -> 5.1.29-1 > ( libs )
  79 libogg0 [ amd64 ] < 1.2.0~dfsg-1 -> 1.3.0-2 > ( libs )
  76 libsm6 [ amd64 ] < 2:1.1.1-1 -> 2:1.2.1-2 > ( libs )
  69 perl [ amd64 ] < 5.10.1-17squeeze3 -> 5.14.2-11 > ( perl )
  68 libcogl9 [ amd64 ] < none -> 1.10.2-3 > ( libs )
  68 libgirepository-1.0-1 [ amd64 ] < none -> 1.32.1-1 > ( libs )
  67 fontconfig-config [ amd64 ] < 2.8.0-2.1 -> 2.9.0-6 > ( fonts )
  67 libudev0 [ amd64 ] < 164-3 -> 175-3.1 > ( libs )
  64 gsettings-desktop-schemas [ amd64 ] < none -> 3.4.2-1 > ( gnome )
  63 libpolkit-gobject-1-0 [ amd64 ] < 0.96-4+squeeze2 -> 0.105-1 > ( libs )
  62 libedataserver-1.2-15 [ amd64 ] < none -> 3.2.2-3 > ( libs )
  62 libvorbis0a [ amd64 ] < 1.3.1-1+squeeze1 -> 1.3.2-1.3 > ( libs )
  62 libjson-glib-1.0-0 [ amd64 ] < 0.10.2-2squeeze1 -> 0.14.2-1 > ( libs )
  61 libkeyutils1 [ amd64 ] < 1.4-1 -> 1.5.5-2 > ( libs )
  61 libnss3-1d [ amd64 ] < 3.12.8-1+squeeze4 -> 2:3.13.4-3 > ( oldlibs )
  60 libcanberra0 [ amd64 ] < 0.24-1 -> 0.28-4 > ( libs )
  59 gir1.2-freedesktop [ amd64 ] < none -> 1.32.1-1 > ( introspection )
  58 libgconf2-4 [ amd64 ] < 2.28.1-6 -> 3.2.5-1 > ( oldlibs )
  57 libcamel-1.2-29 [ amd64 ] < none -> 3.2.2-3 > ( libs )
  57 dbus-x11 [ amd64 ] < 1.2.24-4+squeeze1 -> 1.6.0-1 > ( x11 )
  56 gconf2-common [ amd64 ] < 2.28.1-6 -> 3.2.5-1 > ( libs )
  56 libldap-2.4-2 [ amd64 ] < 2.4.23-7.2 -> 2.4.28-1.1 > ( libs )
  56 libgnome-keyring0 [ amd64 ] < 2.30.1-1 -> 3.4.1-1 > ( libs )
  55 libkrb5support0 [ amd64 ] < 1.8.3+dfsg-4squeeze5 -> 1.10.1+dfsg-1 > ( libs )
  54 libavahi-common3 [ amd64 ] < 0.6.27-2+squeeze1 -> 0.6.31-1 > ( libs )
  53 python-minimal [ amd64 ] < 2.6.6-3+squeeze7 -> 2.7.3~rc2-1 > ( python )
  53 gnome-icon-theme [ amd64 ] < 2.30.3-2 -> 3.4.0-2 > ( gnome )
  52 libreadline6 [ amd64 ] < 6.1-3 -> 6.2-8 > ( libs )
  52 libgstreamer-plugins-base0.10-0 [ amd64 ] < 0.10.30-1 -> 0.10.36-1 > ( libs )
  50 libcap2 [ amd64 ] < 1:2.19-3 -> 1:2.22-1 > ( libs )
  50 libdconf0 [ amd64 ] < none -> 0.12.1-1 > ( libs )
  50 libltdl7 [ amd64 ] < 2.2.6b-2 -> 2.4.2-1 > ( libs )
  47 libgudev-1.0-0 [ amd64 ] < 164-3 -> 175-3.1 > ( libs )
  46 libcogl-pango0 [ amd64 ] < none -> 1.10.2-3 > ( libs )
  46 libnotify4 [ amd64 ] < none -> 0.7.5-1 > ( libs )
  46 libnspr4 [ amd64 ] < none -> 2:4.9-3 > ( libs )
  45 libgtk2.0-common [ amd64 ] < 2.20.1-2 -> 2.24.10-1 > ( misc )
  45 glib-networking [ amd64 ] < none -> 2.32.3-1 > ( libs )
  43 libtdb1 [ amd64 ] < 1.2.1-2+b1 -> 1.2.10-2 > ( libs )
  43 libsoup-gnome2.4-1 [ amd64 ] < 2.30.2-1+squeeze1 -> 2.38.1-2 > ( libs )
  42 libgdbm3 [ amd64 ] < 1.8.3-9 -> 1.8.3-10 > ( libs )
  42 liborc-0.4-0 [ amd64 ] < 1:0.4.6-2 -> 1:0.4.16-2 > ( libs )
  41 librsvg2-common [ amd64 ] < 2.26.3-1 -> 2.36.1-1 > ( libs )
  41 libxau6 [ amd64 ] < 1:1.0.6-1 -> 1:1.0.7-1 > ( libs )
  41 libupower-glib1 [ amd64 ] < 0.9.5-5 -> 0.9.16-2 > ( libs )
  41 libgtk2.0-bin [ amd64 ] < 2.20.1-2 -> 2.24.10-1 > ( misc )
  40 libncursesw5 [ amd64 ] < 5.7+20100313-5 -> 5.9-8 > ( libs )
  40 gsettings-backend [ amd64 ] < none > ( none )
  39 libp11-kit0 [ amd64 ] < none -> 0.12-3 > ( libs )
  39 netbase [ amd64 ] < 4.45 -> 5.0 > ( admin )
  39 libclutter-1.0-0 [ amd64 ] < 1.2.12-3 -> 1.10.6-1 > ( libs )
  39 gvfs [ amd64 ] < 1.6.4-3 -> 1.12.3-1 > ( libs )
  38 libcanberra-gtk3-0 [ amd64 ] < none -> 0.28-4 > ( libs )
  38 libvorbisfile3 [ amd64 ] < 1.3.1-1+squeeze1 -> 1.3.2-1.3 > ( libs )
  38 x11-common [ amd64 ] < 1:7.5+8+squeeze1 -> 1:7.6+13 > ( x11 )
  37 python2.6 [ amd64 ] < 2.6.6-8+b1 -> 2.6.7-4 > ( python )
  37 gir1.2-pango-1.0 [ amd64 ] < none -> 1.30.0-1 > ( introspection )
  36 iso-codes [ amd64 ] < 3.23-1 -> 3.36-1 > ( misc )
  36 gir1.2-gdkpixbuf-2.0 [ amd64 ] < none -> 2.26.1-1 > ( introspection )
  35 mime-support [ amd64 ] < 3.48-1 -> 3.52-1 > ( net )
  35 libxtst6 [ amd64 ] < 2:1.1.0-3 -> 2:1.2.1-1 > ( libs )
  34 perl-modules [ amd64 ] < 5.10.1-17squeeze3 -> 5.14.2-11 > ( perl )
  34 gir1.2-atk-1.0 [ amd64 ] < none -> 2.4.0-2 > ( introspection )
  34 gvfs-daemons [ amd64 ] < none -> 1.12.3-1 > ( libs )
  33 libgnome-desktop-3-2 [ amd64 ] < none -> 3.4.2-1 > ( libs )
  33 passwd [ amd64 ] < 1:4.1.4.2+svn3283-2+squeeze1 -> 1:4.1.5.1-1 > ( admin )
  32 libnss3 [ amd64 ] < none -> 2:3.13.4-3 > ( libs )
  32 gconf2 [ amd64 ] < 2.28.1-6 -> 3.2.5-1 > ( libs )
  31 notification-daemon [ amd64 ] < 0.5.0-2 -> 0.7.4-1 > ( x11 )
  31 psmisc [ amd64 ] < 22.11-1 -> 22.16-1 > ( admin )
  31 libtasn1-3 [ amd64 ] < 2.7-1+squeeze+1 -> 2.12-1 > ( libs )
  31 adduser [ amd64 ] < 3.112+nmu2 -> 3.113+nmu3 > ( admin )
  31 libavahi-client3 [ amd64 ] < 0.6.27-2+squeeze1 -> 0.6.31-1 > ( libs )
  31 libpulse0 [ amd64 ] < none -> 2.0-3 > ( libs )
  31 libgpg-error0 [ amd64 ] < 1.6-1 -> 1.10-3 > ( libs )
  30 libasound2 [ amd64 ] < 1.0.23-2.1 -> 1.0.25-3 > ( libs )
  30 libssl1.0.0 [ amd64 ] < none -> 1.0.1c-3 > ( libs )
  29 libical0 [ amd64 ] < 0.44-3 -> 0.48-2 > ( libs )
  29 libx11-xcb1 [ amd64 ] < none -> 2:1.4.99.901-2 > ( libs )
  29 debconf-i18n [ amd64 ] < 1.5.36.1 -> 1.5.43 > ( localization )
  29 libenchant1c2a [ amd64 ] < 1.6.0-1 -> 1.6.0-7 > ( libs )
  27 gnome-settings-daemon [ amd64 ] < 2.30.2-2+squeeze1 -> 3.4.2-3 > ( gnome )
  27 libebook-1.2-12 [ amd64 ] < none -> 3.2.2-3 > ( libs )
  26 libxklavier16 [ amd64 ] < 5.0-2 -> 5.2.1-1 > ( libs )
  25 gvfs-common [ amd64 ] < none -> 1.12.3-1 > ( libs )
  25 libwebkitgtk-3.0-0 [ amd64 ] < none -> 1.8.1-2 > ( libs )
  25 libtelepathy-glib0 [ amd64 ] < none -> 0.18.1-2 > ( libs )
  25 librsvg2-2 [ amd64 ] < 2.26.3-1 -> 2.36.1-1 > ( libs )
  25 gstreamer0.10-plugins-base [ amd64 ] < 0.10.30-1 -> 0.10.36-1 > ( libs )
  24 gir1.2-gtk-3.0 [ amd64 ] < none -> 3.4.2-1 > ( introspection )
  24 udev [ amd64 ] < 164-3 -> 175-3.1 > ( admin )
  23 gnome-session-bin [ amd64 ] < 2.30.2-3 -> 3.4.2.1-1 > ( gnome )
  23 libnm-util2 [ amd64 ] < none -> 0.9.4.0-5 > ( libs )
  22 libpopt0 [ amd64 ] < 1.16-1 -> 1.16-7 > ( libs )
  22 gvfs-libs [ amd64 ] < none -> 1.12.3-1 > ( libs )
  22 libstartup-notification0 [ amd64 ] < 0.10-1 -> 0.12-1 > ( libs )
  22 libgail-3-0 [ amd64 ] < none -> 3.4.2-1 > ( libs )
  22 libgpm2 [ amd64 ] < 1.20.4-3.3 -> 1.20.4-4 > ( libs )
  22 libecal-1.2-10 [ amd64 ] < none -> 3.2.2-3 > ( libs )
  22 liborbit2 [ amd64 ] < 1:2.14.18-0.1 -> 1:2.14.19-0.1 > ( libs )
  21 libplist1 [ amd64 ] < 1.3-2 -> 1.8-1 > ( libs )
  21 libxt6 [ amd64 ] < 1:1.0.7-1 -> 1:1.1.3-1 > ( libs )
  20 python2.7-minimal [ amd64 ] < none -> 2.7.3~rc2-2.1 > ( python )
  20 libdb4.8 [ amd64 ] < 4.8.30-2 -> 4.8.30-11 > ( oldlibs )
  19 libavahi-glib1 [ amd64 ] < 0.6.27-2+squeeze1 -> 0.6.31-1 > ( libs )
  19 python2.6-minimal [ amd64 ] < 2.6.6-8+b1 -> 2.6.7-4 > ( python )
  19 libusb-0.1-4 [ amd64 ] < 2:0.1.12-16 -> 2:0.1.12-20 > ( libs )
  19 yelp [ amd64 ] < 2.30.1+webkit-1 -> 3.4.2-1 > ( gnome )
  19 debconf-2.0 [ amd64 ] < none > ( none )
  19 gnome-user-guide [ amd64 ] < 2.30.1-1 -> 3.4.2-1 > ( gnome )
  19 consolekit [ amd64 ] < 0.4.1-4 -> 0.4.5-3 > ( admin )
  18 libjavascriptcoregtk-3.0-0 [ amd64 ] < none -> 1.8.1-2 > ( libs )
  18 liblcms2-2 [ amd64 ] < none -> 2.2+git20110628-2.2 > ( libs )
  18 libgoa-1.0-0 [ amd64 ] < none -> 3.4.2-1 > ( libs )
  18 policykit-1 [ amd64 ] < 0.96-4+squeeze2 -> 0.105-1 > ( admin )
  18 libxdmcp6 [ amd64 ] < 1:1.0.3-2 -> 1:1.1.1-1 > ( libs )
  18 policykit-1-gnome [ amd64 ] < 0.96-3 -> 0.105-2 > ( gnome )
  18 ucf [ amd64 ] < 3.0025+nmu1 -> 3.0025+nmu3 > ( utils )
  18 libgnome-keyring-common [ amd64 ] < none -> 3.4.1-1 > ( libs )
  18 libsystemd-login0 [ amd64 ] < none -> 44-2 > ( libs )
  18 gpgv [ amd64 ] < 1.4.10-4 -> 1.4.12-4 > ( utils )
  17 liburi-perl [ amd64 ] < 1.54-2 -> 1.60-1 > ( perl )
  17 libgl1-mesa-glx [ amd64 ] < 7.7.1-5 -> 8.0.2-2 > ( libs )
  17 libnm-glib4 [ amd64 ] < none -> 0.9.4.0-5 > ( libs )
  17 libpulse-mainloop-glib0 [ amd64 ] < none -> 2.0-3 > ( sound )
  17 libgnomekbd7 [ amd64 ] < none -> 3.4.0.2-1 > ( libs )
  17 libgtop2-7 [ amd64 ] < 2.28.1-1 -> 2.28.4-3 > ( libs )
  17 libpolkit-agent-1-0 [ amd64 ] < 0.96-4+squeeze2 -> 0.105-1 > ( libs )
  16 upower [ amd64 ] < 0.9.5-5 -> 0.9.16-2 > ( admin )
  16 gnome-session [ amd64 ] < 2.30.2-3 -> 3.4.2.1-1 > ( gnome )
  16 readline-common [ amd64 ] < 6.1-3 -> 6.2-8 > ( utils )
  16 libxslt1.1 [ amd64 ] < 1.1.26-6 -> 1.1.26-11 > ( libs )
  16 libavahi-common-data [ amd64 ] < 0.6.27-2+squeeze1 -> 0.6.31-1 > ( libs )
  16 nautilus-data [ amd64 ] < 2.30.1-2squeeze1 -> 3.4.2-1 > ( gnome )
  16 gnupg [ amd64 ] < 1.4.10-4 -> 1.4.12-4 > ( utils )
  15 python-gobject-2 [ amd64 ] < none -> 2.28.6-10 > ( oldlibs )
  15 libarchive12 [ amd64 ] < none -> 3.0.4-2 > ( libs )
  15 gnome-icon-theme-symbolic [ amd64 ] < none -> 3.4.0-2 > ( gnome )
  15 libisc83 [ amd64 ] < none -> 1:9.8.1.dfsg.P1-4 > ( libs )
  15 libsndfile1 [ amd64 ] < none -> 1.0.25-4 > ( libs )
  14 aspell-en [ amd64 ] < none -> 7.1-0-1 > ( text )
  14 gnome-power-manager [ amd64 ] < 2.32.0-2 -> 3.4.0-2 > ( gnome )
  14 libbonobo2-0 [ amd64 ] < 2.24.3-1 > ( libs )
  14 libgweather-3-0 [ amd64 ] < none -> 3.4.1-1 > ( libs )
  14 libsigc++-2.0-0c2a [ amd64 ] < none -> 2.2.10-0.1 > ( libs )
  14 gnome-desktop3-data [ amd64 ] < none -> 3.4.2-1 > ( gnome )
  14 gstreamer0.10-plugins-good [ amd64 ] < 0.10.24-1 -> 0.10.31-3 > ( libs )
  14 libgee2 [ amd64 ] < none -> 0.6.4-2 > ( libs )
  14 libapt-pkg4.12 [ amd64 ] < none -> 0.9.5.1 > ( admin )
  14 libwacom2 [ amd64 ] < none -> 0.5-1 > ( libs )
  14 libsasl2-2 [ amd64 ] < 2.1.23.dfsg1-7 -> 2.1.25.dfsg1-4+b1 > ( libs )
  14 man-db [ amd64 ] < 2.5.7-8 -> 2.6.1-2 > ( doc )
  14 libedataserver1.2-13 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  13 libtext-charwidth-perl [ amd64 ] < 0.04-6 -> 0.04-7+b1 > ( perl )
  13 libxxf86vm1 [ amd64 ] < 1:1.1.0-2 -> 1:1.1.2-1 > ( libs )
  13 libgnome-bluetooth10 [ amd64 ] < none -> 3.4.0-2 > ( libs )
  13 libgtkhtml-4.0-0 [ amd64 ] < none -> 4.2.2-1 > ( libs )
  13 libgnome-menu-3-0 [ amd64 ] < none -> 3.4.2-1 > ( gnome )
  13 gnome-session-fallback [ amd64 ] < none -> 3.4.2.1-1 > ( gnome )
  13 libvorbisenc2 [ amd64 ] < 1.3.1-1+squeeze1 -> 1.3.2-1.3 > ( libs )
  13 libpackagekit-glib2-14 [ amd64 ] < none -> 0.7.4-4 > ( libs )
  13 libxv1 [ amd64 ] < 2:1.0.5-1 -> 2:1.0.7-1 > ( libs )
  13 libnautilus-extension1a [ amd64 ] < none -> 3.4.2-1 > ( libs )
  12 libgmp10 [ amd64 ] < none -> 2:5.0.5+dfsg-2 > ( libs )
  12 libebackend-1.2-1 [ amd64 ] < none -> 3.2.2-3 > ( libs )
  12 libwrap0 [ amd64 ] < none -> 7.6.q-23 > ( libs )
  12 gnome-menus [ amd64 ] < 2.30.3-1 -> 3.4.2-1 > ( gnome )
  12 libjbig0 [ amd64 ] < none -> 2.0-2 > ( libs )
  12 python-gi [ amd64 ] < none -> 3.2.2-1 > ( python )
  12 libtheora0 [ amd64 ] < 1.1.1+dfsg.1-3 -> 1.1.1+dfsg.1-3.1 > ( libs )
  12 libraw1394-11 [ amd64 ] < 2.0.5-2 -> 2.0.9-1 > ( libs )
  12 sgml-base [ amd64 ] < 1.26+nmu1 -> 1.26+nmu3 > ( text )
  12 libtext-iconv-perl [ amd64 ] < 1.7-2 -> 1.7-5 > ( perl )
  12 libart-2.0-2 [ amd64 ] < 2.3.21-1 > ( libs )
  12 evolution-data-server-common [ amd64 ] < 2.30.3-2+squeeze1 -> 3.2.2-3 > ( gnome )
  12 gnome-control-center [ amd64 ] < 1:2.30.1-2 -> 1:3.4.2-2 > ( gnome )
  12 evolution-data-server [ amd64 ] < 2.30.3-2+squeeze1 -> 3.2.2-3 > ( gnome )
  12 libaspell15 [ amd64 ] < 0.60.6-4 -> 0.60.7~20110707-1 > ( libs )
  12 libxkbfile1 [ amd64 ] < 1:1.0.6-2 -> 1:1.0.8-1 > ( libs )
  11 libgck-1-0 [ amd64 ] < none -> 3.4.1-3 > ( libs )
  11 libhtml-parser-perl [ amd64 ] < 3.66-1 -> 3.69-2 > ( perl )
  11 gnome-control-center-data [ amd64 ] < none -> 1:3.4.2-2 > ( gnome )
  11 libkmod2 [ amd64 ] < none -> 8-2 > ( libs )
  11 gstreamer0.10-x [ amd64 ] < 0.10.30-1 -> 0.10.36-1 > ( libs )
  11 libhtml-tagset-perl [ amd64 ] < 3.20-2 > ( perl )
  11 libedataserverui-3.0-1 [ amd64 ] < none -> 3.2.2-3 > ( libs )
  11 ca-certificates [ amd64 ] < none -> 20120212 > ( misc )
  11 libgssdp-1.0-3 [ amd64 ] < none -> 0.12.1-2 > ( libs )
  10 libcdio10 [ amd64 ] < 0.81-4 -> 0.81-5 > ( libs )
  10 libgail18 [ amd64 ] < 2.20.1-2 -> 2.24.10-1 > ( libs )
  10 gstreamer0.10-plugins-bad [ amd64 ] < none -> 0.10.23-6 > ( libs )
  10 libicu48 [ amd64 ] < none -> 4.8.1.1-8 > ( libs )
  10 libpam-modules-bin [ amd64 ] < none -> 1.1.3-7.1 > ( admin )
  10 pulseaudio [ amd64 ] < none -> 2.0-3 > ( sound )
  10 x11-xkb-utils [ amd64 ] < 7.5+5 -> 7.7~1 > ( x11 )
  10 gnome-session-common [ amd64 ] < 2.30.2-3 -> 3.4.2.1-1 > ( gnome )
  10 libspeex1 [ amd64 ] < 1.2~rc1-1 -> 1.2~rc1-6 > ( libs )
  10 groff-base [ amd64 ] < 1.20.1-10 -> 1.21-7 > ( text )
  10 libcroco3 [ amd64 ] < 0.6.2-1 -> 0.6.5-1 > ( libs )
  10 libidl0 [ amd64 ] < 0.8.14-0.1 -> 0.8.14-0.2 > ( libs )
  10 libglade2-0 [ amd64 ] < 1:2.6.4-1 > ( libs )
  10 libflac8 [ amd64 ] < 1.2.1-2+b1 -> 1.2.1-6 > ( libs )
  10 libhunspell-1.3-0 [ amd64 ] < none -> 1.3.2-4 > ( libs )
  10 libnewt0.52 [ amd64 ] < 0.52.11-1 -> 0.52.14-10 > ( libs )
  10 python-support [ amd64 ] < 1.0.10 -> 1.0.14 > ( python )
  10 install-info [ amd64 ] < none -> 4.13a.dfsg.1-10 > ( doc )
  10 libusb-1.0-0 [ amd64 ] < 2:1.0.8-2 -> 2:1.0.11-1 > ( libs )
  9 libyelp0 [ amd64 ] < none -> 3.4.2-1 > ( libs )
  9 libcdparanoia0 [ amd64 ] < 3.10.2+debian-9 -> 3.10.2+debian-10.1 > ( libs )
  9 desktop-file-utils [ amd64 ] < 0.15-2 -> 0.18-1 > ( devel )
  9 gvfs-backends [ amd64 ] < 1.6.4-3 -> 1.12.3-1 > ( gnome )
  9 libimobiledevice2 [ amd64 ] < none -> 1.1.1-4 > ( libs )
  9 libpipeline1 [ amd64 ] < none -> 1.2.1-1 > ( libs )
  9 libdevmapper1.02.1 [ amd64 ] < 2:1.02.48-5 -> 2:1.02.74-4 > ( libs )
  9 libdns81 [ amd64 ] < none -> 1:9.8.1.dfsg.P1-4 > ( libs )
  9 gnome-keyring [ amd64 ] < 2.30.3-5 -> 3.4.1-4 > ( gnome )
  9 libvisual-0.4-0 [ amd64 ] < 0.4.0-3 -> 0.4.0-4 > ( libs )
  9 debian-archive-keyring [ amd64 ] < 2010.08.28 -> 2012.4 > ( misc )
  9 libgtkhtml-editor-4.0-0 [ amd64 ] < none -> 4.2.2-1 > ( libs )
  9 libasyncns0 [ amd64 ] < none -> 0.8-4 > ( libs )
  9 gnome-panel [ amd64 ] < 2.30.2-2 -> 3.4.2.1-2 > ( gnome )
  8 iproute [ amd64 ] < none -> 20120521-2 > ( net )
  8 libmpfr4 [ amd64 ] < 3.0.0-2 -> 3.1.0-5 > ( libs )
  8 libv4l-0 [ amd64 ] < 0.8.0-1 -> 0.8.8-2 > ( libs )
  8 libgnome2-0 [ amd64 ] < 2.30.0-1 -> 2.32.1-2 > ( libs )
  8 libgnomecanvas2-0 [ amd64 ] < 2.30.1-1 -> 2.30.3-1 > ( libs )
  8 libgtkhtml-4.0-common [ amd64 ] < none -> 4.2.2-1 > ( libs )
  8 libtext-wrapi18n-perl [ amd64 ] < 0.06-7 > ( perl )
  8 liblocale-gettext-perl [ amd64 ] < 1.05-6 -> 1.05-7+b1 > ( perl )
  8 libgnomevfs2-common [ amd64 ] < 1:2.24.3-1 -> 1:2.24.4-1 > ( oldlibs )
  8 libgcr-3-1 [ amd64 ] < none -> 3.4.1-3 > ( libs )
  8 metacity-common [ amd64 ] < 1:2.30.1-3 -> 1:2.34.3-2 > ( misc )
  8 libfolks25 [ amd64 ] < none -> 0.6.9-1 > ( libs )
  8 xkb-data [ amd64 ] < 1.8-2 -> 2.5.1-1 > ( x11 )
  8 libhttp-date-perl [ amd64 ] < none -> 6.02-1 > ( perl )
  8 libjson0 [ amd64 ] < none -> 0.9-1.1 > ( libs )
  8 libgnome2-common [ amd64 ] < 2.30.0-1 -> 2.32.1-2 > ( libs )
  8 libgnomevfs2-0 [ amd64 ] < 1:2.24.3-1 -> 1:2.24.4-1 > ( oldlibs )
  8 python-cairo [ amd64 ] < 1.8.8-1+b1 -> 1.8.8-1+b2 > ( python )
  8 libgtop2-common [ amd64 ] < 2.28.1-1 -> 2.28.4-3 > ( libs )
  8 file [ amd64 ] < 5.04-5+squeeze2 -> 5.11-1 > ( utils )
  8 libwnck-3-0 [ amd64 ] < none -> 3.4.2-1 > ( libs )
  8 yelp-xsl [ amd64 ] < none -> 3.4.2-1 > ( gnome )
  8 isc-dhcp-common [ amd64 ] < none -> 4.2.2.dfsg.1-5 > ( net )
  8 libbonoboui2-common [ amd64 ] < 2.24.3-1 > ( libs )
  8 libxcb-util0 [ amd64 ] < none -> 0.3.8-2 > ( libs )
  8 libbluetooth3 [ amd64 ] < 4.66-3 -> 4.99-2 > ( libs )
  8 gir1.2-cogl-1.0 [ amd64 ] < none -> 1.10.2-3 > ( introspection )
  8 libgnomecanvas2-common [ amd64 ] < 2.30.1-1 -> 2.30.3-1 > ( x11 )
  8 libclutter-gtk-1.0-0 [ amd64 ] < none -> 1.2.0-2 > ( libs )
  8 libmagic1 [ amd64 ] < 5.04-5+squeeze2 -> 5.11-1 > ( libs )
  7 libgphoto2-port0 [ amd64 ] < 2.4.6-3 -> 2.4.14-2 > ( libs )
  7 libcaca0 [ amd64 ] < 0.99.beta17-1 -> 0.99.beta18-1 > ( libs )
  7 zenity [ amd64 ] < 2.30.0-1 -> 3.4.0-2 > ( gnome )
  7 libgupnp-1.0-4 [ amd64 ] < none -> 0.18.3-1 > ( libs )
  7 libcheese3 [ amd64 ] < none -> 3.4.2-1 > ( libs )
  7 libjack-jackd2-0 [ amd64 ] < none -> 1.9.8~dfsg.4+20120529git007cdc37-1 > ( libs )
  7 libgeoclue0 [ amd64 ] < none -> 0.12.0-4 > ( libs )
  7 libwavpack1 [ amd64 ] < 4.60.1-1 -> 4.60.1-3 > ( libs )
  7 libfribidi0 [ amd64 ] < none -> 0.19.2-3 > ( libs )
  7 libquadmath0 [ amd64 ] < none -> 4.7.0-8 > ( libs )
  7 libiec61883-0 [ amd64 ] < 1.2.0-0.1 > ( libs )
  7 libpanel-applet-4-0 [ amd64 ] < none -> 3.4.2.1-2 > ( libs )
  7 libgdata13 [ amd64 ] < none -> 0.12.0-1 > ( libs )
  7 perlapi-5.14.2 [ amd64 ] < none > ( none )
  7 libaa1 [ amd64 ] < 1.4p5-38 -> 1.4p5-39.1 > ( libs )
  7 gstreamer0.10-pulseaudio [ amd64 ] < none -> 0.10.31-3 > ( sound )
  7 libshout3 [ amd64 ] < 2.2.2-5+b1 -> 2.2.2-8 > ( libs )
  7 libdv4 [ amd64 ] < 1.0.0-2.1 -> 1.0.0-4 > ( libs )
  7 libatasmart4 [ amd64 ] < 0.17+git20100219-2 -> 0.19-1 > ( libs )
  7 libtotem-plparser17 [ amd64 ] < 2.30.3-1 -> 3.4.2-1 > ( libs )
  7 libusbmuxd1 [ amd64 ] < 1.0.4-1 -> 1.0.7-2 > ( libs )
  7 libtag1c2a [ amd64 ] < 1.6.3-1 -> 1.7.1-3 > ( libs )
  7 libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs )
  7 libgfortran3 [ amd64 ] < 4.4.5-8 -> 4.7.0-8 > ( libs )
  7 libcdio-cdda0 [ amd64 ] < 0.81-4 -> 0.81-5 > ( libs )
  7 libexif12 [ amd64 ] < 0.6.19-1 -> 0.6.20-2 > ( libs )
  7 glib-networking-services [ amd64 ] < none -> 2.32.3-1 > ( libs )
  7 liboauth0 [ amd64 ] < none -> 0.9.4-3+b1 > ( libs )
  6 libpolkit-backend-1-0 [ amd64 ] < 0.96-4+squeeze2 -> 0.105-1 > ( libs )
  6 dmsetup [ amd64 ] < 2:1.02.48-5 -> 2:1.02.74-4 > ( admin )
  6 gir1.0-glib-2.0 [ amd64 ] < 0.6.14-1+b1 > ( libs )
  6 gnome-shell [ amd64 ] < none -> 3.4.1-5 > ( gnome )
  6 nautilus [ amd64 ] < 2.30.1-2squeeze1 -> 3.4.2-1 > ( gnome )
  6 libidn11 [ amd64 ] < none -> 1.25-2 > ( libs )
  6 libavc1394-0 [ amd64 ] < 0.5.3-1+b2 -> 0.5.4-1 > ( libs )
  6 libbonobo2-common [ amd64 ] < 2.24.3-1 > ( gnome )
  6 libnm-gtk0 [ amd64 ] < none -> 0.9.4.1-1+b1 > ( libs )
  6 udisks [ amd64 ] < 1.0.1+git20100614-3 -> 1.0.4-5 > ( admin )
  6 gstreamer0.10-gconf [ amd64 ] < none -> 0.10.31-3 > ( sound )
  6 libproxy0 [ amd64 ] < 0.3.1-2 -> 0.3.1-5 > ( libs )
  6 accountsservice [ amd64 ] < none -> 0.6.15-4 > ( admin )
  6 libcheese-gtk21 [ amd64 ] < none -> 3.4.2-1 > ( libs )
  6 libgomp1 [ amd64 ] < none -> 4.7.0-8 > ( libs )
  6 libgweather-common [ amd64 ] < 2.30.3-1 -> 3.4.1-1 > ( libs )
  6 insserv [ amd64 ] < 1.14.0-2 -> 1.14.0-3 > ( misc )
  6 libencode-locale-perl [ amd64 ] < none -> 1.03-1 > ( perl )
  6 libgirepository1.0-0 [ amd64 ] < 0.6.14-1+b1 > ( libs )
  6 libclass-isa-perl [ amd64 ] < none -> 0.36-3 > ( perl )
  6 evince-common [ amd64 ] < 2.30.3-2+squeeze1 -> 3.4.0-2 > ( gnome )
  6 gnome-terminal-data [ amd64 ] < 2.30.2-1 -> 3.4.1.1-1 > ( gnome )
  6 libcanberra-gtk0 [ amd64 ] < 0.24-1 -> 0.28-4 > ( libs )
  6 libmx-1.0-2 [ amd64 ] < none -> 1.4.6-1 > ( libs )
  6 libswitch-perl [ amd64 ] < none -> 2.16-2 > ( perl )
  6 libfolks-eds25 [ amd64 ] < none -> 0.6.9-1 > ( libs )
  6 libjpeg62 [ amd64 ] < 6b1-1 -> 6b1-3 > ( oldlibs )
  6 libbonoboui2-0 [ amd64 ] < 2.24.3-1 > ( libs )
  6 libcurl3-gnutls [ amd64 ] < none -> 7.26.0-1 > ( libs )
  6 libseed-gtk3-0 [ amd64 ] < none -> 3.2.0-1 > ( libs )
  6 libpam-gnome-keyring [ amd64 ] < none -> 3.4.1-4 > ( admin )
  6 liblwp-mediatypes-perl [ amd64 ] < none -> 6.02-1 > ( perl )
  6 python-gtk2 [ amd64 ] < 2.17.0-4 -> 2.24.0-3 > ( python )
  6 epiphany-browser-data [ amd64 ] < 2.30.6-1 -> 3.4.2-1 > ( gnome )
  6 libgnomekbd-common [ amd64 ] < 2.30.2-2 -> 3.4.0.2-1 > ( libs )
  6 kmod [ amd64 ] < none -> 8-2 > ( admin )
  5 libsmbclient [ amd64 ] < 2:3.5.6~dfsg-3squeeze8 -> 2:3.6.5-6 > ( libs )
  5 gir1.2-gnomebluetooth-1.0 [ amd64 ] < none -> 3.4.0-2 > ( introspection )
  5 metacity [ amd64 ] < 1:2.30.1-3 -> 1:2.34.3-2 > ( x11 )
  5 libcdio-paranoia0 [ amd64 ] < 0.81-4 -> 0.81-5 > ( libs )
  5 python-numpy [ amd64 ] < 1:1.4.1-5 -> 1:1.6.2-1 > ( python )
  5 gnome-applets [ amd64 ] < 2.30.0-3 -> 3.4.1-1 > ( gnome )
  5 libsamplerate0 [ amd64 ] < none -> 0.1.8-4 > ( libs )
  5 whiptail [ amd64 ] < 0.52.11-1 -> 0.52.14-10 > ( utils )
  5 gnome-panel-data [ amd64 ] < 2.30.2-2 -> 3.4.2.1-2 > ( gnome )
  5 glib-networking-common [ amd64 ] < none -> 2.32.3-1 > ( libs )
  5 libsocialweb-client2 [ amd64 ] < none -> 0.25.20-1 > ( libs )
  5 gir1.2-json-1.0 [ amd64 ] < none -> 0.14.2-1 > ( introspection )
  5 libapr1 [ amd64 ] < none -> 1.4.6-3 > ( libs )
  5 libedata-book-1.2-11 [ amd64 ] < none -> 3.2.2-3 > ( libs )
  5 libedata-cal-1.2-13 [ amd64 ] < none -> 3.2.2-3 > ( libs )
  5 libmutter0 [ amd64 ] < none -> 3.4.1-4 > ( libs )
  5 libck-connector0 [ amd64 ] < 0.4.1-4 -> 0.4.5-3 > ( libs )
  5 apg [ amd64 ] < none -> 2.2.3.dfsg.1-2 > ( admin )
  5 libdrm2 [ amd64 ] < 2.4.21-1~squeeze3 -> 2.4.33-1 > ( libs )
  5 gir1.2-coglpango-1.0 [ amd64 ] < none -> 1.10.2-3 > ( introspection )
  5 libexempi3 [ amd64 ] < 2.1.1-1 -> 2.2.0-1 > ( libs )
  5 libxaw7 [ amd64 ] < 2:1.0.7-1 -> 2:1.0.10-2 > ( libs )
  5 gnome-themes-standard [ amd64 ] < none -> 3.4.2-1 > ( gnome )
  5 libgdu0 [ amd64 ] < 2.30.1-2 -> 3.0.2-2 > ( libs )
  5 libhttp-message-perl [ amd64 ] < none -> 6.03-1 > ( perl )
  5 librest-0.7-0 [ amd64 ] < none -> 0.7.12-2 > ( libs )
  5 libxmu6 [ amd64 ] < 2:1.0.5-2 -> 2:1.1.1-1 > ( libs )
  5 packagekit [ amd64 ] < none -> 0.7.4-4 > ( admin )
  5 python-gobject [ amd64 ] < 2.21.4+is.2.21.3-1 -> 3.2.2-1 > ( python )
  5 libisccfg82 [ amd64 ] < none -> 1:9.8.1.dfsg.P1-4 > ( libs )
  5 libwww-perl [ amd64 ] < 5.836-1 -> 6.04-1 > ( perl )
  5 librtmp0 [ amd64 ] < none -> 2.4+20111222.git4e06e21-1 > ( libs )
  5 libsemanage1 [ amd64 ] < none -> 2.1.6-2 > ( libs )
  5 libgoa-1.0-common [ amd64 ] < none -> 3.4.2-1 > ( libs )
  5 libwebkitgtk-3.0-common [ amd64 ] < none -> 1.8.1-2 > ( libs )
  5 libgphoto2-2 [ amd64 ] < 2.4.6-3 -> 2.4.14-2 > ( libs )
  4 libevolution [ amd64 ] < 2.30.3-5 -> 3.2.2-1+b1 > ( gnome )
  4 gedit-common [ amd64 ] < 2.30.4-1squeeze1 -> 3.4.2-1 > ( gnome )
  4 gnome-js-common [ amd64 ] < 0.1.1-1 -> 0.1.2-1 > ( interpreters )
  4 libnl-3-200 [ amd64 ] < none -> 3.2.7-2 > ( libs )
  4 libnettle4 [ amd64 ] < none -> 2.4-1 > ( libs )
  4 libgmime-2.6-0 [ amd64 ] < none -> 2.6.9-1 > ( libs )
  4 usbmuxd [ amd64 ] < 1.0.4-1 -> 1.0.7-2 > ( utils )
  4 gtk2-engines [ amd64 ] < 1:2.20.1-1 -> 1:2.20.2-2 > ( gnome )
  4 libspectre1 [ amd64 ] < 0.2.6-1 -> 0.2.6-1+b1 > ( libs )
  4 obex-data-server [ amd64 ] < none -> 0.4.5-1+b3 > ( admin )
  4 epiphany-browser [ amd64 ] < 2.30.6-1 -> 3.4.2-1 > ( gnome )
  4 libtelepathy-logger2 [ amd64 ] < none -> 0.4.0-1 > ( libs )
  4 gnome-terminal [ amd64 ] < 2.30.2-1 -> 3.4.1.1-1 > ( gnome )
  4 libxcb-glx0 [ amd64 ] < none -> 1.8.1-1 > ( libs )
  4 libglapi-mesa [ amd64 ] < none -> 8.0.2-2 > ( libs )
  4 libapt-inst1.5 [ amd64 ] < none -> 0.9.5.1 > ( admin )
  4 libfam0 [ amd64 ] < 2.7.0-17 > ( libs )
  4 libglibmm-2.4-1c2a [ amd64 ] < none -> 2.32.0-1 > ( libs )
  4 liblzma2 [ amd64 ] < 5.0.0-2 > ( libs )
  4 libhtml-tree-perl [ amd64 ] < 3.23-2 -> 4.2-1 > ( perl )
  4 gir1.2-gconf-2.0 [ amd64 ] < none -> 3.2.5-1 > ( introspection )
  4 libxres1 [ amd64 ] < 2:1.0.4-1 -> 2:1.0.6-1 > ( libs )
  4 apt [ amd64 ] < 0.8.10.3+squeeze1 -> 0.9.5.1 > ( admin )
  4 libgnome-desktop-2-17 [ amd64 ] < 2.30.2-2 -> 2.32.1-2 > ( libs )
  4 liblwres80 [ amd64 ] < none -> 1:9.8.1.dfsg.P1-4 > ( libs )
  4 libt1-5 [ amd64 ] < 5.1.2-3+squeeze1 -> 5.1.2-3.5 > ( libs )
  4 libgtkhtml3.14-19 [ amd64 ] < 3.30.3-1 -> 3.32.2-2.1 > ( libs )
  4 gnome-bluetooth [ amd64 ] < none -> 3.4.0-2 > ( gnome )
  4 gnome-applets-data [ amd64 ] < 2.30.0-3 -> 3.4.1-1 > ( gnome )
  4 libnet-http-perl [ amd64 ] < none -> 6.03-2 > ( perl )
  4 libglib2.0-bin [ amd64 ] < none -> 2.32.3-1 > ( misc )
  4 libbind9-80 [ amd64 ] < none -> 1:9.8.1.dfsg.P1-4 > ( libs )
  4 libdjvulibre21 [ amd64 ] < 3.5.23-3 -> 3.5.25.2-4 > ( libs )
  4 evince [ amd64 ] < 2.30.3-2+squeeze1 -> 3.4.0-2+b1 > ( gnome )
  4 pm-utils [ amd64 ] < none -> 1.4.1-9 > ( admin )
  4 isc-dhcp-client [ amd64 ] < none -> 4.2.2.dfsg.1-5 > ( net )
  4 libxpm4 [ amd64 ] < 1:3.5.8-1 -> 1:3.5.10-1 > ( libs )
  4 libdvdnav4 [ amd64 ] < none -> 4.2.0-1 > ( libs )
  4 libgl1 [ amd64 ] < none > ( none )
  4 libdvdread4 [ amd64 ] < none -> 4.2.0-1 > ( libs )
  4 libblas3gf [ amd64 ] < 1.2-8 -> 1.2.20110419-2 > ( libs )
  4 libcap-ng0 [ amd64 ] < none -> 0.6.6-1 > ( libs )
  4 libgeoip1 [ amd64 ] < none -> 1.4.8+dfsg-3 > ( libs )
  4 libquvi7 [ amd64 ] < none -> 0.4.1-1 > ( libs )
  4 libgnomeui-common [ amd64 ] < 2.24.3-1 -> 2.24.5-2 > ( libs )
  4 libgupnp-igd-1.0-4 [ amd64 ] < none -> 0.2.1-2 > ( libs )
  4 zenity-common [ amd64 ] < none -> 3.4.0-2 > ( gnome )
  4 openssl [ amd64 ] < none -> 1.0.1c-3 > ( utils )
  4 libgcr-3-common [ amd64 ] < none -> 3.4.1-3 > ( libs )
  4 libtracker-sparql-0.14-0 [ amd64 ] < none -> 0.14.1-1+b1 > ( libs )
  4 gir1.2-clutter-1.0 [ amd64 ] < none -> 1.10.6-1 > ( introspection )
  4 telepathy-mission-control-5 [ amd64 ] < none -> 1:5.12.0-2 > ( net )
  4 libgtksourceview2.0-common [ amd64 ] < 2.10.4-1 > ( libs )
  3 folks-common [ amd64 ] < none -> 0.6.9-1 > ( libs )
  3 libatlas3gf-base [ amd64 ] < none -> 3.8.3-27 > ( libs )
  3 libcupsimage2 [ amd64 ] < 1.4.4-7+squeeze1 -> 1.5.3-1 > ( libs )
  3 libsgutils2-2 [ amd64 ] < 1.29-1 -> 1.33-1 > ( libs )
  3 gnome-mime-data [ amd64 ] < 2.18.0-1 > ( gnome )
  3 obexd-client [ amd64 ] < none -> 0.46-1 > ( admin )
  3 x11-utils [ amd64 ] < 7.5+4 -> 7.7~1 > ( x11 )
  3 ttf-dejavu-core [ amd64 ] < 2.31-1 -> 2.33-2 > ( fonts )
  3 libjbig2dec0 [ amd64 ] < 0.11-1 -> 0.11+20120125-1 > ( libs )
  3 libparted0debian1 [ amd64 ] < 2.3-5 -> 2.3-9.1 > ( libs )
  3 packagekit-backend-aptcc [ amd64 ] < none -> 0.7.4-4 > ( admin )
  3 libpython2.7 [ amd64 ] < none -> 2.7.3~rc2-2.1 > ( libs )
  3 gedit [ amd64 ] < 2.30.4-1squeeze1 -> 3.4.2-1 > ( gnome )
  3 gcc-4.6-base [ amd64 ] < none -> 4.6.3-1 > ( libs )
  3 libhttp-negotiate-perl [ amd64 ] < none -> 6.00-2 > ( perl )
  3 libfile-listing-perl [ amd64 ] < none -> 6.04-1 > ( perl )
  3 libfftw3-3 [ amd64 ] < none -> 3.3.2-1 > ( libs )
  3 libtimedate-perl [ amd64 ] < none -> 1.2000-1 > ( perl )
  3 libmozjs185-1.0 [ amd64 ] < none -> 1.8.5-1.0.0+dfsg-3 > ( libs )
  3 libtotem0 [ amd64 ] < none -> 3.0.1-8 > ( video )
  3 bluez [ amd64 ] < none -> 4.99-2 > ( admin )
  3 mutter-common [ amd64 ] < none -> 3.4.1-4 > ( misc )
  3 libcap2-bin [ amd64 ] < none -> 1:2.22-1 > ( utils )
  3 libaccountsservice0 [ amd64 ] < none -> 0.6.15-4 > ( libs )
  3 liblwp-protocol-https-perl [ amd64 ] < none -> 6.03-1 > ( perl )
  3 libevdocument3-4 [ amd64 ] < none -> 3.4.0-2+b1 > ( libs )
  3 hunspell-dictionary [ amd64 ] < none > ( none )
  3 cpp [ amd64 ] < 4:4.4.5-1 -> 4:4.6.2-4 > ( interpreters )
  3 libhttp-cookies-perl [ amd64 ] < none -> 6.00-2 > ( perl )
  3 libavahi-ui-gtk3-0 [ amd64 ] < none -> 0.6.31-1 > ( libs )
  3 gcr [ amd64 ] < none -> 3.4.1-3 > ( gnome )
  3 aspell-dictionary [ amd64 ] < none > ( none )
  3 libgtksourceview-3.0-common [ amd64 ] < none -> 3.4.2-1 > ( libs )
  3 libvpx1 [ amd64 ] < none -> 1.1.0-1 > ( libs )
  3 libssh2-1 [ amd64 ] < none -> 1.4.2-1 > ( libs )
  3 libspeexdsp1 [ amd64 ] < none -> 1.2~rc1-6 > ( libs )
  3 cheese-common [ amd64 ] < none -> 3.4.2-1 > ( gnome )
  3 python-dbus [ amd64 ] < none -> 1.1.0-1 > ( python )
  3 gir1.0-freedesktop [ amd64 ] < 0.6.14-1+b1 > ( libs )
  3 libgsm1 [ amd64 ] < none -> 1.0.13-4 > ( libs )
  3 libschroedinger-1.0-0 [ amd64 ] < none -> 1.0.11-2 > ( libs )
  3 libxvidcore4 [ amd64 ] < none -> 2:1.3.2-9 > ( libs )
  3 libcamel1.2-14 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  3 libmission-control-plugins0 [ amd64 ] < none -> 1:5.12.0-2 > ( libs )
  3 libssl0.9.8 [ amd64 ] < 0.9.8o-4squeeze12 > ( libs )
  3 brasero [ amd64 ] < none -> 3.2.0-4 > ( gnome )
  3 dictionaries-common [ amd64 ] < none -> 1.12.8 > ( text )
  3 libgnome-menu2 [ amd64 ] < 2.30.3-1 -> 3.0.1-4 > ( gnome )
  3 libdirac-encoder0 [ amd64 ] < none -> 1.0.2-6 > ( libs )
  3 libebackend1.2-0 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  3 libdjvulibre-text [ amd64 ] < 3.5.23-3 -> 3.5.25.2-4 > ( libs )
  3 libavahi-gobject0 [ amd64 ] < 0.6.27-2+squeeze1 -> 0.6.31-1 > ( libs )
  3 libopenjpeg2 [ amd64 ] < 1.3+dfsg-4 -> 1.3+dfsg-4+b1 > ( libs )
  3 libaprutil1 [ amd64 ] < none -> 1.4.1-2 > ( libs )
  3 libwww-robotrules-perl [ amd64 ] < none -> 6.01-1 > ( perl )
  3 libpaper1 [ amd64 ] < 1.1.24 -> 1.1.24+nmu2 > ( libs )
  3 myspell-dictionary [ amd64 ] < none > ( none )
  3 mawk [ amd64 ] < 1.3.3-15 -> 1.3.3-17 > ( interpreters )
  3 libebook1.2-9 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  2 libopenal1 [ amd64 ] < none -> 1:1.14-4 > ( libs )
  2 file-rc [ amd64 ] < none -> 0.8.12 > ( admin )
  2 libsoundtouch0 [ amd64 ] < none -> 1.6.0-3 > ( libs )
  2 python-gnome2 [ amd64 ] < 2.28.1-1 -> 2.28.1+dfsg-1 > ( python )
  2 libtalloc2 [ amd64 ] < 2.0.1-1 -> 2.0.7+git20120207-1 > ( libs )
  2 hdparm [ amd64 ] < none -> 9.39-1 > ( admin )
  2 libmodplug1 [ amd64 ] < none -> 1:0.8.8.4-3 > ( libs )
  2 libzbar0 [ amd64 ] < none -> 0.10+doc-7+b2 > ( libs )
  2 python-pyorbit [ amd64 ] < 2.24.0-6 -> 2.24.0-6+b1 > ( python )
  2 libgtksourceview-3.0-0 [ amd64 ] < none -> 3.4.2-1 > ( libs )
  2 liblcms1 [ amd64 ] < 1.18.dfsg-1.2+b3 -> 1.19.dfsg-1.1 > ( libs )
  2 bind9-host [ amd64 ] < none -> 1:9.8.1.dfsg.P1-4 > ( net )
  2 libgjs0-libmozjs185-1.0 [ amd64 ] < none > ( none )
  2 aspell [ amd64 ] < none -> 0.60.7~20110707-1 > ( text )
  2 gir1.2-peas-1.0 [ amd64 ] < none -> 1.4.0-2 > ( introspection )
  2 libxxf86dga1 [ amd64 ] < 2:1.1.1-2 -> 2:1.1.2-1 > ( libs )
  2 libnet-dbus-perl [ amd64 ] < 0.33.6-2 -> 1.0.0-1+b1 > ( perl )
  2 hunspell-en-us [ amd64 ] < none -> 20070829-5 > ( text )
  2 gstreamer0.10-plugins-ugly [ amd64 ] < none -> 0.10.19-2+b1 > ( libs )
  2 libxml-parser-perl [ amd64 ] < 2.36-1.1+b1 -> 2.41-1+b1 > ( perl )
  2 libmagickcore5 [ amd64 ] < none -> 8:6.7.7.2-1 > ( libs )
  2 libbluray1 [ amd64 ] < none -> 1:0.2.2-1 > ( libs )
  2 evolution [ amd64 ] < 2.30.3-5 -> 3.2.2-1+b1 > ( gnome )
  2 libgnomeui-0 [ amd64 ] < 2.24.3-1 -> 2.24.5-2 > ( libs )
  2 gir1.2-gee-1.0 [ amd64 ] < none -> 0.6.4-2 > ( introspection )
  2 gstreamer0.10-alsa [ amd64 ] < 0.10.30-1 -> 0.10.36-1 > ( libs )
  2 libgucharmap-2-90-7 [ amd64 ] < none -> 1:3.4.1.1-1 > ( libs )
  2 aspell6a-dictionary [ amd64 ] < none > ( none )
  2 gir1.2-telepathyglib-0.12 [ amd64 ] < none -> 0.18.1-2 > ( introspection )
  2 libzvbi0 [ amd64 ] < none -> 0.2.33-5 > ( libs )
  2 gnome-system-monitor [ amd64 ] < none -> 3.4.1-2 > ( gnome )
  2 libdca0 [ amd64 ] < none -> 0.0.5-5 > ( libs )
  2 libwbclient0 [ amd64 ] < 2:3.5.6~dfsg-3squeeze8 -> 2:3.6.5-6 > ( libs )
  2 libcpufreq0 [ amd64 ] < 007-1+squeeze1 -> 008-1 > ( libs )
  2 libslv2-9 [ amd64 ] < none -> 0.6.6+dfsg1-2 > ( libs )
  2 x-session-manager [ amd64 ] < none > ( none )
  2 libevview3-3 [ amd64 ] < none -> 3.4.0-2+b1 > ( libs )
  2 evolution-common [ amd64 ] < 2.30.3-5 -> 3.2.2-1 > ( gnome )
  2 liblapack3gf [ amd64 ] < 3.2.1-8 -> 3.3.1-1 > ( libs )
  2 libxmuu1 [ amd64 ] < 2:1.0.5-2 -> 2:1.1.1-1 > ( libs )
  2 libthai-data [ amd64 ] < 0.1.14-2 -> 0.1.17-1 > ( libs )
  2 libv4lconvert0 [ amd64 ] < none -> 0.8.8-2 > ( libs )
  2 libwnck-3-common [ amd64 ] < none -> 3.4.2-1 > ( libs )
  2 liblqr-1-0 [ amd64 ] < none -> 0.4.1-2 > ( libs )
  2 libdirectfb-1.2-9 [ amd64 ] < none -> 1.2.10.0-5 > ( libs )
  2 libdatrie1 [ amd64 ] < 0.2.4-1 -> 0.2.5-3 > ( libs )
  2 libnice10 [ amd64 ] < none -> 0.1.2-1 > ( libs )
  2 libgdu-gtk0 [ amd64 ] < 2.30.1-2 -> 3.0.2-2 > ( libs )
  2 gstreamer0.10-ffmpeg [ amd64 ] < none -> 0.10.13-5 > ( video )
  2 imagemagick-common [ amd64 ] < none -> 8:6.7.7.2-1 > ( graphics )
  2 libcluttergesture-0.0.2-0 [ amd64 ] < none -> 0.0.2.1-6+b2 > ( libs )
  2 libmetacity-private0a [ amd64 ] < none -> 1:2.34.3-2 > ( libs )
  2 libpeas-common [ amd64 ] < none -> 1.4.0-2 > ( libs )
  2 libnm-glib-vpn1 [ amd64 ] < none -> 0.9.4.0-5 > ( libs )
  2 libclutter-imcontext-0.1-0 [ amd64 ] < none -> 0.1.4-2+b2 > ( libs )
  2 python-dbus-dev [ amd64 ] < none -> 1.1.0-1 > ( python )
  2 libgme0 [ amd64 ] < none -> 0.5.5-2 > ( libs )
  2 libspandsp2 [ amd64 ] < none -> 0.0.6~pre18-2+b2 > ( libs )
  2 gir1.0-gtk-2.0 [ amd64 ] < 0.6.5-7 > ( libs )
  2 libwildmidi1 [ amd64 ] < none -> 0.2.3.4-2.1 > ( libs )
  2 libvo-aacenc0 [ amd64 ] < none -> 0.1.2-1 > ( libs )
  2 gir1.2-gdesktopenums-3.0 [ amd64 ] < none -> 3.4.2-1 > ( gnome )
  2 liblvm2app2.2 [ amd64 ] < none -> 2.02.95-4 > ( libs )
  2 libgs9 [ amd64 ] < none -> 9.05~dfsg-6 > ( libs )
  2 libraptor2-0 [ amd64 ] < none -> 2.0.7-1 > ( libs )
  2 gnome-contacts [ amd64 ] < none -> 3.4.1-1 > ( gnome )
  2 libfontenc1 [ amd64 ] < 1:1.0.5-2 -> 1:1.1.1-1 > ( libs )
  2 libkate1 [ amd64 ] < none -> 0.4.1-1 > ( libs )
  2 libcdaudio1 [ amd64 ] < none -> 0.99.12p2-11 > ( libs )
  2 libmimic0 [ amd64 ] < none -> 1.0.4-2.1 > ( libs )
  2 gnome-desktop-data [ amd64 ] < 2.30.2-2 -> 2.32.1-2 > ( gnome )
  2 brasero-common [ amd64 ] < none -> 3.2.0-4 > ( gnome )
  2 libclutter-gst-1.0-0 [ amd64 ] < none -> 1.5.4-1+b2 > ( libs )
  2 libblas.so.3gf [ amd64 ] < none > ( none )
  2 libvte-2.90-9 [ amd64 ] < none -> 1:0.32.2-1 > ( libs )
  2 libopus0 [ amd64 ] < none -> 0.9.14+20120521-2 > ( libs )
  2 system-tools-backends [ amd64 ] < 2.10.1-2squeeze1 -> 2.10.2-1 > ( admin )
  2 libfolks-telepathy25 [ amd64 ] < none -> 0.6.9-1 > ( libs )
  2 libio-socket-ssl-perl [ amd64 ] < none -> 1.74-1 > ( perl )
  2 libcogl-common [ amd64 ] < none -> 1.10.2-3 > ( libs )
  2 libmpcdec6 [ amd64 ] < none -> 2:0.1~r459-2 > ( libs )
  2 eject [ amd64 ] < none -> 2.1.5+deb1+cvs20081104-10 > ( utils )
  2 libmx-common [ amd64 ] < none -> 1.4.6-1 > ( misc )
  2 totem-common [ amd64 ] < 2.30.2-6 -> 3.0.1-8 > ( video )
  2 libgjs0b [ amd64 ] < none -> 1.32.0-2 > ( libs )
  2 python-gconf [ amd64 ] < 2.28.1-1 -> 2.28.1+dfsg-1 > ( python )
  2 libxml-twig-perl [ amd64 ] < 1:3.34-1 -> 1:3.39-1 > ( perl )
  2 libjack-0.116 [ amd64 ] < none > ( none )
  2 libofa0 [ amd64 ] < none -> 0.9.3-5 > ( libs )
  2 libmms0 [ amd64 ] < none -> 0.6.2-3 > ( libs )
  2 libasound2-plugins [ amd64 ] < none -> 1.0.25-2 > ( libs )
  2 libvo-amrwbenc0 [ amd64 ] < none -> 0.1.2-1 > ( libs )
  2 hwdata [ amd64 ] < none -> 0.233-1 > ( misc )
  2 libfaad2 [ amd64 ] < none -> 2.7-8 > ( libs )
  2 libtag1-vanilla [ amd64 ] < 1.6.3-1 -> 1.7.1-3 > ( libs )
  1 gnome-sushi [ amd64 ] < none -> 0.4.1-2 > ( gnome )
  1 sound-theme-freedesktop [ amd64 ] < none -> 0.7.pristine-2 > ( sound )
  1 mesa-utils [ amd64 ] < none -> 8.0.1-2+b3 > ( x11 )
  1 cups-pk-helper [ amd64 ] < none -> 0.2.1.2-1 > ( gnome )
  1 menu [ amd64 ] < none -> 2.1.46 > ( admin )
  1 dnsmasq-base [ amd64 ] < none -> 2.61-1 > ( net )
  1 bzip2 [ amd64 ] < 1.0.5-6+squeeze1 -> 1.0.6-1 > ( utils )
  1 libnet-ssleay-perl [ amd64 ] < none -> 1.48-1+b1 > ( perl )
  1 libgsf-1-common [ amd64 ] < 1.14.18-1 -> 1.14.21-2.1 > ( libs )
  1 xsltproc [ amd64 ] < 1.1.26-6 -> 1.1.26-11 > ( text )
  1 libaprutil1-dbd-pgsql [ amd64 ] < none -> 1.4.1-2 > ( libs )
  1 gir1.2-gstreamer-0.10 [ amd64 ] < none -> 0.10.36-1 > ( introspection )
  1 uuid-runtime [ amd64 ] < none -> 2.20.1-5 > ( libs )
  1 libavutil51 [ amd64 ] < none -> 6:0.8.3-1 > ( libs )
  1 libflite1 [ amd64 ] < none -> 1.4-release-4 > ( libs )
  1 libgphoto2-l10n [ amd64 ] < none -> 2.4.14-2 > ( localization )
  1 gnome-media [ amd64 ] < none -> 3.4.0-1 > ( gnome )
  1 telepathy-gabble [ amd64 ] < none -> 0.16.0-3 > ( net )
  1 libunistring0 [ amd64 ] < none -> 0.9.3-5 > ( libs )
  1 procps [ amd64 ] < none -> 1:3.3.2-3 > ( admin )
  1 enchant [ amd64 ] < none -> 1.6.0-7 > ( text )
  1 gir1.2-gmenu-3.0 [ amd64 ] < none -> 3.4.2-1 > ( introspection )
  1 gir1.2-upowerglib-1.0 [ amd64 ] < none -> 0.9.16-2 > ( introspection )
  1 libkpathsea5 [ amd64 ] < 2009-8 > ( libs )
  1 libkpathsea6 [ amd64 ] < none -> 2012.20120530-2+b1 > ( libs )
  1 geoclue-localnet [ amd64 ] < none -> 0.12.0-4 > ( utils )
  1 totem-plugins [ amd64 ] < none -> 3.0.1-8 > ( video )
  1 evolution-plugins [ amd64 ] < none -> 3.2.2-1+b1 > ( gnome )
  1 libwebrtc-audio-processing-0 [ amd64 ] < none -> 0.1-2 > ( libs )
  1 libtie-ixhash-perl [ amd64 ] < none -> 1.21-2 > ( perl )
  1 libxml2-utils [ amd64 ] < 2.7.8.dfsg-2+squeeze3 -> 2.8.0+dfsg1-3 > ( text )
  1 libgail-3-common [ amd64 ] < none > ( none )
  1 libecal1.2-7 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  1 gnome-disk-utility [ amd64 ] < 2.30.1-2 -> 3.0.2-2 > ( admin )
  1 libsocialweb0 [ amd64 ] < none -> 0.25.20-1 > ( libs )
  1 libsystemd-daemon0 [ amd64 ] < none -> 44-2 > ( libs )
  1 libhttp-daemon-perl [ amd64 ] < none -> 6.01-1 > ( perl )
  1 tracker-gui [ amd64 ] < none -> 0.14.1-1+b1 > ( gnome )
  1 telepathy-haze [ amd64 ] < none -> 0.6.0-1 > ( net )
  1 alacarte [ amd64 ] < none -> 0.13.4-2 > ( utils )
  1 libaprutil1-dbd-mysql [ amd64 ] < none -> 1.4.1-2 > ( libs )
  1 libgl1-mesa-dri [ amd64 ] < none -> 8.0.2-2 > ( libs )
  1 libvte-common [ amd64 ] < 1:0.24.3-3 -> 1:0.28.2-4 > ( libs )
  1 libmagickwand5 [ amd64 ] < none -> 8:6.7.7.2-1 > ( libs )
  1 geoclue-yahoo [ amd64 ] < none -> 0.12.0-4 > ( utils )
  1 x-window-manager [ amd64 ] < none > ( none )
  1 libgnomevfs2-extra [ amd64 ] < none -> 1:2.24.4-1 > ( oldlibs )
  1 mobile-broadband-provider-info [ amd64 ] < none -> 20120402-1 > ( admin )
  1 gcc-4.4-base [ amd64 ] < 4.4.5-8 -> 4.4.7-1 > ( libs )
  1 dosfstools [ amd64 ] < none -> 3.0.12-1 > ( otherosfs )
  1 pulseaudio-module-x11 [ amd64 ] < none -> 2.0-3 > ( sound )
  1 libhtml-form-perl [ amd64 ] < none -> 6.03-1 > ( perl )
  1 gir1.2-caribou-1.0 [ amd64 ] < none -> 0.4.2-2 > ( introspection )
  1 libatm1 [ amd64 ] < none -> 1:2.5.1-1.3 > ( libs )
  1 libass4 [ amd64 ] < none -> 0.10.0-3 > ( libs )
  1 libmx-bin [ amd64 ] < none -> 1.4.6-1 > ( misc )
  1 libaprutil1-ldap [ amd64 ] < none -> 1.4.1-2 > ( libs )
  1 telepathy-salut [ amd64 ] < none -> 0.8.0-2 > ( net )
  1 mtools [ amd64 ] < none -> 4.0.12-1 > ( otherosfs )
  1 libcanberra-gtk-module [ amd64 ] < none -> 0.28-4 > ( libs )
  1 libpam-ck-connector [ amd64 ] < none -> 0.4.5-3 > ( admin )
  1 gir1.0-clutter-1.0 [ amd64 ] < 1.2.12-3 > ( libs )
  1 evolution-webcal [ amd64 ] < none -> 2.32.0-2 > ( gnome )
  1 gir1.2-folks-0.6 [ amd64 ] < none -> 0.6.9-1 > ( introspection )
  1 gir1.2-polkit-1.0 [ amd64 ] < none -> 0.105-1 > ( introspection )
  1 x-terminal-emulator [ amd64 ] < none > ( none )
  1 libgtkhtml-editor-common [ amd64 ] < 3.30.3-1 > ( libs )
  1 poppler-data [ amd64 ] < none -> 0.4.5-7 > ( misc )
  1 libisccc80 [ amd64 ] < none -> 1:9.8.1.dfsg.P1-4 > ( libs )
  1 gir1.2-gcr-3 [ amd64 ] < none -> 3.4.1-3 > ( introspection )
  1 libfarstream-0.1-0 [ amd64 ] < none -> 0.1.2-1 > ( libs )
  1 packagekit-tools [ amd64 ] < none -> 0.7.4-4 > ( libs )
  1 libtag1-rusxmms [ amd64 ] < none -> 1.7.1-3 > ( libs )
  1 libmime-base64-perl [ amd64 ] < none > ( none )
  1 apt-utils [ amd64 ] < none -> 0.9.5.1 > ( admin )
  1 tcpd [ amd64 ] < none -> 7.6.q-23 > ( net )
  1 gir1.2-soup-2.4 [ amd64 ] < none -> 2.38.1-2 > ( introspection )
  1 libnss-mdns [ amd64 ] < none -> 0.10-3.2 > ( admin )
  1 gir1.2-gkbd-3.0 [ amd64 ] < none -> 3.4.0.2-1 > ( introspection )
  1 vbetool [ amd64 ] < none -> 1.1-2 > ( utils )
  1 libio-compress-perl [ amd64 ] < none -> 2.052-1 > ( perl )
  1 gir1.2-telepathylogger-0.2 [ amd64 ] < none -> 0.4.0-1 > ( introspection )
  1 libelf1 [ amd64 ] < none -> 0.152-1+b1 > ( libs )
  1 libmailtools-perl [ amd64 ] < none -> 2.08-1 > ( perl )
  1 libcairomm-1.0-1 [ amd64 ] < none -> 1.10.0-1 > ( libs )
  1 libgdata-common [ amd64 ] < none -> 0.12.0-1 > ( libs )
  1 libchamplain-0.12-0 [ amd64 ] < none -> 0.12.2-1+b1 > ( libs )
  1 libgp11-0 [ amd64 ] < 2.30.3-5 > ( libs )
  1 libenca0 [ amd64 ] < none -> 1.13-4 > ( libs )
  1 awk [ amd64 ] < none > ( none )
  1 rtkit [ amd64 ] < none -> 0.10-2 > ( admin )
  1 libxml-xpathengine-perl [ amd64 ] < none -> 0.13-1 > ( perl )
  1 libgmp3c2 [ amd64 ] < 2:4.3.2+dfsg-1 > ( libs )
  1 libnl-genl-3-200 [ amd64 ] < none -> 3.2.7-2 > ( libs )
  1 libnm-gtk-common [ amd64 ] < none -> 0.9.4.1-1 > ( libs )
  1 libhal1 [ amd64 ] < 0.5.14-3 -> 0.5.14-8 > ( libs )
  1 eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome )
  1 libclutter-1.0-common [ amd64 ] < none -> 1.10.6-1 > ( libs )
  1 apt-xapian-index [ amd64 ] < none -> 0.45 > ( admin )
  1 cpufrequtils [ amd64 ] < none -> 008-1 > ( admin )
  1 gjs [ amd64 ] < none -> 1.32.0-2 > ( interpreters )
  1 gir1.2-gtksource-3.0 [ amd64 ] < none -> 3.4.2-1 > ( introspection )
  1 ifupdown [ amd64 ] < none -> 0.7 > ( admin )
  1 libgtkmm-3.0-1 [ amd64 ] < none -> 3.4.0-2 > ( libs )
  1 libmozjs10d [ amd64 ] < none -> 10.0.5esr-1 > ( libs )
  1 crda [ amd64 ] < none -> 1.1.2-1 > ( net )
  1 libaprutil1-dbd-sqlite3 [ amd64 ] < none -> 1.4.1-2 > ( libs )
  1 pciutils [ amd64 ] < none -> 1:3.1.9-3 > ( admin )
  1 kbd [ amd64 ] < none -> 1.15.3-9 > ( utils )
  1 libcurl3-nss [ amd64 ] < none -> 7.26.0-1 > ( libs )
  1 libaacs0 [ amd64 ] < none -> 0.4.0-1 > ( video )
  1 modemmanager [ amd64 ] < none -> 0.5.2.0-1 > ( net )
  1 gir1.2-accountsservice-1.0 [ amd64 ] < none -> 0.6.15-4 > ( introspection )
  1 apache2.2-bin [ amd64 ] < none -> 2.2.22-6 > ( httpd )
  1 at-spi [ amd64 ] < none -> 1.32.0-1 > ( gnome )
  1 freepats [ amd64 ] < none -> 20060219-1 > ( sound )
  1 libopenobex1 [ amd64 ] < none -> 1.5-2 > ( libs )
  1 makedev [ amd64 ] < none -> 2.3.1-91 > ( admin )
  1 mousetweaks [ amd64 ] < none -> 3.4.2-1 > ( gnome )
  1 gir1.0-gstreamer-0.10 [ amd64 ] < 0.10.30-1 > ( libs )
  1 xserver-xorg [ amd64 ] < none -> 1:7.6+13 > ( x11 )
  1 libpoppler-glib4 [ amd64 ] < 0.12.4-1.2 > ( libs )
  1 libpoppler-glib8 [ amd64 ] < none -> 0.18.4-2 > ( libs )
  1 bogofilter [ amd64 ] < none -> 1.2.2+dfsg1-1+b1 > ( mail )
  1 desktop-base [ amd64 ] < 6.0.5squeeze1 -> 6.0.7 > ( x11 )
  1 ispell-dictionary [ amd64 ] < none > ( none )
  1 ttf-freefont [ amd64 ] < none -> 20120503-1 > ( oldlibs )
  1 esound-common [ amd64 ] < 0.2.41-8 -> 0.2.41-10 > ( sound )
  1 python-gi-cairo [ amd64 ] < none -> 3.2.2-1 > ( python )
  1 gnome-shell-common [ amd64 ] < none -> 3.4.1-5 > ( gnome )
  1 ppp [ amd64 ] < none -> 2.4.5-5.1 > ( admin )
  1 libaprutil1-dbd-odbc [ amd64 ] < none -> 1.4.1-2 > ( libs )
  1 geoip-database [ amd64 ] < none -> 20120503-1 > ( net )
  1 gs-cjk-resource [ amd64 ] < none -> 1.20100103-3 > ( text )
  1 libunique-3.0-0 [ amd64 ] < none -> 3.0.2-1 > ( libs )
  1 libhtml-format-perl [ amd64 ] < none -> 2.10-1 > ( perl )
  1 libfont-freetype-perl [ amd64 ] < none -> 0.03-1+b2 > ( perl )
  1 x-ttcidfont-conf [ amd64 ] < none > ( none )
  1 liblapack.so.3gf [ amd64 ] < none > ( none )
  1 cdrdao [ amd64 ] < none -> 1:1.2.3-0.3 > ( otherosfs )
  1 libgd2-xpm [ amd64 ] < none -> 2.0.36~rc1~dfsg-6.1 > ( libs )
  1 xserver-xephyr [ amd64 ] < none -> 2:1.12.1.902-1 > ( x11 )
  1 libdc1394-22 [ amd64 ] < none -> 2.2.0-2 > ( libs )
  1 ttf-bitstream-vera [ amd64 ] < none -> 1.10-8 > ( fonts )
  1 libvisual-0.4-plugins [ amd64 ] < none -> 0.4.0.dfsg.1-7 > ( sound )
  1 ttf-dejavu [ amd64 ] < none -> 2.33-2 > ( fonts )
  1 dmz-cursor-theme [ amd64 ] < 0.4.3 > ( gnome )
  1 libnet-perl [ amd64 ] < none > ( none )
  1 libwebkit-1.0-2 [ amd64 ] < 1.2.7-0+squeeze2 > ( libs )
  1 bash-completion [ amd64 ] < none -> 1:1.99-3 > ( shells )
  1 gtk2-engines-pixbuf [ amd64 ] < 2.20.1-2 -> 2.24.10-1 > ( graphics )
  1 usbutils [ amd64 ] < none -> 1:005-3 > ( utils )
  1 gnome-screensaver [ amd64 ] < 2.30.0-2squeeze1 -> 3.4.1-1 > ( gnome )
  1 alsa-base [ amd64 ] < none -> 1.0.23+dfsg-4 > ( sound )
  1 liblua5.1-0 [ amd64 ] < 5.1.4-5 -> 5.1.5-2 > ( libs )
  1 ghostscript [ amd64 ] < none -> 9.05~dfsg-6 > ( text )
  1 colord [ amd64 ] < none -> 0.1.21-1 > ( graphics )
  1 libwnck-common [ amd64 ] < 2.30.4-2 -> 2.30.7-1 > ( libs )
  1 libwebkitgtk-1.0-0 [ amd64 ] < none -> 1.8.1-2 > ( libs )
  1 libyajl2 [ amd64 ] < none -> 2.0.4-2 > ( libs )
  1 libcanberra-gtk3-module [ amd64 ] < none -> 0.28-4 > ( libs )
  1 krb5-locales [ amd64 ] < none -> 1.10.1+dfsg-1 > ( localization )
  1 dialog [ amd64 ] < none -> 1.1-20120215-1 > ( misc )
  1 sgml-data [ amd64 ] < 2.0.4 -> 2.0.6 > ( text )
  1 libdb4.7 [ amd64 ] < 4.7.25-9 > ( libs )
  1 libxml-xpath-perl [ amd64 ] < none -> 1.13-7 > ( perl )
  1 python-numpy-abi9 [ amd64 ] < none > ( none )
  1 gir1.2-networkmanager-1.0 [ amd64 ] < none -> 0.9.4.0-5 > ( introspection )
  1 geoclue-manual [ amd64 ] < none -> 0.12.0-4 > ( utils )
  1 libgtksourceview2.0-0 [ amd64 ] < 2.10.4-1 > ( libs )
  1 python-qt4-dbus [ amd64 ] < none -> 4.9.1-5 > ( python )
  1 gnupg-curl [ amd64 ] < none -> 1.4.12-4 > ( utils )
  1 gir1.2-mutter-3.0 [ amd64 ] < none -> 3.4.1-4 > ( introspection )
  1 libaprutil1-dbd-freetds [ amd64 ] < none -> 1.4.1-2 > ( libs )
  1 gnome-online-accounts [ amd64 ] < none -> 3.4.2-1 > ( gnome )
  1 cpp-4.6 [ amd64 ] < none -> 4.6.3-1 > ( interpreters )
  1 libwacom-common [ amd64 ] < none -> 0.5-1 > ( libs )
  1 geoclue-hostip [ amd64 ] < none -> 0.12.0-4 > ( utils )
  1 libpam-keyring [ amd64 ] < none > ( none )
  1 host [ amd64 ] < none -> 1:9.8.1.dfsg.P1-4 > ( net )
  1 libgstreamer-plugins-bad0.10-0 [ amd64 ] < none -> 0.10.23-6 > ( libs )
  1 libpaper-utils [ amd64 ] < none -> 1.1.24+nmu2 > ( utils )
  1 fonts-droid [ amd64 ] < none -> 20111207+git-1 > ( fonts )
  1 libgxps2 [ amd64 ] < none -> 0.2.2-2 > ( libs )
  1 console-tools [ amd64 ] < none -> 1:0.2.3dbs-70 > ( utils )
  1 libnet-libidn-perl [ amd64 ] < none -> 0.12.ds-1+b3 > ( perl )
  1 totem [ amd64 ] < 2.30.2-6 -> 3.0.1-8 > ( video )
  1 libxcb-shape0 [ amd64 ] < none -> 1.8.1-1 > ( libs )
  1 gstreamer0.10-nice [ amd64 ] < none -> 0.1.2-1 > ( net )
  1 libsasl2-modules [ amd64 ] < none -> 2.1.25.dfsg1-4+b1 > ( libs )
  1 p7zip-full [ amd64 ] < 9.04~dfsg.1-1 -> 9.20.1~dfsg.1-4 > ( utils )
  1 defoma [ amd64 ] < 0.11.11 > ( admin )
  1 gir1.2-panelapplet-4.0 [ amd64 ] < none -> 3.4.2.1-2 > ( introspection )
  1 libgdata1.2-1 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  1 iptables [ amd64 ] < none -> 1.4.13-1.1 > ( net )
  1 ntfs-3g [ amd64 ] < none -> 1:2012.1.15AR.1-1 > ( otherosfs )
  1 libbrasero-media3-1 [ amd64 ] < none -> 3.2.0-4 > ( libs )
  1 nautilus-sendto-empathy [ amd64 ] < none -> 3.4.2.1-1 > ( gnome )
  1 gsfonts [ amd64 ] < none -> 1:8.11+urwcyr1.0.7~pre44-4.2 > ( fonts )
  1 python-libxml2 [ amd64 ] < 2.7.8.dfsg-2+squeeze3 -> 2.8.0+dfsg1-3 > ( python )
  1 libavcodec-extra-53 [ amd64 ] < none -> 6:0.8.3-1 > ( libs )
  1 spamassassin [ amd64 ] < none -> 3.3.2-2 > ( mail )
  1 gsfonts-x11 [ amd64 ] < none -> 0.22 > ( fonts )
  1 libio-socket-inet6-perl [ amd64 ] < none -> 2.69-2 > ( perl )
  -1 libgweather1 [ amd64 ] < 2.30.3-1 > ( libs )
  -1 libarchive1 [ amd64 ] < 2.8.4.forreal-1+squeeze2 > ( libs )
  -1 libgmime-2.4-2 [ amd64 ] < 2.4.14-1+nmu1 > ( libs )
  -1 libgtkhtml-editor0 [ amd64 ] < 3.30.3-1 > ( libs )
  -1 libgucharmap7 [ amd64 ] < 1:2.30.3-1 > ( libs )
  -1 libseed0 [ amd64 ] < 2.30.0-1+b1 > ( libs )
  -1 libgnome-window-settings1 [ amd64 ] < 1:2.30.1-2 > ( libs )
  -1 libimobiledevice1 [ amd64 ] < 1.0.2-1 > ( libs )
  -1 libgdata-google1.2-1 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  -1 libedata-cal1.2-7 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  -1 libnotify1 [ amd64 ] < 0.5.0-2 > ( libs )
  -1 libpango1.0-common [ amd64 ] < 1.28.3-1+squeeze2 > ( misc )
  -1 gnome-about [ amd64 ] < 2.30.2-2 > ( gnome )
  -1 libgcr0 [ amd64 ] < 2.30.3-5 > ( libs )
  -1 libedataserverui1.2-8 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  -1 libpanel-applet2-0 [ amd64 ] < 2.30.2-2 > ( libs )
  -1 libedata-book1.2-2 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  -1 libegroupwise1.2-13 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  -1 librarian0 [ amd64 ] < 0.8.1-5 > ( libs )
  -1 libevince2 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  -1 libgnomekbd4 [ amd64 ] < 2.30.2-2 > ( libs )
  -1 libslab0a [ amd64 ] < 2.30.0-1 > ( libs )
  -1 libgs8 [ amd64 ] < 8.71~dfsg2-9 > ( libs )
  -1 libhunspell-1.2-0 [ amd64 ] < 1.2.11-1 > ( libs )
  -1 libnautilus-extension1 [ amd64 ] < 2.30.1-2squeeze1 > ( libs )
  -1 liboobs-1-4 [ amd64 ] < 2.30.1-1 > ( libs )
  -1 libeggdbus-1-0 [ amd64 ] < 0.6-1 > ( libs )
  -1 libquvi-scripts [ amd64 ] < none -> 0.4.5-1 > ( libs )
  -1 libjte1 [ amd64 ] < none -> 1.19-1 > ( libs )
  -1 capplets-data [ amd64 ] < 1:2.30.1-2 > ( gnome )
  -1 module-init-tools [ amd64 ] < none -> 8-2 > ( admin )
  -1 libmetacity-private0 [ amd64 ] < 1:2.30.1-3 > ( libs )
  -1 libxcb-render-util0 [ amd64 ] < 0.3.6-1 -> 0.3.8-1 > ( libs )
  -1 libmpc2 [ amd64 ] < none -> 0.9-4 > ( libs )
  -1 libaudiofile0 [ amd64 ] < 0.2.6-8 > ( libs )
  -2 libxcb-aux0 [ amd64 ] < 0.3.6-1 > ( libs )
  -2 libxcb-atom1 [ amd64 ] < 0.3.6-1 > ( libs )
  -2 libxcb-event1 [ amd64 ] < 0.3.6-1 > ( libs )
  Starting 2
  Investigating (0) perl-base [ amd64 ] < 5.10.1-17squeeze3 -> 5.14.2-11 > ( perl )
  Broken perl-base:amd64 Conflicts on defoma [ amd64 ] < 0.11.11 > ( admin ) (< 0.11.12)
    Considering defoma:amd64 1 as a solution to perl-base:amd64 5188
    Added defoma:amd64 to the remove list
    Fixing perl-base:amd64 via remove of defoma:amd64
  Investigating (0) gir1.2-glib-2.0 [ amd64 ] < none -> 1.32.1-1 > ( introspection )
  Broken gir1.2-glib-2.0:amd64 Conflicts on gir1.0-glib-2.0 [ amd64 ] < 0.6.14-1+b1 > ( libs )
    Considering gir1.0-glib-2.0:amd64 6 as a solution to gir1.2-glib-2.0:amd64 132
    Added gir1.0-glib-2.0:amd64 to the remove list
    Fixing gir1.2-glib-2.0:amd64 via remove of gir1.0-glib-2.0:amd64
  Investigating (0) gir1.2-freedesktop [ amd64 ] < none -> 1.32.1-1 > ( introspection )
  Broken gir1.2-freedesktop:amd64 Conflicts on gir1.0-freedesktop [ amd64 ] < 0.6.14-1+b1 > ( libs )
    Considering gir1.0-freedesktop:amd64 3 as a solution to gir1.2-freedesktop:amd64 59
    Added gir1.0-freedesktop:amd64 to the remove list
    Fixing gir1.2-freedesktop:amd64 via remove of gir1.0-freedesktop:amd64
  Investigating (0) gir1.2-pango-1.0 [ amd64 ] < none -> 1.30.0-1 > ( introspection )
  Broken gir1.2-pango-1.0:amd64 Conflicts on gir1.0-pango-1.0 [ amd64 ] < none > ( none )
    Considering gir1.0-gtk-2.0:amd64 2 as a solution to gir1.2-pango-1.0:amd64 37
    Added gir1.0-gtk-2.0:amd64 to the remove list
    Fixing gir1.2-pango-1.0:amd64 via remove of gir1.0-gtk-2.0:amd64
  Investigating (0) libnautilus-extension1a [ amd64 ] < none -> 3.4.2-1 > ( libs )
  Broken libnautilus-extension1a:amd64 Conflicts on libnautilus-extension1 [ amd64 ] < 2.30.1-2squeeze1 > ( libs )
    Considering libnautilus-extension1:amd64 -1 as a solution to libnautilus-extension1a:amd64 13
    Added libnautilus-extension1:amd64 to the remove list
    Fixing libnautilus-extension1a:amd64 via remove of libnautilus-extension1:amd64
  Investigating (0) evolution-data-server [ amd64 ] < 2.30.3-2+squeeze1 -> 3.2.2-3 > ( gnome )
  Broken evolution-data-server:amd64 Conflicts on libebook1.2-9 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
    Considering libebook1.2-9:amd64 3 as a solution to evolution-data-server:amd64 12
    Added libebook1.2-9:amd64 to the remove list
    Fixing evolution-data-server:amd64 via remove of libebook1.2-9:amd64
  Investigating (0) gnome-control-center-data [ amd64 ] < none -> 1:3.4.2-2 > ( gnome )
  Broken gnome-control-center-data:amd64 Conflicts on capplets-data [ amd64 ] < 1:2.30.1-2 > ( gnome )
    Considering capplets-data:amd64 -1 as a solution to gnome-control-center-data:amd64 11
    Added capplets-data:amd64 to the remove list
    Fixing gnome-control-center-data:amd64 via remove of capplets-data:amd64
  Investigating (0) gnome-panel [ amd64 ] < 2.30.2-2 -> 3.4.2.1-2 > ( gnome )
  Broken gnome-panel:amd64 Breaks on libpanel-applet2-0 [ amd64 ] < 2.30.2-2 > ( libs )
    Considering libpanel-applet2-0:amd64 -1 as a solution to gnome-panel:amd64 9
    Added libpanel-applet2-0:amd64 to the remove list
    Fixing gnome-panel:amd64 via remove of libpanel-applet2-0:amd64
  Investigating (0) gir1.2-json-1.0 [ amd64 ] < none -> 0.14.2-1 > ( introspection )
  Broken gir1.2-json-1.0:amd64 Conflicts on gir1.0-json-glib-1.0 [ amd64 ] < 0.10.2-2squeeze1 > ( libs )
    Considering gir1.0-json-glib-1.0:amd64 0 as a solution to gir1.2-json-1.0:amd64 5
    Added gir1.0-json-glib-1.0:amd64 to the remove list
    Fixing gir1.2-json-1.0:amd64 via remove of gir1.0-json-glib-1.0:amd64
  Investigating (0) gir1.2-clutter-1.0 [ amd64 ] < none -> 1.10.6-1 > ( introspection )
  Broken gir1.2-clutter-1.0:amd64 Conflicts on gir1.0-clutter-1.0 [ amd64 ] < 1.2.12-3 > ( libs )
    Considering gir1.0-clutter-1.0:amd64 1 as a solution to gir1.2-clutter-1.0:amd64 4
    Added gir1.0-clutter-1.0:amd64 to the remove list
    Fixing gir1.2-clutter-1.0:amd64 via remove of gir1.0-clutter-1.0:amd64
  Investigating (0) libmetacity-private0a [ amd64 ] < none -> 1:2.34.3-2 > ( libs )
  Broken libmetacity-private0a:amd64 Breaks on libmetacity-private0 [ amd64 ] < 1:2.30.1-3 > ( libs )
    Considering libmetacity-private0:amd64 -1 as a solution to libmetacity-private0a:amd64 2
    Added libmetacity-private0:amd64 to the remove list
    Fixing libmetacity-private0a:amd64 via remove of libmetacity-private0:amd64
  Investigating (0) gir1.2-gstreamer-0.10 [ amd64 ] < none -> 0.10.36-1 > ( introspection )
  Broken gir1.2-gstreamer-0.10:amd64 Conflicts on gir1.0-gstreamer-0.10 [ amd64 ] < 0.10.30-1 > ( libs )
    Considering gir1.0-gstreamer-0.10:amd64 1 as a solution to gir1.2-gstreamer-0.10:amd64 1
    Holding Back gir1.2-gstreamer-0.10:amd64 rather than change gir1.0-gstreamer-0.10:amd64
  Investigating (0) gir1.0-gstreamer-0.10 [ amd64 ] < 0.10.30-1 > ( libs )
  Broken gir1.0-gstreamer-0.10:amd64 Depends on gir1.0-freedesktop [ amd64 ] < 0.6.14-1+b1 > ( libs )
    Considering gir1.0-freedesktop:amd64 3 as a solution to gir1.0-gstreamer-0.10:amd64 1
    Removing gir1.0-gstreamer-0.10:amd64 rather than change gir1.0-freedesktop:amd64
  Investigating (0) libgtkhtml-editor0 [ amd64 ] < 3.30.3-1 > ( libs )
  Broken libgtkhtml-editor0:amd64 Depends on libgtkhtml3.14-19 [ amd64 ] < 3.30.3-1 -> 3.32.2-2.1 > ( libs ) (< 3.31)
    Considering libgtkhtml3.14-19:amd64 4 as a solution to libgtkhtml-editor0:amd64 -1
    Removing libgtkhtml-editor0:amd64 rather than change libgtkhtml3.14-19:amd64
  Investigating (0) libseed0 [ amd64 ] < 2.30.0-1+b1 > ( libs )
  Broken libseed0:amd64 Depends on gir1.0-glib-2.0 [ amd64 ] < 0.6.14-1+b1 > ( libs ) (>= 0.6.3)
    Considering gir1.0-glib-2.0:amd64 6 as a solution to libseed0:amd64 -1
    Removing libseed0:amd64 rather than change gir1.0-glib-2.0:amd64
  Investigating (0) libpango1.0-common [ amd64 ] < 1.28.3-1+squeeze2 > ( misc )
  Broken libpango1.0-common:amd64 Depends on defoma [ amd64 ] < 0.11.11 > ( admin ) (>= 0.11.1)
    Considering defoma:amd64 1 as a solution to libpango1.0-common:amd64 -1
    Removing libpango1.0-common:amd64 rather than change defoma:amd64
  Investigating (0) gnome-about [ amd64 ] < 2.30.2-2 > ( gnome )
  Broken gnome-about:amd64 Depends on gnome-desktop-data [ amd64 ] < 2.30.2-2 -> 2.32.1-2 > ( gnome ) (= 2.30.2-2)
    Considering gnome-desktop-data:amd64 2 as a solution to gnome-about:amd64 -1
    Removing gnome-about:amd64 rather than change gnome-desktop-data:amd64
  Investigating (0) libedataserverui1.2-8 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  Broken libedataserverui1.2-8:amd64 Depends on libebook1.2-9 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs ) (>= 2.30.3)
    Considering libebook1.2-9:amd64 3 as a solution to libedataserverui1.2-8:amd64 -1
    Removing libedataserverui1.2-8:amd64 rather than change libebook1.2-9:amd64
  Investigating (0) libedata-book1.2-2 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs )
  Broken libedata-book1.2-2:amd64 Depends on libebook1.2-9 [ amd64 ] < 2.30.3-2+squeeze1 > ( libs ) (>= 2.30.3)
    Considering libebook1.2-9:amd64 3 as a solution to libedata-book1.2-2:amd64 -1
    Removing libedata-book1.2-2:amd64 rather than change libebook1.2-9:amd64
  Investigating (1) libseed-gtk3-0 [ amd64 ] < none -> 3.2.0-1 > ( libs )
  Broken libseed-gtk3-0:amd64 Depends on gir1.2-gstreamer-0.10 [ amd64 ] < none -> 0.10.36-1 > ( introspection )
    Considering gir1.2-gstreamer-0.10:amd64 1 as a solution to libseed-gtk3-0:amd64 6
    Holding Back libseed-gtk3-0:amd64 rather than change gir1.2-gstreamer-0.10:amd64
  Broken libseed-gtk3-0:amd64 Depends on libgstreamer0.10-0 [ amd64 ] < 0.10.30-1 -> 0.10.36-1 > ( libs ) (< 0.10.25-3)
    Or group keep for libseed-gtk3-0:amd64
  Investigating (1) epiphany-browser [ amd64 ] < 2.30.6-1 -> 3.4.2-1 > ( gnome )
  Broken epiphany-browser:amd64 Depends on libseed-gtk3-0 [ amd64 ] < none -> 3.2.0-1 > ( libs )
    Considering libseed-gtk3-0:amd64 6 as a solution to epiphany-browser:amd64 4
    Removing epiphany-browser:amd64 rather than change libseed-gtk3-0:amd64
  Investigating (1) gnome-core [ amd64 ] < 1:2.30+7 -> 1:3.0+9 > ( gnome )
  Broken gnome-core:amd64 Depends on epiphany-browser [ amd64 ] < 2.30.6-1 -> 3.4.2-1 > ( gnome ) (>= 3.0)
    Considering epiphany-browser:amd64 4 as a solution to gnome-core:amd64 0
    Removing gnome-core:amd64 rather than change epiphany-browser:amd64
  Investigating (2) libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs )
  Broken libpeas-1.0-0:amd64 Depends on libseed-gtk3-0 [ amd64 ] < none -> 3.2.0-1 > ( libs )
    Considering libseed-gtk3-0:amd64 6 as a solution to libpeas-1.0-0:amd64 7
    Holding Back libpeas-1.0-0:amd64 rather than change libseed-gtk3-0:amd64
  Investigating (2) gedit [ amd64 ] < 2.30.4-1squeeze1 -> 3.4.2-1 > ( gnome )
  Broken gedit:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs ) (>= 1.1.0)
    Considering libpeas-1.0-0:amd64 7 as a solution to gedit:amd64 3
    Removing gedit:amd64 rather than change libpeas-1.0-0:amd64
  Investigating (2) libtotem0 [ amd64 ] < none -> 3.0.1-8 > ( video )
  Broken libtotem0:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs ) (>= 1.0.0)
    Considering libpeas-1.0-0:amd64 7 as a solution to libtotem0:amd64 3
    Holding Back libtotem0:amd64 rather than change libpeas-1.0-0:amd64
  Investigating (2) gir1.2-peas-1.0 [ amd64 ] < none -> 1.4.0-2 > ( introspection )
  Broken gir1.2-peas-1.0:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs ) (>= 1.4.0)
    Considering libpeas-1.0-0:amd64 7 as a solution to gir1.2-peas-1.0:amd64 2
    Holding Back gir1.2-peas-1.0:amd64 rather than change libpeas-1.0-0:amd64
  Investigating (2) eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome )
  Broken eog:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs ) (>= 1.0.0)
    Considering libpeas-1.0-0:amd64 7 as a solution to eog:amd64 1
    Holding Back eog:amd64 rather than change libpeas-1.0-0:amd64
  Investigating (2) totem [ amd64 ] < 2.30.2-6 -> 3.0.1-8 > ( video )
  Broken totem:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs ) (>= 1.0.0)
    Considering libpeas-1.0-0:amd64 7 as a solution to totem:amd64 1
    Removing totem:amd64 rather than change libpeas-1.0-0:amd64
  Investigating (3) libglib2.0-0 [ amd64 ] < 2.24.2-1 -> 2.32.3-1 > ( libs )
  Broken libglib2.0-0:amd64 Breaks on eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome ) (< 3.2.2-3)
    Considering eog:amd64 1 as a solution to libglib2.0-0:amd64 1784
    Upgrading eog:amd64 due to Breaks field in libglib2.0-0:amd64
  Investigating (3) eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome )
  Broken eog:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs ) (>= 1.0.0)
    Considering libpeas-1.0-0:amd64 7 as a solution to eog:amd64 1
    Holding Back eog:amd64 rather than change libpeas-1.0-0:amd64
  Investigating (4) libglib2.0-0 [ amd64 ] < 2.24.2-1 -> 2.32.3-1 > ( libs )
  Broken libglib2.0-0:amd64 Breaks on eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome ) (< 3.2.2-3)
    Considering eog:amd64 1 as a solution to libglib2.0-0:amd64 1784
    Upgrading eog:amd64 due to Breaks field in libglib2.0-0:amd64
  Investigating (4) eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome )
  Broken eog:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs ) (>= 1.0.0)
    Considering libpeas-1.0-0:amd64 7 as a solution to eog:amd64 1
    Holding Back eog:amd64 rather than change libpeas-1.0-0:amd64
  Investigating (5) libglib2.0-0 [ amd64 ] < 2.24.2-1 -> 2.32.3-1 > ( libs )
  Broken libglib2.0-0:amd64 Breaks on eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome ) (< 3.2.2-3)
    Considering eog:amd64 1 as a solution to libglib2.0-0:amd64 1784
    Upgrading eog:amd64 due to Breaks field in libglib2.0-0:amd64
  Investigating (5) eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome )
  Broken eog:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs ) (>= 1.0.0)
    Considering libpeas-1.0-0:amd64 7 as a solution to eog:amd64 1
    Holding Back eog:amd64 rather than change libpeas-1.0-0:amd64
  Investigating (6) libglib2.0-0 [ amd64 ] < 2.24.2-1 -> 2.32.3-1 > ( libs )
  Broken libglib2.0-0:amd64 Breaks on eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome ) (< 3.2.2-3)
    Considering eog:amd64 1 as a solution to libglib2.0-0:amd64 1784
    Upgrading eog:amd64 due to Breaks field in libglib2.0-0:amd64
  Investigating (6) eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome )
  Broken eog:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs ) (>= 1.0.0)
    Considering libpeas-1.0-0:amd64 7 as a solution to eog:amd64 1
    Holding Back eog:amd64 rather than change libpeas-1.0-0:amd64
  Investigating (7) libglib2.0-0 [ amd64 ] < 2.24.2-1 -> 2.32.3-1 > ( libs )
  Broken libglib2.0-0:amd64 Breaks on eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome ) (< 3.2.2-3)
    Considering eog:amd64 1 as a solution to libglib2.0-0:amd64 1784
    Upgrading eog:amd64 due to Breaks field in libglib2.0-0:amd64
  Investigating (7) eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome )
  Broken eog:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs ) (>= 1.0.0)
    Considering libpeas-1.0-0:amd64 7 as a solution to eog:amd64 1
    Holding Back eog:amd64 rather than change libpeas-1.0-0:amd64
  Investigating (8) libglib2.0-0 [ amd64 ] < 2.24.2-1 -> 2.32.3-1 > ( libs )
  Broken libglib2.0-0:amd64 Breaks on eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome ) (< 3.2.2-3)
    Considering eog:amd64 1 as a solution to libglib2.0-0:amd64 1784
    Upgrading eog:amd64 due to Breaks field in libglib2.0-0:amd64
  Investigating (8) eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome )
  Broken eog:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs ) (>= 1.0.0)
    Considering libpeas-1.0-0:amd64 7 as a solution to eog:amd64 1
    Holding Back eog:amd64 rather than change libpeas-1.0-0:amd64
  Investigating (9) libglib2.0-0 [ amd64 ] < 2.24.2-1 -> 2.32.3-1 > ( libs )
  Broken libglib2.0-0:amd64 Breaks on eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome ) (< 3.2.2-3)
    Considering eog:amd64 1 as a solution to libglib2.0-0:amd64 1784
    Upgrading eog:amd64 due to Breaks field in libglib2.0-0:amd64
  Investigating (9) eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome )
  Broken eog:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs ) (>= 1.0.0)
    Considering libpeas-1.0-0:amd64 7 as a solution to eog:amd64 1
    Holding Back eog:amd64 rather than change libpeas-1.0-0:amd64
  Done
  The following packages have unmet dependencies:
   libglib2.0-0 : Breaks: eog (< 3.2.2-3) but 2.30.2-1 is to be installed
  E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


Cheers,

Andreas
[gnome-core.log.gz (application/x-gzip, attachment)]

Bug reassigned from package 'gnome-dbg' to 'gnome-core'. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Sat, 16 Jun 2012 09:54:12 GMT) Full text and rfc822 format available.

No longer marked as found in versions meta-gnome3/1:3.0+9. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Sat, 16 Jun 2012 09:54:13 GMT) Full text and rfc822 format available.

Marked as found in versions meta-gnome3/1:3.0+9. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Sat, 16 Jun 2012 09:54:13 GMT) Full text and rfc822 format available.

Added indication that 677407 affects gnome-core and gnome-dbg Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Sat, 16 Jun 2012 09:54:14 GMT) Full text and rfc822 format available.

Marked as found in versions meta-gnome3/1:3.4+1. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Fri, 06 Jul 2012 10:00:25 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-core. (Wed, 18 Jul 2012 12:45:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Fabian Greffrath <fabian@greffrath.com>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 18 Jul 2012 12:45:05 GMT) Full text and rfc822 format available.

Message #30 received at 677407@bugs.debian.org (full text, mbox):

From: Fabian Greffrath <fabian@greffrath.com>
To: 677407@bugs.debian.org
Cc: 677407-submitter@bugs.debian.org, apt@packages.debian.org
Subject: Re: gnome-core: fails to upgrade from squeeze - apt does not find an upgrade path
Date: Wed, 18 Jul 2012 14:39:13 +0200
>   Investigating (9) libglib2.0-0 [ amd64 ] < 2.24.2-1 -> 2.32.3-1 > ( libs )
>   Broken libglib2.0-0:amd64 Breaks on eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome ) (< 3.2.2-3)
>     Considering eog:amd64 1 as a solution to libglib2.0-0:amd64 1784
>     Upgrading eog:amd64 due to Breaks field in libglib2.0-0:amd64
>   Investigating (9) eog [ amd64 ] < 2.30.2-1 -> 3.4.1-2 > ( gnome )
>   Broken eog:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs ) (>= 1.0.0)
>     Considering libpeas-1.0-0:amd64 7 as a solution to eog:amd64 1
>     Holding Back eog:amd64 rather than change libpeas-1.0-0:amd64

For some reason apt believes it is better to not install 
libpeas-1.0-0, which would allow for upgrading eog to a version new 
enough to satisfy libglib2.0-0's Breaks relation.

What does "apt-cache policy eog libpeas-1.0-0" show?

 - Fabian



Message sent on to Andreas Beckmann <debian@abeckmann.de>:
Bug#677407. (Wed, 18 Jul 2012 12:45:06 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-core. (Wed, 18 Jul 2012 14:54:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 18 Jul 2012 14:54:03 GMT) Full text and rfc822 format available.

Message #38 received at 677407@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: Fabian Greffrath <fabian@greffrath.com>
Cc: 677407@bugs.debian.org, apt@packages.debian.org
Subject: Re: Bug#677407: gnome-core: fails to upgrade from squeeze - apt does not find an upgrade path
Date: Wed, 18 Jul 2012 16:46:09 +0200
On 2012-07-18 14:39, Fabian Greffrath wrote:
>>   Broken eog:amd64 Depends on libpeas-1.0-0 [ amd64 ] < none ->
>> 1.4.0-2 > ( libs ) (>= 1.0.0)
>>     Considering libpeas-1.0-0:amd64 7 as a solution to eog:amd64 1
>>     Holding Back eog:amd64 rather than change libpeas-1.0-0:amd64
> 
> For some reason apt believes it is better to not install libpeas-1.0-0,
> which would allow for upgrading eog to a version new enough to satisfy
> libglib2.0-0's Breaks relation.
> 
> What does "apt-cache policy eog libpeas-1.0-0" show?

libpeas-1.0-0:
  Installed: (none)
  Candidate: 1.4.0-2
  Version table:
     1.4.0-2 0
        500 http://MIRROR/debian/ testing/main amd64 Packages
eog:
  Installed: 2.30.2-1
  Candidate: 3.4.2-1
  Version table:
     3.4.2-1 0
        500 http://MIRROR/debian/ testing/main amd64 Packages
 *** 2.30.2-1 0
        100 /var/lib/dpkg/status


That's just what is available in wheezy ...

Any ideas how to find the reason for apt not wanting to install
libpeas-1.0-0?


Andreas



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-core. (Sat, 13 Oct 2012 14:45:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Neil Williams <codehelp@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Sat, 13 Oct 2012 14:45:08 GMT) Full text and rfc822 format available.

Message #43 received at 677407@bugs.debian.org (full text, mbox):

From: Neil Williams <codehelp@debian.org>
To: 677407@bugs.debian.org, 677407-submitter@bugs.debian.org
Cc: control@bugs.debian.org
Subject: No longer reproducible
Date: Sat, 13 Oct 2012 15:42:07 +0100
[Message part 1 (text/plain, inline)]
tag 677407 + unreproducible
thanks

> Any ideas how to find the reason for apt not wanting to install
> libpeas-1.0-0?

From elsewhere in the same log:

  Investigating (2) libpeas-1.0-0 [ amd64 ] < none -> 1.4.0-2 > ( libs )
  Broken libpeas-1.0-0:amd64 Depends on libseed-gtk3-0 [ amd64 ] < none -> 3.2.0-1 > ( libs )
    Considering libseed-gtk3-0:amd64 6 as a solution to libpeas-1.0-0:amd64 7
    Holding Back libpeas-1.0-0:amd64 rather than change libseed-gtk3-0:amd64

So check on libseed-gtk-3-0 ...

  Investigating (1) libseed-gtk3-0 [ amd64 ] < none -> 3.2.0-1 > ( libs )
  Broken libseed-gtk3-0:amd64 Depends on gir1.2-gstreamer-0.10 [ amd64 ] < none -> 0.10.36-1 > ( introspection )
    Considering gir1.2-gstreamer-0.10:amd64 1 as a solution to libseed-gtk3-0:amd64 6
    Holding Back libseed-gtk3-0:amd64 rather than change gir1.2-gstreamer-0.10:amd64
  Broken libseed-gtk3-0:amd64 Depends on libgstreamer0.10-0 [ amd64 ] < 0.10.30-1 -> 0.10.36-1 > ( libs ) (< 0.10.25-3)
    Or group keep for libseed-gtk3-0:amd64

  Investigating (0) gir1.2-gstreamer-0.10 [ amd64 ] < none -> 0.10.36-1 > ( introspection )
  Broken gir1.2-gstreamer-0.10:amd64 Conflicts on gir1.0-gstreamer-0.10 [ amd64 ] < 0.10.30-1 > ( libs )
    Considering gir1.0-gstreamer-0.10:amd64 1 as a solution to gir1.2-gstreamer-0.10:amd64 1
    Holding Back gir1.2-gstreamer-0.10:amd64 rather than change gir1.0-gstreamer-0.10:amd64

Elsewhere the gir1.2- packages correctly cause the removal of the
gir1.0- equivalent packages, except the gstreamer version.

  Investigating (0) gir1.0-gstreamer-0.10 [ amd64 ] < 0.10.30-1 > ( libs )
  Broken gir1.0-gstreamer-0.10:amd64 Depends on gir1.0-freedesktop [ amd64 ] < 0.6.14-1+b1 > ( libs )
    Considering gir1.0-freedesktop:amd64 3 as a solution to gir1.0-gstreamer-0.10:amd64 1
    Removing gir1.0-gstreamer-0.10:amd64 rather than change gir1.0-freedesktop:amd64

yet also:

  Investigating (0) gir1.2-freedesktop [ amd64 ] < none -> 1.32.1-1 > ( introspection )
  Broken gir1.2-freedesktop:amd64 Conflicts on gir1.0-freedesktop [ amd64 ] < 0.6.14-1+b1 > ( libs )
    Considering gir1.0-freedesktop:amd64 3 as a solution to gir1.2-freedesktop:amd64 59
    Added gir1.0-freedesktop:amd64 to the remove list
    Fixing gir1.2-freedesktop:amd64 via remove of gir1.0-freedesktop:amd64

However, I can't see why if gir1.0-freedesktop is to be removed and
then refuses to change it to fix gir1.0-gstreamer-0.10

I have tried to reproduce this problem:

0: A default Squeeze VM, updated to 6.0.6

1: gnome-dbg installed with recommends disabled

2: Wheezy apt source added 

apt-get dist-upgrade calculated a usable path and gave a result of:

1139 upgraded, 823 newly installed, 66 to remove and 2 not upgraded.
Need to get 1,352 MB of archives.
After this operation, 1,010 MB of additional disk space will be used.

This could have been due to transitions which have since completed in Wheezy. 

To test, I took the list of packages involved in the apt dependency
resolution process, removed package names which apt listed as virtual
packages and tried to install the entire set (to see if any test
packages were not installed).

gir1.0-clutter-1.0 : Depends: gir1.0-json-glib-1.0 but it is not going to be installed
 gir1.2-atk-1.0 : Conflicts: gir1.0-atk-1.0
 gir1.2-clutter-1.0 : Conflicts: gir1.0-clutter-1.0 but 1.2.12-3 is to be installed
 gir1.2-freedesktop : Conflicts: gir1.0-freedesktop but 0.6.14-1+b1 is to be installed
 gir1.2-glib-2.0 : Conflicts: gir1.0-glib-2.0 but 0.6.14-1+b1 is to be installed
 gir1.2-gstreamer-0.10 : Conflicts: gir1.0-gstreamer-0.10 but 0.10.30-1 is to be installed
 gir1.2-pango-1.0 : Conflicts: gir1.0-pango-1.0

So the problematic gir1.0 packages appear to have since been replaced
by gir1.2 packages which, from the analysis of the apt debug log, would
appear to be a likely fix for the original problem.

Could this be re-tested in piuparts?

-- 


Neil Williams
=============
http://www.linux.codehelp.co.uk/

[Message part 2 (application/pgp-signature, inline)]

Added tag(s) unreproducible. Request was from Neil Williams <codehelp@debian.org> to control@bugs.debian.org. (Sat, 13 Oct 2012 14:45:09 GMT) Full text and rfc822 format available.

Message sent on to Andreas Beckmann <debian@abeckmann.de>:
Bug#677407. (Sat, 13 Oct 2012 14:45:12 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-core. (Thu, 01 Nov 2012 22:09:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Thu, 01 Nov 2012 22:09:03 GMT) Full text and rfc822 format available.

Message #53 received at 677407@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: Debian Bug Tracking System <677407@bugs.debian.org>
Subject: Re: gnome-dbg: fails to upgrade from squeeze - apt does not find an upgrade path
Date: Thu, 01 Nov 2012 23:04:52 +0100
[Message part 1 (text/plain, inline)]
Package: gnome-core
Followup-For: Bug #677407
Control: found -1 1:3.4+4

Still reproducible in squeeze->wheezy upgrades, new logfile with
problemresolver debug output attached.

Andreas
[gnomedbg.log (text/plain, attachment)]

Marked as found in versions meta-gnome3/1:3.4+4. Request was from Andreas Beckmann <debian@abeckmann.de> to 677407-submit@bugs.debian.org. (Thu, 01 Nov 2012 22:09:03 GMT) Full text and rfc822 format available.

Marked as found in versions meta-gnome3/1:3.4+5. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Thu, 01 Nov 2012 22:39:07 GMT) Full text and rfc822 format available.

Marked as found in versions meta-gnome3/1:3.4+6. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Sat, 03 Nov 2012 13:24:07 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-core. (Mon, 26 Nov 2012 11:45:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Simon McVittie <smcv@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Mon, 26 Nov 2012 11:45:03 GMT) Full text and rfc822 format available.

Message #64 received at 677407@bugs.debian.org (full text, mbox):

From: Simon McVittie <smcv@debian.org>
To: apt@packages.debian.org
Cc: Andreas Beckmann <debian@abeckmann.de>, 677407@bugs.debian.org
Subject: Re: Bug#677407: gnome-dbg: fails to upgrade from squeeze - apt does not find an upgrade path
Date: Mon, 26 Nov 2012 11:44:25 +0000
On Sat, 16 Jun 2012 at 10:49:19 +0200, Andreas Beckmann wrote:
> the problem I previously reported for gnome-dbg now also shows up for
> gnome-core.

Your log from 1st November is for gnome-dbg. Is this reproducible
for gnome-core too, or only for gnome-dbg?

Could you please explain how an apt or GNOME developer with no particular
knowledge of piuparts or pbuilder can reproduce this upgrade issue? (I
use sbuild for my package uploads, so I don't have a working pbuilder
setup; in his message of 13th October, Neil Williams performed a
"realistic" upgrade test of gnome-dbg in a Squeeze virtual machine,
which was successful.)

On Thu, 01 Nov 2012 at 23:04:52 +0100, Andreas Beckmann wrote:
> Still reproducible in squeeze->wheezy upgrades, new logfile with
> problemresolver debug output attached.

The problems still seem to start here:

>   Investigating (0) gir1.2-gstreamer-0.10 [ amd64 ] < none -> 0.10.36-1 > ( introspection )
>   Broken gir1.2-gstreamer-0.10:amd64 Conflicts on gir1.0-gstreamer-0.10 [ amd64 ] < 0.10.30-1 > ( libs )
>     Considering gir1.0-gstreamer-0.10:amd64 1 as a solution to gir1.2-gstreamer-0.10:amd64 1
>     Holding Back gir1.2-gstreamer-0.10:amd64 rather than change gir1.0-gstreamer-0.10:amd64

That's not the answer we want: apt should be willing
to remove gir1.0-gstreamer-0.10:amd64. Unfortunately,
gir1.0-gstreamer-0.10 and gir1.2-gstreamer-0.10 both have a score of 1,
and apt seems to tie-break in the wrong direction.

>   Broken libseed-gtk3-0:amd64 Depends on gir1.2-gstreamer-0.10 [ amd64 ] < none -> 0.10.36-1 > ( introspection )
>     Considering gir1.2-gstreamer-0.10:amd64 1 as a solution to libseed-gtk3-0:amd64 5
>     Holding Back libseed-gtk3-0:amd64 rather than change gir1.2-gstreamer-0.10:amd64

This is the result of the above; that breaks libpeas, which breaks
various applications.

Would an artificial dependency, gnome-dbg Depends: gir1.2-gstreamer-0.10
or even gnome-core Depends: gir1.2-gstreamer-0.10, perhaps reassure apt that it
was doing the right thing by installing gir1.2-gstreamer-0.10 and
dropping gir1.0-gstreamer-0.10? Or is there something else that src:meta-gnome
could do to hint apt to do the right thing?

I call this dependency "artificial" because gnome-core has no particular
reason to depend on a random GIR file; but if doing so for the wheezy
release would help the upgrade, it would be fairly harmless to do so, because
they're already related by these chains:

  gnome-core Depends: gnome-sushi Depends: gir1.2-gstreamer-0.10
  gnome-core D: eog D: libpeas-1.0-0 D: libseed-gtk3-0 D: gir1.2-gstreamer-0.10

Perhaps another way to convince apt to DTRT would be to change the
dependency

  libseed-gtk3-0 D: gir1.2-gstreamer-0.10 | libgstreamer0.10-0 (< 0.10.25-3)

and remove the obsolete alternative (the second branch), to make the
"right answer" more obvious?

Regards,
    S



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-core. (Mon, 26 Nov 2012 18:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Mon, 26 Nov 2012 18:51:03 GMT) Full text and rfc822 format available.

Message #69 received at 677407@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: Simon McVittie <smcv@debian.org>
Cc: 677407@bugs.debian.org
Subject: Re: Bug#677407: gnome-dbg: fails to upgrade from squeeze - apt does not find an upgrade path
Date: Mon, 26 Nov 2012 19:47:19 +0100
On 2012-11-26 12:44, Simon McVittie wrote:
> On Sat, 16 Jun 2012 at 10:49:19 +0200, Andreas Beckmann wrote:
>> the problem I previously reported for gnome-dbg now also shows up for
>> gnome-core.
> 
> Your log from 1st November is for gnome-dbg. Is this reproducible
> for gnome-core too, or only for gnome-dbg?

squeeze2wheezy/main/affected/gnome-dbg_1:3.4+6.log
   libglib2.0-0 : Breaks: eog (< 3.2.2-3) but 2.30.2-1 is to be installed
  E: Error, pkgProblemResolver::Resolve generated breaks, this may be
caused by held packages.

squeeze2wheezy/main/affected/gnome-core_1:3.4+6.log
E: Could not perform immediate configuration on 'libgstreamer0.10-0'.

different issue, could be filed already, but I didn't have time to look
for 'immediate configuration' bugs check the dependenecy tree for
circular dependencies - and break them :-)

> Could you please explain how an apt or GNOME developer with no particular
> knowledge of piuparts or pbuilder can reproduce this upgrade issue? (I
> use sbuild for my package uploads, so I don't have a working pbuilder
> setup; in his message of 13th October, Neil Williams performed a
> "realistic" upgrade test of gnome-dbg in a Squeeze virtual machine,
> which was successful.)

the piuparts logs contain the piuparts command line, installing piuparts
from sid and rerunning that command should work (just drop all the
experimental flags piuparts complains it does not know, e.g.
--allow-database, they should not be needed for checking the gnome issues)

> Would an artificial dependency, gnome-dbg Depends: gir1.2-gstreamer-0.10
> or even gnome-core Depends: gir1.2-gstreamer-0.10, perhaps reassure apt that it
> was doing the right thing by installing gir1.2-gstreamer-0.10 and
> dropping gir1.0-gstreamer-0.10? Or is there something else that src:meta-gnome
> could do to hint apt to do the right thing?

That could work.
Or try to find a library in the involved dependency tree that has a
high score and try to add another Breaks: gir1.0-gstreamer-0.10
Perhaps it loses this battle ... (the metapackages usually have a low score)
If you put such packages (for amd64) somewhere, I could make some tests.

> Perhaps another way to convince apt to DTRT would be to change the
> dependency
> 
>   libseed-gtk3-0 D: gir1.2-gstreamer-0.10 | libgstreamer0.10-0 (< 0.10.25-3)
> 
> and remove the obsolete alternative (the second branch), to make the
> "right answer" more obvious?

since squeeze has 0.10.30-1, this should be cleaned up, but it won't
help (as it's not a possible solution, i.e. there is no old package that
could be kept to satisfy this)

Andreas



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-core. (Tue, 27 Nov 2012 04:00:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 27 Nov 2012 04:00:04 GMT) Full text and rfc822 format available.

Message #74 received at 677407@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Andreas Beckmann <debian@abeckmann.de>, 677407@bugs.debian.org
Cc: Simon McVittie <smcv@debian.org>
Subject: Re: Bug#677407: gnome-dbg: fails to upgrade from squeeze - apt does not find an upgrade path
Date: Tue, 27 Nov 2012 04:57:29 +0100
[Message part 1 (text/plain, inline)]
On 26.11.2012 19:47, Andreas Beckmann wrote:
> On 2012-11-26 12:44, Simon McVittie wrote:
>> On Sat, 16 Jun 2012 at 10:49:19 +0200, Andreas Beckmann wrote:
>>> the problem I previously reported for gnome-dbg now also shows up for
>>> gnome-core.
>>
>> Your log from 1st November is for gnome-dbg. Is this reproducible
>> for gnome-core too, or only for gnome-dbg?
> 
> squeeze2wheezy/main/affected/gnome-dbg_1:3.4+6.log
>    libglib2.0-0 : Breaks: eog (< 3.2.2-3) but 2.30.2-1 is to be installed
>   E: Error, pkgProblemResolver::Resolve generated breaks, this may be
> caused by held packages.
> 
> squeeze2wheezy/main/affected/gnome-core_1:3.4+6.log
> E: Could not perform immediate configuration on 'libgstreamer0.10-0'.
> 
> different issue, could be filed already, but I didn't have time to look
> for 'immediate configuration' bugs check the dependenecy tree for
> circular dependencies - and break them :-)


Since eog triggered my attention, there is already [1] which might be
relevant. Especially [2] and onwards.
In the end, these are apt bugs it seems. But as we can't easily fix apt
in squeeze, we will have to find a workaround somehow.




[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=676485
[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=676485#42
-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Marked as found in versions meta-gnome3/1:3.4+7. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Sat, 15 Dec 2012 23:12:08 GMT) Full text and rfc822 format available.

Changed Bug submitter to 'Andreas Beckmann <anbe@debian.org>' from 'Andreas Beckmann <debian@abeckmann.de>' Request was from Andreas Beckmann <anbe@debian.org> to control@bugs.debian.org. (Sat, 26 Jan 2013 06:29:59 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-core. (Sun, 27 Jan 2013 14:18:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Neil Williams <codehelp@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Sun, 27 Jan 2013 14:18:03 GMT) Full text and rfc822 format available.

Message #83 received at 677407@bugs.debian.org (full text, mbox):

From: Neil Williams <codehelp@debian.org>
To: 677407@bugs.debian.org
Cc: 677407-submitter@bugs.debian.org
Subject: re-test with libglib2.0-0 from sid?
Date: Sun, 27 Jan 2013 14:17:12 +0000
[Message part 1 (text/plain, inline)]
I've tried reproducing this again in a VM with gnome-core installed and
again after installing gnome-dbg - without problems.

There are updates in sid relating to libglib2.0-0 from this change:
http://packages.qa.debian.org/g/glib2.0/news/20130108T234753Z.html

   * Drop the various Breaks from libglib2.0-0. Those are causing APT
to fail on a dist-upgrade from squeeze to wheezy. (Closes: #676485)

Please can #677407 be re-tested using libglib2.0-0 
(= 2.33.12+really2.32.4-5) from unstable?

-- 


Neil Williams
=============
http://www.linux.codehelp.co.uk/

[Message part 2 (application/pgp-signature, inline)]

Message sent on to Andreas Beckmann <anbe@debian.org>:
Bug#677407. (Sun, 27 Jan 2013 14:18:15 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-core. (Sun, 27 Jan 2013 15:09:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <anbe@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Sun, 27 Jan 2013 15:09:07 GMT) Full text and rfc822 format available.

Message #91 received at 677407@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <anbe@debian.org>
To: Neil Williams <codehelp@debian.org>, 677407@bugs.debian.org
Subject: Re: Bug#677407: re-test with libglib2.0-0 from sid?
Date: Sun, 27 Jan 2013 16:07:53 +0100
On 2013-01-27 15:17, Neil Williams wrote:
> I've tried reproducing this again in a VM with gnome-core installed and
> again after installing gnome-dbg - without problems.

> Please can #677407 be re-tested using libglib2.0-0 
> (= 2.33.12+really2.32.4-5) from unstable?

squeeze/main/pass/gnome-dbg_1:2.30+7.log
wheezy/main/pass/gnome-dbg_1:3.4+7.log
sid/main/pass/gnome-dbg_1:3.4+7.log

squeeze2wheezy/main/affected/gnome-dbg_1:3.4+7.log
squeeze2wheezy2sid/main/affected/gnome-dbg_1:3.4+7.log

squeeze2sid/main/pass/gnome-dbg_1:3.4+7.log
testing2sid/main/pass/gnome-dbg_1:3.4+7.log

looks good :-)

If there is a repository somewhere with all the new .debs built from
source(libglib2.0-0) and a Packages file, I could do tests how this
would look like in a squeeze2wheezy upgrade after glib2 migrated to
testing. (I'm just to lazy to rebuild glib2 locally ...)

Andreas



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-core. (Sun, 27 Jan 2013 15:45:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Neil Williams <codehelp@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Sun, 27 Jan 2013 15:45:03 GMT) Full text and rfc822 format available.

Message #96 received at 677407@bugs.debian.org (full text, mbox):

From: Neil Williams <codehelp@debian.org>
To: anbe@debian.org
Cc: 677407@bugs.debian.org
Subject: Re: Bug#677407: re-test with libglib2.0-0 from sid?
Date: Sun, 27 Jan 2013 15:41:13 +0000
[Message part 1 (text/plain, inline)]
On Sun, 27 Jan 2013 16:07:53 +0100
Andreas Beckmann <anbe@debian.org> wrote:

> On 2013-01-27 15:17, Neil Williams wrote:
> > I've tried reproducing this again in a VM with gnome-core installed and
> > again after installing gnome-dbg - without problems.
> 
> > Please can #677407 be re-tested using libglib2.0-0 
> > (= 2.33.12+really2.32.4-5) from unstable?
> 
> squeeze/main/pass/gnome-dbg_1:2.30+7.log
> wheezy/main/pass/gnome-dbg_1:3.4+7.log
> sid/main/pass/gnome-dbg_1:3.4+7.log
> 
> squeeze2wheezy/main/affected/gnome-dbg_1:3.4+7.log
> squeeze2wheezy2sid/main/affected/gnome-dbg_1:3.4+7.log
> 
> squeeze2sid/main/pass/gnome-dbg_1:3.4+7.log
> testing2sid/main/pass/gnome-dbg_1:3.4+7.log
> 
> looks good :-)
> 
> If there is a repository somewhere with all the new .debs built from
> source(libglib2.0-0) and a Packages file, I could do tests how this
> would look like in a squeeze2wheezy upgrade after glib2 migrated to
> testing. (I'm just to lazy to rebuild glib2 locally ...)

No need to rebuild locally. I used reprepro to create a small repo and
then used a filterlist to update from unstable against the list of
binary packages built by glib2.0

http://linux.codehelp.co.uk/emdebian/dists/piuparts/

This is available, temporarily, as an apt source if you want it:

deb http://linux.codehelp.co.uk/emdebian piuparts main

(amd64 & i386 only)

piuparts|main|amd64: libglib2.0-0 2.33.12+really2.32.4-5
piuparts|main|amd64: libglib2.0-0-dbg 2.33.12+really2.32.4-5
piuparts|main|amd64: libglib2.0-0-refdbg 2.33.12+really2.32.4-5
piuparts|main|amd64: libglib2.0-bin 2.33.12+really2.32.4-5
piuparts|main|amd64: libglib2.0-data 2.33.12+really2.32.4-5
piuparts|main|amd64: libglib2.0-dev 2.33.12+really2.32.4-5
piuparts|main|amd64: libglib2.0-doc 2.33.12+really2.32.4-5

 glib2.0 | 2.33.12+really2.32.4-5 | sid          | source

That repository will be available for a few weeks or so.

-- 


Neil Williams
=============
http://www.linux.codehelp.co.uk/

[Message part 2 (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-core. (Sun, 27 Jan 2013 16:54:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <anbe@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Sun, 27 Jan 2013 16:54:05 GMT) Full text and rfc822 format available.

Message #101 received at 677407@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <anbe@debian.org>
To: Neil Williams <codehelp@debian.org>
Cc: 677407@bugs.debian.org
Subject: Re: Bug#677407: re-test with libglib2.0-0 from sid?
Date: Sun, 27 Jan 2013 17:51:31 +0100
On 2013-01-27 16:41, Neil Williams wrote:
> deb http://linux.codehelp.co.uk/emdebian piuparts main

Thanks!

tested distupgrades from squeeze to wheezy + newer glibc for all 
packages that have/had a Breaks in glib2.0:

xxglib2-emacs23.log:1m30.9s INFO: PASS: Upgrading between Debian distributions.
xxglib2-eog.log:1m53.7s INFO: PASS: Upgrading between Debian distributions.
xxglib2-gdm3.log:2m41.7s INFO: PASS: Upgrading between Debian distributions.
xxglib2-gnome-control-center.log:2m26.2s INFO: PASS: Upgrading between Debian distributions.
xxglib2-gnome-dbg.log:3m15.1s INFO: PASS: Upgrading between Debian distributions.
xxglib2-gnome-session.log:2m35.6s INFO: PASS: Upgrading between Debian distributions.
xxglib2-gvfs.log:1m14.7s INFO: PASS: Upgrading between Debian distributions.
xxglib2-gwaei.log:1m42.4s INFO: PASS: Upgrading between Debian distributions.
xxglib2-libgtk-3-0.log:1m6.6s INFO: PASS: Upgrading between Debian distributions.

Looks good. Get glib2.0 unblocked :-)

There are 7759 packages that have some (in-)direct relation to 
libglib2.0-0. If you remind me once the packages are in testing, I can 
reschedule the squeeze2wheezy test for them, just to ensure the
"unBreaks:ing" didn't break some corner cases.

Andreas



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#677407; Package gnome-core. (Sun, 27 Jan 2013 17:03:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Sun, 27 Jan 2013 17:03:03 GMT) Full text and rfc822 format available.

Message #106 received at 677407@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Andreas Beckmann <anbe@debian.org>, 677407@bugs.debian.org
Cc: Neil Williams <codehelp@debian.org>
Subject: Re: Bug#677407: re-test with libglib2.0-0 from sid?
Date: Sun, 27 Jan 2013 17:59:47 +0100
[Message part 1 (text/plain, inline)]
On 27.01.2013 17:51, Andreas Beckmann wrote:
> On 2013-01-27 16:41, Neil Williams wrote:
>> deb http://linux.codehelp.co.uk/emdebian piuparts main
> 
> Thanks!
> 
> tested distupgrades from squeeze to wheezy + newer glibc for all 
> packages that have/had a Breaks in glib2.0:
> 
> xxglib2-emacs23.log:1m30.9s INFO: PASS: Upgrading between Debian distributions.
> xxglib2-eog.log:1m53.7s INFO: PASS: Upgrading between Debian distributions.
> xxglib2-gdm3.log:2m41.7s INFO: PASS: Upgrading between Debian distributions.
> xxglib2-gnome-control-center.log:2m26.2s INFO: PASS: Upgrading between Debian distributions.
> xxglib2-gnome-dbg.log:3m15.1s INFO: PASS: Upgrading between Debian distributions.
> xxglib2-gnome-session.log:2m35.6s INFO: PASS: Upgrading between Debian distributions.
> xxglib2-gvfs.log:1m14.7s INFO: PASS: Upgrading between Debian distributions.
> xxglib2-gwaei.log:1m42.4s INFO: PASS: Upgrading between Debian distributions.
> xxglib2-libgtk-3-0.log:1m6.6s INFO: PASS: Upgrading between Debian distributions.

Thanks for testing! That work you do is really appreciated.

> Looks good. Get glib2.0 unblocked :-)
> 

See #697764. The d-i team wanted to have RC1 released before the package
is unblocked (glib2.0 shipping a udeb).

Michael


-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Removed tag(s) unreproducible. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Sun, 27 Jan 2013 18:33:14 GMT) Full text and rfc822 format available.

Added tag(s) wheezy. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Sun, 27 Jan 2013 18:33:14 GMT) Full text and rfc822 format available.

Reply sent to Julien Cristau <jcristau@debian.org>:
You have taken responsibility. (Mon, 28 Jan 2013 22:18:04 GMT) Full text and rfc822 format available.

Notification sent to Andreas Beckmann <anbe@debian.org>:
Bug acknowledged by developer. (Mon, 28 Jan 2013 22:18:04 GMT) Full text and rfc822 format available.

Message #115 received at 677407-done@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: Andreas Beckmann <debian@abeckmann.de>
Cc: 677407-done@bugs.debian.org
Subject: Re: fixed 592204 in 0.5-1, tagging 592204, affects 684964, found 669278 in 4:4.6.0.0-1 ...
Date: Mon, 28 Jan 2013 23:16:15 +0100
[Message part 1 (text/plain, inline)]
On Sun, Jan 27, 2013 at 19:32:04 +0100, Andreas Beckmann wrote:

> tags 677407 - unreproducible + wheezy

No, that's not how you mark a bug as assigned to the wrong package.
Closing instead, as there's a fixed glib in sid on its way to wheezy.

Cheers,
Julien
[signature.asc (application/pgp-signature, inline)]

Added blocking bug(s) of 677407: 676485 Request was from Andreas Beckmann <anbe@debian.org> to control@bugs.debian.org. (Wed, 13 Feb 2013 20:15:06 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 14 Mar 2013 07:25:45 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 07:08:24 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.