Debian Bug report logs - #676882
dracut-network fails to nfsboot if LVM volume is present

version graph

Package: dracut-network; Maintainer for dracut-network is Thomas Lange <lange@debian.org>; Source for dracut-network is src:dracut.

Reported by: "Thomas Neumann" <blacky+fai@fluffbunny.de>

Date: Sun, 10 Jun 2012 10:16:00 UTC

Severity: normal

Tags: patch

Found in version dracut/019+1+gd77540c-1

Done: Thomas Lange <lange@informatik.uni-koeln.de>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Thomas Lange <lange@debian.org>:
Bug#676882; Package fai-server. (Sun, 10 Jun 2012 10:16:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Thomas Neumann" <blacky+fai@fluffbunny.de>:
New Bug report received and forwarded. Copy sent to Thomas Lange <lange@debian.org>. (Sun, 10 Jun 2012 10:16:03 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: "Thomas Neumann" <blacky+fai@fluffbunny.de>
To: "Debian Bug Tracking System" <submit@bugs.debian.org>
Subject: fai-server: dracut-network fails to nfsboot if LVM volume is present
Date: Sun, 10 Jun 2012 11:07:07 +0200
Package: fai-server
Version: 4.0.1
Severity: important

Tested with fai-nfsroot 4.0.1 and kernel 3.0.2

Installation of a fai nfsclient is not possible, if the client already has
LVM volumes. When the client boots, it recognizes the network card, but
does not boot from it. Instead it activates the LVM volume and does not
proceed.

Workaround: define rd_NO_LVM in the client's pxeconfig file
            (modify fai-chboot?)
Solution: Escalate problem to dracut-network?

nfsroot client info:

# cat /etc/apt/sources.list
--------------------------------------------------------------------------
# These lines should work for many sites
# A more comprehensive example is at /usr/share/doc/fai-doc/examples/etc

deb http://cdn.debian.net/debian wheezy main contrib non-free
deb http://security.debian.org/debian-security wheezy/updates main contrib
non-free

# repository that may contain newer fai packages for wheezy
deb http://fai-project.org/download wheezy koeln
--------------------------------------------------------------------------

# dpkg -l dracut-network fai-nfsroot linux-image-3.2.0-2-amd64
--------------------------------------------------------------------------
    Name                                         Version
ii  dracut-network                               019+1+gd77540c-1
ii  fai-nfsroot                                  4.0.1
ii  linux-image-3.2.0-2-amd64                    3.2.19-1
--------------------------------------------------------------------------






Information forwarded to debian-bugs-dist@lists.debian.org, Thomas Lange <lange@debian.org>:
Bug#676882; Package fai-server. (Thu, 21 Jun 2012 18:27:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Andreas B. Mundt" <andi.mundt@web.de>:
Extra info received and forwarded to list. Copy sent to Thomas Lange <lange@debian.org>. (Thu, 21 Jun 2012 18:27:03 GMT) Full text and rfc822 format available.

Message #10 received at 676882@bugs.debian.org (full text, mbox):

From: "Andreas B. Mundt" <andi.mundt@web.de>
To: 676882@bugs.debian.org
Subject: same with CD installation
Date: Thu, 21 Jun 2012 20:25:44 +0200
Hi,

I got the same issue when installing from a CD. The preparation of the
CD has been documented here:
<URL:http://wiki.debian.org/DebianLAN/bootstrap/wheezy>.  The config
space has been tested extensively on squeeze.  Up to now, no
modifications for wheezy have been made.

The error log looks almost identical to the error documented here:
<URL:https://lists.uni-koeln.de/pipermail/linux-fai/2012-June/009699.html>

Find below disk_config and logs.

Best regards,

     Andi



The disk_config I use is:

disk_config  disk1  fstabkey:uuid
primary  /boot       64-256    ext3    rw
primary  swap        64-2096   swap    sw
logical  -           0-        -       -

disk_config lvm
vg  vg_system  disk1.5
vg_system-root  /      1G-2G     ext3  errors=remount-ro
vg_system-usr   /usr   2G-20G    ext3  defaults
vg_system-var   /var   1G-20G    ext3  defaults
vg_system-home  /lan/mainserver/home0  2G-70%  ext3  defaults

==========

/tmp/fai/format.log:

Starting setup-storage 1.4
Using config file: /var/lib/fai/config/disk_config/LVM6_A
Executing: parted -s /dev/sda unit TiB print
Executing: parted -s /dev/sda unit B print free
Executing: parted -s /dev/sda unit chs print free
    Creating directory "/run/lock/lvm"
    Finding all volume groups
    Finding volume group "vg_system"
    Creating directory "/etc/lvm/archive"
    Archiving volume group "vg_system" metadata (seqno 5).
    Creating directory "/etc/lvm/backup"
    Creating volume group backup "/etc/lvm/backup/vg_system" (seqno 5).
    Finding all volume groups
    Finding volume group "vg_system"
    Finding all volume groups
    Finding volume group "vg_system"
    Finding all volume groups
    Finding volume group "vg_system"
Executing: mdadm --examine --scan --verbose -c partitions
Use of uninitialized value in string eq at /usr/share/fai/setup-storage//Commands.pm line 1142.
Cannot satisfy pre-depends for true: vgchange_a_n_VG_vg_system,pv_sigs_removed_vg_system,self_cleared_home,self_cleared_root,self_cleared_usr,self_cleared_var -- system left untouched.
Prototype mismatch: sub Parse::RecDescent::namespace000001::dclone ($) vs none at /usr/share/perl5/Parse/RecDescent.pm line 1984 during global destruction.

===========

/tmp/fai/fai.log:

             -------------------------------------------------
                   Fully Automatic Installation  -  FAI

                   FAI 4.0.1, 22 May 2012   (c) 1999-2012
               Thomas Lange  <lange@informatik.uni-koeln.de>
             -------------------------------------------------

Calling task_confdir
Kernel currently running: Linux 3.2.0-2-amd64 x86_64 GNU/Linux
Kernel parameters: BOOT_IMAGE=/boot/vmlinuz boot=live FAI_FLAGS=verbose,createvt FAI_ACTION=install hostname=mainserver
Kernel parameter ip= does not contain network parameters.
Warning: no domain name configured, using "localdomain"
Reading /tmp/fai/boot.log
FAI_FLAGS: verbose createvt
No monitor daemon defined.
FAI_CONFIG_SRC is set to file:///var/lib/fai/config
Using local path /var/lib/fai/config as config space.
Calling task_setup
FAI_FLAGS: verbose createvt
Press ctrl-c to interrupt FAI and to get a shell
Starting FAI execution - 20120621_195937
Calling task_defclass
fai-class: Defining classes.
Executing /var/lib/fai/config/class/10-base-classes.
10-base-classes      OK.
Executing /var/lib/fai/config/class/20-hwdetect.source.
loading kernel module usbkbd
loading kernel module ide-disk
20-hwdetect.source   OK.
Executing /var/lib/fai/config/class/50-host-classes.
50-host-classes      OK.
List of all classes:  DEFAULT LINUX AMD64 FAICD FAIBASE FAISERVER LVM6_A LOG_SERVER PROXY NTP_SERVER DNS_SERVER NFS_SERVER LDAP_CLIENT LDAP_SERVER KERBEROS_CLIENT KERBEROS_KDC KDC_LDAP SERVER_A GRUB_PC mainserver LAST
Calling task_defvar
Executing FAIBASE.var
++ FAI_ALLOW_UNSIGNED=1
++ CONSOLEFONT=
++ KEYMAP=us-latin1
++ UTC=yes
++ TIMEZONE=Europe/Berlin
++ ROOTPW='$1$kBnWcO.E$djxB128U7dMkrltJHPf6d1'
++ MODULESLIST='usbkbd ehci-hcd ohci-hcd uhci-hcd usbhid psmouse'
++ STOP_ON_ERROR=700
++ USE_SETUP_STORAGE=1
Executing SERVER_A.var
++ FAI_ALLOW_UNSIGNED=1
++ CONSOLEFONT=
++ KEYMAP=us-latin1
++ UTC=yes
++ TIMEZONE=Europe/Berlin
++ USERNAME=
++ ROOTPW='$1$kBnWcO.E$djxB128U7dMkrltJHPf6d1'
++ DATADIR=/root/installation/
++ KDC_MASTER_PW=
++ LDAP_ADMIN_PW=
++ MAINSERVER_IPADDR=10.0.0.1
++ GATEWAY=10.0.0.1
++ BROADCAST=10.0.255.255
++ NAMESERVER_IPADDR=
++ SUBNET=10.0.0.0
++ NETMASK=255.255.0.0
++ SUBNETMASK=10.0.0.0/16
++ FAINETMASK=10.0.0.0/24
++ RANGE='10.0.1.10 10.0.1.200'
++ WS_RANGE='50 149'
++ DL_RANGE='150 249'
++ APT_REPO_DIR=/var/www/debian/
++ MODULESLIST='usbkbd ehci-hcd ohci-hcd uhci-hcd usbhid psmouse'
++ STOP_ON_ERROR=700
++ USE_SETUP_STORAGE=1
Loading keymap(s) us-latin1 ...done.
Calling task_action
FAI_ACTION: install
Performing FAI installation. All data may be overwritten!

Calling task_install
Calling task_partition
WARNING: The variable USE_SETUP_STORAGE is not needed any more.
setup-storage is now the default tool for partitioning.
Starting setup-storage 1.4
Using config file: /var/lib/fai/config/disk_config/LVM6_A
Executing: parted -s /dev/sda unit TiB print
Executing: parted -s /dev/sda unit B print free
Executing: parted -s /dev/sda unit chs print free
    Creating directory "/run/lock/lvm"
    Finding all volume groups
    Finding volume group "vg_system"
    Creating directory "/etc/lvm/archive"
    Archiving volume group "vg_system" metadata (seqno 5).
    Creating directory "/etc/lvm/backup"
    Creating volume group backup "/etc/lvm/backup/vg_system" (seqno 5).
    Finding all volume groups
    Finding volume group "vg_system"
    Finding all volume groups
    Finding volume group "vg_system"
    Finding all volume groups
    Finding volume group "vg_system"
Executing: mdadm --examine --scan --verbose -c partitions
Use of uninitialized value in string eq at /usr/share/fai/setup-storage//Commands.pm line 1142.
Cannot satisfy pre-depends for true: vgchange_a_n_VG_vg_system,pv_sigs_removed_vg_system,self_cleared_home,self_cleared_root,self_cleared_usr,self_cleared_var -- system left untouched.
Prototype mismatch: sub Parse::RecDescent::namespace000001::dclone ($) vs none at /usr/share/perl5/Parse/RecDescent.pm line 1984 during global destruction.
Error in task partition. Traceback: task_error task_partition task task_install task task_action task main
$LOGUSER is undefined. Not saving log files to remote.
FATAL ERROR. Installation stopped.

=====================




Severity set to 'normal' from 'important' Request was from Thomas Lange <lange@debian.org> to control@bugs.debian.org. (Sun, 24 Jun 2012 11:45:16 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Thomas Lange <lange@debian.org>:
Bug#676882; Package fai-server. (Sun, 15 Jul 2012 10:30:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Andreas B. Mundt" <andi.mundt@web.de>:
Extra info received and forwarded to list. Copy sent to Thomas Lange <lange@debian.org>. (Sun, 15 Jul 2012 10:30:05 GMT) Full text and rfc822 format available.

Message #17 received at 676882@bugs.debian.org (full text, mbox):

From: "Andreas B. Mundt" <andi.mundt@web.de>
To: 676882@bugs.debian.org
Subject: workaround
Date: Sun, 15 Jul 2012 12:16:28 +0200
Hi,

just for the record, a simple work around that solves my issue:

After being dropped to the command line, remove the LVM partition
with fdisk /dev/XXX. Use p (to print the partition table) and d (to
delete a partition).  Finally w (to write the modified table) and
reboot from the CD.  The installation should work again now.

Best regards,

     Andi




Information forwarded to debian-bugs-dist@lists.debian.org, Thomas Lange <lange@debian.org>:
Bug#676882; Package fai-server. (Thu, 19 Jul 2012 15:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mathieu Alorent <malorent@echo.fr>:
Extra info received and forwarded to list. Copy sent to Thomas Lange <lange@debian.org>. (Thu, 19 Jul 2012 15:51:03 GMT) Full text and rfc822 format available.

Message #22 received at 676882@bugs.debian.org (full text, mbox):

From: Mathieu Alorent <malorent@echo.fr>
To: 676882@bugs.debian.org
Subject: confirmed on FAI 4.0.3
Date: Thu, 19 Jul 2012 17:38:30 +0200
[Message part 1 (text/plain, inline)]
Hi,

same problem here on FAI 4.0.3

Executing: mdadm --examine --scan --verbose -c partitions
Cannot satisfy pre-depends for true: 
vgchange_a_n_VG_TEST,pv_sigs_removed_TEST,self_cleared_HOME -- system 
left untouched.
[...]
FATAL ERROR. Installation stopped.



[smime.p7s (application/pkcs7-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Thomas Lange <lange@debian.org>:
Bug#676882; Package fai-server. (Wed, 25 Jul 2012 08:33:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mathieu Alorent <malorent@echo.fr>:
Extra info received and forwarded to list. Copy sent to Thomas Lange <lange@debian.org>. (Wed, 25 Jul 2012 08:33:03 GMT) Full text and rfc822 format available.

Message #27 received at 676882@bugs.debian.org (full text, mbox):

From: Mathieu Alorent <malorent@echo.fr>
To: 676882@bugs.debian.org
Subject: Patch
Date: Wed, 25 Jul 2012 10:30:27 +0200
[Message part 1 (text/plain, inline)]
Hi,

here is my patch for this bug :

https://github.com/kumy/fai/commit/fbdde8f6707f35bed3a377d901389a2d67e7de37

let me know if it's good for you.
Bests

-- 
Mathieu Alorent




[smime.p7s (application/pkcs7-signature, attachment)]

Added tag(s) patch. Request was from Mathieu Alorent <malorent@echo.fr> to control@bugs.debian.org. (Wed, 25 Jul 2012 15:57:05 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Thomas Lange <lange@debian.org>:
Bug#676882; Package fai-server. (Sat, 17 Nov 2012 18:00:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Thomas Lange <lange@informatik.uni-koeln.de>:
Extra info received and forwarded to list. Copy sent to Thomas Lange <lange@debian.org>. (Sat, 17 Nov 2012 18:00:03 GMT) Full text and rfc822 format available.

Message #34 received at 676882@bugs.debian.org (full text, mbox):

From: Thomas Lange <lange@informatik.uni-koeln.de>
To: 676882@bugs.debian.org, 676882-submitter@bugs.debian.org
Subject: two different bug reports?
Date: Sat, 17 Nov 2012 18:58:00 +0100
Hi,

my impression is that we discus two different bugs here. The initial
bug report was about FAI not booting from LAN if an LVM volume exists
because dracut activates this volume and boots from it.

Then Andi and others talk about FAI booting CD but setup-storage
stopped because of existsing LVM volumes.

If this is correct, we should split the bug report into two different
ones.

-- 
regards Thomas



Message sent on to "Thomas Neumann" <blacky+fai@fluffbunny.de>:
Bug#676882. (Sat, 17 Nov 2012 18:00:07 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Thomas Lange <lange@debian.org>:
Bug#676882; Package fai-server. (Mon, 19 Nov 2012 11:27:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Thomas Neumann" <blacky+fai@fluffbunny.de>:
Extra info received and forwarded to list. Copy sent to Thomas Lange <lange@debian.org>. (Mon, 19 Nov 2012 11:27:03 GMT) Full text and rfc822 format available.

Message #42 received at 676882@bugs.debian.org (full text, mbox):

From: "Thomas Neumann" <blacky+fai@fluffbunny.de>
To: "Thomas Lange" <lange@informatik.uni-koeln.de>, 676882-quiet@bugs.debian.org
Cc: 676882@bugs.debian.org, 676882-submitter@bugs.debian.org
Subject: Re: Bug#676882: two different bug reports?
Date: Mon, 19 Nov 2012 11:56:32 +0100
> my impression is that we discus two different bugs here.
[...]
> If this is correct, we should split the bug report into two different
> ones.

I'm under the same impression. Both symptoms are related to LVM, but are
different.

My original report relates to the booting of the fai-client. If an
LVM-volume is present, then the 'remote boot logic' won't run and instead
a local boot is attempted. It is a 'dracut' problem.

The other problem triggers _after_ the fai-client has completed the boot
process and actually attempts to format the disk. It is a 'setup-storage'
problem.

+1 for splitting




Information stored :
Bug#676882; Package fai-server. (Mon, 19 Nov 2012 11:27:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Thomas Neumann" <blacky+fai@fluffbunny.de>:
Extra info received and filed, but not forwarded. (Mon, 19 Nov 2012 11:27:07 GMT) Full text and rfc822 format available.

Message sent on to "Thomas Neumann" <blacky+fai@fluffbunny.de>:
Bug#676882. (Mon, 19 Nov 2012 11:27:09 GMT) Full text and rfc822 format available.

Bug 676882 cloned as bug 693701 Request was from "Thomas Neumann" <blacky+fai@fluffbunny.de> to control@bugs.debian.org. (Mon, 19 Nov 2012 13:57:08 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Thomas Lange <lange@debian.org>:
Bug#676882; Package fai-server. (Wed, 21 Nov 2012 18:39:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Thomas Lange <lange@informatik.uni-koeln.de>:
Extra info received and forwarded to list. Copy sent to Thomas Lange <lange@debian.org>.

Your message did not contain a Subject field. They are recommended and useful because the title of a $gBug is determined using this field. Please remember to include a Subject field in your messages in future.

(Wed, 21 Nov 2012 18:39:03 GMT) Full text and rfc822 format available.


Message #57 received at 676882@bugs.debian.org (full text, mbox):

From: Thomas Lange <lange@informatik.uni-koeln.de>
To: 676882@bugs.debian.org
Date: Wed, 21 Nov 2012 19:37:11 +0100
I think we should disable lvm inside the initrd of dracut. We can do
this by adding a file /etc/dracut.conf.d/fai with content:
omit_dracutmodules+="lvm"

It's important that this file is executable. This file could be
created by fai-make-nfsroot before installing packages.

-- 
regards Thomas



Information forwarded to debian-bugs-dist@lists.debian.org, Thomas Lange <lange@debian.org>:
Bug#676882; Package fai-server. (Thu, 31 Jan 2013 10:45:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Thomas Lange <lange@informatik.uni-koeln.de>:
Extra info received and forwarded to list. Copy sent to Thomas Lange <lange@debian.org>. (Thu, 31 Jan 2013 10:45:06 GMT) Full text and rfc822 format available.

Message #62 received at 676882@bugs.debian.org (full text, mbox):

From: Thomas Lange <lange@informatik.uni-koeln.de>
To: 676882@bugs.debian.org, 676882-submitter@bugs.debian.org
Subject: Workaround
Date: Thu, 31 Jan 2013 11:43:49 +0100
Did you try to add rd.lvm=o the the kernel command line? This disables
the lvm code in dracut during the boot process.
-- 
regards Thomas



Message sent on to "Thomas Neumann" <blacky+fai@fluffbunny.de>:
Bug#676882. (Thu, 31 Jan 2013 10:45:11 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Thomas Lange <lange@debian.org>:
Bug#676882; Package fai-server. (Mon, 18 Feb 2013 12:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Thomas Lange <lange@informatik.uni-koeln.de>:
Extra info received and forwarded to list. Copy sent to Thomas Lange <lange@debian.org>. (Mon, 18 Feb 2013 12:15:03 GMT) Full text and rfc822 format available.

Message #70 received at 676882@bugs.debian.org (full text, mbox):

From: Thomas Lange <lange@informatik.uni-koeln.de>
To: 676882@bugs.debian.org
Subject: fix workaround
Date: Mon, 18 Feb 2013 13:10:29 +0100
Oh! This should be rd.lvm=0.
-- 
regards Thomas



Information forwarded to debian-bugs-dist@lists.debian.org, Thomas Lange <lange@debian.org>:
Bug#676882; Package fai-server. (Wed, 19 Jun 2013 11:45:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to christoph <christoph@kluenter.de>:
Extra info received and forwarded to list. Copy sent to Thomas Lange <lange@debian.org>. (Wed, 19 Jun 2013 11:45:08 GMT) Full text and rfc822 format available.

Message #75 received at 676882@bugs.debian.org (full text, mbox):

From: christoph <christoph@kluenter.de>
To: 676882@bugs.debian.org
Subject: Re: fix workaround
Date: Wed, 19 Jun 2013 13:34:22 +0200
On Mon, Feb 18, 2013 at 01:10:29PM +0100, Thomas Lange wrote:
> Oh! This should be rd.lvm=0.

yup, works. Now setup-storage won't do anything because of the existing lvm,
but thats another bug.




Message sent on to "Thomas Neumann" <blacky+fai@fluffbunny.de>:
Bug#676882. (Mon, 12 Aug 2013 08:06:13 GMT) Full text and rfc822 format available.

Message #78 received at 676882-submitter@bugs.debian.org (full text, mbox):

From: Thomas Lange <lange@informatik.uni-koeln.de>
To: 676882@bug.debian.org, 676882-submitter@bugs.debian.org
Date: Mon, 12 Aug 2013 09:59:34 +0200
I seems that this bug is more a dracut bug. Now, dracut 031-1 is
available, which should fix this bug. Please try the new veriosn and
report if it's working for you. See also #694381 #703879.
-- 
regards Thomas



Information forwarded to debian-bugs-dist@lists.debian.org, Thomas Lange <lange@debian.org>:
Bug#676882; Package fai-server. (Mon, 12 Aug 2013 08:18:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Thomas Lange <lange@informatik.uni-koeln.de>:
Extra info received and forwarded to list. Copy sent to Thomas Lange <lange@debian.org>.

Your message did not contain a Subject field. They are recommended and useful because the title of a $gBug is determined using this field. Please remember to include a Subject field in your messages in future.

(Mon, 12 Aug 2013 08:18:04 GMT) Full text and rfc822 format available.


Message #83 received at 676882@bugs.debian.org (full text, mbox):

From: Thomas Lange <lange@informatik.uni-koeln.de>
To: 676882@bugs.debian.org
Date: Mon, 12 Aug 2013 10:01:30 +0200
I seems that this bug is more a dracut bug. Now, dracut 031-1 is
available, which should fix this bug. Please try the new version and
report if it's working for you. See also #694381 and #703879.

-- 
regards Thomas



Bug reassigned from package 'fai-server' to 'dracut-network'. Request was from Thomas Lange <lange@debian.org> to control@bugs.debian.org. (Tue, 27 Aug 2013 15:51:09 GMT) Full text and rfc822 format available.

No longer marked as found in versions fai/4.0.1. Request was from Thomas Lange <lange@debian.org> to control@bugs.debian.org. (Tue, 27 Aug 2013 15:51:10 GMT) Full text and rfc822 format available.

Marked as found in versions dracut/019+1+gd77540c-1. Request was from Thomas Lange <lange@debian.org> to control@bugs.debian.org. (Tue, 27 Aug 2013 15:51:11 GMT) Full text and rfc822 format available.

Changed Bug title to 'dracut-network fails to nfsboot if LVM volume is present' from 'fai-server: dracut-network fails to nfsboot if LVM volume is present' Request was from Thomas Lange <lange@debian.org> to control@bugs.debian.org. (Tue, 27 Aug 2013 15:57:20 GMT) Full text and rfc822 format available.

Message sent on to "Thomas Neumann" <blacky+fai@fluffbunny.de>:
Bug#676882. (Tue, 17 Sep 2013 19:21:04 GMT) Full text and rfc822 format available.

Message #94 received at 676882-submitter@bugs.debian.org (full text, mbox):

From: Thomas Lange <lange@informatik.uni-koeln.de>
To: 676882-submitter@bugs.debian.org
Date: Tue, 17 Sep 2013 21:18:33 +0200
Oh, I forgot to sent this email to you.
Currently dracut 032-1 is available, and 033 will soon be availabe too.


> I seems that this bug is more a dracut bug. Now, dracut 031-1 is
> available, which should fix this bug. Please try the new version and
> report if it's working for you. See also #694381 and #703879.
-- 
regards Thomas



Reply sent to Thomas Lange <lange@informatik.uni-koeln.de>:
You have taken responsibility. (Wed, 09 Oct 2013 18:27:05 GMT) Full text and rfc822 format available.

Notification sent to "Thomas Neumann" <blacky+fai@fluffbunny.de>:
Bug acknowledged by developer. (Wed, 09 Oct 2013 18:27:05 GMT) Full text and rfc822 format available.

Message #99 received at 676882-done@bugs.debian.org (full text, mbox):

From: Thomas Lange <lange@informatik.uni-koeln.de>
To: 676882-done@bugs.debian.org
Subject: fixed
Date: Wed, 9 Oct 2013 20:23:57 +0200
Special devices are not enabled by default since 024. From the man page:

rd.auto rd.auto=1
   enable autoassembly of special devices like cryptoLUKS, dmraid, mdraid
   or lvm. Default is off as of dracut version >= 024.

-- 
regards Thomas



Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 07 Nov 2013 07:32:22 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 10:47:11 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.