Debian Bug report logs - #673161
digikam: FTBFS: build-depends on no-longer available mysql-server-5.1

version graph

Package: src:digikam; Maintainer for src:digikam is Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>;

Reported by: debian-bsd@lists.debian.org

Date: Wed, 16 May 2012 14:45:06 UTC

Severity: serious

Tags: sid, wheezy

Found in versions digikam/4:2.6.0~rc-2, digikam/4:2.6.0~rc-1

Fixed in version digikam/4:2.6.0~rc-3

Done: Mark Purcell <msp@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>:
Bug#673161; Package src:digikam. (Wed, 16 May 2012 14:45:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to debian-bsd@lists.debian.org:
New Bug report received and forwarded. Copy sent to Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>. (Wed, 16 May 2012 14:45:09 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Christoph Egger <christoph@debian.org>
To: submit@bugs.debian.org
Subject: digikam: FTBFS: build-depends on no-longer available mysql-server-5.1
Date: Wed, 16 May 2012 16:44:01 +0200
Package: src:digikam
Version: 4:2.6.0~rc-1
Severity: serious
Tags: sid wheezy
Justification: fails to build from source (but built successfully in the past)

Hi!

Your package failed to build on the buildds as it depends on
mysql-server-5.1 for building which is no longer available.

Regards

    Christoph

-- 
9FED 5C6C E206 B70A 5857  70CA 9655 22B9 D49A E731
Debian Developer | Lisp Hacker | CaCert Assurer




Added indication that bug 673161 blocks 671115 Request was from Nicholas Bamber <nicholas@periapt.co.uk> to control@bugs.debian.org. (Wed, 16 May 2012 18:48:07 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>:
Bug#673161; Package src:digikam. (Thu, 17 May 2012 09:47:29 GMT) Full text and rfc822 format available.

Acknowledgement sent to Arnold Metselaar <arnold.metsel@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>. (Thu, 17 May 2012 09:47:34 GMT) Full text and rfc822 format available.

Message #12 received at 673161@bugs.debian.org (full text, mbox):

From: Arnold Metselaar <arnold.metsel@gmail.com>
To: 673161@bugs.debian.org
Subject: mysql-server-5.1 is available, but fails to start in chroot
Date: Thu, 17 May 2012 10:55:02 +0200
Hi,

Being interested in digikam 2.6.0, I have tried building it for Wheezy with my own mini-buildd. 
I have discovered that while mysql-server-5.1 is still available in Wheezy, it cannot be set up
in a schroot environment.
The post installation script of mysql-server-5.1 invokes the init script to start mysqld.
The init script of mysql-server users df to check for a nearly full file system before starting, 
but df fails in a schroot environment, so nothing is started  and apt-get reports an error 
with mysql-server-5.1.

I think the schroot package is to blame here, though it may be argued that the bug should be 
reassigned to some other part of the build system, coreutils (df) or mysql-server-5.1 instead.

Regards,
Arnold 

Snippets from the build log:

Selecting previously unselected package mysql-server-core-5.1.
Unpacking mysql-server-core-5.1 (from .../mysql-server-core-5.1_5.1.61-3_i386.deb) ...
Setting up mysql-common (5.1.61-3) ...
Setting up adduser (3.113+nmu1) ...
Selecting previously unselected package mysql-server-5.1.
(Reading database ... 15839 files and directories currently installed.)
Unpacking mysql-server-5.1 (from .../mysql-server-5.1_5.1.61-3_i386.deb) ...
df: Warning: cannot read table of mounted file systems: No such file or directory
[...]
Setting up mysql-server-core-5.1 (5.1.61-3) ...
Setting up mysql-server-5.1 (5.1.61-3) ...
Stopping MySQL database server: mysqld.
df: Warning: cannot read table of mounted file systems: No such file or directory
Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.1 (--configure):
 subprocess installed post-installation script returned error exit status 1





Information forwarded to debian-bugs-dist@lists.debian.org, Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>:
Bug#673161; Package src:digikam. (Fri, 18 May 2012 06:24:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Arnold Metselaar <arnold.metsel@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>. (Fri, 18 May 2012 06:24:03 GMT) Full text and rfc822 format available.

Message #17 received at 673161@bugs.debian.org (full text, mbox):

From: Arnold Metselaar <arnold.metsel@gmail.com>
To: 673161@bugs.debian.org
Subject: Starting mysqld in a chroot
Date: Fri, 18 May 2012 08:21:38 +0200
Hi, 

I was mistaken in my previous message.  Generating a decent /etc/mtab with the line

grep "${CHROOT_PATH}" /etc/mtab | sed -e "s:${CHROOT_PATH}/\?:/:" >"${CHROOT_PATH}/etc/mtab"

in /etc/schroot/setup.d/99mini-buildd helped get rid of warnings from df,  
but mysqld was trying to start without it as well.

Mysqld tries to bind to a port at start-up, and fails when another mysqld outside the chroot is already
bound to that port. When mysqld is not running in the host machine, it starts in a chroot just fine. 
It should also work when mysqld in the host is listening on a non-standard port.

Regards,
Arnold




Reply sent to Mark Purcell <msp@debian.org>:
You have taken responsibility. (Sat, 19 May 2012 13:06:10 GMT) Full text and rfc822 format available.

Notification sent to debian-bsd@lists.debian.org:
Bug acknowledged by developer. (Sat, 19 May 2012 13:06:11 GMT) Full text and rfc822 format available.

Message #22 received at 673161-close@bugs.debian.org (full text, mbox):

From: Mark Purcell <msp@debian.org>
To: 673161-close@bugs.debian.org
Subject: Bug#673161: fixed in digikam 4:2.6.0~rc-2
Date: Sat, 19 May 2012 13:04:30 +0000
Source: digikam
Source-Version: 4:2.6.0~rc-2

We believe that the bug you reported is fixed in the latest version of
digikam, which is due to be installed in the Debian FTP archive:

digikam-data_2.6.0~rc-2_all.deb
  to main/d/digikam/digikam-data_2.6.0~rc-2_all.deb
digikam-dbg_2.6.0~rc-2_amd64.deb
  to main/d/digikam/digikam-dbg_2.6.0~rc-2_amd64.deb
digikam-doc_2.6.0~rc-2_all.deb
  to main/d/digikam/digikam-doc_2.6.0~rc-2_all.deb
digikam_2.6.0~rc-2.debian.tar.gz
  to main/d/digikam/digikam_2.6.0~rc-2.debian.tar.gz
digikam_2.6.0~rc-2.dsc
  to main/d/digikam/digikam_2.6.0~rc-2.dsc
digikam_2.6.0~rc-2_amd64.deb
  to main/d/digikam/digikam_2.6.0~rc-2_amd64.deb
kipi-plugins-common_2.6.0~rc-2_all.deb
  to main/d/digikam/kipi-plugins-common_2.6.0~rc-2_all.deb
kipi-plugins_2.6.0~rc-2_amd64.deb
  to main/d/digikam/kipi-plugins_2.6.0~rc-2_amd64.deb
showfoto_2.6.0~rc-2_amd64.deb
  to main/d/digikam/showfoto_2.6.0~rc-2_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 673161@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Mark Purcell <msp@debian.org> (supplier of updated digikam package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sat, 19 May 2012 14:12:59 +1000
Source: digikam
Binary: digikam showfoto digikam-dbg digikam-data digikam-doc kipi-plugins kipi-plugins-common
Architecture: source amd64 all
Version: 4:2.6.0~rc-2
Distribution: unstable
Urgency: low
Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
Changed-By: Mark Purcell <msp@debian.org>
Description: 
 digikam    - digital photo management application for KDE
 digikam-data - digiKam architecture-independant data
 digikam-dbg - debugging symbols for digiKam
 digikam-doc - handbook for digiKam
 kipi-plugins - image manipulation/handling plugins for KIPI aware programs
 kipi-plugins-common - kipi-plugins architecture-independent data
 showfoto   - image viewer/editor for KDE
Closes: 673161
Changes: 
 digikam (4:2.6.0~rc-2) unstable; urgency=low
 .
   * Fix "FTBFS: build-depends on no-longer available mysql-server-5.1"
     Updated Build-Depends (Closes: #673161)
Checksums-Sha1: 
 0ad31785699d0bb4c0c0fe166b710053ba14157c 2532 digikam_2.6.0~rc-2.dsc
 e4823155a9743d16234dff7f21d2e4a332516e31 41057 digikam_2.6.0~rc-2.debian.tar.gz
 2a00a17fd1d06fdfccee11c3c0239ef550d47021 7619636 digikam_2.6.0~rc-2_amd64.deb
 36aa6ef5c05708fe8916a2b32edf4243ef6b7714 2018120 showfoto_2.6.0~rc-2_amd64.deb
 dd07f41c8f674ca8f08109d3fa9a6fac92774f27 6551502 digikam-dbg_2.6.0~rc-2_amd64.deb
 93304e9015550bca9ef5f99744cddae01d615b6b 11005630 digikam-data_2.6.0~rc-2_all.deb
 964a5d21d37cfd1818a4606c0ef65597fe92adcc 18801340 digikam-doc_2.6.0~rc-2_all.deb
 3ba4fbdc96f07a481abcd3e0ab01d78194298ece 7005712 kipi-plugins_2.6.0~rc-2_amd64.deb
 50fb4eaeab923b2da60435262aec28e2725292cb 7534526 kipi-plugins-common_2.6.0~rc-2_all.deb
Checksums-Sha256: 
 9624568b56fa651322f830521b01652157822df3a254672bbcc0901c506a2bd7 2532 digikam_2.6.0~rc-2.dsc
 c30c7f8a801704d665ee2fb9876b15ac78793409d61c736a7465384d2d5262e7 41057 digikam_2.6.0~rc-2.debian.tar.gz
 6bef990adcbd076f9c0a032eb1810ce8e03e9eba738b51a8f4a78cd2d9466416 7619636 digikam_2.6.0~rc-2_amd64.deb
 c5eb8045da1d5d8f8145e0bf300ea500ce1eb21b9c02cd913dd3a8cd6d4edfcc 2018120 showfoto_2.6.0~rc-2_amd64.deb
 bdd56118d5c18b7140d00c54e390b394ea5c77d7da09d70d806d925dc4cc911c 6551502 digikam-dbg_2.6.0~rc-2_amd64.deb
 4441c4f39c4fd8558a8509e8db16cfde36c60b38f8911929ddd7b2251e8ca637 11005630 digikam-data_2.6.0~rc-2_all.deb
 114b7048ef6dffde37f248d2157cc82955061c17114aed20087e0ee0118c628d 18801340 digikam-doc_2.6.0~rc-2_all.deb
 101352a6bf824c1fb8a28bc275146c8fa01aaad7951abb7226644987064c5bf4 7005712 kipi-plugins_2.6.0~rc-2_amd64.deb
 aeec36f04925164b5ab26a3e62a72f78aeb0d447d72d3127e759a2a369f563e3 7534526 kipi-plugins-common_2.6.0~rc-2_all.deb
Files: 
 e054cc2b30fe6e270e1c086fd6609ef8 2532 graphics optional digikam_2.6.0~rc-2.dsc
 8e8f54f0a5e43c4f1fd196ba1c7152b2 41057 graphics optional digikam_2.6.0~rc-2.debian.tar.gz
 870bb5a652cd811a5f206eef51bc6651 7619636 graphics optional digikam_2.6.0~rc-2_amd64.deb
 50a54fc1809545c028f518a9227ece77 2018120 graphics optional showfoto_2.6.0~rc-2_amd64.deb
 fa7ac0bdf27a104a24a6094438716991 6551502 debug extra digikam-dbg_2.6.0~rc-2_amd64.deb
 33f94b5616779faffd8bfba3ea6dd709 11005630 graphics optional digikam-data_2.6.0~rc-2_all.deb
 108eb753453357015cf4ddf837c7a070 18801340 doc optional digikam-doc_2.6.0~rc-2_all.deb
 c17980c918de8e4a8b162bfd97a5a63e 7005712 graphics optional kipi-plugins_2.6.0~rc-2_amd64.deb
 fb4bf8104177dec2a2627203b11a9290 7534526 graphics optional kipi-plugins-common_2.6.0~rc-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAk+3kF0ACgkQoCzanz0IthLX3QCfUQgHXQqbKvwbtzz2KKV+g67k
dmgAnjB0Uu6eW5Wj/Ypnbpg8NDAwT67R
=hzf5
-----END PGP SIGNATURE-----





Information forwarded to debian-bugs-dist@lists.debian.org, Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>:
Bug#673161; Package src:digikam. (Sat, 19 May 2012 20:45:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to debian-bsd@lists.debian.org:
Extra info received and forwarded to list. Copy sent to Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>. (Sat, 19 May 2012 20:45:05 GMT) Full text and rfc822 format available.

Message #27 received at 673161@bugs.debian.org (full text, mbox):

From: Christoph Egger <christoph@debian.org>
To: 673161@bugs.debian.org
Subject: digikam stilff FTBFS due to mysql dependency
Date: Sat, 19 May 2012 22:41:43 +0200
found 673161 4:2.6.0~rc-2

Package mysql-server-core is a virtual package provided by:
  mysql-server-core-5.5 5.5.23-2
  mysql-server-core-5.1 5.1.62-1

E: Package 'mysql-server-core' has no installation candidate

Note: you can't depend on virtual packages with more than one provider
for buildds to work.

Regards

    Christoph

-- 
9FED 5C6C E206 B70A 5857  70CA 9655 22B9 D49A E731
Debian Developer | Lisp Hacker | CaCert Assurer




Marked as found in versions digikam/4:2.6.0~rc-2; no longer marked as fixed in versions digikam/4:2.6.0~rc-2 and reopened. Request was from Christoph Egger <christoph@debian.org> to control@bugs.debian.org. (Sat, 19 May 2012 20:45:07 GMT) Full text and rfc822 format available.

Reply sent to Mark Purcell <msp@debian.org>:
You have taken responsibility. (Sun, 20 May 2012 04:06:06 GMT) Full text and rfc822 format available.

Notification sent to debian-bsd@lists.debian.org:
Bug acknowledged by developer. (Sun, 20 May 2012 04:06:06 GMT) Full text and rfc822 format available.

Message #34 received at 673161-close@bugs.debian.org (full text, mbox):

From: Mark Purcell <msp@debian.org>
To: 673161-close@bugs.debian.org
Subject: Bug#673161: fixed in digikam 4:2.6.0~rc-3
Date: Sun, 20 May 2012 04:02:43 +0000
Source: digikam
Source-Version: 4:2.6.0~rc-3

We believe that the bug you reported is fixed in the latest version of
digikam, which is due to be installed in the Debian FTP archive:

digikam-data_2.6.0~rc-3_all.deb
  to main/d/digikam/digikam-data_2.6.0~rc-3_all.deb
digikam-dbg_2.6.0~rc-3_amd64.deb
  to main/d/digikam/digikam-dbg_2.6.0~rc-3_amd64.deb
digikam-doc_2.6.0~rc-3_all.deb
  to main/d/digikam/digikam-doc_2.6.0~rc-3_all.deb
digikam_2.6.0~rc-3.debian.tar.gz
  to main/d/digikam/digikam_2.6.0~rc-3.debian.tar.gz
digikam_2.6.0~rc-3.dsc
  to main/d/digikam/digikam_2.6.0~rc-3.dsc
digikam_2.6.0~rc-3_amd64.deb
  to main/d/digikam/digikam_2.6.0~rc-3_amd64.deb
kipi-plugins-common_2.6.0~rc-3_all.deb
  to main/d/digikam/kipi-plugins-common_2.6.0~rc-3_all.deb
kipi-plugins_2.6.0~rc-3_amd64.deb
  to main/d/digikam/kipi-plugins_2.6.0~rc-3_amd64.deb
showfoto_2.6.0~rc-3_amd64.deb
  to main/d/digikam/showfoto_2.6.0~rc-3_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 673161@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Mark Purcell <msp@debian.org> (supplier of updated digikam package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sun, 20 May 2012 12:45:04 +1000
Source: digikam
Binary: digikam showfoto digikam-dbg digikam-data digikam-doc kipi-plugins kipi-plugins-common
Architecture: source amd64 all
Version: 4:2.6.0~rc-3
Distribution: unstable
Urgency: low
Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
Changed-By: Mark Purcell <msp@debian.org>
Description: 
 digikam    - digital photo management application for KDE
 digikam-data - digiKam architecture-independant data
 digikam-dbg - debugging symbols for digiKam
 digikam-doc - handbook for digiKam
 kipi-plugins - image manipulation/handling plugins for KIPI aware programs
 kipi-plugins-common - kipi-plugins architecture-independent data
 showfoto   - image viewer/editor for KDE
Closes: 673161
Changes: 
 digikam (4:2.6.0~rc-3) unstable; urgency=low
 .
   * Updated Build-Depends: mysql-server-core-5.5 | mysql-server-core
     - Fixes "FTBFS: build-depends on mysql-server-5.1" (Closes: #673161)
Checksums-Sha1: 
 871c4e31a5212f0912a1a9606c6b69020889a90e 2531 digikam_2.6.0~rc-3.dsc
 67a4db4fd6abb9a74b3921e0999874da16e0b8a5 41149 digikam_2.6.0~rc-3.debian.tar.gz
 3db497152d8caa56ca8f09421dd2b75e0c89e392 7619564 digikam_2.6.0~rc-3_amd64.deb
 8de84d94bd8ec479349af0fd8834a124c264f8b1 2018150 showfoto_2.6.0~rc-3_amd64.deb
 c9ea022853fb16a4847c1fc74e15bd51c66ea134 6551728 digikam-dbg_2.6.0~rc-3_amd64.deb
 f5fcfd0d1fde663b9c4f7eb7e3454ebf1e1748f7 11005582 digikam-data_2.6.0~rc-3_all.deb
 deb7ac26cee9eed893d504a58a44f659259fcc3b 18801362 digikam-doc_2.6.0~rc-3_all.deb
 2aae929cc521482ee78a891abba05f91c11ff2d5 7005850 kipi-plugins_2.6.0~rc-3_amd64.deb
 414add4fb6df0c77afa71f08c60d8396a35f5d2b 7534480 kipi-plugins-common_2.6.0~rc-3_all.deb
Checksums-Sha256: 
 3e47fe0d99aa7f4fa38bcbb001f1c43e36385349ab90e39d96ac5992f2e71cb1 2531 digikam_2.6.0~rc-3.dsc
 9120ca6cc9a3261acc5235e3927bd83dbbbf0e901811b9df9513082f5aaa3ceb 41149 digikam_2.6.0~rc-3.debian.tar.gz
 18349c22fad566da380fa1eea33efddf00f5daa031b2ec65608ae9d4bfa7153d 7619564 digikam_2.6.0~rc-3_amd64.deb
 87bfd28d3f293947339a828d03cfe149642122ba0e8eea0e2ca1683bb1136404 2018150 showfoto_2.6.0~rc-3_amd64.deb
 c1ce9e19edb7547d0453e2030409def20beb397455e60d244b71d2caf963215b 6551728 digikam-dbg_2.6.0~rc-3_amd64.deb
 9c9143c4cda796e8486b962a6de979a090a4be821241ed2a1e730299a7b214a2 11005582 digikam-data_2.6.0~rc-3_all.deb
 c8247d0c846146a6d1d05bae4de7f7a14611b419afd6387eb92a14bdc59c4258 18801362 digikam-doc_2.6.0~rc-3_all.deb
 d809243d8923ff4bb66f8b2b17a3626f612cab06babce578d0306ec2d9c42c5c 7005850 kipi-plugins_2.6.0~rc-3_amd64.deb
 04e85fd3abf2d7e581690c8d49c89c952f5b8be49ed5409c8e68c43db7e26e49 7534480 kipi-plugins-common_2.6.0~rc-3_all.deb
Files: 
 95eefdbc1c3c048681021bf375e9fda7 2531 kde optional digikam_2.6.0~rc-3.dsc
 a767a62dc72295c92f468181c60bc920 41149 kde optional digikam_2.6.0~rc-3.debian.tar.gz
 9f3b012b02ecdbcc7746e4dcd43b60c9 7619564 kde optional digikam_2.6.0~rc-3_amd64.deb
 de4ae98067895b35270aaa2097378d87 2018150 kde optional showfoto_2.6.0~rc-3_amd64.deb
 5a5813b95779fce688999a2595e436fb 6551728 debug extra digikam-dbg_2.6.0~rc-3_amd64.deb
 95503aa4dac4b4b84f2b93d5f592763c 11005582 kde optional digikam-data_2.6.0~rc-3_all.deb
 dfb2214a140f82c5ae4891d1fb176cf0 18801362 doc optional digikam-doc_2.6.0~rc-3_all.deb
 2e1e6ea3b9a4b21122dfe7d4f533a2e1 7005850 kde optional kipi-plugins_2.6.0~rc-3_amd64.deb
 4797bfe23df6fd685f9a602f3583ccd2 7534480 kde optional kipi-plugins-common_2.6.0~rc-3_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAk+4Ze0ACgkQoCzanz0IthIyygCffoH+PBvhCv/9kk8I3ryEZ3O1
zMcAnjDnoQ54D+5imZe5se8YTPCci84Z
=jaif
-----END PGP SIGNATURE-----





Information forwarded to debian-bugs-dist@lists.debian.org, Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>:
Bug#673161; Package src:digikam. (Tue, 22 May 2012 20:48:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Francesco Riosa <francesco@pnpitalia.it>:
Extra info received and forwarded to list. Copy sent to Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>. (Tue, 22 May 2012 20:48:04 GMT) Full text and rfc822 format available.

Message #39 received at 673161@bugs.debian.org (full text, mbox):

From: Francesco Riosa <francesco@pnpitalia.it>
To: Arnold Metselaar <arnold.metsel@gmail.com>, 673161@bugs.debian.org, digiKam developers room - digiKam - Manage your photographs as a professional with the power of open source <digikam-devel@kde.org>
Subject: Re: [Digikam-devel] Bug#673161: Starting mysqld in a chroot
Date: Tue, 22 May 2012 22:38:22 +0200
Il 18/05/2012 08:21, Arnold Metselaar ha scritto:
> Hi,
>
> I was mistaken in my previous message.  Generating a decent /etc/mtab with the line
>
> grep "${CHROOT_PATH}" /etc/mtab | sed -e "s:${CHROOT_PATH}/\?:/:">"${CHROOT_PATH}/etc/mtab"
>
> in /etc/schroot/setup.d/99mini-buildd helped get rid of warnings from df,
> but mysqld was trying to start without it as well.
>
> Mysqld tries to bind to a port at start-up, and fails when another mysqld outside the chroot is already
> bound to that port. When mysqld is not running in the host machine, it starts in a chroot just fine.
> It should also work when mysqld in the host is listening on a non-standard port.
>
> Regards,
> Arnold

Dunno how this reached digikam mailing list but you can start mysql 
without networking with the following in my.cnf:

[mysqld]
skip-networking

or starting mysqld with --skip-networking option

or at your pleasure change port (usually 3307) with:
[mysqld]
port = 3307





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 07 Aug 2012 07:34:51 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 09:51:46 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.