Debian Bug report logs - #670913
texmacs: R plugin missing

version graph

Package: texmacs; Maintainer for texmacs is Atsuhito KOHDA <kohda@debian.org>; Source for texmacs is src:texmacs.

Reported by: Gaubitzer Erwin <erwin.gaubitzer@univie.ac.at>

Date: Mon, 30 Apr 2012 11:09:16 UTC

Severity: normal

Found in version texmacs/1:1.0.7.15-1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, erwin.gaubitzer@univie.ac.at, Atsuhito KOHDA <kohda@debian.org>:
Bug#670913; Package texmacs. (Mon, 30 Apr 2012 11:09:19 GMT) Full text and rfc822 format available.

Acknowledgement sent to Gaubitzer Erwin <erwin.gaubitzer@univie.ac.at>:
New Bug report received and forwarded. Copy sent to erwin.gaubitzer@univie.ac.at, Atsuhito KOHDA <kohda@debian.org>. (Mon, 30 Apr 2012 11:09:21 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Gaubitzer Erwin <erwin.gaubitzer@univie.ac.at>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: texmacs: R plugin missing
Date: Mon, 30 Apr 2012 13:06:33 +0200
Package: texmacs
Version: 1:1.0.7.15-1
Severity: normal

Dear Maintainer,
Starting the R plugin ends up in a "Dead"-Comment. Looking further into
the package I cannot find the necessary tm_r file which should be
loaded. Instead of this a file called r_install can be found, but the
contents of this shell script makes no sense to me.

Is the R plugin still available for TeXmacs or has it been removed
because of missing maintainance? In either case it should be mentioned
in the README.Debian or processed as a bug.

Thanks a lot
Erwin


-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (900, 'testing'), (300, 'stable'), (100, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_AT.UTF-8, LC_CTYPE=de_AT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages texmacs depends on:
ii  findutils            4.4.2-4
ii  ghostscript-x        9.05~dfsg-4
ii  groff                1.21-7
ii  guile-1.8-libs       1.8.8+1-8
ii  libc6                2.13-30
ii  libfreetype6         2.4.9-1
ii  libgcc1              1:4.6.1-4
ii  libgmp10             2:5.0.4+dfsg-1
ii  libltdl7             2.4.2-1
ii  libqtcore4           4:4.7.4-3
ii  libqtgui4            4:4.7.4-3
ii  libstdc++6           4.6.1-4
ii  mlocate              0.23.1-1
ii  texlive-base         2009-15
ii  texlive-extra-utils  2009-10
ii  texlive-font-utils   2009-10
ii  texlive-math-extra   2009-10
ii  texmacs-common       1:1.0.7.15-1
ii  x11-apps             7.6+5
ii  x11-session-utils    7.6+2
ii  x11-utils            7.6+4
ii  zlib1g               1:1.2.6.dfsg-2

Versions of packages texmacs recommends:
ii  imagemagick    8:6.7.4.0-5
ii  ispell         3.3.02-5
ii  libjpeg-progs  8d-1
ii  librsvg2-bin   2.36.1-1
ii  libtiff-tools  4.0.1-2
ii  netpbm         2:10.0-15+b1
ii  xfig           1:3.2.5.b-2

Versions of packages texmacs suggests:
ii  python                2.7.2-10
ii  python-fann [python]  20091015-1
ii  wget                  1.13.4-3

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Atsuhito KOHDA <kohda@debian.org>:
Bug#670913; Package texmacs. (Mon, 30 Apr 2012 14:24:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Gaubitzer Erwin <erwin.gaubitzer@univie.ac.at>:
Extra info received and forwarded to list. Copy sent to Atsuhito KOHDA <kohda@debian.org>. (Mon, 30 Apr 2012 14:24:03 GMT) Full text and rfc822 format available.

Message #10 received at 670913@bugs.debian.org (full text, mbox):

From: Gaubitzer Erwin <erwin.gaubitzer@univie.ac.at>
To: 670913@bugs.debian.org
Subject: Making it work again, but plotting not right
Date: Mon, 30 Apr 2012 16:14:25 +0200
I found out that compilation of tm_r.c fails because of a missing util.h .
However by removing the line
  #include <util.h>
in tm_r.c leads to a working tm_r and copying it to 
  /usr/lib/texmacs/TeXmacs/bin
makes the plugin work again.

Using the Debian source package it worked, too.

After some testing there is one visible problem left: Plots are small in a big 
white box. Maybe this can be redefined in the v()-function.

Thanks again
Erwin




Information forwarded to debian-bugs-dist@lists.debian.org, Atsuhito KOHDA <kohda@debian.org>:
Bug#670913; Package texmacs. (Sat, 05 May 2012 00:18:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Atsuhito Kohda <kohda@pm.tokushima-u.ac.jp>:
Extra info received and forwarded to list. Copy sent to Atsuhito KOHDA <kohda@debian.org>. (Sat, 05 May 2012 00:18:02 GMT) Full text and rfc822 format available.

Message #15 received at 670913@bugs.debian.org (full text, mbox):

From: Atsuhito Kohda <kohda@pm.tokushima-u.ac.jp>
To: erwin.gaubitzer@univie.ac.at, 670913@bugs.debian.org
Subject: Re: Bug#670913: Making it work again, but plotting not right
Date: Sat, 05 May 2012 08:55:02 +0900 (JST)
Hi Gaubitzer Erwin,

On Mon, 30 Apr 2012 16:14:25 +0200, Gaubitzer Erwin wrote:

> I found out that compilation of tm_r.c fails because of a missing util.h .
> However by removing the line
>   #include <util.h>
> in tm_r.c leads to a working tm_r and copying it to 

Thanks for your report.  I'll investigate the problem
afterwards and sorry for late reply.

Best regards,			2012-5-5(Sat)

-- 
 Debian Developer - much more I18N of Debian
 Atsuhito Kohda <kohda AT debian.org>
 Department of Math., Univ. of Tokushima




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 21:51:36 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.