Debian Bug report logs - #669215
packagesearch: depends on outdated libapt-pkg4.10 while 4.12 is in sid

version graph

Package: packagesearch; Maintainer for packagesearch is Benjamin Mesing <ben@debian.org>; Source for packagesearch is src:packagesearch.

Reported by: bud <bugzi.20.dekonta@spamgourmet.com>

Date: Wed, 18 Apr 2012 08:36:01 UTC

Severity: serious

Tags: sid, wheezy

Found in version packagesearch/2.6

Fixed in version 2.7

Done: Benjamin Mesing <bensmail@gmx.net>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, bugzi.20.dekonta@spamgourmet.com, Benjamin Mesing <bensmail@gmx.net>:
Bug#669215; Package packagesearch. (Wed, 18 Apr 2012 08:36:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to bud <bugzi.20.dekonta@spamgourmet.com>:
New Bug report received and forwarded. Copy sent to bugzi.20.dekonta@spamgourmet.com, Benjamin Mesing <bensmail@gmx.net>. (Wed, 18 Apr 2012 08:36:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: bud <bugzi.20.dekonta@spamgourmet.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: packagesearch: depends on outdated libapt-pkg4.10 while 4.12 is in sid
Date: Wed, 18 Apr 2012 10:32:17 +0200
Package: packagesearch
Version: 2.6+b1
Severity: serious
Justification: Policy 3.5

Dear Maintainer,
packagesearch is uninstallable in unstable atm as apt updated to 0.9.1

   * What led up to the situation?
     apt-get install packagesearch

   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?
     packagesearch: Depends: libapt-pkg4.10 but it is not installable
		    Depends: libept1 but it is not going to be installed
                                     (libept1.4.12 is installed)   

   * What outcome did you expect instead?
     Install - ok


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 3.3-2.towo.1-siduction-686 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages packagesearch depends on:
ii  apt               0.9.1
ii  apt-xapian-index  <none>
ii  debtags           1.9+b1
ii  libapt-pkg4.10    <none>
ii  libc6             2.13-28
ii  libept1           <none>
ii  libgcc1           1:4.7.0-3
ii  libqt4-xml        4:4.7.4-3
ii  libqtcore4        4:4.7.4-3
ii  libqtgui4         4:4.7.4-3
ii  libstdc++6        4.7.0-3
ii  libxapian22       1.2.8-1
ii  zlib1g            1:1.2.6.dfsg-2

Versions of packages packagesearch recommends:
ii  apt-file                       <none>
ii  deborphan                      <none>
ii  konsole [x-terminal-emulator]  4:4.7.4-2
ii  xterm [x-terminal-emulator]    278-1

packagesearch suggests no packages.




Added blocking bug(s) of 669215: 639076 Request was from Adam D. Barratt <adam@adam-barratt.org.uk> to control@bugs.debian.org. (Sat, 21 Apr 2012 20:33:04 GMT) Full text and rfc822 format available.

Reply sent to Benjamin Mesing <bensmail@gmx.net>:
You have taken responsibility. (Wed, 23 May 2012 19:09:12 GMT) Full text and rfc822 format available.

Notification sent to bud <bugzi.20.dekonta@spamgourmet.com>:
Bug acknowledged by developer. (Wed, 23 May 2012 19:09:12 GMT) Full text and rfc822 format available.

Message #12 received at 669215-done@bugs.debian.org (full text, mbox):

From: Benjamin Mesing <bensmail@gmx.net>
To: 669215-done@bugs.debian.org, 639076-done@bugs.debian.org, 598193-done@bugs.debian.org
Subject: Bugs closed in 2.7
Date: Wed, 23 May 2012 21:07:01 +0200
Version: 2.7
thanks

Fixed in version 2.7 of packagesearch which was never uploaded to the
archive (we are now at 2.7.1) and therefore its "Closes" statements
where not processed.

Changelog entry:
packagesearch (2.7) unstable; urgency=high

  * compiled against latest version of libept/libapt (Closes: #669215)
  * fixed compiler error caused by xapian having a slots member 
    variable (Closes: #639076)
  * added support for displaying the "Homepage" field (Closes: #598193)
  * Implemented support for viewing screenshots





Added tag(s) sid and wheezy. Request was from Gerfried Fuchs <rhonda@debian.org> to control@bugs.debian.org. (Sat, 16 Jun 2012 23:27:04 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 15 Jul 2012 07:26:45 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 21:00:03 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.