Debian Bug report logs - #668793
openshot: Update package to support new version of melt/python-mlt5

version graph

Package: openshot; Maintainer for openshot is Jonathan Thomas <Jonathan.Oomph@gmail.com>; Source for openshot is src:openshot.

Reported by: Michael Shuler <michael@pbandjelly.org>

Date: Sat, 14 Apr 2012 12:39:02 UTC

Severity: serious

Tags: patch

Found in version openshot/1.4.2-1

Fixed in version openshot/1.4.2-1.1

Done: Cyril Brulebois <kibi@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Jonathan Thomas <Jonathan.Oomph@gmail.com>:
Bug#668793; Package openshot. (Sat, 14 Apr 2012 12:39:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Shuler <michael@pbandjelly.org>:
New Bug report received and forwarded. Copy sent to Jonathan Thomas <Jonathan.Oomph@gmail.com>. (Sat, 14 Apr 2012 12:39:07 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Michael Shuler <michael@pbandjelly.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: openshot: Update package to support new version of melt/python-mlt5
Date: Sat, 14 Apr 2012 07:34:45 -0500
Package: openshot
Version: 1.4.2-1
Severity: normal

Hi Jonathan,

The melt packages were updated, which removes python-mlt3 and subsequently openshot:

$ sudo apt-get dist-upgrade -Vs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
   libmlt4 (0.7.8-2)
   openshot (1.4.2-1)
   python-mlt3 (0.7.8-2)
The following NEW packages will be installed:
   libmlt5 (0.7.8+git20120409-1)
The following packages will be upgraded:
   libmlt++3 (0.7.8-2 => 0.7.8+git20120409-1)
   melt (0.7.8-2 => 0.7.8+git20120409-1)
2 upgraded, 1 newly installed, 3 to remove and 0 not upgraded.
Remv openshot [1.4.2-1]
Remv python-mlt3 [0.7.8-2]
Inst melt [0.7.8-2] (0.7.8+git20120409-1 Debian:unstable [i386]) []
Inst libmlt++3 [0.7.8-2] (0.7.8+git20120409-1 Debian:unstable [i386]) []
Remv libmlt4 [0.7.8-2] []
Inst libmlt5 (0.7.8+git20120409-1 Debian:unstable [i386])
Conf libmlt5 (0.7.8+git20120409-1 Debian:unstable [i386])
Conf melt (0.7.8+git20120409-1 Debian:unstable [i386])
Conf libmlt++3 (0.7.8+git20120409-1 Debian:unstable [i386])

Thanks!

-- 
Kind regards,
Michael

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (900, 'unstable'), (800, 'testing'), (100, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-2-686-pae (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages openshot depends on:
ii  fontconfig           2.8.0-3.1
ii  gtk2-engines-pixbuf  2.24.10-1
ii  librsvg2-common      2.36.0-5
ii  melt                 <none>
ii  python               2.7.2-10
ii  python-gtk2          2.24.0-3
ii  python-httplib2      0.7.4-1
ii  python-imaging       1.1.7-4
ii  python-mlt3          0.7.8-2
ii  python-pygoocanvas   0.14.1-1+b3
ii  python-support       1.0.14
ii  python-xdg           0.19-4

Versions of packages openshot recommends:
ii  frei0r-plugins  1.1.22git20091109-1.2
ii  openshot-doc    1.4.2-1

Versions of packages openshot suggests:
ii  blender   <none>
ii  inkscape  0.48.3.1-1+b1

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Jonathan Thomas <Jonathan.Oomph@gmail.com>:
Bug#668793; Package openshot. (Mon, 14 May 2012 10:27:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Antonio Ospite <ospite@studenti.unina.it>:
Extra info received and forwarded to list. Copy sent to Jonathan Thomas <Jonathan.Oomph@gmail.com>. (Mon, 14 May 2012 10:27:12 GMT) Full text and rfc822 format available.

Message #10 received at 668793@bugs.debian.org (full text, mbox):

From: Antonio Ospite <ospite@studenti.unina.it>
To: Debian Bug Tracking System <668793@bugs.debian.org>
Subject: Re: openshot: Update package to support new version of melt/python-mlt5
Date: Mon, 14 May 2012 12:18:41 +0200
[Message part 1 (text/plain, inline)]
Package: openshot
Followup-For: Bug #668793

Dear Maintainer,

Here is a patch attached to fix this bug.

By providing an optional dependency on python-mlt5 the package builds fine,
the installation is OK and openshot still works with no obvious problems that
I could find.

Please consider applying it.

Regards,
   Antonio Ospite
   http://ao2.it


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (900, 'unstable'), (600, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.4.0-rc2-ao2 (SMP w/1 CPU core)
Locale: LANG=it_IT.utf8, LC_CTYPE=it_IT.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages openshot depends on:
ii  fontconfig           2.9.0-3
ii  gtk2-engines-pixbuf  2.24.10-1
ii  librsvg2-common      2.36.1-1
ii  melt                 0.7.8+git20120417-1
ii  python               2.7.2-10
ii  python-gtk2          2.24.0-3
ii  python-httplib2      0.7.4-1
ii  python-imaging       1.1.7-4
ii  python-mlt5          0.7.8+git20120417-1
ii  python-pygoocanvas   0.14.1-1+b3
ii  python-support       1.0.14
ii  python-xdg           0.19-4

Versions of packages openshot recommends:
ii  frei0r-plugins  1.1.22git20091109-1.2
ii  openshot-doc    1.4.2-1

Versions of packages openshot suggests:
ii  blender   2.63a-1
ii  inkscape  0.48.3.1-1+b1

-- no debconf information
[openshot_depend_on_python-mlt5.diff (text/x-diff, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Jonathan Thomas <Jonathan.Oomph@gmail.com>:
Bug#668793; Package openshot. (Sun, 27 May 2012 23:42:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Cyril Brulebois <kibi@debian.org>:
Extra info received and forwarded to list. Copy sent to Jonathan Thomas <Jonathan.Oomph@gmail.com>. (Sun, 27 May 2012 23:42:03 GMT) Full text and rfc822 format available.

Message #15 received at 668793@bugs.debian.org (full text, mbox):

From: Cyril Brulebois <kibi@debian.org>
To: Antonio Ospite <ospite@studenti.unina.it>, 668793@bugs.debian.org
Cc: sox@packages.debian.org, mlt@packages.debian.org
Subject: Re: Bug#668793: openshot: Update package to support new version of melt/python-mlt5
Date: Mon, 28 May 2012 01:39:39 +0200
[Message part 1 (text/plain, inline)]
severity 668793 serious
tag      668793 patch
thanks

Antonio Ospite <ospite@studenti.unina.it> (14/05/2012):
> Here is a patch attached to fix this bug.
> 
> By providing an optional dependency on python-mlt5 the package builds
> fine, the installation is OK and openshot still works with no obvious
> problems that I could find.
> 
> Please consider applying it.

Fixing this package is needed to get the sox transition done. If
somebody fancies an NMU, that would make most welcome.

Adding sox and mlt maintainers to the loop so they can give a hand.

Mraw,
KiBi.
[signature.asc (application/pgp-signature, inline)]

Severity set to 'serious' from 'normal' Request was from Cyril Brulebois <kibi@debian.org> to control@bugs.debian.org. (Sun, 27 May 2012 23:42:04 GMT) Full text and rfc822 format available.

Added tag(s) patch. Request was from Cyril Brulebois <kibi@debian.org> to control@bugs.debian.org. (Sun, 27 May 2012 23:42:05 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Jonathan Thomas <Jonathan.Oomph@gmail.com>:
Bug#668793; Package openshot. (Tue, 29 May 2012 09:03:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Cyril Brulebois <kibi@debian.org>:
Extra info received and forwarded to list. Copy sent to Jonathan Thomas <Jonathan.Oomph@gmail.com>. (Tue, 29 May 2012 09:03:04 GMT) Full text and rfc822 format available.

Message #24 received at 668793@bugs.debian.org (full text, mbox):

From: Cyril Brulebois <kibi@debian.org>
To: Antonio Ospite <ospite@studenti.unina.it>, 668793@bugs.debian.org
Cc: sox@packages.debian.org, mlt@packages.debian.org
Subject: Re: Bug#668793: openshot: Update package to support new version of melt/python-mlt5
Date: Tue, 29 May 2012 11:01:52 +0200
[Message part 1 (text/plain, inline)]
severity 668793 pending
thanks

Cyril Brulebois <kibi@debian.org> (28/05/2012):
> Fixing this package is needed to get the sox transition done. If
> somebody fancies an NMU, that would make most welcome.

Just uploaded, with the attached source debdiff.

Mraw,
KiBi.
[openshot+nmu.diff (text/x-diff, attachment)]
[signature.asc (application/pgp-signature, inline)]

Added tag(s) pending. Request was from Cyril Brulebois <kibi@debian.org> to control@bugs.debian.org. (Tue, 29 May 2012 09:09:44 GMT) Full text and rfc822 format available.

Reply sent to Cyril Brulebois <kibi@debian.org>:
You have taken responsibility. (Tue, 29 May 2012 09:42:44 GMT) Full text and rfc822 format available.

Notification sent to Michael Shuler <michael@pbandjelly.org>:
Bug acknowledged by developer. (Tue, 29 May 2012 09:42:49 GMT) Full text and rfc822 format available.

Message #31 received at 668793-close@bugs.debian.org (full text, mbox):

From: Cyril Brulebois <kibi@debian.org>
To: 668793-close@bugs.debian.org
Subject: Bug#668793: fixed in openshot 1.4.2-1.1
Date: Tue, 29 May 2012 09:38:52 +0000
Source: openshot
Source-Version: 1.4.2-1.1

We believe that the bug you reported is fixed in the latest version of
openshot, which is due to be installed in the Debian FTP archive:

openshot-doc_1.4.2-1.1_all.deb
  to main/o/openshot/openshot-doc_1.4.2-1.1_all.deb
openshot_1.4.2-1.1.debian.tar.gz
  to main/o/openshot/openshot_1.4.2-1.1.debian.tar.gz
openshot_1.4.2-1.1.dsc
  to main/o/openshot/openshot_1.4.2-1.1.dsc
openshot_1.4.2-1.1_all.deb
  to main/o/openshot/openshot_1.4.2-1.1_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 668793@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Cyril Brulebois <kibi@debian.org> (supplier of updated openshot package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 29 May 2012 10:51:20 +0200
Source: openshot
Binary: openshot openshot-doc
Architecture: source all
Version: 1.4.2-1.1
Distribution: unstable
Urgency: high
Maintainer: Jonathan Thomas <Jonathan.Oomph@gmail.com>
Changed-By: Cyril Brulebois <kibi@debian.org>
Description: 
 openshot   - Create and edit videos and movies
 openshot-doc - Help manual for OpenShot Video Editor
Closes: 668793
Changes: 
 openshot (1.4.2-1.1) unstable; urgency=high
 .
   [ Cyril Brulebois ]
   * Non-maintainer upload.
   * Apply Antonio's patch, thanks!
   * Set urgency to “high”, for the RC bug fix, needed for the sox/mlt transition.
 .
   [ Antonio Ospite ]
   * Add an optional dependency on python-mlt5. (Closes: #668793)
Checksums-Sha1: 
 383f34521d7c45523e39f3e4365ed1409c40a5ab 1287 openshot_1.4.2-1.1.dsc
 aaa539e159e2ae2131e78a8c1eb305ea28a7d0b8 4192 openshot_1.4.2-1.1.debian.tar.gz
 981d285fa02540ee2dc41335c31f77f6333748ee 19309290 openshot_1.4.2-1.1_all.deb
 8764180acde6984f26ba317e2f027d3f26f58137 7302910 openshot-doc_1.4.2-1.1_all.deb
Checksums-Sha256: 
 f728e0ef69a2c265a70664da73b6dcf4feee568eb255e46466de0c68b1d1c3e9 1287 openshot_1.4.2-1.1.dsc
 040ea42d1db52b70b3403749fcb7cb1372ec12e405d2a9872efe223e178926d8 4192 openshot_1.4.2-1.1.debian.tar.gz
 8c18f773aad6a19bbdb9470076e953973be8b9543ac22ab73703a2e24b03e9e4 19309290 openshot_1.4.2-1.1_all.deb
 502d8d6e960c9ffcf6f588511daf48cf17743c5d3f7c25ae7a4ff560de909661 7302910 openshot-doc_1.4.2-1.1_all.deb
Files: 
 8275ae6607090047aac0280bb05bac50 1287 video optional openshot_1.4.2-1.1.dsc
 6c310aab81b230b6ef45ed1b411e7575 4192 video optional openshot_1.4.2-1.1.debian.tar.gz
 2df3c44fd2e46f419cd257f8827d1716 19309290 video optional openshot_1.4.2-1.1_all.deb
 938c9cc275f1fa2e76a696cf4c1d986a 7302910 doc optional openshot-doc_1.4.2-1.1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAk/Ej6gACgkQeGfVPHR5Nd3hywCeL2OTRvAnOY9+0LwE2nnQfsC0
h4kAoK0l9dASq8jshYa8EcC7ns2H6ZS7
=DFBs
-----END PGP SIGNATURE-----





Information forwarded to debian-bugs-dist@lists.debian.org, Jonathan Thomas <Jonathan.Oomph@gmail.com>:
Bug#668793; Package openshot. (Wed, 30 May 2012 05:45:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jonathan Thomas <jonathan.oomph@gmail.com>:
Extra info received and forwarded to list. Copy sent to Jonathan Thomas <Jonathan.Oomph@gmail.com>. (Wed, 30 May 2012 05:45:05 GMT) Full text and rfc822 format available.

Message #36 received at 668793@bugs.debian.org (full text, mbox):

From: Jonathan Thomas <jonathan.oomph@gmail.com>
To: Cyril Brulebois <kibi@debian.org>, 668793@bugs.debian.org
Subject: Re: Bug#668793: openshot: Update package to support new version of melt/python-mlt5
Date: Wed, 30 May 2012 00:44:37 -0500
[Message part 1 (text/plain, inline)]
Thanks for the fix Cyril.  I have updated the OpenShot bzr branch for our
debian packaging to reflect the diff.
-Jonathan

On Tue, May 29, 2012 at 4:01 AM, Cyril Brulebois <kibi@debian.org> wrote:

> severity 668793 pending
> thanks
>
> Cyril Brulebois <kibi@debian.org> (28/05/2012):
> > Fixing this package is needed to get the sox transition done. If
> > somebody fancies an NMU, that would make most welcome.
>
> Just uploaded, with the attached source debdiff.
>
> Mraw,
> KiBi.
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (GNU/Linux)
>
> iEYEARECAAYFAk/EkIAACgkQeGfVPHR5Nd3ILgCgmt3kTgFZnclUXroEEgN0JV0t
> OLAAnAwZxs9SaXP8MCckq0J7RoAGcSj6
> =g1vQ
> -----END PGP SIGNATURE-----
>
>
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Jonathan Thomas <Jonathan.Oomph@gmail.com>:
Bug#668793; Package openshot. (Wed, 30 May 2012 05:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Cyril Brulebois <kibi@debian.org>:
Extra info received and forwarded to list. Copy sent to Jonathan Thomas <Jonathan.Oomph@gmail.com>. (Wed, 30 May 2012 05:51:03 GMT) Full text and rfc822 format available.

Message #41 received at 668793@bugs.debian.org (full text, mbox):

From: Cyril Brulebois <kibi@debian.org>
To: Jonathan Thomas <jonathan.oomph@gmail.com>
Cc: 668793@bugs.debian.org
Subject: Re: Bug#668793: openshot: Update package to support new version of melt/python-mlt5
Date: Wed, 30 May 2012 07:49:50 +0200
[Message part 1 (text/plain, inline)]
Jonathan Thomas <jonathan.oomph@gmail.com> (30/05/2012):
> Thanks for the fix Cyril.  I have updated the OpenShot bzr branch for our
> debian packaging to reflect the diff

You're welcome. FWIW I hope to see it migrated today or tomorrow at
worst, together with mlt/sox and the relevant binNMUs.

Mraw,
KiBi.
[signature.asc (application/pgp-signature, inline)]

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Fri, 29 Jun 2012 07:43:08 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 00:26:37 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.