Debian Bug report logs - #664579
nvi: versioned backups are broken for vi

version graph

Package: nvi; Maintainer for nvi is Debian QA Group <packages@qa.debian.org>; Source for nvi is src:nvi.

Reported by: Jeffrey Sheinberg <jeff@bsrd.net>

Date: Mon, 19 Mar 2012 00:21:02 UTC

Severity: normal

Found in version nvi/1.81.6-8.1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Information forwarded to debian-bugs-dist@lists.debian.org, jeff@bsrd.net, Jan Christoph Nordholz <hesso@pool.math.tu-berlin.de>:
Bug#664579; Package nvi. (Mon, 19 Mar 2012 00:21:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jeffrey Sheinberg <jeff@bsrd.net>:
Extra info received and forwarded to list. Copy sent to jeff@bsrd.net, Jan Christoph Nordholz <hesso@pool.math.tu-berlin.de>. (Mon, 19 Mar 2012 00:21:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Jeffrey Sheinberg <jeff@bsrd.net>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: nvi: versioned backups are broken for vi
Date: Sun, 18 Mar 2012 20:16:23 -0400
Package: nvi
Version: 1.81.6-8.1
Severity: normal

Hi,

Using 'set backup=N%.~', nvi does not write the backup and emits the
error message 'No filename to substitute for #'.

Using 'set backup=%~' does the same as the above, and sometimes nvi
instead just dumps core.

Curiously, the correct backups are written when I invoke 'nex' using the
same set backup values as above.

Thanks,
Jeffrey Sheinberg


-- System Information:
Debian Release: 6.0.4
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'proposed-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-0.bpo.2-amd64 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash

Versions of packages nvi depends on:
ii  libc6                     2.11.3-3       Embedded GNU C Library: Shared lib
ii  libdb4.7                  4.7.25-9       Berkeley v4.7 Database Libraries [
ii  libncursesw5              5.7+20100313-5 shared libraries for terminal hand

Versions of packages nvi recommends:
ii  nvi-doc                       1.81.6-8.1 4.4BSD re-implementation of vi - d

nvi suggests no packages.

-- no debconf information




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 10:01:52 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.