Debian Bug report logs - #664201
ibus: wrong environment variable

version graph

Package: ibus; Maintainer for ibus is IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>; Source for ibus is src:ibus.

Reported by: AWASHIRO Ikuya <ikuya@fruitsbasket.info>

Date: Fri, 16 Mar 2012 15:39:02 UTC

Severity: normal

Found in version ibus/1.4.1-1

Fixed in version ibus/1.4.1-3

Done: Osamu Aoki <osamu@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Information forwarded to debian-bugs-dist@lists.debian.org, IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>:
Bug#664201; Package ibus. (Fri, 16 Mar 2012 15:39:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to AWASHIRO Ikuya <ikuya@fruitsbasket.info>:
Extra info received and forwarded to list. Copy sent to IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>. (Fri, 16 Mar 2012 15:39:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: AWASHIRO Ikuya <ikuya@fruitsbasket.info>
To: submit@bugs.debian.org
Subject: ibus: wrong environment variable
Date: Fri, 16 Mar 2012 23:37:25 +0900
Package: ibus
Version: 1.4.1-1
Severity: normal

Environment variable "QT4_IM_MODULE" which is in /etc/X11/xinit/xinput.d/ibus
is wrong.
Please set correct environment variable "QT_IM_MODULE" instead.



-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=ja_JP.UTF-8, LC_CTYPE=ja_JP.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages ibus depends on:
ii  gconf2           3.2.3-1
ii  libc6            2.13-24
ii  libgconf2-4      3.2.3-1
ii  libglib2.0-0     2.30.2-5
ii  libgtk2.0-0      2.24.8-3
ii  libibus-1.0-0    1.4.1-1
ii  librsvg2-common  2.34.2-2
ii  libx11-6         2:1.4.4-4
ii  python           2.7.2-10
ii  python-ibus      1.4.1-1
ii  python-notify    0.1.1-3
ii  python-xdg       0.19-4

Versions of packages ibus recommends:
ii  ibus-clutter  0.0+git20090728.a936bacf-4
ii  ibus-gtk      1.4.1-1
ii  ibus-gtk3     1.4.1-1
ii  ibus-qt4      1.3.1-2+b1
ii  im-switch     1.21

ibus suggests no packages.

-- no debconf information

-- 
AWASHIRO Ikuya
ikuya@fruitsbasket.info / ikuya@oooug.jp
GPG fingerprint:
1A19 AD66 C53F 2250 3537 1A9D 3A53 2C1D 20AB CC8A
http://blog.goo.ne.jp/ikunya/
http://twitter.com/ikunya/




Information forwarded to debian-bugs-dist@lists.debian.org, IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>:
Bug#664201; Package ibus. (Fri, 16 Mar 2012 17:06:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Osamu Aoki <osamu@debian.org>:
Extra info received and forwarded to list. Copy sent to IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>. (Fri, 16 Mar 2012 17:06:02 GMT) Full text and rfc822 format available.

Message #10 received at submit@bugs.debian.org (full text, mbox):

From: Osamu Aoki <osamu@debian.org>
To: AWASHIRO Ikuya <ikuya@fruitsbasket.info>, 664201@bugs.debian.org
Cc: submit@bugs.debian.org
Subject: Re: Bug#664201: ibus: wrong environment variable
Date: Sat, 17 Mar 2012 01:58:09 +0900
On Fri, Mar 16, 2012 at 11:37:25PM +0900, AWASHIRO Ikuya wrote:
> Package: ibus
> Version: 1.4.1-1
> Severity: normal
> 
> Environment variable "QT4_IM_MODULE" which is in
> /etc/X11/xinit/xinput.d/ibus is wrong.  Please set correct environment
> variable "QT_IM_MODULE" instead.

Can you elaborate why you are telling me this style is wrong?  (You may
be right but in order for me to change, I need some reference
information.)

Here is my background.

We moved to QT4 and QT4_IM_MODULE is valid
environment variable to use as I heard (I do not use KDE).  Can you
point me to the reference document which is the base of your assertion.

Almost all im-switch code uses QT4_IM_MODULE.

My quick googling related this topic is:
http://lists.debian.org/debian-devel/2012/01/msg00055.html
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=644254

But reading 
http://www.thelins.se/johan/2008/12/environmentally-friendly.html
http://en.gentoo-wiki.com/wiki/SCIM
BOTH may be needed.

If so major updates for many IM and im-config is needed.

Please elucidate me on this subject.

Thanks in advance,

Osamu
 




Information forwarded to debian-bugs-dist@lists.debian.org, IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>:
Bug#664201; Package ibus. (Fri, 16 Mar 2012 17:06:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Osamu Aoki <osamu@debian.org>:
Extra info received and forwarded to list. Copy sent to IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>. (Fri, 16 Mar 2012 17:06:06 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>:
Bug#664201; Package ibus. (Fri, 16 Mar 2012 17:24:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Osamu Aoki <osamu@debian.org>:
Extra info received and forwarded to list. Copy sent to IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>. (Fri, 16 Mar 2012 17:24:02 GMT) Full text and rfc822 format available.

Message #20 received at 664201@bugs.debian.org (full text, mbox):

From: Osamu Aoki <osamu@debian.org>
To: AWASHIRO Ikuya <ikuya@fruitsbasket.info>, 664201@bugs.debian.org
Subject: Re: Bug#664201: ibus: wrong environment variable
Date: Sat, 17 Mar 2012 02:17:02 +0900
Hi Awashiro-san,

I did some check on QT4 source code. (qt4-x11-4.7.4)

$ grep -r QT.*_IM_MODULE *
inputmethods/imsw-multi/qmultiinputcontext.cpp:    QString def = QLatin1String(getenv("QT4_IM_MODULE"));
inputmethods/imsw-multi/qmultiinputcontext.cpp:        def = QLatin1String(getenv("QT_IM_MODULE"));

OK so there is no other place in this source mentioning QT_IM_MODULE or
QT4_IM_MODULE in the source.

src/plugins/inputmethods/imsw-multi/qmultiinputcontext.cpp has:

QMultiInputContext::QMultiInputContext()
    : QInputContext(), current(-1)
{
    keys = QInputContextFactory::keys();
    for (int i = keys.size()-1; i >= 0; --i)
        if (keys.at(i).contains(QLatin1String("imsw")))
            keys.removeAt(i);

    QString def = QLatin1String(getenv("QT4_IM_MODULE"));
    if (def.isEmpty())
        def = QLatin1String(getenv("QT_IM_MODULE"));
    if (def.isEmpty()) {
        QSettings settings(QSettings::UserScope, QLatin1String("Trolltech"));
        settings.beginGroup(QLatin1String("Qt"));
        def = settings.value(QLatin1String("DefaultInputMethod"), QLatin1String("xim")).toString();
    }
...

So only when QT4_IM_MODULE is not defined, QT_IM_MODULE value is used.
If both are undefined, "xim" used as its default value.

So there is no need to set both values.  Use of QT4_IM_MODULE seems good
choice for me.  Am I wrong?

Osamu




Information forwarded to debian-bugs-dist@lists.debian.org, IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>:
Bug#664201; Package ibus. (Sat, 17 Mar 2012 00:09:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to AWASHIRO Ikuya <ikuya@fruitsbasket.info>:
Extra info received and forwarded to list. Copy sent to IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>. (Sat, 17 Mar 2012 00:09:06 GMT) Full text and rfc822 format available.

Message #25 received at 664201@bugs.debian.org (full text, mbox):

From: AWASHIRO Ikuya <ikuya@fruitsbasket.info>
To: Osamu Aoki <osamu@debian.org>, 664201@bugs.debian.org
Subject: Re: [Pkg-ime-devel] Bug#664201: ibus: wrong environment variable
Date: Sat, 17 Mar 2012 08:19:32 +0900
On Sat, 17 Mar 2012 01:58:09 +0900
Osamu Aoki <osamu@debian.org> wrote:

> Can you elaborate why you are telling me this style is wrong?  (You may
> be right but in order for me to change, I need some reference
> information.)
I notice that:
 ikuya@DebianSid:~$ dpkg -l|grep ibus-qt
 ii  ibus-qt4                              1.3.1-2+b1                     qt-immodule for ibus (QT4)
 ii  libibus-qt1                           1.3.1-2+b1                     qt-immodule for ibus (QT4)
 ikuya@DebianSid:~$ dpkg -l |grep im-switch
 ii  im-switch                             1.22                           Input method switch framework
Installed ibus-qt4 and im-switch.

 ikuya@DebianSid:~$ env|grep GTK
 GTK_IM_MODULE=ibus
GTK_IM_MODULE is fine.

 ikuya@DebianSid:~$ env|grep QT
 ikuya@DebianSid:~$
QT4_IM_MODULE is not defined.

Then I changed /etc/X11/xinit/xinput.d/ibus.
 ikuya@DebianSid:~$ env|grep QT
 QT_IM_MODULE=ibus
Looks fine.

> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=644254
I read it.
Hmm, is it im-switch's issue?
-- 
AWASHIRO Ikuya
ikuya@fruitsbasket.info / ikuya@oooug.jp
GPG fingerprint:
1A19 AD66 C53F 2250 3537 1A9D 3A53 2C1D 20AB CC8A
http://blog.goo.ne.jp/ikunya/
http://twitter.com/ikunya/




Information forwarded to debian-bugs-dist@lists.debian.org, IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>:
Bug#664201; Package ibus. (Sat, 17 Mar 2012 00:15:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Osamu Aoki <osamu@debian.org>:
Extra info received and forwarded to list. Copy sent to IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>. (Sat, 17 Mar 2012 00:15:05 GMT) Full text and rfc822 format available.

Message #30 received at 664201@bugs.debian.org (full text, mbox):

From: Osamu Aoki <osamu@debian.org>
To: AWASHIRO Ikuya <ikuya@fruitsbasket.info>
Cc: 664201@bugs.debian.org
Subject: Re: [Pkg-ime-devel] Bug#664201: ibus: wrong environment variable
Date: Sat, 17 Mar 2012 09:06:47 +0900
Hi,

On Sat, Mar 17, 2012 at 08:19:32AM +0900, AWASHIRO Ikuya wrote:
> On Sat, 17 Mar 2012 01:58:09 +0900
> Osamu Aoki <osamu@debian.org> wrote:
> 
> > Can you elaborate why you are telling me this style is wrong?  (You may
> > be right but in order for me to change, I need some reference
> > information.)
> I notice that:
>  ikuya@DebianSid:~$ dpkg -l|grep ibus-qt
>  ii  ibus-qt4                              1.3.1-2+b1                     qt-immodule for ibus (QT4)
>  ii  libibus-qt1                           1.3.1-2+b1                     qt-immodule for ibus (QT4)
>  ikuya@DebianSid:~$ dpkg -l |grep im-switch
>  ii  im-switch                             1.22                           Input method switch framework
> Installed ibus-qt4 and im-switch.
> 
>  ikuya@DebianSid:~$ env|grep GTK
>  GTK_IM_MODULE=ibus
> GTK_IM_MODULE is fine.
> 
>  ikuya@DebianSid:~$ env|grep QT
>  ikuya@DebianSid:~$
> QT4_IM_MODULE is not defined.

This is not right.

$ env|grep QT
QT4_IM_MODULE=ibus

But I have im-config here.

> Then I changed /etc/X11/xinit/xinput.d/ibus.
>  ikuya@DebianSid:~$ env|grep QT
>  QT_IM_MODULE=ibus
> Looks fine.
> 
> > http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=644254
> I read it.
> Hmm, is it im-switch's issue?

Oops.  That is possible.

But that bug itself was fixed.  But this is good start.
I will look into this this week end.  This should be simple to fix.

Osamu




Information forwarded to debian-bugs-dist@lists.debian.org, IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>:
Bug#664201; Package ibus. (Sat, 17 Mar 2012 02:12:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Osamu Aoki <osamu@debian.org>:
Extra info received and forwarded to list. Copy sent to IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>. (Sat, 17 Mar 2012 02:12:03 GMT) Full text and rfc822 format available.

Message #35 received at 664201@bugs.debian.org (full text, mbox):

From: Osamu Aoki <osamu@debian.org>
To: AWASHIRO Ikuya <ikuya@fruitsbasket.info>
Cc: 664201@bugs.debian.org, Aron Xu <happyaron.xu@gmail.com>
Subject: Re: [Pkg-ime-devel] Bug#664201: ibus: wrong environment variable
Date: Sat, 17 Mar 2012 11:03:09 +0900
Hi,

(Aron: See http://bugs.debian.org/664201)

On Sat, Mar 17, 2012 at 08:19:32AM +0900, AWASHIRO Ikuya wrote:
> Installed ibus-qt4 and im-switch.
> 
>  ikuya@DebianSid:~$ env|grep GTK
>  GTK_IM_MODULE=ibus
> GTK_IM_MODULE is fine.
> 
>  ikuya@DebianSid:~$ env|grep QT
>  ikuya@DebianSid:~$
> QT4_IM_MODULE is not defined.
> 
> > http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=644254
> I read it.
> Hmm, is it im-switch's issue?

I realize im-switch only set QT_IM_MODULE and QT4_IM_MODULE in config is
not exported.  This is because im-switch design.

When copying script from im-config, all  QT4_IM_MODULE instances needs
to be changed to  QT_IM_MODULE.  So this is ibus bug and it exist in
fcitx too.

I will fix this for ibus ...

Osamu






Information forwarded to debian-bugs-dist@lists.debian.org, IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>:
Bug#664201; Package ibus. (Sat, 17 Mar 2012 07:48:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Aron Xu <happyaron.xu@gmail.com>:
Extra info received and forwarded to list. Copy sent to IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>. (Sat, 17 Mar 2012 07:48:07 GMT) Full text and rfc822 format available.

Message #40 received at 664201@bugs.debian.org (full text, mbox):

From: Aron Xu <happyaron.xu@gmail.com>
To: Osamu Aoki <osamu@debian.org>
Cc: AWASHIRO Ikuya <ikuya@fruitsbasket.info>, 664201@bugs.debian.org
Subject: Re: [Pkg-ime-devel] Bug#664201: ibus: wrong environment variable
Date: Sat, 17 Mar 2012 15:41:56 +0800
Sorry I don't understand what's the problem:

$ env | grep GTK
GTK_IM_MODULE=fcitx
$ env | grep QT
QT4_IM_MODULE=fcitx

And even if QT*_IM_MODULE aren't exported, why it's a bug in ibus/fcitx?

-- 
Regards,
Aron Xu




Information forwarded to debian-bugs-dist@lists.debian.org, IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>:
Bug#664201; Package ibus. (Sat, 17 Mar 2012 15:29:11 GMT) Full text and rfc822 format available.

Acknowledgement sent to Osamu Aoki <osamu@debian.org>:
Extra info received and forwarded to list. Copy sent to IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>. (Sat, 17 Mar 2012 15:29:12 GMT) Full text and rfc822 format available.

Message #45 received at 664201@bugs.debian.org (full text, mbox):

From: Osamu Aoki <osamu@debian.org>
To: Aron Xu <happyaron.xu@gmail.com>, 664201@bugs.debian.org
Cc: AWASHIRO Ikuya <ikuya@fruitsbasket.info>
Subject: Re: [Pkg-ime-devel] Bug#664201: Bug#664201: ibus: wrong environment variable
Date: Sun, 18 Mar 2012 00:22:28 +0900
On Sat, Mar 17, 2012 at 03:41:56PM +0800, Aron Xu wrote:
> Sorry I don't understand what's the problem:
> 
> $ env | grep GTK
> GTK_IM_MODULE=fcitx
> $ env | grep QT
> QT4_IM_MODULE=fcitx
> 
> And even if QT*_IM_MODULE aren't exported, why it's a bug in ibus/fcitx?

Well.... they are bugs if the hook script provided for im-swich by these
packages does not work with the existing im-switch implimentation.

im-switch was created before QT4 and it uses QT_IM_MODULE only.
Exporting of QT_IM_MODULE from im-switch works with QT4 but setting
QT4_IM_MODULE for im-switch does not do what you wish im-switch should
do.

Since im-switch is going out soonish, let's make changes minimal.  Let's
make ibus/fcitx to work with archaic but exising im-switch.

That is all this is about.

I know this is confusing.  You see, I was confused enough to agree to
use QT4_IM_MODULE for the im-switch hook script.  But Ikuya woke me up.

Regards,

Osamu




Reply sent to Osamu Aoki <osamu@debian.org>:
You have taken responsibility. (Sat, 17 Mar 2012 15:51:16 GMT) Full text and rfc822 format available.

Notification sent to AWASHIRO Ikuya <ikuya@fruitsbasket.info>:
Bug acknowledged by developer. (Sat, 17 Mar 2012 15:51:16 GMT) Full text and rfc822 format available.

Message #50 received at 664201-close@bugs.debian.org (full text, mbox):

From: Osamu Aoki <osamu@debian.org>
To: 664201-close@bugs.debian.org
Subject: Bug#664201: fixed in ibus 1.4.1-3
Date: Sat, 17 Mar 2012 15:48:51 +0000
Source: ibus
Source-Version: 1.4.1-3

We believe that the bug you reported is fixed in the latest version of
ibus, which is due to be installed in the Debian FTP archive:

gir1.2-ibus-1.0_1.4.1-3_amd64.deb
  to main/i/ibus/gir1.2-ibus-1.0_1.4.1-3_amd64.deb
ibus-doc_1.4.1-3_all.deb
  to main/i/ibus/ibus-doc_1.4.1-3_all.deb
ibus-gtk3_1.4.1-3_amd64.deb
  to main/i/ibus/ibus-gtk3_1.4.1-3_amd64.deb
ibus-gtk_1.4.1-3_amd64.deb
  to main/i/ibus/ibus-gtk_1.4.1-3_amd64.deb
ibus_1.4.1-3.debian.tar.gz
  to main/i/ibus/ibus_1.4.1-3.debian.tar.gz
ibus_1.4.1-3.dsc
  to main/i/ibus/ibus_1.4.1-3.dsc
ibus_1.4.1-3_amd64.deb
  to main/i/ibus/ibus_1.4.1-3_amd64.deb
libibus-1.0-0_1.4.1-3_amd64.deb
  to main/i/ibus/libibus-1.0-0_1.4.1-3_amd64.deb
libibus-1.0-dev_1.4.1-3_amd64.deb
  to main/i/ibus/libibus-1.0-dev_1.4.1-3_amd64.deb
python-ibus_1.4.1-3_all.deb
  to main/i/ibus/python-ibus_1.4.1-3_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 664201@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Osamu Aoki <osamu@debian.org> (supplier of updated ibus package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sun, 18 Mar 2012 00:25:01 +0900
Source: ibus
Binary: ibus libibus-1.0-0 libibus-1.0-dev ibus-gtk ibus-gtk3 python-ibus ibus-doc gir1.2-ibus-1.0
Architecture: source amd64 all
Version: 1.4.1-3
Distribution: unstable
Urgency: low
Maintainer: IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>
Changed-By: Osamu Aoki <osamu@debian.org>
Description: 
 gir1.2-ibus-1.0 - Intelligent Input Bus - introspection data
 ibus       - Intelligent Input Bus - core
 ibus-doc   - Intelligent Input Bus - development documentation
 ibus-gtk   - Intelligent Input Bus - GTK+2 support
 ibus-gtk3  - Intelligent Input Bus - GTK+3 support
 libibus-1.0-0 - Intelligent Input Bus - shared library
 libibus-1.0-dev - Intelligent Input Bus - development file
 python-ibus - Intelligent Input Bus - Python support
Closes: 664201
Changes: 
 ibus (1.4.1-3) unstable; urgency=low
 .
   * Fixed im-switch hook script. Closes: #664201
Checksums-Sha1: 
 d713238ed4393619d90bbf7377b64805d9e56569 2003 ibus_1.4.1-3.dsc
 afc7c2fd66671ce77fdae7775dce7e17d05b9194 15650 ibus_1.4.1-3.debian.tar.gz
 e852b69b21857dea6749d046b24262f8407ed3e0 443478 ibus_1.4.1-3_amd64.deb
 15661a5e52b7c62440f6b59c2d57f15f0b86ca3b 260760 libibus-1.0-0_1.4.1-3_amd64.deb
 75a414e233a66c7e5ae8cd9d3b63f5dbb883639f 282452 libibus-1.0-dev_1.4.1-3_amd64.deb
 e6e0ff1bf44106a173af67cb394704282e35208c 164632 ibus-gtk_1.4.1-3_amd64.deb
 c7892f149da39d58bbb47914f0abd035d5b7cb71 164650 ibus-gtk3_1.4.1-3_amd64.deb
 6035fa0b6999f126cf08fae90bfbb7505a003595 185866 python-ibus_1.4.1-3_all.deb
 5e23eb6e3c4f4d66876d5f9bad3931fb7c3e1a9c 335666 ibus-doc_1.4.1-3_all.deb
 4f8c446beb00c1efd1121657019840d060ea336a 204360 gir1.2-ibus-1.0_1.4.1-3_amd64.deb
Checksums-Sha256: 
 f191569b4bb783bcc1244b106a19801956991a07e5302e379dab129b933db46a 2003 ibus_1.4.1-3.dsc
 6edd8fe096c97f66a01599f601d3df81ad155bc781a815ebab4e3f85a0bf1c0c 15650 ibus_1.4.1-3.debian.tar.gz
 4fec1d350572be0b17bc8c873f4500dd685bd77643bbedd7a015e1291d4d7de3 443478 ibus_1.4.1-3_amd64.deb
 f108131c21a800dbcda412808a1dfae1b77a9454c9bc9b24b2c141ec8916c2bd 260760 libibus-1.0-0_1.4.1-3_amd64.deb
 a0ffcea4528d1baa97a661c722a791a682dcc1c224c071f5347b520c261b3d41 282452 libibus-1.0-dev_1.4.1-3_amd64.deb
 5e848f0736f50d28c05b80aca8a6416d3cf058979ad0312daca997fde1c26a59 164632 ibus-gtk_1.4.1-3_amd64.deb
 83140fe62e8afc29cfbbb34ee382f96bd5d53492c1a4c4552d7a600dc0850753 164650 ibus-gtk3_1.4.1-3_amd64.deb
 04035e309b046b18cddacd7a3d0b6baa9fb0c45965602b4038d2cf4e42cba70d 185866 python-ibus_1.4.1-3_all.deb
 497db17650c580356f26941207714a4a274dbcc4de34ed82c3db78a0a4515c9f 335666 ibus-doc_1.4.1-3_all.deb
 b01476a6a735105af31cb99ca959ca58fa95c95d44c052029fd1a6b92c95f394 204360 gir1.2-ibus-1.0_1.4.1-3_amd64.deb
Files: 
 52e14b0a9094b55e75b05f6593e48477 2003 utils optional ibus_1.4.1-3.dsc
 0ecb8eaf1a3d1f461bcbb6521a2c3d40 15650 utils optional ibus_1.4.1-3.debian.tar.gz
 5843f963a528ccba7f84c201501c7b0f 443478 utils optional ibus_1.4.1-3_amd64.deb
 1df23ff6c5020d105d90895ef92071e3 260760 libs optional libibus-1.0-0_1.4.1-3_amd64.deb
 c13117b5f7ddfc9023b77319bf1850f3 282452 libdevel optional libibus-1.0-dev_1.4.1-3_amd64.deb
 bd0240b92fc428182a04f8526bdf7f8a 164632 utils optional ibus-gtk_1.4.1-3_amd64.deb
 801bb2c4ed72c9d9e2c09fd1c47d0277 164650 utils optional ibus-gtk3_1.4.1-3_amd64.deb
 4088ef093a466f6c86b0acac09306eb1 185866 python optional python-ibus_1.4.1-3_all.deb
 077c0038c39eea522e5bbce4dea1d8fc 335666 doc optional ibus-doc_1.4.1-3_all.deb
 610602ad08b834b7c631a2e1df503eda 204360 introspection optional gir1.2-ibus-1.0_1.4.1-3_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAk9krhoACgkQ6A/EwagGHzIQsQCcCfgH2XKkven119NWou8DUhwi
HRYAn1GPyrRPIg/heNgU4pHSOLrtlodw
=gorv
-----END PGP SIGNATURE-----





Information forwarded to debian-bugs-dist@lists.debian.org, IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>:
Bug#664201; Package ibus. (Sat, 17 Mar 2012 18:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Aron Xu <happyaron.xu@gmail.com>:
Extra info received and forwarded to list. Copy sent to IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>. (Sat, 17 Mar 2012 18:15:03 GMT) Full text and rfc822 format available.

Message #55 received at 664201@bugs.debian.org (full text, mbox):

From: Aron Xu <happyaron.xu@gmail.com>
To: Osamu Aoki <osamu@debian.org>
Cc: 664201@bugs.debian.org, AWASHIRO Ikuya <ikuya@fruitsbasket.info>
Subject: Re: [Pkg-ime-devel] Bug#664201: Bug#664201: ibus: wrong environment variable
Date: Sun, 18 Mar 2012 02:13:12 +0800
On Sat, Mar 17, 2012 at 23:22, Osamu Aoki <osamu@debian.org> wrote:
>
> Well.... they are bugs if the hook script provided for im-swich by these
> packages does not work with the existing im-switch implimentation.
>
> im-switch was created before QT4 and it uses QT_IM_MODULE only.
> Exporting of QT_IM_MODULE from im-switch works with QT4 but setting
> QT4_IM_MODULE for im-switch does not do what you wish im-switch should
> do.
>
> Since im-switch is going out soonish, let's make changes minimal.  Let's
> make ibus/fcitx to work with archaic but exising im-switch.
>
> That is all this is about.
>
> I know this is confusing.  You see, I was confused enough to agree to
> use QT4_IM_MODULE for the im-switch hook script.  But Ikuya woke me up.
>
> Regards,
>
> Osamu

Thanks! I get the point. I'll fix this in fcitx in next upload,
expected to happen very soon.

-- 
Regards,
Aron Xu




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 25 Apr 2012 07:32:55 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 02:38:53 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.