Debian Bug report logs - #662964
ekiga: uninstallable

version graph

Package: ekiga; Maintainer for ekiga is Kilian Krause <kilian@debian.org>; Source for ekiga is src:ekiga.

Reported by: Nicolas Évrard <nicoe@no-log.org>

Date: Wed, 7 Mar 2012 16:33:01 UTC

Severity: grave

Tags: patch, sid, wheezy

Fixed in version ekiga/3.2.7-4.2

Done: Mehdi Dogguy <mehdi@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Kilian Krause <kilian@debian.org>:
Bug#662964; Package ekiga. (Wed, 07 Mar 2012 16:33:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Nicolas Évrard <nicoe@no-log.org>:
New Bug report received and forwarded. Copy sent to Kilian Krause <kilian@debian.org>. (Wed, 07 Mar 2012 16:33:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Nicolas Évrard <nicoe@no-log.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: ekiga: uninstallable
Date: Wed, 07 Mar 2012 17:22:15 +0100
Package: ekiga
Severity: grave
Justification: renders package unusable

Dear Maintainer,

I tried to install ekiga today. And it did not work:

    % sudo aptitude update
    … snip Hit and stuff …
    % LANG=C sudo aptitude install ekiga
    The following NEW packages will be installed:
      ekiga{b} libcamel-1.2-29{a} libebook-1.2-12{a} libedataserver-1.2-15{a} libopal3.6.8{ab} 
    The following packages are RECOMMENDED but will NOT be installed:
      yelp 
    0 packages upgraded, 5 newly installed, 0 to remove and 27 not upgraded.
    Need to get 13.7 MB of archives. After unpacking 31.3 MB will be used.
    The following packages have unmet dependencies:
      ekiga: Depends: libpt2.6.7 which is a virtual package.
             Depends: evolution-data-server but it is not going to be installed.
      libopal3.6.8: Depends: libpt2.6.7 which is a virtual package.
                    Depends: libsrtp0 but it is not going to be installed.
    The following actions will resolve these dependencies:

         Keep the following packages at their current version:
    1)     ekiga [Not Installed]                              
    2)     libopal3.6.8 [Not Installed]                       

And thus the installation fail. 


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_BE.UTF-8, LC_CTYPE=fr_BE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash




Information forwarded to debian-bugs-dist@lists.debian.org, Kilian Krause <kilian@debian.org>:
Bug#662964; Package ekiga. (Wed, 07 Mar 2012 20:15:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Eugen Dedu <Eugen.Dedu@pu-pm.univ-fcomte.fr>:
Extra info received and forwarded to list. Copy sent to Kilian Krause <kilian@debian.org>. (Wed, 07 Mar 2012 20:15:07 GMT) Full text and rfc822 format available.

Message #10 received at 662964@bugs.debian.org (full text, mbox):

From: Eugen Dedu <Eugen.Dedu@pu-pm.univ-fcomte.fr>
To: Nicolas Évrard <nicoe@no-log.org>, 662964@bugs.debian.org, Mark Purcell <msp@debian.org>
Subject: Re: Bug#662964: ekiga: uninstallable
Date: Wed, 07 Mar 2012 21:05:23 +0100
On 07/03/12 17:22, Nicolas Évrard wrote:
> Package: ekiga
> Severity: grave
> Justification: renders package unusable
>
> Dear Maintainer,
>
> I tried to install ekiga today. And it did not work:
>
>      % sudo aptitude update
>      … snip Hit and stuff …
>      % LANG=C sudo aptitude install ekiga
>      The following NEW packages will be installed:
>        ekiga{b} libcamel-1.2-29{a} libebook-1.2-12{a} libedataserver-1.2-15{a} libopal3.6.8{ab}
>      The following packages are RECOMMENDED but will NOT be installed:
>        yelp
>      0 packages upgraded, 5 newly installed, 0 to remove and 27 not upgraded.
>      Need to get 13.7 MB of archives. After unpacking 31.3 MB will be used.
>      The following packages have unmet dependencies:
>        ekiga: Depends: libpt2.6.7 which is a virtual package.
>               Depends: evolution-data-server but it is not going to be installed.
>        libopal3.6.8: Depends: libpt2.6.7 which is a virtual package.
>                      Depends: libsrtp0 but it is not going to be installed.
>      The following actions will resolve these dependencies:
>
>           Keep the following packages at their current version:
>      1)     ekiga [Not Installed]
>      2)     libopal3.6.8 [Not Installed]
>
> And thus the installation fail.

Hi Mark,

Has libpt2.6.7 been removed from unstable???  I fear that something very 
wrong happened with this transition.

-- 
Eugen




Information forwarded to debian-bugs-dist@lists.debian.org, Kilian Krause <kilian@debian.org>:
Bug#662964; Package ekiga. (Wed, 07 Mar 2012 21:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mark Purcell <mark@purcell.id.au>:
Extra info received and forwarded to list. Copy sent to Kilian Krause <kilian@debian.org>. (Wed, 07 Mar 2012 21:21:03 GMT) Full text and rfc822 format available.

Message #15 received at 662964@bugs.debian.org (full text, mbox):

From: Mark Purcell <mark@purcell.id.au>
To: Nicolas Évrard <nicoe@no-log.org>, 662964@bugs.debian.org
Subject: Re: Bug#662964: ekiga: uninstallable
Date: Thu, 8 Mar 2012 08:18:09 +1100
[Message part 1 (text/plain, inline)]
On Thu, 8 Mar 2012 03:22:15 Nicolas Évrard wrote:
>     The following packages have unmet dependencies:
>       ekiga: Depends: libpt2.6.7 which is a virtual package.
>              Depends: evolution-data-server but it is not going to be
> installed. libopal3.6.8: Depends: libpt2.6.7 which is a virtual package.

Nicolas,

Some of the libraries for ekiga are going through a transition:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=659202

It is normal during a transition for some dependant libraries to not be 
availble from the unstable distribution.

In this case I would recommend you install libpt2.6.7 from the testing 
distribution while the tranistion is underway:
http://packages.debian.org/search?keywords=libpt2.6.7

Mark
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Kilian Krause <kilian@debian.org>:
Bug#662964; Package ekiga. (Wed, 07 Mar 2012 21:30:13 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mark Purcell <mark@purcell.id.au>:
Extra info received and forwarded to list. Copy sent to Kilian Krause <kilian@debian.org>. (Wed, 07 Mar 2012 21:30:15 GMT) Full text and rfc822 format available.

Message #20 received at 662964@bugs.debian.org (full text, mbox):

From: Mark Purcell <mark@purcell.id.au>
To: Eugen Dedu <Eugen.Dedu@pu-pm.univ-fcomte.fr>, 662964@bugs.debian.org
Cc: Nicolas Évrard <nicoe@no-log.org>
Subject: Re: Bug#662964: ekiga: uninstallable
Date: Thu, 8 Mar 2012 08:26:39 +1100
[Message part 1 (text/plain, inline)]
On Thu, 8 Mar 2012 07:05:23 Eugen Dedu wrote:
> Has libpt2.6.7 been removed from unstable???  I fear that something very 
> wrong happened with this transition.

Eugen,

Yes libpt2.6.7 was updated to libpt2.10.4 as part of this transition.

However, libpt2.6.7 remains in testing and stable until the transition is 
complete. ekiga3.2.7 will remain installable from both testing and stable 
while we complete the tranistion.

To complete the transition we are required to update:
libpt
opal
ekiga
t38modem

You indicated that in a few weeks you wanted to upload ekiga 4.0, so ekiga 
would be part of this transition. It will take a few weeks for the dependant 
libs to be upgraded.

If you want to keep ekiga 3.2.7 in unstable for a longer time, I have offered 
to fork ptlib/ opal packages in unstable:

! If the latter then we can create an NEW {opal3,ptlib2}6.7-lalande packages
! so we don't have to rush the ekiga transition

Please let me know if you would like me to upload the NEW 
{opal3,ptlib2}6.7-lalande packages, or are happy to wait for ekiga4.0 in 
unstable.

Mark
[signature.asc (application/pgp-signature, inline)]

Added blocking bug(s) of 662964: 659202 Request was from Mark Purcell <mark@purcell.id.au> to control@bugs.debian.org. (Sat, 17 Mar 2012 00:57:06 GMT) Full text and rfc822 format available.

Added tag(s) sid and wheezy. Request was from Gerfried Fuchs <rhonda@debian.org> to control@bugs.debian.org. (Sat, 24 Mar 2012 20:27:06 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Kilian Krause <kilian@debian.org>:
Bug#662964; Package ekiga. (Thu, 05 Apr 2012 10:24:16 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mehdi Dogguy <mehdi@dogguy.org>:
Extra info received and forwarded to list. Copy sent to Kilian Krause <kilian@debian.org>. (Thu, 05 Apr 2012 10:24:20 GMT) Full text and rfc822 format available.

Message #29 received at 662964@bugs.debian.org (full text, mbox):

From: Mehdi Dogguy <mehdi@dogguy.org>
To: 664929@bugs.debian.org, 662964@bugs.debian.org
Subject: ekiga: diff for NMU version 3.2.7-4.2
Date: Thu, 5 Apr 2012 12:14:31 +0200
[Message part 1 (text/plain, inline)]
tags 662964 + patch
tags 662964 + pending
tags 664929 + patch
tags 664929 + pending
thanks

Dear maintainer,

I've prepared an NMU for ekiga (versioned as 3.2.7-4.2) and
uploaded it to DELAYED/2. Please feel free to tell me if I
should delay it longer or if I can upload without delay.

Regards.

-- 
Mehdi Dogguy
[ekiga-3.2.7-4.2-nmu.diff (text/x-diff, attachment)]

Added tag(s) patch. Request was from Mehdi Dogguy <mehdi@dogguy.org> to control@bugs.debian.org. (Thu, 05 Apr 2012 10:24:33 GMT) Full text and rfc822 format available.

Added tag(s) pending. Request was from Mehdi Dogguy <mehdi@dogguy.org> to control@bugs.debian.org. (Thu, 05 Apr 2012 10:24:33 GMT) Full text and rfc822 format available.

Reply sent to Mehdi Dogguy <mehdi@debian.org>:
You have taken responsibility. (Thu, 05 Apr 2012 18:21:05 GMT) Full text and rfc822 format available.

Notification sent to Nicolas Évrard <nicoe@no-log.org>:
Bug acknowledged by developer. (Thu, 05 Apr 2012 18:21:05 GMT) Full text and rfc822 format available.

Message #38 received at 662964-close@bugs.debian.org (full text, mbox):

From: Mehdi Dogguy <mehdi@debian.org>
To: 662964-close@bugs.debian.org
Subject: Bug#662964: fixed in ekiga 3.2.7-4.2
Date: Thu, 05 Apr 2012 18:17:31 +0000
Source: ekiga
Source-Version: 3.2.7-4.2

We believe that the bug you reported is fixed in the latest version of
ekiga, which is due to be installed in the Debian FTP archive:

ekiga-dbg_3.2.7-4.2_amd64.deb
  to main/e/ekiga/ekiga-dbg_3.2.7-4.2_amd64.deb
ekiga_3.2.7-4.2.debian.tar.gz
  to main/e/ekiga/ekiga_3.2.7-4.2.debian.tar.gz
ekiga_3.2.7-4.2.dsc
  to main/e/ekiga/ekiga_3.2.7-4.2.dsc
ekiga_3.2.7-4.2_amd64.deb
  to main/e/ekiga/ekiga_3.2.7-4.2_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 662964@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Mehdi Dogguy <mehdi@debian.org> (supplier of updated ekiga package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Thu, 05 Apr 2012 11:51:01 +0200
Source: ekiga
Binary: ekiga ekiga-dbg
Architecture: source amd64
Version: 3.2.7-4.2
Distribution: unstable
Urgency: high
Maintainer: Kilian Krause <kilian@debian.org>
Changed-By: Mehdi Dogguy <mehdi@debian.org>
Description: 
 ekiga      - H.323 and SIP compatible VoIP client
 ekiga-dbg  - H.323 and SIP compatible VoIP client - debug symbols
Closes: 662964 664929
Changes: 
 ekiga (3.2.7-4.2) unstable; urgency=high
 .
   * Non-maintainer upload.
   * Fix FTBFS due to API changes in Opal 3.10 (Closes: #664929, #662964)
     - add debian/patches/opal310.patch
   * Set urgency to "high" to fix RC bugs.
Checksums-Sha1: 
 5be5091a06f2c9321690b525f0e2517fe3de5b13 2135 ekiga_3.2.7-4.2.dsc
 8c77ec881f4e67ba0d1449d66749dd9b4ac687e6 18245 ekiga_3.2.7-4.2.debian.tar.gz
 5809bccc8902a25e4b1cfd7a1560bd6b10b0999b 9217920 ekiga_3.2.7-4.2_amd64.deb
 75063316590ed36a6d7aaf8f5c0923705ac5dfab 10064388 ekiga-dbg_3.2.7-4.2_amd64.deb
Checksums-Sha256: 
 792735e00eda4ca40599032f6f499b076a2c6b0eaabbe844548bb05e2f082e81 2135 ekiga_3.2.7-4.2.dsc
 e17c7819a1fb874ea85007a6eba6f195ae848684bad9b9c0227eb2a728976df1 18245 ekiga_3.2.7-4.2.debian.tar.gz
 012be0214439356564a6ecf81be631a1ffa1ab4ee46619bff4647249ee654852 9217920 ekiga_3.2.7-4.2_amd64.deb
 8d36ea6ead21d2f250fc8abf49ef3289b3e57fea75a9080bc697c9d618f4fa02 10064388 ekiga-dbg_3.2.7-4.2_amd64.deb
Files: 
 0cbfbd1cb91cb2458a6a94f0c04c80d4 2135 gnome optional ekiga_3.2.7-4.2.dsc
 6c013f39bd1e8c9fe43cbcbc6c674f86 18245 gnome optional ekiga_3.2.7-4.2.debian.tar.gz
 09ebe9cd4d09b246f846b88114dbba98 9217920 gnome optional ekiga_3.2.7-4.2_amd64.deb
 3d9ceae921c1649237d553d14392cc89 10064388 debug extra ekiga-dbg_3.2.7-4.2_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQEcBAEBCAAGBQJPfXCWAAoJEDe1GR0FRlJoYGoH/3WNDXH1moyj9AcFMwts38TG
Ow8xAKPhm9ErdIAF64VLxCJMyucB4td8d2UvdSMLuW8bWax2YRK46dZS+K0yuDAL
+iCzry24L4jvzLCWt3xBJXOK8a4Jq7vZAyJL07buLeQisMCvj2rURknSK3wZW1n5
oKXvbwFjqSF3kG292Tclk+YwlQbF0TSboBzf3DEPdDjFdtOZ1RIz0ImPs7Pv1vFm
OuMFaosu2Q04z8eD/6HBNfBA9JCRGOrLgZGrLPWfH8PFdu0lq8aKM/z/G2cSPQKE
c06dKkPixz2e1lpCF4IGsyBdf1flxUc7yFOpiKNeYaiGNrOAUdV/b6lHOmLb5xk=
=PJzs
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 08 May 2012 07:40:36 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 16:03:39 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.