Debian Bug report logs - #661471
gnome-themes-standard: removal of gnome-themes-standard makes files disappear from gnome-accessibility-themes

version graph

Package: gnome-themes-standard; Maintainer for gnome-themes-standard is Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>; Source for gnome-themes-standard is src:gnome-themes-standard.

Reported by: Andreas Beckmann <anbe@debian.org>

Date: Mon, 27 Feb 2012 13:09:03 UTC

Severity: serious

Tags: patch

Found in versions gnome-themes-standard/3.4.1-2, gnome-themes-standard/3.2.1-2, gnome-themes-standard/3.4.2-1

Fixed in versions gnome-themes-standard/3.4.2-2.1, gnome-themes-standard/3.6.2-1

Done: Michael Biebl <biebl@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Mon, 27 Feb 2012 13:09:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
New Bug report received and forwarded. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Mon, 27 Feb 2012 13:09:10 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: gnome-themes-standard: removal of gnome-themes-standard makes files disappear from gnome-accessibility-themes
Date: Mon, 27 Feb 2012 14:06:29 +0100
[Message part 1 (text/plain, inline)]
Package: gnome-themes-standard
Version: 
Severity: serious
User: debian-qa@lists.debian.org
Usertags: piuparts replaces-without-breaks

Hi,

during a test with piuparts and EDOS tools I noticed your package causes
removal of files that also belong to another package.
This is caused by using Replaces without corresponding Breaks.

The installation sequence to reproduce this problem is

  apt-get install gnome-accessibility-themes
  # (1)
  apt-get install gnome-themes-standard
  apt-get remove gnome-themes-standard
  # (2)

The list of installed files at points (1) and (2) should be identical,
but the following files have disappeared:

  /usr/share/icons/HighContrast/index.theme
  /usr/share/icons/HighContrastInverse/index.theme
  /usr/share/themes/HighContrast/gtk-2.0/gtkrc
  /usr/share/themes/HighContrast/index.theme
  /usr/share/themes/HighContrastInverse/gtk-2.0/gtkrc
  /usr/share/themes/HighContrastInverse/index.theme
  /usr/share/themes/LowContrast/gtk-2.0/gtkrc
  /usr/share/themes/LowContrast/index.theme

This is a serious bug violating policy 7.6, see
http://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces
and also see the footnote that describes this incorrect behavior
http://www.debian.org/doc/debian-policy/footnotes.html#f53

The gnome-themes-standard package has the following relationships with gnome-accessibility-themes:

  Conflicts: n/a
  Breaks:    n/a
  Replaces:  gnome-accessibility-themes (<< 3.0)

gnome-accessibility-themes is only available as 2.30.2-1 in squeeze, wheezy, and sid.

>From the attached log (scroll to the bottom...):

0m40.0s ERROR: FAIL: After purging files have disappeared:
  /usr/share/icons/HighContrast/index.theme      owned by: gnome-themes-standard
  /usr/share/icons/HighContrastInverse/index.theme       owned by: gnome-themes-standard
  /usr/share/themes/HighContrast/gtk-2.0/gtkrc   owned by: gnome-themes-standard
  /usr/share/themes/HighContrast/index.theme     owned by: gnome-themes-standard
  /usr/share/themes/HighContrastInverse/gtk-2.0/gtkrc    owned by: gnome-themes-standard
  /usr/share/themes/HighContrastInverse/index.theme      owned by: gnome-themes-standard
  /usr/share/themes/LowContrast/gtk-2.0/gtkrc    owned by: gnome-themes-standard
  /usr/share/themes/LowContrast/index.theme      owned by: gnome-themes-standard

0m40.0s ERROR: FAIL: After purging files have been modified:
  /var/lib/dpkg/info/gnome-accessibility-themes.list     not owned


cheers,

Andreas
[REPL_gnome-accessibility-themes_gnome-themes-standard.log.gz (application/x-gzip, attachment)]

Bug Marked as found in versions gnome-themes-standard/3.2.1-2. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Mon, 27 Feb 2012 14:27:14 GMT) Full text and rfc822 format available.

Added indication that 661471 affects gnome-accessibility-themes Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Mon, 27 Feb 2012 14:27:15 GMT) Full text and rfc822 format available.

Severity set to 'serious' from 'normal' Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Mon, 27 Feb 2012 14:27:20 GMT) Full text and rfc822 format available.

Marked as found in versions gnome-themes-standard/3.4.1-2. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Mon, 23 Apr 2012 01:45:10 GMT) Full text and rfc822 format available.

Marked as found in versions gnome-themes-standard/3.4.2-1. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Fri, 25 May 2012 10:03:14 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Mon, 02 Jul 2012 13:45:12 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Mon, 02 Jul 2012 13:45:13 GMT) Full text and rfc822 format available.

Message #20 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: 661471@bugs.debian.org
Cc: 661471-submitter@bugs.debian.org
Subject: Re: Bug #661471
Date: Mon, 2 Jul 2012 20:39:32 +0700
So, let's add Breaks: gnome-accessibility-themes (<< 3.0)?

Packages affected by this Breaks and the absence of
(gnome-accessibility-themes >= 3.0) would be:

- arista (Depends)
  -> Not a big deal, as g-a-t is just an alternative dependency,
     and can by satisfied by, say, gnome-icon-theme.
- education-desktop-gnome (Recommends)

I don't know how Debian GNOME team thinks about packaging
g-a-t 3.0.0, the latest upstream version, as upstream has stopped
shipping it since 3.2, and Debian now ships GNOME 3.4.

If it's to be dropped, let's file bugs against the two packages
above to remove the dependencies.

Regards,
-- 
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/




Message sent on to Andreas Beckmann <debian@abeckmann.de>:
Bug#661471. (Mon, 02 Jul 2012 13:45:17 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Tue, 03 Jul 2012 11:36:19 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 03 Jul 2012 11:36:23 GMT) Full text and rfc822 format available.

Message #28 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: 661471@bugs.debian.org
Cc: 661471-submitter@bugs.debian.org
Subject: Re: Bug #661471
Date: Tue, 3 Jul 2012 18:34:56 +0700
On Mon, Jul 2, 2012 at 8:39 PM, Theppitak Karoonboonyanan
<thep@debian.org> wrote:
> So, let's add Breaks: gnome-accessibility-themes (<< 3.0)?
>
> Packages affected by this Breaks and the absence of
> (gnome-accessibility-themes >= 3.0) would be:
>
> - arista (Depends)
>  -> Not a big deal, as g-a-t is just an alternative dependency,
>     and can by satisfied by, say, gnome-icon-theme.
> - education-desktop-gnome (Recommends)
>
> I don't know how Debian GNOME team thinks about packaging
> g-a-t 3.0.0, the latest upstream version, as upstream has stopped
> shipping it since 3.2, and Debian now ships GNOME 3.4.

No, it's impossible to package g-a-t 3.0.0 now, as it requires the
outdated gtk-engines-3.pc.

> If it's to be dropped, let's file bugs against the two packages
> above to remove the dependencies.

This may not be necessary, either. Those two packages may
assume old environment and may be installed without
gnome-themes-standard (e.g. on LXDE).

So, let's just add the Breaks.

Regards,
-- 
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/




Message sent on to Andreas Beckmann <debian@abeckmann.de>:
Bug#661471. (Tue, 03 Jul 2012 11:36:33 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Tue, 10 Jul 2012 07:57:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 10 Jul 2012 07:57:05 GMT) Full text and rfc822 format available.

Message #36 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: 661471@bugs.debian.org
Cc: control@bugs.debian.org
Subject: NMU?
Date: Tue, 10 Jul 2012 14:55:39 +0700
[Message part 1 (text/plain, inline)]
tags 661471 +patch
thanks

On Tue, Jul 3, 2012 at 6:34 PM, Theppitak Karoonboonyanan
<thep@debian.org> wrote:

> So, let's just add the Breaks.

I've prepared NMU with change as attached. Note that I also find
the package fails to build twice in a row, but that's dh-autoreconf's
problem. And I have already filed #681036 for that.

Is it OK for upload?

Regards,
-- 
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/
[661471-nmu.diff (application/octet-stream, attachment)]

Added tag(s) patch. Request was from Theppitak Karoonboonyanan <thep@debian.org> to control@bugs.debian.org. (Tue, 10 Jul 2012 07:57:07 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Tue, 10 Jul 2012 13:15:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 10 Jul 2012 13:15:04 GMT) Full text and rfc822 format available.

Message #43 received at 661471@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Theppitak Karoonboonyanan <thep@debian.org>, 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU?
Date: Tue, 10 Jul 2012 15:11:36 +0200
[Message part 1 (text/plain, inline)]
On 10.07.2012 09:55, Theppitak Karoonboonyanan wrote:
> tags 661471 +patch
> thanks
> 
> On Tue, Jul 3, 2012 at 6:34 PM, Theppitak Karoonboonyanan
> <thep@debian.org> wrote:
> 
>> So, let's just add the Breaks.
> 
[..]
> 
> Is it OK for upload?

I don't think this is the right fix, since it makes
gnome-themes-accesibilty uninstallable then. We do not have newer
versions of gnome-accessibility-themes in the archive. By using Breaks
you are now making e.g. arista uninstallable.

Please cancel your NMU.



-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Tue, 10 Jul 2012 13:27:15 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 10 Jul 2012 13:27:16 GMT) Full text and rfc822 format available.

Message #48 received at 661471@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Theppitak Karoonboonyanan <thep@debian.org>, 661471@bugs.debian.org, Martin Pitt <mpitt@debian.org>
Subject: Re: Bug#661471: NMU?
Date: Tue, 10 Jul 2012 15:23:25 +0200
[Message part 1 (text/plain, inline)]
On 10.07.2012 15:11, Michael Biebl wrote:
> On 10.07.2012 09:55, Theppitak Karoonboonyanan wrote:
>> tags 661471 +patch
>> thanks
>>
>> On Tue, Jul 3, 2012 at 6:34 PM, Theppitak Karoonboonyanan
>> <thep@debian.org> wrote:
>>
>>> So, let's just add the Breaks.
>>
> [..]
>>
>> Is it OK for upload?
> 
> I don't think this is the right fix, since it makes
> gnome-themes-accesibilty uninstallable then. We do not have newer
> versions of gnome-accessibility-themes in the archive. By using Breaks
> you are now making e.g. arista uninstallable.

Seems I missed the alternative dependency in arista (which you wrote
about earlier)

> Please cancel your NMU.

Still, by using the Break we pretty much make gnome-accesibilty-themes
useless, as gnome-themes-standard will be installed on most Debian GNOME
desktops.
So we might as well remove gnome-accesibilty-themes then, imho.

I think the alternative Martin proposed is to build
gnome-accessibility-themes from the gnome-themes-standard source package.


-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Tue, 10 Jul 2012 14:36:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 10 Jul 2012 14:36:07 GMT) Full text and rfc822 format available.

Message #53 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: Michael Biebl <biebl@debian.org>
Cc: 661471@bugs.debian.org, Martin Pitt <mpitt@debian.org>
Subject: Re: Bug#661471: NMU?
Date: Tue, 10 Jul 2012 21:34:26 +0700
On Tue, Jul 10, 2012 at 8:23 PM, Michael Biebl <biebl@debian.org> wrote:
> On 10.07.2012 15:11, Michael Biebl wrote:
>
>> Please cancel your NMU.
>
> Still, by using the Break we pretty much make gnome-accesibilty-themes
> useless, as gnome-themes-standard will be installed on most Debian GNOME
> desktops.
> So we might as well remove gnome-accesibilty-themes then, imho.

I think so, as upstream has stopped shipping it since after 3.0.

> I think the alternative Martin proposed is to build
> gnome-accessibility-themes from the gnome-themes-standard source package.

I have also tried it already, but it required the outdated gtk-engines-3.pc.
See message #28 in the bug log.

Regards,
-- 
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/




Removed tag(s) patch. Request was from Bart Martens <bartm@debian.org> to control@bugs.debian.org. (Mon, 23 Jul 2012 11:09:09 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Fri, 27 Jul 2012 19:15:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jeremy Bicha <jbicha@ubuntu.com>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Fri, 27 Jul 2012 19:15:05 GMT) Full text and rfc822 format available.

Message #60 received at 661471@bugs.debian.org (full text, mbox):

From: Jeremy Bicha <jbicha@ubuntu.com>
To: 661471@bugs.debian.org
Subject: Re: bug 661471 gnome-accessibility-themes
Date: Fri, 27 Jul 2012 15:11:30 -0400
On Tue Jul 10, 2012 at 14:34:34 theppitak@gmail.com wrote:
> On Tue, Jul 10, 2012 at 8:23 PM, Michael Biebl <biebl@debian.org> wrote:
> > I think the alternative Martin proposed is to build
> > gnome-accessibility-themes from the gnome-themes-standard source package.
>
> I have also tried it already, but it required the outdated gtk-engines-3.pc.
> See message #28 in the bug log.

I believe you misunderstand. In Ubuntu almost a year ago, I split
gnome-themes-standard into two binary packages: gnome-themes-standard
and gnome-accessibility-themes. We then dropped the
<abandoned-upstream> gnome-themes source package that used to provide
gnome-accessibility-themes. It works pretty well for Ubuntu as we want
to ship the HighContrast themes but not Adwaita due to space
limitations.

Jeremy



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Mon, 13 Aug 2012 08:03:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Mon, 13 Aug 2012 08:03:03 GMT) Full text and rfc822 format available.

Message #65 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: 661471@bugs.debian.org
Subject: Re: bug 661471 gnome-accessibility-themes
Date: Mon, 13 Aug 2012 15:01:39 +0700
On Fri, 27 Jul 2012 15:11:30 Jeremy Bicha <jbicha@ubuntu.com> wrote:
> On Tue Jul 10, 2012 at 14:34:34 theppitak@gmail.com wrote:
> > On Tue, Jul 10, 2012 at 8:23 PM, Michael Biebl <biebl@debian.org> wrote:
> > > I think the alternative Martin proposed is to build
> > > gnome-accessibility-themes from the gnome-themes-standard source package.
> >
> > I have also tried it already, but it required the outdated gtk-engines-3.pc.
> > See message #28 in the bug log.
>
> I believe you misunderstand. In Ubuntu almost a year ago, I split
> gnome-themes-standard into two binary packages: gnome-themes-standard
> and gnome-accessibility-themes. We then dropped the
> <abandoned-upstream> gnome-themes source package that used to provide
> gnome-accessibility-themes. It works pretty well for Ubuntu as we want
> to ship the HighContrast themes but not Adwaita due to space

You're right. I missed the "from the gnome-themes-standard source package"
part in Michael's message. Sorry.

So, I agree with splitting the gnome-accessibility-themes binary.

Regards,
-- 
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Wed, 29 Aug 2012 15:39:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 29 Aug 2012 15:39:05 GMT) Full text and rfc822 format available.

Message #70 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: 661471@bugs.debian.org
Subject: Re: Bug#661471: bug 661471 gnome-accessibility-themes
Date: Wed, 29 Aug 2012 22:35:46 +0700
[Message part 1 (text/plain, inline)]
On Mon, Aug 13, 2012 at 3:01 PM, Theppitak Karoonboonyanan
<thep@debian.org> wrote:
> So, I agree with splitting the gnome-accessibility-themes binary.

Any progress? If not, I'm proposing another NMU, which:
- Splits a11y themes into gnome-accessibility-themes binary
- Splits the shared translation files into gnome-themes-standard-common
- Makes both theme packages depend on -common
- Declares gnome-accessibility-themes and gnome-themes-standard-common
  as Replaces: the old gnome-themes-standard
- Drops Replaces: from gnome-themes-standard

Debdiff is attached.

However, some warnings are found during the upgrade test:

---8<---
Preparing to replace gnome-themes-standard 3.4.2-1 (using
gnome-themes-standard_3.4.2-1.1_amd64.deb) ...
Unpacking replacement gnome-themes-standard ...
dpkg: warning: unable to delete old directory
'/usr/share/icons/HighContrast': Directory not empty
dpkg: warning: unable to delete old directory
'/usr/share/icons/LowContrast': Directory not empty
dpkg: warning: unable to delete old directory
'/usr/share/icons/HighContrastInverse': Directory not empty
---8<---

The remaining files in these directories are "icon-theme.cache".
Any suggestion on how to clear them properly?

Regards,
-- 
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/
[gnome-themes-standard_3.4.2-1.1.debdiff (application/octet-stream, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Wed, 31 Oct 2012 10:39:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 31 Oct 2012 10:39:03 GMT) Full text and rfc822 format available.

Message #75 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: 661471@bugs.debian.org
Subject: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Wed, 31 Oct 2012 17:34:30 +0700
On Wed, Aug 29, 2012 at 10:35 PM, Theppitak Karoonboonyanan
<thep@debian.org> wrote:
> On Mon, Aug 13, 2012 at 3:01 PM, Theppitak Karoonboonyanan
> <thep@debian.org> wrote:
>> So, I agree with splitting the gnome-accessibility-themes binary.
>
> Any progress? If not, I'm proposing another NMU, which:
> - Splits a11y themes into gnome-accessibility-themes binary
> - Splits the shared translation files into gnome-themes-standard-common
> - Makes both theme packages depend on -common
> - Declares gnome-accessibility-themes and gnome-themes-standard-common
>   as Replaces: the old gnome-themes-standard
> - Drops Replaces: from gnome-themes-standard
>
> Debdiff is attached.
>
> However, some warnings are found during the upgrade test:
>
> ---8<---
> Preparing to replace gnome-themes-standard 3.4.2-1 (using
> gnome-themes-standard_3.4.2-1.1_amd64.deb) ...
> Unpacking replacement gnome-themes-standard ...
> dpkg: warning: unable to delete old directory
> '/usr/share/icons/HighContrast': Directory not empty
> dpkg: warning: unable to delete old directory
> '/usr/share/icons/LowContrast': Directory not empty
> dpkg: warning: unable to delete old directory
> '/usr/share/icons/HighContrastInverse': Directory not empty
> ---8<---
>
> The remaining files in these directories are "icon-theme.cache".
> Any suggestion on how to clear them properly?

It seems this does not happen with clean installs. So, it may not be an issue.
Could I do the NMU, then?

Regards,
-- 
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/



Added tag(s) patch. Request was from Theppitak Karoonboonyanan <thep@linux.thai.net> to control@bugs.debian.org. (Wed, 31 Oct 2012 15:00:05 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Tue, 06 Nov 2012 11:09:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 06 Nov 2012 11:09:03 GMT) Full text and rfc822 format available.

Message #82 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Tue, 6 Nov 2012 18:05:45 +0700
On Wed, Oct 31, 2012 at 5:34 PM, Theppitak Karoonboonyanan
<thep@debian.org> wrote:
> On Wed, Aug 29, 2012 at 10:35 PM, Theppitak Karoonboonyanan
> <thep@debian.org> wrote:
>> On Mon, Aug 13, 2012 at 3:01 PM, Theppitak Karoonboonyanan
>> <thep@debian.org> wrote:
>>> So, I agree with splitting the gnome-accessibility-themes binary.
>>
>> Any progress? If not, I'm proposing another NMU, which:
>> - Splits a11y themes into gnome-accessibility-themes binary
>> - Splits the shared translation files into gnome-themes-standard-common
>> - Makes both theme packages depend on -common
>> - Declares gnome-accessibility-themes and gnome-themes-standard-common
>>   as Replaces: the old gnome-themes-standard
>> - Drops Replaces: from gnome-themes-standard
>>
>> Debdiff is attached.
>>
>> However, some warnings are found during the upgrade test:
>>
>> ---8<---
>> Preparing to replace gnome-themes-standard 3.4.2-1 (using
>> gnome-themes-standard_3.4.2-1.1_amd64.deb) ...
>> Unpacking replacement gnome-themes-standard ...
>> dpkg: warning: unable to delete old directory
>> '/usr/share/icons/HighContrast': Directory not empty
>> dpkg: warning: unable to delete old directory
>> '/usr/share/icons/LowContrast': Directory not empty
>> dpkg: warning: unable to delete old directory
>> '/usr/share/icons/HighContrastInverse': Directory not empty
>> ---8<---
>>
>> The remaining files in these directories are "icon-theme.cache".
>> Any suggestion on how to clear them properly?
>
> It seems this does not happen with clean installs. So, it may not be an issue.
> Could I do the NMU, then?

Uploaded to DELAYED/2.

Without response for a long time, I assume it's qualified NMU, despite the
intrusive change.

Regards,
--
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Tue, 06 Nov 2012 13:03:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 06 Nov 2012 13:03:06 GMT) Full text and rfc822 format available.

Message #87 received at 661471@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Theppitak Karoonboonyanan <thep@debian.org>, 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Tue, 06 Nov 2012 13:53:57 +0100
[Message part 1 (text/plain, inline)]
On 06.11.2012 12:05, Theppitak Karoonboonyanan wrote:
> On Wed, Oct 31, 2012 at 5:34 PM, Theppitak Karoonboonyanan
> <thep@debian.org> wrote:
>> On Wed, Aug 29, 2012 at 10:35 PM, Theppitak Karoonboonyanan
>> <thep@debian.org> wrote:
>>> On Mon, Aug 13, 2012 at 3:01 PM, Theppitak Karoonboonyanan
>>> <thep@debian.org> wrote:
>>>> So, I agree with splitting the gnome-accessibility-themes binary.
>>>
>>> Any progress? If not, I'm proposing another NMU, which:
>>> - Splits a11y themes into gnome-accessibility-themes binary
>>> - Splits the shared translation files into gnome-themes-standard-common
>>> - Makes both theme packages depend on -common
>>> - Declares gnome-accessibility-themes and gnome-themes-standard-common
>>>   as Replaces: the old gnome-themes-standard
>>> - Drops Replaces: from gnome-themes-standard
>>>
>>> Debdiff is attached.
>>>
>>> However, some warnings are found during the upgrade test:
>>>
>>> ---8<---
>>> Preparing to replace gnome-themes-standard 3.4.2-1 (using
>>> gnome-themes-standard_3.4.2-1.1_amd64.deb) ...
>>> Unpacking replacement gnome-themes-standard ...
>>> dpkg: warning: unable to delete old directory
>>> '/usr/share/icons/HighContrast': Directory not empty
>>> dpkg: warning: unable to delete old directory
>>> '/usr/share/icons/LowContrast': Directory not empty
>>> dpkg: warning: unable to delete old directory
>>> '/usr/share/icons/HighContrastInverse': Directory not empty
>>> ---8<---
>>>
>>> The remaining files in these directories are "icon-theme.cache".
>>> Any suggestion on how to clear them properly?
>>
>> It seems this does not happen with clean installs. So, it may not be an issue.
>> Could I do the NMU, then?
> 
> Uploaded to DELAYED/2.
> 
> Without response for a long time, I assume it's qualified NMU, despite the
> intrusive change.

The gnome-themes-standard-common binary package is superfluous.
Afaics the gettext translations are only required to translate the
index.theme and background.xml files where the translations are directly
embedded, so you don't actually need to install the .mo files.

I would thus suggest to simply drop gnome-themes-standard-common.

Please also make gnome-theme-standard depend on gnome-accessibility-themes.

Also, gnome-accessibility-themes needs a Breaks along with the Replaces.




-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Tue, 06 Nov 2012 13:12:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 06 Nov 2012 13:12:06 GMT) Full text and rfc822 format available.

Message #92 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: Michael Biebl <biebl@debian.org>
Cc: 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Tue, 6 Nov 2012 20:09:09 +0700
On Tue, Nov 6, 2012 at 7:53 PM, Michael Biebl <biebl@debian.org> wrote:

> The gnome-themes-standard-common binary package is superfluous.
> Afaics the gettext translations are only required to translate the
> index.theme and background.xml files where the translations are directly
> embedded, so you don't actually need to install the .mo files.
>
> I would thus suggest to simply drop gnome-themes-standard-common.

I had also found it out before seeing your message. So, I've cancelled the NMU.

Anyway, I also stumbled upon this lintian info:

I: gnome-themes-standard: arch-dep-package-has-big-usr-share 3549kB 99%

That made me plan to move the non-engine parts into -common instead.
What do you think?

> Please also make gnome-theme-standard depend on gnome-accessibility-themes.

OK. I didn't think normal users want those a11y themes, so I hadn't added the
dependency. Will do it now as you suggest, anyway.

> Also, gnome-accessibility-themes needs a Breaks along with the Replaces.

OK.

Regards,
--
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Tue, 06 Nov 2012 14:12:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 06 Nov 2012 14:12:03 GMT) Full text and rfc822 format available.

Message #97 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: Michael Biebl <biebl@debian.org>
Cc: 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Tue, 6 Nov 2012 21:09:08 +0700
On Tue, Nov 6, 2012 at 8:09 PM, Theppitak Karoonboonyanan
<thep@debian.org> wrote:
> On Tue, Nov 6, 2012 at 7:53 PM, Michael Biebl <biebl@debian.org> wrote:
>
>> The gnome-themes-standard-common binary package is superfluous.
>> Afaics the gettext translations are only required to translate the
>> index.theme and background.xml files where the translations are directly
>> embedded, so you don't actually need to install the .mo files.
>>
>> I would thus suggest to simply drop gnome-themes-standard-common.
>
> I had also found it out before seeing your message. So, I've cancelled the NMU.
>
> Anyway, I also stumbled upon this lintian info:
>
> I: gnome-themes-standard: arch-dep-package-has-big-usr-share 3549kB 99%
>
> That made me plan to move the non-engine parts into -common instead.
> What do you think?
>
>> Please also make gnome-theme-standard depend on gnome-accessibility-themes.
>
> OK. I didn't think normal users want those a11y themes, so I hadn't added the
> dependency. Will do it now as you suggest, anyway.
>
>> Also, gnome-accessibility-themes needs a Breaks along with the Replaces.
>
> OK.

Re-uploaded to DELAYED/2.

Regards,
--
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Tue, 06 Nov 2012 14:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 06 Nov 2012 14:21:03 GMT) Full text and rfc822 format available.

Message #102 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: Michael Biebl <biebl@debian.org>
Cc: 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Tue, 6 Nov 2012 21:20:20 +0700
[Message part 1 (text/plain, inline)]
On Tue, Nov 6, 2012 at 9:09 PM, Theppitak Karoonboonyanan
<thep@debian.org> wrote:

> Re-uploaded to DELAYED/2.

The debdiff.

Regards,
--
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/
[gnome-themes-standard_3.4.2-2.1.debdiff (application/octet-stream, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Wed, 07 Nov 2012 12:51:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 07 Nov 2012 12:51:05 GMT) Full text and rfc822 format available.

Message #107 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: Michael Biebl <biebl@debian.org>
Cc: 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Wed, 7 Nov 2012 19:46:46 +0700
[Message part 1 (text/plain, inline)]
On Tue, Nov 6, 2012 at 8:09 PM, Theppitak Karoonboonyanan
<thep@debian.org> wrote:
> On Tue, Nov 6, 2012 at 7:53 PM, Michael Biebl <biebl@debian.org> wrote:
>
>> The gnome-themes-standard-common binary package is superfluous.
>> Afaics the gettext translations are only required to translate the
>> index.theme and background.xml files where the translations are directly
>> embedded, so you don't actually need to install the .mo files.
>>
>> I would thus suggest to simply drop gnome-themes-standard-common.
>
> I had also found it out before seeing your message. So, I've cancelled the NMU.
>
> Anyway, I also stumbled upon this lintian info:
>
> I: gnome-themes-standard: arch-dep-package-has-big-usr-share 3549kB 99%
>
> That made me plan to move the non-engine parts into -common instead.
> What do you think?

Update: I've renamed -common to -data. Latest debdiff is attached.

Re-uploaded to DELAYED/1.

Regards,
--
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/
[gnome-themes-standard_3.4.2-2.1.debdiff (application/octet-stream, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Wed, 07 Nov 2012 13:27:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to 661471@bugs.debian.org:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 07 Nov 2012 13:27:08 GMT) Full text and rfc822 format available.

Message #112 received at 661471@bugs.debian.org (full text, mbox):

From: Josselin Mouette <joss@debian.org>
To: Theppitak Karoonboonyanan <thep@debian.org>, 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Wed, 07 Nov 2012 14:24:04 +0100
Le mercredi 07 novembre 2012 à 19:46 +0700, Theppitak Karoonboonyanan a
écrit : 
> Update: I've renamed -common to -data. Latest debdiff is attached.

--- gnome-themes-standard-3.4.2/debian/gnome-themes-standard.install    1970-01-01 07:00:00.000000000 +0700
+++ gnome-themes-standard-3.4.2/debian/gnome-themes-standard.install    2012-11-06 19:56:54.000000000 +0700
@@ -0,0 +1 @@
+usr/lib/gtk-3.0/3.0.0/theming-engines/*.so

Isn’t it also time to move the engines to the multiarch path? Currently
Adwaita is not usable by applications of a non-native architecture.

-- 
 .''`.      Josselin Mouette
: :' :
`. `'
  `-




Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Wed, 07 Nov 2012 14:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 07 Nov 2012 14:15:03 GMT) Full text and rfc822 format available.

Message #117 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Wed, 7 Nov 2012 21:10:39 +0700
[Message part 1 (text/plain, inline)]
On Wed, Nov 7, 2012 at 8:24 PM, Josselin Mouette <joss@debian.org> wrote:

> Isn’t it also time to move the engines to the multiarch path? Currently
> Adwaita is not usable by applications of a non-native architecture.

Done. Please review the updated debdiff.

Regards,
--
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/
[gnome-themes-standard_3.4.2-2.1-multiarch.debdiff (application/octet-stream, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Wed, 07 Nov 2012 15:33:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to 661471@bugs.debian.org:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 07 Nov 2012 15:33:02 GMT) Full text and rfc822 format available.

Message #122 received at 661471@bugs.debian.org (full text, mbox):

From: Josselin Mouette <joss@debian.org>
To: Theppitak Karoonboonyanan <thep@debian.org>, 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Wed, 07 Nov 2012 16:31:04 +0100
Le mercredi 07 novembre 2012 à 21:10 +0700, Theppitak Karoonboonyanan a
écrit : 
> On Wed, Nov 7, 2012 at 8:24 PM, Josselin Mouette <joss@debian.org> wrote:
> 
> > Isn’t it also time to move the engines to the multiarch path? Currently
> > Adwaita is not usable by applications of a non-native architecture.
> 
> Done. Please review the updated debdiff.

Awesome, thanks.

The debdiff looks fine to me. Thanks for the thought of
removing /usr/share/locale in the process, it was just dead weight.

Cheers,
-- 
 .''`.      Josselin Mouette
: :' :
`. `'
  `-




Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Wed, 07 Nov 2012 15:48:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 07 Nov 2012 15:48:03 GMT) Full text and rfc822 format available.

Message #127 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Wed, 7 Nov 2012 22:46:01 +0700
[Message part 1 (text/plain, inline)]
On Wed, Nov 7, 2012 at 10:31 PM, Josselin Mouette <joss@debian.org> wrote:
> Le mercredi 07 novembre 2012 à 21:10 +0700, Theppitak Karoonboonyanan a
> écrit :
>> On Wed, Nov 7, 2012 at 8:24 PM, Josselin Mouette <joss@debian.org> wrote:
>>
>> > Isn’t it also time to move the engines to the multiarch path? Currently
>> > Adwaita is not usable by applications of a non-native architecture.
>>
>> Done. Please review the updated debdiff.
>
> Awesome, thanks.

More update: add M-A: foreign to gnome-accessibility-themes
(caught by lintian).

It's still in DELAYED/1, though, just in case more issues are found.

> The debdiff looks fine to me. Thanks for the thought of
> removing /usr/share/locale in the process, it was just dead weight.

Hope there wouldn't be message translation in the engine in the
future.

Regards,
--
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/
[gnome-themes-standard_3.4.2-2.1-multiarch.debdiff (application/octet-stream, attachment)]

Added tag(s) pending. Request was from Anibal Monsalve Salazar <anibal@debian.org> to control@bugs.debian.org. (Thu, 08 Nov 2012 19:06:06 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Mon, 12 Nov 2012 21:33:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Gilbert <michael.s.gilbert@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Mon, 12 Nov 2012 21:33:03 GMT) Full text and rfc822 format available.

Message #134 received at 661471@bugs.debian.org (full text, mbox):

From: Michael Gilbert <michael.s.gilbert@gmail.com>
To: 661471@bugs.debian.org, thep@debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Mon, 12 Nov 2012 16:29:34 -0500
> It's still in DELAYED/1, though, just in case more issues are found.

Not sure if you saw this, but this seemed to not reach unstable.

Best wishes,
Mike



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Tue, 13 Nov 2012 02:36:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 13 Nov 2012 02:36:03 GMT) Full text and rfc822 format available.

Message #139 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: Michael Gilbert <michael.s.gilbert@gmail.com>
Cc: 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Tue, 13 Nov 2012 09:33:19 +0700
On Tue, Nov 13, 2012 at 4:29 AM, Michael Gilbert
<michael.s.gilbert@gmail.com> wrote:
>> It's still in DELAYED/1, though, just in case more issues are found.
>
> Not sure if you saw this, but this seemed to not reach unstable.

I forgot to update to the bug that it's currently in NEW, due to the split.

Regards,
--
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Tue, 13 Nov 2012 02:39:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Gilbert <mgilbert@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 13 Nov 2012 02:39:06 GMT) Full text and rfc822 format available.

Message #144 received at 661471@bugs.debian.org (full text, mbox):

From: Michael Gilbert <mgilbert@debian.org>
To: Theppitak Karoonboonyanan <thep@debian.org>
Cc: 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Mon, 12 Nov 2012 21:35:31 -0500
On Mon, Nov 12, 2012 at 9:33 PM, Theppitak Karoonboonyanan wrote:
> On Tue, Nov 13, 2012 at 4:29 AM, Michael Gilbert
>>> It's still in DELAYED/1, though, just in case more issues are found.
>>
>> Not sure if you saw this, but this seemed to not reach unstable.
>
> I forgot to update to the bug that it's currently in NEW, due to the split.

Ftp masters don't process the NEW queue often during the freeze, so
make sure to ping them and say that it fixes rc issues.

Best wishes,
Mike



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Tue, 13 Nov 2012 02:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Tue, 13 Nov 2012 02:51:03 GMT) Full text and rfc822 format available.

Message #149 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: Michael Gilbert <mgilbert@debian.org>
Cc: 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Tue, 13 Nov 2012 09:48:45 +0700
On Tue, Nov 13, 2012 at 9:35 AM, Michael Gilbert <mgilbert@debian.org> wrote:
> On Mon, Nov 12, 2012 at 9:33 PM, Theppitak Karoonboonyanan wrote:
>> On Tue, Nov 13, 2012 at 4:29 AM, Michael Gilbert
>>>> It's still in DELAYED/1, though, just in case more issues are found.
>>>
>>> Not sure if you saw this, but this seemed to not reach unstable.
>>
>> I forgot to update to the bug that it's currently in NEW, due to the split.
>
> Ftp masters don't process the NEW queue often during the freeze, so
> make sure to ping them and say that it fixes rc issues.

It's being reviewed. And it's likely that some of the changes may be rejected.

Regards,
--
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/



Information forwarded to debian-bugs-dist@lists.debian.org, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>:
Bug#661471; Package gnome-themes-standard. (Wed, 14 Nov 2012 02:33:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Theppitak Karoonboonyanan <thep@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>. (Wed, 14 Nov 2012 02:33:09 GMT) Full text and rfc822 format available.

Message #154 received at 661471@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: Michael Gilbert <mgilbert@debian.org>
Cc: 661471@bugs.debian.org
Subject: Re: Bug#661471: NMU v2 (was: Re: Bug#661471: bug 661471 gnome-accessibility-themes)
Date: Wed, 14 Nov 2012 09:28:21 +0700
On Tue, Nov 13, 2012 at 9:48 AM, Theppitak Karoonboonyanan
<thep@debian.org> wrote:

> It's being reviewed. And it's likely that some of the changes may be rejected.

Re-uploaded with multiarch change dropped. Now in NEW again.

Regards,
--
Theppitak Karoonboonyanan
http://linux.thai.net/~thep/



Reply sent to Theppitak Karoonboonyanan <thep@debian.org>:
You have taken responsibility. (Wed, 14 Nov 2012 22:03:10 GMT) Full text and rfc822 format available.

Notification sent to Andreas Beckmann <debian@abeckmann.de>:
Bug acknowledged by developer. (Wed, 14 Nov 2012 22:03:10 GMT) Full text and rfc822 format available.

Message #159 received at 661471-close@bugs.debian.org (full text, mbox):

From: Theppitak Karoonboonyanan <thep@debian.org>
To: 661471-close@bugs.debian.org
Subject: Bug#661471: fixed in gnome-themes-standard 3.4.2-2.1
Date: Wed, 14 Nov 2012 22:00:08 +0000
Source: gnome-themes-standard
Source-Version: 3.4.2-2.1

We believe that the bug you reported is fixed in the latest version of
gnome-themes-standard, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 661471@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Theppitak Karoonboonyanan <thep@debian.org> (supplier of updated gnome-themes-standard package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 13 Nov 2012 12:03:08 +0700
Source: gnome-themes-standard
Binary: gnome-themes-standard gnome-themes-standard-data gnome-accessibility-themes
Architecture: source all amd64
Version: 3.4.2-2.1
Distribution: unstable
Urgency: low
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Changed-By: Theppitak Karoonboonyanan <thep@debian.org>
Description: 
 gnome-accessibility-themes - Accessibility themes for the GNOME desktop
 gnome-themes-standard - Standard GNOME themes
 gnome-themes-standard-data - Data files for GNOME standard themes
Closes: 661471
Changes: 
 gnome-themes-standard (3.4.2-2.1) unstable; urgency=low
 .
   * Non-maintainer upload.
   * Split out gnome-accessibility-themes to fullfill the old dependencies.
     (Closes: #661471)
   * Split out gnome-themes-standard-data for arch-indep files. [lintian]
   * Capitalize "GNOME" in package description. [lintian]
Checksums-Sha1: 
 65db52ea1858da0300e4fed48778ad6dff0c9d73 2392 gnome-themes-standard_3.4.2-2.1.dsc
 9711ed69bd2148ec82d7cb040e981ff324e5db97 4599 gnome-themes-standard_3.4.2-2.1.debian.tar.gz
 7a06d4b3f8e76320117709aee4e2b2c496ecfdf5 1360794 gnome-themes-standard-data_3.4.2-2.1_all.deb
 9bae7eb434e0afc9b9c20fa4a32b6e50d0fdf0b6 1703804 gnome-accessibility-themes_3.4.2-2.1_all.deb
 92314ca771b6b1f9e504183accc007c2d1905176 134894 gnome-themes-standard_3.4.2-2.1_amd64.deb
Checksums-Sha256: 
 b65af9232128ba1da727c15c844eb345c992e5d9591152ce304df3a07c16e14e 2392 gnome-themes-standard_3.4.2-2.1.dsc
 c5a4bb3d675ad1b338efeb4dfad122351a64e4031689cb0b075380b3055e0627 4599 gnome-themes-standard_3.4.2-2.1.debian.tar.gz
 b724a71c5f1edcf7411128608542dcbe118efad73ece0e16dec42a7866398b7f 1360794 gnome-themes-standard-data_3.4.2-2.1_all.deb
 8f6718ad89ff5e82901846b6989512ed2a19195708860f2699da71f8ab9fb6f1 1703804 gnome-accessibility-themes_3.4.2-2.1_all.deb
 bc6ec40f75c13a660fe12a05bdcc226d0366647d3b2e9383df4ae754c619f879 134894 gnome-themes-standard_3.4.2-2.1_amd64.deb
Files: 
 e40f817c71cf9c416c11aef474163306 2392 gnome optional gnome-themes-standard_3.4.2-2.1.dsc
 f6533f8838d007002ca8021576053115 4599 gnome optional gnome-themes-standard_3.4.2-2.1.debian.tar.gz
 6523d7b771bbc865b7f8c31f0bed30a6 1360794 gnome optional gnome-themes-standard-data_3.4.2-2.1_all.deb
 97a27ef0de8d49a574cb905d1d3d15f2 1703804 gnome optional gnome-accessibility-themes_3.4.2-2.1_all.deb
 d8c922a82a83b5e19f223ff3446415ea 134894 gnome optional gnome-themes-standard_3.4.2-2.1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBAgAGBQJQoeE3AAoJEKLrrtG2+QJBI+UP/R+rYppWrPYTtAZX16NhZQJ1
vOc0eqry3Q8Juab65nMR5B1QZuYy8W1BtrUmFDQk/bGntiHi+v9214ex9SF7pb1p
lZAaMB+ZuBya59WDluoxHsDTbWJ8j3q6OZPItAUtAxB3+gOi8dXEHYyUmYLe3UZ+
XORGbKi5fN6US235+xdXixXVeGM61ZGUQHiA2DDYLXoXEgvbVG2uweGWTwyhCMbJ
mp6c9zbDgOCP36ss1oJMX8DhORh+gwp+nsK1oVGCHlVbOEQ0AWS8jJ948Zl5yXPs
bjNJwBlF87OB8NNdnIQt44trRvemq/YkllE6fN1fH7uAsF4boUFXIwMWxdT7b8/L
ggeO4mPNbIUe53U9yFeOaCr2qumrhZ6OlGJTVt8K+4RL80AWxErHR+9LvjRtcTrS
ZRugaScN/KD7ocksZ1NdpCDi8ERa2s/l0hgVFmgWh/6xZ/kvQGMY6+eXNDxkkgxs
7UcKlFyAF33QLiakq7iOeYwc7XCvsDxkRHHA2XVXe+NEtZp2oLZlljlIitJYF/Jb
NEVq4hDJJyzhOBVbFSXqtXeegNr4WceIrcO32mj4KxfboMrUHSYb7rRQCu6+C4Id
fLnQrWPY73WaJvtPhqo/iay8g3nU9Kqg+/aK5JQBNrRiZYK1R+75I/qZEhS3Cr/s
mvIlnCmZ6ddqtggdA/rZ
=wJgO
-----END PGP SIGNATURE-----




Reply sent to Michael Biebl <biebl@debian.org>:
You have taken responsibility. (Thu, 10 Jan 2013 17:51:03 GMT) Full text and rfc822 format available.

Notification sent to Andreas Beckmann <debian@abeckmann.de>:
Bug acknowledged by developer. (Thu, 10 Jan 2013 17:51:03 GMT) Full text and rfc822 format available.

Message #164 received at 661471-close@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: 661471-close@bugs.debian.org
Subject: Bug#661471: fixed in gnome-themes-standard 3.6.2-1
Date: Thu, 10 Jan 2013 17:47:36 +0000
Source: gnome-themes-standard
Source-Version: 3.6.2-1

We believe that the bug you reported is fixed in the latest version of
gnome-themes-standard, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 661471@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Michael Biebl <biebl@debian.org> (supplier of updated gnome-themes-standard package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Thu, 10 Jan 2013 18:17:33 +0100
Source: gnome-themes-standard
Binary: gnome-themes-standard gnome-themes-standard-data gnome-accessibility-themes
Architecture: source all amd64
Version: 3.6.2-1
Distribution: experimental
Urgency: low
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Changed-By: Michael Biebl <biebl@debian.org>
Description: 
 gnome-accessibility-themes - Accessibility themes for the GNOME desktop
 gnome-themes-standard - Standard GNOME themes
 gnome-themes-standard-data - Data files for GNOME standard themes
Closes: 661471 691691 694055
Changes: 
 gnome-themes-standard (3.6.2-1) experimental; urgency=low
 .
   [ Sjoerd Simons ]
   * Recommend gtk2-engines-pixbuf instead of gtk2-engines. Closes: #691691
 .
   [ Michael Biebl ]
   * New upstream release.
 .
   [ Theppitak Karoonboonyanan ]
   * Split out gnome-accessibility-themes to fullfill the old dependencies.
     (Closes: #661471)
   * Capitalize "GNOME" in package description. [lintian]
   * Split out gnome-themes-standard-data for arch-indep files. [lintian]
   * Add multi-arch support.
     - Bump B-Deps debhelper (>= 8.1.3), cdbs (>= 0.4.93~).
     - d/rules: Add DEB_CONFIGURE_EXTRA_FLAGS.
     - Declare M-A: same for gnome-themes-standard; M-A: foreign for
       gnome-themes-standard-data & gnome-accessibility-themes.
 .
   [ Josselin Mouette ]
   * The above closes: #694055.
   * New upstream release.
   * Only recommend gnome-accessibility-themes. The metapackages will be
     in charge of the Depends.
   * Build-depend on libgtk2.0-dev.
   * Install GTK2 engine.
   * Stop removing .la files, we don’t list them in *.install anyway.
Checksums-Sha1: 
 765cf103aa92ae6355ef3a4d1a7dea068b9ba42f 2441 gnome-themes-standard_3.6.2-1.dsc
 c7f40cc078c67169caee4883c76c5d192061fed2 3609716 gnome-themes-standard_3.6.2.orig.tar.xz
 0c1badc0cc2f189580a1a55f43962474a913fe85 4877 gnome-themes-standard_3.6.2-1.debian.tar.gz
 eb4d8c424a48c081aa0580410708cc71729c6e77 1578066 gnome-themes-standard-data_3.6.2-1_all.deb
 7a172a63e9b216130e22c8d0747e27c91d62625a 2124544 gnome-accessibility-themes_3.6.2-1_all.deb
 24534a99c39d983fb72467a15e7aec1aa1405c2a 219012 gnome-themes-standard_3.6.2-1_amd64.deb
Checksums-Sha256: 
 81f8dea65a05e8b169fef27d0b5908b8824ee7c14466d1eeb8ceacbeb4672df5 2441 gnome-themes-standard_3.6.2-1.dsc
 c41503d0e18e17188c4fd1be5f6a7e90b08564e2a19d9a318b145a56d4455352 3609716 gnome-themes-standard_3.6.2.orig.tar.xz
 8cabbeca3c367ad4416150dcac4728324d0c5db89782790dc6fa46eabd25b6e9 4877 gnome-themes-standard_3.6.2-1.debian.tar.gz
 d66d26c2b72090432d7b89ca3db41bbe2b4e0f583c27e44f7512106815cf0ff9 1578066 gnome-themes-standard-data_3.6.2-1_all.deb
 060969f14a817e68849096701ecb5eddb62841afbccf5d87a4b7d6c2bfabec34 2124544 gnome-accessibility-themes_3.6.2-1_all.deb
 98f0ddba6876e03fd44c2f7f99283be11f3aaf613acaf1f721e84d3f9eb7f269 219012 gnome-themes-standard_3.6.2-1_amd64.deb
Files: 
 2bcf982764eb6082e4219cd82ef2a4ad 2441 gnome optional gnome-themes-standard_3.6.2-1.dsc
 c8f57e0e4ec0c986ea43c838fb68af93 3609716 gnome optional gnome-themes-standard_3.6.2.orig.tar.xz
 666309d1116acc3c6880e7c961dc15ec 4877 gnome optional gnome-themes-standard_3.6.2-1.debian.tar.gz
 5ae4bbbbb5b06fa51ea88ae3069000b3 1578066 gnome optional gnome-themes-standard-data_3.6.2-1_all.deb
 a6b0961399591ffc2170390c50391b59 2124544 gnome optional gnome-accessibility-themes_3.6.2-1_all.deb
 3adea609e3f0573c5bdf52fb44845cd6 219012 gnome optional gnome-themes-standard_3.6.2-1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJQ7vj/AAoJEGrh3w1gjyLc/jkP/07g512l7LFm2/OS7+H/ehDH
gl9OajsFCFih0USPCc14yIZjYudHvlABXJLBpGEk7kjGj8i+bqA5js7nP9BCX4dw
nVa44w283jJX0ZFbLXpfmBNwVckC8oc8H4cIR/7GMeJuFMIgCGJ48iIxPE2FHzGo
3PgfspK8T72pQPYfXTLnw85Ke1180cn7/9qyxDK/l1RpUZ4RMsOXBjlLrAudiCyV
Kt+ZWbheAdmPxJgOaVW5+3+MnD3G7k5FtySMRWzpgWn7prJn24kYkLCShfFlrtCD
GT6fNubS3DXO+Xlx5pOIUVRFh7TkEHwAFuUxcd7GuEZ4FIflFn9SG7wxl5vxGpVT
S9E2z+PkbKEfER3hzDXkCiotnS/Ke5zK0LEIHHP1iZryzRlrscmKnTtY9cbftDKi
+6O3xjHdlpbAP6s+VsI0RninbSWivbuTCpILbBsABYELplWVZI2nruRX7oZIlG/3
XJYBbSwopOx5sqHuv63l+Mw7RtvhFZ00iu69LcWpasvWaxN6pys0nSL1DNmEk2Lr
6flvPhpYwZnLjNToG78ewIIJTgjpdVqU0WDgE24Loc2lYUa0J5Z6fwAFjIHTBGE8
TmFw8o/loxuEpy94z82uEru/+hikSxfjkj2ccqJHxaxVnoWO+AFyhUaEVxQcIBfZ
UcVH0bUQgrgw7IQusfgV
=SDux
-----END PGP SIGNATURE-----




Changed Bug submitter to 'Andreas Beckmann <anbe@debian.org>' from 'Andreas Beckmann <debian@abeckmann.de>' Request was from Andreas Beckmann <anbe@debian.org> to control@bugs.debian.org. (Sat, 26 Jan 2013 06:28:27 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 23 Feb 2013 07:28:22 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 00:52:06 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.