Debian Bug report logs - #660597
Browser fails to report page load errors

version graph

Package: liferea; Maintainer for liferea is David Michael Smith <sidicas2@gmail.com>; Source for liferea is src:liferea.

Reported by: Ben Hutchings <ben@decadent.org.uk>

Date: Mon, 20 Feb 2012 04:00:02 UTC

Severity: normal

Tags: confirmed

Found in versions liferea/1.8.6-1, liferea/1.8.6-1.1, liferea/1.6.5-1.2, liferea/1.10rc1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Luis Rodrigo Gallardo Cruz <rodrigo@debian.org>:
Bug#660597; Package liferea. (Mon, 20 Feb 2012 04:00:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ben Hutchings <ben@decadent.org.uk>:
New Bug report received and forwarded. Copy sent to Luis Rodrigo Gallardo Cruz <rodrigo@debian.org>. (Mon, 20 Feb 2012 04:00:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Ben Hutchings <ben@decadent.org.uk>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: Browser fails to report page load errors
Date: Mon, 20 Feb 2012 03:56:35 +0000
Package: liferea
Version: 1.6.5-1.2+b1
Severity: normal

The browser doesn't show load errors detected on the client side.
For example if I follow a link to a PDF, that can't be shown in
the browser and the page load is aborted.  It would be nice if I
was prompted whether to save or download.  But as a first step,
I should at least be told that the load failed for some reason.

Based on my own experience with embedding Gecko, I think this
requires registering a prompt service.  My implementation is
<http://git.decadent.org.uk/gitweb?p=videolink.git;a=blob;f=null_prompt_service.cpp;h=68d6d9010a287cb6189cd93137afb4d54273afe7>.

Ben.

-- System Information:
Debian Release: wheezy/sid
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'proposed-updates'), (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (x86_64)

Kernel: Linux 3.2.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.utf8, LC_CTYPE=en_GB.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages liferea depends on:
ii  gconf2              3.2.3-1
ii  libatk1.0-0         2.2.0-2
ii  libc6               2.13-26
ii  libcairo2           1.10.2-6.2
ii  libdbus-1-3         1.4.18-1
ii  libdbus-glib-1-2    0.98-1
ii  libgconf2-4         3.2.3-1
ii  libgdk-pixbuf2.0-0  2.24.1-1
ii  libglade2-0         1:2.6.4-1
ii  libglib2.0-0        2.30.2-6
ii  libgtk2.0-0         2.24.9-2
ii  libice6             2:1.0.7-2
ii  liblua5.1-0         5.1.4-12
ii  libnm-glib4         0.9.2.0-2
ii  libnotify4          0.7.4-1
ii  libpango1.0-0       1.29.4-2
ii  libsm6              2:1.2.0-2
ii  libsoup2.4-1        2.36.1-1
ii  libsqlite3-0        3.7.10-1
ii  libwebkitgtk-1.0-0  1.6.3-1
ii  libx11-6            2:1.4.4-4
ii  libxml2             2.7.8.dfsg-7
ii  libxslt1.1          1.1.26-8
ii  liferea-data        1.6.5-1.2

Versions of packages liferea recommends:
ii  curl      7.24.0-1
ii  dbus      1.4.18-1
ii  dbus-x11  1.4.18-1
ii  wget      1.13.4-2

Versions of packages liferea suggests:
ii  network-manager  0.9.2.0-2

-- no debconf information




Marked as found in versions liferea/1.8.6-1. Request was from Ben Hutchings <ben@decadent.org.uk> to control@bugs.debian.org. (Sun, 18 Nov 2012 19:09:03 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Luis Rodrigo Gallardo Cruz <rodrigo@debian.org>:
Bug#660597; Package liferea. (Mon, 07 Jan 2013 08:39:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to David Smith <sidicas2@gmail.com>:
Extra info received and forwarded to list. Copy sent to Luis Rodrigo Gallardo Cruz <rodrigo@debian.org>. (Mon, 07 Jan 2013 08:39:05 GMT) Full text and rfc822 format available.

Message #12 received at 660597@bugs.debian.org (full text, mbox):

From: David Smith <sidicas2@gmail.com>
To: control@bugs.debian.org, 660597@bugs.debian.org
Subject: Re: Browser fails to report page load errors
Date: Mon, 07 Jan 2013 16:34:23 +0800
tags 660597 confirmed
found 660596 1.8.6-1.1
thanks

Yes, in definitely seems liferea's built-in browser ignores clicks to 
links that it can't load without even giving any reason for it.
Have you tried filing a bug report upstream and submitting your patch?

At the very least, I think there should be an error in the status bar 
when a user clicks a link liferea can't load.

http://sourceforge.net/p/liferea/bugs/




Added tag(s) confirmed. Request was from David Smith <sidicas2@gmail.com> to control@bugs.debian.org. (Mon, 07 Jan 2013 08:39:07 GMT) Full text and rfc822 format available.

Marked as found in versions liferea/1.10rc1. Request was from David Smith <sidicas2@gmail.com> to control@bugs.debian.org. (Sun, 17 Mar 2013 04:27:08 GMT) Full text and rfc822 format available.

Marked as found in versions liferea/1.8.6-1.1. Request was from David Smith <sidicas2@gmail.com> to control@bugs.debian.org. (Sun, 17 Mar 2013 04:27:09 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 16 04:55:21 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.