Debian Bug report logs - #660120
wvdial doesn't work on armel / armhf platforms

version graph

Package: wvdial; Maintainer for wvdial is Thierry Randrianiriana <thierry@debian.org>; Source for wvdial is src:wvdial.

Reported by: Thomas Maass <mase@setho.org>

Date: Thu, 16 Feb 2012 15:36:02 UTC

Severity: important

Found in version wvdial/1.61-4

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Thierry Randrianiriana <thierry@debian.org>:
Bug#660120; Package wvdial. (Thu, 16 Feb 2012 15:36:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Thomas Maass <mase@setho.org>:
New Bug report received and forwarded. Copy sent to Thierry Randrianiriana <thierry@debian.org>. (Thu, 16 Feb 2012 15:36:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Thomas Maass <mase@setho.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: wvdial doesn't work on armel / armhf platforms
Date: Thu, 16 Feb 2012 16:33:43 +0100
Package: wvdial
Version: 1.61-4
Severity: important

Dear Maintainer,
wvdial does not work on armel / armhf platforms.
This is the output:

--> WvDial: Internet dialer version 1.61
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: AT+CGDCONT?
AT+CGDCONT?
+CGDCONT: 1,"IP",,,0,0
OK
--> Sending: AT+CGDCONT=1,"IP","internet.t-mobile"
AT+CGDCONT=1,"IP","internet.t-mobile"
OK
--> Modem initialized.
wvdial: utils/wvtask.cc:202: WvTaskMan::WvTaskMan(): Assertion
`getcontext(&get_stack_return) == 0' failed.



-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: armhf (armv7l)

Kernel: Linux 3.0.19-5-ac100 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages wvdial depends on:
ii  debconf [debconf-2.0]   1.5.41
ii  libc6                   2.13-26
ii  libgcc1                 1:4.6.2-14
ii  libstdc++6              4.6.2-14
ii  libuniconf4.6           4.6.1-2
ii  libwvstreams4.6-base    4.6.1-2
ii  libwvstreams4.6-extras  4.6.1-2
ii  ppp                     2.4.5-5

wvdial recommends no packages.

wvdial suggests no packages.

-- debconf information excluded




Information forwarded to debian-bugs-dist@lists.debian.org, Thierry Randrianiriana <thierry@debian.org>:
Bug#660120; Package wvdial. (Mon, 05 Mar 2012 00:27:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Hector Oron <zumbi@debian.org>:
Extra info received and forwarded to list. Copy sent to Thierry Randrianiriana <thierry@debian.org>. (Mon, 05 Mar 2012 00:27:03 GMT) Full text and rfc822 format available.

Message #10 received at 660120@bugs.debian.org (full text, mbox):

From: Hector Oron <zumbi@debian.org>
To: Thomas Maass <mase@setho.org>, 660120@bugs.debian.org
Subject: Re: Bug#660120: wvdial doesn't work on armel / armhf platforms
Date: Mon, 5 Mar 2012 01:16:48 +0100
Hello,

On Thu, Feb 16, 2012 at 04:33:43PM +0100, Thomas Maass wrote:
 
> Dear Maintainer,
> wvdial does not work on armel / armhf platforms.
> This is the output:
> 
> --> WvDial: Internet dialer version 1.61
> --> Cannot get information for serial port.
> --> Initializing modem.
> --> Sending: ATZ
> ATZ
> OK
> --> Sending: AT+CGDCONT?
> AT+CGDCONT?
> +CGDCONT: 1,"IP",,,0,0
> OK
> --> Sending: AT+CGDCONT=1,"IP","internet.t-mobile"
> AT+CGDCONT=1,"IP","internet.t-mobile"
> OK
> --> Modem initialized.
> wvdial: utils/wvtask.cc:202: WvTaskMan::WvTaskMan(): Assertion
> `getcontext(&get_stack_return) == 0' failed.

Right, getcontext syscall is not supported (yet) in libc.
I am currently building eglibc with some patches that might allow getcontext to exist.
It would be great if you could test the packages once are built.

Cheers,
-- 
  Hector Oron




Information forwarded to debian-bugs-dist@lists.debian.org, Thierry Randrianiriana <thierry@debian.org>:
Bug#660120; Package wvdial. (Mon, 05 Mar 2012 10:57:14 GMT) Full text and rfc822 format available.

Acknowledgement sent to Hector Oron <zumbi@debian.org>:
Extra info received and forwarded to list. Copy sent to Thierry Randrianiriana <thierry@debian.org>. (Mon, 05 Mar 2012 10:57:22 GMT) Full text and rfc822 format available.

Message #15 received at 660120@bugs.debian.org (full text, mbox):

From: Hector Oron <zumbi@debian.org>
To: Thomas Maass <mase@setho.org>, 660120@bugs.debian.org
Subject: Re: Bug#660120: wvdial doesn't work on armel / armhf platforms
Date: Mon, 5 Mar 2012 11:57:21 +0100
Hello,

On Mon, Mar 05, 2012 at 01:16:48AM +0100, Hector Oron wrote:
> On Thu, Feb 16, 2012 at 04:33:43PM +0100, Thomas Maass wrote:
  
> > Dear Maintainer,
> > wvdial does not work on armel / armhf platforms.
> > This is the output:
> > 
> > --> WvDial: Internet dialer version 1.61
> > --> Cannot get information for serial port.
> > --> Initializing modem.
> > --> Sending: ATZ
> > ATZ
> > OK
> > --> Sending: AT+CGDCONT?
> > AT+CGDCONT?
> > +CGDCONT: 1,"IP",,,0,0
> > OK
> > --> Sending: AT+CGDCONT=1,"IP","internet.t-mobile"
> > AT+CGDCONT=1,"IP","internet.t-mobile"
> > OK
> > --> Modem initialized.
> > wvdial: utils/wvtask.cc:202: WvTaskMan::WvTaskMan(): Assertion
> > `getcontext(&get_stack_return) == 0' failed.
 
> Right, getcontext syscall is not supported (yet) in libc.
> I am currently building eglibc with some patches that might allow getcontext to exist.
> It would be great if you could test the packages once are built.

If you could test with this packages and report back, that would be really helpful.
< http://people.debian.org/~zumbi/tmp/eglibc+getcontext/ >

Regards,
-- 
  Hector Oron




Information forwarded to debian-bugs-dist@lists.debian.org, Thierry Randrianiriana <thierry@debian.org>:
Bug#660120; Package wvdial. (Fri, 16 Mar 2012 14:51:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Thomas Zander <thomas.e.zander@googlemail.com>:
Extra info received and forwarded to list. Copy sent to Thierry Randrianiriana <thierry@debian.org>. (Fri, 16 Mar 2012 14:51:03 GMT) Full text and rfc822 format available.

Message #20 received at 660120@bugs.debian.org (full text, mbox):

From: Thomas Zander <thomas.e.zander@googlemail.com>
To: 660120@bugs.debian.org
Subject: Re: Bug#660120: wvdial doesn't work on armel / armhf platforms
Date: Fri, 16 Mar 2012 15:47:20 +0100
Hello Hector,

tested on wheezy today. Seems to solve the wvdial problem!

Regards
Riggs




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 02:07:22 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.