Debian Bug report logs - #659869
perl modules obsoleted by perl 5.14 are uninstallable in sid

version graph

Package: perl; Maintainer for perl is Niko Tyni <ntyni@debian.org>; Source for perl is src:perl.

Reported by: Andreas Beckmann <anbe@debian.org>

Date: Tue, 14 Feb 2012 12:00:01 UTC

Severity: wishlist

Found in versions libparent-perl/0.224-1, libtime-piece-perl/1.20-2, libautodie-perl/2.10-2, libextutils-cbuilder-perl/0.280202-2, libshell-perl/0.72-1

Fixed in version libshell-perl/0.72.01-1

Done: Dominic Hargreaves <dom@earth.li>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Niko Tyni <ntyni@debian.org>:
Bug#659869; Package perl. (Tue, 14 Feb 2012 12:00:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
New Bug report received and forwarded. Copy sent to Niko Tyni <ntyni@debian.org>. (Tue, 14 Feb 2012 12:00:06 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: perl modules obsoleted by perl 5.14 are uninstallable in sid
Date: Tue, 14 Feb 2012 12:56:45 +0100
Package: perl
Version: 5.14.2-7
Severity: wishlist
User: debian-qa@lists.debian.org
Usertags: piuparts

Hi,

there are a few perl modules that are now included in the perl 5.14 core
module set and the 'old' separate module packages are no longer
installable in sid (the packages were removed from wheezy during the
perl 5.14 transition).
Perl maintainers expressed intention to keep these packages around in
sid in case these modules get updated.

Some more discussion about this can be found in this thread:
http://lists.debian.org/debian-perl/2012/01/msg00051.html

These old packages fail the piuparts tests in sid (because they are
uninstallable) and the repeated failures distract from real problems
that need bugs to be filed about. Therefore I'm filing this wishlist
bug against perl and will set 
  affects + $package
  found $package/$version
for all affected modules so that piuparts-analyze can mark the fail logs
as 'bugged'.

The packages currently affected are:
  libparent-perl
  libshell-perl
  libtime-piece-perl
  libautodie-perl

Andreas




Added indication that 659869 affects libparent-perl, libshell-perl, libtime-piece-perl, and libautodie-perl Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Tue, 14 Feb 2012 12:10:52 GMT) Full text and rfc822 format available.

Bug Marked as found in versions libparent-perl/0.224-1. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Tue, 14 Feb 2012 12:10:56 GMT) Full text and rfc822 format available.

Bug Marked as found in versions libshell-perl/0.72-1. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Tue, 14 Feb 2012 12:10:59 GMT) Full text and rfc822 format available.

Bug Marked as found in versions libtime-piece-perl/1.20-2. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Tue, 14 Feb 2012 12:11:00 GMT) Full text and rfc822 format available.

Bug Marked as found in versions libautodie-perl/2.10-2. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Tue, 14 Feb 2012 12:11:01 GMT) Full text and rfc822 format available.

Added indication that 659869 affects libextutils-cbuilder-perl Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Wed, 22 Feb 2012 22:54:05 GMT) Full text and rfc822 format available.

Bug Marked as found in versions libextutils-cbuilder-perl/0.280202-2. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Wed, 22 Feb 2012 22:54:06 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#659869; Package perl. (Sat, 25 Feb 2012 14:06:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Niko Tyni <ntyni@debian.org>:
Extra info received and forwarded to list. (Sat, 25 Feb 2012 14:06:03 GMT) Full text and rfc822 format available.

Message #24 received at 659869@bugs.debian.org (full text, mbox):

From: Niko Tyni <ntyni@debian.org>
To: Andreas Beckmann <debian@abeckmann.de>, 659869@bugs.debian.org
Cc: debian-perl@lists.debian.org
Subject: Re: Bug#659869: perl modules obsoleted by perl 5.14 are uninstallable in sid
Date: Sat, 25 Feb 2012 16:01:56 +0200
On Tue, Feb 14, 2012 at 12:56:45PM +0100, Andreas Beckmann wrote:
> Package: perl
> Version: 5.14.2-7
> Severity: wishlist
> User: debian-qa@lists.debian.org
> Usertags: piuparts
 
> there are a few perl modules that are now included in the perl 5.14 core
> module set and the 'old' separate module packages are no longer
> installable in sid (the packages were removed from wheezy during the
> perl 5.14 transition).
> Perl maintainers expressed intention to keep these packages around in
> sid in case these modules get updated.
> 
> Some more discussion about this can be found in this thread:
> http://lists.debian.org/debian-perl/2012/01/msg00051.html
> 
> These old packages fail the piuparts tests in sid (because they are
> uninstallable) and the repeated failures distract from real problems
> that need bugs to be filed about. Therefore I'm filing this wishlist
> bug against perl and will set 
>   affects + $package
>   found $package/$version
> for all affected modules so that piuparts-analyze can mark the fail logs
> as 'bugged'.

Thanks for your work.

I don't really see the point of the wishlist bug against perl. These
should all be separate grave bugs against the respective packages IMO.
No change in perl is going to fix them.

> The packages currently affected are:
>   libparent-perl
>   libshell-perl
>   libtime-piece-perl
>   libautodie-perl

I'm inclined to just go ahead and have them removed from sid straight
away, but I'm cc'ing the debian-perl list as I think some other pkg-perl
folks wanted to keep them around longer.
-- 
Niko Tyni   ntyni@debian.org




Information forwarded to debian-bugs-dist@lists.debian.org, Niko Tyni <ntyni@debian.org>:
Bug#659869; Package perl. (Sat, 25 Feb 2012 14:21:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Dominic Hargreaves <dom@earth.li>:
Extra info received and forwarded to list. Copy sent to Niko Tyni <ntyni@debian.org>. (Sat, 25 Feb 2012 14:21:05 GMT) Full text and rfc822 format available.

Message #29 received at 659869@bugs.debian.org (full text, mbox):

From: Dominic Hargreaves <dom@earth.li>
To: Andreas Beckmann <debian@abeckmann.de>, 659869@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: Bug#659869: perl modules obsoleted by perl 5.14 are uninstallable in sid
Date: Sat, 25 Feb 2012 14:18:16 +0000
On Sat, Feb 25, 2012 at 04:01:56PM +0200, Niko Tyni wrote:
> On Tue, Feb 14, 2012 at 12:56:45PM +0100, Andreas Beckmann wrote:

> I don't really see the point of the wishlist bug against perl. These
> should all be separate grave bugs against the respective packages IMO.
> No change in perl is going to fix them.
> 
> > The packages currently affected are:
> >   libparent-perl
> >   libshell-perl
> >   libtime-piece-perl
> >   libautodie-perl
> 
> I'm inclined to just go ahead and have them removed from sid straight
> away, but I'm cc'ing the debian-perl list as I think some other pkg-perl
> folks wanted to keep them around longer.

In general I agree, but there's a mistake in the perl package too:
libshell-perl shouldn't be broken by perl as it's been deprecated.

I've pushed a fix for this.

-- 
Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)




Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#659869; Package perl. (Sat, 25 Feb 2012 16:27:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Niko Tyni <ntyni@debian.org>:
Extra info received and forwarded to list. (Sat, 25 Feb 2012 16:27:04 GMT) Full text and rfc822 format available.

Message #34 received at 659869@bugs.debian.org (full text, mbox):

From: Niko Tyni <ntyni@debian.org>
To: 659869@bugs.debian.org
Cc: debian-perl@lists.debian.org
Subject: Re: Bug#659869: perl modules obsoleted by perl 5.14 are uninstallable in sid
Date: Sat, 25 Feb 2012 18:26:07 +0200
On Sat, Feb 25, 2012 at 02:18:16PM +0000, Dominic Hargreaves wrote:

> In general I agree, but there's a mistake in the perl package too:
> libshell-perl shouldn't be broken by perl as it's been deprecated.

I don't think that's a bug in the perl package: the libshell-perl package
is lagging behind in Debian as it's at 0.72 while CPAN and core have
Shell 0.72_01.

There's actually a meaningful doc fix in 0.72_01, see
 http://search.cpan.org/diff?from=Shell-0.72&to=Shell-0.72_01&w=1
so Breaks: libshell-perl (<< 0.72.01) seems to be correct and ensures
that the "buggy" 0.72 never overrides the "fixed" 0.72_01.

The best solution AFAICS would be to upgrade the Debian
package and keep the Breaks entry.

(Normally we wouldn't need the separate package at all, but as
 Shell is going away from the core we need something to migrate to.)
-- 
Niko Tyni   ntyni@debian.org




Information forwarded to debian-bugs-dist@lists.debian.org, Niko Tyni <ntyni@debian.org>:
Bug#659869; Package perl. (Sat, 25 Feb 2012 17:24:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Salvatore Bonaccorso <carnil@debian.org>:
Extra info received and forwarded to list. Copy sent to Niko Tyni <ntyni@debian.org>. (Sat, 25 Feb 2012 17:24:04 GMT) Full text and rfc822 format available.

Message #39 received at 659869@bugs.debian.org (full text, mbox):

From: Salvatore Bonaccorso <carnil@debian.org>
To: 659869@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: Bug#659869: perl modules obsoleted by perl 5.14 are uninstallable in sid
Date: Sat, 25 Feb 2012 18:20:40 +0100
[Message part 1 (text/plain, inline)]
Hi Niko and Dominic

On Sat, Feb 25, 2012 at 06:26:07PM +0200, Niko Tyni wrote:
> On Sat, Feb 25, 2012 at 02:18:16PM +0000, Dominic Hargreaves wrote:
> 
> > In general I agree, but there's a mistake in the perl package too:
> > libshell-perl shouldn't be broken by perl as it's been deprecated.
> 
> I don't think that's a bug in the perl package: the libshell-perl package
> is lagging behind in Debian as it's at 0.72 while CPAN and core have
> Shell 0.72_01.
> 
> There's actually a meaningful doc fix in 0.72_01, see
>  http://search.cpan.org/diff?from=Shell-0.72&to=Shell-0.72_01&w=1
> so Breaks: libshell-perl (<< 0.72.01) seems to be correct and ensures
> that the "buggy" 0.72 never overrides the "fixed" 0.72_01.
> 
> The best solution AFAICS would be to upgrade the Debian
> package and keep the Breaks entry.

Okay, just reading your message, and I have updated the package in the
Debian Perl Group repo [1].

Please let me know if we should upload it.

Regards,
Salvatore
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Niko Tyni <ntyni@debian.org>:
Bug#659869; Package perl. (Sat, 25 Feb 2012 18:09:14 GMT) Full text and rfc822 format available.

Acknowledgement sent to Dominic Hargreaves <dom@earth.li>:
Extra info received and forwarded to list. Copy sent to Niko Tyni <ntyni@debian.org>. (Sat, 25 Feb 2012 18:09:14 GMT) Full text and rfc822 format available.

Message #44 received at 659869@bugs.debian.org (full text, mbox):

From: Dominic Hargreaves <dom@earth.li>
To: 659869@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: Bug#659869: perl modules obsoleted by perl 5.14 are uninstallable in sid
Date: Sat, 25 Feb 2012 18:05:01 +0000
On Sat, Feb 25, 2012 at 06:20:40PM +0100, Salvatore Bonaccorso wrote:
> Hi Niko and Dominic
> 
> On Sat, Feb 25, 2012 at 06:26:07PM +0200, Niko Tyni wrote:
> > On Sat, Feb 25, 2012 at 02:18:16PM +0000, Dominic Hargreaves wrote:
> > 
> > > In general I agree, but there's a mistake in the perl package too:
> > > libshell-perl shouldn't be broken by perl as it's been deprecated.
> > 
> > I don't think that's a bug in the perl package: the libshell-perl package
> > is lagging behind in Debian as it's at 0.72 while CPAN and core have
> > Shell 0.72_01.
> > 
> > There's actually a meaningful doc fix in 0.72_01, see
> >  http://search.cpan.org/diff?from=Shell-0.72&to=Shell-0.72_01&w=1
> > so Breaks: libshell-perl (<< 0.72.01) seems to be correct and ensures
> > that the "buggy" 0.72 never overrides the "fixed" 0.72_01.
> > 
> > The best solution AFAICS would be to upgrade the Debian
> > package and keep the Breaks entry.

Yes. Thanks for checking this and apologies for the oversight.
I've reinstated the Breaks.

> Okay, just reading your message, and I have updated the package in the
> Debian Perl Group repo [1].
> 
> Please let me know if we should upload it.

Please do; thanks!

-- 
Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)




Information forwarded to debian-bugs-dist@lists.debian.org, Niko Tyni <ntyni@debian.org>:
Bug#659869; Package perl. (Sat, 25 Feb 2012 19:09:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Salvatore Bonaccorso <carnil@debian.org>:
Extra info received and forwarded to list. Copy sent to Niko Tyni <ntyni@debian.org>. (Sat, 25 Feb 2012 19:09:03 GMT) Full text and rfc822 format available.

Message #49 received at 659869@bugs.debian.org (full text, mbox):

From: Salvatore Bonaccorso <carnil@debian.org>
To: 659869@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: Bug#659869: perl modules obsoleted by perl 5.14 are uninstallable in sid
Date: Sat, 25 Feb 2012 20:07:10 +0100
[Message part 1 (text/plain, inline)]
Hi

On Sat, Feb 25, 2012 at 06:05:01PM +0000, Dominic Hargreaves wrote:
> > Please let me know if we should upload it.
> 
> Please do; thanks!

Okay, done now.

Regards
Salvatore
[signature.asc (application/pgp-signature, inline)]

Removed indication that 659869 affects libshell-perl Request was from Dominic Hargreaves <dom@earth.li> to control@bugs.debian.org. (Sat, 25 Feb 2012 21:03:07 GMT) Full text and rfc822 format available.

Bug Marked as fixed in versions libshell-perl/0.72.01-1. Request was from Dominic Hargreaves <dom@earth.li> to control@bugs.debian.org. (Sat, 25 Feb 2012 21:03:08 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Niko Tyni <ntyni@debian.org>:
Bug#659869; Package perl. (Mon, 05 Mar 2012 16:02:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
Extra info received and forwarded to list. Copy sent to Niko Tyni <ntyni@debian.org>. (Mon, 05 Mar 2012 16:03:49 GMT) Full text and rfc822 format available.

Message #58 received at 659869@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: 659869@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: Bug#659869: perl modules obsoleted by perl 5.14 are uninstallable in sid
Date: Mon, 05 Mar 2012 16:58:26 +0100
On 2012-02-25 15:01, Niko Tyni wrote:
> I don't really see the point of the wishlist bug against perl. These
> should all be separate grave bugs against the respective packages IMO.

Shall I file separate bugs?


Andreas




Information forwarded to debian-bugs-dist@lists.debian.org, Niko Tyni <ntyni@debian.org>:
Bug#659869; Package perl. (Mon, 05 Mar 2012 19:03:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to gregor herrmann <gregoa@debian.org>:
Extra info received and forwarded to list. Copy sent to Niko Tyni <ntyni@debian.org>. (Mon, 05 Mar 2012 19:03:06 GMT) Full text and rfc822 format available.

Message #63 received at 659869@bugs.debian.org (full text, mbox):

From: gregor herrmann <gregoa@debian.org>
To: Andreas Beckmann <debian@abeckmann.de>
Cc: 659869@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: Bug#659869: perl modules obsoleted by perl 5.14 are uninstallable in sid
Date: Mon, 5 Mar 2012 20:01:38 +0100
[Message part 1 (text/plain, inline)]
On Mon, 05 Mar 2012 16:58:26 +0100, Andreas Beckmann wrote:

> On 2012-02-25 15:01, Niko Tyni wrote:
> > I don't really see the point of the wishlist bug against perl. These
> > should all be separate grave bugs against the respective packages IMO.
> Shall I file separate bugs?

I think we can just file removal bugs, if someone has a complete list
of affected packages (IIRC we also have some which are obsolete by
perl 5.12 ...); at least I don't have to overview now :)

Cheers,
gregor
 
-- 
 .''`.  Homepage: http://info.comodo.priv.at/ - OpenPGP key 0xBB3A68018649AA06
 : :' : Debian GNU/Linux user, admin, and developer  -  http://www.debian.org/
 `. `'  Member of VIBE!AT & SPI, fellow of the Free Software Foundation Europe
   `-   NP: Tom Waits: House Where Nobody Lives
[signature.asc (application/pgp-signature, inline)]

Reply sent to Dominic Hargreaves <dom@earth.li>:
You have taken responsibility. (Sun, 10 Jun 2012 17:57:05 GMT) Full text and rfc822 format available.

Notification sent to Andreas Beckmann <debian@abeckmann.de>:
Bug acknowledged by developer. (Sun, 10 Jun 2012 17:57:05 GMT) Full text and rfc822 format available.

Message #68 received at 659869-done@bugs.debian.org (full text, mbox):

From: Dominic Hargreaves <dom@earth.li>
To: Andreas Beckmann <debian@abeckmann.de>, 659869-done@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: Bug#659869: perl modules obsoleted by perl 5.14 are uninstallable in sid
Date: Sun, 10 Jun 2012 18:54:43 +0100
On Mon, Mar 05, 2012 at 08:01:38PM +0100, gregor herrmann wrote:
> On Mon, 05 Mar 2012 16:58:26 +0100, Andreas Beckmann wrote:
> 
> > On 2012-02-25 15:01, Niko Tyni wrote:
> > > I don't really see the point of the wishlist bug against perl. These
> > > should all be separate grave bugs against the respective packages IMO.
> > Shall I file separate bugs?
> 
> I think we can just file removal bugs, if someone has a complete list
> of affected packages (IIRC we also have some which are obsolete by
> perl 5.12 ...); at least I don't have to overview now :)

I've requested removal of libtime-piece-perl[0] and libparent-perl[1],
which are the only packages currently uninstallable due to be being
dual-lived, as far as I can see.

The rest of the packages at
<http://lintian.debian.org/tags/package-superseded-by-perl.html>, currently:

libextutils-command-perl
liblocale-maketext-simple-perl
libperl-ostype-perl
libtest-simple-perl
libthread-queue-perl
libtime-local-perl

are redundant, because they have the same version as perl, but they
are installable, so they are not really the subject of this bug.
Therefore I'm closing this one now.

Note: before many of the above lintian warnings can be fixed, the 
warnings from

<http://lintian.debian.org/tags/versioned-dependency-satisfied-by-perl.html>

need to be fixed.

Cheers,
Dominic.

[0] <http://bugs.debian.org/676944>
[1] <http://bugs.debian.org/676949>

-- 
Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)




Changed Bug submitter to 'Andreas Beckmann <anbe@debian.org>' from 'Andreas Beckmann <debian@abeckmann.de>' Request was from Andreas Beckmann <anbe@debian.org> to control@bugs.debian.org. (Sat, 26 Jan 2013 06:31:25 GMT) Full text and rfc822 format available.

No longer marked as found in versions perl/5.14.2-7. Request was from Dominic Hargreaves <dom@earth.li> to control@bugs.debian.org. (Sun, 17 Feb 2013 01:21:03 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 17 Mar 2013 07:27:00 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 19:40:18 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.