Debian Bug report logs - #659265
debian-edu-install: ltsp-build-client error during install via CD or Usb key

version graph

Package: debian-edu-install; Maintainer for debian-edu-install is Debian Edu Developers <debian-edu@lists.debian.org>; Source for debian-edu-install is src:debian-edu-install.

Reported by: andre <andre.lasfargues@univ-orleans.fr>

Date: Thu, 9 Feb 2012 17:12:02 UTC

Severity: important

Tags: d-i

Found in version amd64-i386-NETINST-1CD

Fixed in version 1.712

Done: Petter Reinholdtsen <pere@hungry.com>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, andre.lasfargues@univ-orleans.fr, Debian Edu Developers <debian-edu@lists.debian.org>:
Bug#659265; Package debian-edu-install. (Thu, 09 Feb 2012 17:12:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to andre <andre.lasfargues@univ-orleans.fr>:
New Bug report received and forwarded. Copy sent to andre.lasfargues@univ-orleans.fr, Debian Edu Developers <debian-edu@lists.debian.org>. (Thu, 09 Feb 2012 17:12:06 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: andre <andre.lasfargues@univ-orleans.fr>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: debian-edu-install: ltsp-build-client error during install via CD or Usb key
Date: Thu, 09 Feb 2012 18:09:12 +0100
[Message part 1 (text/plain, inline)]
Package: debian-edu-install
Version: amd64-i386-NETINST-1CD
Severity: important
Tags: d-i

I wanted to install debian-edu with the debian-edu-amd64-i386-NETINST-1.iso
downlaoded from ftp.skolelinux.org/cd-squeeze-test-amd64-i386-netinst/ from
09/02/2012.

The workstation is a precision T3500 from Dell with 3 hard drives

I choosed an 64bit installation mode with french localization

Auto partitionning and the profiles from the default for debian-edu so Main
Server, Workstation and Thin-client-server

Network using DHCP

All goes well until the 14% of the task Building the ltsp chroot and i am stuck
with the error above in F4 console :

Feb  9 15:34:19 pkgsel: finishing up
Feb  9 15:34:25 kernel: [ 1505.780053] ISO 9660 Extensions: Microsoft Joliet
Level 3
Feb  9 15:34:25 kernel: [ 1505.839660] ISO 9660 Extensions: RRIP_1991A
Feb  9 15:34:25 kernel: [ 1506.161403] ISO 9660 Extensions: Microsoft Joliet
Level 3
Feb  9 15:34:25 kernel: [ 1506.221024] ISO 9660 Extensions: RRIP_1991A
Feb  9 15:34:26 main-menu[466]: DEBUG: resolver (download-installer): package
doesn't exist (ignored)
Feb  9 15:34:26 main-menu[466]: INFO: Menu item 'ltsp-client-builder' selected
Feb  9 15:34:26 ltsp-client-builder: ltsp-build-client options: --mirror
file:///media/cdrom --security-mirror none --mount-cdrom --accept-unsigned-
packages
Feb  9 15:34:26 ltsp-client-builder: Installing package ltsp-server-standalone
in target
Feb  9 15:34:26 in-target: Lecture des listes de paquets...
Feb  9 15:34:26 in-target:
Feb  9 15:34:26 in-target: Construction de l'arbre des dépendances...
Feb  9 15:34:26 in-target:
Feb  9 15:34:26 in-target: Lecture des informations d'état...
Feb  9 15:34:26 in-target:
Feb  9 15:34:26 in-target: ltsp-server-standalone est déjà la plus récente
version disponible.
Feb  9 15:34:26 in-target: 0 mis à jour, 0 nouvellement installés, 0 à
enlever et 0 non mis à jour.
Feb  9 15:34:26 kernel: [ 1507.060910] ISO 9660 Extensions: Microsoft Joliet
Level 3
Feb  9 15:34:26 kernel: [ 1507.120303] ISO 9660 Extensions: RRIP_1991A
Feb  9 15:34:27 kernel: [ 1508.115647] ISO 9660 Extensions: Microsoft Joliet
Level 3
Feb  9 15:34:27 kernel: [ 1508.174013] ISO 9660 Extensions: RRIP_1991A
Feb  9 15:34:27 in-target: info: Found i386 binaries on amd64 CD/DVD.  Keeping
LTSP mirror as ''
Feb  9 15:34:27 in-target: Detected CD install, disabling APT repository
checking.
Feb  9 15:34:27 in-target: deb cdrom:[Debian GNU/Linux 6.0+edu0~b3 _Squeeze_ -
Unofficial Multi-architecture amd64/i386 NETINST #1 20120209-08:09]/ squeeze
contrib local main non-free
Feb  9 15:34:27 in-target: deb http://ftp.skolelinux.org/skolelinux squeeze-
test local
Feb  9 15:34:27 in-target: deb-src http://ftp.skolelinux.org/skolelinux
squeeze-test local
Feb  9 15:34:28 in-target: mount: /dev/sr0 already mounted or /media/cdrom0
busy
Feb  9 15:34:28 in-target: unble to mount cdrom, trying to continue
Feb  9 15:34:28 in-target: I: Retrieving Release
Feb  9 15:34:28 in-target: E: Failed getting release file
file:///media/cdrom/dists/squeeze/Release
Feb  9 15:34:28 in-target: error: LTSP client installation ended abnormally
Feb  9 15:34:28 ltsp-client-builder: ERROR: ltsp-build-client failed to run
Feb  9 15:34:28 main-menu[466]: WARNING **: Configuring 'ltsp-client-builder'
failed with error code 1
Feb  9 15:34:28 main-menu[466]: WARNING **: Menu item 'ltsp-client-builder'
failed.
Feb  9 15:52:39 main-menu[466]: INFO: Modifying debconf priority limit from
'critical' to 'high'

>From here, i tried in F2 console to mount and umount the media/cdrom or to link
to it but all failed
After that the installer proced or jump the installation of grub and succeded
to finish the installation
I can log in to KDE and in Gosa without problem but my ltsp server isn't
installed.

On the first login Debconf is crying me this errors:

error: LTSP client installation ended abnormally, error: LTSP client
installation ended abnormally, error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/reiserfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/ntfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/ntfs-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/qnx4-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: Unable to find
'pool/main/l/linux-kernel-di-amd64-2.6/qnx4-modules-2.6.32-5-amd64-di_1.76+
squeeze6_amd64.udeb'., error: unable to submit to
'http://sitesummary/cgi-bin/sitesummary-collector.cgi', error: unable to submit
to 'http://sitesummary/cgi-bin/sitesummary-collector.cgi', error: ./doc:
Release
manual have 35 FIXMEs. Please fix at
http://wiki.debian.org/DebianEdu/Documentation/Squeeze ., error: Missing
/opt/ltsp/i386/etc/ldap/ssl/ldap-server-pubkey.pem, error: ./ltsp: LTSP chroot
is missing in /opt/ltsp/i386/, error: ./ltsp: package acpi-support-base is not
installed in LTSP chroot, error: ./ltsp: package alsa-base is not installed in
LTSP chroot, error: ./ltsp: package alsa-utils is not installed in LTSP chroot,
error: ./ltsp: package debian-edu-archive-keyring is not installed in LTSP
chroot, error: ./ltsp: package debian-edu-artwork is not installed in LTSP
chroot, error: ./ltsp: package education-thin-client is not installed in LTSP
chroot, error: ./ltsp: package ltsp-client is not installed in LTSP chroot,
error: ./ltsp: package sitesummary-client is not installed in LTSP chroot,
error: ./ltsp: package education-workstation is not installed in LTSP chroot,
error: ./ltsp: Missing /opt/ltsp/i386/etc/debian-edu/config, error: ./ltsp:
/etc/ldap/ssl/ldap-server-pubkey.pem differ inside and outside LTSP, error:
../ltsp: /etc/iceweasel/profile/cert_override.txt differ inside and outside
LTSP,
error: ./ltsp: resolv.conf differ inside and outside LTSP

Consider reporting them to the Debian Edu developers.


I will try to attach a zip file with /var/log/installer /opt/ and some others
/var/log files for you to see

Hope that helps



-- System Information:
Debian Release: wheezy/sid
  APT prefers oneiric-updates
  APT policy: (500, 'oneiric-updates'), (500, 'oneiric-security'), (500, 'oneiric')
Architecture: amd64 (x86_64)

Kernel: Linux 3.0.0-15-generic (SMP w/4 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
[debian-edu-squeeze.zip (application/zip, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Edu Developers <debian-edu@lists.debian.org>:
Bug#659265; Package debian-edu-install. (Sat, 11 Feb 2012 07:18:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Petter Reinholdtsen <pere@hungry.com>:
Extra info received and forwarded to list. Copy sent to Debian Edu Developers <debian-edu@lists.debian.org>. (Sat, 11 Feb 2012 07:18:07 GMT) Full text and rfc822 format available.

Message #10 received at 659265@bugs.debian.org (full text, mbox):

From: Petter Reinholdtsen <pere@hungry.com>
To: 659265@bugs.debian.org, <andre.lasfargues@univ-orleans.fr>
Subject: Re: debian-edu-install: ltsp-build-client error during install via CD or Usb key
Date: Sat, 11 Feb 2012 08:14:27 +0100
I've been unsuccessful in trying to reproduce this in a kvm virtual
machine so far.  I understand it from IRC that you had a successful
VirtualBox installation using the same configuration.

This make me suspect there is some hardware related race condition.
Could the problem be that the /dev/cdrom device show up too late with
your hardware?  I hope to try again with real hardware today and see if
I can replicate it there.
-- 
Happy hacking
Petter Reinholdtsen




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Edu Developers <debian-edu@lists.debian.org>:
Bug#659265; Package debian-edu-install. (Sat, 11 Feb 2012 08:21:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Oded Naveh" <skilinux@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Edu Developers <debian-edu@lists.debian.org>. (Sat, 11 Feb 2012 08:21:06 GMT) Full text and rfc822 format available.

Message #15 received at 659265@bugs.debian.org (full text, mbox):

From: "Oded Naveh" <skilinux@gmail.com>
To: <659265@bugs.debian.org>, <andre.lasfargues@univ-orleans.fr>
Subject: RE: Bug#659265: debian-edu-install: ltsp-build-client error during install via CD or Usb key
Date: Sat, 11 Feb 2012 10:19:16 +0200
[Petter Reinholdtsen - Saturday, February 11, 2012 9:14 AM]

> I've been unsuccessful in trying to reproduce this in a kvm virtual
> machine so far.  I understand it from IRC that you had a successful
> VirtualBox installation using the same configuration.
> 
> This make me suspect there is some hardware related race condition.
> Could the problem be that the /dev/cdrom device show up too late with
> your hardware?  I hope to try again with real hardware today and see
> if I can replicate it there.

Seen this before (a lot) from ltsp-client-builder.

Quoting Vagrant:
"the LTSP plugin that handles the CD mounting is rather stupid, assuming
That /cdrom is the only location for a valid CD-ROM."

See also:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=606313
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=540990

http://bugs.skolelinux.org/show_bug.cgi?id=1341
http://bugs.skolelinux.org/show_bug.cgi?id=1456

Odd.





Information forwarded to debian-bugs-dist@lists.debian.org, Debian Edu Developers <debian-edu@lists.debian.org>:
Bug#659265; Package debian-edu-install. (Sat, 11 Feb 2012 08:27:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Petter Reinholdtsen <pere@hungry.com>:
Extra info received and forwarded to list. Copy sent to Debian Edu Developers <debian-edu@lists.debian.org>. (Sat, 11 Feb 2012 08:27:03 GMT) Full text and rfc822 format available.

Message #20 received at 659265@bugs.debian.org (full text, mbox):

From: Petter Reinholdtsen <pere@hungry.com>
To: 659265@bugs.debian.org
Cc: andre.lasfargues@univ-orleans.fr
Subject: Re: Bug#659265: debian-edu-install: ltsp-build-client error during install via CD or Usb key
Date: Sat, 11 Feb 2012 09:25:21 +0100
[Oded Naveh]
> Seen this before (a lot) from ltsp-client-builder.

Yes, but I created a workaround for it which I hoped would make sure
it kept working.  See
/usr/share/ltsp/plugins/ltsp-build-client/Debian-custom/099-mount-cdrom
in debian-edu-config for the workaround for #606313.

I guess the workaround fail for some reason.
-- 
Happy hacking
Petter Reinholdtsen




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Edu Developers <debian-edu@lists.debian.org>:
Bug#659265; Package debian-edu-install. (Thu, 01 Mar 2012 09:00:21 GMT) Full text and rfc822 format available.

Acknowledgement sent to Petter Reinholdtsen <pere@hungry.com>:
Extra info received and forwarded to list. Copy sent to Debian Edu Developers <debian-edu@lists.debian.org>. (Thu, 01 Mar 2012 09:00:23 GMT) Full text and rfc822 format available.

Message #25 received at 659265@bugs.debian.org (full text, mbox):

From: Petter Reinholdtsen <pere@hungry.com>
To: andre.lasfargues@univ-orleans.fr
Cc: 659265@bugs.debian.org
Subject: Re: Bug#659265: debian-edu-install: ltsp-build-client error during install via CD or Usb key
Date: Thu, 1 Mar 2012 09:59:16 +0100
[Petter Reinholdtsen]
> I guess the workaround fail for some reason.

Yesterday, I tested a main server + thin client server installation
using a USB stick with the DVD iso on it, and the installation worked
without any flaws.  I installed on a Thinkpad X61.  This means I am
unable to reproduce this problem.  Can you provide more information
about the hardware.  Perhaps the problem only show up when there are
more than one hard drive is present?  Can you try on a machine with
only one hard drive?  I do not have any test machines with several
hard drives, so I can't test myself. :(
-- 
Happy hacking
Petter Reinholdtsen




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Edu Developers <debian-edu@lists.debian.org>:
Bug#659265; Package debian-edu-install. (Fri, 02 Mar 2012 13:37:52 GMT) Full text and rfc822 format available.

Acknowledgement sent to Lasfargues André <andre.lasfargues@univ-orleans.fr>:
Extra info received and forwarded to list. Copy sent to Debian Edu Developers <debian-edu@lists.debian.org>. (Fri, 02 Mar 2012 13:37:55 GMT) Full text and rfc822 format available.

Message #30 received at 659265@bugs.debian.org (full text, mbox):

From: Lasfargues André <andre.lasfargues@univ-orleans.fr>
To: Petter Reinholdtsen <pere@hungry.com>
Cc: 659265@bugs.debian.org
Subject: Re: Bug#659265: debian-edu-install: ltsp-build-client error during install via CD or Usb key
Date: Fri, 02 Mar 2012 14:27:32 +0100
Hello,
I can confirm that i'd no more errors with the usb key and the netinst image
but actually i will be on vacation for a week so i won't be able to test
the dvd or cd.

As soon as i return here i 'll try with a new hardware.

Thanks
André




Reply sent to Petter Reinholdtsen <pere@hungry.com>:
You have taken responsibility. (Thu, 13 Jun 2013 08:33:16 GMT) Full text and rfc822 format available.

Notification sent to andre <andre.lasfargues@univ-orleans.fr>:
Bug acknowledged by developer. (Thu, 13 Jun 2013 08:33:16 GMT) Full text and rfc822 format available.

Message #35 received at 659265-done@bugs.debian.org (full text, mbox):

From: Petter Reinholdtsen <pere@hungry.com>
To: 659265-done@bugs.debian.org
Subject: Re: Bug#659265: debian-edu-install: ltsp-build-client error during install via CD or Usb key
Date: Thu, 13 Jun 2013 10:32:26 +0200
Version: 1.712

[André Lasfargues]
> Hello,
> I can confirm that i'd no more errors with the usb key and the netinst image
> but actually i will be on vacation for a week so i won't be able to test
> the dvd or cd.
> 
> As soon as i return here i 'll try with a new hardware.

Hi.  I guess we forgot to close this bug.  I tested a USB stick
installation of Debian Edu Wheezy main+ltsp yesterday, and it worked
just fine.

-- 
Happy hacking
Petter Reinholdtsen



Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Fri, 12 Jul 2013 07:31:07 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 07:21:41 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.