Debian Bug report logs - #658684
package conflict

version graph

Package: ipxe-qemu; Maintainer for ipxe-qemu is Bastian Blank <waldi@debian.org>; Source for ipxe-qemu is src:ipxe.

Reported by: Harald Dunkel <harri@afaics.de>

Date: Sun, 5 Feb 2012 07:48:01 UTC

Severity: serious

Tags: patch

Found in version ipxe/1.0.0+git-20120202.f6840ba-2

Fixed in version ipxe/1.0.0+git-20120202.f6840ba-3

Done: Bastian Blank <waldi@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Bastian Blank <waldi@debian.org>:
Bug#658684; Package ipxe-qemu. (Sun, 05 Feb 2012 07:48:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Harald Dunkel <harri@afaics.de>:
New Bug report received and forwarded. Copy sent to Bastian Blank <waldi@debian.org>. (Sun, 05 Feb 2012 07:48:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Harald Dunkel <harri@afaics.de>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: package conflict
Date: Sun, 05 Feb 2012 08:33:04 +0100
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Package: ipxe-qemu
Version: 1.0.0+git-20120202.f6840ba-2

Trying to install ipxe-qemu I got this:

Selecting previously unselected package ipxe-qemu.
(Reading database ... 163655 files and directories currently installed.)
Unpacking ipxe-qemu (from .../ipxe-qemu_1.0.0+git-20120202.f6840ba-2_all.deb) ...
dpkg: error processing /var/cache/apt/archives/ipxe-qemu_1.0.0+git-20120202.f6840ba-2_all.deb (--unpack):
 trying to overwrite '/usr/lib/ipxe/e1000_82540.rom', which is also in package ipxe 1.0.0+git-20120202.f6840ba-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/ipxe-qemu_1.0.0+git-20120202.f6840ba-2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Obviously the new ipxe-qemu package conflicts with the old ipxe
package. I would suggest to add the appropriate Conflicts line
to the control file.


Regards

Harri
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk8uMKsACgkQUTlbRTxpHjckygCfcA8sliFkIJIyuYkrcdWu6oGC
J0MAnjPLyn8BO0pY8zOu1MfvaosMAb1a
=1ksP
-----END PGP SIGNATURE-----




Information forwarded to debian-bugs-dist@lists.debian.org, Bastian Blank <waldi@debian.org>:
Bug#658684; Package ipxe-qemu. (Tue, 07 Feb 2012 01:57:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Vagrant Cascadian <vagrant@debian.org>:
Extra info received and forwarded to list. Copy sent to Bastian Blank <waldi@debian.org>. (Tue, 07 Feb 2012 01:57:09 GMT) Full text and rfc822 format available.

Message #10 received at 658684@bugs.debian.org (full text, mbox):

From: Vagrant Cascadian <vagrant@debian.org>
To: 658684@bugs.debian.org
Subject: ipxe-qemu: add Breaks/Replaces ipxe
Date: Mon, 6 Feb 2012 17:52:43 -0800
tags 658684 patch
thanks

Package: ipxe-qemu
Version: 1.0.0+git-20120202.f6840ba-2

since ipxe-qemu is taking over files that were previously shipped in ipxe, it 
should declare a versioned Breaks/Replaces relationship, as described in debian 
policy 7.6.1.

diff --git a/debian/control b/debian/control
index 321d78d..34b1790 100644
--- a/debian/control
+++ b/debian/control
@@ -28,6 +28,8 @@ Description: PXE boot firmware
 Package: ipxe-qemu
 Architecture: all
 Depends: ${misc:Depends}
+Breaks: ipxe (<< 1.0.0+git-20120202.f6840ba-2)
+Replaces: ipxe (<< 1.0.0+git-20120202.f6840ba-2)
 Description: PXE boot firmware - ROM images for qemu
  iPXE is network boot firmware.  It supports a variety of network cards,
  including some wireless cards, and variety of network protocols (traditional


live well,
  vagrant




Added tag(s) patch. Request was from Vagrant Cascadian <vagrant@debian.org> to control@bugs.debian.org. (Tue, 07 Feb 2012 01:57:10 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Bastian Blank <waldi@debian.org>:
Bug#658684; Package ipxe-qemu. (Tue, 07 Feb 2012 06:33:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Tokarev <mjt@tls.msk.ru>:
Extra info received and forwarded to list. Copy sent to Bastian Blank <waldi@debian.org>. (Tue, 07 Feb 2012 06:33:05 GMT) Full text and rfc822 format available.

Message #17 received at 658684@bugs.debian.org (full text, mbox):

From: Michael Tokarev <mjt@tls.msk.ru>
To: Vagrant Cascadian <vagrant@debian.org>, 658684@bugs.debian.org
Subject: Re: Bug#658684: ipxe-qemu: add Breaks/Replaces ipxe
Date: Tue, 07 Feb 2012 10:21:24 +0400
On 07.02.2012 05:52, Vagrant Cascadian wrote:
> tags 658684 patch
> thanks
> 
> Package: ipxe-qemu
> Version: 1.0.0+git-20120202.f6840ba-2
> 
> since ipxe-qemu is taking over files that were previously shipped in ipxe, it 
> should declare a versioned Breaks/Replaces relationship, as described in debian 
> policy 7.6.1.
> 
> diff --git a/debian/control b/debian/control
> index 321d78d..34b1790 100644
> --- a/debian/control
> +++ b/debian/control
> @@ -28,6 +28,8 @@ Description: PXE boot firmware
>  Package: ipxe-qemu
>  Architecture: all
>  Depends: ${misc:Depends}
> +Breaks: ipxe (<< 1.0.0+git-20120202.f6840ba-2)
> +Replaces: ipxe (<< 1.0.0+git-20120202.f6840ba-2)

It is not Breaks it is Conflicts.

/mjt




Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#658684; Package ipxe-qemu. (Tue, 07 Feb 2012 07:18:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Bastian Blank <waldi@debian.org>:
Extra info received and forwarded to list. (Tue, 07 Feb 2012 07:18:05 GMT) Full text and rfc822 format available.

Message #22 received at 658684@bugs.debian.org (full text, mbox):

From: Bastian Blank <waldi@debian.org>
To: Michael Tokarev <mjt@tls.msk.ru>, 658684@bugs.debian.org
Cc: Vagrant Cascadian <vagrant@debian.org>
Subject: Re: Bug#658684: ipxe-qemu: add Breaks/Replaces ipxe
Date: Tue, 7 Feb 2012 08:14:13 +0100
On Tue, Feb 07, 2012 at 10:21:24AM +0400, Michael Tokarev wrote:
> On 07.02.2012 05:52, Vagrant Cascadian wrote:
> > +Breaks: ipxe (<< 1.0.0+git-20120202.f6840ba-2)
> > +Replaces: ipxe (<< 1.0.0+git-20120202.f6840ba-2)
> It is not Breaks it is Conflicts.

Breaks is correct for this case.

Bastian

-- 
The more complex the mind, the greater the need for the simplicity of play.
		-- Kirk, "Shore Leave", stardate 3025.8




Severity set to 'serious' from 'normal' Request was from Josh Triplett <josh@joshtriplett.org> to control@bugs.debian.org. (Tue, 07 Feb 2012 12:27:11 GMT) Full text and rfc822 format available.

Reply sent to Bastian Blank <waldi@debian.org>:
You have taken responsibility. (Tue, 07 Feb 2012 15:36:42 GMT) Full text and rfc822 format available.

Notification sent to Harald Dunkel <harri@afaics.de>:
Bug acknowledged by developer. (Tue, 07 Feb 2012 15:36:42 GMT) Full text and rfc822 format available.

Message #29 received at 658684-close@bugs.debian.org (full text, mbox):

From: Bastian Blank <waldi@debian.org>
To: 658684-close@bugs.debian.org
Subject: Bug#658684: fixed in ipxe 1.0.0+git-20120202.f6840ba-3
Date: Tue, 07 Feb 2012 15:33:50 +0000
Source: ipxe
Source-Version: 1.0.0+git-20120202.f6840ba-3

We believe that the bug you reported is fixed in the latest version of
ipxe, which is due to be installed in the Debian FTP archive:

ipxe-qemu_1.0.0+git-20120202.f6840ba-3_all.deb
  to main/i/ipxe/ipxe-qemu_1.0.0+git-20120202.f6840ba-3_all.deb
ipxe_1.0.0+git-20120202.f6840ba-3.debian.tar.gz
  to main/i/ipxe/ipxe_1.0.0+git-20120202.f6840ba-3.debian.tar.gz
ipxe_1.0.0+git-20120202.f6840ba-3.dsc
  to main/i/ipxe/ipxe_1.0.0+git-20120202.f6840ba-3.dsc
ipxe_1.0.0+git-20120202.f6840ba-3_all.deb
  to main/i/ipxe/ipxe_1.0.0+git-20120202.f6840ba-3_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 658684@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Bastian Blank <waldi@debian.org> (supplier of updated ipxe package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 07 Feb 2012 16:09:43 +0100
Source: ipxe
Binary: ipxe ipxe-qemu
Architecture: source all
Version: 1.0.0+git-20120202.f6840ba-3
Distribution: unstable
Urgency: low
Maintainer: Bastian Blank <waldi@debian.org>
Changed-By: Bastian Blank <waldi@debian.org>
Description: 
 ipxe       - PXE boot firmware
 ipxe-qemu  - PXE boot firmware - ROM images for qemu
Closes: 658684 658982
Changes: 
 ipxe (1.0.0+git-20120202.f6840ba-3) unstable; urgency=low
 .
   * Fix to break qemu-system instead of qemu. (closes: #658982)
   * Make ipxe-qemu break and replace ipxe. (closes: #658684)
   * Add link for ipxe.lkrn, so all images can be found in one location.
Checksums-Sha1: 
 b9998c10300846937ca97cbe78948a5fbda4e429 1230 ipxe_1.0.0+git-20120202.f6840ba-3.dsc
 21eabb26ca16924f29ee1360ecbcd2cec66f38f7 7328 ipxe_1.0.0+git-20120202.f6840ba-3.debian.tar.gz
 67e041449042e3dff0b36f8a2fcbe2bc4dc2c1cf 1149236 ipxe_1.0.0+git-20120202.f6840ba-3_all.deb
 bc80e87fa0bf0be322d32257f3df696f3fd6ad46 390872 ipxe-qemu_1.0.0+git-20120202.f6840ba-3_all.deb
Checksums-Sha256: 
 5e6479c0f5527bb6dbd3fdca6df32f85b326cf4ec0e840a7e016ddb686c35649 1230 ipxe_1.0.0+git-20120202.f6840ba-3.dsc
 2effc46b211fd8f6272020cd018649e0d4c3535d0a407262c6d42778dc81bb84 7328 ipxe_1.0.0+git-20120202.f6840ba-3.debian.tar.gz
 38628578301ee039d36656ef7fb4c4e2133647fcbe8f41f1d1b405977e750362 1149236 ipxe_1.0.0+git-20120202.f6840ba-3_all.deb
 e99b959b565e3a4684161600d88fff50eae18c9ecaf9725dfeb71a5c9187e152 390872 ipxe-qemu_1.0.0+git-20120202.f6840ba-3_all.deb
Files: 
 c26db60f598d76b63d42872483e1c160 1230 admin optional ipxe_1.0.0+git-20120202.f6840ba-3.dsc
 a80b1010055b91fa4646d67366477fa0 7328 admin optional ipxe_1.0.0+git-20120202.f6840ba-3.debian.tar.gz
 23fa39c404270229b767a92a67147fdb 1149236 admin optional ipxe_1.0.0+git-20120202.f6840ba-3_all.deb
 8c031f4f209b70f11043ccdf74b8b03d 390872 admin optional ipxe-qemu_1.0.0+git-20120202.f6840ba-3_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAk8xQDMACgkQLkAIIn9ODhGA5gCfRP4rGwlJ5PQCKH9g2Lv8QOy9
jvMAoNQvrJKOLRG/Ud/UbcFHsiZTq5bk
=M5Sv
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 17 Mar 2012 07:43:10 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 15:52:18 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.