Debian Bug report logs - #657413
gridengine-common: fails to upgrade from squeeze - trying to overwrite /usr/share/gridengine/qlogin-wrapper

version graph

Package: gridengine-common; Maintainer for gridengine-common is Debian Grid Engine Maintainers <pkg-gridengine-devel@lists.alioth.debian.org>; Source for gridengine-common is src:gridengine.

Reported by: Andreas Beckmann <debian@abeckmann.de>

Date: Thu, 26 Jan 2012 04:03:01 UTC

Severity: serious

Found in versions gridengine/6.2u5-4, gridengine/6.2u5-5

Fixed in version gridengine/6.2u5-7

Done: Mark Hymers <mhy@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Grid Engine Maintainers <pkg-gridengine-devel@lists.alioth.debian.org>:
Bug#657413; Package gridengine-common. (Thu, 26 Jan 2012 04:03:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Beckmann <debian@abeckmann.de>:
New Bug report received and forwarded. Copy sent to Debian Grid Engine Maintainers <pkg-gridengine-devel@lists.alioth.debian.org>. (Thu, 26 Jan 2012 04:03:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Andreas Beckmann <debian@abeckmann.de>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: gridengine-common: fails to upgrade from squeeze - trying to overwrite ...
Date: Thu, 26 Jan 2012 04:58:47 +0100
[Message part 1 (text/plain, inline)]
Package: gridengine-common
Version: 6.2u5-4
Severity: serious
User: debian-qa@lists.debian.org
Usertags: piuparts

Hi,

during a test with piuparts I noticed your package fails to upgrade from
'squeeze'.
It installed fine in 'squeeze', then the upgrade to 'wheezy' fails
because it tries to overwrite other packages files without declaring a
replaces relation.

See policy 7.6 at
http://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces

>From the attached log (scroll to the bottom...):

  Preparing to replace gridengine-common 6.2u5-1 (using .../gridengine-common_6.2u5-4_all.deb) ...
  Unpacking replacement gridengine-common ...
  dpkg: error processing /var/cache/apt/archives/gridengine-common_6.2u5-4_all.deb (--unpack):
   trying to overwrite '/usr/share/gridengine/qlogin-wrapper', which is also in package gridengine-client 6.2u5-1
  configured to not write apport reports
  dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
  postinst called with unknown argument `abort-upgrade'
  dpkg: error while cleaning up:
   subprocess installed post-installation script returned error exit status 1


cheers,

Andreas
[gridengine-client_6.2u5-4.log.gz (application/x-gzip, attachment)]

Added indication that 657413 affects gridengine-client Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Thu, 26 Jan 2012 04:57:11 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Grid Engine Maintainers <pkg-gridengine-devel@lists.alioth.debian.org>:
Bug#657413; Package gridengine-common. (Mon, 23 Apr 2012 01:27:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Dominique Belhachemi <domibel@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Grid Engine Maintainers <pkg-gridengine-devel@lists.alioth.debian.org>. (Mon, 23 Apr 2012 01:27:03 GMT) Full text and rfc822 format available.

Message #12 received at 657413@bugs.debian.org (full text, mbox):

From: Dominique Belhachemi <domibel@debian.org>
To: 657413@bugs.debian.org
Date: Sun, 22 Apr 2012 21:25:04 -0400
I am going to upload a simple workaround very soon. I just have to
update patches/110-kernel.diff .

-Dominique




Changed Bug title to 'gridengine-common: fails to upgrade from squeeze - trying to overwrite /usr/share/gridengine/qlogin-wrapper' from 'gridengine-common: fails to upgrade from squeeze - trying to overwrite ...' Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Thu, 03 May 2012 13:54:33 GMT) Full text and rfc822 format available.

Marked as found in versions gridengine/6.2u5-5. Request was from Andreas Beckmann <debian@abeckmann.de> to control@bugs.debian.org. (Thu, 03 May 2012 13:54:34 GMT) Full text and rfc822 format available.

Reply sent to Mark Hymers <mhy@debian.org>:
You have taken responsibility. (Sun, 13 May 2012 20:54:06 GMT) Full text and rfc822 format available.

Notification sent to Andreas Beckmann <debian@abeckmann.de>:
Bug acknowledged by developer. (Sun, 13 May 2012 20:54:07 GMT) Full text and rfc822 format available.

Message #21 received at 657413-close@bugs.debian.org (full text, mbox):

From: Mark Hymers <mhy@debian.org>
To: 657413-close@bugs.debian.org
Subject: Bug#657413: fixed in gridengine 6.2u5-7
Date: Sun, 13 May 2012 20:51:25 +0000
Source: gridengine
Source-Version: 6.2u5-7

We believe that the bug you reported is fixed in the latest version of
gridengine, which is due to be installed in the Debian FTP archive:

gridengine-client_6.2u5-7_amd64.deb
  to main/g/gridengine/gridengine-client_6.2u5-7_amd64.deb
gridengine-common_6.2u5-7_all.deb
  to main/g/gridengine/gridengine-common_6.2u5-7_all.deb
gridengine-drmaa-dev_6.2u5-7_amd64.deb
  to main/g/gridengine/gridengine-drmaa-dev_6.2u5-7_amd64.deb
gridengine-drmaa1.0_6.2u5-7_amd64.deb
  to main/g/gridengine/gridengine-drmaa1.0_6.2u5-7_amd64.deb
gridengine-exec_6.2u5-7_amd64.deb
  to main/g/gridengine/gridengine-exec_6.2u5-7_amd64.deb
gridengine-master_6.2u5-7_amd64.deb
  to main/g/gridengine/gridengine-master_6.2u5-7_amd64.deb
gridengine-qmon_6.2u5-7_amd64.deb
  to main/g/gridengine/gridengine-qmon_6.2u5-7_amd64.deb
gridengine_6.2u5-7.diff.gz
  to main/g/gridengine/gridengine_6.2u5-7.diff.gz
gridengine_6.2u5-7.dsc
  to main/g/gridengine/gridengine_6.2u5-7.dsc
libdrmaa-java_6.2u5-7_amd64.deb
  to main/g/gridengine/libdrmaa-java_6.2u5-7_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 657413@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Mark Hymers <mhy@debian.org> (supplier of updated gridengine package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Sun, 13 May 2012 17:21:27 +0100
Source: gridengine
Binary: gridengine-common gridengine-client gridengine-qmon gridengine-master gridengine-exec gridengine-drmaa1.0 libdrmaa-java gridengine-drmaa-dev
Architecture: source all amd64
Version: 6.2u5-7
Distribution: unstable
Urgency: low
Maintainer: Debian Grid Engine Maintainers <pkg-gridengine-devel@lists.alioth.debian.org>
Changed-By: Mark Hymers <mhy@debian.org>
Description: 
 gridengine-client - Utilities for Grid Engine queue management
 gridengine-common - Distributed resource management - common files
 gridengine-drmaa-dev - Distributed resource management Application API library
 gridengine-drmaa1.0 - Distributed resource management Application API library
 gridengine-exec - Distributed resource management - Execution Server
 gridengine-master - Distributed resource management - Master Server
 gridengine-qmon - Graphical utilities for Grid Engine queue management
 libdrmaa-java - Distributed resource management Application API library - Java bi
Closes: 657413
Changes: 
 gridengine (6.2u5-7) unstable; urgency=low
 .
   * gridengine-common: Add Replaces gridengine-client << 6.2u5-2 to avoid
     issues with qlogin-wrapper.  Closes: #657413.
Checksums-Sha1: 
 c2e24086a0696f5417086553b063adc5318aa395 2592 gridengine_6.2u5-7.dsc
 d2523d405486768f4bf3ac08fbaab5f3b4d80086 48929 gridengine_6.2u5-7.diff.gz
 425a4c255c17eb5f2ba64b0133b2bf4d01a7be57 424274 gridengine-common_6.2u5-7_all.deb
 07747575a87a3bece85e0545238d3a6c690bf487 10460874 gridengine-client_6.2u5-7_amd64.deb
 77cae64015b15f8fddbe47e153b736a4ff974aff 1674540 gridengine-qmon_6.2u5-7_amd64.deb
 7d8d619235fcef0749a85ad3847ff06a7fac15bc 6148290 gridengine-master_6.2u5-7_amd64.deb
 cb7f86450e06407ab7c0d4b3e7baa98c488fbb6a 1711570 gridengine-exec_6.2u5-7_amd64.deb
 bd47f2b2d7f526106d4af8840235b877d73fb503 816648 gridengine-drmaa1.0_6.2u5-7_amd64.deb
 f0794418e94097de9231297ec46085941acd69f9 2401522 libdrmaa-java_6.2u5-7_amd64.deb
 549745cd8e91fcd4d73456e553a3d8cfcc8b63dc 53540 gridengine-drmaa-dev_6.2u5-7_amd64.deb
Checksums-Sha256: 
 ad9f4de246fe0efe2b9a60b8f0239605a70074b26001143f5e0ed8addd1d08b3 2592 gridengine_6.2u5-7.dsc
 7f2299a525b67dc84f59396032c1388fcce2cd45c9386602178cca3252027ab8 48929 gridengine_6.2u5-7.diff.gz
 46963c093fa81d8bfb6fcaf56e476881f7032a76b352ca77ba6e9a6a0798aaf5 424274 gridengine-common_6.2u5-7_all.deb
 fb7c5d6eb1a3a3703aeed1450901461cac2ac3829600ea004b5cd9398cc0e9a8 10460874 gridengine-client_6.2u5-7_amd64.deb
 f1305b445b88af51fcf5b3e0bcd15f8a902ef9f95774b74c7b6f5ea6d2611be3 1674540 gridengine-qmon_6.2u5-7_amd64.deb
 3460e063144136295bac89f80e9b0477644fd5fb801f2e581546d360ab082f0b 6148290 gridengine-master_6.2u5-7_amd64.deb
 5dfcfd9c16282a5e6f8f7c82e6dab6875f211024c55ec252215ee017d9cf87f3 1711570 gridengine-exec_6.2u5-7_amd64.deb
 d1870ea6141e84ac4b870d4de2a79bf47cf172825b7d4e10a64dd41708a34a3e 816648 gridengine-drmaa1.0_6.2u5-7_amd64.deb
 4b84f090a106ebdec0bffde85d89e0525c7ba96c9eb8dff3dc73ce3b2b8c35d6 2401522 libdrmaa-java_6.2u5-7_amd64.deb
 3d75eae3b564c24777dda804b13c2e2eb21e6a98489fe8fa50a006284109639a 53540 gridengine-drmaa-dev_6.2u5-7_amd64.deb
Files: 
 fbcbcd169c1ada3b65c4ce041fcf0974 2592 utils optional gridengine_6.2u5-7.dsc
 dc3749b7ba0316c71820b0807e4ce23a 48929 utils optional gridengine_6.2u5-7.diff.gz
 9909fa811f3e64fd93ee8c77cd95254b 424274 utils optional gridengine-common_6.2u5-7_all.deb
 013a5b43d501e0e57b0240f74c4a8b6a 10460874 utils optional gridengine-client_6.2u5-7_amd64.deb
 33dd9a8628f69698cb348b1132806f8a 1674540 utils optional gridengine-qmon_6.2u5-7_amd64.deb
 56b98b0934a196b2cf2bf274f63babbe 6148290 utils optional gridengine-master_6.2u5-7_amd64.deb
 c140df72dc100babf48d477819a024b9 1711570 utils optional gridengine-exec_6.2u5-7_amd64.deb
 46e026e956ede26cf458b8bb2dc2fb4e 816648 libs optional gridengine-drmaa1.0_6.2u5-7_amd64.deb
 ca12869b1a55630a31dbbca310b7d22d 2401522 java optional libdrmaa-java_6.2u5-7_amd64.deb
 478d99f0e2c00ca9f43fd018fb1f00bd 53540 libdevel optional gridengine-drmaa-dev_6.2u5-7_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJPsBeZAAoJEBG05f8VsP2C+9IP+wdLtnfHLigZ/1uMDXoUNYY7
EF2o0LNVeAPfn94QmTPZwGiy+uySOSdllrgnYUSN949KXJhBQEJYFbp+odWq2oe1
QBOt7r7ECVDHcXtwHGNd6o55R8+mPs6vnQdxxwOi6bguPKZ/xsnVl27GZQjPPSaJ
PXFD2JdIvIhMtwZU6dBaaKJ8RXrNTMr2TSHbZcmRkYdFkwJgczXuuInoxJuB5kkR
9YHyWJVP98dJj7214n0ANHJ6WVfUzuxSdXpdOb+yqIeiwhsExJY6Eb+uaZ9ypMzs
1g9phyMYwfwAC0PG144jk+/ag8RzrAOMvevlz1QAWT9qdyTZNxl7Y1x/NuFHrn61
u6WPIdNiR0cU5gTGnlyHU3axjaKvtpRB2pHaaA9K8rJ9hDwhqk6H/O7ok3PPBcMV
i1o6dfGxugfdg5A1SAynsNAH3f6GgrbFpi7lVC39R6X0mmXjS9HPtklR9e5/BA1U
48GzYgpYi4YhOWYPhB8qK3Pt8expFF1Wz8xS5LTAyT12tN6NgiW8kFb+zOw4rElL
nduND+M7OCwy2jhGpfApzabWvnjcKfnLgJkfB572T84p0Rxe6s7nd8OXZEksiCOt
pEeNVnGf4KxZAlOfiB1LH58VWYTD5LXHku0pRky+uf3n2oRoESq26N9ts5PE7u38
vPj05GV8lA9L966Hl+1l
=gRp8
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 13 Jun 2012 07:34:38 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 05:18:57 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.