Debian Bug report logs - #655158
pu: base-installer & libdebian-installer: Power 7 support

version graph

Package: release.debian.org; Maintainer for release.debian.org is Debian Release Team <debian-release@lists.debian.org>;

Reported by: Aurelien Jarno <aurel32@debian.org>

Date: Sun, 8 Jan 2012 21:27:01 UTC

Severity: normal

Tags: confirmed, squeeze

Fixed in version 6.0.4

Done: "Adam D. Barratt" <adam@adam-barratt.org.uk>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, debian-boot@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#655158; Package release.debian.org. (Sun, 08 Jan 2012 21:27:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Aurelien Jarno <aurel32@debian.org>:
New Bug report received and forwarded. Copy sent to debian-boot@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>. (Sun, 08 Jan 2012 21:27:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Aurelien Jarno <aurel32@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: pu: base-installer & libdebian-installer: Power 7 support
Date: Sun, 08 Jan 2012 22:25:08 +0100
Package: release.debian.org
Severity: normal
User: release.debian.org@packages.debian.org
Usertags: pu

Hi,

Debian Squeeze is currently not installable on Power 7 based IBM 
pSeries, unless the Power 6 compatibility mode is enabled. Latest 
version of QEMU is also emulating a Power 7 pSeries, but doesn't have 
this compatibility mode, which make difficult to install Debian on it.

Given this can be fixed by two one liner in base-installer and
libdebian-installer, I think we should fix that in the next point
release. I have put below the diff, would it be ok to upload these
packages?

Thanks,
Aurelien


base-installer
--------------

diff --git a/debian/changelog b/debian/changelog
index 922120f..1732db0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+base-installer (1.115+squeeze1) squeeze; urgency=low
+
+  * Add POWER7 to the powerpc64 family. (Closes: #637519)
+
+ -- Aurelien Jarno <aurel32@debian.org>  Tue, 03 Jan 2012 13:38:24 +0100
+
 base-installer (1.115) unstable; urgency=low
 
   [ Miguel Figueiredo ]
diff --git a/kernel/powerpc.sh b/kernel/powerpc.sh
index 34d18e9..578ba1a 100644
--- a/kernel/powerpc.sh
+++ b/kernel/powerpc.sh
@@ -1,7 +1,7 @@
 arch_get_kernel_flavour () {
 	CPU=`grep '^cpu[[:space:]]*:' "$CPUINFO" | head -n1 | cut -d: -f2 | sed 's/^ *//; s/[, ].*//' | tr A-Z a-z`
 	case "$CPU" in
-	    power3|power4|power4+|ppc970*|power5|power5+|power6|power6x)
+	    power3|power4|power4+|ppc970*|power5|power5+|power6|power6x|power7)
 		family=powerpc64 ;;
 	    cell|i-star|s-star|pa6t|rs64-*)
 		family=powerpc64 ;;


libdebian-installer
-------------------

diff --git a/debian/changelog b/debian/changelog
index e7216d0..33227c6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+libdebian-installer (0.77+squeeze3) squeeze; urgency=low
+
+  * Detect IBM pSeries platform as powerpc/chrp_ibm.
+
+ -- Aurelien Jarno <aurel32@debian.org>  Tue, 03 Jan 2012 10:06:58 +0100
+
 libdebian-installer (0.77+squeeze2) squeeze; urgency=low
 
   * Upload to drop .git from source tarball
diff --git a/src/system/subarch-powerpc-linux.c b/src/system/subarch-powerpc-linux.c
index c4713e4..a91a434 100644
--- a/src/system/subarch-powerpc-linux.c
+++ b/src/system/subarch-powerpc-linux.c
@@ -34,6 +34,7 @@ static struct map map_platform[] = {
 	{ "Cell", "cell" },
 	{ "PA Semi", "pasemi" },
 	{ "Maple", "chrp_ibm" },
+	{ "pSeries", "chrp_ibm" },
 	{ NULL, NULL }
 };
 

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#655158; Package release.debian.org. (Mon, 09 Jan 2012 21:18:16 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Adam D. Barratt" <adam@adam-barratt.org.uk>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Mon, 09 Jan 2012 21:18:22 GMT) Full text and rfc822 format available.

Message #10 received at 655158@bugs.debian.org (full text, mbox):

From: "Adam D. Barratt" <adam@adam-barratt.org.uk>
To: Aurelien Jarno <aurel32@debian.org>, 655158@bugs.debian.org
Subject: Re: Bug#655158: pu: base-installer & libdebian-installer: Power 7 support
Date: Mon, 09 Jan 2012 21:09:50 +0000
tag 655158 + squeeze confirmed
thanks

On Sun, 2012-01-08 at 22:25 +0100, Aurelien Jarno wrote:
> Debian Squeeze is currently not installable on Power 7 based IBM 
> pSeries, unless the Power 6 compatibility mode is enabled. Latest 
> version of QEMU is also emulating a Power 7 pSeries, but doesn't have 
> this compatibility mode, which make difficult to install Debian on it.
> 
> Given this can be fixed by two one liner in base-installer and
> libdebian-installer, I think we should fix that in the next point
> release. I have put below the diff, would it be ok to upload these
> packages?

Please go ahead; thanks.

Regards,

Adam





Added tag(s) squeeze and confirmed. Request was from "Adam D. Barratt" <adam@adam-barratt.org.uk> to control@bugs.debian.org. (Mon, 09 Jan 2012 21:18:26 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#655158; Package release.debian.org. (Mon, 09 Jan 2012 22:24:45 GMT) Full text and rfc822 format available.

Acknowledgement sent to Aurelien Jarno <aurel32@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Mon, 09 Jan 2012 22:24:45 GMT) Full text and rfc822 format available.

Message #17 received at 655158@bugs.debian.org (full text, mbox):

From: Aurelien Jarno <aurel32@debian.org>
To: "Adam D. Barratt" <adam@adam-barratt.org.uk>
Cc: 655158@bugs.debian.org
Subject: Re: Bug#655158: pu: base-installer & libdebian-installer: Power 7 support
Date: Mon, 9 Jan 2012 23:00:16 +0100
On Mon, Jan 09, 2012 at 09:09:50PM +0000, Adam D. Barratt wrote:
> tag 655158 + squeeze confirmed
> thanks
> 
> On Sun, 2012-01-08 at 22:25 +0100, Aurelien Jarno wrote:
> > Debian Squeeze is currently not installable on Power 7 based IBM 
> > pSeries, unless the Power 6 compatibility mode is enabled. Latest 
> > version of QEMU is also emulating a Power 7 pSeries, but doesn't have 
> > this compatibility mode, which make difficult to install Debian on it.
> > 
> > Given this can be fixed by two one liner in base-installer and
> > libdebian-installer, I think we should fix that in the next point
> > release. I have put below the diff, would it be ok to upload these
> > packages?
> 
> Please go ahead; thanks.
> 

Done, thanks.

Best regards,
Aurelien

-- 
Aurelien Jarno	                        GPG: 1024D/F1BCDB73
aurelien@aurel32.net                 http://www.aurel32.net




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#655158; Package release.debian.org. (Tue, 10 Jan 2012 13:15:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Adam D. Barratt" <adam@adam-barratt.org.uk>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Tue, 10 Jan 2012 13:15:06 GMT) Full text and rfc822 format available.

Message #22 received at 655158@bugs.debian.org (full text, mbox):

From: "Adam D. Barratt" <adam@adam-barratt.org.uk>
To: Aurelien Jarno <aurel32@debian.org>, <655158@bugs.debian.org>
Subject: Re: Bug#655158: pu: base-installer & libdebian-installer: Power 7 support
Date: Tue, 10 Jan 2012 13:13:35 +0000
tag 655158 + pending
thanks

On 09.01.2012 22:00, Aurelien Jarno wrote:
> On Mon, Jan 09, 2012 at 09:09:50PM +0000, Adam D. Barratt wrote:
>
>> On Sun, 2012-01-08 at 22:25 +0100, Aurelien Jarno wrote:
>> > Debian Squeeze is currently not installable on Power 7 based IBM
>> > pSeries, unless the Power 6 compatibility mode is enabled. Latest
>> > version of QEMU is also emulating a Power 7 pSeries, but doesn't 
>> have
>> > this compatibility mode, which make difficult to install Debian on 
>> it.
>> >
>> > Given this can be fixed by two one liner in base-installer and
>> > libdebian-installer, I think we should fix that in the next point
>> > release. I have put below the diff, would it be ok to upload these
>> > packages?
>>
>> Please go ahead; thanks.
>>
>
> Done, thanks.

For the record, both packages were accepted earlier today.

Regards,

Adam




Added tag(s) pending. Request was from "Adam D. Barratt" <adam@adam-barratt.org.uk> to control@bugs.debian.org. (Tue, 10 Jan 2012 13:15:12 GMT) Full text and rfc822 format available.

Bug marked as fixed in version 6.0.4, send any further explanations to Aurelien Jarno <aurel32@debian.org> Request was from "Adam D. Barratt" <adam@adam-barratt.org.uk> to control@bugs.debian.org. (Sat, 28 Jan 2012 14:06:54 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 26 Feb 2012 07:37:06 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 16:06:02 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.