Debian Bug report logs - #652285
gst-fluendo-mp3: Please transition gst-fluendo-mp3 for multiarch

version graph

Package: gst-fluendo-mp3; Maintainer for gst-fluendo-mp3 is Maintainers of GStreamer packages <pkg-gstreamer-maintainers@lists.alioth.debian.org>;

Reported by: Steve Langasek <steve.langasek@canonical.com>

Date: Thu, 15 Dec 2011 22:00:02 UTC

Severity: normal

Tags: patch

Found in version 0.10.15.debian-1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Maintainers of GStreamer packages <pkg-gstreamer-maintainers@lists.alioth.debian.org>:
Bug#652285; Package gst-fluendo-mp3. (Thu, 15 Dec 2011 22:00:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Steve Langasek <steve.langasek@canonical.com>:
New Bug report received and forwarded. Copy sent to Maintainers of GStreamer packages <pkg-gstreamer-maintainers@lists.alioth.debian.org>. (Thu, 15 Dec 2011 22:00:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Steve Langasek <steve.langasek@canonical.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: gst-fluendo-mp3: Please transition gst-fluendo-mp3 for multiarch
Date: Thu, 15 Dec 2011 13:56:38 -0800
[Message part 1 (text/plain, inline)]
Package: gst-fluendo-mp3
Version: 0.10.15.debian-1
Severity: normal
Tags: patch
User: ubuntu-devel@lists.ubuntu.com
Usertags: origin-ubuntu precise ubuntu-patch

Hi guys,

Please find attached a patch to gst-fluendo-mp3 to transition it to use of
the multiarch library paths as described at
<http://wiki.debian.org/Multiarch/Implementation>.  This patch has been
tested and included in Ubuntu Precise.

gstreamer is one of the last major bits needed to have a multiarch-friendly
wine package in Ubuntu; I presume it will be useful to Debian for the same
reason.

The changelog entry for this upload to Ubuntu is:

  * Build for multiarch.
  * Bump dependency on libgstreamer0.10-0, and build-dependency on
    libgstreamer0.10-dev, for proper multiarch support.

Note that the build-time dependency in Debian should probably be on
libgstreamer0.10-dev (>= 0.10.35.2-2), not (>= 0.10.35.2-1ubuntu2).

Thanks for considering the patch.

-- 
Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                    http://www.debian.org/
slangasek@ubuntu.com                                     vorlon@debian.org
[gst-fluendo-mp3_0.10.15.debian-1ubuntu1.debdiff (text/x-diff, attachment)]

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 15:43:36 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.