Debian Bug report logs - #651795
Fails to build against Linux 3.1

version graph

Package: lustre-source; Maintainer for lustre-source is Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>;

Reported by: Ben Hutchings <ben@decadent.org.uk>

Date: Mon, 12 Dec 2011 07:48:09 UTC

Severity: grave

Found in version lustre/1.8.5+dfsg-3

Fixed in version 1.8.5+dfsg-3.1+rm

Done: Debian FTP Masters <ftpmaster@ftp-master.debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>:
Bug#651795; Package lustre-source. (Mon, 12 Dec 2011 07:48:14 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ben Hutchings <ben@decadent.org.uk>:
New Bug report received and forwarded. Copy sent to Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>. (Mon, 12 Dec 2011 07:48:15 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Ben Hutchings <ben@decadent.org.uk>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: Fails to build against Linux 3.1
Date: Mon, 12 Dec 2011 07:35:15 +0000
Package: lustre-source
Version: 1.8.5+dfsg-3
Severity: grave

The configure script fails with Linux 3.1:

checking for /usr/src/linux-headers-3.1.0-1-amd64/.config... yes
checking for /usr/src/linux-headers-3.1.0-1-amd64/include/linux/autoconf.h... no
configure: error: Run make config in /usr/src/linux-headers-3.1.0-1-amd64.

Since Linux 2.6.33, include/linux/autoconf.h has moved to
include/generated/autoconf.h.  But there should be no need to look for
it at all.

Ben.

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.utf8, LC_CTYPE=en_GB.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages lustre-source depends on:
ii  bzip2             1.0.6-1          
ii  debhelper         8.9.11           
ii  dpatch            2.0.33           
ii  libsnmp-dev       5.4.3~dfsg-2.3+b1
ii  module-assistant  0.11.4           

lustre-source recommends no packages.

Versions of packages lustre-source suggests:
pn  ofa-kernel-source  <none>

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>:
Bug#651795; Package lustre-source. (Tue, 10 Jul 2012 11:27:30 GMT) Full text and rfc822 format available.

Acknowledgement sent to Patrick Winnertz <winnie@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>. (Tue, 10 Jul 2012 11:27:39 GMT) Full text and rfc822 format available.

Message #10 received at 651795@bugs.debian.org (full text, mbox):

From: Patrick Winnertz <winnie@debian.org>
To: 651795@bugs.debian.org
Cc: control@bugs.debian.org
Subject: linux-3.1 is not supported by upstream
Date: Tue, 10 Jul 2012 13:25:16 +0200
severity 651795 wishlist
thanks

Hey,

as shown on the support matrix from whamcloud (or of lustre.org) linux
3.1 is not supported by upstream, thus the compilation of lustre-source
against the kernel source 3.1 is really allowed to fail here. 

The correct title for this bug report should be: "Support for linux 3.1
is missing." not that it fails to compile...

In order to use lustre you are supposed to grab your kernel source
either from SLES or from kernel.org and compile manually. 

Greetings
Winnie




Severity set to 'wishlist' from 'grave' Request was from Patrick Winnertz <winnie@debian.org> to control@bugs.debian.org. (Tue, 10 Jul 2012 11:33:20 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>:
Bug#651795; Package lustre-source. (Tue, 10 Jul 2012 13:27:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Touko Korpela <touko.korpela@iki.fi>:
Extra info received and forwarded to list. Copy sent to Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>. (Tue, 10 Jul 2012 13:27:09 GMT) Full text and rfc822 format available.

Message #17 received at 651795@bugs.debian.org (full text, mbox):

From: Touko Korpela <touko.korpela@iki.fi>
To: Patrick Winnertz <winnie@debian.org>
Cc: 651795@bugs.debian.org, control@bugs.debian.org
Subject: Re: linux-3.1 is not supported by upstream
Date: Tue, 10 Jul 2012 16:24:22 +0300
severity 651795 grave
thanks

On Tue, Jul 10, 2012 at 01:25:16PM +0200, Patrick Winnertz wrote:
> severity 651795 wishlist
> thanks
> 
> Hey,
> 
> as shown on the support matrix from whamcloud (or of lustre.org) linux
> 3.1 is not supported by upstream, thus the compilation of lustre-source
> against the kernel source 3.1 is really allowed to fail here. 
> 
> The correct title for this bug report should be: "Support for linux 3.1
> is missing." not that it fails to compile...
> 
> In order to use lustre you are supposed to grab your kernel source
> either from SLES or from kernel.org and compile manually. 

Upstream support is irrelavant for this bug.
If this package don't work starting from 3.1 , then it probably won't work
with 3.2 sources that Debian now ship for wheezy (didn't test myself).
This package should be updated to work with 3.2 sources or removed.




Severity set to 'grave' from 'wishlist' Request was from Touko Korpela <touko.korpela@iki.fi> to control@bugs.debian.org. (Tue, 10 Jul 2012 13:27:21 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>:
Bug#651795; Package lustre-source. (Tue, 10 Jul 2012 14:27:11 GMT) Full text and rfc822 format available.

Acknowledgement sent to Patrick Winnertz <winnie@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>. (Tue, 10 Jul 2012 14:27:11 GMT) Full text and rfc822 format available.

Message #24 received at 651795@bugs.debian.org (full text, mbox):

From: Patrick Winnertz <winnie@debian.org>
To: Touko Korpela <touko.korpela@iki.fi>
Cc: 651795 <651795@bugs.debian.org>
Subject: Re: linux-3.1 is not supported by upstream
Date: Tue, 10 Jul 2012 16:26:17 +0200
Hey,

> Upstream support is irrelavant for this bug.
Nope it is not..

in fact this situation was exactly the same for the last two debian
releases... lustre didn't support the standard kernel in these
releases. 
this is not that bad than it sounds as lustre is a very very specific
kind of software, which is rarely/not at all used by normal users. 

This specific package is needed to build the kernel modules for the
server and the client servers of lustre - and for this you really need
plain kernel.org kernels (or SLES ones). 

I would really appreciate if we could come to the agreement, as done for
the last releases also, that the support of the standard debian kernel
is no RC bug for lustre. Loosing this type of software in debian, would
be not good. Citing wikipedia:

Because Lustre has high performance capabilities and open licensing, it
is often used in super computers. At the present time, fifteen of the
top 30 supercomputers in the world have Lustre file systems in them,
including the world's fastest TOP500 supercomputer, IBM Sequoia.
(http://en.wikipedia.org/wiki/Lustre_(file_system))

Greetings
Winnie




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>:
Bug#651795; Package lustre-source. (Tue, 10 Jul 2012 19:36:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Touko Korpela <touko.korpela@iki.fi>:
Extra info received and forwarded to list. Copy sent to Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>. (Tue, 10 Jul 2012 19:36:03 GMT) Full text and rfc822 format available.

Message #29 received at 651795@bugs.debian.org (full text, mbox):

From: Touko Korpela <touko.korpela@iki.fi>
To: Patrick Winnertz <winnie@debian.org>
Cc: Touko Korpela <touko.korpela@iki.fi>, 651795@bugs.debian.org
Subject: Re: linux-3.1 is not supported by upstream
Date: Tue, 10 Jul 2012 22:32:57 +0300
On Tue, Jul 10, 2012 at 04:26:17PM +0200, Patrick Winnertz wrote:
> Hey,
> 
> > Upstream support is irrelavant for this bug.
> Nope it is not..
> 
> in fact this situation was exactly the same for the last two debian
> releases... lustre didn't support the standard kernel in these
> releases. 
> this is not that bad than it sounds as lustre is a very very specific
> kind of software, which is rarely/not at all used by normal users. 
> 
> This specific package is needed to build the kernel modules for the
> server and the client servers of lustre - and for this you really need
> plain kernel.org kernels (or SLES ones). 
> 
> I would really appreciate if we could come to the agreement, as done for
> the last releases also, that the support of the standard debian kernel
> is no RC bug for lustre. Loosing this type of software in debian, would
> be not good. Citing wikipedia:
> 
> Because Lustre has high performance capabilities and open licensing, it
> is often used in super computers. At the present time, fifteen of the
> top 30 supercomputers in the world have Lustre file systems in them,
> including the world's fastest TOP500 supercomputer, IBM Sequoia.
> (http://en.wikipedia.org/wiki/Lustre_(file_system))

I read some basic information from homepage and Wikipedia.
Looks like 2.0, 2.1, 2.2 versions have been released in last years.
Shouldn't Debian package been updated to 2.x as well?
If staying on 1.8, 1.8.6 and later clients can interoperate 2.x servers.
But Debian package is still at 1.8.5 with some bugs that are fixed in later
versions.
Maybe you should ask wider opinion what to do with Lustre in Debian.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>:
Bug#651795; Package lustre-source. (Tue, 10 Jul 2012 23:30:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Adam D. Barratt" <adam@adam-barratt.org.uk>:
Extra info received and forwarded to list. Copy sent to Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>. (Tue, 10 Jul 2012 23:30:09 GMT) Full text and rfc822 format available.

Message #34 received at 651795@bugs.debian.org (full text, mbox):

From: "Adam D. Barratt" <adam@adam-barratt.org.uk>
To: Patrick Winnertz <winnie@debian.org>
Cc: Touko Korpela <touko.korpela@iki.fi>, 651795 <651795@bugs.debian.org>
Subject: Re: linux-3.1 is not supported by upstream
Date: Wed, 11 Jul 2012 00:26:58 +0100
On 10.07.2012 15:26, Patrick Winnertz wrote:
> I would really appreciate if we could come to the agreement, as done 
> for
> the last releases also, that the support of the standard debian 
> kernel
> is no RC bug for lustre.

Who was it previously agreed with?

Regards,

Adam




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>:
Bug#651795; Package lustre-source. (Wed, 11 Jul 2012 08:30:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Patrick Winnertz <winnie@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>. (Wed, 11 Jul 2012 08:30:04 GMT) Full text and rfc822 format available.

Message #39 received at 651795@bugs.debian.org (full text, mbox):

From: Patrick Winnertz <winnie@debian.org>
To: Touko Korpela <touko.korpela@iki.fi>
Cc: 651795 <651795@bugs.debian.org>
Subject: Re: linux-3.1 is not supported by upstream
Date: Wed, 11 Jul 2012 10:27:41 +0200
Hey,

> I read some basic information from homepage and Wikipedia.
> Looks like 2.0, 2.1, 2.2 versions have been released in last years.
> Shouldn't Debian package been updated to 2.x as well?
> If staying on 1.8, 1.8.6 and later clients can interoperate 2.x servers.
> But Debian package is still at 1.8.5 with some bugs that are fixed in later
> versions.
That's correct and there is also work on 2.2 packages for debian -
however these packages are far away from beeing stable. 1.8.5 can be
considered stable and can be used without huge problems on big clusters.

> Maybe you should ask wider opinion what to do with Lustre in Debian.
I think I don't have to do this - as written above there is work in 
progress to get 2.2 in (see our git). - However this software is not stable
enough to be considered for wheezy.

Greetings
Patrick




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>:
Bug#651795; Package lustre-source. (Thu, 12 Jul 2012 04:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Neil McGovern <neilm@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>. (Thu, 12 Jul 2012 04:51:03 GMT) Full text and rfc822 format available.

Message #44 received at 651795@bugs.debian.org (full text, mbox):

From: Neil McGovern <neilm@debian.org>
To: Patrick Winnertz <winnie@debian.org>
Cc: Touko Korpela <touko.korpela@iki.fi>, 651795 <651795@bugs.debian.org>
Subject: Re: linux-3.1 is not supported by upstream
Date: Wed, 11 Jul 2012 22:48:21 -0600
[Message part 1 (text/plain, inline)]
On Tue, Jul 10, 2012 at 04:26:17PM +0200, Patrick Winnertz wrote:
> this is not that bad than it sounds as lustre is a very very specific
> kind of software, which is rarely/not at all used by normal users. 
> 

Hi,

I don't think this is RC from a FTBFS point of view, but I'm not
entirely sure about if it would be policy compliant. The simplest way of
fixing this would be to move it from main to contrib - would you be
willing to do this as maintainer?

Thanks,
Neil
-- 
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>:
Bug#651795; Package lustre-source. (Thu, 20 Sep 2012 00:57:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Dmitrijs Ledkovs <xnox@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>. (Thu, 20 Sep 2012 00:57:03 GMT) Full text and rfc822 format available.

Message #49 received at 651795@bugs.debian.org (full text, mbox):

From: Dmitrijs Ledkovs <xnox@debian.org>
To: 651795@bugs.debian.org
Cc: Touko Korpela <touko.korpela@iki.fi>, Patrick Winnertz <winnie@debian.org>, Neil McGovern <neilm@debian.org>
Subject: RE: [lustre] linux-3.1 is not supported by upstream
Date: Thu, 20 Sep 2012 01:53:48 +0100
[Message part 1 (text/plain, inline)]
As outlined over here [1] have you considered for cherry-picking config
patches from [2].

These are patches for configuration.

On the related issues there are references to the patches for 3.0+
client support.

Can any of them be cherry-picked for Debian?


[1]
http://jira.whamcloud.com/browse/LU-858?page=com.atlassian.jira.plugin.system.issuetabpanels%3Aall-tabpanel#issue-tabs
[2] http://review.whamcloud.com/#change,3396

-- 
Regards,
Dmitrijs.

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>:
Bug#651795; Package lustre-source. (Tue, 13 Nov 2012 11:00:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Christopher Huhn <C.Huhn@gsi.de>:
Extra info received and forwarded to list. Copy sent to Debian Lustre Packaging team <pkg-lustre-maintainers@lists.alioth.debian.org>. (Tue, 13 Nov 2012 11:00:03 GMT) Full text and rfc822 format available.

Message #54 received at 651795@bugs.debian.org (full text, mbox):

From: Christopher Huhn <C.Huhn@gsi.de>
To: 651795@bugs.debian.org
Subject: Debian support for non-standard kernels
Date: Tue, 13 Nov 2012 11:51:02 +0100
[Message part 1 (text/plain, inline)]
Hi all,

because of this bug lustre-source has been removed from Wheezy. From my 
point of view that's a pity.

I wonder if there's a general Debian policy that regulates that kernel 
module sources and kernel patches are not suitable for a release if they 
are not applicable to the default release kernel.

What's the point of rolling your own kernel then?
Is there a list of kernel versions that a certain Debian release is 
compatible with (e.g. is 2.6.32 too old for Wheezy?).

Lustre may not build on > 3.1 but having the Lustre sources debianized 
and in the Debian release still eases building and deployment of lustre 
on Debian a lot. And it prevents duplication of work done by everyone 
who wants to run Lustre on Debian.

Cheers,
	Christo

[smime.p7s (application/pkcs7-signature, attachment)]

Reply sent to Debian FTP Masters <ftpmaster@ftp-master.debian.org>:
You have taken responsibility. (Sat, 21 Sep 2013 21:36:20 GMT) Full text and rfc822 format available.

Notification sent to Ben Hutchings <ben@decadent.org.uk>:
Bug acknowledged by developer. (Sat, 21 Sep 2013 21:36:20 GMT) Full text and rfc822 format available.

Message #59 received at 651795-done@bugs.debian.org (full text, mbox):

From: Debian FTP Masters <ftpmaster@ftp-master.debian.org>
To: 411603-done@bugs.debian.org,646739-done@bugs.debian.org,651795-done@bugs.debian.org,707423-done@bugs.debian.org,711701-done@bugs.debian.org,
Cc: lustre@packages.debian.org, lustre@packages.qa.debian.org
Subject: Bug#690459: Removed package(s) from unstable
Date: Sat, 21 Sep 2013 21:33:33 +0000
Version: 1.8.5+dfsg-3.1+rm

Dear submitter,

as the package lustre has just been removed from the Debian archive
unstable we hereby close the associated bug reports.  We are sorry
that we couldn't deal with your issue properly.

For details on the removal, please see http://bugs.debian.org/690459

The version of this package that was in Debian prior to this removal
can still be found using http://snapshot.debian.org/.

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing
ftpmaster@ftp-master.debian.org.

Debian distribution maintenance software
pp.
Luca Falavigna (the ftpmaster behind the curtain)



Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 20 Oct 2013 07:42:24 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 20:46:05 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.