Debian Bug report logs - #651009
libcaca0: Patch for multiarch support

version graph

Package: libcaca0; Maintainer for libcaca0 is Sam Hocevar <sho@debian.org>; Source for libcaca0 is src:libcaca.

Reported by: William A Van Hevelingen <blkperl@cat.pdx.edu>

Date: Mon, 5 Dec 2011 00:03:01 UTC

Severity: normal

Tags: patch

Merged with 651249

Found in versions 0.99.beta17-2ubuntu1, libcaca/0.99.beta17-1, libcaca/0.99.beta17-2.1

Fixed in version libcaca/0.99.beta18-1

Done: Sam Hocevar <sho@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Sam Hocevar <sho@debian.org>:
Bug#651009; Package libcaca0. (Mon, 05 Dec 2011 00:03:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to William A Van Hevelingen <blkperl@cat.pdx.edu>:
New Bug report received and forwarded. Copy sent to Sam Hocevar <sho@debian.org>. (Mon, 05 Dec 2011 00:03:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: William A Van Hevelingen <blkperl@cat.pdx.edu>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libcaca0: Patch for multiarch support
Date: Sun, 04 Dec 2011 16:01:27 -0800
[Message part 1 (text/plain, inline)]
Package: libcaca0
Version: 0.99.beta17-1
Severity: normal

Hi,

The attached patch makes libcaca0 compatible with multiarch, as described at <http://wiki.debian.org/Multiarch/Implementation>.

Thanks
--
William Van Hevelingen
blkperl@cat.pdx.edu
github.com/~blkperl

-- System Information:
Debian Release: squeeze/sid
  APT prefers natty-updates
  APT policy: (500, 'natty-updates'), (500, 'natty-security'), (500, 'natty'), (100, 'natty-backports')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.38-11-generic (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libcaca0 depends on:
ii  libc6            2.13-0ubuntu13          Embedded GNU C Library: Shared lib
ii  libgcc1          1:4.5.2-8ubuntu4        GCC support library
ii  libncursesw5     5.7+20101128-1          shared libraries for terminal hand
ii  libslang2        2.2.2-4ubuntu2          The S-Lang programming library - r
ii  libstdc++6       4.5.2-8ubuntu4          The GNU Standard C++ Library v3
ii  zlib1g           1:1.2.3.4.dfsg-3ubuntu3 compression library - runtime

libcaca0 recommends no packages.

libcaca0 suggests no packages.

-- no debconf information
[libcaca.diff (text/x-diff, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Sam Hocevar <sho@debian.org>:
Bug#651009; Package libcaca0. (Mon, 05 Dec 2011 00:45:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jakub Wilk <jwilk@debian.org>:
Extra info received and forwarded to list. Copy sent to Sam Hocevar <sho@debian.org>. (Mon, 05 Dec 2011 00:45:07 GMT) Full text and rfc822 format available.

Message #10 received at 651009@bugs.debian.org (full text, mbox):

From: Jakub Wilk <jwilk@debian.org>
To: William A Van Hevelingen <blkperl@cat.pdx.edu>, 651009@bugs.debian.org
Subject: Re: Bug#651009: libcaca0: Patch for multiarch support
Date: Mon, 5 Dec 2011 01:40:06 +0100
(I am not maintainer of this package.)

* William A Van Hevelingen <blkperl@cat.pdx.edu>, 2011-12-04, 16:01:
>The attached patch makes libcaca0 compatible with multiarch, as 
>described at <http://wiki.debian.org/Multiarch/Implementation>.

Hmm, the patch doesn't look complete. It doesn't actually add Multi-Arch 
field to any package...

> Package: libcaca-dev
> Section: libdevel
> Architecture: any
>+Pre-Depends: ${misc:Pre-Depends}

As far as I can tell, this is not needed, as libcaca-dev doesn't ship 
any shared libraries.

On the other hand, Pre-Depends *is* needed for the libcaca0 package.

-- 
Jakub Wilk




Forcibly Merged 651009 651249. Request was from Steve Langasek <vorlon@debian.org> to control@bugs.debian.org. (Wed, 07 Dec 2011 06:15:09 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Sam Hocevar <sho@debian.org>:
Bug#651009; Package libcaca0. (Thu, 15 Mar 2012 19:27:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Johannes Kloos <jkloos@unix-ag.uni-kl.de>:
Extra info received and forwarded to list. Copy sent to Sam Hocevar <sho@debian.org>. (Thu, 15 Mar 2012 19:27:04 GMT) Full text and rfc822 format available.

Message #17 received at 651009@bugs.debian.org (full text, mbox):

From: Johannes Kloos <jkloos@unix-ag.uni-kl.de>
To: Debian Bug Tracking System <651009@bugs.debian.org>
Subject: Re: libcaca0: Patch for multiarch support
Date: Thu, 15 Mar 2012 20:20:28 +0100
[Message part 1 (text/plain, inline)]
Source: libcaca
Version: 0.99.beta17-2.1
Followup-For: Bug #651009

Hi,

I've build and tested an extended version of the multi-arch patch that
fixes some problems with the patch given above (missing multi-arch
stanzas etc.). See attached file.
[multiarch.patch (text/x-diff, attachment)]

Added tag(s) patch. Request was from Frédéric Brière <fbriere@fbriere.net> to control@bugs.debian.org. (Wed, 21 Mar 2012 23:57:05 GMT) Full text and rfc822 format available.

Reply sent to Sam Hocevar <sho@debian.org>:
You have taken responsibility. (Fri, 06 Apr 2012 21:51:24 GMT) Full text and rfc822 format available.

Notification sent to William A Van Hevelingen <blkperl@cat.pdx.edu>:
Bug acknowledged by developer. (Fri, 06 Apr 2012 21:51:29 GMT) Full text and rfc822 format available.

Message #24 received at 651009-close@bugs.debian.org (full text, mbox):

From: Sam Hocevar <sho@debian.org>
To: 651009-close@bugs.debian.org
Subject: Bug#651009: fixed in libcaca 0.99.beta18-1
Date: Fri, 06 Apr 2012 21:48:42 +0000
Source: libcaca
Source-Version: 0.99.beta18-1

We believe that the bug you reported is fixed in the latest version of
libcaca, which is due to be installed in the Debian FTP archive:

caca-utils_0.99.beta18-1_amd64.deb
  to main/libc/libcaca/caca-utils_0.99.beta18-1_amd64.deb
libcaca-dev_0.99.beta18-1_amd64.deb
  to main/libc/libcaca/libcaca-dev_0.99.beta18-1_amd64.deb
libcaca0_0.99.beta18-1_amd64.deb
  to main/libc/libcaca/libcaca0_0.99.beta18-1_amd64.deb
libcaca_0.99.beta18-1.debian.tar.gz
  to main/libc/libcaca/libcaca_0.99.beta18-1.debian.tar.gz
libcaca_0.99.beta18-1.dsc
  to main/libc/libcaca/libcaca_0.99.beta18-1.dsc
libcaca_0.99.beta18.orig.tar.gz
  to main/libc/libcaca/libcaca_0.99.beta18.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 651009@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Sam Hocevar <sho@debian.org> (supplier of updated libcaca package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Fri, 06 Apr 2012 23:14:18 +0200
Source: libcaca
Binary: libcaca-dev libcaca0 caca-utils
Architecture: source amd64
Version: 0.99.beta18-1
Distribution: unstable
Urgency: low
Maintainer: Sam Hocevar <sho@debian.org>
Changed-By: Sam Hocevar <sho@debian.org>
Description: 
 caca-utils - text mode graphics utilities
 libcaca-dev - development files for libcaca
 libcaca0   - colour ASCII art library
Closes: 616254 638589 646515 651009
Changes: 
 libcaca (0.99.beta18-1) unstable; urgency=low
 .
   * New upstream release.
   * Acknowledge Gregor Herrmann's NMU (Closes: #616254, #638589).
   * Add multiarch support, courtesy of William A Van Hevelingen and
     Johannes Kloos (Closes: #651009).
   * debian/control: drop the libncurses5-dev dependency in the -dev package
     (Closes: #646515).
Checksums-Sha1: 
 0cb909f7443f237b2372045e8c990444cbef561d 2120 libcaca_0.99.beta18-1.dsc
 0cbf8075c01d59b53c3cdfec7df9818696a41128 1168552 libcaca_0.99.beta18.orig.tar.gz
 70722bd8ef1dfb6e387634098b6e140d5696ba72 8442 libcaca_0.99.beta18-1.debian.tar.gz
 696ce85e8355f1985291c5aa8340708a6de88779 1004698 libcaca-dev_0.99.beta18-1_amd64.deb
 13a2191dc123f4239dff57e307b3ab6cbf641a63 394810 libcaca0_0.99.beta18-1_amd64.deb
 7af48697dceba8e93c8ff9067c2347b0e8f90d93 208632 caca-utils_0.99.beta18-1_amd64.deb
Checksums-Sha256: 
 2f98acdf9160a49cbec92e6b668c5e5411f7e8d682921de4287c3d70dcd34cb5 2120 libcaca_0.99.beta18-1.dsc
 77ea06633f4a6022dccd4f76c1823e167a40cb05308fc1c7ea0fa1f80f6c33a1 1168552 libcaca_0.99.beta18.orig.tar.gz
 adfcd5796879b1f15c4d1af1e2e9e46577e8de9bc2cf61912c92564048e7d333 8442 libcaca_0.99.beta18-1.debian.tar.gz
 ea42f58a5317f139f2602995ad623ecf3b4f399607ba0df7ee49a87dacc9ecfa 1004698 libcaca-dev_0.99.beta18-1_amd64.deb
 f422f9dbd39682cf49b11bc9eda19febe0d0906a5250e8dccad0d92fb79b0299 394810 libcaca0_0.99.beta18-1_amd64.deb
 12c0cbe648bac9296f676440f74dc83393d8558756f0e9c34ae1eebd637ce5f4 208632 caca-utils_0.99.beta18-1_amd64.deb
Files: 
 c4a8866cc05e038251161a6691a752fe 2120 libs optional libcaca_0.99.beta18-1.dsc
 93d35dbdb0527d4c94df3e9a02e865cc 1168552 libs optional libcaca_0.99.beta18.orig.tar.gz
 e97079e0ffce937359a4f272e320ce91 8442 libs optional libcaca_0.99.beta18-1.debian.tar.gz
 63799b834396b7e20415bb6ec4a5b8ca 1004698 libdevel optional libcaca-dev_0.99.beta18-1_amd64.deb
 142f3451f24091f9ebde6b393f5fbd66 394810 libs optional libcaca0_0.99.beta18-1_amd64.deb
 f6631d374eecc7cdd5003a8f5d1c5dfe 208632 utils optional caca-utils_0.99.beta18-1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJPf2K9AAoJEAVcSzX////+xtwQAJACsPXdXwwE+shneH/g3vZt
gnXxYm3A4MVxxriTbk5PORnVKoetxK3kX0K4wiOvuDv19nRH1S3XHM6UKjSKjUWa
VSACCU+RFFrEVgAY57vOuKCsMjx7WDKDJ3uBbgao266xXoAfXXzrDSKy75cY1xnw
pfXJqA3jUMHXuxHh3HcBNIQCK09Ai91SShx3lHUa1m7MQKxBqVSivTXA7yBzKYiJ
rFly9rSBmCniX97GPaiD3K9KJZcRr3CwttGor4Yi2J0ua8+g6wrAt5uWCBdynenK
LIS9ZnDmu2agcyXDRRFNRpfunAgVIvyHwIkxJbsWk/L50bSuaCo6M7IXIAj8MTRP
gmn1oWvAKYZ76OYjkegm0XRXi+5sIp5zJbyfGqZApwu9pLKQnnXldSWTvs0E62wc
+X4Ljh16NMrNIpwDq/CJo1Wloh84Vd8jCDvb+WZC7yJrWY05NKnE7rGy8ZB0LvcT
SpgUyUzMiItekixKCCxEpwWcL+yNnA8Vdg/HvlAb4eeCxPwHisJFzrXKwQCssrYl
TagH1t2aNwTKB+N8ay22T2MdChKhq5mhWzUE2B9vV5UVozXw7Bm5S+/Lg4VQ+mo/
9WCj9xlmLDEyX1mDCaH7BpirMa2lvJyCARu/wm2iqCnGLHkOo7aUNk2gO+7KxAQE
7baS8f688C5UDLbnhc7z
=Wf3K
-----END PGP SIGNATURE-----





Reply sent to Sam Hocevar <sho@debian.org>:
You have taken responsibility. (Fri, 06 Apr 2012 21:51:35 GMT) Full text and rfc822 format available.

Notification sent to William A Van Hevelingen <blkperl@cat.pdx.edu>:
Bug acknowledged by developer. (Fri, 06 Apr 2012 21:51:38 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 11 Jun 2012 07:34:56 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 14:37:34 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.