Debian Bug report logs - #650611
libkrb5-3 breaks cups

version graph

Package: libkrb5-3; Maintainer for libkrb5-3 is Sam Hartman <hartmans@debian.org>; Source for libkrb5-3 is src:krb5.

Reported by: LUK ShunTim <shuntim.luk@polyu.edu.hk>

Date: Thu, 1 Dec 2011 08:00:02 UTC

Severity: normal

Found in version krb5/1.10+dfsg~alpha1-5

Fixed in version krb5/1.10+dfsg~alpha1-6

Done: Sam Hartman <hartmans@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Sam Hartman <hartmans@debian.org>:
Bug#650611; Package libkrb5-3. (Thu, 01 Dec 2011 08:00:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to LUK ShunTim <shuntim.luk@polyu.edu.hk>:
New Bug report received and forwarded. Copy sent to Sam Hartman <hartmans@debian.org>. (Thu, 01 Dec 2011 08:00:06 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: LUK ShunTim <shuntim.luk@polyu.edu.hk>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libkrb5-3 breaks cups
Date: Thu, 01 Dec 2011 15:52:05 +0800
Package: libkrb5-3
Version: 1.10+dfsg~alpha1-5

Severity: important

Dear Maintainer,

Upgrading to libkrb5-3 breaks cups, at least when the smb backend is used. This is excerpted from the cups log

<cups_log>
D [01/Dec/2011:14:23:16 +0800] [Job 1588] smb://123.456.789.01/hp: relocation error: smb://123.456.789.01/hp: symbol krb5_locate_kdc, version krb5_3_MIT not defined in file libkrb5.so.3 with link time reference
</cups_log>

There's a similar report bug#650603 on breaking mplayer.

Please take a look.

Regards,
ST
-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (900, 'unstable'), (500, 'gutsy'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_HK.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libkrb5-3 depends on:
ii  libc6              2.13-21
ii  libcomerr2         1.42-1
ii  libk5crypto3       1.10+dfsg~alpha1-5
ii  libkeyutils1       1.5.2-2
ii  libkrb5support0    1.10+dfsg~alpha1-5
ii  multiarch-support  2.13-21

Versions of packages libkrb5-3 recommends:
pn  krb5-locales  <none>

Versions of packages libkrb5-3 suggests:
pn  krb5-doc   <none>
pn  krb5-user  <none>

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Sam Hartman <hartmans@debian.org>:
Bug#650611; Package libkrb5-3. (Thu, 01 Dec 2011 08:06:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Russ Allbery <rra@debian.org>:
Extra info received and forwarded to list. Copy sent to Sam Hartman <hartmans@debian.org>. (Thu, 01 Dec 2011 08:06:04 GMT) Full text and rfc822 format available.

Message #10 received at 650611@bugs.debian.org (full text, mbox):

From: Russ Allbery <rra@debian.org>
To: LUK ShunTim <shuntim.luk@polyu.edu.hk>
Cc: 650611@bugs.debian.org
Subject: Re: Bug#650611: libkrb5-3 breaks cups
Date: Thu, 01 Dec 2011 00:03:29 -0800
LUK ShunTim <shuntim.luk@polyu.edu.hk> writes:

> Upgrading to libkrb5-3 breaks cups, at least when the smb backend is
> used. This is excerpted from the cups log

I'm fairly sure these are all duplicates of #650541, a bug in the Samba
libraries.

-- 
Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>




Information forwarded to debian-bugs-dist@lists.debian.org, Sam Hartman <hartmans@debian.org>:
Bug#650611; Package libkrb5-3. (Thu, 01 Dec 2011 08:33:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to LUK ShunTim <shuntim.luk@polyu.edu.hk>:
Extra info received and forwarded to list. Copy sent to Sam Hartman <hartmans@debian.org>. (Thu, 01 Dec 2011 08:33:07 GMT) Full text and rfc822 format available.

Message #15 received at 650611@bugs.debian.org (full text, mbox):

From: LUK ShunTim <shuntim.luk@polyu.edu.hk>
To: Russ Allbery <rra@debian.org>
Cc: 650611@bugs.debian.org
Subject: Re: Bug#650611: libkrb5-3 breaks cups
Date: Thu, 01 Dec 2011 16:28:58 +0800
On 12/01/2011 04:03 PM, Russ Allbery wrote:
> LUK ShunTim <shuntim.luk@polyu.edu.hk> writes:
> 
>> Upgrading to libkrb5-3 breaks cups, at least when the smb backend is
>> used. This is excerpted from the cups log
> 
> I'm fairly sure these are all duplicates of #650541, a bug in the Samba
> libraries.
> 

Thanks for looking into it.

One more piece of information. Downgrading krb5 to 1.9.1+dfsg-3 in
wheezy seems to solve the cups printing problem.

Regards,
ST
-- 





Reply sent to Sam Hartman <hartmans@debian.org>:
You have taken responsibility. (Fri, 02 Dec 2011 01:15:06 GMT) Full text and rfc822 format available.

Notification sent to LUK ShunTim <shuntim.luk@polyu.edu.hk>:
Bug acknowledged by developer. (Fri, 02 Dec 2011 01:15:06 GMT) Full text and rfc822 format available.

Message #20 received at 650611-close@bugs.debian.org (full text, mbox):

From: Sam Hartman <hartmans@debian.org>
To: 650611-close@bugs.debian.org
Subject: Bug#650611: fixed in krb5 1.10+dfsg~alpha1-6
Date: Fri, 02 Dec 2011 01:13:59 +0000
Source: krb5
Source-Version: 1.10+dfsg~alpha1-6

We believe that the bug you reported is fixed in the latest version of
krb5, which is due to be installed in the Debian FTP archive:

krb5-admin-server_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/krb5-admin-server_1.10+dfsg~alpha1-6_amd64.deb
krb5-doc_1.10+dfsg~alpha1-6_all.deb
  to main/k/krb5/krb5-doc_1.10+dfsg~alpha1-6_all.deb
krb5-gss-samples_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/krb5-gss-samples_1.10+dfsg~alpha1-6_amd64.deb
krb5-kdc-ldap_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/krb5-kdc-ldap_1.10+dfsg~alpha1-6_amd64.deb
krb5-kdc_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/krb5-kdc_1.10+dfsg~alpha1-6_amd64.deb
krb5-locales_1.10+dfsg~alpha1-6_all.deb
  to main/k/krb5/krb5-locales_1.10+dfsg~alpha1-6_all.deb
krb5-multidev_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/krb5-multidev_1.10+dfsg~alpha1-6_amd64.deb
krb5-pkinit_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/krb5-pkinit_1.10+dfsg~alpha1-6_amd64.deb
krb5-user_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/krb5-user_1.10+dfsg~alpha1-6_amd64.deb
krb5_1.10+dfsg~alpha1-6.diff.gz
  to main/k/krb5/krb5_1.10+dfsg~alpha1-6.diff.gz
krb5_1.10+dfsg~alpha1-6.dsc
  to main/k/krb5/krb5_1.10+dfsg~alpha1-6.dsc
libgssapi-krb5-2_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/libgssapi-krb5-2_1.10+dfsg~alpha1-6_amd64.deb
libgssrpc4_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/libgssrpc4_1.10+dfsg~alpha1-6_amd64.deb
libk5crypto3_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/libk5crypto3_1.10+dfsg~alpha1-6_amd64.deb
libkadm5clnt-mit8_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/libkadm5clnt-mit8_1.10+dfsg~alpha1-6_amd64.deb
libkadm5srv-mit8_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/libkadm5srv-mit8_1.10+dfsg~alpha1-6_amd64.deb
libkdb5-6_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/libkdb5-6_1.10+dfsg~alpha1-6_amd64.deb
libkrb5-3_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/libkrb5-3_1.10+dfsg~alpha1-6_amd64.deb
libkrb5-dbg_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/libkrb5-dbg_1.10+dfsg~alpha1-6_amd64.deb
libkrb5-dev_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/libkrb5-dev_1.10+dfsg~alpha1-6_amd64.deb
libkrb5support0_1.10+dfsg~alpha1-6_amd64.deb
  to main/k/krb5/libkrb5support0_1.10+dfsg~alpha1-6_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 650611@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Sam Hartman <hartmans@debian.org> (supplier of updated krb5 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 01 Dec 2011 19:34:41 -0500
Source: krb5
Binary: krb5-user krb5-kdc krb5-kdc-ldap krb5-admin-server krb5-multidev libkrb5-dev libkrb5-dbg krb5-pkinit krb5-doc libkrb5-3 libgssapi-krb5-2 libgssrpc4 libkadm5srv-mit8 libkadm5clnt-mit8 libk5crypto3 libkdb5-6 libkrb5support0 krb5-gss-samples krb5-locales
Architecture: source all amd64
Version: 1.10+dfsg~alpha1-6
Distribution: unstable
Urgency: low
Maintainer: Sam Hartman <hartmans@debian.org>
Changed-By: Sam Hartman <hartmans@debian.org>
Description: 
 krb5-admin-server - MIT Kerberos master server (kadmind)
 krb5-doc   - Documentation for MIT Kerberos
 krb5-gss-samples - MIT Kerberos GSS Sample applications
 krb5-kdc   - MIT Kerberos key server (KDC)
 krb5-kdc-ldap - MIT Kerberos key server (KDC) LDAP plugin
 krb5-locales - Internationalization support for MIT Kerberos
 krb5-multidev - Development files for MIT Kerberos without Heimdal conflict
 krb5-pkinit - PKINIT plugin for MIT Kerberos
 krb5-user  - Basic programs to authenticate using MIT Kerberos
 libgssapi-krb5-2 - MIT Kerberos runtime libraries - krb5 GSS-API Mechanism
 libgssrpc4 - MIT Kerberos runtime libraries - GSS enabled ONCRPC
 libk5crypto3 - MIT Kerberos runtime libraries - Crypto Library
 libkadm5clnt-mit8 - MIT Kerberos runtime libraries - Administration Clients
 libkadm5srv-mit8 - MIT Kerberos runtime libraries - KDC and Admin Server
 libkdb5-6  - MIT Kerberos runtime libraries - Kerberos database
 libkrb5-3  - MIT Kerberos runtime libraries
 libkrb5-dbg - Debugging files for MIT Kerberos
 libkrb5-dev - Headers and development libraries for MIT Kerberos
 libkrb5support0 - MIT Kerberos runtime libraries - Support library
Closes: 650603 650611 650671
Changes: 
 krb5 (1.10+dfsg~alpha1-6) unstable; urgency=low
 .
   * Fix segfault with unknown hostnames in krb5_sname_to_principal,
     Closes: #650671
   * Indicate that this library breaks libsmbclient versions that depend on
     krb5_locate_kdc, Closes: #650603, #650611
Checksums-Sha1: 
 90f7df035d942eb007fa4397b891239684337ca5 2293 krb5_1.10+dfsg~alpha1-6.dsc
 9e5d8f0771e2ab98554267d578d0c25e70c9d1c0 120629 krb5_1.10+dfsg~alpha1-6.diff.gz
 e5edd893fe3959a20e9b6d36a363aba82a277782 2652072 krb5-doc_1.10+dfsg~alpha1-6_all.deb
 cf379b5842ed394e451fbe7b8245c773c72bc377 1487422 krb5-locales_1.10+dfsg~alpha1-6_all.deb
 798bf8588a7528391ade5496fcf76fb5c79f4610 150000 krb5-user_1.10+dfsg~alpha1-6_amd64.deb
 81115faedde0a0bced8f2152cb2f12462cc6a08d 221954 krb5-kdc_1.10+dfsg~alpha1-6_amd64.deb
 72f7bdb103189692bfee1d6cd62424b2f3e09383 118700 krb5-kdc-ldap_1.10+dfsg~alpha1-6_amd64.deb
 6c0e6644741480496f7507d0814fc3e290473e16 121660 krb5-admin-server_1.10+dfsg~alpha1-6_amd64.deb
 1031b2c20bedcdef44937f3e4338d90044709f6b 152342 krb5-multidev_1.10+dfsg~alpha1-6_amd64.deb
 4ea645a3a8c2c4ecbf5af9b69b1bc8fa98930230 38942 libkrb5-dev_1.10+dfsg~alpha1-6_amd64.deb
 e1af4b475b1cf2be7adbe0221341de8985385697 1103852 libkrb5-dbg_1.10+dfsg~alpha1-6_amd64.deb
 302cfa5af43e20efa29e99e4a06ba98592285a60 91268 krb5-pkinit_1.10+dfsg~alpha1-6_amd64.deb
 52a83f3fa3c15c601f441783e38b1d7300c4333c 372576 libkrb5-3_1.10+dfsg~alpha1-6_amd64.deb
 cca2d021e47985b8db067461f5462857b728c586 144590 libgssapi-krb5-2_1.10+dfsg~alpha1-6_amd64.deb
 91b13bb3075830abf5554685563f3063f36c4b1b 85386 libgssrpc4_1.10+dfsg~alpha1-6_amd64.deb
 61be54931e9146194f3939423b71655a85380393 81666 libkadm5srv-mit8_1.10+dfsg~alpha1-6_amd64.deb
 1595bc046c34832ac1a19f1ef442f4dae98c44cb 65440 libkadm5clnt-mit8_1.10+dfsg~alpha1-6_amd64.deb
 b0ce7ddd0440e7a102e1b398d32c2b72d5d7a028 104728 libk5crypto3_1.10+dfsg~alpha1-6_amd64.deb
 051b7e052637fc95c6f6479f3e697db578459d76 64340 libkdb5-6_1.10+dfsg~alpha1-6_amd64.deb
 35ba4383968703812ead471be14d771131b294d0 47850 libkrb5support0_1.10+dfsg~alpha1-6_amd64.deb
 90647fde0d9335635e7ad91c8fdcc02d6151de48 50910 krb5-gss-samples_1.10+dfsg~alpha1-6_amd64.deb
Checksums-Sha256: 
 dcfb12023f0fca6155f7de89b4778a31a5a390dc311f366cdb90a0bf84d1bb8f 2293 krb5_1.10+dfsg~alpha1-6.dsc
 7e81e8ea8d065561cc0c849320ce235e793738d983b32a2cf7e2b7a62c79d95f 120629 krb5_1.10+dfsg~alpha1-6.diff.gz
 118096ddf4cc3313a1759d648d78c730d0327f96d29efc0cacdcaca653e4d53e 2652072 krb5-doc_1.10+dfsg~alpha1-6_all.deb
 a41a76e8734c6458c0ff2d91288f23a78f34d53c3b08413b2f9c1151723523f2 1487422 krb5-locales_1.10+dfsg~alpha1-6_all.deb
 cb0385797888aa4da2cf74e769337eeaddc8aa770ba621d0ac5e1de0220bc889 150000 krb5-user_1.10+dfsg~alpha1-6_amd64.deb
 a69464d61df6c9bc503f8d307ab203b7ed6ae8dcb30e80edd25c4c7b8dde15a4 221954 krb5-kdc_1.10+dfsg~alpha1-6_amd64.deb
 10b70291f33f039503e9f90f3eb83666eed427e39bcee50062ce45f9f5ffa83f 118700 krb5-kdc-ldap_1.10+dfsg~alpha1-6_amd64.deb
 4779a9dbb35aa1b1b2a2a94fef228a0be02e1284a6822054e624f158dd706629 121660 krb5-admin-server_1.10+dfsg~alpha1-6_amd64.deb
 0ed47147b1b25cde8055ed6ee8cc736a55b5657f07c3d5cdbc1910606e24bb30 152342 krb5-multidev_1.10+dfsg~alpha1-6_amd64.deb
 6274f50eea26a564ee090a9cb8d37b287369584f12a046a328eaa193d582c322 38942 libkrb5-dev_1.10+dfsg~alpha1-6_amd64.deb
 b12bffcd66e444e9e1f20bc5d49b7aa99e6eb9fb24c64615d8f6d365addcf5ee 1103852 libkrb5-dbg_1.10+dfsg~alpha1-6_amd64.deb
 94ce9e42f2f3c654dbec6c4194a2bab5720588d8821da678aa99a4e16c2c2fd3 91268 krb5-pkinit_1.10+dfsg~alpha1-6_amd64.deb
 e12ccdafc32f613f95422fb52b606389835f75008d92b8036561d0413c6a1603 372576 libkrb5-3_1.10+dfsg~alpha1-6_amd64.deb
 5db5d6f2b5f8e9d30748f657ae0fc48d6538e5d8df6fd0715bee49891c5a4e75 144590 libgssapi-krb5-2_1.10+dfsg~alpha1-6_amd64.deb
 4d8df5386f2c7f7e18bb4bb490fb57ff59fbd9a900c7110e913fa32fa8b3af77 85386 libgssrpc4_1.10+dfsg~alpha1-6_amd64.deb
 23d4edb19908bc778acf831d1be4fe7a2eb73a85ca4033bc493882b6411b3dc0 81666 libkadm5srv-mit8_1.10+dfsg~alpha1-6_amd64.deb
 564e07ed703aec48407a28ec085974195dbab119d78324611927bb8eb9b71d01 65440 libkadm5clnt-mit8_1.10+dfsg~alpha1-6_amd64.deb
 ee1bdea6ce1100cf1aaf8d316aeb109783822a293824cc457a95c4ca3e21ac6e 104728 libk5crypto3_1.10+dfsg~alpha1-6_amd64.deb
 a122b6f86659170670ba39c04b6bcce4db755599f6812ba2a52925f69f6c33f2 64340 libkdb5-6_1.10+dfsg~alpha1-6_amd64.deb
 d4c5790bc66f1ec8019895230aa80f0c64349ea9af03ccfcd635b82e172527cf 47850 libkrb5support0_1.10+dfsg~alpha1-6_amd64.deb
 5b0ff3be7af11548feab8d82f14a07076300ffadba0d76b0f659a9a3745a0d19 50910 krb5-gss-samples_1.10+dfsg~alpha1-6_amd64.deb
Files: 
 71dbb9bea670cc88b253b0e013276a4f 2293 net standard krb5_1.10+dfsg~alpha1-6.dsc
 21b7d48b8a715f68783b6eb457c7132c 120629 net standard krb5_1.10+dfsg~alpha1-6.diff.gz
 3828a8a5ce70f23b5ca415882a979918 2652072 doc optional krb5-doc_1.10+dfsg~alpha1-6_all.deb
 59ad8e121d0ca18558a522f9288c689f 1487422 localization standard krb5-locales_1.10+dfsg~alpha1-6_all.deb
 1be1e31b3c69cfc75345db5d029db8a8 150000 net optional krb5-user_1.10+dfsg~alpha1-6_amd64.deb
 9528d11e6e7ee29c898e033f1479f76d 221954 net optional krb5-kdc_1.10+dfsg~alpha1-6_amd64.deb
 212d9ea8c68f19363299f28e2d19381a 118700 net extra krb5-kdc-ldap_1.10+dfsg~alpha1-6_amd64.deb
 6e39d60170122d9621db10152f26dbdf 121660 net optional krb5-admin-server_1.10+dfsg~alpha1-6_amd64.deb
 fd6f09148be499cafc71dabd3cac053f 152342 libdevel optional krb5-multidev_1.10+dfsg~alpha1-6_amd64.deb
 b5cb49ce85fe638678f3bdfbfcb3cd39 38942 libdevel extra libkrb5-dev_1.10+dfsg~alpha1-6_amd64.deb
 304f9c88a7662c8627ecbe1286fa46ec 1103852 debug extra libkrb5-dbg_1.10+dfsg~alpha1-6_amd64.deb
 0845a3194d0a0a19b524a990c47826d2 91268 net extra krb5-pkinit_1.10+dfsg~alpha1-6_amd64.deb
 cce0122f9457ee6351d31db21af198cc 372576 libs standard libkrb5-3_1.10+dfsg~alpha1-6_amd64.deb
 7b900accc2ab2a7ca14de588f67d286f 144590 libs standard libgssapi-krb5-2_1.10+dfsg~alpha1-6_amd64.deb
 f151cf9d409bc084f58b674d2bc817c8 85386 libs standard libgssrpc4_1.10+dfsg~alpha1-6_amd64.deb
 63ab24d5cabe0b6014170c95767deb89 81666 libs standard libkadm5srv-mit8_1.10+dfsg~alpha1-6_amd64.deb
 bdfad58f7676748b8b736fb50e5cd8a4 65440 libs standard libkadm5clnt-mit8_1.10+dfsg~alpha1-6_amd64.deb
 b0c1f41589adb7c3d105708bb2f0079e 104728 libs standard libk5crypto3_1.10+dfsg~alpha1-6_amd64.deb
 83612a62e56c98eddb74d9c5e4f924f4 64340 libs standard libkdb5-6_1.10+dfsg~alpha1-6_amd64.deb
 2c2b95c3286d410322256d90b7d11a96 47850 libs standard libkrb5support0_1.10+dfsg~alpha1-6_amd64.deb
 2bcd582925490f968efc9626c9425086 50910 net extra krb5-gss-samples_1.10+dfsg~alpha1-6_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAk7YHyUACgkQ/I12czyGJg+yDQCgtHiUN3K8scyyxY3Q88tG7VCq
+rgAoO+440Lep07+rW8hwUOAKvNBZIPt
=Hxhn
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 03 Jan 2012 07:32:38 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 21:03:48 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.