Debian Bug report logs - #649221
live-build: * Edit post

version graph

Package: live-build; Maintainer for live-build is Live Systems Maintainers <debian-live@lists.debian.org>; Source for live-build is src:live-build.

Reported by: Piotr <upiter77@lycos.com>

Date: Fri, 18 Nov 2011 23:36:01 UTC

Severity: normal

Found in version live-build/2.0.12-2

Done: Daniel Baumann <daniel.baumann@progress-technologies.net>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, upiter77@lycos.com, Debian Live Project <debian-live@lists.debian.org>:
Bug#649221; Package live-build. (Fri, 18 Nov 2011 23:36:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Piotr <upiter77@lycos.com>:
New Bug report received and forwarded. Copy sent to upiter77@lycos.com, Debian Live Project <debian-live@lists.debian.org>. (Fri, 18 Nov 2011 23:36:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Piotr <upiter77@lycos.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: live-build: * Edit post
Date: Sat, 19 Nov 2011 00:32:42 +0100
Package: live-build
Version: 2.0.12-2
Severity: normal


I have created wheezy usb-hdd LIVE with XFCE using this config file:

--------------------------------------------------------------------
# cat /home/live/config/binary

# config/binary - options for live-build(7), binary livege

# $LB_BINARY_FILESYSTEM: set image filesystem
# (Default: fat32)
LB_BINARY_FILESYSTEM="fat32"

# $LB_BINARY_IMAGES: set image type
# (Default: usb-hdd)
LB_BINARY_IMAGES="usb-hdd"

# $LB_BINARY_INDICES: set apt/aptitude generic indices
# (Default: true)
LB_BINARY_INDICES="true"

# $LB_BOOTAPPEND_LIVE: set boot parameters
# (Default: empty)
LB_BOOTAPPEND_LIVE="persistent=nofiles quickreboot locales=de_DE.UTF-8 keyboard-layouts=de utc=no timezone=Europe/Amsterdam"

# $LB_BOOTAPPEND_INliveLL: set boot parameters
# (Default: empty)
LB_BOOTAPPEND_INliveLL="cdrom-detect/try-usb=true"

# $LB_BOOTLOADER: set bootloader
# (Default: syslinux)
LB_BOOTLOADER="syslinux"

# $LB_CHECKSUMS: set checksums
# (Default: md5)
LB_CHECKSUMS="md5"

# $LB_COMPRESSION: set compression
# (Default: gzip)
LB_COMPRESSION="bzip2"

# ${LB_BUILD_WITH_CHROOT: control if we build binary images chrooted
# (Default: true)
# DO NEVER, *NEVER*, *N*E*V*E*R* SET THIS OPTION to false.
LB_BUILD_WITH_CHROOT="true"

# $LB_DEBIAN_INliveLLER: set debian-inliveller
# (Default: false)
LB_DEBIAN_INliveLLER="false"

# $LB_DEBIAN_INliveLLER_DISTRIBUTION: set debian-inliveller suite
# (Default: empty)
LB_DEBIAN_INliveLLER_DISTRIBUTION="wheezy"

# $LB_DEBIAN_INliveLLER_PRESEEDFILE: set debian-inliveller preseed filename/url
# (Default: )
LB_DEBIAN_INliveLLER_PRESEEDFILE=""

# $LB_DEBIAN_INliveLLER_GUI: toggle use of GUI debian-inliveller
# (Default: true)
LB_DEBIAN_INliveLLER_GUI="false"

# $LB_ENCRYPTION: set encryption
# (Default: false)
LB_ENCRYPTION="false"

# $LB_GRUB_SPLASH: set custom grub splash
# (Default: empty)
LB_GRUB_SPLASH=""

# $LB_HOSTNAME: set hostname
# (Default: live)
LB_HOSTNAME="live"

# $LB_ISO_APPLICATION: set iso author
# (Default: debian)
LB_ISO_APPLICATION="debian"

# $LB_ISO_PREPARER: set iso preparer
# (Default: live-build $VERSION; http://packages.qa.debian.org/live-build)
LB_ISO_PREPARER="live-build $VERSION; http://packages.qa.debian.org/live-build"

# $LB_ISO_PUBLISHER: set iso publisher
# (Default: Debian Live project; http://live.debian.net/; debian-live@lists.debian.org)
LB_ISO_PUBLISHER="Debian Live project; http://live.debian.net/; debian-live@lists.debian.org"

# $LB_ISO_VOLUME: set iso volume (max 32 chars)
# (Default: Debian wheezy $(date +%Y%m%d-%H:%M))
LB_ISO_VOLUME="Debian wheezy $(date +%Y%m%d-%H:%M)"

# $LB_JFFS2_ERASEBLOCK: set jffs2 eraseblock size
# (Default: unset)
LB_JFFS2_ERASEBLOCK=""

# $LB_MEMTEST: set memtest
# (Default: memtest86+)
LB_MEMTEST="memtest86+"

# $LB_WIN32_LOADER: set win32-loader
# (Default: false)
LB_WIN32_LOADER="false"

# $LB_NET_ROOT_FILESYSTEM: set netboot filesystem
# (Default: nfs)
LB_NET_ROOT_FILESYSTEM="nfs"

# $LB_NET_ROOT_MOUNTOPTIONS: set nfsopts
# (Default: empty)
LB_NET_ROOT_MOUNTOPTIONS=""

# $LB_NET_ROOT_PATH: set netboot server directory
# (Default: /srv/debian-live)
LB_NET_ROOT_PATH="/srv/debian-live"

# $LB_NET_ROOT_SERVER: set netboot server address
# (Default: 192.168.0.99)
LB_NET_ROOT_SERVER="192.168.0.99"

# $LB_NET_COW_FILESYSTEM: set net client cow filesystem
# (Default: nfs)
LB_NET_COW_FILESYSTEM="nfs"

# $LB_NET_COW_MOUNTOPTIONS: set cow mount options
# (Default: empty)
LB_NET_COW_MOUNTOPTIONS=""

# $LB_NET_COW_PATH: set cow directory
# (Default: )
LB_NET_COW_PATH=""

# $LB_NET_COW_SERVER: set cow server
# (Default: )
LB_NET_COW_SERVER=""

# $LB_NET_TARBALL: set net tarball
# (Default: gzip)
LB_NET_TARBALL="gzip"

# $LB_SYSLINUX_SPLASH: set custom syslinux splash
# (Default: empty)
LB_SYSLINUX_SPLASH="config/binary_syslinux/splash.png"

# $LB_SYSLINUX_TIMEOUT: set custom syslinux timeout in seconds
# (Default: 0)
LB_SYSLINUX_TIMEOUT="3"

# $LB_SYSLINUX_CFG: set custom syslinux configuration file
# (Default: empty)
LB_SYSLINUX_CFG=""

# $LB_SYSLINUX_MENU: set syslinux menu
# (Default: true)
LB_SYSLINUX_MENU="true"

# $LB_SYSLINUX_MENU_LIVE_ENTRY: set text to be used on the menu for live entries
# (Default: Live)
LB_SYSLINUX_MENU_LIVE_ENTRY="Live"

# $LB_SYSLINUX_MENU_LIVE_FAILSAFE_ENTRY: set text to be used on the menu for live entries (failsafe ones)
# (Default: )
LB_SYSLINUX_MENU_LIVE_FAILSAFE_ENTRY="none"

# $LB_SYSLINUX_MENU_MEMTEST_ENTRY: set text to be used on the menu for memtest entry
# (Default: Memory test)
LB_SYSLINUX_MENU_MEMTEST_ENTRY="Memory Test"

# $LB_USERNAME: set username
# (Default: live)
LB_USERNAME="live"
-------------------------------------------------------

but still get a "Debian Installer" icon on the desktop.

BTW I didn't get this problem on squeeze usb-hdd live.




-- Package-specific info:

-- System Information:
Debian Release: 6.0.3
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages live-build depends on:
ii  debootstrap              1.0.26+squeeze1 Bootstrap a basic Debian system

Versions of packages live-build recommends:
ii  cpio                          2.11-4     GNU cpio -- a program to manage ar
pn  gnu-fdisk                     <none>     (no description available)

Versions of packages live-build suggests:
ii  dosfstools           3.0.9-1             utilities for making and checking 
ii  fakeroot             1.14.4-1            Gives a fake root environment
ii  genisoimage          9:1.1.11-1          Creates ISO-9660 CD-ROM filesystem
pn  memtest86+ | memtest <none>              (no description available)
ii  mtools               4.0.12-1            Tools for manipulating MSDOS files
pn  parted               <none>              (no description available)
pn  squashfs-tools | gen <none>              (no description available)
ii  sudo                 1.7.4p4-2.squeeze.2 Provide limited super user privile
pn  syslinux | grub      <none>              (no description available)
pn  uuid-runtime         <none>              (no description available)
pn  win32-loader         <none>              (no description available)

-- no debconf information




Reply sent to daniel.baumann@progress-technologies.net:
You have taken responsibility. (Sat, 19 Nov 2011 00:42:09 GMT) Full text and rfc822 format available.

Notification sent to Piotr <upiter77@lycos.com>:
Bug acknowledged by developer. (Sat, 19 Nov 2011 00:42:09 GMT) Full text and rfc822 format available.

Message #10 received at 649221-done@bugs.debian.org (full text, mbox):

From: Daniel Baumann <daniel.baumann@progress-technologies.net>
To: Piotr <upiter77@lycos.com>
Cc: 649221-done@bugs.debian.org
Subject: Re: Bug#649221: live-build: * Edit post
Date: Sat, 19 Nov 2011 01:39:14 +0100
I'm afraid i don't really understand from your bug report what your 
actual problem is, however, you're building wheezy with live-build 2.x 
which is not supported and not supposed to work anyway.

you can build old-stable (lenny) and stable (squeeze) with 2.x from 
stable, but you do need 3.x from unstable to build testing (wheezy) and 
unstable (sid).

-- 
Address:        Daniel Baumann, Donnerbuehlweg 3, CH-3012 Bern
Email:          daniel.baumann@progress-technologies.net
Internet:       http://people.progress-technologies.net/~daniel.baumann/




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 17 Dec 2011 07:32:24 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 16 04:22:28 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.