Debian Bug report logs - #647749
doesn't work; invalid weather.com license key

version graph

Package: xfce4-weather-plugin; Maintainer for xfce4-weather-plugin is Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>; Source for xfce4-weather-plugin is src:xfce4-weather-plugin.

Reported by: Romain Francoise <rfrancoise@debian.org>

Date: Sat, 5 Nov 2011 18:45:02 UTC

Severity: grave

Tags: confirmed, upstream

Merged with 648270, 660635

Found in versions xfce4-weather-plugin/0.7.3-3, xfce4-weather-plugin/0.7.4-1, xfce4-weather-plugin/0.7.4-2

Fixed in versions xfce4-weather-plugin/0.7.4-3, xfce4-weather-plugin/0.7.3-3+squeeze1

Done: Yves-Alexis Perez <corsac@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Sat, 05 Nov 2011 18:45:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Romain Francoise <rfrancoise@debian.org>:
New Bug report received and forwarded. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Sat, 05 Nov 2011 18:45:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Romain Francoise <rfrancoise@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: doesn't work; invalid weather.com license key
Date: Sat, 05 Nov 2011 19:41:29 +0100
Package: xfce4-weather-plugin
Version: 0.7.4-1
Severity: grave
Tags: upstream

The plugin tries to get weather data from xoap.weather.com which replies
"Invalid License Key". Since this affects all users of the package and
makes it useless, I'm setting the severity to 'grave'.

Thanks,

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (900, 'unstable'), (850, 'testing'), (800, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-ore (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages xfce4-weather-plugin depends on:
ii  libc6               2.13-21     
ii  libcairo2           1.10.2-6.1  
ii  libgdk-pixbuf2.0-0  2.24.0-1    
ii  libglib2.0-0        2.28.8-1    
ii  libgtk2.0-0         2.24.7-1    
ii  libpango1.0-0       1.29.4-2    
ii  libxfce4util4       4.8.2-1     
ii  libxfcegui4-4       4.8.1-5     
ii  libxml2             2.7.8.dfsg-5
ii  xfce4-panel         4.8.6-1     

xfce4-weather-plugin recommends no packages.

xfce4-weather-plugin suggests no packages.

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Sat, 05 Nov 2011 20:33:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to Yves-Alexis Perez <corsac@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Sat, 05 Nov 2011 20:33:10 GMT) Full text and rfc822 format available.

Message #10 received at 647749@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: Romain Francoise <rfrancoise@debian.org>, 647749@bugs.debian.org
Cc: control@bugs.debian.org
Subject: Re: [Pkg-xfce-devel] Bug#647749: doesn't work; invalid weather.com license key
Date: Sat, 05 Nov 2011 21:29:44 +0100
[Message part 1 (text/plain, inline)]
tag 647749 confirmed
thanks
On sam., 2011-11-05 at 19:41 +0100, Romain Francoise wrote:
> The plugin tries to get weather data from xoap.weather.com which
> replies
> "Invalid License Key". Since this affects all users of the package and
> makes it useless, I'm setting the severity to 'grave'. 

Yes, and unfortunately the plugin is more or less unmaintained. If noone
steps up at Xfce for that, I guess the only solution will be to remove
it for all Debian versions...

Right now, I guess it could be worth waiting with the bug open an
assigned, in case someone shows up. Then if that doesn't happen, will
reasign to ftp-masters to have it removed.

Regards,
-- 
Yves-Alexis
[signature.asc (application/pgp-signature, inline)]

Added tag(s) confirmed. Request was from Yves-Alexis Perez <corsac@debian.org> to control@bugs.debian.org. (Sat, 05 Nov 2011 20:33:11 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Sun, 06 Nov 2011 01:33:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Dave Lentz <dtl131@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Sun, 06 Nov 2011 01:33:03 GMT) Full text and rfc822 format available.

Message #17 received at 647749@bugs.debian.org (full text, mbox):

From: Dave Lentz <dtl131@gmail.com>
To: 647749@bugs.debian.org
Subject: Re: Bug 647749
Date: Sat, 05 Nov 2011 21:29:22 -0400
[Message part 1 (text/plain, inline)]
It's easy enough to obtain a new license id (quick, automated process) 
and make a little patch (the license numbers are declared at the top of 
weather.h).

The only thing I'm not sure about is legal ramifications, though it 
looks like TWCi has had the same license since 2008.

[00_license.patch (text/x-patch, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Sun, 06 Nov 2011 02:09:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Dave Lentz <dtl131@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Sun, 06 Nov 2011 02:09:03 GMT) Full text and rfc822 format available.

Message #22 received at 647749@bugs.debian.org (full text, mbox):

From: Dave Lentz <dtl131@gmail.com>
To: 647749@bugs.debian.org
Subject: Re: Bug#647749: Info received (Bug 647749)
Date: Sat, 05 Nov 2011 22:07:32 -0400
Now I see that TWC is ending its XMLOAP service in favor of a pay model, 
and the plugin eventually needs a new weather provider. I'd still 
recommend using the patch, as it will buy more time until the issue is 
resolved upstream.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Sun, 06 Nov 2011 11:57:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Yves-Alexis Perez <corsac@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Sun, 06 Nov 2011 11:57:21 GMT) Full text and rfc822 format available.

Message #27 received at 647749@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: Dave Lentz <dtl131@gmail.com>, 647749@bugs.debian.org
Subject: Re: [Pkg-xfce-devel] Bug#647749: Info received (Bug 647749)
Date: Sun, 06 Nov 2011 12:54:59 +0100
[Message part 1 (text/plain, inline)]
On sam., 2011-11-05 at 22:07 -0400, Dave Lentz wrote:
> Now I see that TWC is ending its XMLOAP service in favor of a pay model, 
> and the plugin eventually needs a new weather provider. I'd still 
> recommend using the patch, as it will buy more time until the issue is 
> resolved upstream.
> 
As far as I understand it, the previous licensing model did end oct 31.
Are you sure the patch will work?

Regards,
-- 
Yves-Alexis
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Sun, 06 Nov 2011 16:48:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Dave Lentz <dtl131@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Sun, 06 Nov 2011 16:48:03 GMT) Full text and rfc822 format available.

Message #32 received at 647749@bugs.debian.org (full text, mbox):

From: Dave Lentz <dtl131@gmail.com>
To: 647749@bugs.debian.org
Subject: Patch
Date: Sun, 06 Nov 2011 11:45:23 -0500
TWC automatically disabled all existing xmloap licenses on 10/31. 
However, they didn't disable the xmloap service itself yet (nor the 
ability to get a new license id). The patch will work until TWC's xmloap 
service is ended, which could be tomorrow or many moons from now (your 
guess is as good as mine).

I applied the patch as shown and my weather plugin is working again. It 
will work until TWC ends xmloap or manually disables my license id 
(though I can't see why they would do that since the plugin does follow 
all of the licensing agreements (non-profit, shows logo and promotional 
links, etc.).


Example output from today:
Weather report for: Lancaster, PA.

Observation station located in Lancaster, PA
Last update: 11/6/11 10:53 AM EST.

Temperature
    Temperature: 50 °F
    Windchill: 46 °F
    Description: Fair
    Dew point: 35 °F

Wind
    Speed: 10 mph
    Direction: SSW
    Gusts: N/A

UV
    Index: 3
    Risk: Moderate

Atmospheric pressure
    Pressure: 30.51 in
    State: falling

Sun
    Rise: 06:41:00 AM
    Set: 04:59:00 PM

Other
    Humidity: 57 %
    Visibility: 10.0 mi

More on weather.com
    Local Pollen Reports
    Airport Conditions
    Lawn and Garden Weather
    Rush Hour Traffic





Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Sun, 06 Nov 2011 20:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Yves-Alexis Perez <corsac@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Sun, 06 Nov 2011 20:21:03 GMT) Full text and rfc822 format available.

Message #37 received at 647749@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: Dave Lentz <dtl131@gmail.com>, 647749@bugs.debian.org
Subject: Re: [Pkg-xfce-devel] Bug#647749: Patch
Date: Sun, 06 Nov 2011 21:18:04 +0100
[Message part 1 (text/plain, inline)]
On dim., 2011-11-06 at 11:45 -0500, Dave Lentz wrote:
> TWC automatically disabled all existing xmloap licenses on 10/31. 
> However, they didn't disable the xmloap service itself yet (nor the 
> ability to get a new license id). The patch will work until TWC's xmloap 
> service is ended, which could be tomorrow or many moons from now (your 
> guess is as good as mine).

Well, they revoked the licenses for a reason. They intend to shut the
service down and pass to a paid service. If we manage to fix the plugin
just to have it disabled again in the next future, it might not be worth
it. It might be worth changing provider though.

In any case, thanks for the patch, it might be at least a band-aid
solution for stable where changing provider isn't exactly possible
anyway.

For the rest, feel free to push that upstream (I won't do that, it's
your license).

Regards,
-- 
Yves-Alexis
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Wed, 09 Nov 2011 16:15:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Marcelo Fiscella" <marcelo@fiscella.org>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Wed, 09 Nov 2011 16:15:10 GMT) Full text and rfc822 format available.

Message #42 received at 647749@bugs.debian.org (full text, mbox):

From: "Marcelo Fiscella" <marcelo@fiscella.org>
To: 647749@bugs.debian.org
Subject: Interim fix proposed in the upstream bug report
Date: Wed, 09 Nov 2011 13:02:20 -0300
[Message part 1 (text/plain, inline)]
As it was already mentioned here and also in the upstream bug report, I  
understand that the ideal solution would be to switch providers. But  
unfortunately that's something that probably won't happen in the short  
term.

In the upstream report it was suggested that the license key from ctw (an  
open source weather client currently unmaintained) could be used instead  
of the current one as an interim fix (see  
https://bugzilla.xfce.org/show_bug.cgi?id=8105#c9).

Since I'm not a DD, I don't know how many person-hours it would take to  
apply this trivial patch and upload an updated package to the repository.  
Therefore I can't tell whether the effort would be worth it or not.

However, if this workaround could prevent having another broken or missing  
piece in Xfce, then maybe it's worth it, even if it's just a temporary fix  
and not a solution to the underlying issue.

Best regards,
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Wed, 09 Nov 2011 16:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Yves-Alexis Perez <corsac@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Wed, 09 Nov 2011 16:51:03 GMT) Full text and rfc822 format available.

Message #47 received at 647749@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: Marcelo Fiscella <marcelo@fiscella.org>, 647749@bugs.debian.org
Subject: Re: [Pkg-xfce-devel] Bug#647749: Interim fix proposed in the upstream bug report
Date: Wed, 09 Nov 2011 17:49:43 +0100
[Message part 1 (text/plain, inline)]
On mer., 2011-11-09 at 13:02 -0300, Marcelo Fiscella wrote:
> In the upstream report it was suggested that the license key from ctw (an  
> open source weather client currently unmaintained) could be used instead  
> of the current one as an interim fix (see  
> https://bugzilla.xfce.org/show_bug.cgi?id=8105#c9).
> 
> Since I'm not a DD, I don't know how many person-hours it would take to  
> apply this trivial patch and upload an updated package to the repository.  
> Therefore I can't tell whether the effort would be worth it or not.
> 
> However, if this workaround could prevent having another broken or missing  
> piece in Xfce, then maybe it's worth it, even if it's just a temporary fix  
> and not a solution to the underlying issue. 

Yeah, it's just band-aid, but considering there's not much other
solutions and that the license key owner gave his ack, I guess that's
the best solution for now.

Regards,
-- 
Yves-Alexis
[signature.asc (application/pgp-signature, inline)]

Forcibly Merged 647749 648270. Request was from Yves-Alexis Perez <corsac@debian.org> to control@bugs.debian.org. (Thu, 10 Nov 2011 11:30:04 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Sat, 12 Nov 2011 03:30:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Alexandre Lymberopoulos <lymber@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Sat, 12 Nov 2011 03:30:04 GMT) Full text and rfc822 format available.

Message #54 received at 647749@bugs.debian.org (full text, mbox):

From: Alexandre Lymberopoulos <lymber@gmail.com>
To: Debian Bug Tracking System <647749@bugs.debian.org>
Subject: Re: doesn't work; invalid weather.com license key
Date: Sat, 12 Nov 2011 01:27:21 -0200
Package: xfce4-weather-plugin
Version: 0.7.4-1
Followup-For: Bug #647749

Dear Maintainer,

I confirm this happening here. Hovering the mouse on weather-plugin 
at my dock shows me "Cannot update weather data".

Many people say that this is due to a licence in weather.com that 
has expired, there are also many reports of people recompiling the 
package with a valid license and then every thing works fine. See 
the following link, for example: 

<http://ubuntuforums.org/showthread.php?t=1875487>

This seems to be very simple to fix. I just started with xfce4 a 
few minutes ago and it looks very interesting.

Thanks in advance and very best regards,
Alexandre

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (900, 'testing'), (700, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 3.0.0-1-686-pae (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages xfce4-weather-plugin depends on:
ii  libc6               2.13-21     
ii  libcairo2           1.10.2-6.1  
ii  libgdk-pixbuf2.0-0  2.24.0-1    
ii  libglib2.0-0        2.28.8-1    
ii  libgtk2.0-0         2.24.7-1    
ii  libpango1.0-0       1.29.4-2    
ii  libxfce4util4       4.8.2-1     
ii  libxfcegui4-4       4.8.1-5     
ii  libxml2             2.7.8.dfsg-5
ii  xfce4-panel         4.8.6-1     

xfce4-weather-plugin recommends no packages.

xfce4-weather-plugin suggests no packages.

-- no debconf information




Reply sent to Yves-Alexis Perez <corsac@debian.org>:
You have taken responsibility. (Wed, 16 Nov 2011 22:09:10 GMT) Full text and rfc822 format available.

Notification sent to Romain Francoise <rfrancoise@debian.org>:
Bug acknowledged by developer. (Wed, 16 Nov 2011 22:09:10 GMT) Full text and rfc822 format available.

Message #59 received at 647749-close@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: 647749-close@bugs.debian.org
Subject: Bug#647749: fixed in xfce4-weather-plugin 0.7.4-2
Date: Wed, 16 Nov 2011 22:06:14 +0000
Source: xfce4-weather-plugin
Source-Version: 0.7.4-2

We believe that the bug you reported is fixed in the latest version of
xfce4-weather-plugin, which is due to be installed in the Debian FTP archive:

xfce4-weather-plugin_0.7.4-2.debian.tar.gz
  to main/x/xfce4-weather-plugin/xfce4-weather-plugin_0.7.4-2.debian.tar.gz
xfce4-weather-plugin_0.7.4-2.dsc
  to main/x/xfce4-weather-plugin/xfce4-weather-plugin_0.7.4-2.dsc
xfce4-weather-plugin_0.7.4-2_amd64.deb
  to main/x/xfce4-weather-plugin/xfce4-weather-plugin_0.7.4-2_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 647749@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Yves-Alexis Perez <corsac@debian.org> (supplier of updated xfce4-weather-plugin package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Wed, 16 Nov 2011 22:48:59 +0100
Source: xfce4-weather-plugin
Binary: xfce4-weather-plugin
Architecture: source amd64
Version: 0.7.4-2
Distribution: unstable
Urgency: low
Maintainer: Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>
Changed-By: Yves-Alexis Perez <corsac@debian.org>
Description: 
 xfce4-weather-plugin - weather information plugin for the Xfce4 panel
Closes: 647749
Changes: 
 xfce4-weather-plugin (0.7.4-2) unstable; urgency=low
 .
   * debian/patches:
     - 00_license added, change the license key for the one from CTW since it
       seems to work and brings back the feature. Temporary fix until a real
       solution is found.                                        closes: #647749
   * debian/rules:
     - switch to debhelper with hardening support
   * debian/control:
     - update debhelper build-dep to 8.9.4 for hardening support.
     - add dpkg-dev 1.16.1 build-dep for hardening support.
     - drop cdbs and hardening-includes.
     - fix typo in long description.
   * debian/compat bumped to 9.
Checksums-Sha1: 
 625d9720a4d213b2273b8a04916f119a09f8fe03 2185 xfce4-weather-plugin_0.7.4-2.dsc
 884c35f4962847f50fd2833104dd987453f0cdac 4177 xfce4-weather-plugin_0.7.4-2.debian.tar.gz
 22cab75cdc08d491af080b800d4d7642b93bc0b9 524932 xfce4-weather-plugin_0.7.4-2_amd64.deb
Checksums-Sha256: 
 d992572b4a7a5d3d5a8b58241585767c978c15f239aa46d9a3f8aa3dddcda3fa 2185 xfce4-weather-plugin_0.7.4-2.dsc
 6d723c921777ba22e92bce7495af71262fa04c117179c6f373abed4e99058f5a 4177 xfce4-weather-plugin_0.7.4-2.debian.tar.gz
 54d16adadf0a46c717deae43bce1bbefeef44f53b5f2fd56eb6e08b342eead74 524932 xfce4-weather-plugin_0.7.4-2_amd64.deb
Files: 
 8dd910528eb85da471d398c3706df034 2185 xfce optional xfce4-weather-plugin_0.7.4-2.dsc
 700b67fd1f1e5d22a2c018308e54e378 4177 xfce optional xfce4-weather-plugin_0.7.4-2.debian.tar.gz
 a33b72e44468a70b8036615593a4dbe0 524932 xfce optional xfce4-weather-plugin_0.7.4-2_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQIcBAEBCgAGBQJOxDA4AAoJEDBVD3hx7wuoa4wP/1XV/2iFxkYUDSv73DiEgVcA
hy9lwLPG/EfMAmS0eK0jxtysXDEP0/EJe6xMrwbckK0ZVNMDGGK7WRzCmEqgcWZx
UeF/QMUATXfy3jYVgpBSJ5xGrPS/T5Q4Gup7Azk70ukTCTbBxvohTuKnildzYH1g
A9gmMN+iif8tqWDRfA439+t1om/Mx107YVs+lORweWxAA4FItah+XvORr0puCPlx
2w294Wtyr5IsfpkUuYi9DKPE2DDksretMyI/FHYjeHOHuwf9qQou/BWRLET/Cqvz
ZRU1CbEk9razQpDkmVcIy1n5G89lcN1Yj/rJq4B9mLX3kEJFW5rrzeDI7cVRgvzn
nXuupkpVu7+k8mGpQ7ETjcM+SKJw1rVA0844zgoPw/G0LSEUlGObK+l56Jfg4M1T
fCEyv2b27R7a20L2XvAPH0GbfoJhCirdoQQlKl/SHYRmjpY7R5MUFFKKTw1bB3Uf
nvFlvQsPsgQCnHk1bnH0q4Wg5tnwQX5sdECRyDnD7ZnYt0E1Q2vXx5JMU5RkJ3Jz
e1fFC4Fb8yrtGTidiH8/RlUbEeLKHYSO6lj/vyTag8sSvKuCr6+goEFeSElu6en5
W9MZ6eVglqNmdE+MO6l6fpdE2o03xi099YVv9neMgNuc641mSNBZt37vB1f0zg/4
c0xU8lhSrjDMPrekiW3s
=hFke
-----END PGP SIGNATURE-----





Reply sent to Yves-Alexis Perez <corsac@debian.org>:
You have taken responsibility. (Wed, 16 Nov 2011 22:09:11 GMT) Full text and rfc822 format available.

Notification sent to Stephen <marathon.durandal@gmail.com>:
Bug acknowledged by developer. (Wed, 16 Nov 2011 22:09:11 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Thu, 17 Nov 2011 21:57:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Cesare Leonardi <celeonar@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Thu, 17 Nov 2011 21:57:03 GMT) Full text and rfc822 format available.

Message #69 received at 647749@bugs.debian.org (full text, mbox):

From: Cesare Leonardi <celeonar@gmail.com>
To: 647749@bugs.debian.org
Subject: Fixed?
Date: Thu, 17 Nov 2011 22:55:58 +0100
Still not working for me with 0.7.4-2: No Data.

Cesare.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Fri, 18 Nov 2011 00:33:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Lili-Anne Girard <liliannegirard@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Fri, 18 Nov 2011 00:33:03 GMT) Full text and rfc822 format available.

Message #74 received at 647749@bugs.debian.org (full text, mbox):

From: Lili-Anne Girard <liliannegirard@gmail.com>
To: 647749@bugs.debian.org
Cc: Cesare Leonardi <celeonar@gmail.com>
Subject: [Pkg-xfce-devel] Bug#647749: doesn't work; invalid weather.com license key
Date: Thu, 17 Nov 2011 19:28:56 -0500
[Message part 1 (text/plain, inline)]
The patch doesn't seems to be applied.
It works if I create /xfce4-weather-plugin-0.7.4/debian/patches/series

-- 
lili
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Fri, 18 Nov 2011 06:48:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Yves-Alexis Perez <corsac@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Fri, 18 Nov 2011 06:48:03 GMT) Full text and rfc822 format available.

Message #79 received at 647749@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: Lili-Anne Girard <liliannegirard@gmail.com>, 647749@bugs.debian.org
Cc: Cesare Leonardi <celeonar@gmail.com>
Subject: Re: [Pkg-xfce-devel] Bug#647749: Bug#647749: doesn't work; invalid weather.com license key
Date: Fri, 18 Nov 2011 07:45:13 +0100
[Message part 1 (text/plain, inline)]
On jeu., 2011-11-17 at 19:28 -0500, Lili-Anne Girard wrote:
> The patch doesn't seems to be applied.
> It works if I create /xfce4-weather-plugin-0.7.4/debian/patches/series
> 

Arf, thanks...
-- 
Yves-Alexis
[signature.asc (application/pgp-signature, inline)]

Reply sent to Yves-Alexis Perez <corsac@debian.org>:
You have taken responsibility. (Fri, 18 Nov 2011 10:06:04 GMT) Full text and rfc822 format available.

Notification sent to Romain Francoise <rfrancoise@debian.org>:
Bug acknowledged by developer. (Fri, 18 Nov 2011 10:06:08 GMT) Full text and rfc822 format available.

Message #84 received at 647749-close@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: 647749-close@bugs.debian.org
Subject: Bug#647749: fixed in xfce4-weather-plugin 0.7.4-3
Date: Fri, 18 Nov 2011 10:02:32 +0000
Source: xfce4-weather-plugin
Source-Version: 0.7.4-3

We believe that the bug you reported is fixed in the latest version of
xfce4-weather-plugin, which is due to be installed in the Debian FTP archive:

xfce4-weather-plugin_0.7.4-3.debian.tar.gz
  to main/x/xfce4-weather-plugin/xfce4-weather-plugin_0.7.4-3.debian.tar.gz
xfce4-weather-plugin_0.7.4-3.dsc
  to main/x/xfce4-weather-plugin/xfce4-weather-plugin_0.7.4-3.dsc
xfce4-weather-plugin_0.7.4-3_amd64.deb
  to main/x/xfce4-weather-plugin/xfce4-weather-plugin_0.7.4-3_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 647749@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Yves-Alexis Perez <corsac@debian.org> (supplier of updated xfce4-weather-plugin package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Fri, 18 Nov 2011 10:48:51 +0100
Source: xfce4-weather-plugin
Binary: xfce4-weather-plugin
Architecture: source amd64
Version: 0.7.4-3
Distribution: unstable
Urgency: low
Maintainer: Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>
Changed-By: Yves-Alexis Perez <corsac@debian.org>
Description: 
 xfce4-weather-plugin - weather information plugin for the Xfce4 panel
Closes: 647749
Changes: 
 xfce4-weather-plugin (0.7.4-3) unstable; urgency=low
 .
   * Brown paper bag release.
   * debian/patches/series added, so the patch is really applied.closes: #647749
Checksums-Sha1: 
 691a147d9d681dfbe8d2b9b3c85b4cb455ce4235 2185 xfce4-weather-plugin_0.7.4-3.dsc
 fe495d1d2d98871a35f066ea63964a956ba3a403 4271 xfce4-weather-plugin_0.7.4-3.debian.tar.gz
 520173217dc9b5b82fa0150933f1f866922f0afc 525036 xfce4-weather-plugin_0.7.4-3_amd64.deb
Checksums-Sha256: 
 6d051ce13ce464c00a3ef33f1790920bebbdb813ef199fa4942981864b1ac6d7 2185 xfce4-weather-plugin_0.7.4-3.dsc
 0c703a23467e59a9ec94d2d40c4cf4b9c2f9634d5a25c433446ba185596fcc2b 4271 xfce4-weather-plugin_0.7.4-3.debian.tar.gz
 9427192828b4f0119385584f2b414c7150051ac3658c81566e7e84a56e156253 525036 xfce4-weather-plugin_0.7.4-3_amd64.deb
Files: 
 babd677b48db847c6f504a99e2090e3f 2185 xfce optional xfce4-weather-plugin_0.7.4-3.dsc
 7083e2a3d6fb0c199f00eb79e7950fc4 4271 xfce optional xfce4-weather-plugin_0.7.4-3.debian.tar.gz
 e121641c745afc35835b89674b7af95f 525036 xfce optional xfce4-weather-plugin_0.7.4-3_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQIcBAEBCgAGBQJOxiwFAAoJEDBVD3hx7wuoMq0P/j68HXxg/fks9YhdxVxYvefq
miZEl6Kl6Vamt52hUak6NkWoXO5TaEQOYwckkA+g+LA6PImQzve7rn11X9ZN21UO
lGg2iPLx11ASw7LfucMexa+pWz5so2aOLV1IiYRX1RmovQV9xwN2xd8JSw7XOoZC
L6YXJXpO6cthcXsi2i6p6R5KTErb2bBVdkStTgEdAtR3zzVhcO1yQgkJzD3M2Bs/
BO0LkgdHD0U0FU6FeaQdki7dTMFP6ZRYB736y2V96k+GxOqSO5Xhk+3lbSOB3NfC
vBhfidC7YxRHKi7bIpHbDm+3gR5aDzkjdWy0g73FkhHyughKStYuw6NRLG+PMazq
N0SAjn5nvgdOhw/qwRpbUpWhaatOtK1HbTKcJ4JRLPeTncwsyivJTDDr1CopDXfB
KlNa/kBt3SIxL738/BzvvE5zN5hMHaS5/P+BWxazSf6nA5keIn/zaXZAekO/v3+n
9a9xlhp2U/+Jax+KjZcQX+CnJt2t/TCRa1Z5/aQXxEmCcwzaxwDpbaAix4P4vE6w
bWOUg8q6F95fdr/Y8uwYY+SKCUloFrhWMwrdatVkRXm+xwXmqq35c++4XZY/6bf1
h3yfgR9ObqSMOEUAFDnMOxXMamL4BRESShp2r5kHJyZqZQWkv/S8iFhrO625OOq4
mdF5qFL5QOs0gnH1pYNZ
=9qUI
-----END PGP SIGNATURE-----





Reply sent to Yves-Alexis Perez <corsac@debian.org>:
You have taken responsibility. (Fri, 18 Nov 2011 10:06:11 GMT) Full text and rfc822 format available.

Notification sent to Stephen <marathon.durandal@gmail.com>:
Bug acknowledged by developer. (Fri, 18 Nov 2011 10:06:15 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Sat, 19 Nov 2011 03:06:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Lili-Anne Girard <liliannegirard@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Sat, 19 Nov 2011 03:06:03 GMT) Full text and rfc822 format available.

Message #94 received at 647749@bugs.debian.org (full text, mbox):

From: Lili-Anne Girard <liliannegirard@gmail.com>
To: Yves-Alexis Perez <corsac@debian.org>
Cc: 647749@bugs.debian.org
Subject: [Pkg-xfce-devel] Bug#647749: doesn't work; invalid weather.com
Date: Fri, 18 Nov 2011 22:02:18 -0500
On Fri, 18 Nov 2011 07:45:13 +0100
Yves-Alexis Perez <corsac@debian.org> wrote:

> On jeu., 2011-11-17 at 19:28 -0500, Lili-Anne Girard wrote:
> > The patch doesn't seems to be applied.
> > It works if I
> > create /xfce4-weather-plugin-0.7.4/debian/patches/series
> >
>
> Arf, thanks...

Hi

Can it be applied to xfce4-weather-plugin in stable?

Thanks

-- 
lili




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Sat, 19 Nov 2011 08:27:16 GMT) Full text and rfc822 format available.

Acknowledgement sent to Yves-Alexis Perez <corsac@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Sat, 19 Nov 2011 08:27:16 GMT) Full text and rfc822 format available.

Message #99 received at 647749@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: Lili-Anne Girard <liliannegirard@gmail.com>
Cc: 647749@bugs.debian.org
Subject: Re: [Pkg-xfce-devel] Bug#647749: doesn't work; invalid weather.com
Date: Sat, 19 Nov 2011 09:22:39 +0100
[Message part 1 (text/plain, inline)]
On ven., 2011-11-18 at 22:02 -0500, Lili-Anne Girard wrote:
> On Fri, 18 Nov 2011 07:45:13 +0100
> Yves-Alexis Perez <corsac@debian.org> wrote:
> 
> > On jeu., 2011-11-17 at 19:28 -0500, Lili-Anne Girard wrote:
> > > The patch doesn't seems to be applied.
> > > It works if I
> > > create /xfce4-weather-plugin-0.7.4/debian/patches/series
> > >
> >
> > Arf, thanks...
> 
> Hi
> 
> Can it be applied to xfce4-weather-plugin in stable?
> 
I'm waiting for it to reach testing before, but yes, I intend to do
that. Note that there's no way to know how long it'll work...


-- 
Yves-Alexis
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>:
Bug#647749; Package xfce4-weather-plugin. (Mon, 19 Dec 2011 08:00:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Alexey Eromenko <al4321@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>. (Mon, 19 Dec 2011 08:00:04 GMT) Full text and rfc822 format available.

Message #104 received at 647749@bugs.debian.org (full text, mbox):

From: Alexey Eromenko <al4321@gmail.com>
To: 647749@bugs.debian.org
Subject: Ongoing discussion
Date: Mon, 19 Dec 2011 09:57:30 +0200
Hi All !

There is now an ongoing discussion on debian-legal ML to remove
components of Debian,
that are dependent on non-free web services from 'main' to 'contrib' repo.

Read more here:
http://lists.debian.org/debian-legal/2011/12/msg00002.html
and here:
http://lists.debian.org/debian-legal/2011/12/threads.html

-- 
-Alexey Eromenko "Technologov"




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 17 Jan 2012 07:38:04 GMT) Full text and rfc822 format available.

Bug unarchived. Request was from Yves-Alexis Perez <corsac@debian.org> to control@bugs.debian.org. (Mon, 20 Feb 2012 14:09:05 GMT) Full text and rfc822 format available.

Bug Marked as found in versions xfce4-weather-plugin/0.7.3-3. Request was from Yves-Alexis Perez <corsac@debian.org> to control@bugs.debian.org. (Mon, 20 Feb 2012 14:09:07 GMT) Full text and rfc822 format available.

Forcibly Merged 647749 648270 660635. Request was from Yves-Alexis Perez <corsac@debian.org> to control@bugs.debian.org. (Mon, 20 Feb 2012 14:09:08 GMT) Full text and rfc822 format available.

Reply sent to Yves-Alexis Perez <corsac@debian.org>:
You have taken responsibility. (Thu, 23 Feb 2012 20:51:03 GMT) Full text and rfc822 format available.

Notification sent to Romain Francoise <rfrancoise@debian.org>:
Bug acknowledged by developer. (Thu, 23 Feb 2012 20:51:04 GMT) Full text and rfc822 format available.

Message #117 received at 647749-close@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: 647749-close@bugs.debian.org
Subject: Bug#647749: fixed in xfce4-weather-plugin 0.7.3-3+squeeze1
Date: Thu, 23 Feb 2012 20:47:10 +0000
Source: xfce4-weather-plugin
Source-Version: 0.7.3-3+squeeze1

We believe that the bug you reported is fixed in the latest version of
xfce4-weather-plugin, which is due to be installed in the Debian FTP archive:

xfce4-weather-plugin_0.7.3-3+squeeze1.diff.gz
  to main/x/xfce4-weather-plugin/xfce4-weather-plugin_0.7.3-3+squeeze1.diff.gz
xfce4-weather-plugin_0.7.3-3+squeeze1.dsc
  to main/x/xfce4-weather-plugin/xfce4-weather-plugin_0.7.3-3+squeeze1.dsc
xfce4-weather-plugin_0.7.3-3+squeeze1_amd64.deb
  to main/x/xfce4-weather-plugin/xfce4-weather-plugin_0.7.3-3+squeeze1_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 647749@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Yves-Alexis Perez <corsac@debian.org> (supplier of updated xfce4-weather-plugin package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Tue, 21 Feb 2012 11:18:13 +0100
Source: xfce4-weather-plugin
Binary: xfce4-weather-plugin
Architecture: source amd64
Version: 0.7.3-3+squeeze1
Distribution: stable
Urgency: low
Maintainer: Debian Xfce Maintainers <pkg-xfce-devel@lists.alioth.debian.org>
Changed-By: Yves-Alexis Perez <corsac@debian.org>
Description: 
 xfce4-weather-plugin - weather information plugin for the Xfce4 panel
Closes: 647749
Changes: 
 xfce4-weather-plugin (0.7.3-3+squeeze1) stable; urgency=low
 .
   * debian/patches:
     - 00_license added, change the license key to get a working plugin back.
                                                                 closes: #647749
Checksums-Sha1: 
 c9e06d2baa19c359b22c6b839d09e184a802ecac 2146 xfce4-weather-plugin_0.7.3-3+squeeze1.dsc
 7b1ecceb726a8ef1c55f0c2a22e61f9999606040 4050 xfce4-weather-plugin_0.7.3-3+squeeze1.diff.gz
 d5321e538f6742ca42f6af74a62e44a6eeac7091 464582 xfce4-weather-plugin_0.7.3-3+squeeze1_amd64.deb
Checksums-Sha256: 
 1f4e14ef0fa05261f516409d4be1a45a15579ecdc4cf4c8d1013c121aeef6b56 2146 xfce4-weather-plugin_0.7.3-3+squeeze1.dsc
 a471bf6080f913f40de3a19f181038c88f0024799244ebda07a8f995578cbe15 4050 xfce4-weather-plugin_0.7.3-3+squeeze1.diff.gz
 56c695aba7e604e7f46cea04515c5a8a97d1da3f4d249d18399a7de873748893 464582 xfce4-weather-plugin_0.7.3-3+squeeze1_amd64.deb
Files: 
 2fbb62cb64098e7cd59bdabf678c22e1 2146 xfce optional xfce4-weather-plugin_0.7.3-3+squeeze1.dsc
 43d9facdc8e1b79b51d361b7d0ac308e 4050 xfce optional xfce4-weather-plugin_0.7.3-3+squeeze1.diff.gz
 f51fac405a8fb560d27a744fea038e4f 464582 xfce optional xfce4-weather-plugin_0.7.3-3+squeeze1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQIcBAEBCgAGBQJPQ4dlAAoJEDBVD3hx7wuo3UQP/05cx82ZXQ/G+V6uvB0HIKju
Mh9MWpi3cVL1bH9fSuaDfIzlG6yOXq74DLHc3KPWxOORjXb5c0q0MQNoGGUWzp1R
7G2UEfOblT97yTt/fFGrltCC524RuGnTdIyc4uAWUDcQ9c62hbW4n7pez3j9cbFv
JJFYuLHY5uBn7HXgVMFhEOi3feUu+EvFUAQ1rO2nhPwa8RpUHt5e0H8g9v1FTpbS
JlwZ87BgxJ3k30Pwiz6cyhaCDF30gefTXUtfckPc/lsFcWypmUjQ4p6Lk1DCegDx
x11hNCD3Z8ftCJQm7Qdq++GxWz23LzdfHZB2sx0pHOxx0GeG8NXGaPxIcE716kkZ
rMbYzisHU295rnFRENb5/k3kgL6Ptb2QBZjhrN3Rl8dFlALghg+M3JGarh4iHEMW
kEc1VNGaBeaTMZw5EDY0Ku7XgKOD+FDGr/ArYIvLKlxYvyn+mf6zbqvo5DnGSrv8
JkNop7EHZ8R84sQQ0xy2cJBN1PLPIcHz/9/mxeoD9K0tM1waiAkp2P6eJFQHGOTw
5bQCClvtE/VwvR7thxbc2FK9r7UtqTlvwf4L6d3c5/uTx8R+lp8NBp0LO/BfCVpJ
Ek1QOZOUSJ2zy7s3GUNkEDhxX7CxNMTEezd5DGGN9k1SXyxCmCZ0+pUFaAInb/ie
DtX5PH0sMadCIS+uQyh0
=Nnee
-----END PGP SIGNATURE-----





Reply sent to Yves-Alexis Perez <corsac@debian.org>:
You have taken responsibility. (Thu, 23 Feb 2012 20:51:04 GMT) Full text and rfc822 format available.

Notification sent to Stephen <marathon.durandal@gmail.com>:
Bug acknowledged by developer. (Thu, 23 Feb 2012 20:51:04 GMT) Full text and rfc822 format available.

Reply sent to Yves-Alexis Perez <corsac@debian.org>:
You have taken responsibility. (Thu, 23 Feb 2012 20:51:05 GMT) Full text and rfc822 format available.

Notification sent to aaro <amerivas@yahoo.com>:
Bug acknowledged by developer. (Thu, 23 Feb 2012 20:51:05 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 13 May 2012 07:39:37 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 19:19:46 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.