Debian Bug report logs - #646095
webkit 1.6 dropped webkit_web_view_get_selected_text, breaking midori and claws-mail-fancy-plugin

version graph

Package: libwebkitgtk-1.0-0; Maintainer for libwebkitgtk-1.0-0 is Debian WebKit Maintainers <pkg-webkit-maintainers@lists.alioth.debian.org>; Source for libwebkitgtk-1.0-0 is src:webkitgtk.

Reported by: Paul Menzel <pm.debian@googlemail.com>

Date: Fri, 21 Oct 2011 09:09:02 UTC

Severity: serious

Found in version webkit/1.6.1-2

Fixed in version webkit/1.6.1-5

Done: Gustavo Noronha Silva <kov@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Ryan Niebur <ryan@debian.org>:
Bug#646095; Package midori. (Fri, 21 Oct 2011 09:09:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Paul Menzel <pm.debian@googlemail.com>:
New Bug report received and forwarded. Copy sent to Ryan Niebur <ryan@debian.org>. (Fri, 21 Oct 2011 09:09:42 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Paul Menzel <pm.debian@googlemail.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: midori (libwebkitgtk-1.0-0 1.61-2): symbol lookup error: midori: undefined symbol: webkit_web_view_get_selected_text
Date: Fri, 21 Oct 2011 11:06:57 +0200
[Message part 1 (text/plain, inline)]
Package: midori
Version: 0.4.1-1
Severity: grave
Justification: renders package unusable

Dear Debian folks,


Midori does not start anymore after having upgraded to version 1.6.1-2
of `libwebkitgtk-1.0-0` today. Midori had been running before the
upgrade. Closing it and starting it again after the upgrade I got the
following error.

        $ midori
        [1] 4194
        midori: symbol lookup error: midori: undefined symbol: webkit_web_view_get_selected_text

I hope the fix is as easy as to be recompiled against the new library
version or only proper version information in the package metadata have
to be setup.


Thanks,

Paul

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages midori depends on:
ii  dbus-x11            1.4.16-1    
ii  libc6               2.13-21     
ii  libcairo2           1.10.2-6.1  
ii  libgdk-pixbuf2.0-0  2.24.0-1    
ii  libglib2.0-0        2.28.6-1    
ii  libgtk2.0-0         2.24.7-1    
ii  libnotify4          0.7.4-1     
ii  libpango1.0-0       1.29.4-2    
ii  libsoup2.4-1        2.36.0-1    
ii  libsqlite3-0        3.7.8-1     
ii  libunique-1.0-0     1.1.6-2     
ii  libwebkitgtk-1.0-0  1.6.1-2     
ii  libx11-6            2:1.4.4-2   
ii  libxml2             2.7.8.dfsg-5
ii  libxss1             1:1.2.1-2   

Versions of packages midori recommends:
ii  gnome-icon-theme  3.2.1.2-1

midori suggests no packages.

-- no debconf information

[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Ryan Niebur <ryan@debian.org>:
Bug#646095; Package midori. (Fri, 21 Oct 2011 09:27:24 GMT) Full text and rfc822 format available.

Acknowledgement sent to Yves-Alexis Perez <corsac@debian.org>:
Extra info received and forwarded to list. Copy sent to Ryan Niebur <ryan@debian.org>. (Fri, 21 Oct 2011 09:27:31 GMT) Full text and rfc822 format available.

Message #10 received at 646095@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: Paul Menzel <pm.debian@googlemail.com>, 646095@bugs.debian.org
Cc: control@bugs.debian.org
Subject: Re: Bug#646095: midori (libwebkitgtk-1.0-0 1.61-2): symbol lookup error: midori: undefined symbol: webkit_web_view_get_selected_text
Date: Fri, 21 Oct 2011 11:24:14 +0200
[Message part 1 (text/plain, inline)]
reassign 646095 release.debian.org
retitle 646095 nmu: midori_0.4.1-
severity 646095 normal
user release.debian.org@packages.debian.org
usertag binnmu
thanks

On ven., 2011-10-21 at 11:06 +0200, Paul Menzel wrote:
> Package: midori
> Version: 0.4.1-1
> Severity: grave
> Justification: renders package unusable
> 
> Dear Debian folks,
> 
> 
> Midori does not start anymore after having upgraded to version 1.6.1-2
> of `libwebkitgtk-1.0-0` today. Midori had been running before the
> upgrade. Closing it and starting it again after the upgrade I got the
> following error.
> 
>         $ midori
>         [1] 4194
>         midori: symbol lookup error: midori: undefined symbol: webkit_web_view_get_selected_text
> 
Yes, confirmed

> I hope the fix is as easy as to be recompiled against the new library
> version or only proper version information in the package metadata have
> to be setup.

Confirmed too, so asking for the proper binNMU:

nmu midori_0.4.1-1 . ALL . -m "rebuild against webkit 1.6"

Thanks!
-- 
Yves-Alexis
[signature.asc (application/pgp-signature, inline)]

Bug reassigned from package 'midori' to 'release.debian.org'. Request was from Yves-Alexis Perez <corsac@debian.org> to control@bugs.debian.org. (Fri, 21 Oct 2011 09:27:45 GMT) Full text and rfc822 format available.

Bug No longer marked as found in versions midori/0.4.1-1. Request was from Yves-Alexis Perez <corsac@debian.org> to control@bugs.debian.org. (Fri, 21 Oct 2011 09:27:46 GMT) Full text and rfc822 format available.

Changed Bug title to 'nmu: midori_0.4.1-' from 'midori (libwebkitgtk-1.0-0 1.61-2): symbol lookup error: midori: undefined symbol: webkit_web_view_get_selected_text' Request was from Yves-Alexis Perez <corsac@debian.org> to control@bugs.debian.org. (Fri, 21 Oct 2011 09:27:47 GMT) Full text and rfc822 format available.

Severity set to 'normal' from 'grave' Request was from Yves-Alexis Perez <corsac@debian.org> to control@bugs.debian.org. (Fri, 21 Oct 2011 09:27:47 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#646095; Package release.debian.org. (Fri, 21 Oct 2011 16:00:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to Gustavo Noronha Silva <kov@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Fri, 21 Oct 2011 16:00:10 GMT) Full text and rfc822 format available.

Message #23 received at 646095@bugs.debian.org (full text, mbox):

From: Gustavo Noronha Silva <kov@debian.org>
To: 646095@bugs.debian.org
Subject: Usage of "private" symbol
Date: Fri, 21 Oct 2011 13:57:42 -0200
[Message part 1 (text/plain, inline)]
Hey,

This is caused by midori using a symbol that was only exported for being
used in the test runner. I can't see how a rebuild would fix it, are you
sure it did?

It was removed here: http://trac.webkit.org/changeset/88621

I can add a work-around to webkit if required, but I'd prefer to have
midori use proper API instead of possible =)

Cheers,

-- 
Gustavo Noronha Silva <kov@debian.org>
Debian
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#646095; Package release.debian.org. (Fri, 21 Oct 2011 16:15:03 GMT) Full text and rfc822 format available.

Message #26 received at 646095@bugs.debian.org (full text, mbox):

From: Philipp Kern <pkern@debian.org>
To: Gustavo Noronha Silva <kov@debian.org>, 646095@bugs.debian.org
Cc: debian-release@lists.debian.org
Subject: Re: Bug#646095: Usage of "private" symbol
Date: Fri, 21 Oct 2011 18:09:56 +0200
[Message part 1 (text/plain, inline)]
On Fri, Oct 21, 2011 at 01:57:42PM -0200, Gustavo Noronha Silva wrote:
> This is caused by midori using a symbol that was only exported for being
> used in the test runner. I can't see how a rebuild would fix it, are you
> sure it did?

This means that you just introduced an ABI break and are obliged to bump SONAME
and this would've been a transition that should've been asked for and handled
properly.

Kind regards,
Philipp Kern
-- 
 .''`.  Philipp Kern                        Debian Developer
: :' :  http://philkern.de                         Stable Release Manager
`. `'   xmpp:phil@0x539.de                         Wanna-Build Admin
  `-    finger pkern/key@db.debian.org
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#646095; Package release.debian.org. (Fri, 21 Oct 2011 16:27:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Gustavo Noronha Silva <kov@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Fri, 21 Oct 2011 16:27:03 GMT) Full text and rfc822 format available.

Message #31 received at 646095@bugs.debian.org (full text, mbox):

From: Gustavo Noronha Silva <kov@debian.org>
To: Philipp Kern <pkern@debian.org>
Cc: 646095@bugs.debian.org, debian-release@lists.debian.org
Subject: Re: Bug#646095: Usage of "private" symbol
Date: Fri, 21 Oct 2011 14:22:00 -0200
[Message part 1 (text/plain, inline)]
On Fri, 2011-10-21 at 18:09 +0200, Philipp Kern wrote:
> On Fri, Oct 21, 2011 at 01:57:42PM -0200, Gustavo Noronha Silva wrote:
> > This is caused by midori using a symbol that was only exported for being
> > used in the test runner. I can't see how a rebuild would fix it, are you
> > sure it did?
> 
> This means that you just introduced an ABI break and are obliged to bump SONAME
> and this would've been a transition that should've been asked for and handled
> properly.

You are absolutely right, I am sorry about the transition, I wrongly
assumed it was a good time to upload, I forgot about the addition of new
packages and thought it would not block anyone, I'll be sure to ask in
the future, and I'll do what I can to try to avoid too much disruption.

Regarding the ABI breakage, it's unfortunate that webkitgtk had to use
this strategy of exporting some symbols that were not meant to be used
by applications to be able to run the tests, but they were always
clearly marked, left out of the public headers and you can see that
midori even carries its prototype mentioning the fact that it's
"unstable API". I don't think a soname bump is a good idea for changes
in such symbols.

Sorry again for the mistake!

Cheers,
-- 
Gustavo Noronha Silva <kov@debian.org>
Debian
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#646095; Package release.debian.org. (Fri, 21 Oct 2011 20:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julien Cristau <jcristau@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Fri, 21 Oct 2011 20:21:03 GMT) Full text and rfc822 format available.

Message #36 received at 646095@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: Gustavo Noronha Silva <kov@debian.org>, 646095@bugs.debian.org
Cc: Philipp Kern <pkern@debian.org>, midori@packages.debian.org
Subject: Re: Bug#646095: Usage of "private" symbol
Date: Fri, 21 Oct 2011 22:17:31 +0200
On Fri, Oct 21, 2011 at 14:22:00 -0200, Gustavo Noronha Silva wrote:

> On Fri, 2011-10-21 at 18:09 +0200, Philipp Kern wrote:
> > On Fri, Oct 21, 2011 at 01:57:42PM -0200, Gustavo Noronha Silva wrote:
> > > This is caused by midori using a symbol that was only exported for being
> > > used in the test runner. I can't see how a rebuild would fix it, are you
> > > sure it did?
> > 
> > This means that you just introduced an ABI break and are obliged to bump SONAME
> > and this would've been a transition that should've been asked for and handled
> > properly.
> 
> You are absolutely right, I am sorry about the transition, I wrongly
> assumed it was a good time to upload, I forgot about the addition of new
> packages and thought it would not block anyone, I'll be sure to ask in
> the future, and I'll do what I can to try to avoid too much disruption.
> 
> Regarding the ABI breakage, it's unfortunate that webkitgtk had to use
> this strategy of exporting some symbols that were not meant to be used
> by applications to be able to run the tests, but they were always
> clearly marked, left out of the public headers and you can see that
> midori even carries its prototype mentioning the fact that it's
> "unstable API". I don't think a soname bump is a good idea for changes
> in such symbols.
> 
At the very least the new webkit will need to declare Breaks on midori
(<< 0.4.1-2) or something like that.  And midori needs to get fixed up,
by the sound of it.

Cheers,
Julien




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#646095; Package release.debian.org. (Fri, 21 Oct 2011 20:27:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Yves-Alexis Perez <corsac@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Fri, 21 Oct 2011 20:27:03 GMT) Full text and rfc822 format available.

Message #41 received at 646095@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: Julien Cristau <jcristau@debian.org>
Cc: Gustavo Noronha Silva <kov@debian.org>, 646095@bugs.debian.org, Philipp Kern <pkern@debian.org>, midori@packages.debian.org
Subject: Re: Bug#646095: Usage of "private" symbol
Date: Fri, 21 Oct 2011 22:24:18 +0200
[Message part 1 (text/plain, inline)]
On ven., 2011-10-21 at 22:17 +0200, Julien Cristau wrote:
> At the very least the new webkit will need to declare Breaks on midori
> (<< 0.4.1-2) or something like that.  And midori needs to get fixed up,
> by the sound of it. 

midori has a guard for this, see

https://bugs.launchpad.net/midori/+bug/799603
http://git.xfce.org/apps/midori/commit/?id=b46db9b1708291def5876a0d3522598f3c9785da

so a rebuild fixes the issues, afaict. Do you see something more?

Regards,
-- 
Yves-Alexis
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#646095; Package release.debian.org. (Fri, 21 Oct 2011 20:42:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julien Cristau <jcristau@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Fri, 21 Oct 2011 20:42:05 GMT) Full text and rfc822 format available.

Message #46 received at 646095@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: Yves-Alexis Perez <corsac@debian.org>, 646095@bugs.debian.org
Cc: Gustavo Noronha Silva <kov@debian.org>, Philipp Kern <pkern@debian.org>, midori@packages.debian.org
Subject: Re: Bug#646095: Usage of "private" symbol
Date: Fri, 21 Oct 2011 22:38:25 +0200
On Fri, Oct 21, 2011 at 22:24:18 +0200, Yves-Alexis Perez wrote:

> On ven., 2011-10-21 at 22:17 +0200, Julien Cristau wrote:
> > At the very least the new webkit will need to declare Breaks on midori
> > (<< 0.4.1-2) or something like that.  And midori needs to get fixed up,
> > by the sound of it. 
> 
> midori has a guard for this, see
> 
> https://bugs.launchpad.net/midori/+bug/799603
> http://git.xfce.org/apps/midori/commit/?id=b46db9b1708291def5876a0d3522598f3c9785da
> 
> so a rebuild fixes the issues, afaict. Do you see something more?
> 
That code should be killed, not
#if !WEBKIT_CHECK_VERSION (1, 4, 3)

Cheers,
Julien




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#646095; Package release.debian.org. (Fri, 21 Oct 2011 21:03:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Yves-Alexis Perez <corsac@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Fri, 21 Oct 2011 21:03:05 GMT) Full text and rfc822 format available.

Message #51 received at 646095@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: Julien Cristau <jcristau@debian.org>
Cc: 646095@bugs.debian.org, Gustavo Noronha Silva <kov@debian.org>, Philipp Kern <pkern@debian.org>, midori@packages.debian.org
Subject: Re: Bug#646095: Usage of "private" symbol
Date: Fri, 21 Oct 2011 23:01:08 +0200
[Message part 1 (text/plain, inline)]
On ven., 2011-10-21 at 22:38 +0200, Julien Cristau wrote:
> That code should be killed, not
> #if !WEBKIT_CHECK_VERSION (1, 4, 3) 

I've asked on upstream bug about that, but I'm not sure it's that
trivial nor really important. That code has been present and working in
multiple midori versions already, which is unfortunate but there's not
much we can do for that.

Anyway, let's see the upstream call on that.

Regards,
-- 
Yves-Alexis
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#646095; Package release.debian.org. (Sat, 22 Oct 2011 08:48:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Yves-Alexis Perez <corsac@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Sat, 22 Oct 2011 08:48:06 GMT) Full text and rfc822 format available.

Message #56 received at 646095@bugs.debian.org (full text, mbox):

From: Yves-Alexis Perez <corsac@debian.org>
To: Julien Cristau <jcristau@debian.org>
Cc: 646095@bugs.debian.org, Gustavo Noronha Silva <kov@debian.org>, Philipp Kern <pkern@debian.org>, midori@packages.debian.org
Subject: Re: Bug#646095: Usage of "private" symbol
Date: Sat, 22 Oct 2011 10:45:49 +0200
[Message part 1 (text/plain, inline)]
On ven., 2011-10-21 at 23:01 +0200, Yves-Alexis Perez wrote:
> Anyway, let's see the upstream call on that.

https://bugs.launchpad.net/midori/+bug/799603/comments/16

and I'm not knowledgeable enough to remove the guard and the “else”
part. One thing I can do is add a versioned build-dep for future version
but that won't really help for the current versions.

Anyway, could the binNMU be scheduled so at least unstable users have a working midori?
-- 
Yves-Alexis
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#646095; Package release.debian.org. (Sat, 22 Oct 2011 13:27:32 GMT) Full text and rfc822 format available.

Acknowledgement sent to Laurent Bigonville <bigon@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Sat, 22 Oct 2011 13:27:37 GMT) Full text and rfc822 format available.

Message #61 received at 646095@bugs.debian.org (full text, mbox):

From: Laurent Bigonville <bigon@debian.org>
To: 646095@bugs.debian.org
Subject: /usr/lib/claws-mail/plugins/fancy.so: undefined symbol: webkit_web_view_get_selected_text
Date: Sat, 22 Oct 2011 15:25:39 +0200
Hi,

FYI claws-mail-fancy-plugin is also affected by this, when trying to
load the plugin, I get:

/usr/lib/claws-mail/plugins/fancy.so: undefined symbol:
webkit_web_view_get_selected_text

Cheers

Laurent Bigonville




Bug reassigned from package 'release.debian.org' to 'libwebkitgtk-1.0-0'. Request was from Julien Cristau <jcristau@debian.org> to control@bugs.debian.org. (Sat, 22 Oct 2011 13:48:08 GMT) Full text and rfc822 format available.

Bug Marked as found in versions webkit/1.6.1-2. Request was from Julien Cristau <jcristau@debian.org> to control@bugs.debian.org. (Sat, 22 Oct 2011 13:48:09 GMT) Full text and rfc822 format available.

Changed Bug title to 'webkit 1.6 dropped webkit_web_view_get_selected_text, breaking midori and claws-mail-fancy-plugin' from 'nmu: midori_0.4.1-' Request was from Julien Cristau <jcristau@debian.org> to control@bugs.debian.org. (Sat, 22 Oct 2011 13:48:12 GMT) Full text and rfc822 format available.

Severity set to 'serious' from 'normal' Request was from Julien Cristau <jcristau@debian.org> to control@bugs.debian.org. (Sat, 22 Oct 2011 13:48:15 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian WebKit Maintainers <pkg-webkit-maintainers@lists.alioth.debian.org>:
Bug#646095; Package libwebkitgtk-1.0-0. (Mon, 24 Oct 2011 20:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Gustavo Noronha Silva <kov@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian WebKit Maintainers <pkg-webkit-maintainers@lists.alioth.debian.org>. (Mon, 24 Oct 2011 20:15:03 GMT) Full text and rfc822 format available.

Message #74 received at 646095@bugs.debian.org (full text, mbox):

From: Gustavo Noronha Silva <kov@debian.org>
To: Yves-Alexis Perez <corsac@debian.org>
Cc: Julien Cristau <jcristau@debian.org>, 646095@bugs.debian.org, Philipp Kern <pkern@debian.org>, midori@packages.debian.org, claws-mail-fancy-plugin@packages.debian.org
Subject: Re: Bug#646095: Usage of "private" symbol
Date: Mon, 24 Oct 2011 18:12:52 -0200
[Message part 1 (text/plain, inline)]
On Sat, 2011-10-22 at 10:45 +0200, Yves-Alexis Perez wrote:
> On ven., 2011-10-21 at 23:01 +0200, Yves-Alexis Perez wrote:
> > Anyway, let's see the upstream call on that.
> 
> https://bugs.launchpad.net/midori/+bug/799603/comments/16
> 
> and I'm not knowledgeable enough to remove the guard and the “else”
> part. One thing I can do is add a versioned build-dep for future version
> but that won't really help for the current versions.

With this last upload (1.6.1-4) I think I managed to deal with all the
FTBFS problems that would hold webkit, so we're left with this one to be
handled.

Options I see:

      * Re-add the API in question in the Debian package as a way to
        give claws-mail-fancy-plugin time to react
      * Fix claws-mail-fancy-plugin now to use the DOM APIs instead,
        like midori does, and add appropriate Breaks: for midori and
        claws-mail-fancy-plugin
      * Go shopping instead

Votes? I'll grab claws-mail-fancy-plugin's code to take a look.

Cheers,

-- 
Gustavo Noronha Silva <kov@debian.org>
Debian
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian WebKit Maintainers <pkg-webkit-maintainers@lists.alioth.debian.org>:
Bug#646095; Package libwebkitgtk-1.0-0. (Mon, 24 Oct 2011 23:00:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ricardo Mones <mones@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian WebKit Maintainers <pkg-webkit-maintainers@lists.alioth.debian.org>. (Mon, 24 Oct 2011 23:00:05 GMT) Full text and rfc822 format available.

Message #79 received at 646095@bugs.debian.org (full text, mbox):

From: Ricardo Mones <mones@debian.org>
To: Gustavo Noronha Silva <kov@debian.org>
Cc: Yves-Alexis Perez <corsac@debian.org>, Julien Cristau <jcristau@debian.org>, 646095@bugs.debian.org, Philipp Kern <pkern@debian.org>, midori@packages.debian.org, claws-mail-fancy-plugin@packages.debian.org
Subject: Re: Bug#646095: Usage of "private" symbol
Date: Tue, 25 Oct 2011 00:55:35 +0200
[Message part 1 (text/plain, inline)]
  Hi Gustavo,

On Mon, 24 Oct 2011 18:12:52 -0200
Gustavo Noronha Silva <kov@debian.org> wrote:

> On Sat, 2011-10-22 at 10:45 +0200, Yves-Alexis Perez wrote:
> > On ven., 2011-10-21 at 23:01 +0200, Yves-Alexis Perez wrote:
> > > Anyway, let's see the upstream call on that.
> > 
> > https://bugs.launchpad.net/midori/+bug/799603/comments/16
> > 
> > and I'm not knowledgeable enough to remove the guard and the “else”
> > part. One thing I can do is add a versioned build-dep for future
> > version but that won't really help for the current versions.
> 
> With this last upload (1.6.1-4) I think I managed to deal with all the
> FTBFS problems that would hold webkit, so we're left with this one to
> be handled.
> 
> Options I see:
> 
>       * Re-add the API in question in the Debian package as a way to
>         give claws-mail-fancy-plugin time to react
>       * Fix claws-mail-fancy-plugin now to use the DOM APIs instead,
>         like midori does, and add appropriate Breaks: for midori and
>         claws-mail-fancy-plugin
>       * Go shopping instead
> 
> Votes? I'll grab claws-mail-fancy-plugin's code to take a look.

  Bug of fancy-plugin has already been forwarded upstream, but no
  reaction so far, so feel free provide a patch.

  thanks in advance,
-- 
 Ricardo Mones
 http://people.debian.org/~mones
 «Stay away from hurricanes for a while.»
[signature.asc (application/pgp-signature, attachment)]

Reply sent to Gustavo Noronha Silva <kov@debian.org>:
You have taken responsibility. (Wed, 02 Nov 2011 15:45:09 GMT) Full text and rfc822 format available.

Notification sent to Paul Menzel <pm.debian@googlemail.com>:
Bug acknowledged by developer. (Wed, 02 Nov 2011 15:45:09 GMT) Full text and rfc822 format available.

Message #84 received at 646095-close@bugs.debian.org (full text, mbox):

From: Gustavo Noronha Silva <kov@debian.org>
To: 646095-close@bugs.debian.org
Subject: Bug#646095: fixed in webkit 1.6.1-5
Date: Wed, 02 Nov 2011 15:42:05 +0000
Source: webkit
Source-Version: 1.6.1-5

We believe that the bug you reported is fixed in the latest version of
webkit, which is due to be installed in the Debian FTP archive:

gir1.2-javascriptcoregtk-1.0_1.6.1-5_amd64.deb
  to main/w/webkit/gir1.2-javascriptcoregtk-1.0_1.6.1-5_amd64.deb
gir1.2-javascriptcoregtk-3.0_1.6.1-5_amd64.deb
  to main/w/webkit/gir1.2-javascriptcoregtk-3.0_1.6.1-5_amd64.deb
gir1.2-webkit-1.0_1.6.1-5_amd64.deb
  to main/w/webkit/gir1.2-webkit-1.0_1.6.1-5_amd64.deb
gir1.2-webkit-3.0_1.6.1-5_amd64.deb
  to main/w/webkit/gir1.2-webkit-3.0_1.6.1-5_amd64.deb
libjavascriptcoregtk-1.0-0-dbg_1.6.1-5_amd64.deb
  to main/w/webkit/libjavascriptcoregtk-1.0-0-dbg_1.6.1-5_amd64.deb
libjavascriptcoregtk-1.0-0_1.6.1-5_amd64.deb
  to main/w/webkit/libjavascriptcoregtk-1.0-0_1.6.1-5_amd64.deb
libjavascriptcoregtk-1.0-dev_1.6.1-5_amd64.deb
  to main/w/webkit/libjavascriptcoregtk-1.0-dev_1.6.1-5_amd64.deb
libjavascriptcoregtk-3.0-0-dbg_1.6.1-5_amd64.deb
  to main/w/webkit/libjavascriptcoregtk-3.0-0-dbg_1.6.1-5_amd64.deb
libjavascriptcoregtk-3.0-0_1.6.1-5_amd64.deb
  to main/w/webkit/libjavascriptcoregtk-3.0-0_1.6.1-5_amd64.deb
libjavascriptcoregtk-3.0-dev_1.6.1-5_amd64.deb
  to main/w/webkit/libjavascriptcoregtk-3.0-dev_1.6.1-5_amd64.deb
libwebkit-dev_1.6.1-5_amd64.deb
  to main/w/webkit/libwebkit-dev_1.6.1-5_amd64.deb
libwebkitgtk-1.0-0-dbg_1.6.1-5_amd64.deb
  to main/w/webkit/libwebkitgtk-1.0-0-dbg_1.6.1-5_amd64.deb
libwebkitgtk-1.0-0_1.6.1-5_amd64.deb
  to main/w/webkit/libwebkitgtk-1.0-0_1.6.1-5_amd64.deb
libwebkitgtk-1.0-common_1.6.1-5_all.deb
  to main/w/webkit/libwebkitgtk-1.0-common_1.6.1-5_all.deb
libwebkitgtk-3.0-0-dbg_1.6.1-5_amd64.deb
  to main/w/webkit/libwebkitgtk-3.0-0-dbg_1.6.1-5_amd64.deb
libwebkitgtk-3.0-0_1.6.1-5_amd64.deb
  to main/w/webkit/libwebkitgtk-3.0-0_1.6.1-5_amd64.deb
libwebkitgtk-3.0-common_1.6.1-5_all.deb
  to main/w/webkit/libwebkitgtk-3.0-common_1.6.1-5_all.deb
libwebkitgtk-3.0-dev_1.6.1-5_amd64.deb
  to main/w/webkit/libwebkitgtk-3.0-dev_1.6.1-5_amd64.deb
libwebkitgtk-dev_1.6.1-5_amd64.deb
  to main/w/webkit/libwebkitgtk-dev_1.6.1-5_amd64.deb
webkit_1.6.1-5.debian.tar.gz
  to main/w/webkit/webkit_1.6.1-5.debian.tar.gz
webkit_1.6.1-5.dsc
  to main/w/webkit/webkit_1.6.1-5.dsc



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 646095@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Gustavo Noronha Silva <kov@debian.org> (supplier of updated webkit package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Tue, 01 Nov 2011 23:20:19 -0200
Source: webkit
Binary: libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-1.0-dev libjavascriptcoregtk-1.0-0-dbg gir1.2-javascriptcoregtk-1.0 libwebkitgtk-1.0-0 libwebkit-dev libwebkitgtk-dev libwebkitgtk-1.0-common libwebkitgtk-1.0-0-dbg gir1.2-webkit-1.0 libjavascriptcoregtk-3.0-0 libjavascriptcoregtk-3.0-dev libjavascriptcoregtk-3.0-0-dbg gir1.2-javascriptcoregtk-3.0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-dev libwebkitgtk-3.0-common libwebkitgtk-3.0-0-dbg gir1.2-webkit-3.0
Architecture: source all amd64
Version: 1.6.1-5
Distribution: unstable
Urgency: low
Maintainer: Debian WebKit Maintainers <pkg-webkit-maintainers@lists.alioth.debian.org>
Changed-By: Gustavo Noronha Silva <kov@debian.org>
Description: 
 gir1.2-javascriptcoregtk-1.0 - GObject introspection data for the GTK+-based JavaScriptCore libr
 gir1.2-javascriptcoregtk-3.0 - GObject introspection data for the GTK+-based JavaScriptCore libr
 gir1.2-webkit-1.0 - GObject introspection data for the WebKit library
 gir1.2-webkit-3.0 - GObject introspection data for the WebKit library
 libjavascriptcoregtk-1.0-0 - Javascript engine library for GTK+
 libjavascriptcoregtk-1.0-0-dbg - Javascript engine library for GTK+
 libjavascriptcoregtk-1.0-dev - Javascript engine library for GTK+
 libjavascriptcoregtk-3.0-0 - Javascript engine library for GTK+
 libjavascriptcoregtk-3.0-0-dbg - Javascript engine library for GTK+
 libjavascriptcoregtk-3.0-dev - Javascript engine library for GTK+
 libwebkit-dev - Transitional package for the development files of WebKitGTK+
 libwebkitgtk-1.0-0 - Web content engine library for GTK+
 libwebkitgtk-1.0-0-dbg - Web content engine library for GTK+ - Debugging symbols
 libwebkitgtk-1.0-common - Web content engine library for GTK+ - data files
 libwebkitgtk-3.0-0 - Web content engine library for GTK+
 libwebkitgtk-3.0-0-dbg - Web content engine library for GTK+ - Debugging symbols
 libwebkitgtk-3.0-common - Web content engine library for GTK+ - data files
 libwebkitgtk-3.0-dev - Web content engine library for GTK+ - Development files
 libwebkitgtk-dev - Web content engine library for GTK+ - Development files
Closes: 637228 646095
Changes: 
 webkit (1.6.1-5) unstable; urgency=low
 .
   * debian/rules:
   - also build with stabs debug symbols format when under s390x
     patch by Aurelien Jarno <aurel32@debian.org> (Closes: #637228)
   * debian/control:
   - add Breaks for midori and claws-mail-fancy-plugin versions that
     were using the private webkit_web_view_get_selected_text symbol
     (Closes: #646095)
Checksums-Sha1: 
 296693277846c9f6d77eae1d403a3988ecb2f92f 3337 webkit_1.6.1-5.dsc
 d517042da4da5f2972e03bfa17c50d601a3c2bdd 49598 webkit_1.6.1-5.debian.tar.gz
 4acee67637e3dfff39316ff5804886bcd5bde434 866098 libwebkitgtk-1.0-common_1.6.1-5_all.deb
 7b5cab3bbcbe718c7dc157a1aa9872b1ff519584 866098 libwebkitgtk-3.0-common_1.6.1-5_all.deb
 df745b7b42fe1eff549d991eaa17810e79eb707b 998564 libjavascriptcoregtk-1.0-0_1.6.1-5_amd64.deb
 4f2076ed23fbefe3d8edf8c9f0d0eb9157ead6dd 36038 libjavascriptcoregtk-1.0-dev_1.6.1-5_amd64.deb
 89e8909a433ba142578ad70d94760bd399112c95 18862698 libjavascriptcoregtk-1.0-0-dbg_1.6.1-5_amd64.deb
 1154db932e44a0bfc4573d910e2a742381b1d917 20304 gir1.2-javascriptcoregtk-1.0_1.6.1-5_amd64.deb
 318a425e0f350f9de0b55d36e798c1126aba0153 6909632 libwebkitgtk-1.0-0_1.6.1-5_amd64.deb
 493ca315ac808745e441ac41d28e753603e9a4cf 19886 libwebkit-dev_1.6.1-5_amd64.deb
 ee504cb69df323fd98e4855d967c2309029adf58 229252 libwebkitgtk-dev_1.6.1-5_amd64.deb
 820f730664aa6fd38488d5be27f5909385c8ad39 319262298 libwebkitgtk-1.0-0-dbg_1.6.1-5_amd64.deb
 0228baeb3f6db11f30b3a408da517463b0bb19cc 74508 gir1.2-webkit-1.0_1.6.1-5_amd64.deb
 8c31a22671425060892f8ce87e78b12f3cd1dfe1 998572 libjavascriptcoregtk-3.0-0_1.6.1-5_amd64.deb
 4b4018e4c6042819689d37001ed27fa2b08ad8b4 36056 libjavascriptcoregtk-3.0-dev_1.6.1-5_amd64.deb
 cc8178c17fd11e7411777e604a3c356972771247 18863222 libjavascriptcoregtk-3.0-0-dbg_1.6.1-5_amd64.deb
 b34ee62b89753f6bd5d8431ddb885140db9dde67 20308 gir1.2-javascriptcoregtk-3.0_1.6.1-5_amd64.deb
 f9ca2d76ae6971655cbde5419d0c63c5186f0ee5 6907866 libwebkitgtk-3.0-0_1.6.1-5_amd64.deb
 0cd05eef90a8b7b4e8b7f7a7d6f731def5225a31 229248 libwebkitgtk-3.0-dev_1.6.1-5_amd64.deb
 fd65a5f7c8c70ca5034403bdbf6a42582280861b 318878252 libwebkitgtk-3.0-0-dbg_1.6.1-5_amd64.deb
 dacd033a871d04c907d40641c0967de556808f94 74514 gir1.2-webkit-3.0_1.6.1-5_amd64.deb
Checksums-Sha256: 
 7d78be89d1105350486b5d972793b55d2ff45582b936528b08309ebf2ea524a9 3337 webkit_1.6.1-5.dsc
 d64239edf2eee5d8ae830fab12a8c779d2dbe5e5a423816407a84c418a789bd9 49598 webkit_1.6.1-5.debian.tar.gz
 3e4f765ef97c6de3d8f60f2ccac36cadaf9c18371c96b44bfd491e0793521ead 866098 libwebkitgtk-1.0-common_1.6.1-5_all.deb
 e6c59c4fce62778dbd2a1ac0e9319fff6c97b8482cf2daaa02d50512428413c5 866098 libwebkitgtk-3.0-common_1.6.1-5_all.deb
 ef0457d424972b7d50fac62f1f7eb2b4dbaf92833a6264786371c234f2b3a0bb 998564 libjavascriptcoregtk-1.0-0_1.6.1-5_amd64.deb
 a2576581a99ff985c5c29ad6f30ce4b5d51c51479b14350ca9e4cef2a20ab31e 36038 libjavascriptcoregtk-1.0-dev_1.6.1-5_amd64.deb
 9707c9bee586bced066eb54e8ee244d09fce38b48a97c5b0ae239c86901b1676 18862698 libjavascriptcoregtk-1.0-0-dbg_1.6.1-5_amd64.deb
 84d01aca5e097c269f51b5a373d2a42ff617873e72e67fb7a52fc91d46f3273d 20304 gir1.2-javascriptcoregtk-1.0_1.6.1-5_amd64.deb
 3d5d93c7d014c2a9dd60d16e661b03acc9a4ab3838a726b447a86b2c2c40b4a6 6909632 libwebkitgtk-1.0-0_1.6.1-5_amd64.deb
 2968e2ee6fb4ec6974d24cb77ba662632c843d30049dd9f6efe5f453e613249d 19886 libwebkit-dev_1.6.1-5_amd64.deb
 ed2743278cf21a0b6490c534d86658f7df4173924693e01e12d8434e99747e9c 229252 libwebkitgtk-dev_1.6.1-5_amd64.deb
 4c9262ff2cfca27f75900a684cdfabc52771cbf525c2ad5421b1733ffe6b441d 319262298 libwebkitgtk-1.0-0-dbg_1.6.1-5_amd64.deb
 0abf456b938d942a54086c0fc3ad1cbd0894ff307f1d60fc962214042034dd7a 74508 gir1.2-webkit-1.0_1.6.1-5_amd64.deb
 48372180c3a1f547d5f5aee65144d1d023cfa4876c7483bdb1ac83d29efe1f31 998572 libjavascriptcoregtk-3.0-0_1.6.1-5_amd64.deb
 65d8c575c95b9e3e73acbb63f71e8b1e3613838d1c98a0ec13fa9f86d5a7b5a6 36056 libjavascriptcoregtk-3.0-dev_1.6.1-5_amd64.deb
 e8801ed4a7fbea1278653de2ad617502507ec32b9a95c5592c5d4337114b0dee 18863222 libjavascriptcoregtk-3.0-0-dbg_1.6.1-5_amd64.deb
 b0bf867f895b079b9e3c3e08bca0fba2824f9c8b2d363b0129aeeca34ae0b6f9 20308 gir1.2-javascriptcoregtk-3.0_1.6.1-5_amd64.deb
 de0f795e22110c18be253a7c918171095d60a9d0b1d6a5ae2bbb9045fc8a023d 6907866 libwebkitgtk-3.0-0_1.6.1-5_amd64.deb
 f01ceb1f3abe2872a5a37ff6a6fa64547a0d856361e8de74ff4f7419b80c1945 229248 libwebkitgtk-3.0-dev_1.6.1-5_amd64.deb
 e551be578fc9c62c3d90688feab77bcfaa53ee6360ffb18de2f10305c718ff31 318878252 libwebkitgtk-3.0-0-dbg_1.6.1-5_amd64.deb
 8e68edfa065870c5034c7fdc615a351dfd663372d49518991bbd7c0b9947b470 74514 gir1.2-webkit-3.0_1.6.1-5_amd64.deb
Files: 
 712469545099f9795386018955caeef6 3337 web optional webkit_1.6.1-5.dsc
 7d8e0c2dde58de9e5393c9446d205f4c 49598 web optional webkit_1.6.1-5.debian.tar.gz
 f20bad943d6272582aa294a82c791664 866098 libs optional libwebkitgtk-1.0-common_1.6.1-5_all.deb
 04cd242142ad3c3a29a95ad80ae2e502 866098 libs optional libwebkitgtk-3.0-common_1.6.1-5_all.deb
 02dbb910d93d5eff5e66623999086be2 998564 libs optional libjavascriptcoregtk-1.0-0_1.6.1-5_amd64.deb
 aef927fd5d64444d0b8e19b638edcd99 36038 libdevel extra libjavascriptcoregtk-1.0-dev_1.6.1-5_amd64.deb
 181494a01406a7505786f23db472d873 18862698 debug extra libjavascriptcoregtk-1.0-0-dbg_1.6.1-5_amd64.deb
 a8a6f84cee08e480f0a074289424ff98 20304 libs optional gir1.2-javascriptcoregtk-1.0_1.6.1-5_amd64.deb
 97f4b7991047d3cd4999906ad4c990ae 6909632 libs optional libwebkitgtk-1.0-0_1.6.1-5_amd64.deb
 c745de4fbd5a5ff6b48f1675f5e78f6b 19886 libdevel extra libwebkit-dev_1.6.1-5_amd64.deb
 2f166c7d1b13a39e9dc0b0ba608e123f 229252 libdevel extra libwebkitgtk-dev_1.6.1-5_amd64.deb
 901ac35cb6998da91172360a9f017778 319262298 debug extra libwebkitgtk-1.0-0-dbg_1.6.1-5_amd64.deb
 7b9df828554fc2be98bd5ed526972ea3 74508 libs optional gir1.2-webkit-1.0_1.6.1-5_amd64.deb
 30f23e0cc4f97ccf3ea4271bcd8f1b3c 998572 libs optional libjavascriptcoregtk-3.0-0_1.6.1-5_amd64.deb
 12816595e773370482c5fbf5f0100d77 36056 libdevel extra libjavascriptcoregtk-3.0-dev_1.6.1-5_amd64.deb
 cd079263a743e09cc5cc7386e7ba1372 18863222 debug extra libjavascriptcoregtk-3.0-0-dbg_1.6.1-5_amd64.deb
 bc2ef24fe38aa19a5145ca74ddc3e51f 20308 libs optional gir1.2-javascriptcoregtk-3.0_1.6.1-5_amd64.deb
 9f31d68e8cf961a93c71591952c70d22 6907866 libs optional libwebkitgtk-3.0-0_1.6.1-5_amd64.deb
 7e4616056d14076f7d0ba8c532c38082 229248 libdevel extra libwebkitgtk-3.0-dev_1.6.1-5_amd64.deb
 72db7441a183939ca668fed668db5848 318878252 debug extra libwebkitgtk-3.0-0-dbg_1.6.1-5_amd64.deb
 eb1914b9844d0c9c0af0e3336a48bfe8 74514 libs optional gir1.2-webkit-3.0_1.6.1-5_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQEcBAEBCAAGBQJOsSWsAAoJENIA6zCg+12mfWoIAKIVr0iWFYAe2KaaOVzondfU
csQdvPeG9qPgynYZRVHQ4iNlEajg89iF7fO7juOHKiJ5bARnUgRoAm6akZhVj0Vk
u8FFZMQOcf4KctRK8NZwjvaujrRQsbRKeOH6ZSEclUCHN5ma5TcUNU9FK69gXNtz
hqVPW4PCyKc66onv4BaQ2rsr7JYIaHzf3PniyYNLl0wtLiaCV+AeUkErAlfJ5n6D
kqfkupkIH4y/Xr+c5rMtTem53BZzRa8vLwM9g5EQZrsay6XWceR+MgP+SzdXKLWj
LSbvMuH9M8yakdeOBAG9fOM9oq4ZwuHAfciBL06SduzQ5IrHUxTi3+lqIzw42Mg=
=fs3E
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 10 Dec 2011 07:40:17 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 08:21:58 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.