Debian Bug report logs - #644818
libgeom1 ABI incompatible with kfreebsd-9

version graph

Package: kfreebsd-9; Maintainer for kfreebsd-9 is GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>;

Reported by: Robert Millan <rmh@debian.org>

Date: Sun, 9 Oct 2011 11:30:02 UTC

Severity: normal

Found in version 9.0~svn225873-1

Done: Robert Millan <rmh@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>:
Bug#644818; Package kfreebsd-9. (Sun, 09 Oct 2011 11:30:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Robert Millan <rmh@debian.org>:
New Bug report received and forwarded. Copy sent to GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>. (Sun, 09 Oct 2011 11:30:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Robert Millan <rmh@debian.org>
To: Arno Töll <debian@toell.net>
Cc: debian-bsd@lists.debian.org
Subject: libgeom1 ABI incompatible with kfreebsd-9
Date: Sun, 9 Oct 2011 13:26:05 +0200
Package: kfreebsd-9
Version: 9.0~svn225873-1

Making a bug out of this, please followup there.

2011/10/8 Arno Töll <debian@toell.net>:
> I backported and compiled kfreebsd-9:

Why not you just use the package from experimental?

> ii  libgeom1                      8.2+ds1-4         FreeBSD GEOM library
>
> This is the same version as Sid has, right now.
>
> This seems to cause an ABI incompatibility between libgeom and
> kfreebsd-9.

I don't recall this happening last time I tested. Could you check if
earlier kfreebsd-9 uploads [1] also exhibit this problem? If not,
which version introduced it?

[1] http://snapshot.debian.org/package/kfreebsd-9/

-- 
Robert Millan




Information forwarded to debian-bugs-dist@lists.debian.org, GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>:
Bug#644818; Package kfreebsd-9. (Sun, 09 Oct 2011 14:33:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Arno Töll <debian@toell.net>:
Extra info received and forwarded to list. Copy sent to GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>. (Sun, 09 Oct 2011 14:33:05 GMT) Full text and rfc822 format available.

Message #10 received at 644818@bugs.debian.org (full text, mbox):

From: Arno Töll <debian@toell.net>
To: Robert Millan <rmh@debian.org>
Cc: 644818@bugs.debian.org
Subject: Re: libgeom1 ABI incompatible with kfreebsd-9
Date: Sun, 09 Oct 2011 16:30:37 +0200
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 09.10.2011 13:26, Robert Millan wrote:
> Why not you just use the package from experimental?

I was testing this on real hardware which needs non-free firmware
(following the procedure outlined in #642468). Hence I prepared and
compiled a pristine kernel image containing my network card driver
(among other non-free stuff).

However, I tested the issue with the package straight out of
experimental and can confirm the same behavior.


> I don't recall this happening last time I tested. Could you check if
> earlier kfreebsd-9 uploads [1] also exhibit this problem? If not,
> which version introduced it?

I did and I couldn't reproduce it on a virtual machine I prepared for
testing. Hence I did further triaging and it turned out to be more
likely a problem between grub and libgeom1, not kfreebsd-9 and libgeom1.

I am not sure what caused the problem, but upgrading grub from 1.99-6 to
1.99-12 solved the problem. My wild guess is, that this may be a
duplicate of #630197 fixed in -8. Hence, the bug is, if anything, a
missing "Breaks" relation.

Sorry for the noise.
- -- 
with kind regards,
Arno Töll
IRC: daemonkeeper on Freenode/OFTC
GnuPG Key-ID: 0x9D80F36D
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJOkbANAAoJEMcrUe6dgPNt11QP+gI2CKU3XfMhlutjFnIdyQMq
iaYJBHbUBQDldSBUT8mgM3c5sY6cZGr8PFvudO4jJJi9MC6vs5H5B3qgn1BaK+Bg
IWrwpBC+wwXmoaTFQI7HDbY3nA5SnC/RQSDx1IH5TI0m+6wwe8YQ0ELDKS2ofm1D
78HxKj+9E5v45i6GZtxv+hdGOgXGty9DtxZBJHvV97J8bDLk/ZaHYobQzz4OwJ3s
ChA4OR7Pfxk1s8BLLXpEeuo5Nh83cr00czDtIoRRe+f1e7fsKkibseP3chfKDjlN
RBguJaER6sNbQkMK12Tp4VrxWbTnQ3QVgyiRn8LnzLnpTv0F8ICm8o/E3dqIq4TL
tspWtABFuDT1WUDz1O0UiLrFdHaXYh0gvde5yhm/H+GmMv3zN5yVi3hOSiw0WRHN
RinMqnRa1nzk/rfHjkeur+krRXP2ugpAEazWAAJpNcDPz0cR1EIVAqors+plKa/9
gnfjiReo1GIub1Dr3O7DMgcEnWpc9ZEmVJSWPA6+YE8XSwRO0tKQSAvaZ4JU/JCj
+Ry+RacCUKQFymWuNpeBQJoRCh6o9IUzjBc0Ha3aaXzngccyekQsOWksMPCIOJf7
ylUHKUdgyLag8DN7jOVD8WfS1sUv83nRG5UGZXmNgny7F21ibGQFd162fmxS7ynL
CF9JwCmdpYMDoyso9feF
=/Yns
-----END PGP SIGNATURE-----




Reply sent to Robert Millan <rmh@debian.org>:
You have taken responsibility. (Sun, 09 Oct 2011 15:33:04 GMT) Full text and rfc822 format available.

Notification sent to Robert Millan <rmh@debian.org>:
Bug acknowledged by developer. (Sun, 09 Oct 2011 15:33:04 GMT) Full text and rfc822 format available.

Message #15 received at 644818-done@bugs.debian.org (full text, mbox):

From: Robert Millan <rmh@debian.org>
To: Arno Töll <debian@toell.net>
Cc: 644818-done@bugs.debian.org
Subject: Re: libgeom1 ABI incompatible with kfreebsd-9
Date: Sun, 9 Oct 2011 17:31:06 +0200
2011/10/9 Arno Töll <debian@toell.net>:
> I did and I couldn't reproduce it on a virtual machine I prepared for
> testing. Hence I did further triaging and it turned out to be more
> likely a problem between grub and libgeom1, not kfreebsd-9 and libgeom1.
>
> I am not sure what caused the problem, but upgrading grub from 1.99-6 to
> 1.99-12 solved the problem. My wild guess is, that this may be a
> duplicate of #630197 fixed in -8. Hence, the bug is, if anything, a
> missing "Breaks" relation.

But if we add "Breaks: grub-common (<< 1.99-8)" in libgeom1, this
might prevent a backport of this library.

I don't think this is a Breaks relation. grub 1.99-7 was buggy because
it was built with a fscked version of libgeom which is no longer in
the archive. We don't need to add a Breaks for each buggy package
IMHO.

Closing.

-- 
Robert Millan




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 07 Nov 2011 07:33:56 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 25 06:50:21 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.