Debian Bug report logs - #644799
zpool: /lib/libbsd.so.0: version LIBBSD_0.3 not found (required by /lib/libgeom.so.1)

version graph

Package: zfsutils-udeb; Maintainer for zfsutils-udeb is GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>; Source for zfsutils-udeb is src:zfsutils.

Reported by: Robert Millan <rmh@debian.org>

Date: Sun, 9 Oct 2011 09:30:01 UTC

Severity: grave

Fixed in version 8.3~svn226546-5

Done: Robert Millan <rmh@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>:
Bug#644799; Package zfsutils-udeb. (Sun, 09 Oct 2011 09:30:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Robert Millan <rmh@debian.org>:
New Bug report received and forwarded. Copy sent to GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>. (Sun, 09 Oct 2011 09:30:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Robert Millan <rmh@debian.org>
To: submit@bugs.debian.org
Subject: Re: Any tracking of good mini-iso images?
Date: Sun, 9 Oct 2011 11:26:29 +0200
Package: zfsutils-udeb
Severity: grave

Filing a bug report, please followup there.

2011/10/8 Arno Töll <debian@toell.net>:
> partman-zfs: zpool:  /lib/libbsd.so.0: version `LIBBSD_0.3´ not found
> (required by /lib/libgeom.so.1)
>
> Is that a known issue?

Which D-I version? Can this be reproduced outside of D-I environment?
Which are the versions of zfsutils-udeb, libgeom and libbsd involved?

--
Robert Millan



-- 
Robert Millan




Changed Bug title to 'zpool: /lib/libbsd.so.0: version LIBBSD_0.3 not found (required by /lib/libgeom.so.1)' from 'Any tracking of good mini-iso images?' Request was from Robert Millan <rmh@debian.org> to control@bugs.debian.org. (Sun, 09 Oct 2011 09:45:06 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>:
Bug#644799; Package zfsutils-udeb. (Sun, 09 Oct 2011 15:54:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Arno Töll <debian@toell.net>:
Extra info received and forwarded to list. Copy sent to GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>. (Sun, 09 Oct 2011 15:54:05 GMT) Full text and rfc822 format available.

Message #12 received at 644799@bugs.debian.org (full text, mbox):

From: Arno Töll <debian@toell.net>
To: Robert Millan <rmh@debian.org>, 644799@bugs.debian.org
Subject: Re: Bug#644799: Any tracking of good mini-iso images?
Date: Sun, 09 Oct 2011 17:48:39 +0200
[Message part 1 (text/plain, inline)]
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 09.10.2011 11:26, Robert Millan wrote:
> Which D-I version? Can this be reproduced outside of D-I environment?

It's the netinstall daily-image produced yesterday, Oct. 10. You can
still fetch the image on [1].

Steps to reproduce:

1) Select Partition disks
2) Choose Manual
3) Select "Configure ZFS"
4) Create ZFS pool
5) Select pool name (doesn't matter)
6) Choose any disk/partition (doesn't matter)

This yields:

Error while creating ZFS pool
The ZFS pool vmm could not be created. Check /var/log/syslog or see
virtual console 4 for the details.

I've attached debug logs, but at least the partman log is not really
helpful.


It turns out, it is not partman itself what fails, but the zpool/zfs
binaries:


~ # zpool
zpool: /lib/libbsd.so.0: version `LIBBSD_0.3' not found (required by
/lib/libgeom.so.1)
~ # zfs
zfs: /lib/libbsd.so.0: version `LIBBSD_0.3' not found (required by
/lib/libgeom.so.1)


Involved versions:

Oct  9 14:49:56 anna[374]: DEBUG: retrieving partman-auto 99
Oct  9 14:49:57 anna[374]: DEBUG: retrieving partman-base 151
Oct  9 14:49:57 anna[374]: DEBUG: retrieving partman-utils 151
Oct  9 14:49:57 anna[374]: DEBUG: retrieving partman-basicfilesystems 71
Oct  9 14:49:58 anna[374]: DEBUG: retrieving partman-basicmethods 48
Oct  9 14:49:59 anna[374]: DEBUG: retrieving partman-btrfs 6
Oct  9 14:49:59 anna[374]: DEBUG: retrieving partman-partitioning 82
Oct  9 14:50:00 anna[374]: DEBUG: retrieving partman-target 76
Oct  9 14:50:01 anna[374]: DEBUG: retrieving partman-ufs 8
Oct  9 14:50:01 anna[374]: DEBUG: retrieving partman-xfs 48
Oct  9 14:50:02 anna[374]: DEBUG: retrieving partman-zfs 14


> Which are the versions of zfsutils-udeb, libgeom and libbsd involved?

zfsutils-udeb 8.2-4
libgeom1-udeb 8.2+ds1-4

libbsd0 does not appear in the syslog, which is probably part of the
problem. There is a /lib/libbsd.so.0 available though, but I can not
further identify it's origin.

Manual inspection (sorry, no objdump) indicates, it would be (also
appears as literal) libbsd.so.0.2.0. At least it exports the following
versions:
LIBBSD_0.0
LIBBSD_0.1
LIBBSD_0.2




[1]
http://cdimage.debian.org/cdimage/daily-builds/wheezy_d-i/current/kfreebsd-amd64/iso-cd/

- -- 
with kind regards,
Arno Töll
IRC: daemonkeeper on Freenode/OFTC
GnuPG Key-ID: 0x9D80F36D
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJOkcJWAAoJEMcrUe6dgPNtBkoQAJqC/S/klIh1QGCWrl9KF66N
jAw+Pjz9jyZYgL5esWT/x5NZ3gSaoY0XxedkjTLx8M1VzbVzkg+WHsFdyWOUB7C2
UtRso8Bs3r39nt1GFjajougQRGe4J4lf7gtaxthHjmQr2DpcVB+L3YrdCWoO9JuU
xMMT9S4aBhfVhDjm1LBVjWrJ7vLRSVTt4DYrqt7GF/NYhC2nO2rk8Bs7+7a632wj
kCmsLtHU8zxptFLyr+g/kdPFH0iCDkiU7njX91G+HTUCeXLgY48AvKimlkxGxULy
CoYW9Z6gbQMb/ocwuvHHwkdQ281mhotcdbGYN35ej2g/W679X3qC/5gCHIOHbXTg
MXPnNtOld/CBeYVN5CUuXoFcWdZGl43jVvvAEEHzCgdiOqX6/cAhc5o+6lRkQb6z
BZYnFQkYYQgN0abdxeHSNkHLu2Bic23KLPZKRA4vu0FBNLJwfX1UAxhPowqCTUq1
CQ7GKM0hu0Kf0JuAkz7UYX9AaYUU4H7FsrGKakvk7E+vKSsA6TI0Ke/uNFIetLml
cv7sTRd927Ttnm55elf6ljm1b2UU+sK99MaNEeTbJEsBXBI7GXza3iiditrV0VyD
U3+nLuLknetijN8SqeDs9i4mEHguj/SEhkDbvm7O8jMWrGm/LHNNdhDqwBygY1eH
IRwkXMpWdiomzvZGQ6hA
=q+jU
-----END PGP SIGNATURE-----
[hardware-summary (text/plain, attachment)]
[partman (text/plain, attachment)]
[syslog (text/plain, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>:
Bug#644799; Package zfsutils-udeb. (Sun, 09 Oct 2011 18:39:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Robert Millan <rmh@debian.org>:
Extra info received and forwarded to list. Copy sent to GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>. (Sun, 09 Oct 2011 18:39:03 GMT) Full text and rfc822 format available.

Message #17 received at 644799@bugs.debian.org (full text, mbox):

From: Robert Millan <rmh@debian.org>
To: Arno Töll <debian@toell.net>
Cc: 644799@bugs.debian.org
Subject: Re: Bug#644799: Any tracking of good mini-iso images?
Date: Sun, 9 Oct 2011 20:37:16 +0200
2011/10/9 Arno Töll <debian@toell.net>:
> It turns out, it is not partman itself what fails, but the zpool/zfs
> binaries:

I know, that's why I ask if it can be reproduced outside of D-I environment.

Can it?

It seems like an ABI problem.  Maybe a rebuild helps?

-- 
Robert Millan




Information forwarded to debian-bugs-dist@lists.debian.org, GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>:
Bug#644799; Package zfsutils-udeb. (Sun, 09 Oct 2011 18:57:11 GMT) Full text and rfc822 format available.

Acknowledgement sent to Arno Töll <debian@toell.net>:
Extra info received and forwarded to list. Copy sent to GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>. (Sun, 09 Oct 2011 18:57:11 GMT) Full text and rfc822 format available.

Message #22 received at 644799@bugs.debian.org (full text, mbox):

From: Arno Töll <debian@toell.net>
To: 644799@bugs.debian.org
Subject: Re: Bug#644799: Any tracking of good mini-iso images?
Date: Sun, 09 Oct 2011 20:51:38 +0200
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello Robert,

On 09.10.2011 20:37, Robert Millan wrote:
> 2011/10/9 Arno Töll <debian@toell.net>:
>> It turns out, it is not partman itself what fails, but the zpool/zfs
>> binaries:
> 
> I know, that's why I ask if it can be reproduced outside of D-I environment.

I wonder how I am supposed to test that? For obvious reasons I can't
install with this netinst image provided and in an actual installation
(i.e. zfsutils installed from the latest binary package in the archive
it does not seem to happen).


- -- 
with kind regards,
Arno Töll
IRC: daemonkeeper on Freenode/OFTC
GnuPG Key-ID: 0x9D80F36D
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJOke05AAoJEMcrUe6dgPNtVB8P/2ieSQt2ftlEoH2CWkDxMKYa
RXG12B49fvC+fzz+GhVKE1P3GPxu39eTy3yy8iFz57QcmqpX7yujhg6zqpDO3LYl
9eVVuWTZlSAEhuhKlgeKT78iMXzLv4LYtoMBscg7JcSLZPtZEqEarVAp1AWKIXgA
KEIEXK9n/DTzG7+wVMdFVGY21rpqeSbQNtx+SpcAchWKYCEshPCfUe9VB0EI3gPz
MJTBVDpcyKMU2RGewiz8y80oEZ84f9cYzDgEz/80gfP1kdAmjFGZ/BEnnzVAU8l/
CqOiJ9UKTYl0Kt73DFtwYGXq6qCPKu47qcoLtccNusyabuVdsOAHznrLtMrm62mu
NoIHoMAaDhB2e1Z9OONRAdfHoIg7m47MqJ5iPjPF/0ttMN9OPEAUrL3MTY5VXyUo
HSyEjCPY3VN31jU+FgNzmHW12bBoTfC9zpqqcjZuIs84L+QRZlVc2mtkIlB0Ecfy
UOSLXivuvdy95JOD461R4UUXVHYzaEgl6YkvITCIc9C0qZMl0KttYEgkSHVJSdqO
D5K0qwHKJ6n6mPVC9EAfh4OfK26S+Ca2fTBro76qTPeAc1ePXaOrH8K6lS+izMeY
pEqH9A6dPCVU9WtYBq9qLWyIQstF29rI7k/c8sns6di/2iCYyAVublKt9UC8L3Ix
UG6hNRYUElRMuBZq4f0+
=OFnT
-----END PGP SIGNATURE-----




Information forwarded to debian-bugs-dist@lists.debian.org, GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>:
Bug#644799; Package zfsutils-udeb. (Sun, 09 Oct 2011 19:24:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Robert Millan <rmh@debian.org>:
Extra info received and forwarded to list. Copy sent to GNU/kFreeBSD Maintainers <debian-bsd@lists.debian.org>. (Sun, 09 Oct 2011 19:24:03 GMT) Full text and rfc822 format available.

Message #27 received at 644799@bugs.debian.org (full text, mbox):

From: Robert Millan <rmh@debian.org>
To: Arno Töll <debian@toell.net>, 644799@bugs.debian.org
Subject: Re: Bug#644799: Any tracking of good mini-iso images?
Date: Sun, 9 Oct 2011 21:20:38 +0200
2011/10/9 Arno Töll <debian@toell.net>:
>> I know, that's why I ask if it can be reproduced outside of D-I environment.
>
> I wonder how I am supposed to test that? For obvious reasons I can't
> install with this netinst image provided and in an actual installation
> (i.e. zfsutils installed from the latest binary package in the archive
> it does not seem to happen).

Which means the answer is no ;-)

-- 
Robert Millan




Reply sent to Robert Millan <rmh@debian.org>:
You have taken responsibility. (Tue, 13 Dec 2011 17:54:10 GMT) Full text and rfc822 format available.

Notification sent to Robert Millan <rmh@debian.org>:
Bug acknowledged by developer. (Tue, 13 Dec 2011 17:54:10 GMT) Full text and rfc822 format available.

Message #32 received at 644799-done@bugs.debian.org (full text, mbox):

From: Robert Millan <rmh@debian.org>
To: 644799-done@bugs.debian.org
Subject: fixed
Date: Tue, 13 Dec 2011 18:50:43 +0100
Version: 8.3~svn226546-5

-- 
Robert Millan




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 11 Jan 2012 07:39:53 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 06:30:08 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.